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Introduction

The Help System

The detailed help system of WaveLab makes it easy to look up interface features 
and get information from within the program.

Three main types of help are available:

• The help provides detailed information on the features and functionality of 
WaveLab. You can set bookmarks, and use the search function and index to 
quickly find information.

• “What’s This” tooltips give detailed information on the functionality of a 
specific user interface element.

• The status bar at the bottom of each workspace window gives detailed 
information on menu items when moving the mouse over an item.

• In the Audio Montage workspace, the status bar shows what kind of editing 
can be performed when using the mouse and modifier keys.

Accessing the Help System

There are several ways of accessing the help system.

• To open the WaveLab help, select Help > Contents.

• To open the manual in PDF format, browse to the installation folder. The 
documents are located in the Documentation folder.

• To show tooltips, move the mouse over an interface icon.

• To open the help for the active dialog, click the question mark icon on the title 
bar (Windows) or in the dialog (Mac OS) to show the Help button, and then 
click the Help button, or press [F1] (Windows) or [Command]-[?] (Mac OS).

• To use the menu help, move the mouse over a menu item. The help text is 
displayed on the status bar at the bottom of the workspace window.

• To see information on what kind of editing can be performed when using the 
mouse and modifier keys in the audio montage window, move the mouse over 
the montage window. The help text is displayed on the status bar at the 
bottom of the workspace window.
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• To activate/deactivate the help texts on the status bar, select Options 
(WaveLab menu on Mac) > Global preferences > Display tab, and in the 
Workspaces section, select Display status bar.

To open the “What’s This” help, you have the following possibilities:

• In any workspace, press [Shift]-[F1], and move the mouse over an interface 
item, or select Help > What is this?.

• In a dialog, select the question mark icon on any title bar (Windows) or in the 
dialog (Mac OS), and move the mouse over an interface item or a menu 
option.

• Some “What’s this” tooltips have a different background color to indicate that 
a dedicated help topic is available in the WaveLab help. Click the link in the 
tooltip to open the corresponding information in the help.

About the Program Versions

The documentation covers two different operating systems, Windows and Mac OS 
X. Some features and settings are specific to one of the operation systems.

This is clearly stated in the applicable cases. If nothing else is said, all descriptions 
and procedures in the documentation are valid for all WaveLab versions for both 
Windows and Mac OS X.

The screenshots are taken from the English Windows version of WaveLab.

Typographical Conventions

Many of the default key commands in WaveLab use modifier keys, some of which 
are different depending on the operating system. For example, the default key 
command for Undo is [Ctrl]-[Z] on Windows and [Command]-[Z] on Mac OS X.

When key commands with modifier keys are described in this manual, they are 
shown with the Windows modifier key first, in the following way:

• [Win modifier key]/[Mac modifier key]-[key]

For example, [Ctrl]/[Command]-[Z] means “press [Ctrl] on Windows or [Command] 
on Mac OS X, then press [Z]”.

Similarly, [Alt]/[Option]-[X] means “press [Alt] on Windows or [Option] on Mac OS 
X, then press [X]”.

NOTE

This manual often refers to right-clicking, for example, to open context menus. If you 
are using a Mac with a single-button mouse, hold down [Ctrl] and click.
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How You Can Reach Us

On the Help menu in WaveLab, you find items linking to additional information.

The menu contains links to various Steinberg web pages. Selecting a menu item 
automatically launches your browser and opens the page. On these pages, you can 
find support and compatibility information, answers to frequently asked questions, 
information about updates and other Steinberg products, etc. This requires that you 
have a web browser installed on your computer, and a working internet connection.
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Setting Up Your System

Before you start working, you need to make some settings.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Make sure that all equipment is turned off before making any connections.

Connecting Audio

Your system setup depends on many different factors, for example, the kind of 
project that you want to create, the external equipment that you want to use, or the 
computer hardware available to you.

About Audio Cards and Background Playback

When you activate playback or recording in WaveLab, other applications cannot 
access the audio card. Likewise, if another application uses the audio card, 
WaveLab is unable to play back. The Windows MME driver is an exception from 
this.

You can run WaveLab together with other applications and always give the active 
application access to the audio card.

To do so, select Options > VST Audio Connections, and on the Options tab, 
activate Release driver when WaveLab is in background.

About Latency

Latency is the delay between when audio is sent from the program and when you 
actually hear it. While a very low latency can be crucial in a real-time DAW 
application such as Steinberg Nuendo or Cubase, this is not strictly the case with 
WaveLab.

When working with WaveLab, the important issues are optimum and stable 
playback and editing precision. You should not try to reach the lowest possible 
latency figures.
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The latency in an audio system depends on the audio hardware, its drivers, and 
settings. In case of dropouts, crackles, or glitches during playback, raise the Buffer 
Number setting on the VST Audio Connections dialog, or increase the buffer size 
in the ASIO control panel, specific to the audio card.

Defining VST Audio Connections

To be able to play back and record audio in WaveLab, you must specify how the 
internal input and output channels in WaveLab are connected to your sound card 
and which device you intend to use for audio playback and recording.

You can define the buffer settings for your device as well as set up connections to 
external gear, such as external effects units. You should select at least two channels 
for stereo playback and recording.

If you have no third-party audio card, you can select the Windows MME driver or 
Built-in Audio (Mac) options. You can also use MME with most third party audio 
cards, with the advantage that you can record and play at different sample rates. 
However, Windows MME drivers do not allow audio monitoring in the Recording 
dialog or multichannel operation, and other drivers generally offer better sound 
quality and performance.

Selecting an ASIO Driver

Audio Stream Input/Output (ASIO) is a computer device driver protocol for digital 
audio specified by Steinberg. It provides a low-latency and high fidelity interface 
between a software application and the soundcard of a computer.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > VST 
Audio Connections.

2. From the Audio Device menu, select your ASIO driver.
The ASIO plug-ins tab and the Control panel button are activated.

3. Optional: Click the Control panel button and make your settings.

4. On the ASIO plug-ins tab, select the audio ports that are used for recording 
and monitor input of the ASIO plug-ins.

5. Click OK.
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Selecting a Windows MME Driver

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > VST 
Audio Connections.

2. From the Audio Device menu, select the Windows MME driver.

3. On the Playback tab, select the audio ports that are used for playback.

4. On the Recording tab, select the audio ports that used for recording and 
monitor input.

5. Click OK.

VST Audio Connections Dialog

This dialog allows you to specify how the internal input and output channels in 
WaveLab are connected to your sound card and which device you want to use for 
audio playback and recording.

In any workspace, except the Podcast workspace, select Options > VST Audio 
Connections.

Global Settings

Audio device

Here, select the audio device that you want to use for playback and recording 
audio. If you do not have a third-party audio card, you can select the Windows 
MME driver or Built-in Audio (Mac) options.

Control panel

When you select an ASIO driver, the Control panel button is activated. Click 
the button to open the settings application of your sound card, which is 
usually installed with the sound card. Depending on your sound card and 
driver, this provides settings for buffer size, digital formats, additional I/O 
connections, etc.

Refresh

This button causes audio devices to be evaluated again to reflect device 
changes.
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Playback Tab

This tab allows you to select and name audio ports that are used for playback. If you 
are monitoring on a surround system, specify your surround speaker outputs here. 
Furthermore, you can rename the channels and set up the Speaker configuration 
to be able to switch between different speakers.

Recording Tab

This tab allows you to select and name your audio ports that are used for recording 
and input monitoring. The inputs that you define here are then available in the 
Recording dialog. Furthermore, you can rename the channels and select the 
Speaker configuration.

External Gear Tab
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This tab allows you to select inputs from and outputs to external audio processing 
equipment. The name of this tab corresponds to the installed driver, for example, 
ASIO plug-ins.

Options Tab

This tab allows you to specify the number of buffers and the control driver 
functionality.

Buffer Number

Increasing this value improves the elasticity of audio streaming to avoid 
dropouts.

MME Specific - Buffer size

Increasing this value improves the elasticity of audio streaming to avoid 
dropouts. This is only available when an MME driver is selected.

Initialize streaming engine at first use

Initializes the audio streaming engine when playback or recording are used for 
the first time. If this option is deactivated, the audio streaming engine is 
initialized at program startup.

Reset driver when changing sample rate

Resets the driver when sample rate is changed. When playback or recording 
must be set to a new sample rate, certain audio device drivers must be fully 
reset to work properly. This operation takes some time.

Perform short fade-in/out when starting/stopping playback

Performs a short fade-in when starting playback and a short fade-out when 
stopping playback. This avoids clicks that are caused by waveforms that are 
not starting on a zero-crossing point.

Release driver when WaveLab is in background

Closes the audio device when WaveLab is no longer the front application. 
This allows other audio applications to use the same audio device.

CD/DVD Recorders

For general instructions on installing internal or connecting external recorders via 
USB or Firewire, please refer to the instruction manual for your computer or your 
recorder.

Make sure to have the latest firmware version installed on your recorder unit. For CD 
recorders, the existing firmware must support disc-at-once mode. In addition, 
running a unit with older firmware can prevent you from writing sub-index markers 
into the tracks, for example.
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Remote Devices

You can use remote devices to remote-control WaveLab.

Several commands can be controlled with knobs and sliders of your remote control 
device. For all commands that can be assigned to a keyboard shortcut, a MIDI 
trigger can also be assigned.

Remote Devices Dialog

This dialog allows you to select a device to remote-control WaveLab, and see and 
edit the control map of MIDI control devices.

In any workspace, except the Podcast workspace, select Options > Remote 
devices.

Device Editing Tab

This tab lets you select a MIDI control device, see the control map, assign WaveLab 
commands to MIDI controls, and import/export control assignments.
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Device menu

Select the MIDI device to edit. Select MIDI shortcuts for menus to define 
the MIDI input port that is used for MIDI shortcuts. The shortcuts can then be 
assigned in the Customize commands dialog.

Select MIDI Control Device #1 - #10 to select a slot for a connected MIDI 
control device. You can then assign a device by selecting a MIDI input port 
and output port.

Active

Activates the selected device and scans the MIDI ports.

In-Port/Out-Port

Select the MIDI input/output ports of the device that you want to use.

Edit map

Activates the edit mode of the MIDI control map for the selected device. To 
leave the edit mode, click again.

Save

Saves the modifications that have been made to the MIDI control map.

Undo

Undoes the modifications that have been made to the MIDI control map.

Reset

If the map has a factory preset, clicking Reset resets all changes that have 
been made to the map. If the map has no factory preset, the map is cleared.

Import

Opens the file browser where you can select a map definition file (XML file). 
This kind of file can be supplied by a MIDI device manufacturer or another 
WaveLab user, for example.

Export

Lets you export a map definition file (XML file). This file can be sent to another 
WaveLab user, for example.

Name

Lets you enter a map name.

Only display assignments

If this option is activated, the control map only displays the parameters that 
are associated with a remote control.

Expand/Collapse

Expands/collapses the folder tree of the control map.

WaveLab action list

This folder tree lists the parameters that you can remote-control. The top 
folder represent contexts. The related parameters can only be controlled if the 
context is active. For example, if an audio file is active.
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A remote control can be used in several contexts if these are exclusive. For 
example, parameters that can be used for an active audio file or an active 
audio montage.

The Global folder contain the parameters that can always be controlled.

Control editor - Save

If a control has been created or modified, click this button to save it.

Control editor - Undo

If a control has been modified, click this button to undo the changes.

Control editor - Clear

Erases the selected control’s definition.

Control name

Lets you enter a name for the control. Each control must have a name.

Type

In the Type section, you can edit the type of the selected control.

When more than one type of control can be assigned to a parameter, you can 
select a type from the first pop-up menu. You can choose between relative 
and absolute editing for certain parameters. For example, a master section 
slider can be associated to a remote motorized fader (absolute editing), or to 
an infinite knob (relative editing).

Several protocols are supported to interpret the MIDI messages. You can 
select the protocol that you want to use from the second menu. The MIDI 
learn function can automatically change this protocol, according to the 
received MIDI messages.

Remote controls send messages but can also receive messages from 
WaveLab, to light up a button or move a motorized fader, for example. You can 
select the mode to use from the third menu.

Message

Activates the MIDI learn function. When activated, you can use the control 
(knob, fader, etc.) on your MIDI controller. When MIDI messages are received, 
they are analyzed after the MIDI activity stops for several milliseconds. The 
result is displayed in the Message field. This is then used by WaveLab as the 
control identifier.

Clear

Erases the MIDI event that identifies the control.

Conditions

A modifier is a WaveLab parameter that can be activated by a MIDI control 
(for example, a foot switch) or a computer key ([Ctrl]/[Command], [Shift], etc.). 
By associating a remote control with one or two modifiers, you can use a 
single remote control to edit different parameters.
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Options Tab

This tab lets you use the MIDI Learn function to assign a control of a MIDI remote 
control device to a function.

Emulate mouse wheel

If this option is activated, the AI knob acts as a mouse wheel in the WaveLab 
user interface, except for plug-ins.

Edit focused numeric field

If this option is activated, the AI knob can be used to edit the focused numeric 
field that you find in many WaveLab windows and dialogs.

Selecting a MIDI Remote Control Device

PREREQUISITE 

The MIDI remote control device is connected to your PC/Mac.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > Remote 
devices.

2. On the Device editing tab, select one of the MIDI control device slots or the 
MIDI shortcuts for menus option from the pop-up menu at the top.

3. Select Active to activate the selected device.

4. From the In-Port and Out-Port menus, select a MIDI input port and output 
port.

Assigning a MIDI Controller to a Parameter

If you are using a Steinberg remote control device, for example, the CC121, the 
controls are already assigned to parameters. You can customize these default 
settings.

PREREQUISITE 

You have set up your MIDI remote control device.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > Remote 
devices.

2. From the pop-up menu at the top of the dialog, select your MIDI control 
device.

3. On the Device editing tab, click the Edit map button.

4. In the tree structure, click the parameter that you want to remote-control.

5. In the Control editor section, enter a name in the Control name field.
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6. Select the type of control.
Depending on the type of control on the MIDI remote control device, you must select 
a control with relative values (knob), trigger values (button), or absolute values (fader).

7. Click in the Message field, and on your MIDI remote control device, move the 
control that you want to assign.
The name of the controller is displayed in the Message field.

8. Click the Save button to the right of the This control is modified message.

9. Click the Save button to the right of the Edit map button.

RESULT 

The MIDI controller is now assigned to the function.

Assigning Custom Parameters to Plug-ins

You can assign custom parameters to many VST 3 plug-ins.

PREREQUISITE 

In the Remote devices dialog, assign the controls of your MIDI controller to the 
plug-in custom parameters. If you are using the Steinberg CC121 controller, the 
parameters are assigned by default.

PROCEDURE

1. From the Master Section or the Effects window, open the plug-in that you 
want to control with the MIDI remote control device.

2. [Ctrl]/[Command]-click the circle icon at the top of the plug-in window to 
enter the Edit mode.

3. Click OK.
The circle icon turns into a tool icon to indicate that you are in MIDI learn mode.
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4. Move the mouse over a plug-in parameter, and move the MIDI control that you 
want to assign.
Repeat this for all the parameters and controls that you want to assign.

5. When finished, click the tool icon to exit Edit mode, and click OK.

RESULT 

The assignment is saved. You can now control the assigned parameters with your 
MIDI remote control device. A plug-in can be controlled via the custom parameter 
if the Remote control mode is activated and only one plug-in can be activated at 
a time.

When a plug-in is activated for remote control, it also has precedence over other 
application settings that are controlled by the same parameter.

To remove all remote control assignments on the plug-in, hold [Ctrl]/[Command] 
and [Shift], and click the Remote control mode button.

Importing and Exporting Remote Control Definition Files

Map definition files are XML files, containing control assignments for your remote 
devices. You can exchange them with other users or save a backup copy.

Select Options > Remote devices, and open the Device editing tab.

• To import a map definition file, click the Import button, browse to the location 
of the map definition file, and select the file.

• To export a map definition file, click the Export button, and browse to the 
location where you want to save the file.

Editing Changes in the Remote Control Devices Settings

Changes that have been made to the map, for example, changing the name of a 
control, can be saved, reset, undone, and removed.

• To save any changes that you have made, click Save.

• To restore the factory preset of a MIDI remote control device, click Reset. If 
the control device does not have factory presets, the map is cleared.

• To undo your last action, click Undo.

• To remove the control definition of the selected control or to unassign the 
selected control, click Clear.
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Using Modifiers for Remote Controlling Parameters

You can use the same controller for controlling different parameters, using one or 
two modifiers. A modifier can be a MIDI control (for example, a foot switch) or a 
modifier key on your computer keyboard (for example, [Shift] and/or 
[Ctrl]/[Command]).

To determine one or two modifiers, open the Remote devices dialog, and when 
editing a parameter, select the modifiers from the Conditions section.

You can use the [Shift] and [Alt]/[Option] modifiers to alter the edit steps of infinite 
knob controls as follows:

• Press [Shift] to edit values in small steps.

• Press [Alt]/[Option] to edit values in bigger steps.

CC121 Advanced Integration Controller

You can use Steinberg's CC121 Advanced Integration Controller to control 
WaveLab.

This section describes the WaveLab factory preset for the CC121. For detailed 
information on how to use the controller, refer to the manual that came with the 
CC121. Note that the CC121 was originally designed for Cubase. The following 
mapping combines the WaveLab functionality with the CC121 controls. The 
controls that are not listed in the following paragraph are not assigned to a 
parameter.

Channel Section

You can use all controls of the CC121 channel section, except the fader, to control 
the elements of the selected track in a WaveLab audio montage. You can use the 
fader for the Master Section.

Fader

Controls the Master Section fader.

PAN knob

Controls the gain of the selected track.

Mute

Mutes/unmutes the selected track.

Solo

Activates/deactivates solo for the selected track.

CHANNEL SELECT

Selects the previous/next track in the audio montage.
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To move the cursor to the previous/next clip edge in the audio montage, hold 
[Alt]/[Option]. To move the cursor to the previous/next region edge, hold 
[Shift]. To move the cursor to the previous/next marker in the Audio Files 
workspace, hold [Ctrl]/[Command].

EQ Section

With the EQ section you can easily control the Steinberg Studio EQ plug-in.

If the EQ TYPE button is activated on the CC121, you can adjust the parameters 
of the focused Studio-EQ. All necessary EQ parameters, such as Q/F/G of each 
band, EQ TYPE selection, and ALL BYPASS on/off can be set. You can switch to 
WaveLab navigation mode by turning off the EQ TYPE button. In WaveLab 
navigation mode, you get access to alternative functions, such as scrolling, 
zooming, and switching between workspaces.

EQ Type activated:

Bandwidth knobs (Q)

Adjusts the Q (bandwidth) of each EQ band.

Frequency knobs (F)

Adjusts the center frequency of each EQ band.

Gain knobs (G)

Adjusts the gain of each EQ band.

ON

Activates/deactivates the EQ bands.

ALL BYPASS

Activates/deactivates bypass for all plug-ins in the Master Section.

EQ Type deactivated:

LOW ON

Opens the Audio Files workspace.

LOW-MID ON

Opens the Audio Montage workspace.

HIGH-MID ON

Opens the Batch Processors workspace.

HIGH ON

Opens the Control Window.

EQ-1 knob for the EQ Gain (G)

Scrolls left/right on the timeline.

EQ-2 knob for the EQ Gain (G)

Adjusts the horizontal zoom on the timeline.
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EQ-3 knob for the EQ Gain (G)

Adjusts the vertical zoom on the timeline.

EQ-4 knob for the EQ Gain (G)

Scrolls tracks on the Audio Montage workspace or scrolls vertically on the 
Audio Files workspace.

EQ-1 knob for the EQ Frequency (F)

Scrolls left/right on the overview timeline of the Audio Files workspace.

EQ-2 knob for the EQ Frequency (F)

Horizontally zooms in/out on the overview timeline of the Audio Files 
workspace.

EQ-3 knob for the EQ Frequency (F)

Vertically zooms in/out on the overview timeline of the Audio Files workspace.

EQ-4 knob for the EQ Frequency (F)

Vertically scrolls on the overview timeline of the Audio Files workspace.

Transport Section

In this section you can control the transport functions of WaveLab.

Previous button

Moves the cursor position to the beginning of the project.

Rewind button

Rewind

Forward button

Forward

Next button

Moves the cursor position to the end of the project.

Cycle button

Activates/deactivates Cycle mode.

Stop button

Stops playback. Press again to move the cursor to the previous start position. 
Press a third time to move the cursor to the beginning of the project.

Play button

Starts playback.

Record button

Press once to open the Recording window. Press again to start the 
recording. Press a third time to stop recording. The recorded file opens in the 
Audio Files workspace.
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Function Section

In this section, you can adjust certain functions, such as fades and envelope level, 
by using the VALUE knob.

VALUE knob/button

Rotate this knob to adjust the assigned function. Press the knob to reset the 
parameter to its default value.

FUNCTION button 1

Adjusts the fade-in settings of the focused clip.

FUNCTION button 2

Adjusts the fade-out settings of the focused clip.

FUNCTION button 3

Adjusts the envelope level of the focused clip.

FUNCTION button 4

The element clicked last on the Edit > Nudge menu in the Audio Montage 
workspace is assigned to this button.

AI Knob Section

WaveLab can be controlled with the AI knob of Steinberg’s CC121, CI2+, and 
CMC-AI controllers. With the AI knob, you can control the parameter that the 
mouse points to.

NOTE

The AI knob only works on parameters that are automatable.

In this section you can control parameters via the AI knob.

AI KNOB

Controls the VST 3plug-in parameters, emulates the mouse wheel, for 
example, for scrolling, and lets you edit a focused numeric field. To control a 
parameter with the AI knob, move the mouse cursor over the parameter that 
you want to control, and move the AI knob. You can activate/deactivate the 
emulation of the mouse wheel and the editing of the focused numeric field in 
the Options tab.

LOCK

When the mouse cursor points to a parameter, press LOCK to control this 
parameter regardless of the position of the mouse cursor.

JOG

Activates Jog mode. While Jog mode is activated, press LOCK to enter 
shuttle mode.
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CUBASE READY Indicator

The CUBASE READY indicator has no function in WaveLab.

Foot Switch Section

The foot switch has the same function as [Shift]. Press and hold the foot switch 
while turning the AI knob to fine tune parameters.
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WaveLab Concepts

This chapter describes general concepts that you will use when working with 
WaveLab. Getting accustomed with these procedures allows you to work more 
effectively with the program.

General Editing Rules

The common editing operations can be used in any Steinberg product.

• To select and move interface items, and to select ranges, click and drag with 
the mouse.

• Use the keys of your computer keyboard to enter numeric values and text, to 
navigate lists and other selectable interface items, and to control the transport 
functions.

• Common operations like cut, copy, paste, or the selection of multiple items 
can be performed using standard keyboard shortcuts.

NOTE

The behavior of your product is also governed by your preference settings.

RELATED LINKS

Global Preferences Dialog on page 666
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Startup Screen

When WaveLab starts, a startup screen opens where you can select which window 
layout you want to use.

Restore last window layout

Restores the window layout that you last used in WaveLab, including all files 
that were open.

Restore last window layout without files

Restores the same window layout that you last used in WaveLab without 
opening any files.

Restore default window layout

Restores the default window layout without opening any files.

Restore factory window layout

Restores the factory window layout without opening any files.

Keep answer and do not show this message again

If this option is activated, the option that you select is used from now on and 
the startup screen does not open anymore. To display the General window 
layout dialog, even if this option has been activated, press [Ctrl]/[Command] 
when starting WaveLab.

RELATED LINKS

Window Layout on page 615
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Basic Window Handling

WaveLab follows the basic guidelines for the Windows/Mac OS interface, which 
means that Windows/Mac OS standard procedures apply.

Closing Windows

• To close a tabbed window, click the “X” button of the corresponding tab or 
press [Ctrl]/[Command]-[W].

• To close a tabbed window without saving your changes, hold 
[Ctrl]/[Command]-[Shift], and click the “X” button. This avoids having to 
confirm a warning message whenever you want to close an unsaved window.

• To close all tabbed windows at once, right-click a tab, and select Close all.

• To close all tabbed windows but the selected tabbed window, right-click a 
tab, and select Close all but this one.

• To individually select the tabbed windows that you want to close, right-click a 
tab, and select Select files to close. This opens the Files to close dialog, 
where you can select the files that you want to close.

RELATED LINKS

Files to Close Dialog on page 66
Managing Tabs on page 65

Switching Between Files

You can have multiple files open and switch between them.

• To bring a file to the front, click the corresponding tab.

• To cycle between all open files in a workspace, hold [Ctrl]/[Command], and 
press [Tab] continuously.

• To cycle back and forth between the last two active files, press 
[Ctrl]/[Command]-[Tab]. Between each step you have to release all keys.

• To cycle backwards, press [Ctrl]/[Command]-[Shift]-[Tab].

Window Switcher

The window switchers let you easily switch between workspaces, create new 
workspaces, or open existing projects. There are two types of window switchers: 
The central switcher bar and the floating window switcher.

The floating window switcher behaves like the central switcher bar, but takes less 
room and floats above other windows.
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• To activate/deactivate the central switcher bar, in the Audio Files workspace 
or the Audio Montage workspace, select Workspace > Command bars > 
Central switcher bar.

• To activate/deactivate the floating window switcher, in any workspace, select 
Options (WaveLab menu on Mac) > Global preferences, and on the 
Display tab, activate Use Floating Window Switcher.

Using the Window Switcher

You can use the floating window switcher and the central switcher bar to navigate 
through your workspaces.

• To switch between workspaces, click a workspace button. If several 
workspaces of the same type are open, [Alt]/[Option]-click the workspace 
button to cycle between the workspaces. If the workspace is not yet open, a 
pop-up menu opens from which you can open a new workspace.

• To copy a file from one workspace to another, drag it to the button of the 
workspace that you want to open, wait until the workspace becomes active, 
and release the file where you want.

• To create a new file in any workspace, press [Ctrl]/[Command], and click a 
workspace button.

• To open the Open window to select a file, press [Shift], and click a workspace 
button.

• To display a menu listing the files that have recently been used in a particular 
workspace, right-click any workspace icon.

• To create a new file or open a file, right-click any workspace icon, and select 
New or Open. While left-clicking activates a workspace, right-clicking does 
not activate a workspace.
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Customizing the Central Switcher Bar

You can customize the central switcher bar using the settings menu.

To open the settings menu, right-click an empty part of the central switcher bar.

Hide

Hides the central switcher bar.

Fold

Minimizes the central switcher bar to a thin line. To unfold the bar, click the 
thin line.

Left side/Top/Right side/Bottom

Determines the location of the central switcher bar.

Large/Medium/Small size

Determines the size of the central switcher bar.

Workspace buttons

Determines which workspace buttons are visible on the central switcher bar.

Extra buttons

Determines whether to show or hide the extra buttons that some workspaces 
offer.

Customizing the Floating Window Switcher

You can set up the floating window switcher to your liking.

PROCEDURE

1. In any workspace, select Options (WaveLab menu on Mac) > Global 
preferences.

2. On the Display tab, make sure that Use Floating Window Switcher is 
activated.
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3. Customize the floating window switcher by activating/deactivating the 
corresponding options.

4. Click OK.

Selecting Audio

Almost all types of editing and processing that you perform in WaveLab operate on 
the audio selection. There are numerous ways to make an audio selection.

To select the whole audio file, double-click it. If the audio file contains markers, 
triple-click it.

Selecting a Range by Dragging

The standard way to select a range in a wave window or a montage window is to 
click and drag.

If you drag all the way to the left or right side of the window, it scrolls automatically, 
allowing you to select larger sections than what can be shown in the window. The 
speed of the scrolling depends on how far from the window edge you are.

Audio Range Selection in an Audio File

You can edit, process, or play back selection of an audio file.

In the Audio Files workspace, select Edit > Select time range.

Edit

Opens the Audio Range dialog, where you can define selection ranges very 
accurately.

All

Selects the entire waveform.

Toggle

Toggles the current audio selection on/off.

Extend to start of file

Extends the selection to the start of the audio file. If there is no selection, a 
selection is created from the edit cursor position.

Extend to end of file

Extends the selection to the end of the audio file. If there is no selection, a 
selection is created from the edit cursor position.
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Extend to previous marker

Extends the left edge of the selection to the nearest marker to the left or the 
start of the audio file. If there is no selection, a selection is extended until the 
edit cursor position.

Extend to next marker

Extends the right edge of the selection to the nearest marker to the right or 
the end of the audio file. If there is no selection, a selection is extended until 
the next marker position.

Extend to cursor

Extends the selection to the edit cursor position.

From start of file until cursor

Selects the range between the start of the audio file and the edit cursor 
position.

From cursor to end of file

Selects the range between the edit cursor position and the end of the audio 
file.

From cursor to previous marker

Selects the range between the edit cursor position and the nearest marker to 
the left or the start of the audio file.

From cursor to next marker

Selects the range between the edit cursor position and the next marker or the 
end of the audio file.

Playback position => Selection start

Creates a selection range from the playback position to the end of the audio 
file. If no playback is taking place, the position of the edit cursor is used.

Playback position => Selection end

Creates a selection range from the playback position to start of the audio file. 
If no playback is taking place, the position of the edit cursor is used.

Double length

Doubles the length of the current selection range.

Halve length

Halves the length of the current selection range.

Extend to all channels

Extends the current selection range to all channels.

Left channel only

Reduces the current selection range to the left channel only.

Right channel only

Reduces the current selection range to the right channel only.
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CD track

Selects the range between the two CD track markers that encompass the edit 
cursor.

Loop region

Selects the range between the two loop markers that encompass the edit 
cursor.

Exclusion region

Selects the range between the two exclusion markers that encompass the 
edit cursor.

Generic region

Selects the range between the two generic markers that encompass the edit 
cursor.

Audio Range Selection in an Audio Montage

You can edit, process, or play back selections of an audio montage.

In the Audio Montage workspace, select Edit > Select audio range.

Edit

Opens the Audio Range dialog, where you can define selection ranges very 
accurately.

Double length

Doubles the length of the current selection range.

Halve length

Halves the length of the current selection range.

Toggle

Toggles the current selection range on/off.

Playback position => Selection start

Creates a selection range from the playback position to the end of the audio 
montage. If no playback is taking place, the position of the edit cursor is used.

Playback position => Selection end

Creates a selection range from the playback position to start of the audio 
montage. If no playback is taking place, the position of the edit cursor is used.

Audio Range Dialog

This dialog allows you to accurately specify an audio range for editing, processing, 
or playing back.

In the Audio Files workspace, select Edit > Select time range > Edit.
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In the Audio Montage workspace, select Edit > Select audio range > Edit.

From/To Sections

Zero/End

The selection begins at the start/end of the file.

Cursor

The selection begins at the edit cursor.

Start/End of selection

The selection begins at the start/end of the selection range.

Marker (with name)

The selection begins at the marker that is selected from the pop-up menu 
below.

Offset (±)

Allows you to specify an offset for the selected position.

Custom

Allows you to specify a start/end time for the selection.

Options Section

Specify length

The length you want to give to the selection.

Set as selection length

Clicking this button freezes the current selection length. This is useful if you 
simply want to move the selection.

Round down length

If this option is activated, the selection length is rounded down to the length 
specified in the value field.



WaveLab Concepts
Selecting Audio

35

Snap to zero-crossing

If this option is activated, the start and the end of a selected range always 
snap to a zero-crossing point of the waveform.

Channels

Select whether the selection spans the left channel, the right channel, or both.

Play Options

With the play options, you can preview the specified audio range.

Play to

Plays the range before the specified position.

Play from

Plays the range after the specified position.

Play once

Plays the selection once.

Play looped

Loops the selection.

Play duration

Sets the playback length. Note that this overrides the From/To parameters.

Memorizing Selection Length and Cursor Position

You can copy the length of a selection range and the position of the edit cursor 
position to an internal memory. This is useful if you want to use these values in 
several places in WaveLab.

• To save the length of the active selection range, in the Audio Files workspace 
or the Audio Montage workspace, select Edit > Memorize selection length.

• To save the position of the edit cursor, in the Audio Files workspace or the 
Audio Montage workspace, select Edit > Memorize cursor position.

• To apply the memorized information, right-click any time edit field and select 
Set memorized position or Set memorized duration.
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Selecting in Stereo Files

If you are working on stereo material in the Audio Files workspace, you can apply an 
operation to one channel only or to the entire stereo material.

Which channel is selected when you click and drag in the wave window depends 
on where you position the mouse cursor, as indicated by the pointer shape. The 
pointer shape indicates which channel will be affected.

The following pointer shapes are available:

Switching the Selection Between Channels

You can switch the selection that you have made for a channel to all channels or 
switch the selection to the other channel.

PROCEDURE

1. In the Audio Files workspace’s wave window, make a selection range.

2. Select Edit > Select time range, and select Extend to all channels, Left 
channel only, or Right channel only, or press [Tab] to cycle between the 
different channel selections.

Selecting in the Overview of the Audio Files Workspace

The selection ranges that you make in the overview of the Audio Files workspace 
also apply to the main view.

PROCEDURE

• In the Audio Files workspace’s wave window, hold down [Ctrl]/[Command], 
and click and drag in the overview.

Pointer Shape Description

Clicking in the upper half of the left channel selects the left channel.

Clicking in the middle area between the left and the right channel 
selects both channels.

Clicking in the lower half of the right channel selects the right channel.
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Moving a Selection Range

If a selection range is the right length, but at the wrong position, you can move it.

PROCEDURE

1. In the wave window, hold down [Ctrl]/[Command]-[Shift].

2. Click in the middle of the selection and drag to the left/right.

Extending and Reducing the Selection

You can resize a selection range in the wave window or the montage window 
without having to make a new one.

There are several ways to extend/reduce the selection:

• Make a selection range, [Shift]-click outside the selection range, and drag to 
the left/right, or click and drag the edges of the selection range to the 
left/right.

• To extend the selection to the previous/next boundary (marker or start/end of 
file), press [Shift] and double-click the non-selected area between the 
boundaries.

Extending and Reducing the Selection Using the Cursor Keys

• To move the start/end of a selection in the wave window to the left/right, hold 
down [Shift] and press the left/right cursor keys. To move it in bigger steps, 
press the [Page Up]/[Page Down] keys.

• To extend a selection to the previous/next boundary in the wave window 
(marker or start/end of the audio file), hold down [Ctrl]/[Command]+[Shift] 
and press the left/right cursor keys.

Deleting Selections

There are several options for deleting a selected time range.

Audio Files Workspace

The following options can be found on the Edit menu:

Trim

Removes the data outside the selection.

Remove

Removes the selection. The audio to the right of the selection is moved to the 
left to fill the gap.
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Smooth remove

Removes the selection and inserts crossfades at the edges. You can edit the 
default crossfade length and type in the Audio file editing preferences 
dialog, on the Editing tab.

Audio Montage Workspace

The following options can be found on the Edit menu:

Delete

If there is a selection range, the clip parts inside the selection range are 
deleted and the right section of the clips are moved to the left to fill the gap.

If there is no selection, the selected clips are deleted.

Erase selected time range

Deletes the clip parts inside the selection range, without filling the gap.

Sliders

At various places in WaveLab, slider controls are available to change parameters. 
There are a number of ways to change the value of a slider.

• Position the mouse over the slider and use the mouse wheel (no click is 
required). Hold [Ctrl]/[Command] while using the mouse wheel to scroll 
faster. This modifier also applies to the zoom wheels. To move the button of a 
slider, click and drag it.

• To move the slider handle directly to a position, click the slider at any position.

• To move the slider handle in smaller steps, right-click or below the handle. 
Keep the mouse button pressed to automatically step to the next value.

• To reset the slider to the default value, if available, [Ctrl]/[Command]-click the 
slider, or click using the third mouse button, or double-click the handle.

Renaming Items in Tables

You can rename items in tables in the Markers window, the CD window, and the 
Clips window.

• To rename an item, double-click it or select it, and press [Return], and enter 
the new name.

• To rename the previous/next item, press [Arrow Up] or [Arrow Down] instead 
of [Return]. This way you move the focus on the previous/next item, while 
staying in the edit mode.
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File Browser

The File Browser window in the Audio Files workspace and the Audio Montage 
workspace allows you to browse files directly from within WaveLab. It can be very 
useful in speeding up the process of auditioning sound files.

The File Browser window provides you with all the standard browsing functions as 
well as additional controls to audition audio files and any marker defined regions. 
You can use it to open or insert files or regions of files by dragging them onto an 
open workspace.

You can also choose to only view certain types of files.

File Browser Window

In this window, you can browse files and open them in WaveLab.

In the Audio Files workspace or the Audio Montage workspace, select Workspace 
> Specific tool windows > File Browser.

You can add your favorite folders to the left pane by dragging them from the middle 
pane.

The following options are available in the File Browser windows:

Look in

Lets you select a file location to browse and lists the recently used locations.

Back/Forward/Parent Directory

Let you navigate through the list and file hierarchy.

List View

Shows only the file name in the file list.

Detail View

Shows the file name, size, type, and modification date in the file list.

File name

Shows the file name of the selected file.

File format list

Lets you select which file format to display.
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The following options are only available in the File Browser window in the Audio 
Montage workspace:

Select Audio Files

Shows only audio files.

Select Audio Montages

Shows only audio montages.

Select Clip Files

Shows only clip files.

Auto-Play mode

Starts playback automatically for the selected file.

Play selected audio file

Plays the selected audio file.

Tab Groups

A tab group is a region within a workspace, in which you can open audio files, audio 
montages, meters (Control Window only), batches, or Podcasts. With tab groups, 
you can view the content of different files and meters at the same time, without 
having to navigate through different windows.

3 empty tab groups in the Audio Montage workspace
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Each tab group has its own content and title bar. In the Audio Files workspace, each 
tab contains an audio file. In the Audio Montage workspace, each tab contains an 
audio montage.

3 tab groups with audio montages in the Audio Montage workspace

In the Control Window, a tab group can contain meters and the Master Project 
window.

2 tab groups in the Control Window

Using Tab Groups

Tabs are used differently depending on the type of window.

• To add a tab group, select Workspace > Add Tab Group at right or 
Workspace > Add Tab Group below.

• To remove an empty tab group, activate the tab group, and select Workspace 
> Remove active Tab Group.

• To use one of the tab group layout presets, select Workspace > Tab Group 
presets, and select a layout.

• To reorder tabs, drag the tab to a new position on the tab bar.

• To move a tab to another workspace, drag the tab to another workspace.

• To paste the content of a tab into an audio file, drag the tab onto the 
waveform. The tab is inserted at the cursor position.

• To create an empty file inside a tab group, double-click an empty part of the 
tab bar. The created file uses the active file as template.
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Peak Files

A peak file (extension .gpk) is automatically created by WaveLab each time an audio 
file is modified or opened in WaveLab for the first time. The peak file contains 
information about the waveform and determines how it is drawn in the wave window 
or the montage window.

Peak files speed up the time it takes to draw the corresponding waveform.

By default, the peak file is stored in the same location as the audio file.

The peak file behavior can be set in the Audio file editing preferences dialog on 
the File tab.

• To store peak files in another location, activate Create peak files in an 
independent folder, select Edit and specify another file location.

• To create peak files when writing audio files, activate Create peak files when 
writing audio files.

• To delete peak files when closing audio files, activate Delete peak files when 
closing audio files.

RELATED LINKS

Audio File Editing Preferences Dialog on page 675

Rebuilding Peak Displays

Normally, peak files are automatically updated when the peak file’s date is older than 
the audio file’s date. However, it can happen that the date of the audio file is wrong 
and therefore not automatically updated. In this case you can force a rebuild of the 
peak file.

PROCEDURE

• In the Audio Files workspace, select View > Rebuild peak display.

Companion Files

Companion files (extension .vs) store Master Section presets and view settings for 
audio files. If this feature is activated when you save a file, the stored settings are 
recreated the next time that you load the file.

Companion files are only available in the Audio Files workspace.

The following view settings are included in companion files:

• Window size and position

• Zoom level

• Scroll position
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• Display mode (Waveform/Spectrum/Loudness)

• Snapshots

• Master Section presets associated with the file

Deleting a companion file does not alter the audio contents.

Master Section presets are specific to WaveLab and can therefore not be 
integrated inside the various audio file headers.

Storing Companion Files in Another Location

By default, companion files are stored in the same location as the audio file. 
However, you can select another file location.

PROCEDURE

1. In the Audio Files workspace, select Options > Folders.

2. Select Companion files, and specify another file location.

EBU Loudness Standard R-128

The EBU loudness recommendation R-128 establishes well-defined methods to 
measure loudness, dynamics, and peak values, and also defines reference values to 
achieve for these measurements. Though the reference values are intended for the 
broadcast world, the measurement methods are helpful in any application dealing 
with audio and loudness control.

WaveLab supports these audio measurements in many places, for metering, audio 
analysis, and processing. The following text gives some basic information about the 
EBU R-128 standard. For more information, refer to the internet.

Loudness Measurement

This method takes into account the frequency sensitivity of the human ear to 
loudness levels. There are 3 types of measurements:

1) Integrated loudness, also called programme loudness: this reports how loud 
an audio piece is, on average. This measurement uses a gating method to 
ignore long periods of silence.

2) Short-term loudness: this measures the loudness every 1 second on an audio 
block of 3 seconds. This gives information about the loudest audio passages.

3) Momentary loudness: every 100 ms, a range of 400 ms of audio is measured. 
This gives instantaneous feedback about the loudness.
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Loudness Range

This measures the dynamics of the audio signal. It reports the ratio between the 
loudest and the quietest (but non-silent) sections. The audio is divided into small 
blocks. There is one audio block every second and each block lasts 3 seconds 
(analyzed blocks overlap).

The top 10 % of the quiet blocks and the top 5 % of the loud blocks are excluded 
from the final analysis. The calculated loudness range is the ratio between the 
loudest and quietest remaining audio blocks. This measurement helps to decide if 
and how much compression or expansion can or should be applied to the audio.

True Peaks

When a digital signal is converted to an analog signal, the EBU R-128 recommends 
measuring an estimation of the real peaks, rather than relying on digital peaks, to 
avoid clipping and distortion. This is accomplished by over-sampling the signal 4 
times and retaining the peak values.

Naming and Units

The EBU R-128 proposes naming and units conventions:

• A relative measurement, such as a value relative to a reference level: “LU” as 
“Loudness Unit” (1 LU is 1 dB).

• An absolute measurement, LUFS as “Loudness Unit Full Scale”. 1 LUFS can 
be understood as 1 dB in the AES-17 scaling.

When WaveLab relates to the EBU R-128 loudness, these units are used rather 
than dB.
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Program Overview

Command Bars

Commonly used tools, shortcuts, and commands are represented by command 
buttons. Related buttons are grouped into various Command bars.

Command bars in the Audio Files workspace

You can dock Command bars to any window edge or open them in a separate 
window, and rearrange them freely. Each workspace has an appropriate set of 
command bars that can be displayed. All the commands that are represented by the 
command buttons are also available on the menus.

RELATED LINKS

Locking the Window Layout on page 617

Hiding and Showing Command Bars

You can hide command bars that are irrelevant for your project.

• To view a list of available command bars, in the Audio Files workspace or the 
Audio Montage workspace, right-click an empty part of the top edge of the 
workspace, or select Workspace > Command bars.

• To show/hide a command bar, select Workspace > Command bars, and 
activate/deactivate the command bars that you want to show/hide. You can 
also right-click a command bar, and select Close.

Docking Command Bars

Command bars can either be used as separate floating windows or docked at the 
top, bottom, left, or right side of the workspace window.

• To make a command bar floatable, right-click the bar, and select Floatable. 
Then click the dots on the left side or the top of the command bar to drag the 
bar to another location.
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Status Bar

The status bar at the bottom of the screen of the Audio Files workspace and the 
Audio Montage workspace shows information about the active window using the 
units specified in the rulers.

The information displayed on the status bar is updated depending on the cursor 
position and on the audio selection that you have made.

Time/Level (dB)

Displays the time of the audio file at the mouse cursor position. In the Audio 
Files workspace, it also displays the level.

Audio information at edit cursor

Displays the time at the position of the edit cursor. This information changes 
when you reposition the cursor.

• To define the cursor position, click the indicator to open the Cursor 
position dialog.

• To focus the cursor position, right-click the indicator.

Audio selection indicator (Audio Files workspace)/Audio range indicator 
(Audio Montage workspace)

In the Audio Files workspace, this displays the length of the current selection, 
or the total length of the audio file if no selection has been made.

In the Audio Montage workspace, this displays the length of the audio 
selection, if a clip is focused, or the size of the audio montage.

When you have zoomed in, you can right-click the indicator to display the 
selected audio range, the focused clip, or the whole file. Left-click the 
indicator to open the Audio Range dialog, where you can define or refine a 
selection.

Zoom indicator

Displays the current zoom factor.

• To open a pop-up menu, where you can make additional zoom settings, 
click the indicator.

• To open the Zoom factor dialog, where you can edit the zoom factor, 
right-click the indicator.

Sampler key indicator (Audio Files workspace only)

Indicates the key of the current audio file (if defined). Click the indicator to 
open the Sample Attributes window.
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Audio properties indicator

In the Audio Files workspace, this displays the bit resolution and the sample 
rate. It also indicates whether the audio file is mono or stereo. Click the 
indicator to open the Audio properties dialog.

In the Audio Montage workspace, this displays the number of audio channels 
and the sample rate of the audio montage. Click the indicator to open the 
Audio Montage properties dialog.

Play through Master Section

If this button is activated, the audio is played through the Master Section. If 
the button is deactivated, the Master Section is ignored.

Store Master Section preset

Opens the Save Master Section Preset dialog, where you can save the 
active Master Section configuration inside the companion file or audio 
montage.

Load Master Section preset stored with the audio file/audio montage

Applies the Master Section with the configuration previously saved to the 
audio file/audio montage.

Include Master Section preset when rendering as super clip (Audio Montage 
workspace only)

If this option is activated, the Master Section preset stored with the audio 
montage is used when rendering super clips of audio montages.

Document button (drag and drop)

Allows you to drag the current file into another file, for example, an audio file 
to the Audio Montage workspace. This is equivalent to dragging the file tab.

Background information

The status bar shows the progress of some background operations, such as 
rendering an effect. The operation can be paused or canceled using the 
provided buttons.

Context Menus

Throughout WaveLab, various context menus are available. These menus group the 
commands and/or options that are specific to the current working window.

The context menus appear when you right-click certain areas and are useful for 
speeding up your workflow.

For example, right-click a file tab to open a context menu with some relevant file 
options. Right-click the ruler of the waveform window brings up the Time Ruler 
context menu that allows you to access a number of options for changing the time 
ruler display format.
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You can find most context menu commands in the main menus, but some 
commands are only available in context menus. When you search for a function, 
right-click the current working window to check if it has a context menu.

Context menu in the wave window

Time Ruler and Level Ruler

In the Audio Files workspace, you can display a time and a level ruler in the wave 
window. In the Audio Montage workspace, you can display a time ruler in the 
montage window.

You can also determine which time and level units the rulers show.

Time ruler Level ruler 
(Audio Files workspace only)
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Time Ruler and Level Ruler Options

You can specify the time and level (amplitude) formats for each ruler in each wave 
window and the time formats for each ruler in the montage window separately by 
right-clicking the ruler, and selecting a format from the pop-up menu.

Time Ruler Menu

Timecode

Displays a list of frames per second for various SMPTE timecodes and for CD 
resolution.

Clock

Displays time units.

Samples

Positions are shown as number of samples. The number of samples per 
second depends on the sample rate of the audio file. For example, at 44.1 kHz, 
there are 44100 samples per second.

Bars and beats

If this is selected, the ruler is linear relative to the meter position.

File size (Audio Files workspace only)

Shows positions in MegaBytes. Decimals represent KiloBytes.

Show grid (Audio Montage workspace only)

Displays vertical lines in the montage window, aligned with time ruler marks.

Time format

Opens the Time format dialog, where you can edit the appearance of the 
time ruler formats.

Save current settings as default

If this option is activated, the time ruler uses the current time format in all new 
wave windows or montage windows.

Set ruler’s origin to start of file

If this option is activated, the ruler’s zero position is set to the beginning of the 
first sample.

Set ruler’s origin at cursor

If this option is activated, the ruler’s zero position is set to the current cursor 
position.

Set ruler’s origin to BWF reference (Audio Files workspace only)

If this option is activated, the first sample matches the BWF time reference, 
provided that the time reference is available.

Show playback range

If this option is activated, the time ruler displays the audio range that is played 
with the “Play Range” command.
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Show playback anchor

If this option is activated, a marker is displayed below the time ruler to indicate 
the audio anchor that corresponds to the “Play From”” and “Play To” 
commands.

Show pre-/post-roll

If this option is activated, the pre-roll and post-roll times are displayed.

Level Ruler Menu (Audio Files workspace only)

dB

Sets the level format to decibels.

+-100 %

Sets the level format to percentage.

Normalized +1/-1

Sets the level format to a ruler gradation corresponding to 32-bit float audio.

16-bit range

Sets the level format to a ruler gradation corresponding to 16-bit audio.

24-bit range

Sets the level format to a ruler gradation corresponding to 24-bit audio.

Save current settings as default

If this option is activated, the level ruler uses the current level format in all new 
wave windows.

Time Format Dialog

In this dialog, you can customize the time format. The time format of the ruler is also 
used in various time fields, for example, the status bar and certain dialogs.

In the Audio Files workspace, depending on whether you want to set the time format 
for the overview display or the main view display, select View > Overview display 
> Time ruler > Time format or View > Main view display > Time ruler > Time 
format.

In the Audio Montage workspace, select View > Time ruler > Time format.
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Timecode Tab

On this tab, you can configure the appearance of the Timecode option.

Frames per second

List of standard frame rates. From the drop-down menu, select Other to enter 
a custom frame rate. You can also choose which frames/units are displayed.

Show absolute frames

Shows the time format as a number of frames, without other time elements.

Show quarter frames

Adds the quarter frame number to the time format.

Show hundredth frames

Adds the number of a hundredths of a frame to the time format.

Show units

Adds time units to the time format of the ruler.

Clock Tab

On this tab, you can configure the appearance of the Clock option.

Show Units

Adds time units to the time format of the ruler.

Compact

Shows the time without unit indicators.
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Meter Tab

On this tab, you can configure the appearance of the Bars and beats option.

Time signature

Lets you edit the time signature used to display the time represented as a 
musical notation.

Tempo

Lets you edit the tempo used to display the time represented as a musical 
notation.

Ticks per quarter note

Lets you edit the number of ticks per quarter note that are used to display 
times that are compatible with your sequencer.

Offset Tab

On this tab, you can configure the Time ruler offset.

Zero (default)

Deactivates the time offset in the ruler.

Set zero-point at cursor position

Sets the current cursor position to be the starting point of the ruler.

Set zero-point at BWF time reference (Audio Files workspace only)

If the audio file contains BWF meta-data, the corresponding time reference 
value is used as offset.

Set time of first sample

Specifies the time that corresponds to the ruler’s zero origin.
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Setting the Cursor Position

Many operations, such as playback and selection, depend on the current cursor 
position. For example, playback often starts at the cursor position. The current 
cursor position is indicated by a vertical flashing line.

There are various ways to move the cursor:

• Click somewhere in the wave window, the montage window, or the time ruler. 
If you have made a selection, click the time ruler to prevent deselecting.

• Click and drag in the time ruler.

• Use the transport controls.

• Select View > Move cursor to, and select an option.

• Use the cursor keys.

• Double-click a marker.

Setting the Ruler Start Position

By default, the audio file starts at the ruler position 0. However, you can set the 0 
position at another position.

PROCEDURE

1. In the wave window or the montage window, right-click the time ruler, and 
select Time Format.

2. Select the Offset tab.

3. Select one of the Time ruler offset options, and click OK.

Working With a Meter-Based Display

If your working material is tempo-based, you can select the meter format (bars, 
beats, and ticks) for the ruler legend. This makes it easier to find musically related 
cutting points.

PROCEDURE

1. In the wave window or the montage window, right-click the time ruler, and 
select Bars and beats.

2. Right-click the time ruler, and select Time format.

3. On the Meter tab, set the Time signature and Tempo to values that match 
your audio file.
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4. Set the Ticks per quarter note setting to a number that you feel comfortable 
with.
For example, this can be the same value that is used by your MIDI sequencer.

5. Click OK.

Value Editing

At various places in the program, numerical values can be edited by using a 
combination of text fields and spin controls.

These values are sometimes composed of several parts, for example, 12 mn 30 sec 
120 ms. Each value can be edited by using any of the following methods:

• To change a value, click in a value field and type a new value, or click the small 
arrows in the value field.

• To change the value by one unit at a time, press the [Left Arrow] and [Right 
Arrow] keys.

• To change the value by several units, press the page up and page down keys.

• To change the value using the mouse wheel, position the mouse cursor over 
a value, and spin the mouse wheel, or use the AI knob of your MIDI controller.

• To change the value with the mouse, click a value and drag the mouse up or 
down.

• To jump to the maximum and minimum values, press the [Home] and [End] 
keys.

• To move from one part of the value to another, press the [Left Arrow] and 
[Right Arrow] keys.

Drag Operations

WaveLab makes much use of drag-and-drop techniques to perform various 
operations, some of which cannot be performed otherwise. These are referred to as 
drag operations in this documentation.

• To drag an object, click and hold with the mouse when positioned on the 
object and drag it. Drop the object by releasing the button.

Many types of objects can be dragged between different source and destination 
locations including files, text, clips, items in a list, and markers.

NOTE

It is also possible to drag and drop files from WaveLab to Steinberg’s Nuendo.

Drag objects within and between workspaces to perform the following operations:
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• To dock a tool window, drag its title bar to any side of the workspace, beside 
or above another tool window.

• To move a command bar, drag the bar grip at the left-hand end of a command 
bar and reposition it.

• To reorder a tab within its own tabbed group, drag horizontally. To move a tab 
to another workspace, drag vertically.

• To drag any object to another workspace, use the Central Switcher bar. Drag 
the object over the corresponding workspace icon in the Central Switcher 
bar, wait until the new workspace becomes active, and drag the tab in the 
target workspace.

• To open a file, drag a compatible file from the File Browser window of 
WaveLab, from the file browser of the operation system, or from another 
application to the tab bar.

• To create a copy of a file, drag its tab vertically to another position of the tab 
bar, then press [Ctrl]/[Option], and release the mouse button.

Dragging in the Audio Files Workspace and Audio Montage Workspace

• To insert an audio file in another audio file, drag the title bar tab or document 
button of the file onto the waveform area of another file. You can also drag an 
audio file directly from the File Browser window, the file browser of your 
system, or from another application into the Audio Files workspace.

• To move a marker, drag it along the time ruler.

• To create a copy of this marker, press [Shift], and drag it to another position 
on the time ruler.

• To delete a marker, drag it above the time ruler.

• To copy an audio selection, drag a selected region of audio onto the waveform 
area of the same file or another file.

• To change the extent of a selection range, position the edit cursor at the 
start/end of the selection range, and drag to the left or right.

• To move the edit cursor without losing the current selection, and to snap it to 
an anchor, press [Shift], and move the mouse near the audio file/montage 
cursor. The mouse cursor shape changes and you can drag the cursor left and 
right.

• To move the edit cursor without changing or losing the current selection, 
press [Shift], click the edit cursor, and drag it to another position.

• To scroll the waveform horizontally, click the bar above the time ruler and drag 
left or right. You can also click anywhere on the waveform using the 3rd 
mouse button, and drag left or right.

• To create a generic marker from a selected text, drop text that you have 
selected in an external application onto the time ruler. The text becomes the 
marker’s name.
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• To create a stereo copy of a mono file, or a mixed copy of a stereo file, drag a 
tab to another position of the tab bar, press [Ctrl]-[Alt] (Windows) or 
[Options]-[Ctrl] (Mac), and release the mouse button.

Dragging in the Podcast Workspace

• To reorder episodes in the episodes list, drag them to another position.

Dragging in the Master Section

• To change the order of processing, drag effects between different effects 
slots.

Dragging in the Batch Processors Workspace

• To change the order in which plug-ins are processed, drag plug-ins within the 
audio plug-in chain window.

• To add a file to batch process, drag a file tab to the batch conversion tool or 
batch processor.

Undoing and Redoing

You can undo and redo as many steps as you like. The only limitation is the available 
hard disk space.

By default, when undoing or redoing any operation in the Audio Files workspace or 
the Audio Montage workspace, the zoom factor, cursor position, scroll position, clip 
selection status, and time range are restored to the state before the operation 
occured.

To exclude the scroll and zoom settings when undoing/redoing, deactivate Edit > 
Undo/Redo including zoom settings. This is useful if you make an operation, 
zoom in on the changed area, and then undo the step to see the change, for 
example. When you do this you do not want snapshots to be restored and change 
your scroll and zoom settings. This option is independent for the Audio Files 
workspace and the Audio Montage workspace.

• To undo a step, in the Audio Files workspace or Audio Montage workspace, 
select Edit > Undo.

• To redo a step, in the Audio Files workspace or Audio Montage workspace, 
select Edit > Redo.



Program Overview
Undoing and Redoing

57

Clearing the Undo/Redo History

If you have a large number of undo/redo steps that you no longer need, you can 
clear the whole change history. This frees up memory, hard disk space, and any 
involved audio file.

This function must be activated for each file separately. Only the undo/redo history 
for the active file is cleared.

• In the Audio Files workspace, select Edit > Clear change history, and click 
OK.

• In the Audio Montage workspace, select Edit > History > Clear, and click 
OK.

NOTE

When you save an audio file, the undo history is cleared automatically. This is not 
the case for audio montages.

About Undo/Redo and History in the Audio Montage 
Workspace

The undo/redo function in the Audio Montage workspace is identical with the 
undo/redo function in the Audio Files workspace. However, the Audio Montage 
workspace provides additional undo/redo functions and a History window that 
allows you to view a history of all recent editing activities in the audio montage and 
to revert to a previous state.

Each audio montage has its own history.

• To open the History window, select Workspace > Specific tool windows > 
History.

• To revert the current audio montage to a previous state, double-click the 
operation to which you want to return.

• To group similar operations in the undo history, select Options > Audio 
Montage Preferences, and on the All Audio Montages tab, activate Group 
similar operations. This groups all operations of the same type to one single 
operation, as soon as an operation of another type is performed.

• To clear the history after each saving, select Options > Audio montage 
preferences, and on the All Audio Montages tab, activate Clear after each 
saving.

• To undo all operations, select Edit > History > Undo all operations.

• To undo all operations since the last saving command, select Edit > History 
> Undo all operations since the last saving command.

• To redo all operations, select Edit > History > Redo all operations.

• To clear the history, select Edit > History > Clear.
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History Window

In this window, you can see all the operations that have been performed in the Audio 
Montage workspace at a specific time and revert to a previous state.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
History.

Status

Shows which operations are done and undone.

Operation

Shows the type of the performed operation.

Time

Shows the time at which the operation was performed.

Description

Describes the performed operation in detail.

Zooming

There are several zooming functions in the Audio Files workspace and Audio 
Montage workspace.

Horizontal Zooming

• When you zoom out as far as possible, the entire file fits in the window.

• When you zoom in as far as possible, each sample occupies several pixels on 
the screen. This allows for single sample-accurate editing of waveforms.

Vertical Zooming

• When you zoom out as far as possible, the height of the wave fits in the 
window.

• As you progressively zoom in, the display only shows a part of the total height. 
The vertical scrollbars lets you adjust exactly which section is shown. Check 
the ruler to see which part of the waveform is currently shown in the display.

• To optimize the vertical zoom of the waveform, press [Ctrl]/[Command], click 
and hold the time ruler, and move the mouse up or down.
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High Zoom Level

• When the zooming level is very high, each sample is shown with a step and a 
bullet. The steps show the real digitized state, while the bullets make it easier 
to see the samples, especially for zeroed samples.

• The curve also represents an estimation of the analog reconstructed signal to 
give hints on true peaks.

Zooming in the Overview and Main View Sections (Audio Files Workspace Only)

• You can have different zoom levels in the overview and main view section. In 
the overview, a range indicator on the time ruler indicates which section of the 
file is currently displayed in the main view. The range indicator is only shown 
if the option Sync with other view is deactivated.

• To adjust the zoom level, drag the edges of the range indicator.

• To scroll in the main view, drag the range indicator. The range indicator is 
located at the top of the overview display.

• To adjust the zoom level using the scrollbar, drag the edges of the scrollbar.
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Zooming Using the Zoom Controls

Both the main view and the overview have horizontal and vertical zoom controls.

• To zoom horizontally, click the Horizontal zoom control, and drag left or right, 
or use the mouse wheel.

• To zoom vertically, click the Vertical zoom control, and drag up or down, or 
use the mouse wheel.

• To fully zoom-out, double-click the zoom controls.

Zooming Using the Magnifying Glass Tool

The Magnifying Glass tool is used to zoom in a specific section of the waveform so 
that is occupies the entire wave window. This is only available in the Audio Files 
workspace.

Using the Magnifying Glass Tool in the Main View

The selection that you make in the main view of the wave window is magnified and 
fills up the entire main view.

PROCEDURE

1. In the Audio Files workspace, activate the Magnifying Glass tool by doing one 
of the following:
• Click the Magnifying Glass icon.

• Hold down [Ctrl]/[Command].

2. In the main view of the wave window, click and drag left or right, and release 
the mouse button.
The selected part of the wave now occupies the entire main window.
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Using the Magnifying Glass Tool in the Overview

The selection that you make in the overview of the wave window is displayed in the 
main view.

PROCEDURE

• In the overview of the wave window, click and drag left or right, and release 
the mouse button.

RESULT 

The selected range of the waveform is shown in the main view.

Zooming Using the Mouse

With the mouse, you can change the zoom factor by clicking and dragging or by 
scrolling the mousewheel.

• To zoom horizontally, in the wave window or the montage window, position 
the mouse cursor over the time ruler, click, and drag up or down.

• To zoom horizontally while maintaining the cursor position, position the mouse 
cursor over the time ruler, press [Shift], and drag up or down.

• To zoom horizontally using the mousewheel, press [Ctrl]/[Command], point at 
a waveform, and move the mousewheel.

• To zoom vertically using the mousewheel, press [Shift], point at a waveform, 
and move the mousewheel.

Audio Files Workspace Only

• To zoom vertically, in the wave window, position the mouse cursor over the 
level ruler, click, and drag left or right.

• To reset the vertical zoom to 0 dB, double-click the level ruler.

• To set the vertical zoom to the best value that is the current minimum and 
maximum displayed samples, make sure that the level ruler is set to 0 dB, and 
double-click the level ruler.

Zooming Using the Keyboard

A quick way to zoom the active wave or montage window is to use the arrow keys 
on the computer keyboard.

• To zoom horizontally in the active wave window or montage window, press 
[Arrow Up] or [Arrow Down].

• To zoom vertically in the active wave/montage window, hold [Shift], and press 
[Arrow Up] or [Arrow Down].
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• To zoom vertically to fit the available height, press 
[Ctrl]/[Command]-[Shift]-[Arrow Up].

• To zoom out fully, press [Ctrl]/[Command]-[Arrow Down]. To zoom in fully, 
press [Ctrl]/[Command]-[Arrow Up].

NOTE

You can increase or decrease the zoom steps with the Interval for the zoom key 
command option in the Global Preferences dialog.

RELATED LINKS

Global Preferences Dialog on page 666

Zoom Menu

The zoom menu allows you to quickly access various zoom settings.

In the Audio Files workspace or the Audio Montage workspace, select View > 
Zoom.

View all

Zooms out as far as possible.

Zoom in on 1 minute/30 seconds/10 seconds/.../500 ms

Adjusts the zoom to display the selected time range.

Zoom in 1:1

Zooms in so that one pixel on the screen represents one sample.

Microscope

Zooms in as far as possible.

Zoom selection

Zooms the window so that the current selection occupies the entire 
wave/montage window.

Zoom in on selected clips (Audio Montage workspace only)

Zooms in to display all selected clips in the wave/montage window.

Zoom in audio

Zooms in in small steps.

Zoom out audio

Zooms out in small steps.
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Edit

Opens the Zoom factor dialog, where you can edit the zoom factor.

• Samples per screen point allows you to specify how many audio 
samples are summarized in each screen point.

• Screen points per sample allows you to specify how many screen 
points are used to represent a single audio sample.

Reset vertical zoom to 1:1

Adjusts zoom to display audio levels up to 0 dB.

Optimize vertical zoom

Changes the vertical zoom factor so that the peaks are clearly visible. This 
adjustment is done according to the section of the wave that is currently 
visible in the wave/montage window.

Optimize vertical zoom (Audio Files workspace only)

Zooms in to display all audio peaks in the wave window.

Zoom to -12 db/-24 db/.../-96 db

Adjusts the zoom to only display samples below the selected dB value.

Zoom in vertically

Zooms in to show waveforms with a lower level.

Zoom out vertically

Zooms out to show waveforms with a higher level.
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About Zooming in the Audio Montage Workspace

Zooming options in the Audio Montage workspace are almost similar to those in the 
Audio Files workspace. However, there are additional zooming options for tracks 
and the Zoom window for displaying a close-up view of the beginning of the 
focused track.

Zoom Buttons in the Audio Montage Workspace

The zoom buttons in the Audio Montage workspace allow you to apply zoom 
presets.

• To only display the focused track, or also the tracks below and/or above the 
focused track, click the corresponding buttons.

• To set the zoom setting to fit the focused clips in 25 %, 50 %, or 100 % of the 
available space, click the corresponding buttons.

• To select a certain area, click [Ctrl]/[Command], and drag the rectangle over 
the tracks and clips that you want to zoom in.

Displaying More or Less Tracks

The number of tracks that are displayed in the Audio Montage workspace can be 
changed with the magnification controls in the lower right corner of the montage 
window.

• To display more tracks, click the smaller magnifying glass icon.

• To display less tracks, click the larger magnifying glass icon.

• To make a single track fit the whole montage window, click the numbered 
button to the left of a track, and select Zoom from the pop-up menu. You can 
also right-click the lower area of a track, and select Whole clip from the 
pop-up menu.
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Managing Tabs

A tab is a container for a file in WaveLab. You can open several tabs, but only one 
can be active at a time. The Tabs menu allows you to sort and close tabs and 
navigate between the tabs.

Close/Close all but active/Close all

Closes the active tab, all tabs except the active tab, or all tabs.

Select files to close

Opens a dialog in which you can specify the files to be closed.

Sort

Lets you sort the tabs by name, date, or modification date. If several tab 
groups exist, only the active tab group is sorted.

Activate next/previous

Selects the next/previous tab.

Pick list

Opens a list of all open tabs. To open a tab, double-click it.

Move to new workspace

Opens the active tab in a new workspace of the same type.

The following options are only available in the Audio Files workspace:

Cascade

Cascades the open tabs.

Tile

Tiles the open tabs.

Fold

Displays only the title bar of the tabs.

Restore

Restores the tab to its original size.

Minimize/Maximize

Minimizes/maximizes the tab.
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Files to Close Dialog

In this dialog, you can specify which files you want to close.

In any workspace, except the Control Window workspace, select Tabs > Select 
files to close.

Files list

Displays all open files. You can set a checkmark for the files that you want to 
close. By default, only the active file will remain open and all other files will be 
closed.

Select all

Select all files in the list.

Select none

Deselects all files in the list.

Close files

Closes the files.

Presets

You can create presets to save commonly used settings. WaveLab provides a 
selection of presets that can be used by most dialogs.

You can save customized presets. The next time that you load the program, the 
presets are available.

Presets are saved as single files and can be organized in subfolders. The root folder 
of the preset is different for each type of preset and cannot be changed.

Saving a Preset

Saved presets can be used to apply commonly used settings to dialogs or plug-ins.

PROCEDURE

1. Open the dialog that you want to use, and modify the parameters.

2. Select the Preset menu, and select Save as.
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3. Optional: Click the folder icon, and select a name for a subfolder in which you 
want to save the preset.

4. Type in a name, and click Save.

Loading Presets

To apply a saved preset to a dialog or plug-in, you must load the preset.

PROCEDURE

• Inside a dialog, click the Presets menu, and select the preset that you want 
to apply to the dialog.

Modifying a Preset

You can modify a preset and save the changes.

PROCEDURE

1. Open the dialog that you want to use, and load the preset that you want to 
modify.

2. Modify the parameters of the dialog.

3. Click the Preset menu, and select Save.

Deleting a Preset

PROCEDURE

1. Open the dialog that you want to use and select the preset that you want to 
delete.

2. Click the Presets menu, and select Organize presets.

3. In the Explorer window, select the preset file that you want to delete, and 
press [Delete].
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Storing and Restoring Temporary Presets

Some dialogs allow you to save and load up to 5 temporary presets. This is useful 
if you want to quickly test and compare different settings.

Storing Presets

PROCEDURE

1. Open the dialog that you want to use, and make your settings.

2. Click the Presets menu, and from the Store temporarily submenu, select a 
slot.

Restoring Presets

PROCEDURE

1. Open the dialog in which you have saved a preset.

2. Click the Presets menu, and from the Restore submenu, select a preset.

Saving a Picture of the Active Window

You can save a picture of the active window in the BMP, JPG/JPEG, or PNG file 
format, or copy it to the clipboard.

NOTE

Plug-in windows are not included in the picture.

PROCEDURE

1. Click in the window for which you want to save a picture.
For example, click in the wave window or the montage window.

2. In the Audio Files workspace or the Audio Montage workspace, select View 
> Save picture of active window.
The Save picture of active window dialog opens.
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3. In the Save picture of active window dialog, you have the following options:
• To copy the picture to the clipboard, activate Copy to clipboard.

• To save the picture in a specified file format, activate Save as file. Optionally, 
you can activate Open picture after saving.

4. Click OK.
• If you have activated Copy to clipboard, the picture is copied to the clipboard.

• If you have activated Save as file, the Save as dialog opens where you can 
specify the file location, file format, and file name. Click Save to confirm your 
settings.

If you have set the montage window as the active window, the resulting picture could 
look like this.

Log Window

This window allows you to view log messages that have been issued by WaveLab.

For example, when using the scripting language of WaveLab, the logWindow( ) 
function outputs messages to this window. Toggle buttons allow you to filter the 
types of messages that are displayed.

In the Audio Files workspace, the Audio Montage workspace, or the Control 
Window select Workspace > Shared tool windows > Log.

Clear

Removes all messages from the window.
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Show errors

If this option is activated, error messages are displayed.

Show warnings

If this option is activated, warning messages are displayed.

Show notes

If this option is activated, notes are displayed.
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File Operations

List of All Open Files Throughout the Application Dialog

In this dialog, all open files in WaveLab are listed.

In any workspace, select Global > List of all open files.

The dialog displays all the files that are opened in workspaces. These can be 
opened, closed, renamed, and saved, and audio files can be auditioned. The list can 
also be filtered by file type.

The dialog is automatically updated if a file is closed, opened, saved, or edited. You 
can navigate in the list using the arrow keys, or pressing [A]-[Z] on your keyboard.

Filter pop-up

The pop-up in the top right corner allows you to filter the list by file type.

Visible/Hidden files

This opens let you show visible files and/or hidden files. Hidden files are 
shown with gray text.

Bring to front

Brings the file that is selected in the list to the front.

and close this window

If this option is activated, this window closes, after you have clicked Bring to 
front.

Close

Closes the selected file.

Play/Stop

Plays back the selected audio file. If you click the button again, the playback 
stops.

Save

If a file has unsaved changes, you can click this button to save the file in its 
current location.

Rename

Opens the Rename dialog where you can rename the selected file, and 
optionally change its path.
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Close this window

Closes the dialog.

Recently Used Files

All files that you have recently used in WaveLab are saved in a list. This helps you 
to gain fast access to recent projects.

Opening Recently Used Files

You can open recently used files via the File menu, or open the Recently used files 
dialog, which displays more files and offers additional options.

PROCEDURE

1. In any workspace, except the Control Window, select File > Open recent.

2. Choose from which workspace you want to open the file, by selecting the 
corresponding tab.

3. Optional: Use the search field to enter the name of the file that you are looking 
for.

4. Select the file that you want to open, and select Open selection.

NOTE

If you cannot find the file that you are looking for in the list, select Open other, 
and select the file from the Windows Explorer/Mac OS Finder.

Recently Used Files Dialog

This dialog allows you to view and manage all the files that you have recently used 
in WaveLab. You can search for files, open multiple files at once, and remove 
individual files or files that cannot be located from the list.

In any workspace, except the Control Window, select File > Open recent.

Only show recently created files

Only shows the files that have not been opened since they were created by 
WaveLab. For example, a file that is rendered has this status until it is opened.

Search field

Lets you search for text in the Name column.

Remove non-existing files

Removes files from the list that cannot be located on the media.
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Remove selected files

Removes all selected files from the list.

Filtering Recently Used Files by Name

The search field in the Recently used files dialog allows you to filter the files list by 
name.

To specify if the Name or the Path column is used, click the column header.

• In the Recently used files window, enter the text that you want to search for 
in the search field.

• To switch the focus from the search field to the list of recently used files, press 
the arrow down key.

• To switch the focus from the list of recently used files to the search field, press 
[Ctrl]/[Command]-[F].

Setting the Number of Recently Used Files

PROCEDURE

1. In any workspace, select Options (WaveLab menu on Mac) > Global 
preferences > Display.

2. In the Miscellaneous options section, set the maximum number of items that 
you want to list in the following areas:
• Recent file menus

• Recent file manager

• Recent folders menu

3. Click OK.

Favorite Files

You can add files that you are using regularly to the favorite files list.

• To add a file to the favorite files list, select File > Favorite files > Add active 
file.
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• To open a file from the favorite files list, select File > Favorite files, and select 
the file from the menu.

• To remove files from the favorite files list, select File > Favorite files > Edit 
list, select the files that you want to remove, and click Remove selected files.

• To remove files that have been deleted from the favorite files list, select File 
> Favorite files > Edit list, and click Remove non-existing files.

• To save a list of all open files, select File > Export > List of all open files, 
specify a name and a location for the file list, and click Save.

• To open a saved list of all open files, select File > Import > List of files to 
open, select the file list, and click Open.

Favorite Files Dialog

This dialog allows you to display and edit the favorite files list.

In any workspace, select File > Favorite files > Edit list.

List of favorite files

Shows the favorite files.

Only show recently created files

Only shows the files that have not been opened since they were created by 
WaveLab. For example, a file that is rendered has this status until it is opened.

Search field

Lets you filter the favorite files list.

Audio File/Audio Montage/Batch Processor/Podcast

Lets you display the favorite files of a specific workspace.

Remove non-existing files

Removes files from the list that are no longer present on the media.

Remove selected files

Removes all selected files from the list.

Open selected

Opens the selected files in WaveLab.
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Open other

Opens the file selector where you can select files and add them to the favorite 
files list.

Filtering Favorite Files

The search field in the Favorite files dialog allows you to filter the favorite files list 
by names.

• In the Favorite files dialog, enter the text that you want to search for in the 
search field.

• To switch the focus from the search field to the favorite files list, press the 
arrow down key.

• To switch the focus from the favorite files list to the search field, press 
[Ctrl]/[Command]-[F].

Save and Save As

• When you save a file for the first time, it does not matter whether you select 
Save or Save as.

• Once a file has been saved, select File > Save, or press 
[Ctrl]/[Command]-[S] to update the file and make the changes permanent.

• If you want to specify a new name, location, and/or file format, select File > 
Save as.

• In the Audio Files workspace, all save operations except Save Copy clear the 
undo history, which means that after saving you cannot undo or redo.

About Tab Colors

Tab colors give information on whether a file is saved or not.

The following colors can be shown:

Orange

The file is saved.

Green (Audio Files workspace only)

The file uses a decoded file format and is saved.

Purple

A new file that is not empty but has not been saved yet. For example, when 
creating a new file and pasting content into it.

Red

The file has been modified and changes have not been saved yet.
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Unsaved Changes Indicator

When you have made changes to a file, an asterisk is displayed next to the file name 
until you save the file and the tab changes its color.

Save Multiple Files at Once

You can save some or all open files at once.

PROCEDURE

1. In any workspace, except the Control Window, select File > Save all.

2. Select the files that you want to save.

3. Click Save.

Reverting to Saved File

You can revert the file you are working on back to its last saved state. This undoes 
all the changes made to the file since it was last saved.

PROCEDURE

1. In any workspace, except the Control Window, select File > Revert to saved.

2. In the warning dialog, click Yes to revert to the last saved state.

RESULT 

The last saved version of the file is loaded from disk.

Automatic Backups

Backups are created automatically if a file with the same name already exists.

For example, if you select Save As and specify a file name already used in that 
folder, you will be asked if you want to back up the existing file first. If you click Yes, 
the backup name will be the original name, with “.bak” added at the end.
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About Saving Audio Montages

The saving operations for audio montages are the same as for audio files. However, 
there are things to note when saving audio montages.

• Audio montage files only contain references to audio files. If you want to 
rename audio files referenced by audio montages, use the Rename dialog. All 
clip references are updated automatically.

• If the audio montage contains clips that refer to untitled audio files, save these 
audio files before saving the audio montage.

Templates

You can create a template from an active audio montage, audio file, Podcast, or 
batch processor document and use it as a basis for newly created files.

Creating a Template

Templates are useful when creating new audio files, audio montages, Podcasts, or 
batch processes.

PREREQUISITE 

Set up the audio file, audio montage, Podcast, or batch processor file properties.

PROCEDURE

1. Select File > Export > Template.

2. In the Save Template dialog, do one of the following.
• To create a new template, select New, enter a name, and click OK.

• To update an existing template, select Update.

3. When saving or updating an audio file template or an audio montage template, 
you can make additional settings.
• When saving an audio file template, the Audio File Template Parameters 

dialog opens. Here, select whether WaveLab should propose a specific audio 
file configuration with optional meta-data when saving an audio file.

• When saving an audio montage template, the Audio Montage Template 
Parameters dialog opens. Here, select whether to include track plug-ins, clips, 
and/or markers. Also select whether WaveLab should propose a specific audio 
file configuration with optional meta-data when rendering an audio montage.

4. Click OK.
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Audio File Template Parameters Dialog

This dialog displays the audio properties of the audio file template that you are 
creating. You can also specify whether to always propose a specific audio file 
configuration with optional meta-data when creating an audio file template or not.

In the Audio Files workspace, select File > Export > Template.

When saving, always propose a specific audio file configuration (with optional 
meta-data)

If this option is activated, whenever you open the Render or Save as dialogs, 
the audio file configuration specified below is proposed by default.

Audio Montage Template Parameters Dialog

In this dialog, you can set various options when creating an audio montage 
template.

In the Audio Montage workspace, select File > Export > Template.

Include track and master plug-ins

If this option is activated, track plug-ins and master plug-ins are saved in the 
template.

Include clips

If this option is activated, clips are saved in the template.

Include markers

If this option is activated, markers are saved in the template.

When saving, always propose a specific audio file configuration (with optional 
meta-data)

If this option is activated, whenever you open the Render dialog, the audio file 
configuration specified below is proposed by default.
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Setting a Template as Default

You can set a template as default template.

PREREQUISITE 

Create a template with the settings that you want to use as default settings for a file.

PROCEDURE

1. In any workspace, except the Control Window, select File > New from.

2. From the templates list, select the template that you want to use as the default 
template.

3. Click Set as default.

4. Click OK.

RESULT 

When you select New, a file based on the selected template is created. To remove 
the default template setting, click the Do not set as default button.

Creating a File From a Template

You can create a file from a template to use its settings.

PROCEDURE

1. In any workspace, except the Control Window, select File > New from.

2. From the list of the available templates, select the template that you want to 
take as the basis of the new file.

3. Click Open.
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Create From Template Dialog

This dialog shows all templates. Here, you can open and delete them, and set a 
default template.

In the any workspace, except the Control Window, select File > New from. If no 
template exists, the dialog will not open.

List of the available templates

Lists all saved templates.

Use template name as default document name

If this option is activated, the new file uses the name of the template. If this 
option is deactivated, the name of the new file is “untitled”.

Set as default

Saves the selected template as default template.

Open

Creates a new file from the selected template.

None

Creates a new file without any reference to a template.

Explore

Opens the folder where the template files are located. Here, you can delete 
templates.

File Renaming

The Rename function allows you to rename a file and update all references 
automatically. For example, if you rename an audio file named India to Sitar, all 
currently open files that reference the file India are updated to reference the file 
as Sitar.

Audio files, peak, and marker files are also renamed accordingly.

The following files use audio file references:

• Audio montages
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• Basic Audio CDs

• DVD-Audio projects

Renaming a File

PROCEDURE

1. Select the file that you want to rename.

2. In any workspace, except the Control Window, select File > Rename.

3. Enter the new name and/or a new file location.

4. Select a file suffix from the drop-down list.

5. Click OK.

Rename File Dialog

In this dialog, you can choose a new file name, file extension, and folder location for 
the active file.

In any workspace, except the Control Window, select File > Rename.

Name

Type in the new name.

File extension drop-down list

Select a case for the file extension.

Change folder

If this option is activated, you can change the folder location of the file.

NOTE

This is only possible within the same drive partition.

Keep as default

If this option is activated, the same path is selected next time you open the 
dialog. This is useful if you need to move several files successively.



File Operations
Deleting Files

82

Deleting Files

You can delete the currently active file from within WaveLab.

PREREQUISITE 

The file that you want to delete is not copied to the clipboard, is not pasted into 
another file that is open, and is not open in another application.

PROCEDURE

1. Select the file that you want to delete.

2. In any workspace, except the Control Window, select File > Delete.

3. Click OK.

RESULT 

The file including its peak and marker files, is deleted.

Special Menu

From this menu you can select various file related options, for example, you can add 
the active file to a Master Project, Batch Processor, Data CD/DVD, or Podcast.

In any workspace, except the Control Window, select File > Special.

Depending on the workspace, not all options are available.

Information

Displays information about the active file.

Add to Master Project

Adds the active file to a Master Project.

Add to Batch Processor

Adds the active file to a Batch Processor.

Add to Data CD/DVD

Adds the active file and all the related files to a Data CD/DVD.

Add to Podcast

Adds the active file to a Podcast.

Reveal in Windows Explorer/Mac OS Finder

Opens the Windows Explorer/Mac OS Finder to show the location of the 
active file.

Copy to clipboard

Opens a menu, from which you can select which information about the active 
file you want to copy to the clipboard.
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Create a file link on the desktop (Windows only)

Creates a file link on the desktop. The link opens the file with the default 
application associated with the file type.

Temporary Files

Temporary files are used for certain operations, such as the undo/redo functions. 
You can specify where WaveLab saves its temporary files.

You can specify up to three different folders for storing temporary files. If you have 
access to more than one drive, saving your temporary files on separate physical 
drives (not partitions) can speed up performance considerably.

For example, if your source files are located on the C: drive, you could specify 
D:\temp and E:\temp as temporary folders. This improves the performance and 
reduces disc fragmentation.

RELATED LINKS

Specifying Folders on page 83

Work Folders vs. Document Folders

WaveLab distinguishes between two types of folders: work folders and document 
folders.

In work folders, temporary files are stored. Document folders contain 
WaveLab-specific files, such as wave files, audio montages, etc.

Specifying Folders

You can specify which folder should open when you perform any open or save 
operation (document folder). You can also specify up to three folders for temporary 
files (work folder).

PROCEDURE

1. Open the workspace for which you want to specify document folders.

2. Select Options > Folders.

3. Click the type of folder for which you want to specify a location.

4. Specify a location in the Folder field.

5. Optional: Depending on the selected type of folder, you can make additional 
settings.

6. Click OK.
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Folders Dialog

In this dialog, you can specify default document folders and work folders for each 
workspace.

In any workspace, select Options > Folders.

In the list to the left, you specify the folder type that you want to make settings for. 
The following options are available:

Folder for temporary files #1, #2, and #3

You can specify three folders for storing temporary files. If your system 
comprises multiple hard disks, specifying one folder for temporary files on 
each of these hard disks can speed up file operations.

Companion files

Specify a folder for storing the companion files, that is Master Section presets 
and view settings for audio files.

Cache folder

Activating Use cache folder for decoded files allows you to specify a cache 
folder. The cache folder contains wave files that are created when you are 
working with files in compressed file formats, such as MP3 files. To prevent 
the cache folder to grow indefinitely, WaveLab checks the date of each file in 
this folder and deletes files that were created before a certain number of days.

When Use cache folder for decoded files is deactivated, the compressed 
files are decoded each time they are opened.

Audio File - Open Folder/Save Folder

The default open and save folders for audio files.

Audio Montage - Open folder/Save folder

The default open and save folders for audio montage files.

Basic Audio CD - Open Folder/Save Folder

The default open and save folders for Basic Audio CD files.

Batch Processor - Open Folder/Save Folder

The default open and save folders for Batch Processor files.
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DVD-Audio Project - Open Folder/Save Folder

The default open and save folders for DVD-Audio Project files.

Master Project - Open Folder/Save Folder

The default open and save folders for Master Project files.

Podcast - Open Folder/Save Folder

The default open and save folders for Podcast files.

Script (Audio File/Audio Montage) - Open Folder/Save Folder

The default open and save folders for script files.

Depending on the selected item, different settings are available on the right side of 
the dialog:

Current Folder

In this field, the folder that is currently used as default is displayed. You can 
click the folder button to the right to navigate to a folder, or to create a new 
folder.

Keep last used

Uses the last folder for saving or opening files of the selected type.

Change when save-folder/open-folder changes

Updates the default open folder when you change the default save folder, and 
vice versa. Activate this option for both the save folder and the open folder for 
a specific file type to use the same folder for saving and for opening this type 
of file.

On opening the application, revert to this folder

Activate this option to restore a specific folder each time you open WaveLab. 
This way changes to save/open folders are only temporary and reset when 
you restart WaveLab.
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Uploading to SoundCloud

SoundCloud is an online platform for uploading and sharing your audio recordings. 
The Upload to SoundCloud option in WaveLab allows you to upload an audio file 
directly to your SoundCloud account.

If you do not have a SoundCloud account, visit www.soundcloud.com to register.

PROCEDURE

1. In the Audio Files workspace, select File > Export > Upload to 
SoundCloud.

2. Once you have logged in to your SoundCloud account, the file upload starts.

AFTER COMPLETING THIS TASK 

After uploading the audio file, you can edit the privacy settings and add meta-data.

Copying Audio Information to the Clipboard

You can copy information about the name and location of the selected audio file, 
including any selection information and cursor position. This information can be 
pasted into an external text application.

This is useful if you need accurate file path/selection information when writing a 
script, for example.

PROCEDURE

1. In the Audio Files workspace or the Audio Montage workspace, select Edit > 
Copy audio information.

2. In the Copy audio information dialog, activate the textual information that you 
want to copy to the clipboard.

3. Click OK.
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Setting the Focus on the Current File

If you are editing inside a floating window or a tool window and want to switch back 
the focus to a wave/montage window, you can use the Set focus on current file 
option.

PROCEDURE

• In any workspace, press [Win]/[Ctrl]-[ESC], to set the focus on the 
wave/montage window.
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About Workspaces

A workspace provides an editing and playback environment for a particular audio 
file type. Each type of workspace has functions for its specific file types.

In WaveLab, each file type has its own workspace designed for a specific purpose:

• Audio Files workspace for viewing and editing audio files.

• Audio Montage workspace for assembling and editing audio montages.

• Batch Processors workspace for processing a list of audio files with offline 
effects, VST plug-ins, and Master Section presets.

• Podcast workspace for preparing and uploading Podcasts.

• Control Window workspace for hosting and organizing tool windows, 
especially in a multi-monitor setup.

A workspace is highly customizable to match your workflow. A workspace can 
appear as a simple window with a single menu or as a sophisticated arrangement 
of command bars, tool windows, tab groups, and active meters.

When a file is opened from a given workspace, it is added to the active tab group 
of this workspace. If a file is opened from the Control Window, a new workspace is 
created for it.

You can have several instances of the same workspace open simultaneously. For 
example, you can have two Audio Files workspaces open with different layouts.

You can drag files between workspaces if their formats are compatible. For 
example, you can drag an audio file from the Audio Files workspace to the Audio 
Montage workspace by using its tab bar or its document button.

Elements of a Workspace

The center of the workspace is about the data that you want to edit, and all the 
menus, command bars, tool windows, controls, and tools to help you with that.

Each workspace contains the following elements:

• A menu bar. Each workspace has a different menu bar, but certain menus are 
common for all workspaces and each menu can be customized in various 
ways. The workspace menu has a submenu to show/hide the available 
Command bars and tool windows.

• One or more Command bars with buttons for instant access to functions. 
Command bars can be customized extensively.
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• Tab groups to host the files to edit. This is the central part of the workspace. 
You can move a tab to another workspace, create a new empty tab, display 
the file path, and access other functions by right-clicking.

• A set of Specific tool windows. Which tools are available depends on the 
workspace. They can be activated/deactivated individually.

• A set of Shared tool windows. The shared tools vary according to the 
workspace, and can be turned on or off individually. A shared tool window is 
a global window that is located in one workspace at a time.

Audio Files Workspace

This workspace provides tools and functions for sample-accurate audio editing, 
high-quality analysis, and processing. It is the environment commonly known as an 
audio editor.

Features include various metering tools, a signal generator, a compare function, and 
a tool for correcting errors.

The wave window gives you a graphical representation of the audio file and allows 
you to view, play back, and edit the file.

Audio Montage Workspace

In this workspace, you assemble audio clips into a montage. You can arrange, edit, 
and play back clips on an unlimited number of both stereo or mono tracks.

Features include track and clip-based effects, volume and pan automation, and 
wide-ranging fade and crossfade functions. You can use the Audio Montage 
workspace for creating music CDs, mastering, multimedia work, radio spot 
production, etc. You can create multitrack compositions and author professional 
audio CDs or DVD-Audio. Depending on the channel configuration of the montage, 
you can route each track to different surround channels (up to 6) or non-surround 
channels (up to 8).

You can place any number of clips, on an audio track. A clip contains a reference to 
a source audio file on your hard disk, as well as start and end positions in the file.

The montage window gives you a graphical representation of clips on tracks. In it 
you can view, play back, and edit the tracks and clips.
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Batch Processors Workspace

This workspace allows you to batch process any number of audio files or audio 
montage files using the plug-ins and presets of the Master Section, offline effects, 
and other plug-ins that are unique to batch processing.

You can save the processed file in a different file format, rename files, and run an 
external application when the batch is finished.

RELATED LINKS

Batch Processing on page 539

Podcast Workspace

In this workspace, you assemble, define, and publish your Podcast to the internet.

RELATED LINKS

Podcasts on page 602

Control Window

In this workspace, you can organize certain tool windows, for example, a selection 
of meters in a separate window.

This is useful if you have multiple monitors. You can place the Control Window on 
your secondary display and use it to manage the tool windows you use most.

Furthermore, the Control Window can contain the following windows:

• Meters

• Master Section

• Master Project

• Log window

• Background task monitor

• Import Audio CD
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• Data CD/DVD

Control Window Options

In the Control Window, select Options.

Show tab if only one window is open

If this option is activated, the tab is displayed, even if only one window is open.

Stay on top

If this option is activated, the Control Window stays on top of other windows.

Creating an Empty Workspace

When creating an empty workspace, no file is opened.

There are two ways of creating an empty workspace:

• In any workspace, select Workspace > New Workspace, and select the type 
of workspace that you want to create.

• On the Central switcher bar, click a workspace icon, and select Open 
empty workspace. The New Workspace dialog opens, where you can select 
what layout to use for the new workspace.
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New Workspace Dialog

In this dialog, you can select what layout you want to use when creating a new 
workspace.

In any workspace, select Workspace > New workspace and select which 
workspace you want to open.

As last closed workspace

This is the layout of the workspace of the same type that was closed last.

The default layout

This is the layout that you previously saved as default.

Factory preset: Empty layout

The workspace will be created without any docked tool windows. This preset 
is used by default if your screen is small.

Factory preset: Moderate

The workspace will be created with only the most important tool windows. 
This preset is used by default if your screen size is moderate.

Factory preset: Power-user

The workspace will be created with almost all possible docked tool windows. 
This preset is used by default if your screen size is large.

Factory preset: Ultimate

The workspace will be created with all possible docked tool windows. This 
preset is used by default if your screen configuration is made up of two large 
screens.
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Don’t show this dialog again

If this option is activated, WaveLab will select the layout automatically in the 
following order:

1) As the default layout if one has been saved from the Workspace menu.
2) As the last similar workspace that was closed during the present 

session.
3) A factory preset according to the screen configuration.

Opening Files in a Workspace

You can open files in the workspace that you are working in and in any other 
workspace, without having to switch workspaces first.

• To open a file in a workspace, select File > Open. From the file browser, 
select the workspace file that you want to open, and click Open.

• On the Central switcher bar, click a workspace icon, and select Open. From 
the file browser, select the file that you want to open, and click Open.

Organizing Workspace Windows

For working with several workspace windows, WaveLab offers functions to 
organize the windows.

• To lock a workspace layout, activate Workspace > Lock layout. This 
prevents you from moving or closing tool windows.

• To automatically move the shared tool windows to the newly activated 
workspace, every time you switch between workspaces, activate Workspace 
> Auto move shared tool windows.

• To activate full screen view, select Workspace > Full screen view.

• To specify the workspace position on the screen, select Workspace > 
Position on screen, and select an option.

• To bring all workspace windows to front, select Workspace > Bring all to 
front.

• To cascade all workspace windows, select Workspace > Cascade all.

• To switch between the previously selected workspace window and the active 
workspace window, select Workspace > Switch to previous workspace, or 
press [F5].

• To close the active workspace, select Workspace > Close.
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Saving a Workspace Layout

You can save a workspace layout and use it in other projects or other instances of 
WaveLab.

PREREQUISITE 

Set up your workspace layout.

PROCEDURE

1. Optional: If you want to use the current workspace layout as default, select 
Workspace > Layout > Save current layout as default.

NOTE

The default layout is the layout that is used when a new workspace window is 
created.

2. In any workspace, select Workspace > Layout > Save as.

3. In the Workspace layout dialog, enter a Name for the layout.

4. Optional: Decide whether you want to use the following options:
• To save the size and position of the workspace and its command bars and tool 

windows, activate Save placement of this workspace and its peripheral 
windows.

• To save the position and size of the tab groups within the workspace, activate 
Save layout of tab groups.

5. Click Save.

About Tool Windows

Throughout WaveLab there are various tool windows available that allow you to 
view, analyze, and edit the active file.

Generally, the content of a tool window is synchronized with the active file, with the 
exception of the audio meters which displays the audio file being played back. Tool 
windows can be docked and undocked, and saved in your custom layouts. There 
are two types of tool windows available:

• Specific tool windows

• Shared tool windows

The tool windows can be accessed via the Workspace menu.

Specific Tool Windows

Specific tool windows are windows that are specific to the current workspace. The 
following specific tool windows are available:
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Shared Tool Windows

The difference between specific and shared tool windows is that there can only be 
a single instance of a shared window in WaveLab. For example, a single Master 
Section, or a single level meter.

When you open a shared tool window in another workspace it undocks and moves 
from its original workspace, if this option is activated. An empty tab container with 
a title bar remains in its previous workspace. You can set the moving behavior by 
activating/deactivating Workspace > Auto move shared tool windows.

A shared tool window, if docked, can only appear in a single workspace at a time. 
To retrieve a shared tool window from another workspace, click the tool window. 
For example, if you have the Level Meter displayed in the Audio Montage workspace 
and you want to display it in the Audio Files workspace, click the icon in the Level 
Meter window of the Audio Files workspace.

If there are several workspaces of the same type, each workspace has its own 
independent tool window set.

The following shared tool windows are available:

Audio Files workspace Audio Montage 
workspace

Podcast workspace

Batch Processors workspace Control Window workspace
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Opening and Closing Tool Windows

You can close all tool windows you do not need for your project.

• To open or close a specific tool window, select Workspace > Specific tool 
windows, and select a tool window, or use the Specific Tool Windows 
command bar.

• To open or close a shared tool window, select Workspace > Shared tool 
windows, and select a tool window, or use the Shared Tool Windows 
command bar.

• To close a tool window, move the mouse on the left side or the top of the 
window, and on the toolbar that appears, click Close.

Tool Windows Command Bar

On the Specific Tool Windows and Shared Tool Windows command bars you 
can quickly switch tool windows on and off, without having to navigate through a 
menu.

• To open or close the Shared Tool Windows command bar, select 
Workspace > Command bars > Shared Tool Windows.

Shared Tool Windows command bar in the Audio Montage workspace

Audio Files workspace and Audio Montage workspace

Batch Processors workspace
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• To open or close the Specific Tool Windows command bar, select 
Workspace > Command bars > Specific Tool Windows.

Specific Tool Windows command bar in the Audio Montage workspace

Docking and Undocking Tool Windows

Tool windows can be used as docked windows or as floating windows. They can 
be freely dragged around and docked at various locations. Command bars can also 
be freely moved around and docked along the edges of most windows.

To dock/undock a tool window, use one of the following methods:

• Double-click the title bar, located on the left or the top of the tool window.

• Click the double window icon at the top left corner of the window.

• Drag the tool window title bar of a specific tool window. To dock the tool 
window, drag it by its title bar to another position.

To prevent an undocked tool window from docking, use one of the following 
methods:

• Hold down [Ctrl]/[Command] before dragging the tool window.

• Activate the Floating versus docking priority icon on the left or the top of 
the tool window.

Differences Between Windows and Mac OS

Floating windows behave slightly different on Windows and Mac OS.

• On Windows systems, a floating window is hidden when its dependent 
workspace is minimized or covered by another window. If WaveLab is not the 
active application, all its independent floating windows are hidden.

• On Mac OS X systems, a tool window is always on top of all other windows 
and a floating window remains visible even if its dependent workspace is not 
active or is minimized. If WaveLab is not the active application, all its floating 
windows are hidden.
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Playback

WaveLab offers numerous playback functions.

There are 4 playback modes available:

• Traditional playback, with playback starting from the cursor position and 
stopping anywhere when stopping playback.

• Play range, where playback starts from a given point and stops at another 
point of interest.

• Play from anchor, where playback starts from a specific point of interest.

• Play until anchor, where playback starts anywhere but stops at a given point 
of interest.

RELATED LINKS

Playback Shortcuts on page 109

Transport Bar

With this command bar you can control playback of an audio file or audio montage, 
navigate between various positions in an audio file or audio montage, and open the 
Recording dialog.

In the Audio Files workspace or the Audio Montage workspace, select Workspace 
> Command bars > Transport bar.

Transport bar in the Audio Files workspace

Transport bar in the Audio Montage workspace

Presets

Lets you save and apply transport bar presets.

Jog and Shuttle

Activates the Jog and Shuttle mode.

Speed settings

Opens a menu where you can specify the playback speed.
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Skip range

If this option is activated, playback skips the selected range and any region 
surrounded by exclusion markers.

On stop, move cursor back

If this option is activated, the edit cursor jumps back to the start position when 
playback stops. If you want to activate this option for the options Play from 
anchor, Play until anchor, and Play range, right-click this button, and 
activate On alternate playback stop, move cursor back to start.

Perform pre-roll

Activates pre-roll for the commands Play from anchor, Play until anchor, 
and Play range.

Right-click the button to select the pre-roll length and to specify to which 
commands you want to apply pre-roll to. To edit the pre-roll times, select Edit 
pre/post-roll.

Perform post-roll

Activates post-roll for the commands Play from anchor, Play until anchor, 
and Play range.

Right-click the button to select the post-roll length and to specify to which 
commands you want to apply post-roll to. To edit the post-roll times, select 
Edit pre/post-roll.

Auto selection

If this option is activated, the anchor and/or range are automatically selected 
according to the editing actions. Right-click to open a menu with related 
options and auto selection modes.

Ranges

Lets you select one of the following ranges:

• Selected time range

• Marked region where edit cursor is located

• Range of focused clip (audio montage only)

• Crossfade range (audio montage only)

• Fade-in range (audio montage only)

• Fade-out range (audio montage only)

Play range

Plays the selected range. Post-roll and Pre-roll settings are taken into 
account.

Anchors

Lets select which anchor to use as reference for the commands Play from 
anchor and Play until anchor. When there are multiple possibilities, for 
example, multiple markers, the last selected item is taken into account as a 
reference anchor or the closest marker near the edit cursor position if no 
marker is selected.

You can select one of the following anchors:
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• Start of file

• Start of selected time range

• End of selected time range

• Any marker

• Region start marker

• Region end marker

• Clip start (audio montage only)

• Clip end (audio montage only)

• Selected envelope point in focused clip (audio montage only)

When an anchor is detected, for example, a region marker pair, this is 
indicated by a green anchor marker.

Play from anchor

Plays from anchor. Pre-roll and post-roll settings are taken into account.

Play until anchor

Plays until anchor. Pre-roll and post-roll settings are taken into account.

Move cursor to previous/next anchor

Moves the edit cursor position to the previous/next anchor. To set the type of 
anchor, right-click the next anchor button and select an option from the menu. 
If you click during playback, playback continues from the anchor position.

Move playback position backwards/forwards

Moves the edit cursor position to the left/right. If you click during playback, 
playback jumps to the new edit cursor position.

To move the edit cursor to the start/end of the file, press [Ctrl]/[Command], 
and click the Move playback position backwards/forwards button.

Loop

Activates the loop mode. Right-click the loop button to select whether to 
loopforever or only a few times.

Stop

Stops the audio being played. If playback is already stopped, the edit cursor 
is moved to the previous start position.

Play

Starts playing the active audio file or audio montage from the edit cursor 
position.It can also be used to play back other sources, for example, the 
focused Basic Audio CD track or the focused clip in the Clips window.
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If the audio being played back is not the active audio file, the Play button has 
a different color. This happens if you switch to another workspace during 
playback, for example.

The playback button when playing back in the active window (left) and when 
playing in another window or workspace (right).

Record

Opens the Recording dialog.

Time display

Displays the edit cursor or playback position. Click to select another time unit.

Fold bar

Minimizes the transport bar. To unfold the transport bar again, click the thin 
line where the transport bar was located.

Settings

Opens layout menu of the transport bar and lets you edit shortcuts for the 
transport bar. You can also right-click the transport bar to open this menu.

Transport Bar in the Podcast Workspace and Batch Processors Workspace

In the Podcast workspace and Batch Processors workspace, a simplified transport 
bar allows you to play back the selected Podcast episode and selected batch 
process source files and destination files.

Play Button

Clicking the Play button on the transport bar starts playing back the active audio file 
or audio montage from the edit cursor position.It can also be used to play back other 
sources, for example, the focused Basic Audio CD track or the focused clip in the 
Clips window.

You can also use the Space bar or the Enter key on your keyboard to start playback. 
Pressing the Space bar during playback stops playback, while pressing Enter 
during playback makes playback restart from the last start position.

When loop is activated, the audio selection is looped, if available. Otherwise, the 
region defined by loop markers is looped, if available. If there are no selection 
ranges or loop markers, the entire file is looped.

The standard Play command is not influenced by the Play range, Play from anchor, 
and Play to anchor options.
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Stop Button

The result of clicking the Stop button or on the transport bar or [0] on your numeric 
keypad depends on the current situation.

• If you trigger Stop in stop mode, the edit cursor moves either to the previous 
Playback start marker, or to the selection start (whatever is closer), until the 
start of the file is reached.

• If there is no selection or if the edit cursor is positioned to the left of the 
selection, it is moved to the beginning of the file instead.

Playing Back Audio Ranges

You can play back audio ranges using the Ranges options on the transport bar.

PROCEDURE

1. On the transport bar, select the type of range that you want to play back.

2. Optional: Activate pre-roll and/or post-roll.

3. Position the edit cursor inside the range that you want to play back or make a 
selection range.
This selected range and, if activated, the pre-roll and post-roll times are displayed on 
the time ruler.

4. To play back the selected range, click the Play range button on the transport 
bar or press [F6].

RESULT 

The selected range is played back. Pre-roll and post-roll settings are taken into 
account. When the Loop mode is active, pre-roll is used before the first loop only, 
and post-roll is only used after the last loop.

Playing Back From an Anchor or Until an Anchor

You can play back audio from an anchor or until a specified anchor using the 
Anchor options on the transport bar.

PROCEDURE

1. On the transport bar, select an anchor type
If nothing is selected and you use the Play from anchor button, the edit cursor is the 
default anchor.
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2. Depending on the selected anchor type, position the edit cursor in the wave 
window or montage window inside the range that you want to play back.
For example, if you have selected Region start marker, click somewhere in the area 
of the region marker pair from which you want to play back from/to. The green anchor 
marker jumps to the selected anchor.

3. Optional: Activate pre-roll and/or post-roll.

4. To play back from the anchor marker, click the Play from anchor button on 
the transport bar or press [F7]. To play back until the anchor marker, click the 
Play until anchor button on the transport bar or press [F8].

RESULT 

Play back starts from the anchor/until the anchor. Pre-roll and post-roll settings are 
taken into account.

About the “Play From Anchor” and “Play Until Anchor” 
Functions

You can play back audio from an anchor or until an anchor using the Play from 
anchor or Play until anchor functions on the transport bar. These playback 
functions behave differently depending on the pre-roll and post-roll settings.

Play from anchor

• If post-roll is selected, playback starts at the anchor position and stops after 
the post-roll time. If no post-roll is selected, playback continues until the end 
of the audio file or audio montage.

• If pre-roll is selected, playback starts from the selected anchor, minus the 
pre-roll time.

• If pre-roll and post-roll are selected, playback starts from the selected anchor, 
minus the pre-roll time and stops after the anchor point plus the post roll time.

• If the loop mode is activated, the pre-roll and post-roll settings are taken into 
account. This way you can play a loop around the edit cursor position, without 
having to make further range settings.

Play until anchor

• Playback starts from the cursor, and stops at the selected anchor. If the cursor 
is beyond the selected anchor, playback starts at the selected anchor. If 
pre-roll is activated, it is taken into account.

• If pre-roll is selected, playback starts from the selected anchor minus the 
pre-roll time, until the selected anchor.

• If there is no selected anchor, Play until anchor is disabled.
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• The loop settings have no effect.

Using the Auto Selection Mode

You can use the auto selection mode in combination with the playback shortcuts to 
play back audio ranges or anchors, without needing to interact with the transport 
bar. This makes it easy to monitor your editing actions.

PROCEDURE

1. On the transport bar, activate Auto selection mode.

2. In the wave window or the montage window, do one of the following:
• Make a selection range.

• Click inside the area of a marker pair.

• Click a fade-in, fade-out, or crossfade.

• Click anywhere in the wave/montage window.

• Drag a marker.

Depending on your action, the most appropriate range, or anchor is selected. For 
example, if you click inside a marker pair, this region is selected as playback range.

The time ruler shows the selected range or anchor.

NOTE

In Auto selection mode, you can still change some range and anchor options 
in the transport bar to play a different range/anchor. However, the 
range/anchor will be reselected when you starting editing again with the 
mouse.

3. Use the playback shortcuts to start playback.
• To play back the selected audio range, press [F6].

• To play back from an anchor, press [F7].

• To play back until an anchor, press [F8].

You can also use the Play range, Play from anchor, and Play to anchor buttons on 
the transport bar.

RESULT 

The selection range is played back, or play back starts from the anchor/until the 
anchor. Pre-roll and post-roll settings are taken into account.

NOTE

A selection range has priority over any other range. To allow other ranges to be 
auto-selected, deselect the selection range.
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Using Auto Replay While Editing

You can have playback automatically re-triggered while editing audio with the 
mouse. This is useful if you want to monitor the adjustment of a selection boundary, 
for example.

PROCEDURE

1. On the transport bar, right-click the Auto selection mode icon, and activate 
Auto replay while editing.

2. In the wave window or the montage window, make a selection range and hold 
the mouse button pressed.

3. Start playback by using one of the following shortcuts:
• To play back the selected audio range, press [F6].

• To play back from an anchor, press [F7].

• To play back until an anchor, press [F8].

4. Drag the cursor to the right or left.
The selection range is adjusted and played back until you release the mouse button. 
When playback ends, the new selection range is played back.

Automated Selection Mode Settings

You can select whether the automated selection mode should select only ranges, 
only anchors, or both. To use the selected settings, activate Auto selection of 
anchor and range, based on editing actions.

To open the automated selection mode settings menu, right-click the Auto 
selection of anchor and range, based on editing actions icon on the transport 
bar, and make your selection.

Auto replay while editing

If this option is activated, playback is automatically restarted when you hold 
down the mouse button while editing ranges or anchors, and used the 
shortcuts to trigger playback. This is useful to find a loop, for example.

This option works even when the automated selection mode is deactivated.

Solo track when editing

If this option is activated, when holding down the mouse button when editing 
ranges or anchors in the montage window, the track is soloed when playing 
back via the shortcuts for Play range, Play from anchor, or Play until 
anchor. This option is only available in the Audio Montage workspace.
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This option works even when the automated selection mode is deactivated, 
because it is independent from this mode.

Auto select range and anchor

If this option is activated, ranges and anchors are automatically selected.

Auto select range

If this option is activated, ranges are automatically selected.

Auto select anchor

If this option is activated, anchors are automatically selected.

Skipping Sections During Playback

You can automatically skip a selected audio range during playback. This way, you 
can audition what the material would sound like with certain sections cut out.

PROCEDURE

1. On the transport bar, activate Skip range.

2. Activate Use Pre-Roll and Use Post-Roll.

3. If you want to use the Play range function, activate one of the Ranges modes.

4. Depending on the Ranges mode, do one of the following:
• If you have activated Selected audio range, make an audio selection in the 

wave window.

• If you have activated Marked region where edit cursor is located, click the 
section between a marker pair.

The audio range that will be skipped is displayed on the time ruler along with the 
pre-roll and post-roll times.

5. Select Play range, or press [F6].

RESULT 

The selected range is skipped during playback.

You can also use the factory preset for skipping selections during playback. 
Activate Skip range, make an audio selection, and press [Shift]-[F6].
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NOTE

This mode also works with the standard Play button, if there is a time selection or if 
exclusion start and end markers are set. In this case, the pre-roll and post-roll times 
are ignored.

About Loops

Loop points are updated continuously during playback. If you change the loop start 
or end during playback, the loop changes. This way you can audition selection 
points for rhythmic material.

If you loop a section in an audio montage, playback loops within the boundaries of 
the current selection range. This selection range may be on any track, even if empty. 
The vertical position of the selection range is of no relevance for loop playback, only 
the left and right selection boundaries matter.

Pre-Roll and Post-Roll

You can start playback slightly before a specific position (pre-roll) and stop 
playback slightly after another position (post-roll). This gives you a brief context if 
you are auditioning a clip, for example.

The position can be an anchor or the start or end of a range. The pre-roll and 
post-roll times are displayed in the time ruler.

To activate pre-roll and/or post-roll, activate the Use Post-Roll and Use Pre-Roll 
buttons on the transport bar.

When right-clicking the pre-roll or post-roll icon on the transport bar, you can select 
a pre-roll/post-roll time. Here, you can also select which play option you want to 
apply the pre-roll/post-roll to, and you can open the Edit Times dialog.
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Pre-Roll and Post-Roll Times Dialog

This dialog allows you to define a short, an average, and a long pre-roll and post-roll 
time. These settings are global to WaveLab.

In the wave window or the montage window, on the transport bar, right-click the 
pre-roll or post-roll icon, and select Edit pre/post-roll.

Playback Speed Dialog

This dialog allows you to specify the playback speed of the active audio file and all 
clips of the active audio montage.

On the Transport bar, click the Speed settings icon, and select Edit speed.

Presets

You can enter a name to save the settings as a preset and select them from 
the Playback Speed pop-up menu later.

Speed factor

Sets the playback speed as a percentage of the normal speed (100 %).

Time stretching

Compared to the speed coefficient, this is the inverse, a deceleration 
coefficient. This value is equivalent to the percentage found in the Time 
Stretching dialog.

Keep constant pitch (pure time stretching)

Indicates the time stretching.
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Quality

The Best and High quality modes provide the highest quality, but are also the 
most CPU intensive. In most cases, the Standard quality is sufficient.

Acceleration by skipping low level regions

If this option is activated, regions of the audio that are below the threshold 
level (level under which audio is skipped) are skipped during playback.

Level detection sensitivity

Determines the resolution of the level detection analysis, and thus its 
sensitivity.

Level under which audio is skipped

Determines the threshold level for a region to be considered low level.

Bypass effects and Master Section

If this option is activated, all active effects in the audio montage and all global 
effects in the Master Section are bypassed. This saves processing power and 
usually the plug-ins are not needed trying to locate audio material.

Bypass audio meters

If this option is activated, all meters are bypassed to save processing power.

NOTE

Changing the playback speed does not change the original audio, but only its 
playback speed in WaveLab.

Playback Shortcuts

In addition to the buttons on the transport bar, there are shortcuts to control the 
playback.

Space bar

Start/stop playback. This shortcut can be used even when the wave window 
or montage window is not the active window.

0 on numeric keypad

Stop. If the program is stopped and you trigger Stop again, the edit cursor 
moves either to the previous Playback start marker, or to the selection start 
(whatever is closer), until the start of the file is reached. This is the same as 
clicking the Stop button on the transport bar. This shortcut can be used even 
when the wave window or montage window is not the active window.

Enter

Starts playback. If pressed during playback, playback restarts from the 
previous start position. This is the same as clicking the Play button on the 
transport bar.
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[F6]

Starts playback of the selected range, depending on the selected option in 
the Ranges section of the transport bar.

[F7]

Starts playback from the selected anchor, depending on the selected option 
in the Anchors section of the transport bar.

[F8]

Starts playback until the selected anchor, depending on the selected option 
in the Anchors section of the transport bar.

Save Transport Bar Presets Dialog

In this dialog, you can save a transport bar setup as preset.

On the transport bar, click the preset icon, and select Save as.

Path name

Opens the root folder of the preset in the Windows Explorer/Mac OS Finder. 
Here, you can create subfolders for your presets.

Presets list

Lists all existing presets.

Name

Lets you specify a name for your preset.

Create shortcut for selecting the preset

If this option is activated and you click Save, the Shortcut Definitions dialog 
opens, where you can define a shortcut for this preset.
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If a preset already has an assigned shortcut, this option is grayed out. To 
change the existing shortcut, double-click the preset name in the presets list.

When preset is selected with shortcut

This lets you assign a customized playback command to a shortcut. For 
example, you can set a shortcut to play a range with a short pre-roll/post-roll, 
and another shortcut to play a range without a pre-roll/post-roll.

On stop, restore previous settings

If this option is activated, the settings are restored as they were before 
playback start. This is useful to trigger a special play task, and automatically 
switch back to the standard settings, as soon as playback is finished.

Transport Bar Settings

In the transport bar settings menu, you can customize the transport bar. This is 
useful to optimize the transport bar according to the available screen space.

To open the settings menu, right-click the transport bar, or click the Settings button 
on the transport bar.

Hide

Hides the transport bar. To make it visible again, select Workspace > 
Command bars > Transport bar.

Fold

Minimizes the transport bar. To unfold the transport bar again, click the thin 
line where the transport bar was located.

Top/Bottom

Aligns the transport bar at the top/bottom of the wave window or the montage 
window.

Large transport buttons/Small transport buttons

Determines the size of the transport bar buttons.

Align buttons left/Align buttons right/Center button

Moves the transport bar buttons to the corresponding position.

Show time display

Shows/hides the time display.

Show alternate play buttons

Shows/hides the alternate play buttons in the Ranges and Anchors section 
of the transport bar.
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Show all Range and Anchor buttons

Shows/hides the full range of Ranges and Anchors buttons. If this option is 
deactivated, only one range and one anchor button is visible. The other 
buttons can be accessed via shortcuts or when you right-click this button.

Show Preset button

Shows/hides the Presets button.

Show Skip button

Shows/hides the Skip mode button.

Show Speed button

Shows/hides the Speed settings button.

Show Jog and Shuttle button

Shows/hides the Jog and Shuttle button.

Edit shortcuts

Opens the Customize commands dialog, where you can edit the shortcuts 
for the transport bar commands.

Playing Back Only One Channel

You can choose to play only the left or the right channel of an audio file in the Audio 
Files workspace.

PROCEDURE

• In the Audio Files workspace, select Options, and activate/deactivate Play 
left channel and/or Play right channel.

Starting Playback From the Ruler

You can use the ruler to quickly jump to a position and start playback from there.

• Double-clicking the ruler starts playback from that position. Playback 
continues until you click Stop or until the end of the audio file or audio 
montage.

• To set the playback position to a certain position, click the ruler during 
playback. This also applies for clicking the time rulers of another audio file or 
audio montage, which allows you to quickly switch playback between audio 
files or audio montages.

• To start playback from a marker position, press [Ctrl]/[Command] and 
double-click a marker.
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Using the Play Tool

This tool allows you to play back from any position on one or both stereo channels.

PROCEDURE

1. In the Audio Files workspace, select the Play tool from the Edit tools 
command bar, or press and hold [Alt]/[Option].

2. In the wave window, click at the position where you want playback to start.
The cursor shape indicates whether the left (L), the right channel (R), or both channels 
are played back.

RESULT 

Playback continues for as long as you keep the mouse button pressed, or until the 
audio file ends. After playback has stopped, the cursor is moved to the playback 
start position.

Playback Scrubbing

Playback scrubbing helps you find a certain position in an audio file, by restarting 
playback repeatedly when you click and drag on the time ruler during playback or 
use the Play tool.

Scrubbing Using the Play Tool

PROCEDURE

1. In the Audio Files workspace, select the Play tool from the Edit tools 
command bar, or press and hold [Alt]/[Option].

2. Click in the wave window, or click and drag the time ruler.
If you click in the wave window, playback starts at the position where you clicked. If 
you click and drag in the time ruler, the audio is played back from the edit cursor 
position and a small section is looped once.
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Scrubbing Using the Time Ruler

PROCEDURE

1. Optional: In the Audio Files workspace, activate Options > Stop after 
playback scrubbing, to stop playback after scrubbing.
The edit cursor then jumps back to the start position.

2. Start playback.

3. Click the time ruler and hold the mouse button pressed, and drag left or right.

4. When you are done scrubbing, release the mouse button.

Playback Scrubbing Preferences

You can define the behavior of the Play tool in the Audio file editing preferences.

In the Audio Files workspace, select Options > Audio file editing preferences > 
Editing tab.

• If Restrict to Play Tool is activated, scrubbing is not available when you click 
and drag on the time ruler during playback.

• The Sensitivity setting determines the length of the audio loop that is played 
once when click and drang on the time ruler with the Play tool activated.

Timecode Window

This window can display the recorded time, the time offset in relation to various 
positions, and dynamic colors according to the context. During playback, the song 
position is displayed. If there is no playback, the edit cursor position is displayed.

In the Audio Files workspace, Audio Montage workspace, or Control Window, 
select Workspace > Shared tool windows > Timecode.
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View Menu

Edit colors

Opens the Timecode colors dialog, where you can edit the colors of the 
Timecode window.

Positive times

If this option is activated, positive values are displayed. If Negative times is 
also activated, the closest offset, negative or positive, is displayed.

Negative times

If this option is activated, negative values are displayed. If Positive times is 
also activated, the closest offset, negative or positive, is displayed.

Time ruler

Displays the position in relation to the origin of the time ruler. The time format 
is displayed according to the ruler.

Offset display

Lets you select from which position you want to display the offset. The 
following positions are available: edit cursor, selection start/end, marker, CD 
track start/end, clip start/end.

Recorded time

If this option is activated, when you start recording, the Timecode window 
displays the recorded time.

Recorded time (from last marker)

If this option is activated, when you start recording, the Timecode window 
displays the recorded time since the last dropped marker.

Jog/Shuttle Function

This function allows you to play back audio forwards or backwards, at any speed. 
This is useful for finding exact spots in the audio file and audio montage.

NOTE

The Jog and Shuttle functions are CPU intensive. If you experience stuttering 
playback, try reducing the window size.
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Using the Jog Function

This can be viewed as dragging the audio past a playback point, much like dragging 
a reel-to-reel tape past the playback head.

PROCEDURE

1. Zoom in the wave window or the montage window, so that you get a good 
visual feedback.

2. On the transport bar, activate Jog/Shuttle.
A vertical line appears in the middle of the wave/montage window. This is the 
playback point.

3. Click in the area above the time ruler and drag to the left or right, to play back 
the audio.
Dragging to the left of the line plays the audio forwards, dragging to the right plays 
the audio backwards.

Using the Shuttle Function

This can be viewed as playing back with a continuous control for tape speed and 
direction.

PROCEDURE

1. Zoom in the wave window or the montage window, so that you get a good 
visual feedback.

2. On the transport bar, activate Jog/Shuttle.
A vertical line appears in the middle of the wave/montage window. This is the 
playback point.

3. Click in the wave/montage window and drag to the left or right of the vertical 
line.
Clicking to the left of the line plays the audio backwards, clicking to the right plays the 
audio forwards.

The playback speed is determined by the distance from the line to the pointer. The 
further away from the line you move the pointer, the faster the playback.

4. Release the mouse button to stop playback.

5. Deactivate the Jog/Shuttle button on the transport bar by using any stop 
command.

Scroll During Playback

You can determine how the view should be scrolled in Play mode.

In the Audio Files workspace or the Audio Montage workspace, select View > 
Scroll during playback.
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The following options are available:

Immobile view

Disables scrolling.

View follows cursor

The view automatically changes to keep the playback cursor visible.

Scroll view (partial)

The view only scrolls when necessary to keep the playback cursor visible.

Scroll view (always)

Scrolls the view to keep the playback cursor centered.

NOTE

If you get dropouts during playback, do not use the scroll options.

About Playback in the Audio Montage Workspace

Playback in the Audio Montage workspace works the same way as in the Audio 
Files workspace. However, there are some things to note.

Mute and Solo Tracks

You can mute or solo tracks in an audio montage by using the corresponding 
buttons in the track control area.

• When a track is muted, the mute button is yellow.

• When atrack is soloed, the solo button is red.

• Solo can only be activated for one track at a time. However, you can unmute 
other tracks when Solo is active if you want to listen to a combination of 
tracks.

Muting Individual Clips

You can mute individual clips of a track.

PROCEDURE

1. In the Audio Montage workspace, open the Clips window.

2. Select the clips that you want to mute, and select Functions > 
Mute/Unmute selected clips, or check the box in the Mute column.
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Playing Back Individual Clips

You can play back an individual clip on a track. Overlapping clips or clips on other 
tracks are muted.

PROCEDURE

1. In the Audio Montage workspace, right-click the lower part of the clip that you 
want to play back.

2. On the menu, select one of the following play options:
• To play back the clip, select Play focused clip.

• To play back the clip with pre-roll, select Play focused clip with pre-roll.

Playing Back a Selection Range of a Track

You can select a section of a clip and play it back, while overlapping clips or clips 
on other tracks are muted.

PROCEDURE

1. In the Audio Montage workspace, make a selection range, either in a clip or in 
an empty section of a track.

2. Right-click the selection range, and select Play clip inside selection range.

Speaker Configuration

You can configure up to 8 speaker setups to switch to another audio speaker 
configuration with no latency. This allows you to compare the sound on different 
speaker setups.

After setting up the speaker configurations in the VST Audio Connections dialog, 
the configurations can be selected from the bottom of the Master Section.

The switching between different setups is done at the lowest level, right before 
sending the audio to the hardware, and without any plug-in processing.

A gain can be set individually for each configuration.

• The speaker gain is not taken into account by the meters. This means that the 
signal could clip even if the meters do not indicate clipping.

• The speaker gain has no effect on file rendering or CD writing.

• Since a gain affects samples, any dither settings are reset when changing the 
gain. This has an effect when monitoring quiet music passages.
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The speaker configuration #1 is active on startup and should be the default 
configuration, without a gain change.

The gain settings are saved with the active configuration. To save the gain settings 
of the speaker configurations as a preset, open the VST Audio Connections 
dialog, and save the speaker configurations as a preset.

RELATED LINKS

Speaker Configurations Pane on page 378
VST Audio Connections Dialog on page 12

Speaker Configuration LED Colors

Dark green

No gain is applied and dithering is preserved.

Red

Positive gain is applied, dithering is canceled, and there is a risk of clipping.

Orange

Negative gain is applied without the risk of clipping, but dithering is canceled.

Setting Up the Speaker Configuration

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > VST 
Audio Connections.

2. In the VST Audio Connections dialog, select an Audio Device.

3. Select the Playback tab, and select the speaker configuration that you want 
to edit.

4. Select and name the audio ports used for playback.

5. Select the Recording tab, and select the speaker configuration that you want 
to edit.

6. Select and name the audio ports used for recording and input monitoring.

NOTE

The input selection is not affected by the speaker configuration.

7. When you are done setting up the speaker configurations, click OK.
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Audio File Editing

Audio file editing refers to opening, editing, and saving audio files.

Wave Window

The wave window displays audio files graphically. Here, you view, play back, and 
edit individual audio files.

The wave window consists of two displays. You can use one display as an overview 
to navigate through the project and the other as the main view for editing.
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You can select different display modes for the two displays. For example, one 
display can show the waveform and the other the loudness.

You can synchronize the waveform displays so that they display the same part of 
the audio file, by clicking the Sync with other view button.

Display Modes

In the wave window, the upper and the lower displays can independently be set to 
one of three display modes.

• The Waveform tab displays the waveform of the audio file.

• The Spectrum tab displays the audio as a spectrogram.

• The Loudness tab displays the loudness graphs of the audio file.
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Waveform Tab

The Waveform tab displays the waveform of the audio file. The horizontal axis 
shows the time and the vertical axis the amplitude of the waveform.

Spectrum Tab

This allows you to view the level intensity of each area in the frequency spectrum. 
The Spectrum tab in conjunction with the Spectrum Editor is a unique editing and 
restoration tool.
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Spectrogram Options

In this dialog, you can define how the frequency spectrum is displayed.

In the Audio Files workspace, select the Spectrum tab, and click the Edit settings 
button.

Colors

Displays the frequency spectrum in colors.

Black & White

Displays the frequency spectrum in black and white. Frequencies with a high 
intensity are displayed in white, and frequencies with a low intensity in black.

White & Black

Displays the frequency spectrum in black and white. Frequencies with a high 
intensity are displayed in black, and frequencies with a low intensity in white.

Logarithmic frequency scale

If this option is activated, the frequency spectrum is displayed on a logarithmic 
scale instead of a linear scale, thus spacing the octaves equally. This models 
the perception of pitch of the human ear more closely. However, for audio 
restoration purposes the linear scale is more useful, because you typically 
want to edit higher frequencies which can be located more easily on a linear 
scale.

Display frequencies higher than

Any frequency below this level is not displayed in the spectrogram. Increasing 
this value allows you to focus the display on the more audible part of the 
spectrum.

Audio gain for analysis

Allows you to apply gain to the analyzed signal without changing the level of 
the original audio. This helps you find low-level artifacts.

Resolution

Sets the number of samples that are analyzed to create the spectrogram. If 
you specify a higher value, more frequencies are analyzed but they are located 
less accurately in the time domain.
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Loudness Tab

The curves on the Loudness tab represent the loudness over time in an audio file.

Because isolated peaks do not alter the perceived loudness of audio material very 
much, this display represents the loudness of an audio file more accurately than the 
waveform display.

This display mode also gives you an overview of the compression or dynamic range 
of a song. For example, the more peaks and valley expressions in the curve, the more 
dynamics in the audio material. An even curve with few peaks indicates that the 
material is compressed with a limited dynamic range.

RELATED LINKS

EBU Loudness Standard R-128 on page 43

Loudness Envelope Curves

The loudness envelope curves represent the average loudness of the signal in 
different areas of the frequency spectrum. These curves are shown in the Loudness 
display of the wave window.

The following loudness curves are available:

1) Momentary loudness (100 ms resolution)

2) Short-term loudness (1 sec resolution)
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3) Integrated loudness (loudness of the whole file)

4) Loudness range

5) True peak hints

The curves can be shown individually or in any combination. Which curves are 
displayed and what frequency area they represent is specified in the Loudness 
Display dialog.

NOTE

The resolution is 100 ms, which means the momentary loudness information is 
collected every 100 ms and the short-term loudness every second to match the 
EBU standard. This is the same for true peaks. A clipping indicator is displayed 
when a 400 ms audio region contains one or more over peaks.

Loudness Display Settings Dialog

In this dialog, you can specify how the loudness envelope waveform is displayed.

In the Audio Files workspace, select the Loudness tab, and click the Edit Settings 
button.

Momentary Loudness/Short-term Loudness

Color

Lets you edit the color of the associated element.

Curve thickness

Lets you customize the curve thickness. When Auto Thickness is selected, 
the curve thickness increases when zooming in.
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Show range

If this option is activated, the dynamic range is visualized. This displays the 
difference between the recent minimum and maximum loudness values. The 
wider the band, the wider the dynamics.

Range transparency

Lets you specify the transparency of the range section.

Range inertia

Determines the inertia of the loudness range, that is, how fast the range edges 
meet each other after a new minimum or maximum loudness is reported.

Integrated Loudness/Loudness Range/True Peaks

Color

Lets you edit the color of the associated element.

Curve thickness

Lets you customize the curve thickness. When Auto Thickness is selected, 
the curve thickness increases when zooming in.

Only show hot points (True Peaks section only)

If this option is activated, the curve is hidden and only the peak overloads are 
displayed as red bullets.

Axes

Upper/Reference/Lower

Lets you activate several axes, and edit their color and position in the loudness 
tab to get a visual reference.

Additional Color Settings

Background/Selected background

Lets you edit the color of the associated element.

Additional Options

Curve smoothing

If this option is activated, the transitions between the loudness measurements 
are smoothly drawn. This is less accurate when abrupt changes occur.

Apply to all open files

If this option is activated, the settings are applied to all open audio files, when 
clicking OK to close this dialog.
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Magnetic Bounds in Audio Files

Certain positions, such as markers or selection edges, can be defined as magnetic. 
Dragged elements can snap to these positions. This makes it easier to position 
items accurately.

For example, when you move a marker and it gets close to one of the magnetic 
bounds, the marker snaps to this position. A label is displayed, indicating the snap 
position.

Magnetic Bounds Menu

On this menu, you can specify which positions should be magnetic. When Snap to 
magnetic items is activated, items that you move snap to these positions.

In the Audio Files workspace, select Options > Magnetic bounds.

You can let items snap to the following positions:

Start/End of file

Moved elements snap to the start/end of the file when they are moved near 
these positions.

Time ruler marks

Moved elements snap to the time ruler grid when they are moved near these 
positions.

Markers

Moved elements snap to marker positions when they are moved near these 
positions.

Selection edges

Moved elements snap to the selection edges when they are moved near these 
positions.

Cursor

Sets the edit cursor magnetic when moved near this position.
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Zero Crossing

A zero crossing is a point where the waveform crosses the zero level axis.

If you cut out a portion of a wave and paste it in somewhere else, there often is 
discontinuity where the two waves are joined. This discontinuity results in a transient 
in the wave, which is perceived as a click or bump in the sound.

To avoid this, you must make the splice at a zero crossing, especially if you do not 
use crossfades.

If you activate Options > Snap selection to zero crossings, the selections that 
you make are always adjusted so that they start and end at the nearest zero 
crossing.

WaveLab can automatically search for zero crossings and extend the selection 
outwards so that it begins and ends at a zero crossing. This helps avoid clicks, 
pops, and bumps.

When you perform editing operations, such as cutting, pasting, or dragging, make 
sure that the material is inserted at a zero crossing.

Setting Up the Zero Crossing Detection

You can let selection edges automatically snap to the nearest zero crossing point 
when making a selection. In the Audio file editing preferences dialog, you can 
specify whether to allow snap at high zoom factors, and specify the scan range for 
the zero crossing detection.

PROCEDURE

1. In the Audio Files workspace, select Options > Snap selection to zero 
crossing.

2. Select Options > Audio file editing preferences.
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3. On the Editing tab, fill out the Snap selection to zero crossing options.

4. Click OK.

Moving the Cursor Position to the Closest Zero Crossing

You can automatically move the cursor position to the closest zero crossing.

PROCEDURE

1. In the Audio Files workspace, position the cursor in the waveform.

2. Select View > Move cursor to > Snap position.

File Handling in the Audio Files Workspace

About Mono/Stereo Handling

WaveLab is very flexible in its handling of stereo. All editing operations can be 
performed on either one channel or on both.

Supported File Formats

WaveLab can open and save audio files in a number of file formats.

The following table gives you some basic information about the formats:

Format Description

Wave (.wav) The following bit resolutions are supported: 8 bit, 16 bit, 20 bit, 
24 bit, and 32 bit (float).

Wave 64 (.w64) This file format is very similar to the Wave format but with one 
important difference; it allows you to record and/or edit files of 
virtually any length. Standard Wave files are limited to 2 GB 
(stereo files) in WaveLab.

NOTE: Wave 64 does not support meta-data. If you need large 
files and meta-data, use Wave with the RF64 option.

WavPack (.wv/.wvc) This file format allows digital audio to be losslessly 
compressed, including 32 bit float audio files.
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RF64 In the Audio file editing preferences, on the File tab, you can 
activate the RF64 file format support. If this is activated, the 
standard Wave file format switches automatically to the RF64 
file format as soon as the file size exceeds 2 GB, without any 
performance loss or interruption. This is useful when recording 
very long sessions. A RF64 file has the extension “.wav”, but it 
can only be opened with an application that supports the RF64 
standard if the file exceeds 2 GB.

AIFF (.aif, .aiff, .snd) Audio Interchange File Format, a standard defined by Apple 
Computers Inc. The following bit resolutions are supported: 
8 bit, 16 bit, 20 bit, and 24 bit.

MPEG-1 Layer 3 
(.mp3)

The most common audio compression format. The major 
advantage of MPEG compression is that the file size is 
significantly reduced, while there is little degradation of sound 
quality. WaveLab can both open and save files in this format.

NOTE: When you open an MPEG compressed file in WaveLab, 
the file is converted to a temporary wave file. On saving, the 
temporary wave file is converted back to MP3.

MPEG-1 Layer 2 
(.mp2, .mpa, .mpg, 
.mus)

MP2 (sometimes referred to as “Musicam files”) is a common 
file format in the broadcast industry. With regard to file sizes, 
the same applies for MP3 files.

Original Sound 
Quality (.osq)

This is the proprietary lossless compressed audio format of 
WaveLab. By saving files in this format, you can save 
considerable disk space without compromising audio quality.

Sound Designer II 
(.sd2)

This audio file format is used by Digidesign applications (such 
as Pro Tools). The following bit resolutions are supported: 8 bit, 
16 bit, and 24 bit.

U-LAW (.ulaw, .vox) This is an audio encoding and compression technique 
supported by Windows and Web phones, using 8 bit resolution. 
The U.S. telephone system uses U-law encoding for 
digitization.

A-LAW (.alaw, .vox) This is an audio encoding and compression technique for 
telephony, using 8-bit resolution. The EU telephone system 
uses A-law encoding for digitization.

Sun/Java (.snd, .au) This is an audio file format used on Sun and NeXT computers. 
The following bit resolutions are supported: 8 bit, 16 bit, and 
24 bit.

ADPCM – 
Microsoft/Dialogic 
(.vox)

This is a format commonly used for games and telephony 
applications. It offers a lower bit rate than linear PCM and thus 
requires less storage space/bandwidth.

Ogg Vorbis (.ogg) Ogg Vorbis is a compressed file format that is open, 
patent-free, and creates very small audio files maintaining 
comparatively high audio quality.

Format Description
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NOTE

The “$$$” file type is a temporary file format of WaveLab. In case you experience a 
computer crash, you may restore some of your work by opening any stray “$$$” 
files on your hard disk.

About 20-bit, 24-bit, and 32-bit Float Files

You do not need a 20-bit or 24-bit audio card to take advantage of the fact that 
WaveLab can handle 20-bit and 24-bit audio files. Any processing or editing 
performed on the files is always done at full resolution (32-bit float), even if your card 
does not support the full resolution.

For playback, WaveLab automatically adapts to the card that you have installed.

Text/Excel (.txt) This is a text representation of a waveform. By saving an audio 
file as a text file and then opening it in a spreadsheet 
application such as Excel, you can view it in textual, decimal 
form, and edit the sample values. When you open a text file 
representing a waveform in WaveLab, it is decoded and 
opened as an audio file. Note that these files are not 
compressed in any way, so they become get very large. Note 
that when using 32-bit float files, the .txt format is not 100 % 
lossless. This is because it is not possible to express a binary 
floating point value in textual decimal form without some 
precision loss.

Windows Media 
Audio (.wma, .asf)

Microsoft’s own compressed format. WaveLab lets you 
import/export audio in this format (Windows only). To 
import/export audio in WMA surround format, Windows Media 
Player 9 or later must be installed on your system.

Ensoniq Paris (.paf) Used by the Ensoniq Paris™ system. The following bit 
resolutions are supported: 16 bit and 24 bit.

Raw PCM files (.raw, 
.bin, .pcm, .$$$)

In this format, no information about bit resolution or sample rate 
is included. If you open a file in this format, WaveLab asks you 
to specify the bit resolution and sample rate. If this is not done 
correctly, the file will not play back as intended.

FLAC (.fla) Free Lossless Audio Codec (FLAC) is a codec which allows 
digital audio to be losslessly compressed.

AAC (.aac) Advanced Audio Coding (AAC) is a codec that allows lossy 
compression and encoding scheme for digital audio.

Format Description
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Creating a New Audio File

You can create an empty audio file, to assemble material from other audio files, for 
example.

PROCEDURE

1. In the Audio Files workspace, select File > New.

2. In the dialog, specify the audio properties, and click OK.

Saving an Audio File

PROCEDURE

1. In the Audio Files workspace, do one of the following:
• To save an audio file that has never been saved before, select File > Save as.

• To save an audio file that has been saved before, click the Save button, or 
select File > Save.

2. In the Save Audio File dialog, specify a file name and location.

3. Set up the available options:
• Keep this format for next time

• Save copy

• Open standard file selector before this dialog

4. Click Save.

Saving in Another Format

You can change the file format, sampling frequency, bit resolution, and stereo/mono 
status when saving.

PROCEDURE

1. In the Audio Files workspace, select File > Save as.

2. Specify the file name and location.

3. Click in the Output Format field.

4. In the Audio File Format dialog, set the file format and specify the properties.

5. Click OK.

6. Click Save.

RESULT 

A new file is created. The original file is not affected by the operation.
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Audio File Format Dialog

In this dialog, you can change various file settings when saving.

In the Audio Files workspace, select File > Save as, and click the Output Format 
field. This dialog can also be opened from various other locations in WaveLab.

Type

Select an audio file type. This affects the options available on the Audio 
format menu.

File extension

Select a file extension compatible with the current file type.

Audio format

Select an audio format compatible with the current file type.

Channels

Specify the number of audio channels for the files to be created. For 
multichannel audio montages, you can create multiple files.

Sample rate

Select a sample rate for the audio file. If you change this setting, a sample rate 
conversion takes place.

IMPORTANT

Use this only for simple conversions. For professional results, use the 
Resample plug-in and add limiting and dithering.

Bit resolution

Select a bit resolution for the audio file. This option is only available for certain 
file types.

IMPORTANT

Reducing the bit resolution is only advised for simple conversions. For 
professional results, it is recommended to add dithering in the Master 
Section.
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Meta-data

Lets you make meta-data settings that are saved with the file. This option is 
only available for certain file types.

The following options are available:

• When Do not save anything is selected, no meta-data are saved with 
the file.

• When Inherit from source file is selected, the meta-data of the source 
file are used. If this option is selected and the source meta-data is 
empty, the default meta-data will be used, if available. For example, this 
can be used to create Wave files with a Unique Material Identifier (BWF 
standard).

• When selecting Specific to this configuration, you can edit the 
meta-data, or replace it with a meta-data preset. To edit the meta-data, 
open the meta-data pop-up menu again, and select Edit.

Single file format/Multiple file format

Switches the view between the Audio File Format dialog and the Multi 
Audio File Format dialog.

About Changing the Format

When changing the sample rate, bit resolution, and number of channels of an audio 
file, several operations are performed.

• If you only want to change the bit resolution, you can do this directly in the Edit 
> Audio properties dialog instead, and then save the audio file.

• For high quality mastering purposes, it is not recommended to change the 
sample rate and number of channels using the Audio properties dialog, but 
instead use plug-ins and functions of the Master Section.

Property Action

Sample rate If a new sample rate is specified, a sample rate conversion is 
performed.

Bit resolution If a different bit resolution is specified, the file is either truncated 
down to 8 bits, or padded up to 24 bits. If you are converting to a 
lower bit resolution, you should consider adding dithering.

Mono/Stereo If the file is converted from mono to stereo, the same material is used 
in both channels. If the conversion is from stereo to mono, a mix of 
the two channels is created.
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• For the available compressed file formats (MP3, MP2, WMA, and Ogg 
Vorbis), you can specify various options, such as bit rate and compression 
method, and also enter text tags for the file.

Saving as OSQ File

OSQ (Original Sound Quality) is a lossless audio compression format, which can 
significantly reduce the audio file size without affecting the audio quality.

PROCEDURE

1. In the Audio Files workspace, select File > Save as.

2. Specify the file name and location.

3. Click in the Output Format field.

4. In the Audio File Format dialog, set the type to Original Sound Quality 
(OSQ) and specify the properties.

5. Click OK.

6. Click Save.

Saving a Selection as an Audio File

You can save a selection in the currently open audio file as a new audio file.

PROCEDURE

1. In the wave window, make a selection range.

2. Select File > Export > Selected time range.

3. Specify a file name, location, and output format.

4. Click Save.

Saving Left/Right Channel as Audio File

You can save each channel individually into a separate file. Use this option when 
you have been editing dual mono files, for example.

PROCEDURE

1. In the Audio Files workspace, select File > Export > Left channel or Right 
channel.

2. Specify a file name, location, and output format.

3. Click Save.
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Encoding Audio Files

Audio can be stored in different formats. The process of converting audio to another 
format is called encoding. When saving audio files, you can specify various 
encoding options for some file formats.

MP3 Encoding Dialog

You can edit the encoding options when you save an MP3 audio file.

You can open the MP3 encoding dialog from most places where you can select an 
output file format. For example, in the Audio Files workspace, select File > Save as, 
click the Output Format field, select MPEG-1 Layer 3 (MP3) as type, click the 
Encoding field, and select Edit.

Encoder

Lets you select the encoder (Fraunhofer or Lame).

Constant/Variable Bit Rate

The bit rate is related to the quantity of data used to encode the audio signal. 
The higher the value, the better the quality, but the larger the output file. If you 
choose Variable Bit rate, the rate changes, according to the complexity of the 
audio material.
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Highest quality (slowest)/Fastest

Select the quality that you want to achieve. The higher the quality, the more 
resources and time are required to analyze and compress the audio signal.

NOTE

When selecting Highest quality (slowest), this can enforce a certain sample 
rate for the audio file. If this is the case and the sample rate is different from 
the input sample rate, a message is displayed.

When using the Lame encoder, additional settings can be made on the 
Advanced tab.

Allow intensity stereo coding

Decreases the bit rate by reorganizing the intensity information between the 
channels.

Specify as Original Recording

Marks the encoded file as the original recording.

Write private bit

This is a custom flag.

Write copyright flag

Marks the encoded file as copyright protected.

Write check-sum

Allows other applications to check the integrity of the file.

Create long frames

Saves space by writing fewer headers in the file (not compatible with all 
decoders).
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AAC Encoding Dialog

You can edit the encoding options when you save an AAC audio file.

You can open the AAC encoding dialog from most places where you can select an 
output file format. For example, in the Audio Files workspace, select File > Save as, 
click the Output Format field, select AAC (Advanced Audio Coding) as type, click 
the Encoding field, and select Edit.

Container

Lets you select the container for the AAC file. A container is a file format that 
can contain compressed audio data and meta-data.The following containers 
are available:

• MPEG-4 (recommended format for iTunes)

• 3GPP (3rd Generation Partnership Project)

• ADIF (Audio Data Interchange Format)

• ADTS (Audio Data Transport Stream)

• ADTS (with CRC)

• LATM LOAS (Low Overhead Audio Stream)

Audio compression method

Lets you select the audio compression method. The following methods are 
available:

• LC (Low Complexity, iTunes standard)

• LC (Low Complexity, with Error Resilience)

• HE (High Efficiency)

• HE v2 (High Efficiency, Parametric Stereo)

• HD 16 bit (Lossless)

• HD 24 bit (Lossless)

LC (Low Complexity) does not mean lower quality, but less compression 
attempts. It is used for best audio quality.
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HE (High Efficiency) is an extension of Low Complexity AAC (AAC LC) and 
is optimized for low-bit-rate applications, for example, streaming audio.

HE v2 enhances the compression efficiency of stereo signals. The HE formats 
provide extremely compressed audio files with a high quality sound.

HD is an extension to the MPEG-4 standard and allows lossless audio 
compression that is scalable to lossy compression. This means that the 
decoding can be lossless or lossy, depending on the decoder settings. 
However, the file size is larger than with the other compression methods.

Constant/Variable bit rate

The bit rate is related to the quantity of data that is used to encode the audio 
signal. The higher the value, the better the quality, but the larger the output 
file. If you choose Variable bit rate, the rate changes over time according to 
the complexity of the audio material.

Quality

Select the quality that you want to achieve. The higher the quality, the more 
resources and time are required to analyze and compress the audio signal.

NOTE

Highest quality can require a particular sample rate for the audio file.

MPEG-1 Layer 2 Encoding Dialog

You can edit the encoding options when you save an MPEG-1 Layer 2 (MP2) audio 
file.

You can open the MPEG-1 Layer 2 encoding dialog from most places where you 
can select an output file format. For example, in the Audio Files workspace, select 
File > Save as, click the Output Format field, select MPEG-1 Layer 2 as type, 
click the Encoding field, and select Edit.

Bit rate

Lets you select the bit rate. The bit rate is related to the quantity of data used 
to encode the audio signal. The higher the value, the better the quality, but the 
larger the output file.
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Stereo encoding - Standard

In this mode, the encoder does not use the correlation between channels. 
However, the encoder can take space from a channel that is easy to encode 
and use it for a complicated channel.

Stereo encoding - Joint

In this mode, the encoder uses existing correlations between the two 
channels to increase the ratio quality/space.

Stereo encoding - Dual

In this mode, both channels are independently encoded. This mode is 
recommended for signals with independent channels.

Specify as Original Recording

Marks the encoded file as the original recording.

Write private bit

This is a custom flag.

Write copyright flag

Marks the encoded file as copyright protected.

Write check-sum

Allows other applications to check the integrity of the file.

Encode peaks (ancillary data)

This must be activated for compatibility with certain system, for example, 
DIGAS.

FLAC Encoding Dialog

You can edit the encoding options when you save a FLAC audio file.

You can open the FLAC Encoding dialog from most places where you can select 
an output file format. For example, in the Audio Files workspace, select File > Save 
as, click the Output Format field, select FLAC as type, click the Encoding field, 
and select Edit.

Compression level

Lets you specify the compression level. The more compression, the slower the 
encoding.
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Ogg Vorbis Dialog

You can edit the encoding options when you save an Ogg Vorbis audio file.

You can open the Ogg Vorbis dialog from most places where you can select an 
output file format. For example, in the Audio Files workspace, select File > Save as, 
click the Output Format field, select Ogg Vorbis as type, click the Encoding field, 
and select Edit.

Average bit rate

If this option is activated, the average bit rate in the file remains constant 
during encoding. Because the file size is proportional to time, the localization 
of a given point is easier, but it can result in a lower quality compared to the 
Variable bit rate option.

Variable bit rate

If this option is activated, the bit rate in the file will vary during encoding, 
depending on the complexity of the material. This can give a better quality/size 
ratio in the resulting file.

In the Quality field, select the quality. Lower quality settings result in smaller 
files.

Windows Media Audio Encoding Dialog

You can edit the encoding options when you save a Windows Media Audio (WMA) 
audio file. This dialog is only available in on Windows systems.

You can open the Windows Media Audio dialog from most places where you can 
select an output file format. For example, in the Audio Files workspace, select File 
> Save as, click the Output Format field, select Windows Media Audio (WMA) as 
type, click the Encoding field, and select Edit.
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Encoder

Lets you select the encoder.

Output sample rate

Lets you specify the output sample rate of the encoded file. The higher the 
sample rate, the higher the quality, but the larger the output file.

Output bit resolution

Lets you specify the output bit resolution of the encoded file. This parameter 
is not available for all encoders.

Channels and bit rate

The available items here depend on the selected encoding method and the 
output sample rate.

VBR (Variable bit rate)

If this option is activated, the bit rate in the file will vary during the encoding, 
depending on the complexity of the material. This can produce a better 
quality/size ratio in the output file.

In the Quality field, select the quality. Lower quality settings result in smaller 
files.

Two-pass encoding (better, but twice as long)

If this option is activated, the encoding quality increases, but the process 
takes twice as long.

Constrained bit rate

This option is available when the VBR and Two-pass encoding options are 
activated. This is used to maintain the bit rate within limits to avoid peaks. This 
is recommended for certain media, such as CD or DVD.

Creating an Audio Montage from an Audio File

You can export audio files to an audio montage, including all markers that you have 
set in the audio file.

PROCEDURE

1. Optional: If you only want to use a certain time range of the audio file, create 
a selection range in the wave window.

2. In the Audio Files workspace, select File > Export > Create audio montage 
from active file.

3. Select whether to export the whole file or the selected time range.
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4. Optional: Decide if you want to perform any of the following marker 
operations:
• Import markers
• Split at generic region markers
• Split at CD Track markers

5. Click OK.

Inserting Audio Files into Another Audio File

You can assemble an audio file from several audio files.

PROCEDURE

1. In the Audio Files workspace, open the audio file in which you want to insert 
another audio file.

2. If you want to insert an audio file at the edit cursor position, select View > 
Move cursor to > Snap position.
The edit cursor snaps to the nearest zero crossing. This avoids glitches.

3. Select File > Import and choose one of the following options:
• Insert audio file at start
• Insert audio file at end
• Insert audio file at cursor position

When you select Insert audio file at cursor position, the audio file is cut at the insert 
position. The part after the cut is moved to the right.

4. Select the audio file that you want to insert, and click Open.

Turning Selections Into New Files

You can turn selections into new files via dragging, or by using the Edit menu.

Turning Selections Into New Files By Dragging

PROCEDURE

1. In the Audio Files workspace, make a selection in the wave window.

2. Drag the selection to the WaveLab tab bar, and release the mouse button.

RESULT 

The selection appears in a new stereo window.
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Turning Selections Into New Files Using the Menu

PROCEDURE

1. In the Audio Files workspace, make a selection in the wave window.

2. Select Edit > Copy selection to new window > As is.

RESULT 

The selection appears in a new stereo window.

Special File Format Dialog

When opening files via the Unknown audio file option, you can specify how to 
interpret the format of the audio file that you want to open.

In the Audio Files workspace, select File > Import > Unknown audio file.

Sample format

Specifies the binary representation of the samples in the file.

Byte order

Specifies the order in which bytes should be interpreted. This only applies for 
16 bit or more.

Channels

Specifies the number of audio channels in the audio file.

Data to ignore (number of bytes)

Specifies how many bytes WaveLab should ignore at the start and end of the 
audio file.
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Sample rate

Specifies the sample rate of the audio file.

File extension

Specifies the default file name extension for the audio file. When the file 
selector opens after closing this dialog, only the file with this extension is 
displayed.

Dual-Mono Files

Dual-mono files are two mono files that are the left and right channels of a stereo 
recording. You can open several dual-mono files at the same time and have them 
grouped automatically, provided the files have channel tags in their file name.

You can open dual-mono files like stereo files in the Audio Files workspace, the 
Audio Montage workspace, and the Batch Processors workspace.

In the Audio file editing preferences, on the File tab, you can set the channel ID 
for the left and right channel, and the channel ID to add to dual-mono files when 
saving the files. Up to 7 name descriptors can be defined, each one can be of the 
type Suffix or Advanced.

In the Advanced mode, the channel ID can be located anywhere in a file name. For 
this purpose, a name pattern must be defined. This name pattern must have a 
{capture} section.

Name matching is not case sensitive and the file extension is ignored.

By default, WaveLab recognizes the file name endings “.L/.R”, “-L/-R”, or “_L/_R” 
as the left and right channels.

Allowing Opening of Dual Mono Files

NOTE

To avoid accidentally opening two separate mono files as a dual-mono file, you 
should only activate Allow opening of dual-mono files for the time that you are 
opening dual-mono files on purpose.

PROCEDURE

1. In the Audio Files workspace, select Options > Audio file editing 
preferences.

2. Open the File tab, and activate Allow opening of dual-mono files.
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3. If you want to open several dual-mono files at the same time, define the 
naming scheme of the dual-mono files in the Dual-mono file identification 
section.

4. Click OK.

RELATED LINKS

Audio File Editing Preferences Dialog on page 675

Opening Dual-Mono Files in the Audio Files Workspace

PREREQUISITE 

Activate Allow opening of dual-mono files, and place the dual-mono files in the 
same folder.

PROCEDURE

1. In the Audio Files workspace, select File > Open.

2. Browse to the file location.

3. Select the dual-mono files that you want to open, and click Open.

Opening Dual Mono Files in the Audio Montage Workspace

PREREQUISITE 

Activate Allow opening of dual-mono files, and place the dual-mono files in the 
same folder.

PROCEDURE

1. In the Audio Montage workspace, select File > Import > Insert audio files.

2. Browse to the file location.

3. Select the dual-mono files that you want to open, and click Open.

4. In the Insert Audio Files dialog, make your settings.

5. Click OK.
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Opening Dual-Mono Files in the Batch Processors Workspace

PROCEDURE

1. In the Audio file editing preferences dialog, activate Allow opening of 
dual-mono files, and place the dual-mono files in the same folder.

2. In the Batch Processors workspace, drag the dual-mono files from the File 
Browser window to the Files to process list, or right-click the list, and select 
Insert audio files.

Dual-mono files are displayed in purple in the list.

Converting From Stereo to Mono and From Mono to Stereo

You can convert audio files from mono to stereo and from stereo to mono. 
Converting a mono file into a stereo file produces an audio file that contains the 
same material in both channels, for example for further processing into real stereo.

Converting a Selection From Stereo to Mono Using the Menu

PROCEDURE

1. In the Audio Files workspace, make a stereo selection in the wave window.

2. Select one of the following options:
• To mix the left and right stereo channels when converting to mono, select Edit 

> Copy selection to new window > Convert to Mono (Mix).
• To mix the left channel with the inverse of the right channel when converting to 

mono, select Edit > Copy selection to new window > Convert to Mono 
(Subtract right channel from left channel). The resulting mono wave 
contains the difference between the channels. For example, this allows you to 
verify that a wave file really is a true stereo file rather than a mono file converted 
to stereo format.

RESULT 

The selection appears in a new stereo window.

Converting From Stereo to Mono While Saving

PROCEDURE

1. In the Audio Files workspace, select File > Save as.

2. Click in the Output Format field.
The Audio File Format dialog opens.
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3. From the Channels menu, select one of the mono settings.
For example, when selecting Mono (Mix -3 dB), the resulting audio file is attenuated 
by 3 dB. Because mixing two channels into mono can introduce clipping. These two 
settings can be used to remedy this.

4. Click OK.

5. Click Save.

Converting a Selection From Mono to Stereo

PROCEDURE

1. In the Audio Files workspace, make a mono selection in the wave window.

2. Select Edit > Copy selection to new window > Convert to Stereo.

RESULT 

The selection appears in a new stereo window.

Swapping Channels in a Stereo File

You can move the audio in the left channel to the right channel, and vice versa.

• To swap the channels of the whole audio file in the Audio Files workspace, 
select Edit > Swap stereo channels.

• To swap only a selected range of the audio file, make a selection range in the 
wave window, and select Edit > Swap stereo channels.

Special Paste Operations

On the Paste special menu, you find additional paste options.

In the Audio Files workspace, select Edit > Paste special.

Overwrite

Overwrites data in the destination file, rather than moving data to make room 
for the inserted audio. How much is overwritten depends on the selection in 
the destination file:

• If there is no selection in the destination file, a section with the same 
length as the pasted selection is overwritten.

• If there is a selection in the destination file, the pasted selection 
replaces that selection.

Append

Adds the pasted audio after the end of the file.
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Prepend

Adds the pasted audio before the beginning of the file.

Multiple copies

Opens a dialog in which you can enter the number of copies that you want to 
create.

Mix

Blends two files into each other, starting at the selection or, if there is no 
selection, at the cursor position.

• When you select the Mix option, a dialog opens, allowing you to specify 
the gain for the audio on the clipboard and at the destination.

• All the data on the clipboard is always mixed in, regardless of the length 
of the selection.

Moving Audio

You can rearrange the order of audio in a file by dragging, and cutting and pasting.

Moving Audio by Dragging

PREREQUISITE 

Decide whether you want to use Snap selection to zero-crossing.

PROCEDURE

1. In the wave window, make a selection.

2. Drag the selection to a position outside the selection in the same file, or to 
another wave window.

3. Hold [Shift]/[Command] and release the mouse button.

Moving Audio Using Cut and Paste

PREREQUISITE 

Decide whether you want to use Snap selection to zero-crossing.

PROCEDURE

1. In the wave window, make a selection.

2. Use one of the following copy methods:
• Select Edit > Cut.
• Press [Ctrl]/[Command]-[X].

• Drag the selection onto the Cut icon.



Audio File Editing
File Handling in the Audio Files Workspace

150

3. Select how you want to insert the selection:
• If you want to insert the audio, click once at the position in the same file or in 

another file.

• If you want to replace a section of audio, select it.

4. Select Edit > Paste or press [Ctrl]/[Command]-[V].

RESULT 

The selection is removed from its original position and inserted where you drop it.

NOTE

To completely undo a move between two files you must first undo the paste in the 
destination window and then undo the cut in the source window.

Moving Audio by Nudging

The Nudge left/right tools can be used to move the audio in small steps within a file.

PROCEDURE

1. In the wave window, make a selection.

2. Depending on whether you want to nudge the selection to the left or to the 
right, select one of the following tools:
• Select Edit > Tools > Nudge left, or click the Nudge left icon on the toolbar.

• Select Edit > Tools > Nudge right, or click the Nudge right icon on the 
toolbar.

3. Click the selection.
Pressing [Shift] switches nudge left to nudge right and vice versa.

4. To exit the nudge tool mode, click anywhere outside of the selection.

RESULT 

The audio is moved one pixel. Exactly how much this is depends on how far you are 
zoomed in. For example, if the status bar displays x1:256, the selection is moved 
256 samples. The moved section overwrites the audio at that position.

Copying Audio

You can copy sections of audio within the same file or between audio files.

Stereo/Mono Handling

Stereo/mono is handled as follows when you drag between files:
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Stereo/mono is handled as follows when you copy and paste files:

Sample Rate Conflicts

If you copy or move audio from one window to another, and the sample rates of the 
two files are not the same, the copied/moved sound plays back at the wrong pitch 
(speed). The program warns you if this is about to happen.

While mixing sample rates can be used as an effect, it is most often not intended. 
There are two ways to get around this:

• Convert the sample rate of the source file to the same rate as the destination 
file before editing.

• Convert the sample rate of the destination file to the same rate as the source 
file before adding the audio.

Dragged section Drop wave Action

Stereo Stereo The dragged audio is always inserted into 
both channels.

Stereo Mono Only the left channel is inserted.

Mono Stereo What happens depends on the vertical drop 
position. This is indicated by the cursor shape. 
The selection can be inserted into only one of 
the channels, or the same material can be 
inserted into both channels.

Copied section Paste wave Action

Stereo Stereo If the wave cursor extends across both 
channels of the destination file, the material is 
inserted into both channels.

Stereo Stereo If the wave cursor is only in one channel, the 
audio is only pasted in that channel. Material 
from the left channel is pasted in the left 
channel and vice versa.

Stereo Mono Only the left channel is pasted.

Mono Stereo What happens depends on whether the wave 
cursor is in one channel or both. The audio is 
either pasted in one of the channels, or the 
same material is inserted into both channels.
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Copying Audio Using Copy and Paste

PREREQUISITE 

Decide whether you want to use Snap selection to zero-crossing.

PROCEDURE

1. In the Audio Files workspace, make a selection.

2. Use one of the following copy methods:
• Select Edit > Copy.

• Press [Ctrl]/[Command]-[C].

• Drag the selection onto the Copy icon.

3. Select how you want to insert the selection:
• If you want to insert the audio, click once at the position in the same file or in 

another file.

• If you want to replace a section of audio, select it.

4. Select Edit > Paste, or press [Ctrl]/[Command]-[V].

Copying Audio by Dragging

PREREQUISITE 

Decide whether you want to use Snap selection to zero-crossing.

PROCEDURE

1. In the Audio Files workspace, make a selection.

2. Click the middle of the selection, and drag it to a position outside the selection 
in the same file, or to another wave window.

3. Release the mouse button.

RESULT 

The selection is inserted at the indicated point. The audio that previously began at 
that point is moved to the right.

Information About the Active Audio File

You can open a dialog that shows the name, file location, size, date, and file format 
of the active audio file.

PROCEDURE

• In the Audio Files workspace, select File > Special > Information.
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Changing the Audio Properties

You can change the declared sample rate and sample accuracy of audio files.

Changing these values does not process the audio file in any way (in contrast to 
using Save as). However, the following rules apply:

• If you change the sample rate, the file plays back at a new pitch.

• If you change the bit resolution, the file is converted to the new resolution the 
next time you save it.

NOTE

There is no undo for this. If you save with a lower bit resolution, the file is converted 
permanently.

PROCEDURE

1. In the Audio Files workspace, open an audio file.

2. Select Edit > Audio properties.

3. Specify a new Sample rate and/or Accuracy.

4. Click OK.

Audio Properties Dialog

This dialog reports the audio properties of the active audio file. It allows you to 
change the number of audio samples per second (sample rate) and the accuracy of 
samples in the audio stream (bit rate).

In the Audio Files workspace, select Edit > Audio properties.

Channels

The number of audio channels (mono/stereo).

Sample rate

The number of audio samples per second.

Accuracy

The accuracy of samples in the audio stream.
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Meta-Data

Meta-data consists of attributes that describe the audio contents, for example, the 
title of the track, the author, and the date the track was recorded. Depending on the 
file format of the selected audio file, this data varies.

When opening an audio file, audio montage, or batch process, the meta-data found 
in the file is loaded. You can also create different meta-data presets for audio files, 
audio montages, and batch processes. When creating a new file from a template, 
this file can inherit the meta-data of the preset, if available.

A preview of the meta-data is displayed in the Meta-data window. To view the 
complete meta-data of the file and edit the meta-data, select Edit > Meta-data, or 
click the Edit button in the Meta-data window.

Not all file formats can store meta-data. Depending on the output file format, all 
meta-data or only part of the meta-data will be stored in the audio file. The following 
file formats can contain meta-data:

• .wav

• .mp3

• .ogg

• .wma

• .flac

• .aac

For MP3, the following meta-data types are available:

• ID3 v1 and ID3 v2, including picture support, and ReplayGain standard

AAC is used for MPEG4 (iTunes compatible) and 3GPP containers.

NOTE

• AAC is not ID3v2 is compatible. However, in WaveLab it uses the same 
editor.

• The meta-data codes that are followed by an “(i)” indicate the iTunes 
compatible fields. Lyrics and pictures are also iTunes compatible.

For WAV, the following meta-data types are available:

• RIFF

• BWF version 2 (EBU R-128 loudness support)

• BWF support for USID and UMID standards (Unique Source Identifier and 
Unique Material Identifier)
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• iXML (with EBU R-128 loudness support)

• aXML (BWF standard to attach XML data)

• CART (AES standard, dedicated to broadcast needs)

• MD5 (Extra tab)

• ID3 v2, including picture support

When saving or recording an audio file in the Audio File Format dialog, you can 
specify whether not to use any meta-data, inherit the meta-data from the source file, 
or edit the meta-data of the file.

Meta-data can be entered manually or generated automatically.

The following options can be generated automatically:

• Unique Source Identifier (BWF, Basics tab)

• UMID (BWF, Unique Material Identifier (UMID) tab)

• Loudness and true peak values* (BWF, Loudness tab)

• Insert BWF data (iXML)

• Time markers (CART)

• MD5 checksum* (Extra)

• ReplayGain information* (ID3, ID3 v2 tab)

• USID (BWF, Basics tab)

(*) These options cause a file analysis while the file is written, which means that the 
file writing process can take longer.

WaveLab includes several meta-data presets. They are used as examples and can 
be customized for your needs. You can load meta-data presets from the Meta-data 
presets pop-up menu in the Audio File Format dialog, or from the Meta-data 
dialog.

RELATED LINKS

Audio File Format Dialog on page 133
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Meta-Data Dialog

This dialog allows you to define the meta-data to be embedded in your audio file.

In the Audio Files workspace, the Audio Montage workspace, or the Batch 
Processors workspace, select Edit > Meta-data. Depending on the workspace, 
the meta-data is handled differently.

Meta-data dialog for a WAV file

Meta-data dialog for a WMA file

When opening the Meta-data dialog in the Audio Files workspace, you can edit the 
meta-data that is stored in the audio file. This meta-data is saved to disk later.

When opening the Meta-data dialog in the Audio Montage workspace or the Batch 
Processors workspace, you can edit the meta-data for the WAV, MP3, and AAC 
audio files when rendering the audio montage or processing through the batch 
processor. If you render to WAV, MP3, or AAC formats, the meta-data will be be 
associated to these files.
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NOTE

The meta-data codes that are followed by an “(i)” indicate the iTunes compatible 
fields. Lyrics and pictures are also iTunes compatible.

Meta-Data Presets

In the Meta-data dialog, you can save meta-data presets and apply these presets 
to other files. Meta-data presets can be applied to WAV, MP3, and AAC files.

The Use as default for new .wav files option allows you to define a set of 
meta-data as default.

When you create a new file, and do not add any meta-data, this default meta-data 
is applied to the file when saving it. For example, you can save or record WAV files 
with BWF meta-data and automatically add a Unique Material Identifier.

To edit the default meta-data preset, select Load default, and edit the preset.

About CART and Markers

WaveLab reads the CART markers, if any, and merges them with the existing 
markers of the file.

The CART standard can contain up to 8 markers. WaveLab stores them if their 
names obey the CART standard.

When Generate time markers is activated in the CART tab of the Meta-data 
dialog, the markers are generated if at least one CART text field has content. 
Otherwise the CART data is meant to be unused.

When rendering a file, the render option Copy markers must be activated in the 
Render dialog.

About Meta-Data and Variables

Variables make handling meta-data more efficient. You can use the various variable 
options to quickly add meta-data to a file, without having to type the same 
information multiple times.

You can also quickly add available information such as dates or file names.

The idea behind this is to set up the meta-data and variables once, and then be able 
to output various file versions from the project.
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Example of Using Meta-Data and Variables

Let’s say we have an audio montage that contains CD tracks and want to render all 
CD tracks to individual audio files, including meta-data information. We have 
already added some CD-Text to each track. The CD-Text of each CD track is 
automatically available in the CD Meta-data dialog and can be used as variables.

Now we want to add information that is not available as CD-Text, for example, the 
year of the CD track and a comment, to have these information available in the 
rendered audio files.

1) In the CD window, select Functions > Edit Meta-data, and fill out the 
@CdTrackYear@ and @CdTrackInfo1@ fields. Use the scroll-bar on the right 
of the dialog to select the other tracks, and add these information for all tracks. 
Close the dialog.

2) Edit the meta-data from the Meta-data dialog in the Audio Montage 
workspace. In this Meta-data dialog, set up the ID3 v2 fields, using the 
variables. Click the arrow icon to open the variables and text snippets pop-up 
menu for a field. You can also fill out other meta-data chunks, such as BWF, 
RIFF, or CART, or add an album picture. Or you could apply a previously set 
up meta-data preset to add meta-data.

3) Once the information are complete, we can open the Render dialog. In the 
What to render section, activate Regions, and select Tracks from the 
Regions pop-up menu.

4) Open the File Format dialog, and in the Meta-data pop-up menu, select 
Inherit from source file.

5) Once you have set up the dialog, click OK. Then click OK again to close the 
Audio file format dialog. Then in the Render dialog, click OK to render the 
files.

Result: When we now open the rendered audio files and look at the meta-data, we 
can see that the variables were automatically replaced with the meta-data that has 
been set up for each track.

An alternative way of step 2 is to select Specific to this configuration in the Audio 
file format dialog, and select a preset.

RELATED LINKS

Variables and Text Snippets on page 643

Meta-Data in the Batch Processors Workspace

You can batch process meta-data. For this you can set up the Meta-data dialog in 
the Batch Processors workspace, and apply the meta-data to the files of the batch 
process.

In the Batch Processors workspace, on the Format tab, the following options are 
available:

• Select Ignore if you do not want the batch meta-data to change the 
meta-data of the files in the batch.
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• Select Merge if you want to merge the meta-data of the batch with the 
meta-data of the source files (WAV files only).

• Select Replace if you want to replace the meta-data of the source files with 
the meta-data of the batch.

Examples for Merging Meta-Data

A simple example would be if you have 1000 files with a mistake in a copyright field 
of their meta-data. With this batch option, you can preserve the meta-data of the 
files, and edit only the copyright field.

However, the merge option can also be used for complex batch meta-data. You can 
process an audio file and specify which meta-data to use from the source audio file 
and which from the batch meta-data. For this, use the Merge codes options in the 
Meta-data dialog of the Batch Processors workspace.

If you enter #Source# in a value field, the value of the source audio file’s meta-data 
is used when batch processing. If you enter #Remove# in a value field, the 
corresponding value of the source audio file’s meta-data is removed when batch 
processing. In order to set up the merging process, you must set up these codes in 
the value field that you want to merge.

An example on how to merge meta-data while using the #Source# and #Remove# 
options:

• The batch process contains an audio file that already has meta-data.

• The batch meta-data is set up.

When starting the batch process, the meta-data are merged in the following way:

• If value field “A” in the audio file meta-data contains the text “Jazz”, while value 
field “A” is empty in the batch meta-data, the resulting output file has the text 
“Jazz” in value field “A”.

• If value field “B” in the batch meta-data contains the text “Modern”, while value 
field “B” in the audio file meta-data is empty, the resulting output file has the 
text “Modern” in value field “B”.
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• If value field “C” contains text both in the source audio file and in the batch 
meta-data, some more editing in the Meta-data dialog of the Batch 
Processors workspace is necessary to specify which meta-data should be 
used.

Examples on how to use the #Source# and #Remove# codes:

• No code is used, the source audio file has the text “Piano”, and the batch 
meta-data has the text “Trumpet”. Result: “Piano” is retained, because the 
source audio file meta-data has precedence over the batch meta-data.

• The source audio file has the text “Piano”, and the batch meta-data has the 
text “Electric #Source#”. Result: The resulting output file has the text “Electric 
Piano”.

• The source audio file has the text “Piano”, and the batch meta-data has the 
text “#Remove#”. Result: “Piano” is removed from the value field.

• The source audio file has the text “Piano”, and the batch meta-data has the 
text “#Remove#Trumpet”. Result: “Piano” is removed, and “Trumpet” is 
added.

Silence Generator Dialog

This dialog allows you to insert silence or background noise in an audio file.

In the Audio Files workspace, select Edit > Silence (advanced).

Type of silence - True silence

Select this to insert digital silence.

Type of silence - Background noise (file will be looped if needed)

Allows you to select an audio file containing ambient noise.
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Type of silence - Gain to apply to this file

Lowers or raises the gain of the background noise.

Silence Duration - As selection

Uses the duration of the active audio selection as the duration of the silent 
section. Specify the duration of the silent section in the value field below.

Edges - Fade-in/out

Performs a crossfade at the start and end of the silent section for smoother 
transitions. Specify the fade time in the value field below.

Destination - Replace selection

Replaces the current audio selection with the silent section.

Destination - Insert at cursor

Inserts the silent section at the cursor position.

Destination - From end of file until cursor

Extends the audio file with silence up to the cursor position. Activating this 
option also defines the silence duration and ignores the Silence Duration 
setting.

True Silence vs. Background Noise

Recordings can sound unnatural when you insert true silence. This is particularly 
true for voice recordings and field recordings, where a natural background noise is 
often present. To produce more natural results, you can insert a file with background 
noise.

The file that you specify must have the same properties (stereo/mono, sample rate, 
etc.) as the file in which you want to insert the silence. The file can be any length – 
if the silence region is longer than the file, the file is looped.

Replacing a Selection with Silence

You can replace a section of an audio file with true silence or background noise.

PROCEDURE

1. In the Audio Files workspace, make a selection.

2. Select Edit > Silence (advanced).

3. In the Silence Generator dialog, select the type of silence:
• True silence
• Background noise. For this option you must select a file containing the 

background noise.

4. Set the silence duration to As selection, and the destination to Replace 
selection.

5. Click Apply.
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Inserting Silence

You can insert a specified length of true silence or a background noise at any 
position of the audio file.

PROCEDURE

1. In the Audio Files workspace, set the cursor where you want the inserted 
silence to begin.

2. Select Edit > Silence (advanced).

3. In the Silence Generator, select the type of silence:
• True silence
• Background noise. For this option you need to select a file containing the 

background noise.

4. Deactivate As selection, and specify the length.

5. Set the destination to Insert at cursor.

6. Click Apply.

Fast Muting a Selection

The Fast mute function replaces the selection with true silence without needing to 
write any audio sample to the media.

PROCEDURE

• In the Audio Files workspace, make a selection, and select Edit > Fast mute.

Waveform Restoration with the Pen Tool

The Pen tool allows you to redraw the waveform directly in the wave window. This 
can be used to quickly repair waveform errors.

The Pen tool can be used if the zoom resolution is set to 1:8 (one pixel on the screen 
equals 8 samples) or higher.

• To redraw the waveform, select the Pen tool, click in the waveform, and draw 
the new waveform.
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• To redraw the waveform of both channels at once, press [Shift] during the 
drawing process.
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Audio Analysis

WaveLab provides you with a comprehensive set of tools for analyzing your audio 
and for detecting any errors.

For example, you can use the suite of audio meters, or the 3D Frequency Analysis. 
There are also several tools that help you examine any sample of your audio for 
errors or anomalies.

You can compare two audio files with the Audio File Comparator tool and view 
audio in a Spectrum or Loudness view.

Error Detection and Correction

You can search for unwanted clicks and digital artifacts in an audio file. You can use 
several detection and restoration methods to detect, mark and name, jump to, play 
back, and remove individual audio errors.

You can also restore damaged portions of an audio file by using waveform 
replacement. The Error Correction window in the Audio Files workspace gives you 
access to the error detection and correction tools.

NOTE

Since errors can have multiple origins and effects, various algorithms are needed to 
cover these cases. Experience with the settings to find the best parameters to 
detect the errors in your files.

Selecting an Error Detection and Correction Method

Before searching for errors in your audio file, set up the error detection and 
correction methods. Try out different settings.

PROCEDURE

1. In the Audio Files workspace, open the Error Correction window.

2. In the Error Correction window, open the Detection tab.

3. Select an error detection method from the Method used to detect errors 
menu, and set the parameters.
Depending on the method that you have selected, different detection parameters are 
available.
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4. Open the Correction tab.

5. Select an error correction method from the Default method to correct errors 
menu.

AFTER COMPLETING THIS TASK 

When you have selected error detection and correction methods, you can continue 
to detect and correct errors in the active audio file.

Strategies to Detect and Correct Errors

There are several strategies for detecting and correcting errors. Depending on the 
error, some detection and correction methods are more successful than others.

Set up the error detection and correction methods before following these 
strategies.

• To correct an error, select a range in the audio part that contains the error, 
then in the Error Correction window, select Correct or Mark for subsequent 
correction.

• To automatically locate the next error, in the Error Correction window, select 
Detect next error, then select Correct or Mark for subsequent correction.

• To detect all errors in the selected range, select Detect all errors. Then you 
can browse the detected errors and correct them individually, or select 
Correct all marked errors.

Correcting Individual Errors

You can detect and correct individual errors using different detection methods and 
parameter settings for each error. This is useful when errors are difficult to correct.

PROCEDURE

1. In the Audio Files workspace, open the audio file in which you want to correct 
errors.

2. Open the Error Correction window.

3. In the Error Correction window, open the Detection tab.

4. Select an error detection method from the Method used to detect errors 
menu, and set the parameters.
Depending on the method that you have selected, different detection parameters are 
available.
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5. Click Detect next error.
WaveLab analyzes the audio file from the beginning and stops at the first found error.

RESULT 

In the browse and correct section you now have several options for how to proceed. 
For example, you can correct the error, detect the next error, or mark the error for 
later restoration. Some of the options are only available after selecting another 
option.

RELATED LINKS

Error Correction Window on page 167

Automatically Detecting and Correcting Errors

Use WaveLab to automatically remove all click noise errors that it detects.

PROCEDURE

1. In the Audio Files workspace, open the Error Correction window.

2. In the Error Correction window, click Detect all errors.
WaveLab searches the complete file and inserts a pair of markers for each found 
error.

3. In the Correction tab, select a correction method from the Default method 
to correct errors menu.
A description of what the selected method does is displayed below the Default 
method to correct errors menu.

4. Click Correct all marked errors.

RESULT 

WaveLab automatically corrects all detected errors.
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Error Correction Window

This window provides access to the error detection and correction tools.

In the Audio Files workspace, select Workspace > Specific tool windows > Error 
Correction.

Detection Tab

On this tab, you can specify how to detect errors.

Method used to detect errors

Lets you select the error detection method. Depending on which method you 
have selected, different detection parameters are available.

Threshold

Specifies the threshold value for the error detection. Lower values detect 
softer clicks.

Detection

Specifies the lower limit of the analyzed frequency range.

Detection Width

Specifies whether to detect short or long error lengths.

Correction Tab

On this tab, you can specify the method that is used to correct errors.
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Default method to correct errors

Lets you select the error correction method. The following methods are 
available:

• Linear interpolation draws a straight line between the first and the last 
selected samples.

• Optimal for small clicks – 1 ms is optimal for clicks smaller than 1 ms.

• Optimal for common clicks – 3 ms is optimal for clicks smaller than 
3 ms.

• Waveform replacement – 4 s replaces the corrupt samples with the 
best match found in the material up to 4 seconds to the left/right.

• Waveform replacement – 500 ms replaces the corrupt samples with 
the best match found in the material up to 500 milliseconds to the 
left/right.

• Waveform replacement – left 6 s replaces the corrupt samples with 
the best match found in the material up to 6 seconds to the left.

• Waveform replacement – right 6 s replaces the corrupt samples with 
the best match found in the material up to 6 seconds to the right.

Search Area Tab

On this tab, you can specify the range of audio that you want to search for errors.

Range to scan - Define as whole file

Searches the whole audio file for errors.

Range to scan - Define as selected audio range

Searches the selected audio range for errors. Once defined, you can change 
the audio selection without altering this search area.

Range to scan - Whole audio file

Displays the active scan area.

Position to search from - Set at cursor

Starts the search at the edit cursor position.

Position to search from - Set at beginning of search area

Starts the search at the beginning of the defined search area.
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Options Tab

This tab provides a range of preferences for playing back, viewing, and marking any 
found errors.

Set markers around corrected errors

Creates correction markers around the audio section each time an error is 
corrected. This area can be larger than the marked error area when 
crossfades are performed by the corrector.

Remove markers after correction

Removes the error marker each time an error is corrected.

Zoom level

Specifies the zoom level when displaying an error.

Adjust selection by this number of samples

Defines by how many samples the selection edges are moved, when you use 
the Adjust selection buttons to adjust the error area.

Auto-play

Automatically plays back the error area after it has been detected or 
corrected.

Pre-roll time

Specifies a pre-roll time to play some audio before the start of the error 
section.

Post-roll time

Specifies a post-roll time to play some audio after the end of the error section.

Override global shortcuts

Gives priority to the error correction shortcuts if these shortcuts are also used 
elsewhere in WaveLab. Use this when you are working mainly with this tool. 
However, this option should be deactivated when you are done with the error 
correction.



Audio Analysis
Error Detection and Correction

170

Browse and Correct Section

In this section, you can step through your defined search region detecting each 
error in turn. You can choose to correct any errors or mark them for later correction. 
There are controls to jump between error markers and to make fine adjustments to 
the selection. You can also automatically detect and correct all marked errors in the 
search region.

Detect next error

Searches for the next error, starting at a specified position or from the end of 
the last found error.

Back to previous error

Returns to the last detected error.

Correct

Restores the audio selection with the default correction method. You can use 
the pop-up menu to correct the audio with any of the other methods.

Mark for subsequent correction

Sets a pair of error markers to the audio selection, without performing any 
correction.

Unmark

Deletes the error markers surrounding the audio selection.

Play

Starts playback of the current audio selection while taking into account the 
pre-roll and post-roll settings.

Adjust selection

The green arrows move the left edge of the selection to the left/right. The 
orange arrows move the right edge of the selection to the left/right. This lets 
you finely adjust an audio selection that was suggested by the detection 
function.

Macro - Detect all errors

Searches the specified range from the beginning to the end and creates pairs 
of error markers for each detected error without performing any correction.

Macro - Correct all marked errors

Restores the audio located within each pair of error markers in the specified 
range.
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Previous/Next correction mark

Jumps to the previous/next correction marker pair.

Previous/Next error mark

Jumps to the previous/next error marker pair.

Auto move on correction

Automatically jumps to the previous/next marked error when you click 
Correct.

Global Analysis

In WaveLab you can perform advanced analysis on your audio to identify areas with 
specified properties. This helps you find problem areas such as glitches or clipped 
samples. You can also check general information, such as the pitch of a sound.

When you analyze a section of an audio file, WaveLab scans the section or the 
audio file and extracts information which is displays in the dialog. WaveLab also 
marks sections of the file that meet specific characteristics, for example, sections 
that are very loud or almost silent. You can then browse between these points, set 
markers, or zoom in on markers. On most of the tabs, you find settings that 
determine exactly how the analysis is performed. Each tab focuses on a particular 
analysis area.

You perform the global analysis in the Global Analysis dialog. This dialog consists 
of the following tabs that provide different analysis types:

• The Peaks tab lets you find individual samples with very high values.

• The Loudness tab lets you find sections with high intensity.

• The Pitch tab lets you find the exact pitch of a sound or section.

• The Extra tab provides information about DC offsets and the significant bit 
resolution.

• The Errors tab lets you find glitches and sections where the audio has been 
clipped.

Most of the analysis types provide a number of positions in the file that indicate 
peaks, glitches, etc. These points are called “hot points”.
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Opening the Global Analysis Dialog

The Global Analysis dialog provides various analysis options.

PROCEDURE

1. In the Audio Files workspace, select a range in the audio file that you want to 
process.
If you want to analyze the entire file, press [Ctrl]/[Command]-A. If Process whole file 
if there is no selection is activated in the Audio file editing preferences dialog, the 
whole file is processed automatically provided that no selection has been made.

2. Select Analysis > Global analysis.

RELATED LINKS

Audio File Editing Preferences Dialog on page 675

Choosing the Analysis Type

Several types of analysis can be performed. Each of them takes some time, so make 
sure that only the types that you need are included in the analysis.

Select the analysis types by activating them in the corresponding tabs.

• To include the Peaks analysis, activate Find Peaks.

• To include the Loudness analysis, activate Analyze Loudness.

• To include the Pitch analysis, activate Find Average Pitch.

• To include the Extra analysis, activate Find DC Offset.

• To include the Errors analysis, activate Find Possible Glitches and Find 
Clipped Samples.

Global Analysis - Peaks Tab

This tab is used to find digital peak and true peak values in the audio, that is, single 
samples with very high values.

In the Audio Files workspace, select Analysis > Global Analysis, and select the 
Peaks tab.
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Find Peaks

Enables peak analysis.

Digital/True

Displays the highest peak in the analyzed section. When you click this value, 
the number of peaks that are found in the selection is shown in the Number 
of hot points section in the lower left corner of the dialog. You can use the 
hot points to move the cursor between the peaks.

At cursor

Displays the level at the current audio file cursor position at the time of the 
analysis.

Maximum number of peaks to report

Restricts the number of reported peaks. For example, setting this to 1 reports 
only the highest peak.

Minimum time between 2 peaks

Controls the distance between points, so they do not appear too close to 
each other. For example, setting this to 1 s ensures that there is always at 
least one second between reported points.

Results of the Analysis

The Find Peaks fields show the highest peak in the analyzed section and the level 
of the sample at the wave cursor position at the time of the analysis.

Global Analysis - Loudness Tab

This tab is for finding sections that are perceived by the human ear as louder or 
weaker in volume. To find sections that the ear perceives as significant in volume, 
you must look at a longer section of audio.

In the Audio Files workspace, select Analysis > Global Analysis, and select the 
Loudness tab.

The following options are available for both the Raw Loudness tab and the EBU 
R-128 tab:

Maximum number of loudness points to report

Restricts the number of reported hot points. The highest points are reported. 
For example, setting this to 1 reports only the loudest section or one of the 
sections with the same highest value.

Minimum time between 2 points

Controls the distance between points, so they do not appear too close to 
each other. For example, setting this to 1 s ensures that there is always at 
least one second between reported points.
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Raw Loudness

Analyze Loudness

Enables RMS loudness analysis.

Average

Displays the overall loudness of the analyzed selection.

Maximum

Displays the level of the loudest section in the analyzed selection. Clicking this 
value displays the number of loud sections found within the selection, in the 
Number of hot points section in the lower left corner of the dialog.

Minimum

Displays the level of the quietest section in the analyzed selection. Clicking 
this value displays the number of weak sections that are found within the 
selection in the Number of hot points section in the lower left corner of the 
dialog. This provides adequate information about the signal-to-noise ratio 
(SNR) of the audio material.

Around cursor

Displays the loudness at the audio file cursor position at the time of the 
analysis.

Resolution

The length of audio to be measured and averaged. If this value is lowered, 
short passages of loud/weak audio are detected. When it is raised, the sound 
must be loud/weak for a longer period to result in a hot point.

Threshold (for the average)

Ensures that the average value is calculated correctly for recordings with 
pauses. The value that you set here determines a threshold below which any 
found audio is considered to be silence, and is therefore excluded from 
average value calculations.
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EBU R-128

Integrated loudness

Displays the integrated loudness of the analyzed selection, also known as 
Programme Loudness, according to the EBU R-128 specification. This 
indicates how loud the audio is on average.

Loudness range

Displays the loudness range according to the EBU R-128 specification. It is 
based on a statistical distribution of loudness within a programme, thereby 
excluding the extremes.

Short-term loudness: Maximum

Displays the level of the loudest 3 seconds section in the analyzed selection. 
When you click this value, the number of loud sections that are found within 
the selection is shown in the Number of hot points section in the lower left 
corner of the dialog.

Short-term loudness: Minimum

Displays the level of the quietest 3 seconds section in the analyzed selection. 
When you click this value, the number of quiet sections that are found within 
the selection is shown in the Number of hot points section in the lower left 
corner of the dialog. This provides adequate information about the 
signal-to-noise ratio (SNR) of the audio material.

Momentary loudness: Maximum

Displays the level of the loudest very short section (400 milliseconds) in the 
analyzed selection. When you click this value, the number of loud sections 
that are found within the selection is shown in the Number of hot points 
section in the lower left corner of the dialog.
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Momentary loudness: Minimum

Displays the level of the quietest very short section (400 milliseconds) in the 
analyzed selection. When you click this value, the number of quiet sections 
that are found within the selection is shown in the Number of hot points 
section in the lower left corner of the dialog.

RELATED LINKS

EBU Loudness Standard R-128 on page 43

Global Analysis - Pitch Tab

This tab is for finding the average pitch of an audio section.

In the Audio Files workspace, select Analysis > Global Analysis, and select the 
Pitch tab.

You can use this tab to gather information for pitch shifting, for example, to get one 
sound in tune with another. The display shows the pitch for each channel, both in 
Hertz (Hz) and as semitones and cents (hundredths of a semitone). Since the 
display shows an overall value for the entire analyzed section, the hot point controls 
in the lower section of the dialog are not used on this tab.

Usage guidelines for the Pitch tab:

• The result is an average value for the whole selection.

• The method only works on monophonic material, not on chords or harmonies.

• The algorithm assumes that the analyzed section has a reasonably stable 
pitch.

• The material must be relatively well isolated from other sounds.

• It is preferable to analyze the sustain portion of a sound rather than the attack. 
The pitch is usually not stable during the attack.

• Some synthetic sounds may have a weak fundamental (first harmonic) which 
can irritate the algorithm.
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Global Analysis - Extra Tab

This tab shows the average DC Offset of the analyzed section and the Apparent 
Bit Resolution.

In the Audio Files workspace, select Analysis > Global Analysis, and select the 
Extra tab.

The Apparent Bit Resolution attempts to detect the actual resolution in the audio. 
This is useful, for example, if you want to check, whether a 24-bit file really uses 24 
bits or if it was actually recorded with 16-bit resolution and then expanded to 24 
bits.

NOTE

For more accurate results on the bit resolution, use the Bit Meter.

RELATED LINKS

Bit Meter on page 436

Errors Detection

You can detect errors, such as glitches and sections where the audio has clipped. 
For a more advanced error detection, use the Error Correction window.

Glitches

• These are disruptions in the audio. Glitches may occur after problematic 
digital transfers, after careless editing, etc. They manifest themselves as 
“clicks” or “pops” in the audio.

Clipping

• A digital system has a finite number of levels that it can represent properly. 
When recorded sound levels are too high or when the system cannot handle 
levels that have been raised by digital processing, hard clipping occurs that 
you can hear as strong distortion.

A sine waveform before clipping and after.
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Result of the Analysis

This reports the number of glitches and clipping instances that have been found.

Global Analysis - Errors Tab

This tab helps you find glitches and sections where the audio has clipped.

In the Audio Files workspace, select Analysis > Global Analysis, and select the 
Errors tab.

Maximum number of error points to report

Allows you to restrict reported numbers of hot points.

Minimum time between 2 points

Controls the distance between points, so they do not appear too close to 
each other. For example, setting this to 1 s ensures that there is always at 
least one second between reported points.

Find possible glitches

Enables glitch analysis.

Find possible glitches - Threshold

Sets the value at which a change in level is considered to be a glitch. The 
higher the value, the less sensitive the detection.

Find possible glitches - Sensitivity

Length value that represents the length of time in which the waveform must 
exceed the threshold to be reported as a glitch. The higher the value, the less 
sensitive the detection.
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Find possible glitches - Output format

Displays the number of clipping occurrences that are found by the analysis. 
Clicking this value displays the number of clips in the Number of hot points 
section in the lower left corner of the dialog.

NOTE

Make sure that the points that are found by the algorithm are real glitches. 
Zoom in and play back to check whether the found points really indicate a 
problem.

Find clipped samples

Enables clipping analysis.

Find clipped samples - Threshold

Checks for a number of consecutive samples at full value, to determine 
whether clipping has occurred. The Threshold setting determines the exact 
number of these consecutive samples that must occur for the program to 
report clipping.

Find clipped samples - Output format

Displays the number of clipping occurrences that are found by the analysis. 
Clicking this value displays the number of clips in the Number of hot points 
section in the lower left corner of the dialog.

Performing a Global Analysis

PREREQUISITE 

In the Audio Files workspace, select Analysis > Global Analysis, and select the 
tab that you want to include in the analysis.

PROCEDURE

1. In the Global Analysis dialog, set up the parameters.
Most of the tabs have settings that determine how the analysis should be performed.

2. If the Peak or Loudness tab is selected, move the cursor to the position that 
you want to analyze.
The Peak and Loudness tabs report values specifically for the position of the cursor.

3. Click Analyze.
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Results of the Global Analysis

Depending on the analysis type, one or several values are returned for the analyzed 
audio.

For the Pitch and Extra analyses, only one value is returned. The other analysis types 
provide a number of positions in the file that indicate peaks, glitches, etc. These 
points are called “hot points”.

Checking the Results of the Global Analysis

The results of the global analysis are marked with hot points. You can browse 
through these points to see the results of the analysis.

PREREQUISITE 

In the Audio Files workspace, select Analysis > Global Analysis, and perform the 
analysis.

PROCEDURE

1. In the Global Analysis dialog, click the tab that represents the values that you 
want to check.

2. Check the display for maximum/minimum values in the entire analyzed section.

3. Decide which of these values you want to browse.

4. Click the button that currently displays this value.

5. Check the Number of hot points value at the bottom of the dialog.
The value shows the number of positions that were found by the analysis.

6. Use the scrollbar below the Number of hot points value to browse between 
the found positions.
The edit cursor shows the position in the wave window.

7. To browse another property, click the corresponding tab, and then the value 
button.

NOTE

The result of the analysis is saved until you close the dialog or click Analyze 
again.
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Creating Markers at Hot Points

Creating markers at hot points simplifies browsing the results of the global analysis.

PREREQUISITE 

In the Audio Files workspace, select Analysis > Global Analysis, and perform the 
analysis.

PROCEDURE

1. In the Global Analysis dialog, select the analysis type for which you want to 
create markers at hot points.
You can add markers for only one channel at a time.

2. Click the Create markers at hot points button.
Temporary markers are added at all hot points.

RESULT 

The markers are named using the following principle: “Hot point number (Channel)”. 
For example, a marker at the third hot point in the left channel would be labeled “3 
(L)”.

Focusing Hot Points

After a global analysis, you can focus the display on a certain hot point.

PREREQUISITE 

In the Audio Files workspace, select Analysis > Global Analysis, and perform the 
analysis.

PROCEDURE

1. Use the Number of hot points scroll bar to move the position indicator to the 
position in which you are.

2. Click the Focus button.
The wave window zooms in on the selected point. The Global Analysis dialog is 
reduced to the bottom part.

3. To return to the unzoomed view and return to the full view of the Global 
Analysis dialog, click the Focus button again.

Audio File Comparator

You can compare audio files to find differences.

Use the Audio File Comparator to:
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• See and hear the effect of using an equalizer.

• Check the noise added by a processor.

• Check the effects of data compression.

• Compare two versions of an apparent similar recording to see if they are really 
the same.

You can create a delta audio file that contains only the differences between the two 
compared audio files. To see and hear small differences easily, you can amplify 
them.

Markers can be automatically added at positions in the audio file where differences 
are found.

Audio File Comparator Dialog

In this dialog, you can compare two audio files.

In the Audio Files workspace, select Analysis > File Comparator.

Files to Compare

If more than two audio files are open in the Audio Files workspace, select the 
two files that you want to compare.

Generate Delta File

A delta file contains only the differences between the two compared files.

Difference amplification

Amplifies the differences in the delta file to facilitate seeing and hearing them.

Create markers at points of difference

Creates markers at points where differences are found.

Maximum number of markers

Sets the maximum number of markers to be inserted.
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Minimum time between two markers

Determines the density of the generated difference markers.

Comparing Audio Files

The File Comparator lets you see the differences between two files.

PREREQUISITE 

In the Audio Files workspace, open the audio files that you want to compare.

PROCEDURE

1. Select Analysis > File Comparator.

2. If more than two audio files are open, select the two files that you want to 
compare.

3. Optional: Activate Generate Delta File.
This creates a new audio file that contains only the differences between the compared 
audio files.

4. Optional: Make marker settings.
This creates markers at points of differences, to facilitate finding the differences.

5. Click OK.

3D Frequency Analysis

Using the 3D Frequency Analysis, you can view an audio file in the frequency 
domain.

Use the 3D Frequency Analysis to:

• See how the frequency spectrum is distributed in a mix.

• Identify which frequencies to reduce or boost as a basis for equalizing.

• See which parts of the frequency spectrum are occupied by a certain 
background noise that you want to filter out.

A wave display (time domain) informs you about the start and end of a sound in a 
file, but lacks information about the timbral contents of the file that a frequency 
graph (frequency domain) provides. The graph that is used in WaveLab is often 
referred to as an FFT (Fast Fourier Transform) plot. If you select a stereo recording, 
a mix of the two channels is analyzed.
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The wheel control allows you to view the frequency spectrum from different angles. 
For example, you can open several 3D Frequency Analysis windows, each with a 
different perspective. This allows you to get a better view of an otherwise crowded 
graph.

Creating a Graph for 3D Frequency Analysis

The length of the selected audio affects the accuracy of the analysis. For short 
selections, the result is more detailed. Consider making a separate analysis of the 
attack in which the most drastic variations occur.

PROCEDURE

1. In the Audio Files workspace, select the section of the file that you want to 
analyze.
If you make no selection, the whole audio file is analyzed.

2. Select Analysis > 3D Frequency Analysis.
The audio is analyzed.

3. To edit the analysis parameters, click the 3d analysis options button.

4. Adjust the parameters, and click OK.
The audio is re-analyzed.
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3D Analysis Options

In the options dialog of the 3D Frequency Analysis dialog, you can define which 
frequency range is analyzed and modify the appearance of the graph for the 3D 
frequency analysis.

In the Audio Files workspace, select Analysis > 3D Frequency Analysis, and click 
the 3D analysis options button.

Top/Bottom frequency

Specifies the highest/lowest frequency of the range.

Logarithmic ruler (octaves)

Divides the frequency ruler in equally spaced octaves.

Amplitude

Select whether you want the peaks to be proportional to their amplitude 
(Linear) or to their power (Logarithmic with decibel scale).

Colors

Defines the color scheme of the graph.

Background

Defines the background color.
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Offline Processing

Offline processes are useful for a variety of editing purposes and creative effects. 
For example, when the computer is too slow for real-time processing or when the 
editing requires more than one pass.

After the processing the audio file is permanently altered.

Applying Processing

Processing can be applied to a selection or to a whole file. For certain operations 
processing the entire file is necessary.

NOTE

If Process whole file if there is no selection is activated in the Options > Audio 
file editing preferences > Editing tab, the whole file is automatically processed if 
no selection exists.

PROCEDURE

1. In the wave window, make a selection.

2. Select the type of processing that you want to apply from the Process menu.

3. If a dialog appears, make the settings.

4. Click Apply to render the effect to file.

Gain Dialog

In this dialog, you can apply a gain to change the level of an audio file.

In the Audio Files workspace, select Process > Gain.
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Click Find current peak level to obtain a report on the peak level of the audio 
selection, or the whole file if there is no selection. This is useful if you want to 
calculate how much you can increase the overall gain of a file without clipping 
(exceeding 0 dB), for example.

This processor also lets you add clipping. Clipping is when the gain is raised to a 
point where distortion is added. While this is normally not wanted, mild clipping can 
add some punch, for example, to accentuate the attack of a drum sound.

Normalize Level Dialog

In this dialog, you can change the peak level of an audio file.

In the Audio Files workspace, select Process > Level Normalizer.

This dialog is also available as a multipass plug-in in the Batch Processors 
workspace.

Peak level

Enter the peak level (in dB) that you want the audio selection to have.

Stereo Link

Applies the gain to both channels.

Reference menu

Select whether WaveLab should use sample values (digital peaks) or analog 
reconstructed values (true peaks).

Mix to Mono

Mixes the left and the right channel. The resulting mono file will have the 
specified peak level. This ensures a mix without clipping.

Find current peak value

Creates a report on the peak level of the current audio selection, or the whole 
audio file if there is no selection.
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Loudness Normalizer

You can use the Loudness Normalizer to achieve a specific loudness.

Increasing the loudness to a certain value can provoke clipping. To remedy this, a 
peak limiter (Peak Master plug-in) can be part of the process. The Loudness 
Normalizer raises the loudness and limit peaks in the signal at the same time if 
needed, to achieve the wanted loudness.

This process happens in several stages. First an analysis and then the final 
rendering.

Loudness Normalizer Dialog

In this dialog, you can specify the loudness of a file.

In the Audio Files workspace, select Process > Loudness Normalizer.

This dialog is also available as a multipass plug-in in the Batch Processors 
workspace.

Loudness (EBU R-128)

Loudness to achieve

If the loudness cannot be achieved with a simple positive gain change, a 
limiter must come into action to prevent clipping.

Here, specify the loudness that you want to achieve. The EBU R-128 
recommendation for broadcast is -23 dB.

Specifying high values might require a gain outside the normal capabilities of 
the limiter, which can cause distortion.
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It is recommended to use Statistics after specifying a loudness. This way you 
know how much the gain needs to be raised and if peak limiting needs to be 
applied. If heavy limiting is necessary this might degrade the audio quality. In 
such cases a warning is shown after applying the process, allowing you to 
undo it.

Catch loudness from audio selection

Sets the Loudness to achieve value to the average loudness found in the 
audio file.

Reference menu

Select a reference: the loudness of the entire file (EBU R-128 
recommendation), the average loudest 3 second audio section (Top of 
loudness range), or the loudest 3 seconds audio section (Maximum 
short-term loudness).

Peaks menu

Select whether WaveLab should limit the sample values (digital peaks) or the 
analog reconstructed samples (true peaks).

Peak Limiter

Max peak level

Here, specify the maximum peak level of the resulting audio. The lower this 
value, the lower the loudness.

Softness

This parameter affects the way that the Peak Master operates. A high setting 
maximizes the perceived loudness effect, but can result in a slight harshness 
of the sound.

Adjust this parameter to optimize the balance between sound quality and the 
effect that you want to achieve.

Pre-Processing Options

Remove DC offset

DC offset in the file affects the loudness computation. Therefore it is 
recommended that you keep this option activated.

Attempts/Analysis

Tolerance (+/-)

If the Loudness to achieve requires peak limiting, this also reduces the 
loudness to some degree. This cannot be computed in advance and cannot 
be automatically applied to the gain change. Instead, several simulation 
passes are performed to find the best possible gain. This option lets you 
define the precision of the result that you want to achieve.
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Maximum number of passes

WaveLab performs as many analysis passes as needed to match the 
precision that you want to achieve. Use this option to specify the maximum 
number of passes to be performed.

Authorized peak compression

As too much compression degrades the audio quality, you can specify a limit 
for the applied compression. The value can be set between -1 and -20 dB. 
Consider to lower the Loudness to achieve, as this renders better results.

Warn if unmatched

If this option is activated, you are warned if the normalizing process does not 
meet the specified loudness/precision. This option is not available during 
batch processing.

Statistics

Opens a window which shows you information about the file to be processed. 
It shows any DC offset, the current loudness, the current peak level, and the 
required gain to achieve the specified loudness. Furthermore you are informed 
if limiting is required.

RELATED LINKS

EBU Loudness Standard R-128 on page 43

Pan Normalizer Dialog

This dialog allows you to ensure that both channels of a stereo file have the same 
level or loudness, and helps you to get the best possible stereo balance.

In the Audio Files workspace, select Process > Pan Normalizer.

This dialog is also available as a multipass plug-in in the Batch Processors 
workspace.

This process first analyzes the audio and then renders any required level changes. 
You must have a stereo selection in a stereo file to apply this process.

Peak level

Raises the channel with the lowest peak level to match the peak level of the 
other channel.
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Loudness (EBU R-128)

Analyzes the loudness of both channels and adjusts their gain so that both 
channels get the same loudness. No clipping can be introduced using the Pan 
Normalizer.

Remove DC offset

Removes DC offsets which affect the loudness computation. We recommend 
to keep this option activated.

Analyze channel difference

Shows the current Loudness ratio between the left/right channels. The result 
changes depending on the selected Peak/Loudness mode.

Envelope Dialog

In this dialog, you can create a volume envelope which can be applied to a selected 
range or a whole audio file. This is useful if you want to even-out loud and quiet parts 
or create a sophisticated fade-in/fade-out, for example.

In the Audio Files workspace, select Process > Envelope.

The dialog shows a waveform with an envelope curve (initially a straight line). A 
vertical ruler displays the level in dB, and the horizontal ruler displays the timeline.

The following options are available:

• Undo/Redo the last operation

• Deselect the envelope points

• Delete the selected envelope points

• Reset the selected envelope points

• Reset the whole envelope

• Flip the envelope around the horizontal axis

• Reverse the envelope time sequence
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• Toggle the envelope smoothing

Basic Envelope Operations

By adding points to the envelope curve you can create an envelope curve that 
changes the volume of the material over time. When you point the mouse in the 
display or move a point, the current position and level change is shown in the field 
above the display.

• To add a point, double click the envelope curve.

• To select a point, click it.

• To select several points, click and drag the selection rectangle.

• To move a point, click and drag it. If more than one point is selected, all points 
are moved.

• To move the whole curve up or down, click the envelope curve, and drag up 
or down.

• To move the curve segment between selected points, select the points, click 
the envelope curve between the points, and drag up or down.

• To move two points horizontally, press [Shift], click the curve segment 
between two points, and drag left or right.

• To move the segment between 2 points vertically, press [Ctrl]/[Command], 
click the segment, and drag up or down.

Fades in Audio Files

A fade-in is a gradual increase in level and a fade-out is a gradual decrease in level.

You can create fades by selecting an individual fading type for each 
fade-in/fade-out, or by using the Easy Fade function.
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Creating a Fade-In and Fade-Out

PROCEDURE

1. In the Audio Files workspace, make a selection.

2. Depending whether you want to create a fade-in or a fade-out, select one of 
the following:
• To create a fade-in, select Process > Fade-in.

• To create a fade-out, select Process > Fade-out.

3. Select the type of fade that you want to create.
A graph in the waveform indicates the resulting shape.

Applying Easy Fades

The Easy Fade function allows you to quickly apply a default fade-in or fade-out to 
an audio file.

The shape of the fade is governed by the default fade/crossfade setting in the 
Options > Audio file editing preferences > Editing tab, in the Default 
fade/crossfade section.

PROCEDURE

1. In the Audio Files workspace, make one of the following selections:
• From the start of the audio file to where you want the fade-in to end.

• From the position where you want the fade-out to start to the end of the audio 
file.

2. Select Process > Easy Fade.
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Crossfades

A crossfade is a gradual fade between two sounds, where one is faded in and the 
other faded out. You can automatically create a crossfade when pasting an audio 
section into another.

Creating Crossfades

The material that you want to crossfade can either be in two different sections of the 
same audio file, or in two different audio files.

PROCEDURE

1. In the Audio Files workspace, select the section that you want to fade-in.

2. Select Edit > Copy, or press [Ctrl]/[Command]-C.

3. Select the section that you want to fade-out.
The length of this selection determines the length of the actual crossfade (check the 
length on the status bar). The section can be within the selected audio file or in 
another wave window. However, the selection must not be longer than the selection 
that you just copied.

4. Select Edit > Paste and crossfade, and select one of the crossfade types.

5. Play back the file and adjust the crossfade if necessary.

RESULT 

The crossfade is created. Any material that originally appeared after the selection in 
the file into which you paste, is moved so that it now appears after the pasted 
material.

Any excess material in the copied selection appears after the fade at full level.

NOTE

If both files already have full level sections in the crossfade area (for example, if you 
have normalized both files), clipping and distortion might occur. If this happens, 
reduce the amplitude of both files by 3 to 6 dB and try again.

Paste and Crossfade Options

These options allow you to select a crossfade type for pasting.

In the Audio Files workspace, select Edit > Paste and crossfade.

Linear (equal gain)

Level changes linearly.
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Sinus (equal power)

Level changes according to a sine curve, the power of the mix remains 
constant.

Square-root (equal power)

Level changes according to the square-root curve, the power of the mix 
remains constant.

Inverting the Audio Phase

Inverting the phase turns the signal upside down. The most common use for this 
function is to fix a stereo recording where one of the channels has been recorded 
out of phase with the other.

PROCEDURE

1. Optional: If you only want to invert the phase for a certain time range of the 
audio file, create a selection range in the wave window.

2. In the Audio Files workspace, select Process > Invert phase.

An inverted phase is indicated by an icon in the wave window.

Reversing Audio

You can reverse an audio file or a part of an audio file as if playing a tape backwards.

PROCEDURE

1. Optional: If you only want to reverse a certain time range of the audio file, 
create a selection range in the wave window.

2. In the Audio Files workspace, select Process > Reverse.

DC Offset

A DC offset is when there is too large a DC (direct current) component in the signal. 
This most often appears due to mismatches between various types of recording 
equipment.

A DC offset is problematic for the following reasons:

• It affects where the zero crossing positions.
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• Certain processing options do not give optimal results when performed on 
files with a DC offset.

Removing DC Offset

PROCEDURE

1. In the Audio Files workspace, open the audio file that you want to check for 
DC offset and fix.

2. Select Process > Remove DC offset.
A dialog appears, stating the amount of DC offset in the audio file. You can also 
create a selection range in the wave window and then select this option, to only show 
the DC offset in the selection range.

NOTE

This function should be applied to whole files, since the problem is normally 
present throughout the entire recording.

3. Click OK to remove the DC offset.

Time Stretching

Time stretching is an operation that allows you to change the length of a recording 
without affecting its pitch.

With time stretching you can make audio material longer or shorter. This function is 
most often used to make a section of audio fit in with some other material. You 
select the material to be stretched and use the options in the Time stretching 
dialog to find a stretch factor. This is done by specifying a length or a tempo, 
according to what the situation requires.

Time Stretching Dialog

In this dialog, you can change the duration of an audio selection, usually without 
changing its pitch. You can stretch a selection to a specified duration (in minutes, 
seconds, and milliseconds), tempo (in bpm), or stretch factor (as percentage).

In the Audio Files workspace, select Process > Time stretching.
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This dialog is also available as a monopass plug-in in the Batch Processors 
workspace.

Source (Audio Selection)

Duration - Edit tempo

If this option is activated, you can change the tempo of the audio source. The 
number of bars and beats and the stretch factor is updated automatically.

Duration - Edit bars

If this option is activated, you can set the number of bars and beats and the 
signature for the audio source. The source tempo and according the stretch 
factor is automatically updated.

Result

Target duration

If this option is activated, the audio source changes its duration.

Target tempo

If this option is activated, the audio changes its tempo. For this to work, you 
must specify the original tempo or the number of bars and beats.

Target stretch factor

Lets you see how much the audio duration changes. This parameter is 
automatically updated when you edit the other parameters, but you can also 
activate this option to edit it manually.

Reset

Resets the stretch factor to 100 % (no stretch).

Method

Preserve pitch

If this option is activated, the pitch of the audio material is not affected when 
you apply time stretch. If this option is deactivated, the pitch changes 
proportionally with the time stretch ratio.
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Method pop-up menu

Auto/Preview: Automatically selects the best time/frequency trade-off for 
real-time/preview performance. This is the fastest setting, but might not 
provide optimal results in all cases.

Time localization ++ (instruments, voices): Selects full time localization. 
This is a good setting for single instruments and solo voices.

Time localization +: Time/frequency localization with the emphasis on time 
localization. If the previous mode produces echo artifacts, try this option.

Average Time/Frequency localization: Sets the time/frequency localization 
halfway between the time and frequency domains. It is the best setting for all 
general purpose signals.

Frequency localization +: Time/Frequency localization with the emphasis on 
frequency localization. Good setting for classical music.

Frequency localization ++ (complex mixes): Highest possible frequency 
localization. This setting might not work well on material with many sharp 
attack transients, but it can produce good results with less 
transient/percussive material.

Transcribe mode (for large changes): This uses a content aware algorithm 
to time stretch and pitch shift music by up to 4x the original length without 
losing information critical to transcription, such as attack transients.

Quality pop-up menu

The High quality and Best (very slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
quality mode is sufficient.

Use modulation envelope

Modulates the stretch factor over time.

Time Stretching Limitations

Time stretch is a complicated Digital Signal Processing (DSP) operation, that 
always affects the sound quality to some extent.

• For speech, stretch factors within a ±30 % limit provide good results.

• For composite music, try to limit the range to ±10 %.

• For sensitive material, like solo piano, try to limit the range to ±3 %.
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About the DIRAC Time Stretching Processor

The DIRAC engine is a high quality time stretcher. It produces the best quality 
results possible, but takes longer to process.

Pitch Shift

Pitch shift allows you to detect and to change the pitch of a sound, with or without 
affecting its length. This is useful for fixing an off-key vocal note in a live recording, 
or tuning the pitch of a kick drum sample to fit a particular song, for example.

Pitch Shift Dialog

In this dialog, you can change the pitch of a sound.

In the Audio Files workspace, select Process > Pitch shifting.

This dialog is also available as a monopass plug-in in the Batch Processors 
workspace.

Amount of Shift - Semitones

Specifies the amount of pitch change in semitones.

Amount of Shift - Cents

Specifies the amount of pitch change in cents.

Find current pitch of audio selection

Analyzes the pitch of the selected audio and displays it below.

According to the current pitch, compute the required shift to match the key 
hereafter

Click to adjust Amount of Pitch parameters automatically, based on the 
currently detected pitch and the pitch specified in the value field below this 
button.

Pitch field

Specifies the resulting pitch.
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Length preservation

Specifies how the length of the selection is affected by the operation:

• A setting of 100 means that the length of the audio remains unchanged.

• A setting of 0 means that the program behaves like a tape recorder, 
when the speed of its tape is changed. For example, if you raise the 
pitch by one octave, the audio is half as long.

• Intermediate values give results in between these two extremes.

For large transposition values, the lower this setting, the better the quality of 
the effect.

Method pop-up menu

Auto/Preview: This automatically selects the best time/frequency trade-off 
for real-time/preview performance. This is the fastest setting, but might not 
provide optimal results in all cases.

Time localization ++ (instruments, voices): Selects full time localization. 
This is a good setting for single instruments and solo voices.

Time localization +: Time/frequency localization with the emphasis on time 
localization. If the previous mode produces echo artifacts, try this option.

Average Time/Frequency localization: This sets the time/frequency 
localization halfway between the time and frequency domains. It is the best 
setting for all general purpose signals.

Frequency localization +: Time/Frequency localization with the emphasis on 
frequency localization. Good setting for classical music.

Frequency localization ++ (complex mixes): Highest possible frequency 
localization. This setting might not work well on material with many sharp 
attack transients, but it can produce good results with less 
transient/percussive material.

Transcribe mode (for large changes): This uses a content aware algorithm 
to time stretch and pitch shift music by up to 4x the original length without 
losing information critical to transcription, such as attack transients.

Quality pop-up menu

The High quality and Best (very slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
quality mode is sufficient.

Correct formants

If this option is activated, changing the pitch of vocal material gives a more 
realistic result. When processing non-vocal material you should leave this 
option deactivated, since it uses a slightly slower processing algorithm.

NOTE

This Algorithm might cause a noticeable increase in signal level.
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Modulate formants correction

If this option is activated, the formant correction is modulated over time.

NOTE

When the envelope is not used and the formant correction is activated, a 
100 % correction is performed.

Pitch Quantize Dialog

This dialog allows you to automatically detect and correct the pitch of an audio file. 
The input signal is quantized to discrete notes.

In the Audio Files workspace, select Process > Pitch quantizing.

This dialog is also available as a monopass plug-in in the Batch Processors 
workspace.

Pitch quantize works best on recordings that have monophonic signals, such as 
voice or single instruments.

Reference frequency

Defines the reference tuning (in Hz) for the pitch shift.

Liaison time

Defines the time it takes for the correction to reach the full correction amount. 
Typically, sung notes are slightly unstable at the beginning, because the 
attack phase of a sound has a higher amount of noise, and because singers 
gradually adjust their tuning after the onset of the note.

The slur time makes the pitch shift sound more natural because it mimics this 
effect.

Preserve Formants

If this option is activated, the formants are corrected according to the pitch 
shift amount.

Quality pop-up menu

The High quality and Best (very slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
quality mode is sufficient.
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Pitch Bend

Pitch bend allows you to change the pitch of a sound over time. Changing the pitch 
using pitch bend affects its duration unless Preserve duration is activated.

This function can be used for creating the classic tape stop effect, or for blending 
the tempo/pitch of one track into another, for example.

You can draw the curve that you want the pitch to follow. The pitch offset is 
displayed on the vertical ruler of the envelope and the range of the envelope effects 
can be adjusted. Positive pitch values produce sounds with a higher pitch and a 
shorter length, negative values produce sounds with a lower pitch and a longer 
length.

If Preserve duration is activated, you can choose the algorithm that is used to 
perform the pitch bend operation. Depending on the type of audio material you are 
processing, choose the appropriate mode. You can also adjust the quality used 
when processing the pitch bend. The quality setting and the selected mode affect 
the processing time for this effect.

Pitch Bend Dialog

In this dialog, you can gradually change the pitch of a sound using an envelope 
curve.

In the Audio Files workspace, select Process > Pitch bend.

The following options are available at the top of the dialog:

• Undo/redo the last operation

• Deselect the envelope points

• Delete the selected envelope points

• Reset the selected envelope points
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• Reset the whole envelope

• Flip the envelope around the horizontal axis

• Reverse the envelope time sequence

• Toggle the envelope smoothing

The following options are available at the bottom of the dialog:

Preserve duration

If this option is activated, a time stretching process is applied to compensate 
for the change of duration caused by the pitch modifications.

Method menu

Auto/Preview: This automatically selects the best time/frequency trade-off 
for real-time/preview performance. This is the fastest setting, but might not 
provide optimal results in all cases.

Time localization ++ (instruments, voices): Selects full time localization. 
This is a good setting for single instruments and solo voices.

Time localization +: Time/frequency localization with the emphasis on time 
localization. If the previous mode produces echo artifacts, try this option.

Average Time/Frequency localization: This sets the time/frequency 
localization halfway between the time and frequency domains. It is the best 
setting for all general purpose signals.

Frequency localization +: Time/Frequency localization with the emphasis on 
frequency localization. Good setting for classical music.

Frequency localization ++ (complex mixes): Highest possible frequency 
localization. This setting might not work well on material with many sharp 
attack transients, but it can produce good results with less 
transient/percussive material.

Transcribe mode (for large changes): This uses a content aware algorithm 
to time stretch and pitch shift music by up to 4x the original length without 
losing information critical to transcription, such as attack transients.

Varies with envelope

If this option is activated, time stretching is continuously applied, but varies, 
depending on the pitch changes. If this option is deactivated, time stretching 
is applied equally to all audio parts.

In both cases, the global audio duration is preserved. The option is activated 
by default because this gives a more natural result. Note however, that this 
affects the quality of the audio.

Quality menu

The High quality and Best (very slow) modes provide high quality time 
stretching, but the processing takes longer. For most uses, the Standard 
quality mode is sufficient.
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Range (semitones)

Specifies the maximum range in semitones for the pitch change. When you 
change this value, this is indicated in the vertical ruler.

Resample

You can change the sample rate of a recording. This is useful if the file that you want 
to use in a certain audio system was recorded at a sample rate that this system does 
not support.

Note the following:

• Sample rate conversion from a low frequency upwards does not improve the 
sound quality. The high frequencies that were lost cannot be restored by a 
conversion.

• When you resample to a lower frequency, high frequency material is lost. 
Therefore, converting down and then up again leads to a degradation in 
sound quality.

NOTE

Using the Crystal Resampler in the quality mode High to change the sample rate 
results in the same quality as when using Process > Resample in the Audio Files 
workspace. However, that is only the case if the sample rate in the Sample rate 
dialog exists in the values of the Crystal Resampler Sample rate menu. If you 
choose a custom sample rate, another algorithm is used, which results in a lower 
quality of what the Crystal Sampler can achieve.

Converting a Sample Rate

NOTE

Sample rate conversion is always applied to the entire file.

PROCEDURE

1. In the Audio Files workspace, select Process > Resample.

2. In the Sample Rate dialog, select a sample rate from the pop-up menu.

3. Click OK.
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Effect Morphing

Effect morphing allows you to smoothly morph from one effect to another, or from 
an unprocessed audio segment to a processed audio segment.

Effect morphing always involves two audio ranges. For example, two versions of the 
same audio range, of which one is processed and the other unprocessed.

Effect Morphing Dialog

In this dialog, you can gradually mix two audio ranges that have different 
effects/processing applied to them.

In the Audio Files workspace, select Edit > Effect morphing.

The dialog consists of a waveform display that shows the current selection and an 
envelope curve (by default a straight line) in the middle. By adding points to the 
envelope, you can create a curve that is used for the morphing process.

The following options are available at the top of the dialog:

• Undo/Redo the last operation

• Deselect the envelope points

• Delete the selected envelope points

• Reset the selected envelope points

• Reset the whole envelope

• Flip the envelope around the horizontal axis

• Reverse the envelope time sequence

• Toggle the envelope smoothing

The following options are available in the lower right corner of the dialog:

Mix current selection with - Unprocessed selection

Mixes the audio selection with the unprocessed version of the same audio.
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Mix current selection with - Clipboard

Mixes the audio selection with the clipboard.

RELATED LINKS

Basic Envelope Operations on page 192

Setting Up the Effect Morphing

Effect Morphing always involves two audio ranges.

PROCEDURE

1. In the Audio Files workspace, open the two audio files that you want to apply 
effect morphing to.

2. In the wave window, make a selection range over the time that you want the 
effect morphing to take place.

3. Process this range by using any Master Section effects or offline processing.
You cannot use processing/effects that alter the length of the selection, for example, 
time stretching.

4. Select Edit > Effect morphing.

5. Make sure that Unprocessed selection is activated.
The current processed selection is mixed with an unprocessed version of the same 
selection.

6. Adjust your envelope points over time between 0 % and 100 %.
This determines the level and direction of the morph. For example, starting at 100 % 
and ending at 0 % fades out the effect.

7. Click Apply to apply the effect morphing.
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Morphing Effects of Differently Processed Audio Segments

Effect Morphing can take place between two differently processed audio segments.

PREREQUISITE 

In the Audio Files workspace, make a range selection, and process the selection.

PROCEDURE

1. Select the result, and press [Ctrl]/[Command]-[C].

2. Undo the processing.

3. Process the selection again, this time with a different effect.

4. Select Edit > Effect morphing.

5. Activate Clipboard.

6. Select Apply.

RESULT 

The curve enables you to morph between two different processing methods.

NOTE

The clipboard could also be a copy from another wave file, but the clipboard size 
and the selection size must match.
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Audio Montage

The audio montage is a multichannel and multitrack non-destructive editing 
environment which allows you to arrange, edit, play back, and record audio clips on 
multiple tracks and channels.

Non-destructive means that when you delete or change a part of an audio file, the 
audio is not deleted or permanently changed. Instead, a set of pointers keeps track 
of all the edits, so these can be readily reversed. WaveLab provides comprehensive 
facilities for non-destructive editing.

Features include both track- and clip-based effects, volume and pan automation, as 
well as wide-ranging fade and crossfade functions. Multichannel support makes it 
possible to create surround mixes that can be written to DVD-Audio compatible 
discs.

The audio montage is a great tool for Audio CD or DVD-Audio creation, mastering, 
multimedia work, radio spot production, etc.

Basic Terminology

Audio montages can contain an unlimited number of stereo or mono audio tracks. 
You can use them to structure the work graphically or logically, but do not see them 
as virtual tape tracks. Depending on the channel configuration of the audio 
montage, you can route each track to a stereo output or route each track to different 
surround channels (up to 6) or non-surround audio channels (up to 8).

On an audio track, you can place any number of clips. These are containers for the 
audio, and include a number of settings and functions such as volume and pan 
curves, fades, etc.

A clip contains a reference to a source audio file on your hard disk, as well as start 
and end positions in the file (allowing clips to play back smaller sections of their 
source audio files). Any number of clips can reference the same source file.

In addition to audio tracks, you can create DVD-Audio picture tracks in the audio 
montage.
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Montage Window

The montage window in the Audio Montage workspace is where you assemble your 
audio montage. This is where you view, play back, and edit audio montages.

The montage window gives you a graphical representation of the tracks and clips.

Track Control Area

The track control area offers several options regarding the track.

Fold/Unfold

Folds/unfolds the track.

Mute

Mutes the track.

Solo

Solos the track.

FX

Opens the Effects menu in which you can select effects for the track. A blue 
icon indicates that a track has track effects.

Track menu

Opens the track menu that contains track-related options.
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Audio Track Dispatching

Opens the Audio Track Dispatching dialog in which you can route a track to 
an output channel.

Track name

Opens the Track name dialog where you can enter a name for the track.

Track Menu

This menu contains all track-related options. In the Audio Montage workspace, 
open the Track menu, or click the number button of a track.

Add stereo track

Adds a stereo track below the active track.

Add mono track

Adds a mono track below the active track.

Add picture track

Adds a picture track below the active track.

Move track up

Moves the track one position up in the track list.

Move track down

Moves the track one position down in the track list.

Virtual-split into two mono tracks

Converts the stereo track into two mono tracks without altering the audio 
material.
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Duplicate track

Creates a copy of the active track. The duplicated track is created below the 
active track.

Remove track

Deletes the active track.

Mute

Mutes the active track.

Solo

Solos the active track.

Route to Master Section

Routes the audio signal of the active track to the Master Section input.

Route to Master Section and upper track

Routes the audio signal of the active track to the Master Section input and to 
the modulation input of the Ducker plug-in.

Route to upper track only

Routes the audio signal of the active track to the modulation input of the 
Ducker plug-in.

Record at cursor

Opens the Recording dialog to start recording at the cursor position.

Lock

If this option is activated, you cannot edit the track.

Half-height

Reduces the track height to half the current size.

Quarter-height

Reduces the track height to a quarter of the current size.

Zoom

Shows the active track in the full available height.

Color

Opens a submenu where you can select a color for the active track.

Signal Flow in the Audio Montage

The audio signal flow goes through the various sections of WaveLab in a certain 
way.

• Read audio clip samples

• Clip envelope (unless post-effects mode is active)

• Clip effects
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• Clip envelope (if post-effects mode is active)

• Clip pan

• Clip individual gain (Clips window)

• Clips are mixed into the track slot (for example, overlapping clips)

• Track effects

• Track leveling/surround pan

• Each track is mixed into a bus that has as many channels as defined by the 
Audio montage properties (between 1 to 8, usually 2).

• These audio channels are processed through the plug-ins of the master 
output.

• These channels are then sent to the Master Section input.

Master Section:

• Channels/sample rate might change at each plug-in slot

• Master Section meters

• Master Section Dithering slot

• Independent meters

• Playback or file format rendering

Creating a New Audio Montage

You can add tracks and clips to your new audio montage.

PROCEDURE

1. In the Audio Montage workspace, select File > New.

2. In the Audio montage properties dialog, select a Mode, Channels, and a 
Sample rate.

3. Click OK.

Audio Montage Properties Dialog

This dialog allows you to define the mode (stereo, mono, or multichannel), the 
number of audio channels, and the sample rate of the project.

This dialog open when you create a new audio montage.
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To change the settings for the currently opened audio montage, select Edit > 
Audio montage properties.

Mode

Lets you select the following modes for audio montage projects.

• CD creation, optimized for a stereo mixdown

• Multichannel configuration (1-6 output channels), compatible with the 
DVD-Audio format

• Free multichannel configuration (8 output channels)

Channels

Lets you define the number of audio channels and their configuration at the 
output of the audio montage. This is only available when Multichannel, 
DVD-Audio compatible mode is selected.

Enable additional DVD-Audio configurations

Enables additional DVD-Audio channel configurations in the channels pop-up 
menu. This is only available when Multichannel, DVD-Audio compatible 
mode is selected.

Sample rate

Lets you select the sample rate of the audio montage.

Alternative Ways of Creating a New Audio Montage

There are several ways to create a new audio montage.

• Import cue-sheet/CD images as audio montage

• Import audio CD tracks to an audio montage

• Convert a Basic Audio CD into an audio montage

• Create an audio montage from a wave file with the Auto Split function

• Import an AES-31 project file to an audio montage

• Import an XML text file to an audio montage

• Convert wave files to an audio montage

• When you render, you can open the resulting file into a montage.

• File > New from
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• File > Import > Audio Montage copy

• File > Import > Audio DDP image

• File > Clone

• File > Export > Clone completly

• Press [Ctrl]/[Option], and drag a montage tab on the tab bar

• Double-click an empty section of the tab bar

• From a script

Creating an Audio Montage from an Audio File

You can export audio files to an audio montage, including all markers that you have 
set in the audio file.

PROCEDURE

1. Optional: If you only want to use a certain time range of the audio file, create 
a selection range in the wave window.

2. In the Audio Files workspace, select File > Export > Create audio montage 
from active file.

3. Select whether to export the whole file or the selected time range.

4. Optional: Decide if you want to perform any of the following marker 
operations:
• Import markers
• Split at generic region markers
• Split at CD Track markers

5. Click OK.

Import Options for Audio Montages

You can import different files into your audio montage, for example, audio files, audio 
montages, and DDP images.

In the Audio Montage workspace, select File > Import. The following import 
options are available:

Insert audio files

Opens the file browser where you can select one or more audio files to insert 
at the edit cursor position on the focused track.
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Insert clips

Opens the file browser where you can select one or more previously saved 
clips to insert at the edit cursor position on the focused track. If you import 
several clips at the same time, they will be lined up in alphabetical order, 
according to their file names, and separated according to the set pre-gap.

Insert audio montages

Opens the file browser where you can select an audio montage to insert at 
the edit cursor position on the focused track.

Insert surround audio files

Opens the file browser where you can select a surround audio file to insert at 
the edit cursor position on the focused track. The audio montage must be set 
to Multichannel, DVD-Audio compatible mode with 6 channels.

Each file is placed on a different track, and routed to the corresponding 
surround output. Mono surround channels are placed on mono tracks and 
stereo surround channels on stereo tracks.

Audio CD

Opens the Import Audio CD dialog where you can browse for audio CD 
tracks to extract.

Audio DDP image

Converts a DDP image to an audio montage.

Audio CD cue file

Converts a CD cue file with its audio data to an audio montage.

Basic Audio CD

Converts a Basic Audio CD to an audio montage.

Audio montage copy

Creates a copy of an existing audio montage and opens it.

AES-31 file

Converts an AES-31 file to an audio montage.

Audio montage as XML file

Opens an audio montage that has been previously saved as an XML file.

List of files to open

Opens all files that are listed in a text file.
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Missing Files in Audio Montage Dialog

This dialog opens when you open an audio montage, and some audio files that the 
audio montage refers to could not be found. You can then search for the files or 
select a replacement.

Missing files list

Lists the files that could not be found. Each file can be replaced by an existing 
file. To search replacements for multiple files, select the files and specify a 
new path in the Where to search field.

A file with a green checkmark is associated with a valid replacement. A file 
with a red checkmark is not yet associated with a valid replacement, but there 
are possible replacement candidates available at the bottom of this dialog.

Find files with the same name

Instructs WaveLab to find all files with the same name in the folder specified 
in the Where to search field.

Replace selected files with

Replaces the missing files with a single specific file.

Reset

Removes all possible replacements for the selected missing files.

Where to search

Lets you specify a location for searching files. Click Find files with the same 
name to start the search.

Replacement list

Lists the files that can be used as a replacement. You can also drag a file into 
the list from the Windows Explorer/Mac OS Finder.
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Assembling the Audio Montage

You assemble your audio montage by adding tracks and clips.

In the audio montage, only one track can be focused at a time. This focused track 
has a different color for the header. Certain WaveLab functions are always applied 
to the focused track.

About Tracks

Tracks form the structure that is used to organize clips. The tracks can be 
mono/stereo audio tracks or picture tracks.

• Audio tracks allow you to add clips to an audio montage.

• Picture tracks allow you to add pictures to an audio montage. These are 
shown when you play back the final DVD-Audio.

Adding Tracks

You can add stereo tracks, mono tracks, and picture tracks.

• In the Audio Montage workspace, click the number button of a track to open 
the Track menu, and then select the type of track that you want to add to your 
audio montage.

NOTE

By default, the new track is added below the focused track. If you want to place it 
above the focused track, press [Ctrl]/[Command] when adding the new track.

Adding Pictures to a Picture Track

PROCEDURE

1. In the Audio Montage workspace, add a picture track to your audio montage.

2. On the picture track, set the edit cursor at the position where you want to 
insert the picture.

3. Right-click an empty area of the picture track, and select Insert files.

4. Select a picture, and click Open.
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Moving Tracks in the Track View

You can change the order of the tracks in the montage window.

PROCEDURE

1. In the Audio Montage workspace, click a track’s number button.

2. Select Move track up/Move track down.

Removing Tracks

Removing a track with clips also removes the clips. However, the audio files to 
which the clips refer are not affected.

PROCEDURE

1. In the Audio Montage workspace, click the number button of the track that you 
want to remove.

2. Select Remove track.

Folding and Unfolding Tracks

To save screen space in the Audio Montage workspace, you can fold tracks that do 
not need to be visible.

• To fold a track, click the arrow button at the top left corner of the track control 
area.

• To unfold a folded track, click the button again, or double-click anywhere in 
the folded track.

Locking and Unlocking Tracks

You can lock tracks to prevent them from being accidentally moved, edited, or 
deleted.

• To lock a track, click the number button of the track, and activate Lock. The 
waveform is marked with stripes to indicate that the track is locked.

• To unlock a track, click the locked track, and confirm the dialog, or click the 
number button of the track, and deactivate Lock.
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Splitting Audio Tracks

You can split a stereo audio track into two mono tracks. This is a virtual split which 
does not affect or create audio files.

PROCEDURE

1. In the Audio Montage workspace, click the number button of the track that you 
want to split.

2. Select Virtual-split into two mono tracks.

RESULT 

The track is split. If the track has no clips, this is the same as deleting the track and 
inserting two new mono tracks. However, if there are clips on the track, the two 
stereo sides are now separate clips, allowing you to move, edit, or process them 
independently.

About Clips

A clip contains a reference to a source audio file on your hard disk as well as start 
and end positions in the file, volume and pan curves, fades, etc. This allows clips to 
play back smaller sections of their source audio files.

Any number of clips can reference the same source file. Since a clip only references 
to the original source file, it contains no audio data. Any number of clips can 
reference the same source file.

You can also use envelopes and effects on clips.

You can see the clips of the active audio montage in the Clips window.

3 clips on a track

Adding Audio Clips to the Audio Montage

You create clips by copying audio selections into the audio montage. There are 
several ways to do this.

NOTE

You cannot add a mono clip to a stereo track or vice versa.
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Dragging from the Wave Window

PROCEDURE

1. In the wave window of the Audio Files workspace, select the audio section 
that you want the clip to refer to.

2. Drag the selection on a track of the audio montage.
If you want to add the whole audio file, drag the tab on a track.

3. Select an insert option from the pop-up menu that appears when you release 
the mouse button.

RESULT 

A clip is created, named after the original file.

Inserting From Open Wave Windows Using the Insert Menu

PREREQUISITE 

In the Audio Files workspace, open the audio files that you want to insert as clips.

PROCEDURE

1. In the Audio Montage workspace, right-click an empty part of a track.

2. From the pop-up menu, select the audio file that you want to insert as clip.

Using Copy and Paste

PROCEDURE

1. In the wave window of the Audio Files workspace, select the audio section to 
which you want the clip to refer to.

2. Select Edit > Copy, or press [Ctrl]/[Command]-[C].

3. In the Audio Montage workspace, select the track where you want to insert 
the clip.
The clip insert position is indicated by the edit cursor.

4. Select Edit > Paste, or press [Ctrl]/[Command]-[V].

5. Select an insert option from the pop-up menu.
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Dragging Audio Files From the File Browser Tool Window

NOTE

The following can also be done from the Windows Explorer/Mac OS Finder.

PROCEDURE

1. In the Audio Montage workspace, open the File Browser window.

2. Select the audio files to which you want the clip to refer, and drag them on a 
track, or double-click the file to insert it.
• If you have selected a single audio file, the Insert pop-up menu opens.

• If you have selected several audio files, the Insert Audio Files dialog opens.

3. Depending on whether you have selected one or several audio files, do one 
of the following:
• If you have selected a single audio file, select an insert option from the pop-up 

menu.

• If you have selected several audio files, specify how the files should be ordered 
and placed, and click OK.

Dragging Regions From the File Browser Tool Window

If you have defined marker regions in an audio file, you can drag these regions 
directly from the File Browser onto a track.

PROCEDURE

1. In the Audio Montage workspace, open the File Browser window.

2. Select the audio file to which you want the clip to refer.
On the right side of the File Browser window, a list shows the available audio regions 
of the selected file.

3. Drag any region to the track.

4. Select an insert option from the pop-up menu.

Importing Audio Files

PROCEDURE

1. In the Audio Montage workspace, select the track on which you want to put 
the clip.
The clip insert position is indicated by the edit cursor.

2. Right-click an empty area on the track, and select Insert audio files from the 
pop-up menu.

3. Select the audio files that you want to import as clips, and click Open.
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4. Depending on whether you have selected one or several audio files, you have 
the following options:
• If you have selected a single audio file, select an insert option from the pop-up 

menu.

• If you have selected several audio files, specify how the files should be ordered 
and placed, and click OK.

Copying Clips From Another Audio Montage

If you have opened more than one audio montage, you can copy clips from one 
audio montage to another, either by using drag and drop or by using copy and 
paste.

Dragging Clips From the Clips Tool Window

You can add clips that are already used in the same audio montage.

PROCEDURE

1. In the Audio Montage workspace, open the Clips window.

2. Select one or several clips, and drag them to a track.
If you have selected a single audio file, select an insert option from the pop-up menu.

Clip Inserting Options

When inserting a clip in another clip, you can choose between different clip 
inserting options. For example, you can create default fades. You can also insert 
multiple clips at the same time.

You can insert clips by pasting, importing from disk, using drag and drop, etc. When 
inserting multiple clips at the same time, the Insert audio files dialog opens, in 
which you can decide where to insert the files.
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Single Clip Inserting

When adding a single clip to an audio montage, a pop-up menu appears at the 
insert position. By selecting one of the menu items, you specify how the clip should 
be inserted, whether existing clips should be affected or not, etc.

Add/Mix

Inserts the clip without affecting any clips that already exist on the destination 
track. However, if an inserted audio clip partially overlaps another audio clip, 
a crossfade is created in the overlapping zone provided that an auto 
crossfade option is active.

Add/Mix & bind right clips (track)

When the clip is inserted, all clips to the right of the clip (on the same track) 
are moved to the right.

Add/Mix & bind right clips (global)

When the clip is inserted, all clips to the right of the clip (on all tracks) are 
moved to the right.

Split/Insert

Only available if the insertion point is within an existing clip (audio tracks only). 
When the clip is inserted, the existing clip is split and the right section is 
moved to the right. Other clips are not affected.

Split/Insert & bind right clips (track)

Applies the Split/Insert function and moves all other clips on the same track 
to the right (audio tracks only).

Split/Insert & bind right clips (global)

Applies the Split/Insert function and moves all other clips on all tracks to the 
right (audio tracks only).

Replace selected range

Only available if there is a selection range on the destination track. The clip 
with the selection range is split at the selection range edges, the inserted clip 
replaces the range, and the section to the right of the range is moved to the 
left or right (depending on the length of the inserted clip and the length of the 
selection range), to prevent gaps behind the inserted clip.
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Replace selected range (trim source accordingly)

Only available if there is a selection range on the destination track and if that 
selection range is shorter than the range of the clip that is to be inserted. The 
inserted clip overwrites only the selected range, for example, the range to be 
inserted is trimmed according to the current selection.

Replace selected range & bind right clips (track)

Applies the Replace selected range function and moves all other clips on the 
same track to the right.

Replace selected range & bind right clips (global)

Applies the Replace selected range function and moves all other clips on all 
tracks to the right.

Overwrite from cursor

If the inserted clip overlaps any other clips, the overlapped regions are 
removed from the existing clips.

Make next choice persistent

If this option is activated, you can select a default option from the menu. This 
default option is used when inserting audio. However, there are two 
exceptions:

• If the option is not compatible with the context, it is not processed and 
the default option is deactivated. For example, when using Replace 
selected range while there is no range selected.

• You can fully deactivate this option by deactivating Options > Use 
default insert action.

Cancel

No clip is added.

Multiple Clips Inserting

When you add multiple audio clips to an audio montage by importing from disk or 
using drag and drop, the Insert Audio Files dialog appears.
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Arrow up/down

Moves the selected file up/down in the list.

Add file

Opens the file browser where you can select files to be added to the list.

Remove file

Removes the selected file from the list.

Line up on the current track

If this option is activated, the clips are added to the audio montage, lined up 
contiguously on a single track and spaced according to the pre-gap. The 
pre-gap can be defined in the Audio montage preferences.

Shift existing clips to the right

If this option is activated, any already existing clips in the audio montage are 
moved to the right by an amount equaling the length of the first new added file.

Place each file on a different track

If this option is activated, the clips are added to the audio montage on 
separate tracks, according to the following settings.

Start inserting below focused track

If this option is activated, the new tracks for the added files are inserted below 
the focused track.

Always create new tracks (otherwise only create when required)

If this option is activated, and you add more files to an audio montage, they 
end up on separate tracks.

RELATED LINKS

Dual-Mono Files on page 145

Mismatched Sample Rates When Inserting Audio Files

When inserting audio files with a different sample rate than the sample rates of the 
audio montage, WaveLab can create and use resampled versions of the files.

The resampled file versions are created in the implicit folder that is defined in the 
Audio montage preferences. The name of the file is the name of the original file 
name with the new sample rate as suffix. If the resampled file already exists, it is not 
recreated. However, you can also activate the option Recreate resampled files in 
the Mismatched sample rates dialog.

The created file is a 32-bit float file without any dithering process.

If you modify the original audio file, you must use the Replace audio file option in 
the Focused clip window to select the modified audio file. This will recreate the 
resampled file.
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Mismatched Sample Rates Dialog

This dialog opens when you insert an audio file with a different sample rate than the 
sample rate of the audio montage. This dialog lets you create a resampled copy of 
the audio file.

Resampling quality

This option allows you to select the resampling quality.

Recreate resampled files

If this option is activated and a resampled file exists, it is recreated. Otherwise, 
the existing version is used. Activate this option if the original audio file has 
been modified and you want to recreate its resampled version.

Empty Clips

If the audio file of a clip is missing, the clip is displayed as an empty clip. This way 
the length and position of the clip is visible, even if the corresponding audio file is 
unavailable.

Empty clips can also be used for the following:

• To create audio montage templates with empty clips as place holders.

• As an alternative to muting a clip. The difference is that for empty clips no 
audio is copied when cloning the audio montage.

• To define regions. Since a clip has a start and end point in the audio montage, 
it defines a range which can be used as a reference for any purpose.
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Creating Empty Clips

You can create an empty clip out of a selection range.

PROCEDURE

1. In the Audio Montage workspace, make a selection range.

2. Right-click an empty area of the track, and select Create empty clip from 
selection range.

Removing the Source of a Clip

By removing a source file of a clip you create an empty clip.

PROCEDURE

1. In the Audio Montage workspace, select the clip for which you want to remove 
the source audio file.

2. In the Focused clip window, open the Edit panel.

3. Right-click the Replace audio file option, and select Remove source.

Saving and Loading Clips

You can save clips to disk as separate files. This is useful if you have, for example, 
created a perfect fade, envelope, or clip effect configuration, but want to continue 
experimenting with the clip in the audio montage.

By saving the clip, you can always revert to the perfect version by reloading it. 
However, saved clips are still a reference to the original source file and contain no 
audio data.

Saving Clips

PROCEDURE

1. In the Audio Montage workspace, right-click the bottom area of a clip.

2. From the pop-up menu, select Save.

3. Specify a name and location, and click Save.
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Loading Clips

PREREQUISITE 

Select a stereo track for stereo clips and a mono track for mono clips.

PROCEDURE

1. In the Audio Montage workspace, on an empty part of a track, right-click 
where you want to insert the clips.

2. From the pop-up menu, select Insert clip files.

3. Select a “.clip” file, and click Open.

RESULT 

The clips are inserted on the focused track. If you selected more than one clip, the 
first clip is positioned at the audio montage cursor, and any following clips are 
spaced according to the default pre-gap time that is set in the Audio Montage 
Preferences. When you import several clips, they are sorted alphabetically 
according to their the file names.

Rearranging Clips

You can freely arrange clips in the montage window.

About Selected and Focused Clips

There is a distinction between selected and focused clips. Some editing functions 
can only be processed on an individual clip or focused clip, while others can be 
processed on multiple clips or selected clips.

• A selected clip is a clip that you have selected using any of the selecting clips 
procedures. Several clips can be selected at the same time. This allows you 
to edit multiple clips at the same time using functions such as copy, delete, 
move, etc. Selected clips have a different background color. Right-clicking in 
the top part of a clip opens the Clip selection menu. More options for the 
selected clips are available in the Clips window.

• A focused clip is the clip that you selected, clicked, or edited last. Only one 
clip can be focused at a time. By default, the focused clip is distinguished by 
a highlighted name label. There are certain functions that can only be 
processed on a focused clip. Right-clicking in the lower part of a clip opens 
the Focused Clip menu. More options for the focused clip are available in the 
Focused Clip window.
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About Mouse Zones

Basic rearranging of clips in the audio montage is achieved by clicking and dragging 
with the mouse. However, the results of dragging with the mouse depend on where 
in the clip you click. The different areas in a clip are called mouse zones.

By default, the mouse zones have the following basic functionalities:

Top clip area

• Copy a clip by dragging

• Open the source file by double-clicking

• Split at cursor position by 
double-clicking the edit cursor or 
pressing [S].

Upper clip area

• Make a selection range

• Open the Clip selection menu by 
right-clicking
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Lower and bottom clip area

• Move a clip by dragging

• Open the Focused clip menu by 
right-clicking

Clip edges

• Resize a clip by dragging the edges, 
while keeping the audio source static

• Resize the left or right side of a clip 
while letting the audio follow by holding 
[Ctrl]/[Command] and dragging the left 
or right edges

Clip name

• Open the effects menu by right-clicking 
the clip name

• Rename the clip by double-clicking
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When you move the mouse cursor over a mouse zone, the info line at the bottom 
left indicates the corresponding actions.

Info Line

The info line at the bottom of the Audio Montage workspace shows what happens 
when you click the mouse button with or without modifier keys, depending on the 
cursor position.

• To activate/deactivate the info line, select Options > Audio montage 
preferences, and on the All Audio Montages tab, activate/deactivate 
Display indications of possible actions.

The following symbols are used in the info line:

Indicates that you can right-click to display a menu. The name of the menu is 
displayed to the right of the symbol.

Indicates what happens when you click.

Indicates what happens when you double-click.

Indicates that you can [Ctrl]/[Command]-click for an additional function.

Indicates that you can [Alt]/[Option]-click for an additional function.

Indicates that you can [Shift]-click for an additional function.

Indicates what happens when you click and drag up or down.

Indicates what happens when you click and drag left or right.
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Indicates what happens when you click and drag an item in any direction 
within the audio montage.

Indicates what happens when you click and drag an item out of the audio 
montage.

This indicates that you are moving or resizing clips, or changing envelope 
values, for example.

Indicates that you can use combined modifier keys.

Magnetic Bounds in Audio Montages

Certain positions, such as markers or the start and end of a clip, can be defined as 
magnetic.

When you move or resize, for example, a clip, and its edges or its cue point get close 
to one of the magnetic bounds, the clip snaps to this position. A label is displayed, 
indicating to what the clip snaps. This makes it easier to position items accurately.

Activating Snapping to Magnetic Items

To make use of the magnetic bounds function, Snap to magnetic items must be 
activated.

PROCEDURE

• In the Audio Montage workspace, select Options > Snap to magnetic 
items, or click the Snap to magnetic items icon.

Magnetic Bounds Menu

In this menu, you can specify which positions should be magnetic. When Snap to 
magnetic items is activated, items that you move snap to these positions.

In the Audio Montage workspace, select Options > Magnetic bounds.

You can let items snap to the following positions:



Audio Montage
Rearranging Clips

233

Start of montage

Makes the start of the audio montage magnetic.

Clip start

Makes the start of the clips magnetic.

Clip end

Makes the end of the clips magnetic.

Clip cue point

Makes the cue point in the clips magnetic.

Clip end cue point

Makes the position that is located after the clip end magnetic. If this option is 
deactivated, all end cue points are invisible in the audio montage.

Time ruler marks

Makes the main time units that are displayed in the ruler magnetic.

Markers

Makes the markers magnetic.

Markers in audio sources

Makes the markers in the original audio files of the clip magnetic if they are 
visible.

Time selection edges

Makes the edges of the selected time range magnetic.

Cursor

Makes the edit cursor magnetic.

Selecting Clips

You can edit multiple selected clips at once.

• To select a clip, click in the bottom clip area. Selected clips are displayed in 
a different color.

• To select multiple clips, [Ctrl]/[Command]-click in the bottom clip areas.

• To select a range of clips, [Shift]-click them.

• To select several adjacent clips, double-click the upper area of a clip, and 
after the second click, drag to select the adjacent clips.

• To select several clips on several tracks with a selection rectangle, hold down 
[Ctrl]/[Command]-[Shift], and drag the rectangle.

• To choose between several clip selection options, in the Clips window, open 
the Select menu, or right-click the top clip area, and select from the menu.
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Selection Ranges in the Audio Montage Workspace

A selection range is a selected area on a track. The selection range can be entirely 
or partially within a clip or in an empty section of the track.

There are several uses for selection ranges:

• Edit clips by cutting or erasing the selection, or trimming the clip to contain 
only the selection.

• Create a new clip by dragging the selection range to another track.

• Open a montage window with the selection range from the source audio file 
by dragging the selection range to the Audio Files workspace.

• Play back only the selection range, either the whole audio montage or only the 
clip with the intersecting clip part .

• Loop the playback within the selection by activating the loop and selecting the 
Loop mode on the transport bar.

Creating and Editing Selection Ranges in the Audio Montage Workspace

You can resize, create, move, and remove selection ranges.

• To create a selection range in an empty area on a track, click and drag with 
the mouse. The start and end position and the length of the range are 
displayed in the info line.

• To create a selection range within a clip, click and drag with the mouse in the 
upper clip area. The start and end position and the length of the range are 
displayed in the info line.

• To create a selection range of the area between two markers, double-click 
between the markers.

• To create a selection range from a region marker pair, press [Shift], and 
double-click the start or end marker. In the Markers window, you can also 
double-click the Length field of a region marker.

• To create a selection range from a CD track, in the CD window, double-click 
the number to the left of the corresponding track.

• To create a selection range from a clip, in the Clips window, 
[Alt]/[Option]-click the number to the left of the corresponding clip. To zoom 
in on the selected clip, double-click the number to the left of the clip.

• To resize a selection range, [Shift]-click and drag left or right, or click and drag 
the edges of the selection range.

• To move a selection range while keeping its length, press [Ctrl]/[Command] 
and [Shift], and drag the selection range to the left or right.

• To remove a selection range, click elsewhere in the audio montage, or press 
[ESC].
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Clip Context Menus

Many editing functions for clips can be accessed via the clip context menus. 
Depending on where you right-click the clip, different context menus are available.

1) Fade-in section: Opens the Fade-in menu where you can edit the fade-in.

2) Bottom part of a clip: Opens the Focused clip menu where you can edit the 
focused clip.

3) Upper part of a clip: Opens the Clip selection menu where you can select 
certain areas of a clip, lock a clip, etc.

4) Sustain section: Opens the Envelope menu where you can edit the envelope.

5) Clip name: Opens the Effects menu where you can add effects to the clip.

6) Fade-out section: Opens the Fade-out menu where you can edit the 
fade-out.

Clip Editing

All currently used clips are displayed in the Clips window in the Audio Montage 
workspace. In this window, you can edit and rearrange clips and drag them in the 
audio montage.

The currently focused clip is highlighted in bold in the clips list.

RELATED LINKS

Clips Window on page 236
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Clips Window

This window contains a list of the clips that are placed in the currently active audio 
montage together with additional information about the clips.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Clips.

Clip List

In the columns of the clip list, you can edit the following settings for each clip:

• Name

• Track number

• Pre-gap

• Start and end time

• Length

• Gain

• Comment

You can also mute and lock clips, search for clip names, and play back a clip with 
or without pre-gap. The playback buttons work in the following way:

Playback from start with a pre-roll.

-[Alt]/[Option]

Playback from start with a long pre-roll.

Playback from start.

The blue Fx icon indicates that a clip has one or more plug-ins. Double-clicking the 
Fx icon activates the Effects window.

• To zoom in on the clip, click the name of the clip.

• To select the time range corresponding to the clip, [Alt]/[Option]-click the 
number to the left of the clip name.

• To perform both of the previous functions, double-click the number to the left 
of the clip name.
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Select Menu

Select all clips

Selects all clips in the audio montage.

Select clips on focused track

Selects all clips that are included in the focused track.

Select clips inside selected time range

Selects all clips that are fully encompassed in the selected time range on all 
tracks.

Select clips located before the cursor on the focused track

Selects all clips that have their end point left of the cursor on the focused 
track.

Select clips located before the cursor on all tracks

Selects all clips that have their end point left of the cursor on all tracks.

Select clips located after the cursor on the focused track

Selects all clips that start to the right of the cursor on the focused track.

Select clips located after the cursor on all tracks

Selects all clips that start to the right of the cursor on all tracks.

Inverse selection

Deselects all selected clips and selects all other clips.

Deselect all clips

Deselects all selected clips.

Functions Menu

Create super clip from selected clips

Replaces the selected clips with a super clip that refers to a sub-montage.

Export clip list as text

Opens a plain text version of the clip list in the default text editor.

Batch clip renaming

Opens the Batch renaming dialog in which you can batch-rename any 
number of clips.

Use audio file name for selected audio clips

Gives each clip the name of the audio file to which it refers.

Update BWF time stamps (selected clips)

Updates the time stamp of each audio file that is referenced by a selected clip 
to reflect the clip position in the audio montage.
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The file header of a WAV audio file may contain a time stamp in the Broadcast 
Wave Format. This time stamp makes it possible to insert audio at precise 
positions in different applications. The audio files are marked as modified and 
must be saved.

Move selected clips to their related BWF time stamp

Moves the selected clips to the positions that are contained in their source 
audio files, provided the audio files contain a time stamp.

Align clips

Opens the Align clips dialog which lets you align all selected clips on the 
focused track relatively to one another.

Resize selected clips to match the focused clip

Uses the length of the focused clip as reference to change the length of all 
selected clips.

Mute/Unmute selected clips

Mutes/unmutes all selected clips.

Lock/Unlock selected clips

Locks the clip to prevent that it is edited by accident.

Lock/Unlock moving and resizing

Locks the position and size of a clip. Other editing options are still possible.

Show/Hide source’s ruler and markers

Changes the visibility of the ruler and the marker display of the source audio 
files for all selected clips.

Options Menu

Only show clips externally selected

If this option is activated, only clips that are selected in the montage window 
are displayed. This is useful to display only the clips that belong to a given 
group (Groups window) or to a given audio file (File Browser window).

Show audio/picture clips

Shows the activated clip type.

Show global pre-gaps

Displays the length of the gap between the start of a clip and the end of the 
previous clip on any track in the Pre-gap column. If the clips overlap, the time 
is displayed in red.

Show pre-gaps by track

Displays the length of the gap between the start of a clip and the end of the 
previous clip on the same track. If the clips overlap, the time is displayed in 
red.

Zoom the clip when selected

If this option is activated when you select a clip in the list, the clip is displayed 
to fill the space in the track area in the most efficient way.
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Make clip entirely visible when selected

If this option is activated when you select a clip in the list, the track area is 
scrolled and/or zoomed to display the whole clip.

Filtering Clip Names

The search field allows you to filter the clips list for names.

You can search for text in the Name and Comment columns. The Comment 
column is only searched if it is the sorted column. Otherwise, the name column is 
searched. The Select All function only selects the filtered items.

• In the Clips window toolbar, click in the search field, and enter some letters 
of the clip that you are searching.

• To switch the focus from the search field to the clips list, press the arrow 
down key.

• To switch the focus from the clips list to the search field, press 
[Ctrl]/[Command]-[F].

Focused Clip Window

This window allows you to edit the focused clips using various tools. For example, 
you can edit the cue points, envelope curves, fade-in/fade-out, and colors of clips.

In the Audio Montage, select Workspace > Specific tool windows > Focused 
Clip.
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Edit

Edit plug-ins

Opens the plug-ins used by the focused clip.

Edit audio/Edit sub-montage

Opens the source file of the clip in the related workspace.

Zoom

Adjusts the view to display mainly the focused clip.

Play focused clip

Plays the focused clip from start to end.

Play focused clip with pre-roll

Plays the focused clip with a pre-roll. The amount of pre-roll is defined in the 
transport bar.

Play selection range inside clip

Plays the selection in the focused clip.

Split at cursor position

Splits the focused clip into two new clips, at the edit cursor or playback cursor 
position.

Create clip from selection

Creates a clip from the selection range.

Cut to clipboard

Cuts the focused clip to the clipboard.

Copy to clipboard

Copies the focused clip to the clipboard.

Erase part of clip inside selection range

Removes the intersection between the clip and the selected time range.

Erase selection and patch up

Removes the selection in a focused clip. If a second clip is created, it is 
crossfaded with the original clip.

Trim to selection

Resizes the selected part of the clip at both boundaries.

Delete clip

Deletes the focused clip.

Auto Split

Opens the Auto Split dialog where you can select how to split clips.

Repeat clip

Opens the Repeat Clip dialog where you can select how clips should be 
repeated.
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Clone and substitute

Creates a copy of the source audio file and makes the clip reference this new 
file. As a result, you can modify the new source file without affecting other 
clips of the original audio file. The cloned audio file is stored in the implicit 
folder, that is specified in the Audio Montage Preferences.

Replace audio file

Allows the clip to refer to another audio file while all clip settings are retained. 
The audio file must be at least as long as the end position of the clip. You 
cannot substitute a stereo file with a mono file or vice versa. Clicking the arrow 
icon opens a list of recently used folders.

Time stretch to cursor

Opens the Time Stretching dialog that allows you to time stretch the clip so 
that it ends at the audio montage edit cursor position. When this function is 
used, a clone of the original audio file is created, containing the audio range 
used in the clip. The process is applied to the clone, and the clip references 
to this file instead. Neither the original audio file nor other clips that refer to 
the same audio file are affected. The cloned audio file is stored in the implicit 
folder, that is specified in the Audio montage preferences.

Pitch shifting

Opens the Pitch Shift dialog, where you can change the pitch of the clip. 
When this function is used, a clone of the original audio file is created, that 
contains the audio range used in the clip. The Process is applied to the clone, 
and the clip references to this file instead. Neither the original audio file nor 
other clips that refer to the same audio file are affected. The cloned audio file 
is stored in the implicit folder, that is specified in the Audio montage 
preferences.

Save

Opens the Save Clip as dialog where you can select a file location. Clips get 
the “.clip” extension and can be reused in any audio montage.

Shortcuts

Opens the Customize commands where you can define shortcuts for all the 
commands that are found in the Focused clip window.

Options

Lock editing

Locks the clip to prevent accidental editing.

Lock moving and resizing

Locks the position and size of a clip. Other editing options are still possible.

Mute

Mutes the clip.
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Invert phase

Inverts the phase of the clip. An inverted phase is indicated by an icon in the 
wave window.

Source’s ruler and markers

Displays the markers in the source audio file of the clip in the clip, together 
with the ruler.

Cue Points

Cue point - Set at cursor

Sets the cue point at a fixed position from the start of the clip.

Cue point - Set at default pre-gap position

Sets the cue point before the start of the clip, at a distance governed by the 
default pre-gap position.

Cue point - Follows fade-in end point

Sets the cue point to be the fade-in end point.

Cue point - Follows fade-out start point

Sets the cue point to be the fade-out start point.

End cue point - Custom offset

Sets the end cue point at a custom position from the end of the clip. This 
option allows you to edit the gap individually for each clip.

If this option is deactivated, the default gap defined in the Audio Montage 
Preferences is used.

Envelope

The following options are available for all envelope types:

Envelope type menu

Sets the type of envelope. Depending on the selected type, different options 
are available.

The following options are available, when selecting Volume/Fades or Pan:

Reset all

Resets the envelope to its neutral form.

Delete selected points

Deletes the selected envelope points.

Deselect

Resets the selection status of all envelope points.
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Copy shape

Copies the envelope shape into a dedicated clipboard while excluding any 
fade part.

Paste shape

Replaces the envelope shape while excluding any fade part.

Presets menu

Lets you save and restore envelope presets.

Smoothing

Rounds the resulting envelope curve angles. This produces smoother, more 
natural envelope curves.

Lock

Hides the envelope curve points. This way, they cannot be edited with the 
mouse. However, you can drag the whole curve up or down.

The following options are only available, when selecting Volume/Fades:

Convert to stereo envelope

Creates independent envelopes for the left and right channels.

Reset level to 0 dB

Replaces the segments between the fade-in and fade-out points to a single 
neutral segment.

Reset selected points to 0 dB

Resets the selected points to their default level.

Raise selection with envelope

Adds volume envelope points and draws a curve to raise the audio level with 
20 ms fall and rise times. You can drag the created segment up and down to 
adjust the level.

Mute selection with envelope

Adds volume envelope points and draws a curve to mute the selection 
between the clip and the selected time range by lowering the volume to zero 
with default 10 ms fall and rise times.

Duck according to other track

Opens the Ducking options dialog. This allows you to create ducking effects 
between clips on two adjacent tracks while having the volume of one track 
lowered whenever there are clips on the other track.

Level/fade envelope after effects

Places the level/fade envelope after the clip effect section. This is useful when 
using dynamic processors that alter the level of the clip.

The following options are only available when selecting Pan:

Pan menu

Lets you select a pan mode.
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Fade-in/Fade-out

Zoom

Adjusts the view to display mainly the fade-in/fade-out part of the focused 
clip.

Copy

Copies the fade-in/fade-out shape to the clipboard.

Paste

Replaces the fade-in/fade-out shape and duration with the clipboard 
contents.

Paste shape only

Replaces the fade-in/fade-out shape with the clipboard contents. The original 
length is preserved.

Paste to selected clips

Replaces the fade-in/fade-out shape and duration of the selected clips with 
the clipboard contents.

Linear

Changes level linearly.

Sinus (*)

Changes level according to a sine curve. When used in a crossfade, the 
loudness (RMS) remains constant during the transition.

Square-root (*)

Changes level according to the square-root curve. When used in a crossfade, 
the loudness (RMS) remains constant during the transition.

Sinusoid

Changes level according to the sine curve.

Logarithmic

Changes level logarithmically.

Exponential

Changes level exponentially.

Exponential+

Changes level strongly exponentialy.

Crossfade compensation menu

Lets you select the crossfade compensation.

Set time

Sets the clip fade-in/fade-out time to the specified value.

Presets menu

Lets you save and restore fade presets.
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Apply default

Replaces the current fade-in/fade-out with the default setting saved from the 
Presets menu.

Smoothing

Rounds the resulting envelope curve angles. This produces smoother, more 
natural envelope curves.

Automatic changes

If this option is activated, the fade-in/fade-out is not changed automatically, 
for example, by automatic crossfading of overlapping clips. This is useful if you 
have set a fade that you do not want to be altered, even though you may want 
to overlap the clip with another clip.

This option is individual for each clip, as opposed to Mode > No automatic 
crossfading which is global.

Colors

On this panel, you apply the custom colors that you have set in the Audio Montage 
Colors dialog (Options > Colors).

Align Clips Dialog

This dialog allows you to align clips at specific intervals, with an optional space 
between them. You must select at least two clips to use this function.

In the Audio Montage workspace, in the Clips window, select Functions > Align 
clips.

NOTE

This tool ignores audio montage groups. This means that a clip can be moved 
independently from the group to which it belongs.
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Place clips one after the other, using end cue points as reference

Positions the selected clips successively on the focused track. Each clip is 
aligned to the end cue point of the preceding clip.

Place clips one after the other, with the gap below

Positions the selected clips successively on the focused track. In the time 
field, specify the time between the end of a clip and the start of the next clip.

Place clips one after the other, crossfading them over the time specified 
below

Crossfades all clips successively. In the time field, specify the crossfade time.

Place every

Lets each clip start at the specified interval from the start of the preceding clip. 
In this case, the clips can overlap each other. In the time field, specify the 
interval between the start of a clip and the start of the next one.

Treat overlapping clips on a track as one unit

All overlapping or adjacent clips on a track are treated as one unit. This means 
that all clips are shifted with the same offset.

Treat overlapping clips as one unit, regardless of their tracks

All overlapping or adjacent clips on a track are treated as one unit, even if they 
are on different tracks. This means that all clips are shifted with the same 
offset.

Only selected clips

If this option is activated, only selected clips are moved. For example, if a 
group of overlapping clips has any clip which is not selected, the whole group 
is not moved.

Only clips of focused track

If this option is activated, only clips of the focused track are moved. For 
example, if a group of overlapping clips has any clip which is not part of the 
focused track, the whole group is not moved.

Re-ordering Clips in the Audio Montage By Dragging

In the Clips window, you can re-order clips by dragging them to another position in 
the list.

PROCEDURE

1. In the Audio Montage workspace, open the Clips window.

2. In the clip list, drag a clip to another position in the list.
The option Move overlapping clips together is taken into account.

You can move more than one clip at the same time, by selecting multiple clips and 
dragging them. If more than one clip is selected, all clips between the leftmost 
selected clip and the rightmost selected clips are moved.
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Exporting the Clip List as Text

You can export the clip list as text to various formats. For example, the list contains 
the names, source files, tracks, and length of the clips in the active audio montage.

PROCEDURE

1. In the Audio Montage workspace, open the Clips window.

2. In the Clips window, select Functions > Export clip list as text.

3. Choose the information that you want to export and the output format.

4. Click OK.

RESULT 

The clip list opens in the selected output format. When selecting Print, the Print 
Preview window opens. The text file is stored in the specified folder for temporary 
files.

RELATED LINKS

Temporary Files on page 83

Export Clip List as Text Dialog

This dialog allows you to export the clip list in various file formats, or as printout. You 
can decide which information about the clips to include in the exported file.

In the Audio Montage workspace, in the Clips window, select Functions > Export 
clip list as text.
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About Moving and Crossfading Clips

You can let clips overlap other clips, move clips to another location, and create 
crossfades between clips.The Options menu in the Audio Montage workspace 
provides several options for defining the behavior when inserting, moving, and 
crossfading clips.

Moving Clips

NOTE

You cannot move mono clips to stereo tracks and vice versa.

PROCEDURE

1. Select the clips that you want to move.

2. Click the clip area, and move the clips in any direction.
While dragging, the info line displays the current start position of the clip you are 
dragging.

Moving Clips with Auto-Grouping

You can specify the behavior of clips when moving them horizontally. There are four 
different options that affect the result when moving clips. The options can be 
selected in the Audio Montage workspace on the Options menu.

RELATED LINKS

Options for Moving and Crossfading Clips on page 249

Optimized Crossfades When Snapping to Other Clips

If you line up clips so that one clip ends exactly where the next one starts, for 
example, by using Magnetic bounds, the waveforms at the intersection point 
probably do not match. To remedy a possible abrupt jump in level, that may result 
in pops and clicks, you can optimize the crossfade when snapping to other clips.

On the Options menu, activate Snap to waveform when crossfading. When this 
option is activated and you move a clip so that its start snaps to the end of another 
clip, the following happens:

• WaveLab scans the waveforms of the clips within a short range to find the 
position where the waveforms of the two clips match best. This is the same 
automatic phase matching as in the Zoom window. You can specify how far 
you want the program to scan into the clips, by selecting a Search range on 
the menu of the Zoom window.

• The position of the clip that you moved is adjusted slightly to achieve the best 
possible match between the waveforms. This creates a short crossfade.
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NOTE

This function only applies when moving from right to left, for example, when you let 
the start of the moved clip snap to the end of the clip on the left.

About Overlapping Clips

You can move clips so that they overlap each other.

Note the following:

• The tracks in the audio montage are polyphonic, which means that each track 
can play back several overlapping clips at the same time. Overlapping clips 
are transparent, allowing you to see the underlying clips and their waveforms.

• To select an overlapped clip, click the bottom clip area of the crossfade area.

• There are crossfading options that automatically adjust the volume envelope 
curves when you overlap clips.

Options for Moving and Crossfading Clips

The Options menu provides you with options that help you when moving and 
crossfading clips. You can choose how you want clips to be handled when they are 
moved, decide whether automatic fades are created or not, and select the behavior 
of clips when they are moved.

In the Audio Montage workspace, select Options.

Auto-shift clips on the right (on same track)

Moves all clips that are located on the right of the edited clip to the right. This 
option is taken into account when moving or resizing clips, and when inserting 
or pasting more than one clip at the same time.

Auto-shift clips on the right (on all tracks)

Moves all clips that are located on the right of the edited clip to the right. This 
option is taken into account when moving or resizing clips, and when inserting 
or pasting more than one clip at the same time.

Move overlapping clips together (on same track)

If this option is activated and you move a clip horizontally, all overlapping clips 
or clips with adjacent clip edges on the same track are also moved.

Move overlapping clips together (on all tracks)

If this option is activated and you move a clip horizontally, all vertically 
overlapping clips in the audio montage are moved.

Create default fades in new clips

If this option is activated, all new clips get the default fade-in and fade-out 
shape and length. For clips that are created by splitting a clip, only the default 
fade time is used.
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Lock fade times when adjusting clip edges

If this option is activated, the defined fade-in and fade-out lengths are locked 
to the clip start or end, even if you adjust the clip edges. This means that if you 
resize a clip by dragging its edge, the corresponding fade junction point 
moves accordingly, while maintaining the fade length.

No automatic crossfading

If this option is activated, no automatic crossfading is performed when clips 
overlap.

Automatic crossfading -- free overlaps

If this option is activated, automatic crossfades are created when a clip 
overlaps the edge of another clip on the same track. The length of the overlap 
determines the length of the crossfade.

Automatic crossfading -- fade-in constrains overlaps

If this option is activated, the fade-in length of a clip constrains the maximum 
possible overlap, and thus the crossfade time. If the clip on the right side (the 
clip with the fade-in in the overlap) is moved to the left, past the set overlap 
time, the other clip is progressively resized. Moving the other clip to the right 
(into the clip that contains the fade-in in the overlap) produces the same 
result.

Automatic crossfading -- fade-out constrains overlaps

If this option is activated, the fade-out length of a clip constrains the maximum 
possible overlap, and thus the crossfade time. If the clip on the left side (the 
clip with the fade-out in the overlap) is moved to the right, past the set overlap 
time, the other clip is progressively resized. Moving the other clip to the left 
(into the clip that contains the fade-out in the overlap) produces the same 
result.

Snap to waveform when crossfading

If this option is activated and you create a crossfade by dragging a clip 
towards another one located at its left side, the position of the moved clip is 
automatically adjusted to obtain a good correspondence between the clip 
waveforms. This correlation process provides a crossfade that is aligned in 
phase and thus sounds correct.

Auto-create crossfade and snap to waveform when snapping to left clip

If this option is activated and you move a clip to let its start snap to the end of 
another clip to its left, the clip is slightly moved to the left to create a short 
crossfade that is based on an optimal correlation between the two waveforms. 
This correlation process provides a crossfade that is aligned in phase and 
thus sounds correct.

Auto-create a crossfade when snapping to left clip

If this option is activated and you move a clip to let its start snap to the end of 
another clip to its left, the clip is slightly moved to the left to create a 
crossfade.
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The length of the crossfade is the fade-in length of the clip on the right. If the 
fade-in length is zero, the fade-out length of the left clip is used as a basis 
instead. If that length is also zero, the Create crossfade and snap to 
waveform when snapping to left clip function is performed if activated.

Allow automatic crossfading with clips on focused track

If this option is activated, crossfades are automatically created when you 
move a clip on any track so that it overlaps another clip that is located on the 
focused track.

Allow multiple automatic crossfades

If this option is activated, crossfades are automatically created for all moved 
clips that overlap other clips on their track. If deactivated, a crossfade is only 
created for the clip that you drag, even if several clips are moved 
simultaneously due to being selected.

Snap to magnetic items

If this option is activated, moved elements such as clip edges, time selection 
edges, cursor, and markers snap to the magnetic items that are activated in 
the Magnetic bounds submenu.

Magnetic bounds

From this submenu, select which items should be magnetic. The following 
items can be selected:

• Start of montage

• Clip start

• Clip end

• Clip cue point

• Time ruler marks

• Markers

• Markers in audio sources

• Time selection edges

• Cursor

Global envelope lock

If this option is activated, all envelopes are locked and cannot be edited with 
the mouse. The envelopes and their points are still displayed but cannot be 
selected or edited.
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Duplicating Clips

NOTE

You cannot copy mono clips to stereo tracks and vice versa.

PROCEDURE

1. In the Audio Montage workspace, select one or more clips.

2. Click the upper clip area and drag the clips in any direction.
While you are dragging the clips, a dotted line indicates where the first of the copied 
clips will be placed. The position is also indicated on the info line.

If you dragged a single clip, a pop-up menu opens. Select the option that you want 
to apply to the duplicate of the clip. If you dragged more than one clip, the duplicates 
are inserted, taking the auto-grouping settings into account.

Duplicating with Auto-Grouping

If you duplicate more than one clip, two of the auto-grouping settings on the 
Options menu affect the result.

• If Auto-shift clips on the right (on same track) is activated when you 
duplicate clips, all clips on the destination track to the right of the new copy 
are moved to the right.

• If Auto-shift clips on the right (on all tracks) is activated when you duplicate 
clips, all clips to the right of the new copy in the whole audio montage are 
moved to the right.

Repeating Clips

You can make a number of copies of a clip and lay them out at various intervals on 
the current track of your audio montage.

NOTE

The repeating clip function does not create overlapping clips.

PROCEDURE

1. If you do not know how many copies you need, but know roughly where you 
want to position the last clip in the row, click this position to place the edit 
cursor.

2. Right-click the lower area of a clip, and select Repeat clip.

3. In the Repeat clip dialog, select one of the following options:
• Select Count, and specify the number of copies.

• Select Repeat until cursor.
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4. Select one of the Placement options.

5. Click OK.

RESULT 

The copies are created. If you chose the Repeat until cursor option, the last clip 
starts on the left of the audio montage cursor.

Repeat Clip Dialog

This dialog allows you to specify the number of clones to produce and control their 
placement, alignment, and spacing.

In the Audio Montage workspace, in the Focused Clip window, on the Edit panel, 
select Repeat clip.

Number of clones - Count

Creates the specified number of clips.

Number of clones - Repeat until cursor

Creates as many clips as possible until the last clip crosses the edit cursor.

Placement - Place clips one after the other

Places the clips one after the other on the track.

Placement - Use end cue points as reference

Places the selected clips one after the other on the focused track. Each clip 
is aligned with the end cue point of the preceding clip.

Placement - Gap between clips

Sets the gap duration between clips.
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Placement - Place every

Places the copied clips in the time interval that you set in the field below. This 
is the interval between two succeeding clip starts.

Placement - Align with clips of focused track

Aligns the copied clips with the starting position of the clips on the focused 
track, including any offset value that you can set in the Offset field.

Placement - Insert copies at markers

Aligns the copied clips with certain markers. Specify these markers on the 
menus below.

Dragging Selection to Create New Clips

If you have made a selection range in a clip, you can copy this range to create a new 
clip.

PROCEDURE

1. In the Audio Montage workspace, create a selection range.
If the selection range covers more than one clip, only the section that is part of the 
focused clip is copied.

2. Click the upper clip area and drag the selection to the new position.
When you are dragging, the position of the pointer is displayed on the info line. 
Magnetic bounds apply.

3. Select one of the insert options.

NOTE

Envelopes and effects are not included when you copy selection ranges.
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Clip Resizing

In this context, resizing usually means moving the start and end points of a clip so 
that more or less of the original audio file is revealed.You can resize a clip while 
keeping the audio source static relative to the time line of the audio montage, or 
relative to the resized edge of the clip.

Resize Clips With a Static Audio Source

To resize clips, click the left or right edge of the clip and move the start or end point 
to the left or to the right.

The start and end positions and the length of the clip are displayed on the info line 
while you are dragging. You cannot drag the edge of a clip past the start or end 
point of the audio file to which it refers.

When you drag the right edge of a clip, the auto-grouping settings are taken into 
account. This means that if Auto-shift clips on the right (on same track) is 
activated, all the following clips on the track are moved when you resize the clip. If 
Auto-shift clips on the right (on all tracks) is activated, this applies to clips on all 
tracks in the audio montage.

If you press [Alt]/[Option], all selected clips are resized by the same value.

Resize Clips With a Tied Audio Source

When you resize a clip using this method, the audio source is tied to the edge that 
you are moving. This means that the audio is scrolled at the other edge of the clip. 
You [Ctrl]/[Command]-click the left or right edge of the clip and move the start or 
end point to the left or to the right.

The start and end positions and the length of the clip are displayed on the info line 
while you are dragging. Magnetic bounds and the auto-grouping options apply.

If you press [Alt]/[Option]-[Ctrl]/[Command] when resizing, all selected clips are 
resized by the same value.
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Resizing Clips by Trimming

You can use trimming to remove unnecessary material at the beginning and end of 
a clip.

PROCEDURE

1. In the Audio Montage workspace, select a range within a clip while 
encompassing the audio material that you want to keep in the clip.

2. Right-click the selection range, and select Trim to selection.

RESULT 

The clip is resized so that is contains only the selected audio.

Sliding the Audio in a Clip

You can adjust the position in the audio file to which the clip refers by sliding the 
audio within the clip, without resizing the clip.

PROCEDURE

1. In the Audio Montage workspace, position the mouse cursor over the lower 
area of the clip.

2. Press [Ctrl]/[Command]-[Alt]/[Option], and drag left or right to slide the audio 
source.
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Moving a Clip With the Audio Source Fixed

When you have resized the clip to only display a section of the audio source, you 
can move the clip while the audio source remains fixed in position.

PROCEDURE

1. In the Audio Montage workspace, position the mouse cursor over the lower 
area of the clip.

2. Press [Shift]-[Alt]/[Option], and drag left or right to move the clip.

This reveals other sections of the underlying audio source.

Splitting a Clip

You can split a clip in two.

PREREQUISITE 

Decide whether you want to automatically create crossfades between the left and 
right clip by activating/deactivating Options > Create default fades in new clips.

PROCEDURE

1. In the Audio Montage workspace, click the position where you want to split 
the clip.

2. Position the mouse cursor on the edit cursor position in the top clip area.
The cursor takes on the shape of a pair of scissors.

3. Double-click.

RESULT 

The clip is split in two. The two clips have the same name and settings. Envelopes 
and fades are converted so that the two clips play back as if they were still one clip.

To split clips on all track, select Edit > All tracks > Split at cursor position.
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Erase Selections of a Clip

You can erase a selection range within a clip.

Erase Part of Clip Inside Selection Range

If you right-click the lower area of a selection, and select Erase part of clip inside 
selection range, the selected range is removed. This results in a gap between two 
clips.

If Snap to waveform when crossfading or Auto-create a crossfade when 
snapping to left clip are activated on the Options menu, the position of the right 
clip is adjusted for the best possible phase match between the clips.

The auto-grouping settings are taken into account.

Erase Selection and Patch Up

If you right-click the lower area of a selection, and select Erase selection and 
patch up, the selected range is removed, and the right section of the clip is moved 
to the left to fill the gap.

If any of the automatic crossfading modes or the option Create default fades in 
new clips are activated on the Options menu, a default crossfade is created 
between the resulting two clips, to create a clean transition.

Erasing a Selected Time Range of a Clip

PROCEDURE

1. In the Audio Montage workspace, select a range.

2. Right-click the selection in the lower part of the clip, and choose one of the 
following options:
• Erase part of clip inside selection range
• Erase selection and patch up

Deleting Clips

There are two principal ways to delete a clip:

• Right-click a clip, and select Delete.

• Select a clip, and press [Delete]. Make sure that there is no selection range 
before deleting. Otherwise the range is deleted instead of the clip. To ensure 
that there is no selection range, press [ESC].
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Locking Clips

You can lock clips to prevent them from being accidentally moved, edited, or 
deleted.

PROCEDURE

1. In the montage window, select a clip.

2. Do one of the following:
• In the Focused clip window, select the Options panel, and activate Lock 

editing or Lock moving and resizing.

• In the montage window, right-click the upper half of a clip, and activate 
Lock/Unlock selected clips or Lock/Unlock moving and resizing.

• In the Clips window, select Functions, and activate Lock/Unlock selected 
clips or Lock/Unlock moving and resizing.

RESULT 

A lock symbol indicates that a clip is locked.

Unlocking Clips

Use one of the following ways to unlock a locked clip:

• Click the locked clip, and confirm the dialog.

• Open the Focused clip window, and on the Options panel, deactivate Lock 
editing or Lock moving and resizing.

About Clips and Cue Points

A cue point is a defined position marker that belongs to a clip. It may be positioned 
within or outside the clip. Cue points are displayed as dotted vertical lines.

When you move a clip, its cue point is magnetic to any edges, markers, or positions 
that are activated on the Magnetic bounds menu. There are several uses for this:
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• To set the cue point at a relevant position in the audio, and use it to align the 
clip with other clips, etc.

• To set the cue point before the start of a clip to position clips in a row with 
pre-defined spaces.

• To set the cue point at the fade-in or fade-out point of a clip, making it easy 
to maintain defined fade lengths when crossfading. Making the cue points 
magnetic makes it easy to select them.

NOTE

Each clip can only have one cue point. If you select another cue point insert option, 
the cue point is moved to a new position.

Using Cue Points

You can add one cue point for each clip.

PROCEDURE

1. In the Audio Montage workspace, click the clip position where you want to set 
a cue point.

2. Open the Focused clip window, and on the Cue points panel, select one of 
the following options:
• Set at cursor

• Set at default pregap position

3. Decide if you want to activate the following options:
• Follows fade-in end point

• Follows fade-out start point

• End cue point

About Nudging

The audio montage window has a special function for making fine adjustments, 
which is called nudging. The Nudge function is not restricted to the position of clips 
and can be applied to a number of objects and properties.

Each time that you use the nudge function, the selected element is nudged by a 
certain amount. By holding down user-specified modifier keys, you can nudge the 
element by smaller or larger amounts.

Generally, the magnetic bounds are not used when nudging. That is, the nudged 
elements do not snap to other positions but can be moved freely.
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Nudging

PROCEDURE

1. In the Audio Montage, select the objects that you want to nudge.
For example, if you want to adjust the position of a clip or any property of a clip, such 
as left/right edge, fade-in/fade-out length, etc., select the clip.

2. Select Edit > Nudge, and activate the element that you want to nudge.

3. Select Edit > Nudge, and select one of the Nudge - or Nudge + options, 
use the nudge icons on the transport bar, or the keyboard shortcuts.
By holding down the user specified modifier keys, you can nudge the element by 
smaller or larger amounts.

Setting the Default Nudge Impulse

You can define the nudge value that is used to adjust the elements. The large, small, 
and micro impulses are relative to the default value.

PROCEDURE

1. In the Audio Montage workspace, select Options > Audio montage 
preferences.

2. On the All Audio Montage tab, in the Basic amplitudes for nudging 
section, specify a default time for the nudge impulse in the Time field.

3. In the Gain field, specify the default impulse gain for the nudging volume.

4. Click OK.

Elements That Can Be Nudged

The nudge menu lists the elements and properties that can be nudged.

In the Audio Montage workspace, select Edit > Nudge.

Nudge - x10

Nudges the target to the left or down, with 10 times the amplitude that is 
defined in the Audio montage preferences.

Nudge + x10

Nudges the target to the right or up, with 10 times the amplitude that is 
defined in the Audio montage preferences.

Nudge -

Nudges the target to the left or down, with the amplitude that is defined in the 
Audio montage preferences.
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Nudge +

Nudges the target to the right or up, with the amplitude that is defined in the 
Audio montage preferences.

Nudge - /10

Nudges the target to the left or down, with 10 times less the amplitude that is 
defined in the Audio montage preferences.

Nudge+ /10

Nudges the target to the right or up, with 10 times less the amplitude that is 
defined in the Audio montage preferences.

Nudge - /100

Nudges the target to the left or down, with 100 times less the amplitude that 
is defined in the Audio montage preferences.

Nudge +/100

Nudges the target to the right or up, with 100 times less the amplitude that is 
defined in the Audio montage preferences.

Auto-select item

Attempts to automatically select what should be nudged, depending on your 
last action. For example, if your last action was to select or move a clip, the 
Clip position option is automatically selected in the Nudge submenu. In most 
cases, this allows you to use the nudge feature without having to manually 
select nudge elements on the submenu.

Clip position

Moves all selected clips.

Clip’s left/right edge

Resizes the focused clip. This function is similar to resizing with a static audio 
source.

Clip’s fade-in/fade-out

Moves the fade-in/fade-out junction points of the focused clip. If the envelope 
is a stereo envelope, both sides are adjusted.

Clip’s crossfade

Narrows or widens the crossfade zone by moving the junction points of both 
clips in the crossfade. This nudging only functions if you select the second 
clip (the one to the right) in a crossfade pair.

Edit cursor

Moves the edit cursor.

Left edge of selected time range

Moves the left edge of a selection range.

Right edge of selected time range

Moves the right edge of a selection range.
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Selected marker

Moves the selected audio montage marker. To select a marker, click it in the 
area above the ruler.

Volume of focused clip

Adjusts the volume of the focused clip step by step according to the Gain 
setting in the Audio Montage Preferences.

Volume of all selected clips

Adjusts the volume of all selected clips step by step according to the Gain 
setting in the Audio Montage Preferences.

Pan of focused clip

Adjusts the pan of the focused clip. Nudge + pans to the left and Nudge – 
to the right.

Pan of selected clips

Adjusts the pan of all selected clips. Nudge + pans to the left and Nudge – 
to the right.

Surround Pan of focused clip

Adjusts the Pan of the focused clip. Nudge + pans to the left and Nudge – 
to the right.

Surround Pan of all selected clips

Adjusts the Pan of all selected clips. Nudge + pans to the left and Nudge – 
to the right.

Audio Montages Within Audio Montages

You can insert external audio montages to an open audio montage or gather several 
clips of an audio montage to an internal sub-montage. This makes it easy to build 
large audio montages while hiding edit complexities inside other audio montages.

This also increases the performance of your system by providing options to freeze 
edits and audio effects in cached audio files.

An example: You have an album that is composed of 15 songs. Each song requires 
complex edits. In this case you can create 15 super clips, of which each one 
represents a song. The main audio montage will be composed of these super clips, 
while each song can have its own audio montage.

Moreover, because super clips can represent external audio montages with 
different sample rates, you could provide your songs in high-resolution audio (96k 
sample rate), and build an audio montage album in 44.1k for a CD and another 
album at 96k for a DVD-Audio, for example.

RELATED LINKS

Super Clips on page 264
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Super Clips

A super clip is the representation of another audio montage. It refers to an audio file 
that is the rendering of either an internal sub-montage or an external sub-montage.

A super clip is handled as any other clip that you can split or copy, or to which you 
add fades and effects, etc.

You can reopen the super clip to edit the containing tracks and clips, and then 
render the changes to update the super clip.

A super clip can either be a mono or a stereo audio montage.

External Sub-Montages

A super clip can refer to an external sub-montage which is an audio montage in 
another file. An external sub-montage is independent from the audio montage in 
which you insert it.

External sub-montages can be shared between projects and used in audio 
montages with a different sample rate. They can be nested to any depth.

External sub-montage files can contain other external audio montages to any depth.

Super clips that refer to external sub-montages are indicated by a yellow icon.

A super clip that refers to an external sub-montage is also called X-Clip.

NOTE

An external sub-montage is a normal audio montage. The term “external” is to point 
out its inclusion in another audio montage.

Internal Sub-Montages

A super clip can refer to an internal sub-montage, which is an audio montage that 
is stored in the same file as the audio montage of the super clip. Such a super clip 
can be regarded as a folder that contains another audio montage.

Internal sub-montages are handled within a single audio montage file. For example, 
when you have finished editing certain clips of your audio montage, you can render 
them as a super clip.

An internal sub-montage cannot contain another internal sub-montage. However, it 
can contain super clips that represent external audio montages.

Super clips that are internal sub-montages are indicated by a blue icon.

A super clip that refers to an internal sub-montage is also called I-Clip.
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Creating a Super Clip

You can render clips of an audio montage to a super clip and thereby create an 
internal sub-montage or export the clips to an external audio montage.

PROCEDURE

1. In the Audio Montage workspace, open the audio montage in which you want 
to create a super clip.

2. Select the clips that you want to render to a super clip in the montage window 
or in the Clips window.

3. Select one of the following options:
• Right-click in the upper half of one of the selected clips, and select Create 

super clip from selected clips.

• In the Clips window, select Functions > Create super clip from selected 
clips.

4. In the Super Clip Creation dialog, decide whether to create an I-Clip (internal 
sub-montage) or an X-Clip (external sub-montage).

5. Optional: Enter a name for the super clip.

6. Click OK.

RESULT 

The clips are rendered as a super clip inside the audio montage.
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Super Clip Creation Dialog When Creating Super Clips from Selected 
Clips

In this dialog, you specify how to create super clips for internal and external 
sub-montages.

In the Audio Montage workspace, right-click the upper half of one or several 
selected clips, and select Create super clip from selected clips.

Name

Lets you specify the name for the super clip. For X-Clips, the name is also 
used as the name of the audio montage.

Create I-Clip (internal sub-montage)

Creates a new audio montage inside the open audio montage and inserts a 
super clip to reference it.

Place I-Clip

When creating a sub-montage from clips that reside on different tracks, you 
can specify on which track the super clip is inserted.

Export as external audio montage and create X-Clip (external sub-montage)

Creates a independent audio montage and a super clip that refers to this 
audio montage.

Destination

Lets you select the destination folder of the external sub-montage.

Include track effects

If this option is activated, the track effects are included in the sub-montage. If 
you want to keep the super clip on the track, deactivate this option.

Super Clip Creation Dialog When Inserting External Audio Montages

In this dialog, you can select whether to create X-Clips or I-Clips when inserting an 
external audio montage in another audio montage.

In the Audio Montage workspace, right-click the upper half of one or several 
selected clips, and select Create super clip from selected clips.
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If the sample rates of the external audio montage and the currently opened audio 
montage are the same, the following dialog opens:

If the sample rates of the external audio montage and the currently opened audio 
montage differ, the following dialog opens:

Create X-Clip (external sub-montage)

The super clip refers to the audio montage file.

Make a deep copy and create I-Clip (internal sub-montage)

The audio montage is copied into the other audio montage. The super clip 
refers to this independent copy.

Resampling quality

If the sample rate of the external audio montage and the currently opened 
audio montage differ, you can use the Crystal Resampler plug-in to perform 
a sample rate conversion.

Inserting External Sub-Montages into Audio Montages

You can insert an external sub-montage as a super clip into another audio montage.

PROCEDURE

1. In the Audio Montage workspace, open the audio montage in which you want 
to insert another audio montage.

2. Do one of the following:
• Right-click an empty area of the montage window, select Insert audio 

montages > Browse, select the audio montages that you want to insert, and 
click Open.

• Drag the audio montage that you want to insert from the Windows 
Explorer/Mac OS Finder or from inside WaveLab onto the montage window.
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3. In the Super Clip Creation dialog, select whether to create an X-Clip or an 
I-Clip, and click OK.

4. From the pop-up menu, select how to add and mix the external sub-montage.

RESULT 

The external sub-montage is rendered, and the resulting super clip is inserted at the 
edit cursor position.

Editing Super Clips

You can reopen super clips’ sources, edit the clips that they contain, and apply the 
changes to update the super clips of the external or internal audio montages.

The changes in the internal or externale audio montage are applied to the parent 
audio montage when the sub-montages are rendered.

Editing External Sub-Montage of a Super Clip

PROCEDURE

1. In the montage window, right-click the bottom area of a super clip of an 
external sub-montage and select Edit sub-montage, or double-click at the 
top area of the super clip.
The external sub-montage opens in another tab.

2. Edit the external sub-montage, and save the changes.

3. Decide on how you want to update the audio montage.
• To apply the changes to all audio montages that refer to the updated audio 

montage, select File > Export > Render for montages using it as a 
sub-montage.

• To apply the changes to a single audio montage, go back to the audio montage 
that contains the external sub-montage that you have updated. Select the 
updated audio montage, and in the Files window, select Menu > Update 
rendering of selected audio montage.

4. Save the audio montage.
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Editing Internal Sub-Montage of a Super Clip

PROCEDURE

1. In the montage window, right-click the bottom area of a super clip of an 
internal sub-montage and select Edit sub-montage, or double-click at the 
top area of the super clip.
The internal sub-montage opens in another tab.

2. Edit the clips of the internal sub-montage, and save the changes.

RESULT 

The changes are automatically rendered to update the super clip.

Freezing External Sub-Montages

Freezing external sub-montages renders the external sub-montage to an audio file 
while converting the super clips into regular clips.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Once a sub-montage has been frozen, it is no longer possible to edit it as an audio 
montage.

PROCEDURE

1. In the Audio Montage workspace, select the external sub-montage that you 
want to freeze.

2. In the Files window, select Menu > Freeze external sub-montage.

3. Specify a name and a location, and click Save.

Managing Source Files of Clips

The Files window helps you to manage files that are used in the current audio 
montage.

It displays all files that are used by clips in the current audio montage along with 
their location, size, and last modification date. In addition, the following file 
operations are available:

• Replace files in the audio montage

• Rename files (all internal clip references are updated)

• Open files that are used in the audio montage in the Audio Files workspace

• Export file names as text
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Files Window

This window helps you to manage files that are used in the current audio montage, 
including internal and external montages.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Files.

Files List

The files list shows the names, dates, sizes, and paths of the files that are used in 
the current audio montage. The location and type of the files determine how paths 
are displayed:

• If the path is relative to the file audio montage location, the path is displayed 
in green.

• If the path is on the same partition as the audio montage, for example in a 
subfolder, the path is displayed in blue.

• If the path is on another partition, the path is displayed in red.

• Internal sub-montages have no path.

Menu

Update rendering of selected audio montage

Renders the focused audio montage to a new audio file. This is necessary, to 
forward the changes that you have made in the selected sub-montage to the 
open audio montage.

Update outdated renderings

Renders all audio montages that have been modified since their rendered 
audio file was created.

Exchange file

Replaces the selected file with another one.

Freeze external sub-montage

Renders the external sub-montage to an audio file while converting the super 
clips into regular clips.

Rename file

Lets you change the file name. The internal references of the audio montage 
are updated accordingly.
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Export file names as text

Creates a text file that lists all files that are used in the active audio montage.

Select clips of selected file

Selects all clips that make reference to the selected file.

Edit audio

Opens the selected files in the Audio Files workspace. If the selected files are 
sub-montages, the related audio montage opens in the Audio Montage 
workspace.

Reveal in Windows Explorer

Opens the Windows Explorer/Mac OS Finder to locate the selected file.

Exchanging the Source File of a Clip

You can replace a source file of a clip with another file and have all clips that refer 
to the old source file refer to the new source file.

PROCEDURE

1. In the Audio Montage workspace, open the Files window.

2. In the Files window, select the file that you want to exchange.

3. Select Menu > Exchange file, or click the Exchange file icon.

4. Select the replacing file, and click Open.

Changing Name and File Location of Audio Files

You can change the name and location of an audio file in your audio montage 
project. All clips that reference this file are automatically updated.

PROCEDURE

1. In the Audio Montage workspace, open the Files window.

2. In the Files window, select the file that you want to rename.

3. Select Menu > Rename file, or click the Rename file icon.

4. In the Rename File dialog, enter a new name.

5. To enter a new file location, activate Change folder, and enter a new file 
location.

6. Optional: If you want the related clips to change their name according to the 
new file name, activate Rename related clips as file name.

7. Click OK.
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Exporting File Names as Text

You can export the file names list as text to various formats. The list contains the 
names and paths of the audio files in the active audio montage.

PREREQUISITE 

Set up your audio montage.

PROCEDURE

1. In the Audio Montage workspace, open the Files window.

2. In the Files window, select Menu > Export file names as text.

3. Choose the information that you want to export and the output format.

4. Click OK.

RESULT 

The file names list opens in the selected output format. When selecting Print, the 
Print Preview window opens. The text file is stored in the specified folder for 
temporary files.

Editing the Source File of a Clip

Editing the audio montage may require that you process or edit the actual audio files 
that are referenced by the clips.

Use one of the following methods to edit the source file of a clip:

• Right-click the bottom area of the clip that you want to edit, and select Edit, 
or double-click the top area of the clip. The source file of the clip opens in the 
Audio Files workspace. Edit the clip, save it, and return to the audio montage.

• Drag the clip onto the Audio Files workspace.

Note the following:

• Any editing that you perform this way affects all clips that use the audio file, 
including clips in other audio montages.

• You can undo/redo all changes in audio files. These changes are reflected 
immediately in all open audio montages.

• If you use File > Save as to save the source audio file with a different name, 
all open audio montages that refer to the file now refer to the new file.
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About Cloning and Substituting the Source File of a Clip

Cloning an audio source file avoids the risk that other clips are affected when the 
source file of a clip is edited.

Use the Clone and substitute function to create a copy of the audio source file, 
and make the clip reference to the new file. As a result, you can edit the source file 
without affecting other clips or the original audio file.

The cloned audio file has the original file name with the suffix “_#X”, where X is a 
number. The cloned audio file is stored in the implicit folder that is specified in 
Audio Montage preferences.

The implicit folder is used when WaveLab needs to create new files that can be 
referenced by an audio montage. Files that are stored in the implicit folder are not 
temporary, that is, they are not deleted when you close WaveLab. This is necessary 
since the audio montage contains references to the files.

Cloning and Substituting the Source File of a Clip

PROCEDURE

• In the Audio Montage workspace, right-click the bottom area of a clip, and 
select Clone and substitute.

RESULT 

A clone of the source file replaces the selected clip. All clips that are referring to the 
original file are referenced to the new file.

Replacing the Audio File of a Clip

You can replace the audio file of a clip to compare different takes.

NOTE

You cannot substitute a stereo file with a mono file and vice versa.

PROCEDURE

1. In the Audio Montage workspace, right-click the bottom area of a clip, and 
select Replace audio file.

2. Select the file to which you want to reference, and click Open.
Make sure that the selected audio file is long enough. It must at least cover the range 
between the start and end points of the clip.

RESULT 

The selected audio file replaces the clip. All clip settings are retained, and any other 
clip references to the replaced file are still available.
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Track Activity Indicator

The track activity indicator shows the volume level for audio tracks. It is located on 
the right side of the track control area in the Audio Montage workspace.

Instead of exact level readings the track activity indicator provides an overview of 
which tracks are currently playing back audio at what approximate level.

Envelopes for Clips

For clips in the audio montage, you can create envelopes for volume and fades and 
for panning.

You can create an independent volume envelope curve to automate volume, to 
create fades and crossfades, and to mute clip sections.

You can also draw pan envelopes to automate pan settings for clips. For mono clips, 
pan governs the left/right position in the stereo field. For stereo clips, pan sets the 
left/right balance.

Edit the envelope settings in the Focused clip window, or by right-clicking an 
envelope curve. The settings menu is different, depending on whether you click the 
fade-in part, the fade-out part, or the sustain part.

How the Envelope is Displayed

By default, all clips display a volume envelope curve. You can view the envelope as 
three separate envelopes: the fade-in part, the sustain part, and the fade-out part.

The points on the left and right side of the curve are the fade-in and fade-out 
junction points that separate the fade parts from the sustain part.
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The envelope curve indicates if points, fade-ins, or fade-outs have been defined. In 
addition to the curve, changes in the volume envelope are by default also reflected 
in the waveform.This can be activated/deactivated by selecting View > Map 
waveform to volume.

Selecting the Envelope

You can switch between volume/fade envelopes and pan envelopes.

PROCEDURE

1. In the Audio Montage workspace, select a clip, and open the Focused clip 
window.

2. On the Envelope panel, select which envelope to edit from the menu at the 
top.

Hiding the Envelope Curves

All clips display envelopes by default. You can hide these envelopes. However, 
hidden envelopes are still active.

PROCEDURE

• In the Audio Montage workspace, select a clip, open the Focused clip 
window, and on the Envelope panel, select Hide all.

Clip Envelope Editing

Curve points allow you to create volume curves, pan curves, and fade curves for a 
clip. You can edit the envelope curve by adding and moving curve points.

Editing Curve Points

Many of the editing operations that are commonly used in the context of your 
computer operating system can be applied when editing curve points. On top of 
these, a number of specific procedures apply.

• To add a curve point, double-click the envelope curve.

• To delete a curve point, double-click the curve point. The curve point between 
the sustain and fade parts of the envelope cannot be deleted.

• To delete several curve points, select the curve points that you want to delete, 
right-click one of the points, and select Delete selected points.

• To select a range of points, [Alt]/[Option]-click and drag to create a selection 
rectangle.
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• To move all selected points, click one of the selected points and drag.

• To raise or lower the value of two consecutive curve points, 
[Ctrl]/[Command]-click the segment between the points and drag up or 
down.

• To change the time position of two consecutive curve points, [Shift]-click the 
segment between the points and drag left or right.

• To raise or lower the entire envelope curve, make sure that no curve point is 
selected, click the envelope curve, and drag up or down. Do not drag a 
segment that is delimited by selected points.

• To adjust the envelopes in all selected clips, hold down [Alt]/[Option], and 
drag any envelope curve up or down. This is a quick way to adjust the level or 
pan of several clips at the same time and also to adjust both sides of a stereo 
envelope simultaneously.

• To move a fade-in/fade-out point vertically, [Ctrl]/[Command]-click and drag 
the fade point.

• To change the level or the fade in/out time of multiple envelopes at the same 
time, select the clips that you want to edit, then press [Alt]/[Option], and edit 
the envelope with the mouse.

Resetting Curve Points

You can reset curve points to the default level.

• To reset a single point to 0 dB, right-click the point, and select Reset 
selected points to 0 dB.

• To reset the whole envelope curve to default, right-click the envelope curve, 
and select Reset level to 0 dB.

Copying Envelopes

You can use existing envelope curves in other clips.

PROCEDURE

1. In the Audio Montage workspace, right-click on an envelope curve, and select 
Copy shape.

2. Right-click the envelope curve of the destination clip, and select Paste 
shape.
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Raising the Level of a Selection

You can raise the audio level with certain fall and rise times (by default 20 ms) and 
then adjust the level.

PROCEDURE

1. In the Audio Montage workspace, in a clip, select the range for the section 
that you want to raise in level.

2. Right-click the envelope curve, and select Raise selection with envelope.
The level of the selection range is raised.

3. Click the envelope of the selection range and drag up or down to adjust the 
level.

Muting a Selected Range of a Clip

You can mute a selected range by lowering the volume to -144 dB.

These muted sections are not affected when you drag the envelope curve up or 
down.

PROCEDURE

1. In the Audio Montage workspace, in a clip, make a selection range for the 
section that you want to mute.

2. Right-click the envelope curve, and select Mute selection with envelope.

RESULT 

The section is muted. A fade-in and fade-out of 20 ms is applied to the muted 
section.
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Envelope Smoothing

To produce smoother, more natural envelope curves, you can activate the 
Smoothing function. It can be used while drawing the envelope curve or it can be 
applied to an existing curve.

• To activate this function, open the Focused clip window, and on the 
Envelope panel, activate Smoothing.

Creating Envelope Presets

You can create envelope presets that you can later recall and apply to other clips. 
There are separate presets for the sustain parts (envelope presets) and the fade 
parts.

PROCEDURE

1. In the Audio Montage workspace, activate the clip with the envelope curve 
that you want to save as a preset.

2. Open the Focused clip window, and on the Envelope panel, click the 
Presets menu.

3. Select Save as.

4. Enter a name for the preset, and click Save.

Applying Envelope Presets

PROCEDURE

1. In the Audio Montage workspace, activate the clip to which you want to apply 
the envelope preset.

2. Open the Focused clip window, and on the Envelope panel, click the 
Presets menu.

3. Select a preset from the list.

RESULT 

The envelope curve is applied.
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NOTE

Volume envelope presets can only be applied to volume envelopes. Non-volume 
envelope presets (such as pan and effect presets) can be applied to any other 
non-volume envelope, but not to volume envelopes.

Locking the Envelope Curve

When an envelope curve is locked, the volume envelope curve points are hidden 
and cannot be edited with the mouse. However, you can drag the whole curve up 
or down.

PROCEDURE

1. In the Audio Montage workspace, activate the clip that you want to lock.

2. Open the Focused clip window, and the Envelope panel, activate Lock.

Locking All Envelope Curves

If you lock all envelope curves globally, they cannot be edited with the mouse.

PROCEDURE

• In the Audio Montage, select Options, and activate Global envelope lock.

RESULT 

The envelopes and their points are still displayed, but cannot be selected or edited.

Changing the Overall Volume Envelope of a Clip

The default envelope curve contains no volume envelope points. In this condition, 
you can still use the curve to change the overall volume for a clip.

PROCEDURE

1. In the Audio Montage workspace, place the mouse cursor on the envelope 
curve.
The mouse cursor takes on the shape of a circle with two arrows that point up and 
down.

2. Click and drag the curve up or down to change the clip envelope volume.
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Mono/Stereo Volume Envelopes

It is possible to display two volume envelope curves for stereo clips, allowing you to 
control the volume separately for the left and right channels.

• To convert a mono envelope to a stereo envelope, right-click the volume 
envelope of a clip, and select Convert to stereo.

• To convert a stereo envelope to a mono envelope, right-click the volume 
envelope of a clip, and select Convert to mono.

NOTE

Only volume envelopes can be converted to stereo.

About Pan Modes

The power of the sum of the channels drops by about 3 dB if a signal is panned hard 
left or right, compared to the same signal being panned center. This can be 
compensated with pan modes.

Experiment with the modes to see which fits best. The pan modes can be set for 
tracks, clips, and the master output.

• To set the pan modes for clips, use the pan modes menu in the Focused clip 
window on the Envelope panel, or use the pan modes menu and knob in the 
Effects window.

• To set the pan modes for tracks and the master output, use the pan modes 
menu and knob in the Effects window.

The following pan modes are available:

Pan Mode Description

Channel damp 
(0 dB/mute)

This mode does not compensate for power loss at all. If a signal is 
panned hard left or right, the power of the sum of the channels 
drops by 3 dB.

Constant power 
(+3 dB/mute)

This is the default mode. Regardless of the pan position, the 
power of the sum of the channels remains constant.

Channel boost 
(+4.5 dB/mute)

If this mode is selected and a signal is panned hard left or right, 
the power of the sum of the channels is higher than with a 
signal-panned center.

Channel boost 
(+6 dB/mute)

If this mode is selected and a signal is panned hard left or right, 
the power of the sum of the channels is higher than with a 
signal-panned center. This is the same as the previous option, but 
with even greater power boost.
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About Modulating Audio With Other Audio

You can use the audio signal of one track to modulate the compression factor of 
another track. The signal of the upper audio track (clip) is usually called the carrier 
signal, because it contains the audio to be transmitted.

The Ducker plug-in is used for this purpose as it lowers the volume of one signal 
whenever another signal is present.

RELATED LINKS

Ducking Clips on page 281

Ducking Clips

Ducking happens when the signal level on one track or channel is automatically 
lowered through the presence of another signal on another track or channel. You 
can create ducking effects between clips on two adjacent tracks.

If you activate the Duck according to other track option, the presence of another 
clip on an adjacent track causes ducking.

A typical application for ducking would be a music track with a commentary 
voice-over on another track. Whenever the commentary voice is heard, the volume 
of the music track is lowered by a certain level through automatically created volume 
envelope curves.

NOTE

• The method of ducking clips is independent from clip modulation, though they 
share some concepts. Ducking clips is more flexible but needs more manual 
adjustments.

• The clips that cause ducking must be located completely inside the time 
range of the clip to which ducking is applied.

• If the clips that cause ducking contain silent passages, ducking does not 
function properly. These clips must be edited so that each phrase is a 
separate clip without any silence. The reason for this is that, in this case, the 
clip activates the ducking.
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• When Duck according to other track is performed it is applied to one clip 
at a time. For example, if the music consists of several clips that have been 
spliced together, only one of the clips is ducked by the voice-over. To solve 
this issue, you can to repeat the function for each clip or use the Render 
function in the Master Section to create a specific (single) file from the 
separate clips and re-import this as a new clip in the audio montage.

Creating a Ducking Effect

In the following example, the track to which ducking is applied contains music and 
an adjacent track that causes ducking contains a voice-over.

PROCEDURE

1. In the Audio Montage workspace, place the clips that contain the music and 
the voice-over on separate adjacent tracks.
The voice-over clips must be located inside the time range of the music clip.

2. Select the clip containing the music, and open the Focused clip window.

3. In the Envelope panel, from the envelope type menu, select Volume/Fades.

4. In the Envelope panel, select Duck according to other track.

5. In the Ducking options dialog, make your settings.
Depending on whether the voice-over track is above or below the music track, you 
must select Previous track or Next track.

6. Click OK.

RESULT 

The level of the music is automatically lowered by the voice-over clips.

Ducking Options Dialog

In this dialog, you can create ducking effects.

In the Audio Montage workspace, in the Focused Clip window, on the Envelope 
panel, select Duck according to other track.
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Fall region - Balance clip fade-in

Ignores any duration or gap settings in the Fall region section. Instead, the 
ducking envelope lowers the volume from the fade-in end position of the 
voice-over clip.

Fall region - Duration

The time it takes for the level to fall when ducking starts.

Fall region - Gap before clip

The time between the end of the Fall region and the start of the voice clip.

Rise region - Balance clip fade-out

Ignores any duration or gap settings in the Rise region section. Instead, the 
ducking envelope raises the volume from the fade-out start position of the 
voice-over clip.

Rise region - Duration

The time it takes for the level to rise to the original level after ducking ends.

Rise region - Gap before clip

The time between the end of the voice clip and the start of the Rise region.

Modulator clips - Previous/Next track

Defines whether the modulator track should be before (Previous track) or 
after (Next track) the track that is to be ducked.

Modulator clips - Only selected clips

If this option is activated, only the selected clips on the modulator track cause 
ducking.

Damp factor

Sets the amount of ducking, that is, the degree of attenuation that is applied 
to the affected clip.

Fades and Crossfades in the Audio Montage

A fade-in is a gradual increase in level and a fade-out is a gradual decrease in level. 
A crossfade is a gradual fade between two sounds, where one is faded in and the 
other faded out.

Creating Fades

By default, all clips display a fade-in and a fade-out junction point. These can be 
dragged horizontally to create a fade-in or fade-out for a clip.

You can add envelope points to a fade just as with volume envelopes.

• To create a fade-in, click the fade-in point at the beginning of a clip, and drag 
it to the right.
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• To create a fade-out, click the fade-out point at the end of a clip, and drag it 
to the left.

• To move a fade-in/fade-out point vertically, press [Ctrl]/[Command] while 
dragging.

The resulting linear fade-in/fade-out curve is displayed in the clip, and the fade is 
also reflected in the waveform. If you position the mouse over the fade-in point, a 
label appears, showing the fade-in time in seconds and milliseconds and the volume 
in dB.

Editing Fades Menu

In this menu, you can select various preset fade curves and other fade-related 
options.

In the Audio Montage workspace, right-click the fade-in or fade-out point to open 
the Fade-in/Fade-out menu. This menu is a subset of the Focused clip window.

Fade-in region/Fade-out region

Adjusts the view to mainly display the fade-in/fade-out part of the focused 
clip.

Copy shape

Copies the fade-in/fade-out shape to the clipboard.

Paste shape

Replaces the fade-in/fade-out shape with the shape that was copied to the 
clipboard. The original length is preserved.

Paste to selected clips

Replaces the fade-in/fade-out shape of all selected clips with the shape that 
was copied to the clipboard. The original length is preserved.

Linear

Changes level linearly.
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Sinus (*)

Changes level according to the first quarter period of the sine curve. When 
used in a crossfade, the loudness (RMS) remains constant during the 
transition.

Square-root (*)

Changes level according to the square-root curve. When used in a crossfade, 
the loudness (RMS) remains constant during the transition.

Sinusoid

Changes level according to a half period part of the sine curve.

Logarithmic

Changes level logarithmically.
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Exponential

Changes level exponentially.

Exponential+

Changes level strongly exponential.

Set fade-in time/Set fade-out time

Sets the fade-in time/fade-out time to the value that you have specified in the 
Focused clip window on the Fade-in/Fade-out panel.

Apply default

Replaces the current fade-in/fade-out with the default setting that is specified 
in the Focused clip window on the Fade-in/Fade-out panel.

Saving a Fade-In/Fade-Out as Default

The default fade-in/fade-out curve shape is linear. You can change this setting and 
define a default shape and/or length separately for fade-ins and fade-outs.

PROCEDURE

1. In the Audio Montage workspace, drag the fade-in/fade-out point to the 
position that you want to set as default.

2. Open the Focused clip window, and on the Fade-in or Fade-out panel, open 
the Presets menu.
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3. Depending on whether you want to save the current fade as default for 
fade-ins and/or crossfades, select one of the following options:
• Save as default for automatic fade-ins/fade-outs
• Save as default for automatic crossfades

4. Click OK.

RESULT 

When you right-click a fade-in/fade-out point and select Apply default, the saved 
fade is applied. In addition, when you create a new clip and Create default fades 
in new clips is activated, the default fade is used.

NOTE

The default fades are saved for each audio montage. If you want to use the same 
default fade for several audio montages, you should update the audio montage 
template file.

Applying a Default Fade-In/Fade-out

PROCEDURE

1. In the Audio Montage workspace, right-click the fade-in/fade-out area for 
which you want to apply the default fade-in/fade-out.

2. Select Apply default.
You can also click the Apply default button in the Focused clip window.

RESULT 

The fade-in/fade-out time is set to the defined default value.

Applying Default Fades to New Clips

PROCEDURE

• In the Audio Montage workspace, select Options > Create default fades in 
new clips.

RESULT 

All new clips that are imported or recorded in the audio montage get the default 
fade-in and fade-out shape and length if Create default fades in new clips is 
active. In this case, the default crossfade shapes are used. This also applies to clips 
that are created through splitting clips.
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Locking the Fade Times When Adjusting Clip Edges

PROCEDURE

• In the Audio Montage workspace, select Options > Lock fade times when 
adjusting clip edges.

RESULT 

The defined fade-in/fade-out length is locked to the clip start or end, even if you 
adjust the clip edges.

Copying Fades

You can copy a fade-in or fade-out and paste it onto another clip.

PROCEDURE

1. In the Audio Montage, right-click a fade-in/fade-out point, and select Copy 
shape.

2. Right-click the fade-in/fade-out point for which you want to apply the fade, 
and select Paste shape.

RESULT 

The fade is applied to the clip.

Setting the Fade/Level Envelope After the Effects

When using dynamic processors that alter the level of the clip, it is useful to place 
the level/fade envelope after the clip effect section.

PROCEDURE

1. In the Audio Montage, open the Focused clip window.

2. On the Envelope panel, activate Level/fade envelope after effects.
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Deactivating Automatic Fade Changes for Individual Clips

You can deactivate automatic fade changes for individual clips. This can be used if 
you have set a fade that you do not want to be altered in any way, even though you 
may want to overlap the clip with another clip.

PROCEDURE

1. In the Audio Montage workspace, select the clip for which you want to disable 
automatic fade changes.

2. Open the Focused clip window, and on the Fade-in or Fade-out panel, 
deactivate Automatic changes.

Creating Automatic Crossfades in Audio Montages

Crossfades in audio montages can be created automatically when clip edges 
overlap. You can specify the type of crossfade that is performed.

PREREQUISITE 

Deactivate Options > No automatic crossfading.

PROCEDURE

1. In the Audio Montage, select Options, and select one of the following 
automatic crossfade types:
• Automatic crossfading - free overlaps
• Automatic crossfading - fade-in constrains overlaps
• Automatic crossfading - fade-out constrains overlaps

2. Move a clip so that it overlaps the edge of another clip.

RESULT 

The crossfade is automatically created in the overlap. By default, there are two equal 
length linear fade curves, one fading out and the other fading in. This also happens 
if you paste a clip so that it overlaps another clip.
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About the Crossfade Compensation Attributes

When creating a crossfade, the fade-in/fade-out shape changes to optimize the 
volume evolution during the crossfade.

In the Audio Montage workspace, in the Focused clip window, on the Fade-in or 
Fade-out panel, open the crossfade compensation menu.

Pure shape

The fade shape is not changed and is used as defined. This is the default 
setting when any fade-in/fade-out preset is selected.

Amplitude compensation

If this option is selected for a fade-in/fade-out curve in a crossfade, the 
summed fade-in/fade-out gains remain constant along the crossfade region. 
This option is recommended for short crossfades.

Medium compensation

Provides an intermediary between amplitude compensation and power 
compensation. This is recommended if the other two compensation attributes 
do not provide the expected result.

Power compensation

If this option is selected, the energy (power) of the crossfade is constant all 
along the crossfade region. Crossfading between completely different types 
of audio material can sometimes cause harmonics to “cancel out each other” 
at the crossfade splice point, causing the volume to drop. Constant power 
crossfades compensate for this problem. Using either the Sinus (*) or 
Square-root (*) fade presets for a fade-in/fade-out provide a constant power 
crossfade without selecting this option.

NOTE

Selecting a compensation attribute for a single fade (not in a crossfade) changes 
the shape of the curve. However, the actual compensation is only applied when the 
fade becomes part of a crossfade.

Crossfade Editing

You can create crossfades with independent shapes and lengths for the fade-in and 
fade-out curves.

The default automatic crossfade is linear. It uses the same shape and fade lengths 
for fade-in and fade-out. In most cases, an unaltered linear or sine crossfade 
produces the intended result. The following rules apply:

• A crossfade includes fade-in and fade-out.

• You can edit the fade-in and fade-out curves in crossfades in the same way 
as fades.
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• To resize the crossfade time symmetrically, press [Shift], click the crossfade 
area, and drag left and right.

• To move the crossfade region while keeping its length, press 
[Ctrl]/[Command], click the crossfade area, and drag left and right.

• When you move a clip so that it overlaps another clip to create a crossfade, 
and neither clip has a defined fade in the overlap, a default crossfade is 
created, if one of the auto crossfade options is activated.

• When moving a clip with a defined fade curve so that it overlaps the adjacent 
edge of another clip (without a defined fade), the unmoved clip automatically 
gets the same fade shape as the moved clip (but as a corresponding opposite 
fade), with amplitude compensation. This only applies if the fade-out length of 
the unmoved clip is set to zero.

• If both clips have different defined fade curves at their adjacent edges when 
creating a crossfade, this creates an asymmetrical crossfade, based on the 
defined fade curves.

Apart from the different combinations described above, there are other factors that 
govern the result when creating crossfades. In the following example a pre-defined 
fade-out and an undefined fade-in are used. The fade-in is created when the 
crossfade is performed. What happens depends on what type of defined fade-out 
curve is used:

• If the fade-out is a preset (except Sinus (*) or Square-root (*)) that uses Pure 
shape, the corresponding fade-in gets the same preset with amplitude 
compensation.

• If the fade-out is a preset that uses a compensation attribute, the fade-in gets 
the same preset, but with Pure shape activated, for the compensation to take 
effect.

• If the fade-out uses either the Sinus (*) or Square-root (*) presets with the 
Pure shape setting, the fade-in gets the same preset also with the Pure 
shape setting, and the compensation attribute is grayed out on the menu. In 
fact, power compensation is used. This is because the Sinus (*) and 
Square-root (*) curves provide constant power crossfades by themselves.

The Options menu provides additional options that affect crossfades.

RELATED LINKS

Options for Moving and Crossfading Clips on page 249
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Crossfading with Fade Constrained Overlaps

PREREQUISITE 

To use fade-in/fade-out constrained overlaps, there must be a defined (not set to 
zero) fade-in/fade-out in the overlap. Otherwise, Automatic crossfading - free 
overlaps is activated for that crossfade.

The following description applies to fade-in constrained overlaps and fade-out 
constrained overlaps. For the latter, however, the defined fade-out length constrains 
the overlap, and accordingly, the left edge of the right clip is adjusted.

PROCEDURE

1. In the Audio Montage workspace, activate Options > Automatic 
crossfading - fade-in constrains overlaps.

2. On a track that contains several clips, create a fade-in curve in a clip.

3. Drag the clip to the left so that it overlaps another clip, past the right clip edge.
A crossfade is created in the overlap.

4. Continue dragging the clip, so that the fade-in point of the dragged clip 
overlaps the right edge of the left clip.

5. Drag the clip to the right again.
The resized clip is gradually uncovered. The original clip length is memorized, so you 
can later restore the resized clips.

6. Separate the two clips again without creating an overlap so that they return to 
the original left/right position relative to each other.

7. Drag the left clip to the right so that it overlaps the other clip, and continue 
dragging to the right.
The right edge of the left clip is progressively resized as you drag the clip further to 
the right.

RESULT 

Fade constrained overlaps can also be used with the options Allow multiple 
automatic crossfades and Allow automatic crossfading with clips on focused 
track.

About Adjusting Crossfades Between Clips

The Zoom window shows a magnified view of the beginning of the selected clip and 
allows you to accurately adjust the crossfade point for two adjacent clips.

The main purpose of this is to help you splice two consecutive clips together. In this 
case, the zoom view displays the end of the left clip and the start of the right clip. 
This type of splicing is achieved by applying short crossfades.

There are two main types of crossfades:
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• Artistic crossfades: for example, if you want to crossfade two songs to make 
a nice transition. Usually, these types of crossfades are quite long and can 
easily be created from the audio montage window.

• Patch crossfades: for example, if you want to replace a section of audio as 
transparently as possible, without audible discontinuity in the resulting audio. 
In these cases, you must shorten the crossfades as much as possible. These 
types of crossfades are best created in the Zoom window.

NOTE

The zoom view is centered around the starting point of the right clip. If you move the 
right clip on the track, the left clip appears to be moving in the zoom view.

Adjusting Crossfades Between Clips

Accurately adjusting the crossfades between clips is important to avoid clicks at the 
junction points. WaveLab analyzes the waveforms to automatically find the best 
crossfade offsets.

PROCEDURE

1. In the Audio Montage workspace, on a track, align the two clips that you want 
next to each other.

2. Select the clip that is located on the right.

3. Open the Zoom window.
This shows a close-up of the two clips.

4. Set the zoom factor using the icons above the zoom view, or select a zoom 
factor from the Menu.
If you activate Menu > Automatic level zooming, the waveforms are automatically 
zoomed vertically to fill out the Zoom view.

5. If necessary, move or resize the clip located on the right in the zoom view.

6. Set the search range using the icons above the zoom view, or select a search 
range from the Menu.

7. Decide whether you want to move the clip on the left or the clip on the right.
• To move the clip on the left, click the Move to left (match waveform) icon, or 

select Menu > Move to left (match waveform).
• To move the clip on the right, click the Move to right (match waveform) icon, 

or select Menu > Move to right (match waveform). This is useful if the two 
clips are already overlapping.

RESULT 

WaveLab scans the audio to the left of the splice point and moves the clip on the 
right to the position which provides the best possible phase match, to avoid 
harmonic cancelation. When the clip on the right is moved over the clip on the left, 
a short crossfade is automatically created.
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Zoom Window

In the Zoom window, you can find the best crossfade point for two adjacent clips.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Zoom.

On the Menu, you have the following options:

Move to left (match waveform)

Scans the audio to the left of the splice point and finds the best possible 
phase match to avoid harmonic cancelation. The clip on the right is moved 
over the clip on the left. This automatically creates a short crossfade, ensuring 
the smoothest possible splice.

Move to right (match waveform)

Scans the audio to the right of the splice point and finds the best possible 
phase match, to avoid harmonic cancelation. The clip on the right is then 
moved further to the right. This automatically creates a short crossfade, 
ensuring the smoothest possible splice. This function is useful if the two clips 
already overlap.

Search range

Determines how deep WaveLab scans the clips when searching for the best 
possible phase match. Higher values result in greater accuracy but also 
longer processing times. If the sounds contain a lot of bass, avoid the shortest 
search range setting.

Zoom

Sets the zoom factor. For example, 1:4 means that 1 pixel on the screen 
corresponds to 4 audio samples.

Automatic level zooming

Automatically zooms the waveform vertically to fill the view.

Show envelope

Displays the envelope curves of the clips in the view. Which curves are exactly 
displayed depends on the settings of each clip.
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Clip Time Stretching

You can adjust the length of a clip by using time stretching.

The best results when stretching or compressing a clip are achieved when using 
small or moderate amounts of time stretch. You should avoid time stretching of 
already time stretched material.

When you perform time stretching on a clip, a copy of the original audio file is 
created, that contains the audio range that is used in the clip. The time stretch is 
applied to the copy, and the clip now references to the copy.

• The copied audio file has the same name as the original, but with the suffix 
“_#X” where X is a number.

• The copied audio file is stored in the implicit folder that is specified in the 
Audio montage preferences.

NOTE

Since the new copied audio file contains exactly the audio range that the clip uses, 
it is not possible to lengthen the clip by resizing after Time stretch to cursor has 
been applied.

Time-Stretching Clips

PROCEDURE

1. In the Audio Montage workspace, move the edit cursor to the position where 
you want the clip to end.

2. Right-click the clip that you want to time-stretch, and select Time stretch to 
cursor position.
The Time Stretching dialog opens. Only the Method section is available for editing, 
since the other settings are determined by the edit cursor position.

3. In the Time Stretching dialog, edit your settings, and click OK.

RESULT 

The clip is stretched or shortened so that it ends at the edit cursor position.

RELATED LINKS

Time Stretching Dialog on page 196
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Clip Pitch Shifting

You can adjust the pitch of a clip by using pitch shifting.

When you perform pitch shifting on a clip, a copy of the original audio file is created, 
that contains the audio range that is used in the clip. The pitch shift is applied to the 
copy, and the clip references to the copy.

• The copied audio file has the same name as the original, but with the suffix 
“_#X” where X is a number.

• The copied audio file is stored in the implicit folder that is specified in the 
Audio montage preferences.

Pitch-Shifting Clips

PROCEDURE

1. In the Audio Montage, right-click the lower part of a clip for which you want to 
apply pitch shifting, and select Pitch shifting.
The Pitch shift dialog opens.

2. In the Pitch shifting dialog, edit your settings, and click OK.

RELATED LINKS

Pitch Shift Dialog on page 199

Effects for Tracks, Clips, and the Master Output

You can add VST effect plug-ins to individual clips, tracks, or the master output of 
an audio montage. Clip effects affect individual clips only, track effects affect all 
clips on a track, and the master output affects the whole audio montage.

Only VST 2 and VST 3 plug-ins can be used in the audio montage. Each clip, audio 
track, and the master output can be independently processed by up to 10 VST 
effect plug-ins.

Effects are configured as follows:

• As inserts, when all sound is processed by the effects

• As send effects (split mode), where the balance between the unprocessed 
sound and the effect send level can be adjusted or controlled by effect 
envelope curves (clip effects and certain VST 2 plug-ins only)

An icon in front of a clip name indicates that effects are applied to a clip.
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Hovering over a clip name shows the effects that are used for the clip.

NOTE

• Only clip effects for clips that are active at the current playback position 
consume CPU power. Track and master output effects are always active.

• The first time that you play an audio montage after is has been opened or 
copied, the program has to load all effects into memory. If you have many 
effects, this can result in a short silence before the playback starts.

• Effects that are used for tracks must support stereo audio, even if the audio 
track is mono.

About the Master Output Effects

You can add master output effects to an audio montage. While the Master Section 
is shared among all audio montages, the master output effects are local to each 
montage. This allows you to have a fully embedded project, without needing to use 
the Master Section.

The master output effects are located at the output of the audio montage.

NOTE

If you want to use a dithering plug-in, place it in the master output.
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Effects Window

This window lets you add effect plug-ins to tracks, clips, and the master output, 
import the plug-ins from the Master Section, and make pan and gain settings.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Effects.

Menu

Clip effects

Displays the plug-ins of the focused clip.

Track effects

Displays the plug-ins of the focused track.

Master effects

Displays the plug-ins of the master output.

Add slot

Adds a slot into which an audio plug-in can be inserted.

Remove

Removes the selected plug-in.

Remove from selected clips

Removes the plug-in if a selected clip uses the same plug-in.

Close all

Closes all plug-in windows that relate to this audio montage.

Copy

Copies the selected plug-in and its settings to the clipboard.

Paste

Replaces the selected plug-in with the plug-in that was copied to the 
clipboard. If no slot has been added, a new slot is created.

Paste to selected clips

Replaces the selected plug-in with the plug-in that was copied to the 
clipboard on all selected clips. If no slots have been added, new slots are 
created.
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Load plug-in chain

Replaces the current plug-ins with a plug-in chain that has previously been 
saved on disk.

Save plug-in chain

Saves the current plug-in chain as a preset.

Import Master Section plug-ins

Imports the plug-ins that are currently loaded in the Master Section. Existing 
plug-ins are overwritten.

Plug-in map

Opens the Plug-in Map dialog, that displays all plug-ins that are used in the 
audio montage and the clips and tracks that are using them.

Bypass all plug-ins

If this option is activated, all plug-ins of the active clip or track are bypassed 
during playback.

Plug-in window handling

Opens the Plug-in Window Handling dialog in which you can set up the 
appearance of plug-in windows.

Customize commands

Opens the Customize commands dialog in which you can set up shortcuts 
for the Effects window.

Effects List

The effects list displays the effect plug-ins of the selected track, clip, or master 
output. In the list, you can select new effects for the existing effect plug-ins, change 
the effect order, and edit the Send level and Tail of effects.

The following options are available:

Plug-in window icon

Opens the plug-in window.

Effect name

Shows the effect name. Clicking an effect name opens the Plug-ins menu 
where you can select a new effect.

Preset

Shows the last preset that was loaded for the plug-in.
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Send level

If this option is activated, you can enter a send level for the effect. This mode 
is only available for certain VST 2 plug-ins.

Latency

Shows the latency (delay) in the audio path. Certain plug-ins must analyze the 
sound before passing it on. However, real-time changes, such as turning an 
effect knob, are delayed according to the maximum latency that is found 
among all clips. Plug-ins with latency cannot be used for adjusting the send 
level.

Tail (clip effects only)

Effects, such as reverb and delay, produce audio tails. This means, for 
example, that the effect sound continues after the clip sound ends. For 
example, if you add echo to a clip without specifying a tail value, the echo 
effect is muted as soon as the clip ends. Set the tail length so that the effect 
is allowed to decay naturally. If you add another plug-in to the clip that also 
produces a tail, there is no need to set a separate tail value for this plug-in, 
unless you want the decay to sum up. The overall tail length for the clip is the 
sum of the tail of each plug-in. The maximum tail setting is 30 seconds.

Gain/Pan Section

In this section, you can edit gain and pan settings for each clip and track.

Global Gain Section

In this section, you can set the global gain for the active audio montage. This gain 
can be applied before (pre) or after (post) the master output, depending on the 
setting of the pre/post button on the left of this section. Pre is the default setting.

The Loudness Meta Normalizer can change the global gain to set the audio 
montage output loudness, for example, to match the EBU R-128 recommendation.

RELATED LINKS

About Pan Modes on page 280
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Adding Effects to a Track, Clip, or Master Output

You can add effect plug-ins to every track and clip of the audio montage, and to the 
master output of the audio montage.

Adding Effects Via the Effects Window

PROCEDURE

1. In the Audio Montage workspace, open the Effects window.

2. Select the clip section, track section, or master output section.

3. Click the Add slot button.

4. In the Effect name column, select the added slot.

5. Select a plug-in.

RESULT 

The selected effect opens in a window.

NOTE

You can add effects during playback. However, if you add an effect with a latency 
larger than zero it is better to stop and restart playback to avoid timing 
discrepancies. In addition, a small number of VST plug-ins may change latency 
depending on parameter settings. If that is the case, make sure to stop and restart 
playback after the latency is changed.

Additional Ways of Adding Effects

• To add an effect to a track, click the FX button in the track control area, select 
Add effect, and select an effect from the menu.

• To add an effect to a clip, in the montage window, right-click the clip name, 
select Add effect, and select an effect from the menu.
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Adding the Master Section Effects to the Track, Clip, or Master Output

You can add the Master Section effects to the clip, track or master output of an 
audio montage.

PREREQUISITE 

Set up the Master Section plug-ins.

PROCEDURE

1. In the Audio Montage workspace, open the Effects window.

2. Select the track, clip, or master output to which you want to add the Master 
Section effects.

3. Select Menu > Import Master Section plug-ins.

RESULT 

The Master Section effects are added to the focused track, clip, or master output.

NOTE

To copy a single Master Section effect, you can drag it from a Master Section slot 
to the effects list of the Effects window.

Removing Effects from Tracks, Clips, or the Master Output

PROCEDURE

1. In the Audio Montage workspace, open the Effects window.

2. Select the clip section, track section, or master output section.

3. Click the effect that you want to remove, and select None.

RESULT 

The effect is removed from the slot. You can either select a new effect for the slot 
or leave the slot unused.
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Rearranging the Order of Effects

The effect order in the effects list determines to a certain degree how the effects 
affect each other. You can rearrange the effects to change the processing order.

PROCEDURE

1. In the Audio Montage workspace, open the Effects window.

2. In the effects list, drag the effect that you want to rearrange to another 
position.

Applying Effects to Another Track, Clip, or Master Output

You can save the plug-in chain of a track, clip, or master output as a preset and 
apply it to other tracks, clips, or the master output of another audio montage.

PROCEDURE

1. In the Audio Montage workspace, open the Effects window, and set up your 
plug-in chain.

2. Select Menu > Save plug-in chain.

3. Enter a name and the file location for the effect chain, and click Save.

4. Select the track, clip, or master output for which you want to apply the effect 
chain.
Plug-in chains are applied to the focused clip.

5. Select Menu > Load plug-in chain.

6. Select a plug-in chain, and click Open.

Copying Effect Settings to Other Tracks, Clips, or the Master 
Output

You can copy the effect and its settings of a track, clip, or master output to other 
tracks, clips, or the master output of the same or another audio montage.

PROCEDURE

1. In the Audio Montage workspace, open the Effects window.

2. Select the effect from which you want to copy the settings.

3. Select Menu > Copy.
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4. Decide if you want to paste the effect settings to a new slot or replace an 
existing effect.
• To paste the effect settings to a new slot, add a new slot, and select Menu > 

Paste.

• To replace an existing effect, select the effect, and select Menu > Paste.

• To copy to multiple clips, select the clips, and select Menu > Paste to 
selected clips.

Undoing Effect Changes

You can undo/redo changes to the effect settings. However, WaveLab only 
registers the changes when the Effects window loses focus.

PROCEDURE

1. In the plug-in window, click another window to lose focus of the plug-in in 
which you want to undo the settings.

2. Go back to the plug-in in which you want to undo the settings.

3. Press [Ctrl]/[Command]-[Z] to undo the settings.

Using Effect Envelopes

You can automate the effect send level for split mode clip effects by using effect 
envelope curves.

PREREQUISITE 

Set up a split mode effect plug-in for a clip.

PROCEDURE

1. In the Audio Montage workspace, in the Focused clip window, open the 
Envelope panel.

2. In the envelope type menu, select the effect that you want to use for the 
envelope curve.

3. Create the envelope curve.

Setting the Pan and Gain for Effects

You can set the pan and gain of the effects for each clip and track individually.

PROCEDURE

1. In the Audio Montage workspace, select the Effects window.

2. Select a clip or track.
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3. Adjust the pan and gain using the controls on the left of the Effects window.

Setting the Global Gain for Effects

You can set a global gain for the master output effects of your audio montage and 
apply it before (pre) or after (post) the master output effects.

PROCEDURE

1. In the Audio Montage workspace, select the Effects window.

2. Select the master output.

3. Adjust the global gain using the fader on the left of the Effects window.

4. Click the pre/post button on the left of the global gain fader.

If you use a dithering plug-in, set the gain to be pre-master.
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Setting the Send Level for Tracks, Clips, or the Master Output

Effects for tracks, clips, and the master output can be configured either as insert or 
send effects. To set the send level for a track or clip, you must activate the Send 
level option.

NOTE

Only effect plug-ins that are capable of using send effects can be activated for 
setting the send level. For all other effect plug-ins, this function is deactivated.

PROCEDURE

1. In the Audio Montage workspace, open the Effects window.

2. In the Send level column, activate the checkbox for the track/clip for which 
you want to set the send level.

3. Specify the send level in dB.

About Resetting Plug-ins

You can reset the plug-ins before playing back or rendering the audio montage.

The following options are available in the Audio Montage workspace, when you 
select Options > Audio montage preferences, and open the Active Audio 
Montage tab.

• If Reset plug-ins when starting playback is activated and you start 
playback, the plug-ins release any samples in the plug-in memory. Activate 
this if you get a small click or noise when the playback position reaches the 
start of a clip with effects (typically reverb or delay effects). Only use this 
option if you need it, since having it activated could result in a slightly delayed 
response when you start playback, especially in an audio montage with many 
plug-ins.

• If Reset plug-ins before rendering is activated, all plug-ins are reloaded 
before the files are rendered. Certain plug-ins are only properly initialized 
when they are created. If you have activated Reset plug-ins when starting 
playback and still get clicks on playback, you can activate Reset plug-ins 
before rendering. This requires twice the amount of plug-in memory.
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Plug-in Window

In this window, you can display the effect plug-ins that are used for a track, clip, or 
the master output. You can display all effects in one plug-in window or have 
separate windows for each effect, for all track effects, all clip effects, or all master 
output effects.

Plug-in chain window

Single plug-in window

When you add a new effect plug-in to a track, clip, or master output, the plug-in 
window opens automatically. In the plug-in window, the effects are displayed in a 
plug-in chain by default. To change the processing order of the effects, you can 
drag each effect to a new position in the chain.

You can adjust the handling of the effects in the plug-in window in the Plug-in 
window handling dialog.

Opening the Plug-in Window

You can open the plug-in window from different locations in the Audio Montage 
workspace.

• To open the plug-in window from the Effects window, in the effects list, click 
the plug-in window icon to the left of a plug-in.

• To open the plug-in window for a clip from the montage window, right-click 
the bottom part of a clip, and select Edit plug-ins. You can also right-click the 
clip name and select a plug-in.

• To open the plug-in window for a track, click the FX button in the track control 
area.

• To open the plug-in window for a focused clip, in the Focused clip window, 
on the Edit panel, select Edit plug-ins.
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Adding Effects From Within the Plug-in Window

Effects that are added to a clip, track, or the master output in the Effects window 
are automatically displayed in the plug-in window. However, you can also add 
effects to a track or a clip directly from within the plug-in chain window.

PROCEDURE

1. In the Plug-in window handling dialog, activate Use plug-in chain 
windows.

2. In the Audio Montage workspace, open the plug-in window for the clip, track, 
or master output to which you want to add an effect.

3. In the plug-in chain window, click the Add plug-in button.

4. Select an effect from the menu.
The effect is added at the end of the plug-in chain. The added effect is also displayed 
in the Effects window.

5. Optional: If you want to move the added effect in the plug-in chain, drag it to 
another position.

Changing Effects From Within the Plug-in Window

When displaying effect plug-ins in the plug-in window, you can change plug-ins to 
change the processing.

PROCEDURE

1. In the Audio Montage workspace, open the plug-in window for the clip, track, 
or master output for which you want to change an effect.

2. Click the plug-in menu icon, and select an effect from the menu.

The changed effect is also displayed in the Effects window.

3. Optional: If you want to move the changed effect in a plug-in chain window, 
drag it to another position.
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Switching Between Clip, Track, and Master Output Effects in the Plug-in 
Windows

In the plug-in window, you can quickly switch between the effect chain of clips, 
tracks, and the master output, and between plug-in windows, when you have 
opened several plug-in windows.

• To skip through the clips, tracks, and the master output of the active audio 
montage, use the left and right arrow icons.

• When using one plug-in window for both clips and tracks of an audio 
montage, you can switch between the plug-ins of the focused clip or the track 
which displays the focused clip by clicking the Show Clip Plug-ins or Show 
Track Plug-ins icons.

• To lock a plug-in window, activate Lock Window. If this option is activated, 
and you select another track or clip, another plug-in window opens. If this 
option is deactivated, and you select another track or clip, the effects are 
displayed in the same plug-in window.

NOTE

This button is only visible if Use plug-in chain windows and Unlimited 
number of open windows is activated.

Closing All Plug-in Windows

PROCEDURE

1. In the Audio Montage workspace, open the Effects window.

2. Select Menu > Close all.
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Plug-in Window Handling Dialog

In this dialog, you can set up the appearance and behavior of the plug-in window.

In the Audio Montage, open the Effects window, and select Menu > Plug-in 
window handling.

Use one window per plug-in

Opens each plug-in in an individual window. Several plug-in windows can be 
open at the same time.

Close other windows when opening a new one

Closes all open plug-in windows of the same audio montage each time that 
you open a plug-in window. This means that only one plug-in is displayed at 
a time for a each audio montage.

Use plug-in chain windows

Shows all open plug-ins in the plug-in window as tabs, which allows you to 
quickly switch between the plug-ins.

Unlimited number of open windows

Allows for any number of plug-in chain windows to be open at the same time. 
There can be one for each track and one for each plug-in.

Lock window on opening

Automatically locks a plug-in each time a plug-in chain window is opened.

If a plug-in window is locked, and you select another track or clip, another 
plug-in window opens. If this option is deactivated, and you select another 
track or clip, the effects are displayed in the same plug-in window.

Use one window for clips and one for tracks

Uses one plug-in window for all clips, one for all tracks, and one for the master 
output. This means that the plug-in window for clips is reused when activating 
a new clip, and the plug-in window for tracks is reused when activating a new 
track.

Use one window per montage

Uses one plug-in window for the clips, tracks, and the master output of an 
audio montage. This means that the plug-in window for clips is reused when 
you select any element that uses plug-ins (clips, tracks, master output).
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Auto switch between tracks and clips

If this option is activated and you click the track control area of a track, the 
plug-in window switches to display the track plug-ins, even if the window was 
displaying clip plug-ins or the master output plug-ins. If you click a clip header, 
the plug-in window switches to display the clip plug-ins, even if the window 
was displaying track plug-ins or the master output plug-ins.

About the CD Window

The CD window combines the functions for creating an audio CD or DVD-Audio 
within WaveLab.

It displays a list of CD tracks along with information about each track. You can edit 
each track and the playback properties of the CD, check the conformity to the Red 
Book standards, add and edit CD-Text, add UPC/EAN and ISRC codes, generate 
a CD report, and write the CD.

You can also choose whether to replace the gap between track markers with 
silence or with sound by using the Audio in pauses function. When you select a 
clip in the montage window, the corresponding track is highlighted in the CD 
window.

A CD track in the audio montage is defined by CD markers.

You can reorder CD tracks in the CD track list with drag and drop. However, only 
ranges of CD tracks that are located between a CD track start marker and a CD 
end marker can be moved. For example, we have the following markers:

• Start marker A

• Splice marker B

• Splice marker C

• End marker D

• Start marker E

• Start marker F

Then the range between A and D (which is a group of 3 CD tracks) is moved as well 
as the range between E and F. The ranges A-B, or B-C, or C-D cannot be moved 
individually.

About CD Markers

A track in the audio montage is defined by CD track start and end markers or CD 
track splice markers.

• CD track splice markers indicate the end of one track and the start of the next.

• If you delete the CD markers defining a track, the track is deleted from the CD 
window.
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• If you edit a marker position of a CD track, the change is reflected in the track 
in the CD window.

• The name of a CD track is the name of the CD track start marker. Editing the 
marker name also changes the CD Track name, and vice versa.

CD Window

In this window, you can create an audio CD or DVD-Audio.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
CD.

Track List

You can edit tracks directly from the track list in the CD window.

Playback triggers

The following playback buttons are available:

Playback from start with a pre-roll.

-[Alt]/[Option]

Playback from start with a long pre-roll.

Playback from start.

You can also hold [Ctrl]/[Command] and double-click a CD track start marker 
triangle to start playback from the marker position.

Name

Shows the track name. To change the name, double-click in the 
corresponding cell, and enter a new value.

Pause

Shows the pause between two tracks.

Start

Shows the start position of the track.

End

Shows the end position of the track.
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Length

Shows the time value from the CD track start position to the corresponding 
end or splice marker.

Pre-gap

Shows the pre-gap of a track.

Post-gap

Shows the post-gap of a track.

Lock

The key symbol indicates a track copy protection flag. Note that not all CD-R 
units can handle this flag.

Emphasis

The rainbow-colored symbol indicates the emphasis flag. This setting is used 
to indicate if the track was recorded with emphasis or not. 
Activating/deactivating this option does not apply/remove emphasis from the 
audio. It is just an indicator for how the file was created.

ISRC

Lets you enter an ISRC code. To change the code, double-click the 
corresponding cell, and enter a new value.

CD-Text

Lets you specify the CD-Text. To change the CD-Text, double-click the 
corresponding cell, and enter a new value.

Comment

Allows you to enter a comment. To enter a comment, double-click a cell.

Functions Menu

Write Audio CD or DDP

Opens a dialog from which you start writing a CD.

Check CD conformity

Verifies that the settings for the audio montage are in accordance with the 
Red Book standard.

CD Wizard

Opens a dialog that helps you generate and adjust CD markers.

Edit CD-Text

Opens the CD-Text editor that allows you to enter descriptive text for the 
tracks that are written on CD.

Edit CD meta-data

Opens the CD Meta-data editor that allows you to associate meta-data with 
each CD track. When rendering CD tracks via the Render dialog, the audio 
files inherit this meta-data.
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Generate Audio CD report

Opens a dialog that lets you create a text report that describes the contents 
of the audio CD.

Play previous/next CD-track

This is used to audition the track before/after the selected track. This depends 
on the pre-roll settings.

Play all CD-track starts

This is used to check the transitions between all tracks. In the Edit playback 
times dialog of the CD window, you can set the playback length of CD track 
starts.

Options Menu

Mode “Audio in pauses”

Usually, when you create a CD, only the sections between track markers are 
written, and the pauses between tracks are replaced by silence. However, if 
Mode “Audio in pauses” is activated, the exact image of the audio montage 
is written, including any audio between tracks. This makes it possible to hear 
audio either between CD tracks or before the first track, for example, to create 
a hidden track.

Show times relative to track #1

If this option is activated, the start of track #1 is the time code reference, 
excluding any pause before that track.

Show times relative to CD’s absolute zero

If this option is activated, the beginning of the CD, including any pause before 
track #1, is the time code reference.

Time code with CD frames

If this option is activated, the time code is displayed in hours, minutes, 
seconds, and CD frames.

Time code with milliseconds

If this option is activated, the time code is displayed in hours, minutes, 
seconds, and milliseconds.

Pre-Roll mode

If this option is activated, all tracks start with a pre-roll time when they are 
played back using the commands of the CD window.

Edit playback times

Opens a dialog to adjust time values that are related to CD track playback.

Toolbar

The following indicators are only available on the toolbar of the CD window:
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Cursor Position Indicator

Indicates the position of the playback/edit cursor, relative to the CD track start 
in which it is located.

UPC/EAN Code

Opens a dialog in which you can specify an UPC/EAN code.

Edit Playback Times Dialog

In this dialog, you can edit time values that are related to the playback of the CD 
track when using the playback commands of the CD window.

In the Audio Montage workspace, in the CD window, select Options > Edit 
playback times.

CD Track Pre-Roll

Specifies the time that passes before the start of a CD track to help you 
evaluate the transition between one CD track and another.

Add One Second of Silence Before Playback

If this option is activated, WaveLab waits one second before starting playback 
of the next CD track start. This improves the listening experience.

Test Time

Specifies the playback length of CD track starts before jumping to the next 
one. This applies when Play all CD-track starts is selected in the CD 
window.

Meta-Data for CD Tracks

You can associate meta-data with each CD track or for the entire CD. When 
rendering CD tracks via the Render dialog, the audio files can inherit this meta-data.

Since standard CD Text is not unicode, it does not always provide the optimum text 
data. To solve this issue, WaveLab provides variables.

For CD tracks, there are two type of variables:

• Auto variables

• Custom variables

Auto variables are automatically added by WaveLab. For example, ISRC, track 
names, and CD-Text. Custom variables can be manually edited to add additional 
meta-data for the track.
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To see and edit the CD track meta-data, in the CD window, select Functions > Edit 
CD meta-data.

NOTE

In this dialog, you prepare the meta-data. How they are stored, for example, as ID3 
or RIFF, is specified in the Meta-data dialog. See the meta-data chapter for more 
information about using the meta-data that you have specified in the CD Meta-data 
dialog.

RELATED LINKS

Meta-Data on page 154

Creating Audio CD Tracks From Clips

The CD Wizard tool lets you generate CD track and splice markers from clip regions 
and crossfade points. You can use the Check CD conformity option to check 
whether the audio montage is ready for writing to audio CD.

PROCEDURE

1. In the Audio Montage workspace, make sure that the audio montage contains 
the material that you want on the audio CD.
CD tracks must have a length of at least 4 seconds.

2. In the CD window, select Functions > CD Wizard, or click the CD Wizard 
icon.

3. Edit the settings in the CD Wizard dialog, and click Apply.

4. Audition the tracks in the CD window, and make corrections if necessary.

5. In the CD window, select Functions > Check CD conformity.
• If a warning message appears, make corrections and check the CD conformity 

again.

• If no warning message appears, the audio montage is ready to write to audio 
CD.
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CD Wizard Dialog

In this dialog, you can generate and adjust CD markers for audio montages.

In the Audio Montage workspace, in the CD window, select Functions > CD 
Wizard, or click the CD Wizard icon.

Generate CD Track Markers

If this option is activated, the CD Wizard automatically generates CD track 
markers according to the sub-options.

Create markers at clip boundaries

If this option is activated, CD track start and end markers are added at the 
beginning and end of all non-overlapping clips.

Use splice markers (keep pauses within tracks)

If this option is activated, single splice markers are generated instead of 
start/end markers. Instead of a standard pause, pause spaces are generated. 
The pauses are kept within tracks. This can be useful for electronic 
distribution and for compatibility with portable players.

Create markers at crossfade points

If this option is activated, CD track splice markers are created at all crossfade 
intersection points. Activate this option if you have clips that overlap each 
other and that should become different tracks on the CD.

Keep locked CD track markers

Normally, any previously created CD track markers in the montage are 
removed by the CD Wizard. If Keep locked CD track markers is activated, 
any locked CD track markers are kept.

CD marker naming

Allows you to set up a naming scheme.

Start marker

On this menu, select a naming scheme for the CD track start markers. The 
following options are available:

• As clips: The name of the closest clip.

• Specific name: The name specified below.

• Specific name + number X: The name and a number.

• Specific name + number XX: The name and a number that is padded 
on the left with 0.

• Specific name + number (auto): As Specific name + number XX, 
but only if the number of tracks is greater than 10.

• Number X + specific name: A number and a name.

• Number XX + specific name: A number that is padded on the left with 
0 and a name.

• Number (auto) + specific name: As Number XX + specific name, 
but only if the number of tracks is greater than 10.
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• Custom: Opens the Marker Naming dialog where you can rename 
multiple markers according to specified settings.

End marker

On this menu, select the name of the CD track end marker. The following 
options are available:

• No name

• As start marker

• As start maker + “(end)”

• Custom

Adjust pauses before tracks

If this option is activated, pauses before tracks are automatically adjusted 
according to the sub-options.

Set time

If this option is activated, you can specify the length of the pauses between 
tracks.

Round existing pauses to closest second

If this option is activated, the existing pauses between tracks are rounded to 
seconds.

Don’t change first pause

If this option is activated, the pause between the start of the montage and the 
first track are not changed. If you change the length of the pauses to anything 
other than 2 seconds and want to be conform to the Red Book standard, you 
must activate this option.

Adjust gaps between markers and sound (as CD frames)

If this option is activated, small adjustments to the spacing before and after 
the CD track markers are made according to the sub-options. This is useful 
to ensure that a low-quality CD player does not miss the start of tracks or cuts 
them off before their actual end. In most cases, the default settings are 
sufficient.

Silence after first track start marker

Lets you add a few frames of silence before the first track of the CD. Usually, 
the pause needs to be longer for the first track than for the other tracks to 
ensure that a low quality CD player does not miss the start of the first track.

Silence after track start marker

Lets you add a few frames of silence before each track on the CD to ensure 
that a low quality CD player does not miss the start of tracks.

Silence before each track end marker

Lets you add a few frames of silence after each track of the CD to ensure that 
a low quality CD player does not cut off tracks before their actual end.
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Silence before last track end marker

Lets you add a few frames of silence after the last track of the CD to ensure 
that a low quality CD player does not cut off the end of the track or that the 
listener is not disturbed by any clicks or motor noise that the player makes at 
the end of a CD.

Ensure required minimum size for CD tracks

If this option is activated, markers are adjusted to ensure that each CD track 
has the minimum length that the standard requires.

Quantize CD markers to nearest CD frame

If this option is activated, markers are quantized to the nearest CD frame.

Generate ISRC codes

If this option is activated, ISRC codes for the CD tracks are created. Each 
code is based on the code that is specified in this option, but with an ending 
number that is set according to the order of the tracks.

UPC/EAN code (13 digits)

Lets you specify an optional UPC/EAN code for the CD.

Audio in Pauses

When you normally write an audio montage on an audio CD, only the sections 
between the CD markers are written, and the pauses between tracks are replaced 
by silence. However, when Audio in pauses is activated, the exact image of the 
audio montage is written on the CD, including any audio between tracks.

Using Audio in Pauses

The following describes two use cases for the Audio in pauses function.

Adjusting CD Track Markers to Hide Audio Sections

If you have a live recording with a section of applause between two songs, you can 
move the track markers so that the applause section is between the tracks and 
activate Audio in pauses. Thus the applause cannot be heard if you play any of the 
two tracks on their own, but you can hear it when playing through the CD tracks.

PROCEDURE

1. In the Audio Montage workspace, place the CD track end marker of the first 
track at the position where the music ends, but before the applause section.

2. If necessary, place the CD track start marker of the following track at the 
position where the music starts.

3. Select Options > Mode “Audio in pauses”, or click the corresponding icon 
on the toolbar.
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Placing a Clip Before Track 1

You can create a hidden CD track before track 1, for example.

PROCEDURE

1. In the Audio Montage workspace, place a clip without CD track markers prior 
to the first track start marker in the audio montage.

NOTE

It is recommended that you do not place the hidden track at the very start of 
the montage but leave a little room between the montage start and the start 
of the hidden track.

2. Select Options > Mode “Audio in pauses”, or click the corresponding icon 
on the toolbar.
If you now select Functions > Check CD conformity, the audio CD track list is valid, 
given that the rest of the montage is ok.

3. Proceed with writing the CD.
To hear the hidden track after writing the disc, rewind from the start of track 1.

About Cloning Audio Montages

When you clone an audio montage, you create a copy.There are two different types 
of cloning: Clone and Clone completely.

Clone copies the audio montage and lets the new clips reference to the original 
audio files. This is useful if you want to create several versions of the audio montage, 
for example, to experiment with variations. However, any processing or editing that 
you apply to the actual audio files are reflected in both audio montages.

Clone completely copies the audio montage and the actual audio files, thus 
creating a new self-contained audio montage. There are several uses for complete 
cloning:

• Edit and process the audio files without affecting other audio montages.

• Create different versions of the audio montage that focus on a certain aspect 
of the audio montage by removing any unused audio sections.

• Split audio files and give them specific names.

• Reduce the size of an audio montage project by only using the needed audio 
material.

NOTE

Clone completely does not render effects to files.
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Cloning Audio Montages

This creates a copy of the audio montage in which the new clips reference to the 
original audio files.

PROCEDURE

• In the Audio Montage workspace, select File > Clone, or press 
[Ctrl]/[Command], drag a tab, and drop it on the tab bar.

RESULT 

A copy of the audio montage opens in another tab.

Cloning Audio Montages Completely

This creates a copy of the audio montage in which the actual audio files are cloned, 
thus creating a new self-contained audio montage.

PROCEDURE

1. In the Audio Montage workspace, select File > Export > Clone completely.

2. Specify a file name and destination path.

3. In the How to recreate audio files section, select the type of cloning.

4. Optional: Decide if you want to reset the clips names from the file names 
and/or if you want to copy audio file markers by activating the corresponding 
options.

5. Click OK.

RESULT 

A copy of the audio montage opens in another tab.
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Complete Audio Montage Cloning Dialog

In this dialog, you can specify how the selected audio montage is cloned.

In the Audio Montage workspace, select File > Export > Clone completely.

Clone file name

The name of the file to write.

Destination path

The path where you want to create the audio montage clone and all its audio 
files.

Recreate exact audio files

If this option is activated, the cloned audio files are exact copies of the original 
files. Unused ranges are not removed.

The files are recreated and saved in an uncompressed format. For example, 
an MP3 file that is included in an audio montage will be recreated as a PCM 
file. In other words, the content is recreated, not the file format.

Optimally combine all audio files into as few audio files as possible

If this option is activated, all used ranges in the original audio files are copied 
and combined into a single audio file to which the clips in the clone refer. The 
file gets the same name as the audio montage clone file.

NOTE

If the audio montage contains both mono and stereo clips, there will be two 
combined audio files, one for mono material (with the suffix “M”) and one for 
stereo material (with the suffix “S”).

Keep same number of files but remove unused ranges

If this option is activated, the same number of audio files is created, but any 
unused ranges in the files are removed. This reduces the file size.



Audio Montage
About Cloning Audio Montages

323

Split files to remove unused ranges

If this option is activated, unused ranges in the files are removed, and the file 
is split into several new files when a range is removed.

Create exactly one file per clip

If this option is activated, every clip in the audio montage clone refers to a 
unique file, containing only the audio that is used in the clip. The files are 
named after the clips. A number is added if several clips have the same name.

Create one file per clip, avoid duplicates

If this option is activated, every clip in the audio montage clone refers to a 
unique file, containing only the audio that is used in the clip. The files are 
named after the clips. However, if two clips use the same audio range, a 
common file is created for these clips.

Clips margins

Allows you to add a specified number of seconds before and after the 
beginning and end of the clip range in the created audio files. If you want to 
be able to lengthen the clips in the cloned audio montage at a later stage, 
specify a clip margins value greater than zero.

Reset clip names from file names

If this option is activated, the clips in the cloned audio montage get the name 
of the corresponding audio file.

Copy audio file markers

If this option is activated, the markers in the original audio files are included in 
the recreated files.

Importing Audio Montage Copies

You can open a copy of an existing audio montage in various ways.

PROCEDURE

1. In the Audio Montage workspace, select File > Import > Audio montage 
copy.

2. Select the audio montage that you want to open as a copy, and click Open.

3. In the Import audio montage copy dialog, select which parts of the audio 
montage you want to include in the copy.

4. Click OK.
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Import Audio Montage Copy Dialog

In this dialog, you can specify which parts of the audio montage to include in the 
copy of this audio montage.

In the Audio Montage workspace, select File > Import > Audio montage copy, 
select an audio montage, and click Open.

Do not import clips

If this option is activated, the clips of the opened audio montage are not 
imported. For example, this can be used to open an audio montage with all the 
CD markers in place and to insert alternate audio clips to compare them with 
the original audio montage.

Import markers

If this option is activated, the markers of the opened audio montage are 
imported.

Import track and master plug-ins

If this option is activated, the track and master plug-ins of the opened audio 
montage are imported.

Reuse existing audio files

If this option is activated, the audio files of the opened audio montage are 
used for the copy of this audio montage.

Duplicate audio files

If this option is activated, you can specify a name and destination folder for the 
duplicates of the audio files to create a fully independent audio montage.

Snapshots

You can save a number of snapshots of your audio montage, to capture the current 
zoom factor, cursor position, scroll position, clip selection status, and time range.

You can recall a particular view or snapshot at any time. Snapshots can be named 
and updated.
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To recall a snapshot, double-click its title in the list. This restores all of its view 
settings. You can also choose to recall only specific view properties by activating 
the corresponding checkbox for a snapshot.

Capturing the Current View

Capturing the current view saves the current zoom factor, cursor position, scroll 
position, clip selection status, and time range.

PROCEDURE

1. In the Audio Montage workspace, set up the view of the audio montage 
window.

2. In the Snapshots window, click the Take snapshot icon.

3. Optional: To rename a snapshot, click its name and enter a new name.

RESULT 

A new snapshot is added to the snapshots list.

Updating Snapshots

You can update a previously captured snapshot with the current view.

PROCEDURE

1. In the Audio Montage workspace, in the Snapshots window, click the 
snapshot that you want to update.

2. Click the Update snapshot icon.

RESULT 

The new snapshot replaces the selected snapshot.

Deleting Snapshots

PROCEDURE

1. In the Audio Montage workspace, in the Snapshots window, click the 
snapshot that you want to delete.

2. Click the Delete snapshot icon.
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Snapshots Window

In this window, you can take, recall, and edit snapshots.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Snapshots.

Snapshot List

In the snapshot list, you can activate which view properties you want to restore 
when applying a snapshot. You can activate the following view properties:

Restore zoom and scroll position

Restores the scroll position and zoom.

Restore cursor position

Restores the edit cursor position.

Restore time range selection

Restores the selected time range.

Restore clip selection status

Restores the selection status of each clip as well as the focused clip.

Menu

Take snapshot

Saves the view settings into a new snapshot.

Update snapshot

Takes a snapshot and replaces the selected snapshot.

Delete snapshot

Deletes the selected snapshot.

Apply

Applies all checked view settings that are stored in the selected snapshot. 
Double-click a snapshot for the same result.
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Mixing Down - The Render Function

The render function in the Master Section allows you to mix down the whole audio 
montage or sections of it to a single audio file or to several files in case of a 
multichannel audio montage. It also allows you to render to an audio CD, to a CD 
image and cue sheet, or to a new audio montage.

A mixdown is necessary to produce an audio file from the audio montage. The 
render function can be used for the following purposes:

• Write a CD from a CPU-intensive audio montage, because it allows you to 
first render all track and clip effect processing to recreate a new audio 
montage and then write the CD in a second pass.

• Render audio files or audio montages to multiple file formats at the same time. 
This feature is also compatible with region renderings.

• Render surround channels as multiple files while retaining the stereo/mono 
status of the individual surround channels.

• Create a CD image and cue-sheet.

• Render audio montages to a single file or various parts to multiple audio files 
in one operation. For example, you can render regions, groups, clips, or CD 
tracks.

RELATED LINKS

Rendering on page 380

Rendering to Audio File

You can render to a single audio file format or to multiple audio file formats at the 
same time.

PREREQUISITE 

Set up your audio montage. If you want to render to multiple file formats, create file 
format presets.

PROCEDURE

1. In the Audio Montage workspace, select File > Export > Render.

2. In the Render dialog, make your settings.

3. Activate Create named file.

4. Click the File format field and select Edit.
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5. In the Audio File Format dialog, do one of the following:
• If you want to render to one audio format, make your settings in the Audio File 

Format dialog.

• If you want to render to multiple file formats, click the Multiple file format 
button, click , and select the file format presets that you want to render to.

6. Click OK.

RESULT 

The audio montage is rendered.

If you render a surround mix to Multi Stereo/Mono files, the mono/stereo status of 
the rendered files reflect the mono/stereo status of the surround channels. If the 
audio montage uses a 6 channel (5.1) surround mode, two stereo files (Lf/Rf and 
Ls/Rs) and two mono files (C/Lfe) are rendered. The names of the rendered files 
reflect the name of the surround channel to which they belong.

If you render an 8 channel configuration using the Multi Stereo/Mono option, the 
channels are grouped as logical pairs (1-2, 3-4, etc.). Thus, for tracks that are 
routed to only one channel in a pair, a mono file is created.

Under Windows, you can also render single multichannel surround files in the WMA 
5.1 and 7.1 formats. Use the Windows Media Audio 9 Professional encoder.

RELATED LINKS

Multi Audio File Format Dialog on page 382
Creating Multiple Audio File Format Presets on page 381

Loudness Meta Normalizer

This tool is a key mastering component to ensure that all songs get the same 
loudness and to prevent clipping. It allows you to adjust the loudness of each clip 
in the audio montage so that they all have the same loudness. It is also possible to 
adjust the loudness of the audio montage mix down as well as the loudness at the 
Master Section output.

This tool operates on gains. It does not affect the underlying audio files or use any 
audio compressor.

If it is not possible to match the loudness in a given clip without clipping, the level 
of the other clips is reduced so that all clips still achieve the same loudness. This 
does not happen if the Ignore peaks option is selected.

To avoid clipping at the Master Section stage, you can limit the mixdown output of 
the audio montage before it goes into the Master Section and/or the Master Section 
output.

The loudness is computed according to the EBU R-128 specification. The 
reference loudness can either be the loudness of the loudest clip, of a given clip, or 
a specific custom value.

There are three possible loudness references:
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• Loudness of an entire file (EBU R-128 recommendation).

• Top of a loudness range, that is, the average loudest 3 second audio section 
of the file. This ensures that a single unusually loud sound is not taken into 
account for the reference.

• Maximum short-term loudness, that is, the maximum loudness that is found in 
a 3 second audio section of the file, for example, the loudness of a short music 
passage.

NOTE

• The audio path in the audio montage uses 32-bit floating point processing. 
You can therefore overload it, for example, use levels above 0 dB in clips, 
without causing clipping in the signal path. The only section of the audio path 
that can introduce clipping is the output of the Master Section or the output 
of the audio montage. Both of these issues can also be solved by the 
Loudness Meta Normalizer.

• Since loudness requires several seconds of audio to be correctly computed, 
this tool is not adapted for very short clips (under 3 seconds).

Loudness Meta Normalizer Dialog

In this dialog, you can adjust the loudness of each clip in the audio montage so that 
they get the same loudness. You can also adjust the whole output, while taking the 
EBU R-128 audio measurement recommendation and a true peak analysis into 
account.

In the Audio Montage workspace, select Tools > Loudness Meta Normalizer.

Clips, Master Section Output, and Audio Montage Output

• When Clips is activated, the gain settings of all clips in the audio montage are 
adjusted individually so that all clips play back at equal loudness.
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• When Audio montage output is activated, the general gain setting of the 
audio montage is modified so that the audio montage mixdown matches a 
given loudness and optionally does not clip.

• When Master section output is activated, the Master Section gain is 
adjusted so that the audio montage mixdown that is processed through all 
Master Section plug-ins matches a given loudness and optionally does not 
clip. The audio montage itself is not modified by this operation.

The following options are available for the gain settings of clips, the audio montage 
output, and the Master Section output.

Match loudness menu

Select whether the audio montage output should match a given loudness or 
not. The following options are available:

• Do not change loudness

• Match loudest clip

• Match focused clip

• Match specific loudness

Loudness

Determines the specific loudness to match. For example, -23 LUFS if you 
want to follow the EBU R-128 recommendation for broadcast.

Reference menu

Select the loudness, that WaveLab should reference:

• Loudness of the entire clip (EBU R-128 recommendation)

• Average loudest 3 second audio section (Top of loudness range)

• Loudest 3 seconds audio section (Maximum short-term loudness)

Peaks menu

Select whether WaveLab should limit the sample values (digital peaks), the 
analog reconstructed samples (true peaks), or ignore the peaks.

This setting is less important for clips, as the whole audio montage mixdown 
can be further reduced.

Maximum peak

Determines the maximum peak value that is not to be exceeded.

Additional Options

Exclude audio montage effects

If this option is activated, audio montage effects are not taken into account 
when you use the Loudness Meta Normalizer for processing.

Only selected clips

If this option is activated, only selected clips are processed with the Loudness 
Meta Normalizer.



Audio Montage
Navigator Window

331

Navigator Window

This window displays a representative view of the entire active audio montage and 
allows you to quickly navigate around it. It is useful if you have a large audio montage 
with many tracks and clips.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Navigator.

Each clip is represented by a colored block. The visible window content is shown 
by a black rectangle.

Navigating in the Navigator Window

Navigating in the Navigator window allows you to quickly find positions in large 
audio montages.

Dragging this rectangle in any direction scrolls the main audio montage window, 
thus allowing you to easily navigate to a location in your audio montage.

• To adjust the visible range of the active window, you can resize the selection 
rectangle vertically and horizontally by dragging its edges. You can also resize 
by [Shift]-clicking the selection rectangle.

• To zoom in on a clip, left-click its block, or double-click if the clip is inside the 
black rectangle.

• To completely zoom out, right-click anywhere.

Notes Window

This window allows you to keep notes about the current audio montage session.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Notes.
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You can type into the window and use the standard HTML text editor controls to 
format your text, add images, and lists. The notes are saved with the audio montage 
file.

About Groups

Groups are a selection of clips that you can quickly re-select via the Groups 
window in the Audio Montage workspace, or by clicking any clip of a group.

NOTE

Groups can be seen as a clip selection facility. For advanced grouping features, see 
the chapter about super clips.

A clip cannot be part of more than one group. If you add a clip to a group, it is 
automatically removed from any other group. You can select a specific color for a 
group to make it easy to discern it in the track view.

You can render all groups as individual files in the Render dialog of the Master 
Section.

• To create nested groups, drag a group into another group.

• To temporarily deactivate a group, deactivate the checkbox to the left of a 
group in the list. When a group is deactivated, you can move individual clips 
in the group as if they were not grouped.

• To rename a group, double-click its name.

• To select all clips of a group in your audio montage for editing, click a group.

RELATED LINKS

Super Clips on page 264

Groups Window

This window displays a list of groups within the current audio montage.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
Groups.

Group selected clips

Adds all selected clips to a group.

Remove selected group

Removes the group that is selected in the list. The clips in the group are not 
affected.

A mouse click selects a group

If this option is activated, selecting a clip in the track view automatically 
selects all clips in the same group.
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If this option is deactivated, selecting a whole group requires that you click the 
group name in the groups view list. This is useful if you want to be able to 
modify the relative positions of clips in the group without having to remove 
them from the group.

Color

Lets you select a color for the group.

Grouping Clips

PROCEDURE

1. In the Audio Montage workspace, select the clips that you want to group.

2. In the Groups window, select Group selected clips.

3. Enter a name for the group, and click OK.

RESULT 

The new group appears in the group list. The group name is prepended to the 
names of the clips that are included in the group. This applies to the clip names on 
each track.

Adding Clips to an Existing Group

PROCEDURE

1. In the montage window, select the clips that you want to group.

2. In the Groups window, select Group selected clips.

3. Select the group to which you want to add the clips, and click OK.

Removing Groups

PROCEDURE

1. In the Audio Montage workspace, in the Groups window, select a group.

2. Select Functions > Remove selected group.

RESULT 

The group is removed, and the clips are not affected.
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Coloring Groups

Coloring groups in different colors makes it easier to navigate through the groups.

PROCEDURE

1. In the Audio Montage workspace, in the Groups window, select a group.

2. From the Color menu, select a color.
Any individual color selections for the clips override the group color.

Backing Up Audio Montages

The Audio Montage workspace backup mechanism allows you to maintain previous 
versions of saved audio montages and automatically save the audio montage.

Whenever you save the audio montage, the previously saved version is copied to 
the subfolder Backup.mon which is in the same folder as the audio montage file. 
This backup folder is automatically created by WaveLab. The backup files are 
named “Montage_#X”, where “Montage” is the name of the audio montage and “X” 
is a number.

You can specify how many previous versions you want to keep (maximum 1000). 
Once the specified number of backups is created, the oldest file is overwritten each 
time the audio montage is backed up.

NOTE

The numbers in the backup file names are not related to the age of the backup files. 
Instead, you must check the dates of the files to know which backup is the most 
recent.

Unsaved and untitled audio montages are also backed up. The backup files for 
“Untitled” audio montages are saved in the temporary folder, and use a number as 
name, so that the files are called “Y_#X”, where “Y” is a number identifying the 
audio montage, and “X” is the number of the backup file. Once the audio montage 
is saved, these temporary backup files can be discarded.

Setting Up the Audio Montage Backup

You can specify the number of audio montage backups and define how often the 
backup should be updated.

PROCEDURE

1. In the Audio Montage workspace, select Options > Audio montage 
preferences.

2. Select the All Audio Montages tab.
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3. Specify the maximum number of backups.
To turn off the backup function, set this setting to 0.

4. Optional: Activate Auto save, and specify how often the backup should be 
updated.

5. Click OK.

Opening an Audio Montage Backup

You can open the backup of an audio montage to restore a former version of the 
audio montage.

PROCEDURE

• In the Audio Montage workspace, select File > Open previous version.

RESULT 

If the audio montage has no unsaved changes, the most recent backup file is 
opened in a new window. If you select the function from an open backup file, the 
previous backup version is opened.

If the audio montage has unsaved changes, the saved audio montage file is opened 
in a new window. The opened audio montage is not a backup file. This is not the 
same as selecting File > Revert to saved.

Revert to saved closes the current (unsaved) audio montage and opens the last 
saved version. This replaces the current audio montage, while Open previous 
version opens the saved version in a new window without closing the current, 
unsaved version.

Multichannel Operations in the Audio Montage

WaveLab supports the use of up to 8 ASIO inputs and outputs. If you use a 
multichannel audio interface with an ASIO driver, you can route audio montage 
tracks to up to 8 separate channel outputs and to up to 6 surround outputs.

You can also record up to 8 channels simultaneously. This automatically creates 
new tracks in the montage, one for each recorded channel or channel pair.

To be able to use WaveLab for multichannel/surround projects, you need the 
following:

• An audio card/interface with multiple inputs and outputs (at least 8).

• Set up an ASIO driver in the VST Audio Connections dialog, and specify 
how the internal input/output channels are connected to your audio card.
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Multichannel Configuration

You can configure the number of channels to use for each audio montage. All 
multichannel configurations except the free configuration mode have surround 
formats and are internally assigned to surround channels in WaveLab. This means 
that the channels go through the Master Section and then to the audio card.

The are two operational modes that you can use for multichannel operation:

• In the Multichannel, DVD-Audio compatible mode, in surround mode, tracks 
can be routed to one or several surround output channels (Left/Right Front, 
Center, etc.). You can route up to 6 surround channels.

• In the Multichannel, free configuration mode, channels refer to the names 
of the 8 WaveLab output channels instead of the surround channels. Track 
channels can be routed to one (mono tracks) or two (stereo tracks) of the 8 
available output channels.

Which configuration you should select depends on a number of factors:

• The number of outputs that are available on your audio card. If you only have 
4 outputs on your card, you can only use surround formats with 4 or less 
channels.

• Whether or not you intend to mix the audio montage to a surround format. If 
not, select normal stereo operation or 8 channel mode which is 
non-surround-oriented.

• The intended use of the final surround mix. For example, if you want your mix 
to be compatible with the 5.1 surround set-up, select 6 channel mode.

Assigning Track Channels to Output Channels

When you select a multichannel configuration, you must create and assign track 
channels to surround output channels manually. However, when you import a 
multichannel interleaved audio file in the 5.1 format, tracks that are routed to the 
corresponding surround channels are automatically created.

PROCEDURE

1. In the Audio Montage workspace, in the track control area, click the Audio 
Track Dispatching button for an audio track.
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2. In the Audio Track Dispatching dialog, route each channel of a track to an 
output channel by activating the corresponding channels.
Which channels are available depends on the selected channel configuration.

3. Click OK.

RESULT 

If you have selected a surround format, you can route a track channel to several or 
all surround output channels. If you select more than one output channels for a 
stereo track channel, the Surround Panner automatically appears in the track 
control area for the corresponding track.
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Audio Track Dispatching Dialog

In this dialog, you set up to which channels the top and bottom audio channels of 
the audio montage are sent. The available channels depend on the selected channel 
configuration, for example, stereo or multichannel.

In the Audio Montage workspace, in the track control area, click the Audio Track 
Dispatching button for an audio track.

Top audio channel is sent to

Lets you select to which audio montage audio outputs the left channel of the 
track is sent and mixed.

Bottom audio channel is sent to

Lets you select to which audio montage audio outputs the right channel of the 
track is sent and mixed.

Low pass filtering of the LFE channel

If an LFE output is selected, a low pass filter (12 dB/octave) can be applied to 
the track signal so that only the low frequency content can pass. The cutoff 
frequency for the filter can be adjusted.

Surround Panning

You can use surround panning to position a track freely in the surround image.

The Surround Panner lets you adjust the pan of your audio between surround 
sound channels. Each track can have its own Surround Panner window, and 
several of these windows can be open at the same time.
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Using Surround Panning

You can route any audio montage channel of a track directly to a surround channel 
or to a combination of surround channels using the Audio Track Dispatching 
dialog. However, if you also want to position a track freely in the surround image, 
you can use the Surround Panner.

In this example, it is assumed that you have set up an audio montage in 5.1 surround 
format and that you want to use the Surround Panner for a stereo track.

PROCEDURE

1. In the Audio Montage workspace, in the track control area, click the Audio 
Track Dispatching button for the track that you want to use for surround 
panning.

2. In the Audio Track Dispatching dialog, activate the surround channels.
You can activate different surround channel combinations for the top (left) and bottom 
(right) audio channels.

3. Click OK.
A Surround Panner display appears in the track control area.

4. Click and drag in the Surround Panner display to make coarse adjustments.
For a more precise control of the imaging, right-click the Surround Panner display to 
open a larger version of the Surround Panner.

5. In the Surround Panner dialog, click the blue square and move the mouse.
This pans the audio of the left/top channel. The other channel is automatically 
mirrored horizontally. Right-click the display to choose from a number of positioning 
presets.

6. To view and edit the other channel, click the gray square.
The gray square turns to red, and red speaker lines indicate the speaker levels.

7. When you have finished your settings, click Close.
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Surround Panner Dialog

This dialog allows you to adjust the pan of your audio between surround sound 
channels.

In the Audio Montage workspace, set up a multichannel, DVD-Audio compatible 
audio montage, and select 2 or more output channels per track channel. For each 
track that is set to Surround in the Audio Track Dispatching dialog, a small 
Surround Panner window is displayed in the track view.

Right-click on the small Surround Panner window to open the Surround Panner 
dialog.

In the graphic display, the positions of the left/right audio channels of the clip are 
shown as small squares. The proportional signal levels of the individual speakers are 
indicated by colored lines from the speakers to the center of the display.

The graphic display shows the surround imaging of either the left/top (blue) track 
audio channel, or the right/bottom (red) track audio channel. The color of the 
speaker lines shows which channel is selected for viewing and editing.
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If you are viewing the left/top channel, you see a blue square indicating the position 
of the audio. The other, gray square represents the other channel. Click the gray 
square to view and edit this channel. The gray square turns to red and red speaker 
lines indicate the speaker levels.

Center

Determines how much the track signal should be mixed into the audio 
montage output corresponding to the center speaker. This is only available if 
the Center channel is activated in the Audio Track Dispatching dialog.

Divergence

Determines the attenuation curve that is used when positioning sound 
sources. If this is set to 0 %, positioning a sound source on a speaker sets all 
other speakers to zero level, except for the center speaker which depends on 
the center level. With higher values, the other speakers receive a percentage 
of the sound source. This makes the sound less localized.

Front/Rear ratio

Determines how much the front and rear levels are affected by the vertical 
positioning in the Surround Panner dialog. The higher the ratio, the less 
difference exists between sounds that are panned front and rear. If set to 
100 %, the rear and front levels are always the same.

Constant power

Determines whether the loudness (RMS) or the level of the summed signals 
should be preserved. If set to 100 %, the total loudness is the same regardless 
of panning settings. If set to 0 %, the total level is preserved.

LFE Gain

Sets the amount of signal that are sent to the LFE channel. This is only 
available if the LFE channel is activated in the Audio Track Dispatching 
dialog.

Copy

Copies the settings of the selected Surround Panner to the clipboard.

Paste

Applies the copied settings to the Surround Panner.
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Presets menu

Right-click the graphical view of the Surround Panner to select from different 
surround panning presets.

About Surround Pan Envelopes

You can automate surround panning for individual clips using envelopes. This is 
slightly different from using regular volume and pan envelopes.

• Internally, there is a single surround pan envelope where each envelope point 
contains a complete surround state (left-right position, front-rear position, and 
LFE amount).

• When you look at the envelope for a clip, you can choose to view either the 
left-right, front-rear, or the LFE curve.

• When setting envelope points for either one of the envelope types, that point 
is automatically added to the other envelope types at the same position in the 
clip. This happens because there is actually only one surround pan envelope. 
However, you can only edit a part of it at the same time.

Setting Up Surround Panning Envelopes

You can use the Surround Panner to program each envelope point. This makes it 
easy to set up automated surround panning for a clip.

If you want the signal to start at the front center position, then move to the left rear 
speaker, and finally move to the right rear speaker, do the following:

PROCEDURE

1. In the Audio Montage workspace, set up a track for surround panning by 
activating the surround channels in the Audio Track Dispatching dialog.

2. Select the clip, and open the Focused Clip window.

3. On the Envelope panel, select one of the Surround Pan envelopes.
For example, Surround Pan (Left <-> Right).

4. In the montage window, double-click the envelope to add a new envelope 
point in the middle of the clip.
This will be the position where the signal reaches the left rear speaker. Only the 
position in the clip is important when you create envelope points at this stage, not the 
vertical position of the point.

5. In the track control area, right-click the Surround Panner display.

6. In the montage window, select the envelope point at the start of the clip.

7. Use the Surround Panner dialog to position the sound. In our example, the 
panning should start in the front center position. Drag the position square to 
the top middle of the display. You can also right-click the display and select 
the Front Center preset.
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8. In the montage window, select the next envelope point in the clip, and in the 
dialog, drag the position square to the lower left corner of the display. You can 
also right-click the display and select the Rear left preset.

9. In the montage window, select the last envelope point, and in the dialog, drag 
the position square to the lower right corner of the display. You can also 
right-click the display and select the Rear right preset.
The left-right surround envelope curve now looks like this:

10. In the Focused Clip window, on the Envelope panel, select Surround Pan 
(Front <-> Rear).
The Front-Rear surround envelope curve looks like this:

11. Play back the clip.
You should hear the sound move from center front to left rear to right rear.

12. To create more complex surround panning, add more envelope points and 
program these in the same way.

Editing Envelope Curves Directly

You can edit the envelope curves without affecting other panning settings, by 
adjusting their points in the clip. This can be useful if you only want to change the 
LFE amount without affecting panning, or if you only want to change the left-right 
panning without affecting front-rear panning and vice versa.

NOTE

If you move an envelope point in time, all surround pan envelopes are affected in the 
same way.
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About the Multichannel, DVD-Audio Compatible Mode

When the Multichannel, DVD-Audio compatible mode is activated for an audio 
montage, you can choose between various multichannel configurations. The 
surround channels can be handled as mono or stereo channels.

In the Audio Montage properties dialog, select Multichannel, DVD-Audio 
compatible. In the Channels menu, the following multichannel configurations are 
available:

About the Free Configuration Mode

When the free configuration channel mode is selected, you can route track 
channels to one of the 8 output channels. Free configuration mode is non-surround 
oriented and enables you to use the audio montage as an 8 channel 
recording/playback environment.

To activate this mode, select Edit > Audio montage properties, and from the 
Mode menu, select Multichannel, free configuration.

Channels are grouped as stereo pairs (1-2, 3-4, etc.), which is reflected in the 
Master Section and when rendering to multiple files.

Surround channel Description

Left/Right front (Lf, Rf) This is used in all surround configurations. These correspond 
to standard left/right stereo speaker positions in front of the 
listener. You should route a stereo track to these channels.

Center (C) This is placed in between the Lf/Rf surround speakers. You 
should route a mono track to this channel.

Low Frequency 
Effects (LFE)

The LFE channel is connected to a subwoofer and provides 
low frequency content (normally below 120 Hz). It normally 
used to provide special low frequency effects like deep 
rumbles, explosions, etc. For each channel that is routed to the 
LFE channel, there is a low-pass filter that allows you to extend 
or lower the low frequency range that is reproduced by the 
LFE channel. There are no strict rules for where to place the 
LFE subwoofer, but it is usually placed in an asymmetrical 
position beside the center speaker. You should route a mono 
track to this channel.

Surround (S) This is sometimes referred to as the back surround channel 
and is normally placed in between the left/right surround 
channels. You should route a mono track to this channel.

Left/Right Surround 
(Ls, Rs)

These are placed behind the listening position, mirroring the 
left/right front speakers. You should route a stereo track to 
these channels.
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About the Enable Additional DVD-Audio Configurations Option

The DVD-Audio specification allows for mixed sample resolutions within the same 
channel configuration, which therefore needs to be divided into two separate 
groups. For example, the Lf/Rf channel group could, according to the standard, 
have a higher sample rate resolution than the other surround channels in the same 
configuration.

The slash in the surround channel menu indicates which channels belong to which 
group.

However, the use of mixed resolutions is not supported in WaveLab and disabled 
by default.

To allow all possible modes, in the Audio Montage properties dialog, select 
Multichannel, DVD-Audio compatible mode, and activate Enable additional 
DVD-Audio configurations.

Multichannel Recording

You can record up to 8 channels simultaneously in the audio montage.

Multichannel Recording Preparations

PREREQUISITE 

Set up how the inputs on your audio card are connected to the internal channels of 
WaveLab.

PROCEDURE

1. In the transport bar of the Audio Montage workspace, click the Record 
button, or press [*] on the numeric key pad.

2. From the File to create section, select whether to create a named file or a 
temporary file.

3. Specify a file name and the location where you want to store the file.

4. Click the audio format text to open the Audio File Format dialog.

5. Select the audio file format.

6. On the Channels menu, select Multi Stereo/Mono or Multi Mono.
Multi Stereo/Mono produces single stereo or mono files, depending on the 
activated channels in the Recording channels dialog. The channels are logically 
grouped as pairs (1-2, 3-4, etc.). This governs the mono/stereo status of the 
recorded files and the tracks they will end up on. For example, if you have activated 
the channels 1, 2, and 3, one stereo file (containing channels 1 and 2) and one mono 
file (channel 3) will be created.

7. Click OK.

8. On the menu below the file format, select Add to focused track of montage.
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9. Select Set input, activate the channels from which you want to record, and 
click OK.
For each of the activated recording channels, a meter is displayed in the Recording 
dialog.

10. Optional: Make further settings.

Recording a Multichannel Project

PREREQUISITE 

Prepare a multichannel recording.

PROCEDURE

1. In the Audio Montage workspace, set the edit cursor where you want to start 
recording.

2. In the Recording dialog, click Record.

3. When you have finished recording, click Stop.
When you record on multiple channels, new tracks are automatically created in the 
audio montage, one for each mono or stereo clip that is recorded. Each track is routed 
to the same output by default, but can be routed to any output that is used in the 
current configuration in the Audio track dispatching dialog.

RESULT 

If you have activated more than 2 input channels in the Recording channels dialog 
and select any channel option except the Multi Mono or Multi Stereo/ Mono 
options, the activated recording inputs are mixed and produce a single file (or two 
if you selected Dual Mono).

Multichannel Configurations in the Master Section

The Master Section automatically rearranges itself when starting play back of a 
multichannel audio montage. You can rearrange the Master Section without starting 
playback by clicking the Rearrange icon at the top of the Master Section.
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The output channels for the selected channel configuration are displayed in the 
Master Section, with one level fader and clip indicator for each output channel.

Stereo Mixdown of a Multichannel Configuration

The Stereo button in the Master Section allows you to monitor a stereo mixdown of 
the Master Section outputs.

You can use this for the following:

• Preview a stereo mixdown of a surround mix.

• Preview stereo mixdown settings for DVD-Audio projects.

Master Effects and Multichannel Audio Montages

Handling effects for a multichannel audio montage is similar to handling effects 
when working in stereo mode. However, not all plug-ins support multichannel 
operations. In this case, a warning is displayed when you try to insert them.

XML Export and Import of Audio Montages

You can export and import audio montages as XML.

This option can be used for the following:

• Change many file names that are used by the audio montage.

• Generate audio montages from scratch or from a template.

• Compare two audio montages with a text file comparing tool.
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Exporting and Importing XML Files

• To export an audio montage to XML, in the Audio Montage workspace, select 
File > Export > Export as XML file.

• To import an audio montage that was previously saved as an XML file, in the 
Audio Montage workspace, select File > Import > Audio Montage as XML 
file.

AES-31 Files Export and Import

The AES-31 standard is an open file interchange format for overcoming format 
incompatibility issues between different audio hardware and software. It can be 
used for transferring projects via disk or network from one workstation to another, 
retaining time positions of events, fades, etc.

AES-31 uses Broadcast Wave as the default audio file format. AES-31 files can be 
transferred to and used with any digital audio workstation that supports AES-31, 
regardless of the used hardware and software, as long as the workstation can read 
Broadcast Wave files.

The exported files are XML files but with the extension .adl (audio decision list).

Exporting AES-31 Files

When exporting audio montages to an AES-31 file, the file contains all audio track 
data, including audio file references.

PROCEDURE

1. In the Audio Montage workspace, select File > Export > Export as AES-31 
file.

2. Specify a name and file location, and click Save.

3. In the AES-31 Export options dialog, edit the settings, and click OK.
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AES-31 Export Options Dialog

In this dialog, you can set up the behavior of the AES-31 export.

In the Audio Montage workspace, select File > Export > Export as AES-31 file, 
specify a name and file location, and click Save.

Render linear fades as audio files

If this option is activated, linear fades, which are dynamically computed by 
WaveLab, are rendered to small audio files while preserving the exact audio 
effect.

Render curved fades as audio files

If this option is activated, complex fades, which are dynamically computed by 
WaveLab, are rendered to small audio files while preserving the exact audio 
effect.

Render crossfades as audio files

If this option is activated, crossfades, which are dynamically computed by 
WaveLab, are rendered to small audio files while preserving the exact audio 
effect.

Skip muted clips

If this option is activated, muted clips are not included in the AES-31 file.

After exporting, import file

If this option is activated, the exported file is immediately imported. This lets 
you check the export result.
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Importing AES-31 Files

PROCEDURE

1. In the Audio Montage workspace, select File > Import > AES-31 file.

2. In the file browser, select the AES-31 file that you want to import, and click 
Open.

3. In the AES-31 Import options dialog, edit the settings, and click OK.

RESULT 

The imported AES-31 file opens as a new, untitled audio montage that contains all 
the audio tracks that are stored in the AES-31 file.

AES-31 Import Options Dialog

In this dialog, you can set up the behavior of the AES-31 import.

In the Audio Montage workspace, select File > Import, and open an AES-31 file.

Use linear fade files if available (otherwise, create dynamic fades)

If this option is activated, the available audio files for linear fades are used. If 
no files are available, dynamic fades are created.

Use curved fade files if available (otherwise, create dynamic fades)

If this option is activated, the available audio files for complex fades are used. 
If no files are available, dynamic fades are created.

About Importing AES-31 Files Created in Nuendo

By importing an AES-31 file, you can, for example, import a project that was created 
in Steinberg’s Nuendo into WaveLab.

In this case, it is possible to add specific codes to the marker names in Nuendo to 
facilitate their conversion into WaveLab-specific markers. For example, if an 
AES-31 file that was exported in Nuendo is imported into WaveLab, the markers 
that it contains are interpreted as WaveLab markers upon import.

For the CD track markers, you can use the following codes:
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• You must use Nuendo 2.0 or later if you want to create specially named 
markers that are interpreted as WaveLab markers.

• In Nuendo, a marker track must be created for the specially named markers.

• When importing AES-31 projects that contain specially named markers, the 
marker codes are not displayed in WaveLab.

Marker Type Marker Code Example Marker Name

CD track start [t-start] “So it begins [t-start]”

CD track end [t-end] “The end [t-end] of the 
road”

CD track splice [t-splice] Intermission [t-splice]

CD track index [t-index] [t-index] Hello
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Recording

You can record audio in the Audio Files workspace and in the Audio Montage 
workspace.

Setting Up the Recording Dialog

Before you start recording, set up the Recording dialog.

PROCEDURE

1. In the Audio Files workspace or the Audio Montage workspace, click the 
Record button, or press [*] on the numeric key pad.

2. In the File to create section, open the pop-up menu, and select whether you 
want to record a named file or a temporary file.

3. In the File to create section, select a file name and the location where you 
want to store your file.

4. Select the audio format by doing one of the following:
• Click the down arrow button to select a preset audio format.

• Click the audio format text to open the Audio File Format dialog, select the 
format, and click OK.

5. Select whether you want to record to an audio file or an audio montage track, 
by selecting one of the following options:
• Create new audio file window
• Add to active audio file
• Add to focused track of montage

6. Select an Input mode, depending on whether you want to record the audio 
card input or the playback output.

7. Select Set input, activate the channels that you want to record to, and click 
OK.
For each of the activated recording channels, a meter is displayed in the Recording 
dialog.

8. Select whether you want the Level or the Spectrum display.

9. Optional: Make further settings in the Options section, and on the Options 
and the Values tabs.
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10. Click Record, to start recording.
If you have selected one of the Auto-start options, the recording goes into Pause 
mode, until the specified Auto-start criteria are met.

The background of the Recording dialog turns red to indicate that you are recording.

11. Optional: You can pause the recording by clicking the Pause button.

12. Optional: You can drop markers in the file during recording by clicking the 
drop marker buttons.

13. When you have finished recording, click Stop.

14. Optional: If you want to record another take, click Record again.

Dropping Markers During Recording

When you are recording, you can click the marker buttons to add a marker to the 
recorded file.

PROCEDURE

1. Open the Recording dialog.

2. Optional: If you want to name the markers that you drop rather than using 
generic markers, do the following:
• Activate Recording > Options tab > Confirm name of markers to drop.

• On the Method tab, type the name in the Next marker name field.

3. Make your settings and start recording.



Recording
Recording Dialog

354

4. Select the type of marker that you want to drop.
• To drop a numbered generic marker, click the yellow marker button, or press 

[Ctrl]/[Command]-M.

• To drop numbered generic region start and end markers, click the white 
buttons, or press [Ctrl]/[Command]-L/[Ctrl]/[Command]-R.

When you chose to confirm marker names to drop, a dialog appears each time you 
drop a marker. In this dialog, you can enter a name and specify an offset, which allows 
you to place a marker at a specific time before you triggered the command.

RESULT 

The markers are dropped each time that you click the marker button.

NOTE

If you insert two or more region start markers in a row with no region end markers 
in between, only the last of these start markers is kept. The same applies for region 
end markers.

Recording Dialog

In this dialog, you can make recording settings and start recording an audio file.

In the Audio Files workspace or the Audio Montage workspace, click the Record 
button or select Transport > Record.

Main Buttons

Record

Starts recording. Depending on the recording options, the Pause mode is 
activated.

Split now

Opens the audio already recorded in a new window while recording 
continues. By clicking this button, you can decide when the splitting occurs. 
The button is activated if you are recording a named file, you are not pausing, 
and Split mode is not activated.

Pause

Pauses recording.
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Stop

Stops recording.

Discard

Stops recording and deletes anything recorded so far.

Method Tab

On this tab, you can define options for starting, stopping, and pausing the recording 
automatically. You can select an input device and choose to start a recording at a 
specific time or stop if after a specific duration.

File to create

Specify whether you want to record a temporary file to be saved later, or 
record to a file with a specific name and location.

Auto number from

If this option is activated, increasing numbers are added to the file names of 
the successively saved files.

Name

The name of the file to be written, without the path. When typing, all files in 
the selected folder that start with the same letters are displayed. To display all 
files in the selected folder, click the list icon.

Where

Specifies the folder where you want to save the recording.

Audio File Format

Opens the Audio File Format dialog, where you can specify the file format.

Location of the Recording

Specifies where the audio is recorded:

• In a new audio file window.

• In an existing audio file is inserted at the edit cursor position (if none 
exists, a new one is created).

• In an existing audio montage is inserted at the edit cursor position (if 
none exists, a new one is created).
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Input

Specify if you want to record the audio device input or the audio output from 
the Master Section.

Set input

If you are using an ASIO driver, this button opens the Recording channels 
dialog, where you can activate channels for recording. Up to 8 input channels 
can be used simultaneously. When additional inputs are selected, the number 
of meters in the dialog is automatically updated.

Auto-start if sound detected

If this option is activated, recording starts when the audio input level exceeds 
the threshold level specified on the Values tab.

Auto-start at given time

If this option is activated, recording starts at a specified time according to the 
computer clock. Specify the time on the Values tab.

Auto-stop after given duration

If this option is activated, recording stops automatically after the duration 
specified on the Values tab.

Auto-stop if silence

If this option is activated, recording automatically stops when the audio input 
level drops below a specified threshold level and stays there for a certain 
amount of time. Specify the level and the duration on the Values tab.

Auto-pause if silence

If this option is activated, recording automatically pauses when the audio input 
level drops below a specified threshold level and stays there for a certain 
amount of time. Specify the level and the duration on the Values tab.

Auto-create markers at pause point

If this option is activated, a generic marker is created each time you click 
Pause during recording.

Auto-create markers at silence points

If this option is activated, a generic marker is created each time the audio input 
level drops below a specified threshold level and stays there for a certain 
amount of time. You specify the level and the duration on the Values tab.
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Split mode

If this option is activated, the recording is split into several audio files. The files 
can be split either by size (after a certain amount of MB), or by duration (after 
a certain amount of time). Split mode is useful if you make long continuous 
audio recordings, such as live recordings.

• This option is only available when Named File is selected.

• Split files are contiguous, that is, there are not gaps between the files.

• Selecting Split mode automatically activates the Auto number option 
for audio file names.

NOTE

It is recommended to save each Split mode recording in an empty folder. This 
prevents the Auto number option from creating files with names that already 
exist in this location.

Options Tab

On this tab, you can make additional settings for the recording process.

Activate monitoring when opening record window

If this option is activated, the meters are activated when the Recording dialog 
opens. If this option is deactivated, the meters and the audio thru are 
displayed when pressing Record or activating Monitor.

Deactivate monitoring when ending recording

If this option is activated, the meters and the audio thru are deactivated when 
recording ends. This releases the audio device input.

Stop playback when monitoring or recording

If this option is activated, playback stops before monitoring or recording 
starts.

Show Discard button

Determines whether the Discard button is visible or hidden.

Confirm when discarding recording

If this option is activated, you are asked to confirm before discarding a 
recording.

Confirm when stopping recording

If this option is activated, you are asked to confirm before stopping a 
recording.
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Confirm name of markers to drop

If this option is activated, you are asked to enter a name for the last dropped 
marker.

Open audio file in WaveLab after recording

If this option is activated, the audio files are opened in WaveLab after 
recording.

Add markers when inserting recording in audio file

If this option is activated and a recording is inserted into an audio file, markers 
are added encompassing the new samples.

After recording, move edit cursor at the end

When recording into an audio file or montage, it is often convenient to move 
the cursor to the end of the recording.

Values Tab

On this tab, you can define values for the various recording options.

Auto-start on sound - Threshold (RMS)

Specify the average sound level that is sufficient to trigger recording.

Auto-start on sound - Record previous samples

Allows you to include a short section of audio before the start point, to capture 
attacks, for example. It is only relevant when the option Auto-start if sound 
detected is activated.

Silence Detection - Threshold (RMS)/Silence duration required

The threshold value used for the options Auto-stop if silence and 
Auto-create markers at silence points. It is used in conjunction with the 
Silence duration required setting, so that recording is stopped or a marker 
is added if the input level stays below the threshold value for the specified 
duration.

Recording programming - Start

Determines the time at which recording starts when the option Auto-start at 
specific time is activated.

Recording programming - On tomorrow

If this option is activated, you can specify a time on the next day.
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Recording programming - Duration

Determines the length of the recording when the option Auto-stop after 
specific duration is activated.

Split argument - File size

If this option is activated, a new file is created when the recorded file reaches 
the size specified in the corresponding value field.

Split argument - File duration

If this option is activated, a new file is created when the recorded file reaches 
the length specified in the corresponding value field.

Pause memory

This is a safety buffer when you are using the Pause button. When you resume 
recording, this buffer is used to restore the last short section of audio before 
you deactivated the pause button. This way, you can resume recording even 
if you deactivated the Pause button a bit too late.

Meter Display

Level/Spectrum

Specifies which meter to display.

Settings

Opens the LeveL/Pan Meter Settings dialog, where you can customize the 
meter settings.

Reset

Resets the peak values.

Monitor

If this option is activated, the audio input is also sent to the output ports (not 
available if Windows MME drivers is used).

Mix with playback

If this option is activated and the same audio ports are selected for monitoring 
and for playback (in the VST Audio Connections dialog), the signals are 
mixed. If this is not activated, the monitoring signal has priority.

This allows you to toggle between the auditioning of the recorded signal and 
the playback signal, and to have full control over the monitor outputs.

Next marker name

Edit the name of the next marker to insert.
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Solo

Reduces/increases the size of the window and hides/shows all other 
WaveLab windows.

Meter Display

In the lower part of the Recording dialog, you find a meter display. This is useful for 
checking the input level and the frequency spectrum of the input signal.

The meters in the Recording dialog are miniature versions of the Level, Spectrum 
in the meter windows. Activate the meters, by activating the Monitor checkbox.This 
is done automatically, if the option Activate monitoring when opening record 
window is activated on the Options tab in the Recording dialog.

To reset the meters, click the Reset button.

Level Meter

In the Level meter, horizontal bars show the peak level (outer bars) and average 
loudness (VU, inner bars) of each channel. Values are also shown numerically. 
When clicking the Settings button, the Level/Pan Meter Settings dialog opens.

Spectrum Meter

The Spectrum Meter shows a bar diagram, providing a continuous graphical 
representation of the frequency spectrum. From the Settings pop-up menu you can 
choose whether to restrict to high audio levels, or to include medium or low audio 
levels.

Disk Capacity Indicator

This indicator at the bottom of the Recording dialog indicates the approximate 
amount of available disk space on the hard disk specified in the File to create 
section, or the hard disk that you have selected for temporary files.

NOTE

When there is less than 30 seconds of available hard disk space left, the disk 
capacity indication is displayed in red.
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Recording in the Audio Montage Workspace

You can record audio directly as clip in the audio montage.

By Using the Track Menu

PROCEDURE

1. In the Audio Montage workspace, click at the position where you want the 
recorded clip to start.

2. Select Track > Record at cursor.

By Using the Track Menu During Playback

PROCEDURE

1. In the Audio Montage workspace, start playback.

2. Select Track > Record at cursor.

3. In the Recording dialog, make your settings.

4. Click Record.

NOTE

If you first go into Pause mode and then activate recording, you get a pre-roll 
time according to the pause buffer, allowing you to capture the audio just 
before you start recording.

About Playing Back During Recording

When you record in a multitrack environment, it is often necessary to have the 
existing track play back during recording, performing an overdub.

For this to be possible in the audio montage, Stop playback when monitoring or 
recording must be deactivated on the Options tab of the Recording dialog.
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Master Section

The Master Section is the final block in the signal path before the audio is sent to 
the audio hardware, to an audio file, or to the audio meters. This is where you adjust 
master levels, add effects, and apply dithering.

The settings and effects in the Master Section are taken into account in the 
following cases:

• When playing back an audio file in the wave window.

• When playing back an audio montage. Note that the Master Section effects 
are global for all clips and tracks in an audio montage, as opposed to the 
individual clip or track effects.

• When using the Render function.

• When using the Audio input plug-in.

• When writing a CD from the audio montage.

By default, the Master Section is active. You can turn it off for each file individually 
by deactivating the Play through Master Section button at the bottom of the 
wave/montage window.

To turn the Master Section off globally, deactivate the Playback goes through 
Master Section button at the bottom right of the Master Section.
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Master Section Window

In this window you can apply effect plug-ins, adjust the master level, apply dithering, 
and render the audio file or audio montage.

To open the Master Section window, in any workspace, select Global > Master 
Section.

The Master Section consists of the Effects pane, the Master Level pane, the 
Dithering pane, the Post-Processing pane, and the Speaker Configurations 
pane.
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Signal Path

The three panes in the Master Section window correspond to the three processing 
blocks of the Master Section: Effects, Master Level, and Dithering.

The signal passes through these blocks from top to bottom, as shown in the 
following figure:

In the Master Section, the signal goes through all plug-ins, even when some 
plug-ins are soloed. However, the sound is not affected by this because the muted 
plug-ins are bypassed from the playback process stream.

When removing the bypass, the process signal is immediately available without 
latency. This allows you to quickly switch between different solo/mute settings.

The Master Section meters can monitor the signal right after any slot if the 
Monitoring point icon is activated for the corresponding slot.
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Effects Pane

This pane in the Master Section allows you to add up to 10 effect plug-ins in series, 
and manage them.

In the Audio Files workspace or the Audio Montage workspace, select Workspace 
> Shared tool windows > Master Section.

Rearrange

Rearranges the Master Section according to the sample rate and channel 
configuration of the active audio file. The internal bus of the Master Section 
and any active plug-ins are configured accordingly.

This operation is performed automatically before playback or rendering. It is 
sometimes helpful to manually rearrange the Master Section, because some 
plug-ins do not accept a mono or stereo signal as input, or a given sample 
rate. In that case, clicking the button informs you about any problems, before 
playback or rendering.

This operation has no effect if playback is already in progress or if there is no 
active audio file.

Show one more slot

Makes one more slot visible.

Hide bottom slot

Hides the bottom slot.

Fold/unfold section

Expands or collapses the Effects pane.

Bypass during playback

Bypasses the plug-in during playback and optionally for a rendering 
operation. The signal is still processed by the plug-in, but is not injected in the 
audible stream.

Solo (bypass)

Bypasses all plug-ins except this one during playback.

Monitoring point

Lets the Master Level meter monitor the signal right after this plug-in.

Effect plug-in slot

Slot where you can insert an effect plug-in.
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Presets menu

Lets you store and recall preset settings. The Presets menu offers additional 
options to save and load default banks and effects.

Plug-in visibility

Activates/Deactivates the plug-in window.

Lock slot

Locks the slot. A locked slot is not bypassed if the Solo function is active. The 
plug-in in the slot remains as is when a Master Section preset is loaded, or 
when Reset all is used.

Switch effect on/off

Excludes the plug-in from playback and rendering, and rearranges the bus 
without this effect.

Supported Effect Plug-in Formats

WaveLab supports different plug-in standards. WaveLab-specific plug-ins, VST 2 
plug-ins and VST 3 plug-ins, and plug-ins that adhere to the Microsoft DirectX 
standard.

WaveLab-specific Plug-ins

Some specific plug-ins are included in WaveLab, for example, the Audio Input and 
External Gear plug-ins. These are only available if you are using an ASIO driver.

VST Plug-ins

Steinberg’s VST plug-in format is supported by a lot of programs and plug-in 
manufacturers. You find a number of VST plug-ins included with WaveLab. Other 
plug-ins can be purchased separately from Steinberg or other manufacturers, or in 
some cases downloaded from the internet.

Plug-ins that Adhere to the Microsoft DirectX Standard

These are known as DirectX or DX plug-ins and are also widely available.

Setting Up Effects

The number of effects available depends on which plug-ins you have installed.

• To select an effect plug-in for a slot, click the slot, and select an effect from 
the pop-up menu. When you have selected an effect, it is automatically 
activated, and its control panel opens.

• To turn off an effect, click its Switch effect on/off button. To activate the 
effect, click again.

• To remove an effect plug-in, click the slot, and select None.
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• To hide the control panel of an effect, click its Plug-in visibility button.

• To solo an effect, click the Solo button to the left of the effect slot. This allows 
you to check the sound of that effect only. You can also bypass effects in their 
control panels.

• To change the order of the slots, and thus the order in which the signal passes 
through the effects, click a slot, and drag it to a new position.

Master Section Plug-in Window

In the plug-in windows of the Master Section, you can make settings for a Master 
Section effect plug-in, such as bypass, solo, render in place, monitoring, or presets.

In the Master Section’s Effects pane, click an effect’s Plug-in visibility button to 
open the corresponding plug-in window for the effect.

Plug-in chain

If Use plug-in chain window is activated in the settings menu of the Master 
Section, the effects of the active audio document are displayed in a plug-in 
chain at the top of the plug-in window.

You can right-click a plug-in tab or an empty tab to select a new plug-in for 
the slot.

Bypass during playback

If this option is activated, this plug-in is bypassed during playback, and 
optionally for a rendering operation. To deactivate an effect when rendering, 
use the Switch effect on/off buttons in the Master Section’s Effects pane.

Solo (bypass)

If this option is activated, all plug-ins except this one are bypassed during 
playback.

Render in place

Processes the audio in place without any intermediary step. Bypassed 
plug-ins are excluded and rendered audio is crossfaded at boundaries.

Monitoring point

If this option is activated, the Master Level meters monitor right after this 
plug-in.

Switch effect on/off

If you deactivate the plug-in, it is excluded from both playback and rendering.
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Presets

Opens a menu to save/load presets for this plug-in.

Effect Plug-in Presets

With WaveLab comes a number of factory presets for the included effect plug-ins 
that you can select and use as is, or use as a starting point for your own settings.

Third-party plug-ins can provide their own factory presets. To access the presets 
for an effect, click the Preset button in its control panel window. The available 
functions depend on the type of plug-in.

Presets for VST 3 Plug-ins

Applying and saving presets for WaveLab specific plug-ins works exactly as with 
any other preset, apart from the fact that there are no preset tabs or menu items as 
in dialogs. Instead, clicking the Preset button opens a separate Preset dialog.

The options in this dialog are the same as for dialogs with Preset tabs.

The file format is compatible with Cubase.

Presets for VST 2 Plug-ins

VST 2 plug-ins have their own preset handling. When you click the Preset button 
for this type of effect, a pop-up menu with the following options opens:

Load/Save Bank

Loads and saves complete sets of presets. The file format is compatible with 
Cubase.

Load/Save Default Bank

Load the default set of presets or saves the current set of presets as the 
default bank.

Load/Save Effect

Loads or saves a preset. This is also compatible with Cubase.

Edit name of current program

Allows you to define a name for the preset.

Preset List

Allows you to select one of the currently loaded presets.

Presets for DirectX Plug-ins

For DirectX plug-ins, the same functionality is provided as for WaveLab plug-ins. In 
addition, you can import native presets created for the plug-in.



Master Section
Master Section Window

369

Master Level Pane

This pane in the Master Section allows you to control the master level of the active 
audio file.

Faders

The faders in the Master Level pane govern the final output level. Use the faders to 
optimize the level of the signal that is sent to the audio hardware.

NOTE

It is important to avoid clipping, especially when mastering. Clipping is indicated by 
the clip indicators of the Master Section.

Meters

The Master Section meters show the signal level of the signal before dithering or 
any other plug-in that you have applied post-master fader.

Use these to get an overview of the signal levels. The numeric fields above the 
faders show the peak levels for each channel. The peak indicators turn red 
whenever the signal clips. If this happens, you should lower the faders, reset the clip 
indicators by clicking the Reset peaks button, or clicking the values, and play back 
the section again until no clipping occurs.

NOTE

For critical level metering, we recommend using the Level Meter. It is more precise, 
and it is applied after the whole Master Section (after dithering) and thus shows the 
actual signal level that is sent to the audio hardware.

Mono Button

The Mono button sums two channels to mono. The output level is automatically 
reduced by -6 dB, to avoid clipping. The Mono button is useful for checking mono 
compatibility of stereo mixes, etc.
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If the Mono button is activated, the red indicator for the Master Level pane is lit, even 
if the master level is not adjusted. This helps you avoid accidentally leaving the 
Mono button activated.

Unlink Button

Determines whether the faders should be individually adjustable or ganged.

If Unlink is deactivated, moving one fader also moves the other by the same 
amount. Activating Unlink allows you to correct improper stereo balancing by 
adjusting the channels’ levels individually.

• If you offset the faders with Unlink activated and then deactivate Unlink 
again, you can adjust the overall level without changing the level offset 
between the channels.

• Fader offsets are not preserved at the end of the range of movement or once 
the mouse button is released.

True peaks button

If this button is activated, the analog reconstructed peaks (true peaks) are displayed 
in the Master Level meter. If this button is deactivated, the sample values (digital 
peaks) are displayed.

Dithering Pane

This pane in the Master Section allows you to add dithering to the signal before it 
is sent to the audio hardware or saved as a file on a disk.

Fold/unfold section

Expands or collapses the Dithering pane.

Bypass during playback

Bypasses the plug-in during playback, and optionally during rendering.

Monitoring point

Lets the Master Level meter monitor the signal right after this plug-in.

Effect plug-in slot

Slot where you can insert an effect plug-in.

Presets menu

Lets you store and recall preset settings.
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Plug-in visibility

Activates/Deactivates the plug-in window.

Lock slot

Locks the slot. A locked slot is not bypassed if the Solo function is active. The 
plug-in in the slot remains as is when a Master Section preset is loaded, or 
when Reset all is used.

Switch effect on/off

Excludes the plug-in from playback and rendering.

Noise type

Lets you set one of the available noise types that are added to the signal. This 
is only available if Internal dither is activated.

Noise shaping

Lets you select the type of filtering for improving the apparent signal-to-noise 
ratio of the output. This is only available if Internal dither is activated.

Number of bits

Lets you select the number of bits that the signal should be quantized to. This 
is only available if Internal dither is activated.

About Dithering

Dithering is the technique of adding small quantities of noise to a signal to reduce 
the audibility of low level distortion in a digital recording. A small amount of random 
noise is added to the analog signal before the sampling stage, reducing the effect 
of quantization errors.

In the case of WaveLab, dithering is applied when reducing the number of bits in a 
recording, for example, when moving from 24 to 16 bits, and when applying 
processing. You can choose between WaveLab’s internal dithering algorithm, 
Apogee’s UV22HR algorithm, or any external dithering plug-in.

Dithering largely depends on the type of material. When making the dithering 
settings we recommend that you experiment and let your ears be the final judge.

During low level passages, only a few bits are used to represent the signal, which 
leads to audible quantization errors and distortion. This is perceived as graininess 
during low level passages in a recording.

When truncating bits, as a result of moving from, for example, 24- to 16-bit 
resolution, such quantization noise is added to an otherwise immaculate recording.

By adding a special kind of noise at an extremely low level, the quantization errors 
are minimized. The added noise can be perceived as a very low-level quiescent hiss 
added to the recording. However, this is hardly noticeable and preferred to the 
distortion that occurs otherwise. The Noise Shaping options allow to filter this 
noise to a frequency area less sensitive to the human ear.
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NOTE

Dithering should always be applied after the output bus fader stage, and after any 
kind of audio process.

Selecting Dithering Algorithms

WaveLab comes with two dithering plug-ins: Internal dithering and the UV22HR 
dithering. However, you can also add other dithering plug-ins.

• To select and activate a dithering algorithm in the Master Section, click the 
dithering plug-in slot in the Dithering pane, and select one of the options from 
the pop-up menu.

• To deactivate the dithering algorithm, open the dithering pop-up menu, and 
select None.

Adding Other Plug-ins to the Dithering Pane

If you want to use another dithering plug-in than the internal or UV22HR dithering, 
you can add it to the Dithering pane.

NOTE

The meters in the Master Section monitor the signal before the Dithering pane. To 
avoid clipping, check the Level/Pan Meter and adjust the output level setting of the 
plug-in, if available.

PROCEDURE

1. In any workspace, select Options > Plug-in settings.

2. Open the Organize tab.

3. Locate the plug-in that you want to add to the Dithering pane in the list, and 
activate the checkbox in the Dither column for the plug-in.

4. Click OK.

RESULT 

The plug-in appears on the pop-up menu in the Dithering pane, and can be 
inserted after the Master Level faders. The plug-in is still available for selection as a 
regular pre-master effect if the corresponding entry in the Dither column in the 
Plug-in settings dialog is activated.
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When to Apply Dithering

The basic rule is that you should dither when moving to a lower bit resolution. One 
instance of this is when converting an audio file to a lower resolution. For example, 
preparing a 24-bit file for mastering to CD, that uses 16-bit format.

However, even if you are playing back or rendering a 16-bit or 24-bit file to the same 
resolution, you need to dither if you are using any processing in WaveLab. The 
reason for this is that WaveLab works with an internal resolution of 32 bit (floating 
point) for supreme audio quality. This means that as soon as you perform any kind 
of processing, the audio data is treated at this high resolution instead of the original 
16 bits or 24 bits, thus making dithering necessary.

Examples of real-time processing include level adjustments, any effects, mixing of 
two or more clips in a Montage, etc. The only time when a 16-bit file is played back 
at 16-bit resolution is if you play it without any fades or effects, and with the Master 
Faders set to 0.00 (no level adjustment – Master level indicator turned off).

NOTE

To make sure whether you need to dither or not, use the Bit Meter to check the 
actual resolution of your audio signals.

Dither Quality Testing

In the Master Section, you can compare the quality of different dither plug-ins, by 
making the quantization noise and the dither signal more audible.

Now, when you activate a dither plug-in, and play back an audio section, you can 
hear what the effect of the dither plug-in sounds like. You can try different dither 
plug-ins, to find out which one has the best dither effect on the audio.

To activate this option, in the Master Section, click the settings button, and activate 
Monitor 16-bit dithering.

For a significant dithering test, listen to a long decaying sound, such as a piano 
dying note. This option has no effect on the rendering process.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Make sure to deactivate Monitor 16-bit dithering once you are done testing the 
dithering quality.

NOTE

Only dither to 16 bit, otherwise the result does not have any meaning.
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Post-Processing Pane

This pane in the Master Section contains the Encoder Checker that allows you to 
compare audio encoders. You can also add your own post-processing plug-ins to 
the post-processing slot.

NOTE

The plug-in in the Post-Processing pane is only part of the playback processing. It 
is not applied when rendering files or CDs.

Fold/unfold section

Expands or collapses the Post-Processing pane.

Bypass during playback

Bypasses the plug-in during playback.

Monitoring point

Lets the Master Level meter monitor the signal directly after this plug-in.

Effect slot

In this slot, you can load your own post-processing effects or the included 
Encoder Checker.

In the Plug-in settings dialog, you can select which plug-ins to make 
available in the effect plug-in slot.

Presets menu

Lets you store and recall presets.

Plug-in visibility

Shows/Hides the plug-in panel.

Lock slot

Locks the slot. A locked slot is not bypassed if the Solo function is active. The 
plug-in in the slot remains unaffected if a Master Section preset is loaded, or 
if Reset all is used.

Switch effect on/off

Excludes the plug-in from playback.

RELATED LINKS

Plug-in Settings Dialog on page 639
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Encoder Checker

The Encoder Checker plug-in allows you to compare the quality differences 
between different audio encoders. It is applied in the Post-Processing pane of the 
Master Section.

With the Encoder Checker you can find the best settings for your encoders and test 
the effect of other plug-ins on the compression. The Encoder Checker is only used 
for playback and is bypassed during audio file rendering.

NOTE

The more encoders are selected in the Encoder Checker dialog, the more CPU 
power is used. Also, the more audio compression is applied to the audio file, the 
higher the latency. The latency is determined by the encoder with the highest 
latency.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

The Encoder Checker does not support multichannel audio montages.

Checking the Quality of Encoded Audio Files

PROCEDURE

1. Open the audio file that you want to check in different encoding qualities.

2. In the Master Section, open the Post-Processing menu in the 
Post-Processing pane and select Steinberg > Encoder Checker.

3. Click in the first field and select a factory preset or select Edit to specify a 
custom audio file format.

4. Optional: Specify more audio file formats.

5. Play back the audio file.
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6. Click the Original sound button and the number icons to switch between the 
original audio and the encoders.
If the Encoder Checker window is active, you can also press the [1], [2], and [3] keys 
on your keyboard to switch between the encoders and click [.] to select the original 
sound.

NOTE

If you select or edit an encoder, the plug-in synchronizes the new encoder 
settings with the other active encoders and the original sound. This can result 
in short audio artifacts.

RESULT 

You can compare the quality of the encoders.

AFTER COMPLETING THIS TASK 

Once you have found the best encoder for your needs, you can click Render to 
render the audio file to the selected audio file format. You can also click the Batch 
processor button to open the Batch Processors workspace with an audio file 
format preset that corresponds to the selected encoder.

Blindly Checking the Quality of Encoded Audio Files

To make sure that you only rely on your ears when checking the encoder quality, you 
can use the Blind modes to compare the encoders without knowing which encoder 
is currently playing.

PROCEDURE

1. Open the audio file that you want to check in different encoding qualities.

2. In the Master Section, open the Post-Processing menu in the 
Post-Processing pane and select Steinberg > Encoder Checker.

3. Click in the first field and select a factory preset or select Edit to specify a 
custom audio file format.

4. Optional: Specify more audio file formats.

5. Do one of the following:
• To compare only the encoders, activate Blind (encoders). For this function, at 

least 2 encoders must be selected.

• To compare the encoders and the original sound, activate Blind (encoders + 
original sound).

6. Play back the audio file.

7. Use the up/down or left/right arrow keys to switch between the encoders.
The LED lights up each time that you switch to another encoder.
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8. Use the + and - keys to rate the encoder that you are listening to.

9. Deactivate Blind mode.

RESULT 

The encoder that you have heard last is highlighted and you can see the ratings of 
the encoders.

AFTER COMPLETING THIS TASK 

Once you have found the best encoder for your needs, you can click Render to 
render the audio file to the selected audio file format.

Encoder Checker Dialog

In this dialog, you can compare the quality of different audio encoders.

In the Master Section, open the Presets menu in the Post-Processing pane and 
select Steinberg > Encoder Checker.

Display

Displays the spectrum (FFT) of the original sound (green) and of the selected 
encoder (red). This gives you a rough estimation of the effects that the 
encoder has on the audio spectrum.

Switch indicator LED

In the Blind modes, this LED lights up each time a new encoder is selected 
via the arrow keys.

Blind (encoders)

If this option is activated, the original sound is selected. When you use an 
arrow key, a random encoder is played back. You can use the arrow keys to 
cycle between the selected encoders without being able to see which 
encoder is selected.
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You can use the + and - keys to rate the encoder that you are listening to. The 
rating results are displayed when you deactivate Blind mode.

Blind (encoders + original sound)

If this option is activated, a random encoder or the original sound is selected. 
You can use the arrow keys to cycle between the selected encoders and the 
original sound without being able to see which one is selected.

You can use the + and - keys to rate the encoder that you are listening to. The 
rating results are displayed when you deactivate Blind mode.

Freeze display

If this option is activated, the FFT display freezes.

Original sound

Lets you hear the original audio file during playback.

Encoders

Lets you select different audio encoders and switch between them during 
playback.

Rating

Shows the number of plus and minus marks that have been set during the 
Blind modes.

Compression

The realtime estimation of the audio compression ratio with a 16-bit file size 
as reference.

Latencies

The first latency value indicates how long you have to wait until you hear the 
encoder when you select another encoder. The second latency value 
indicates the delay when switching between encoders.

Batch processor

Opens the Batch Processors workspace with an audio file format preset that 
corresponds to the audio file format that is being monitored.

Render

Opens the Render dialog with an audio file format preset that corresponds to 
the audio file format that is being monitored.

Speaker Configurations Pane

This pane of the Master Section allows you to select the speaker configurations. 
The speaker configurations are set up in the Audio file editing preferences dialog.
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Speaker configurations

Lets you select the speaker configurations.

Audio file editing preferences button

Opens the Audio file editing preferences dialog, where you can set up the 
speakers for the speaker buttons.

Speaker gain

Lets you edit the gain of the speaker configuration. Positive gains are 
indicated by a red LED, and negative gains are indicated by an orange LED. 
When the gain is zero, the LED is dark green (off).

RELATED LINKS

Speaker Configuration on page 118

Master Section Tools

The tools and options at the bottom pane of the Master Section window allow you 
to make various settings before rendering the file, make bypass settings, and decide 
whether the playback goes through the Master Section or not.

Bypass all effects

Bypasses any kind of processing in the effect panel during playback, and 
optionally when rendering.

Smart bypass

Opens the Smart bypass dialog, where you can make special bypass 
settings.

Reset all

Removes all the active effects from the effects slots and sets the master 
output to 0 dB.

Setting menu

Opens the Master Section settings menu.

Render

Clicking opens the Render dialog. Right-clicking opens a menu where you 
can select whether you want to open the Render dialog, render using the last 
settings, or use in-place rendering.

Playback goes through Master Section

If this option is deactivated, the Master Section is ignored during playback of 
any file, freeing up resources. However, rendering to file is still possible. If 
playback is activated when you change this option, it stops and restarts.
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Rendering

By rendering the effects in the Master Section, they become a permanent part of a 
file, rather than using them in real-time to test a set of effects on a file. So instead 
of performing all processing in real-time during playback, you can save the audio 
output to a file on disk.

This is done with the Render function of the Master Section.

You can render to a single file format or to multiple audio file formats.

Writing the output of the Master Section to a file on disk allows you to apply 
Master Section processing to an audio file, or mix down an audio montage to an 
audio file. In case of a multichannel audio montage, several files can be created, one 
for each channel in the selected configuration.

There are several uses for rendering:

• Mix down a complete audio montage to an audio file.

• Process a file and save a file to a new audio file, including Master Section 
effects, dithering, and other settings. You can choose the format of the new 
audio file, which allows you to create an MP3 file and add effects at the same 
time, for example.

• Process one or more regions of an audio file in place or to new files.

Multiple File Format Rendering

You can render to multiple audio file formats simultaneously. To do so, you must first 
create file format presets for these formats.

You can also create multiple audio file format presets. These are a list of single file 
format presets.

Rendering Files

PREREQUISITE 

Set up your audio file or audio montage. If you want to render to multiple file formats, 
you must first create audio file format presets.

PROCEDURE

1. In the Master Section, make your settings.

2. On the bottom of the Master Section, click the Render button.

3. In the Render dialog, make your rendering settings.

4. Activate Create named file.

5. Click the File format field and select Edit.
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6. In the Audio File Format dialog, do one of the following:
• To render to one audio format, make your settings in the Audio File Format 

dialog.

• To render to multiple file formats, click the Multiple file format button, click , 
and select the file format presets that you want to render to.

7. Click OK.

8. When you have set up the rendering process, click OK.

RESULT 

The file is rendered. You can see the progress in the Background tasks window.

NOTE

Several rendering operations can be performed at the same time when using 
different files.

RELATED LINKS

Multi Audio File Format Dialog on page 382
Creating Multiple Audio File Format Presets on page 381

Creating Single Audio File Format Presets

PROCEDURE

1. In the Audio File Format dialog, specify the audio file format.

2. Open the Presets menu and select Save as.

3. Enter a name for the preset and click Save.

Creating Multiple Audio File Format Presets

PREREQUISITE 

Create a preset for each audio file format that you want to add to the multi format 
preset.

PROCEDURE

1. In the Audio File Format dialog, click Multiple file format.

2. Click  and select the preset that you want to use.

3. Add as many audio file format presets as you need.
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4. Optional: To make changes to an existing preset, click it and select Edit.

5. Open the Presets menu and select Save as to save the multiple format as 
preset.

Multi Audio File Format Dialog

In this dialog, you can select audio file format preset. These allow you to render an 
audio file or an audio montage to multiple file formats.

The Multi Audio File Format dialog is available from the Render dialog in the Audio 
Files workspace and in the Audio Montage workspace, and from the Format tab in 
the Batch Processors workspace.

Opens a menu from which you can select a preset file format to add it to the 
preset list.

Removes the selected preset from the preset list.

Preset list

Shows the selected audio file format presets, an optional subfolder in which 
the files are rendered to, and an optional suffix for the rendered files. The 
Subfolder column allows you to sort the output files to different subfolders. 
The Suffix column helps to avoid name conflicts.

Multicore rendering

If this option is activated, all audio files are generated at the same time, each 
with a different CPU core, if possible. This increases the rendering speed.

NOTE

It is recommended to deactivate the Multicore rendering option if a batch 
processor is running that already uses multiple CPU cores.
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Single file format/Multiple file format

Switches the view between the Audio File Format dialog and the Multi 
Audio File Format dialog.

In-Place Rendering

In the Audio Files workspace, you can process a section of an audio file or the whole 
audio file directly from within a plug-in window, without any intermediary step. This 
is a quick way to process several audio sections in an audio file, or test the effect of 
different plug-ins on an audio file.

When using this function, the following render settings are always active:

• Fade-in/out at boundaries

• Exclude bypassed plug-ins

NOTE

Once an audio section has been processed, there is no automatic bypass of 
plug-ins or the Master Section.

An example for using in-place rendering:

Let’s say that you are restoring a file and have 3 favorite plug-ins, for example, 3 
DeClicker plug-ins. Now you want to use the one that gives the best results.

1) Load all 3 plug-ins in the Master Section.

2) Select a region, solo plug-in #1, and play the region.

3) Solo plug-in #2, and play the region.

4) Solo plug-in #3, and play the region.

5) Solo the plug-in that you think sounded the best, and click the Render in 
place button, or press [Alt]/[Option]-[A].
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Rendering an Audio Selection In-Place

You can render the plug-ins of a section of an audio file or the whole audio file.

PREREQUISITE 

In the Audio Files workspace, open the audio file that you want to render, and set 
up the Master Section.

PROCEDURE

1. If you only want to process a section of the audio file, in the wave window, 
select the audio section that you want to process.

2. Open the plug-in window.

3. Optional: If you only want to use some plug-ins of the Master Section, solo 
the plug-ins that you want to use.

4. Do one of the following:
• In the plug-in window, click the Render-in place button.

• In the Master Section, right-click the Render button, and select In-place 
rendering.

RESULT 

The audio section or the audio file is processed.

Render Dialog

This dialog allows you to select what parts of an audio file to render, into which 
format, and what to do with the result.

To open the Render dialog, click the Render button in the Master Section, or select 
File > Export > Render.

The following options are available for both rendering in the Audio Files workspace 
and in the Audio Montage workspace:

Audio range - One region

Processes and renders a time range specified using region markers. In the 
drop-down menu below this option, select the region you want to render. For 
example, a CD track.
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Multiple sources - Regions

Processes and renders each marked audio range to an independent file, or 
renders in place, according to the related settings. By defining multiple 
isolated regions in an audio file, you can process them in place in one 
operation.

Specify the type of marked regions to process in the drop-down menu.

Create named files

If this option is activated, you can set name of the rendered file. Otherwise, 
the file is named “untitled”.

Name

Enter a name for the rendered file. Clicking the arrow icon opens a menu that 
offers you several automatic naming options.

Auto naming

When rendering multiple sources, you can activate this option to add a 
numeric prefix to all rendered files.

Where

Select a folder where the file is rendered to.

File format

Opens the Audio File Format dialog, where you can select the file format.

Batch Processor

Opens the Batch Processor with the same plug-in setup as the one currently 
used in the Master Section. This allows you to process more files in a batch, 
or add off-line processors to the audio processing chain.

Fade-in/out at boundaries

If this option is activated, a fade is performed at the audio range bounds when 
a new file is created, or a crossfade with the audio neighborhood is created if 
the audio range is processed in place.

Crossfades allow a smooth transition between the processed and the 
non-processed parts. The crossfade time and shape are set in the Audio file 
editing preferences. If the fade time is longer than half the length of the 
processed file, it is not performed.

Copy markers

If this option is activated, markers included in the range to process are copied 
to the rendered file.
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Bypass Master Section on resulting audio file

If this option is activated, playback of the resulting audio file bypasses the 
entire Master Section after rendering. This setting can be toggled by clicking 
on the button at the bottom right of the wave window or montage window.

NOTE

It is recommended to have this option activated, because you do not want to 
monitor this new file through the effects again when the effects have been 
applied to a file.

No tail

If this option is activated, the audio tail produced by effects such as reverbs 
is not included in the rendered file.

Some plug-ins do not provide a tail duration to WaveLab. In this case, this 
option has no effect. For such plug-ins, you could add the Silence plug-in to 
add extra samples at the end of the file. An audio tail appears in this space.

Upload to SoundCloud

If this option is activated, the rendered file is uploaded to SoundCloud, after 
the rendering process is finished.

Bypass Master Section

If this option is activated, the plug-ins and gain of the Master Section are 
bypassed when rendering.

Exclude bypassed plug-ins

If this option is activated, the plug-ins that are bypassed during playback are 
not used for rendering.

This applies to the bypass states managed by WaveLab, not any bypass state 
that is under the control of the plug-ins.

Open resulting audio file

If this option is activated, each rendered file is opened in a new window.
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Render Dialog in the Audio Files Workspace

The following options in the Render dialog are exclusive to the Audio Files 
workspace:

Automatic pre-selection

If this option is activated, the source to render is automatically selected 
according to the selected time range of the Audio Montage. This can lead to 
the selection of one of the following options:

• Whole file

• Selection

• One region

Time range - Whole file

Processes and renders the whole audio range.

Time range - Selection

Processes and renders the selected audio range.

Time range - Skip exclusion regions

If this option is activated, audio ranges marked as muted are skipped and not 
included in the result.

Process in place

If this option is activated, the rendered audio range replaces the source audio 
range. Otherwise, a new file is created.
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Render Dialog in the Audio Montage Workspace

The following options in the Render dialog are exclusive to the Audio Montage 
workspace:

Automatic pre-selection

If this option is activated, the source to render will automatically be selected 
according to the selected time range of the audio montage. This can lead to 
the selection of one of the following options:

• Whole montage

• Time selection

• Selected CD track

• One region

For Selected CD track to work, the time selection must match the CD track 
range. To select the CD track range, in the CD window, double-click the track 
number of the track that you want to select.

Time range - Whole montage

Processes and renders the whole audio range.

Time range - Time selection

Processes and renders the selected audio range.

Time range - As selected clips

Processes and renders the audio range that starts from the first selected clip 
and ends with the last selected clip. Only the selected clips are included in 
the process.

Time range - Selected CD track

Processes and renders the selected CD track in the CD window.
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Multiple sources - Groups

Processes and renders each audio montage group to an independent file. The 
group names are used for the output file names.

Multiple sources - Selected clips

Processes and renders each clip to an independent file. The clip names are 
used as output file names.

Create Basic Audio CD

If this option is activated, a file of the whole audio montage, including clip 
effects and master effects, is created. Then a Basic Audio CD window opens.

Create CD image and cue-sheet

If this option is activated, the audio montage is exported as a CD image with 
an accompanying cue-sheet (a text file identifying the CD tracks in the image 
file). The cue-sheet and the image file it describes can then be imported into 
any CD recording application that supports this function (including WaveLab) 
and written onto a CD.

The CD image is a Wave file.

Open as new audio montage

If this option is activated, the rendered audio file is imported in a new audio 
montage.

Record From an ASIO Input

You can record an audio file directly to disk from an ASIO input, while the audio is 
collected from the audio input. The ASIO input audio is rendered through the 
Master Section and any of its plug-ins and saved as a file, as when rendering 
normally.

This is another way to record. When you record normally, no plug-ins are used, but 
more options are possible.

Rendering ASIO Input to File

PREREQUISITE 

In the VST Audio Connections, set up the input and output channels of the ASIO 
plug-in.

PROCEDURE

1. In the Master Section, at the top of the Effects panel, add the Audio input 
plug-in to a slot.

2. In the lower part of the Master Section, click Render.
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3. In the Render ASIO input to file dialog, make your settings.

4. Click OK.

RESULT 

The audio file is recorded to disk from the ASIO input, until you click the Stop button 
on the transport bar.

Smart Bypass

Smart bypass allows you to compare the original (unprocessed) signal to the 
processed signal with a level correction applied to it. This function is particularly 
useful when you are making final level adjustments to a recording, for example, 
during mastering.

Smart bypass compares the signal at the input of the Master Section to the signal 
at the output of the Master Section, and adjusts the level accordingly.

The main reason for Smart bypass is that processing audio often changes the level 
or loudness of the signal. When comparing the processed signal with the original 
signal, your ears are sensitive to this loudness change, which may in turn affect your 
judgment. If you need to compare the sound of the effect independently from the 
loudness change, a level correction is required.

Smart Bypass Dialog

In the Master Section, click the Smart bypass button to open the Smart bypass 
dialog, which allows you to choose whether to bypass all the active effects in the 
Effects slots, including faders. This allows you to compensate for any level 
difference introduced by the Master Section.

NOTE

This is for playback only, not for file rendering.

The following options are available:
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Play - Original audio

Monitors the unprocessed signal at the Master Section input.

Play - Processed audio + level correction

Monitors the signal at the Master Section output plus the applied level 
correction. To be able to listen to the corrected level, click the Update gains 
button first.

Play - Processed audio

Monitors the unprocessed signal at the Master Section output without level 
correction.

Level Correction - Match loudness (RMS)

If this option is activated, the output is adjusted so that the loudness of the 
processed signal corresponds to that of the original signal.

Level Correction - Match peaks

If this option is activated, the output is adjusted so that the peak levels of the 
processed signal correspond to those of the original signal layout.

Level Correction - Custom correction

Allows you to set a custom level compensation (no analysis).

Level Correction - Analysis time

Determines how many samples are used to calculate the reference loudness.

Level Correction - Update gains

Updates the volume analysis.

Using Smart Bypass

PROCEDURE

1. Click the Smart bypass button.

2. Select one of the following Play options:
• Original audio
• Processed audio + level correction
• Processed audio

You can also use key commands to select a Play option. Press [A] for Original audio, 
[B] for Processed audio + level correction, and [C] for Processed audio.

3. Select one of the following Level correction modes:
• Match loudness (RMS)
• Match peaks
• Custom correction

4. Depending on your selection, you have the following options:
• If you have selected Custom correction, specify a value, start the play back, 

and proceed with step 7.

• If you have selected Match loudness (RMS) or Match peaks, specify the time 
range you want to analyze in the Analysis time field, and proceed with step 5.
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5. Play back the audio and wait for the analysis to complete.
For example, wait as long as the time specified in the Analysis time field.

6. Click the Update gains button.
Depending on the selected correction method, the level correction that is applied is 
shown below the corresponding button.

You can also press [U] to update the gains.

7. Switch between the three Play mode options to compare between the 
processed audio with level correction, the processed audio without level 
correction, and the original audio (unprocessed).

AFTER COMPLETING THIS TASK 

Optional: If you change the analysis time or start playback from another position you 
have to wait for the set time, and then click the Update gains button again to 
update the analysis.

Saving a Master Section Preset

You can turn all settings currently made in the Master Section into a preset. This 
includes which processors are used, what settings are made for each one of them, 
and dithering options.

PROCEDURE

1. Set up the Master section as you want it.

2. Click the presets button at the bottom of the Master Section, and select Save 
as.

3. Optional: In the Save Master Section Preset dialog, click the path name, 
enter a name, and click OK to create a new subfolder in the Master Section 
preset folder.

4. Enter a name for the preset in the Name field.

5. Decide, whether you want to include one or several of the following options 
in the preset:
• To include the plug-ins from the Effects pane, activate Save Effects plug-ins.

• To include the settings made in the Master Level pane, activate Save Master 
Level settings.

• To include the plug-in from the Dithering pane, activate Save Dithering 
plug-in.

• To exclude locked plug-ins, activate Exclude locked plug-ins.

6. Optional: Activate Create shortcut for selecting the preset, to assign a 
shortcut to open the preset, after you clicked Save.

7. Click Save.
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Save Master Section Preset Dialog

In this dialog, you can save a Master Section setup as preset and define which parts 
of the current Master Section you want to include in the preset.

In the Master Section, click the Presets button at the bottom, and select Save as.

Path name

Opens the root folder of the preset in the Windows Explorer/Mac OS Finder. 
Here, you can create subfolders in which presets can be stored.

Presets list

Lists all existing presets.

Name

Lets you specify the name of the preset to save.

Create shortcut for selecting the preset

If this option is activated and you click Save, the Shortcut Definitions dialog 
opens, where you can define a shortcut to apply this preset.

If a preset already has an assigned shortcut, this option is grayed out. To 
change the existing shortcut, double-click the preset name in the presets list.

Save Effects plug-ins

If this option is activated, the effect plug-ins are saved with the preset.

Save Master Level settings

If this option is activated, the Master Level settings are saved with the preset.

Save Dithering plug-in

If this option is activated, the dithering plug-in is saved with the preset.

Exclude locked plug-ins

If this option is activated, locked plug-ins are not saved as part of the Master 
Section preset.
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Loading a Master Section Preset

You can load a previously saved Master Section presets, a temporarily stored 
Master Section preset, or import WaveLab 4/5/6 presets.

Open the Presets menu on the bottom of the Master Section window.

• To load a preset that has been previously saved in the Presets\Master Section 
folder, select a preset from the Presets menu.

• To load a preset from any location, select Open from any location, select a 
preset, and click Open.

• To load a temporarily saved preset, open the Restore submenu, and select a 
preset.

• To import a WaveLab 4/5/6 preset, select Import WaveLab 4/5/6 presets, 
select a preset, and click Open.

Storing a Master Section Preset in an Audio File or Audio 
Montage

You can store the current settings of the Master Section along with an audio file or 
inside an audio montage.

• To store a current setting in the Master Section along with an audio file, in the 
Audio Files workspace, select Edit > Store Master Section preset along 
with audio file. The preset is stored in companion files.

• To store a current setting in the Master Section as part of an audio montage, 
in the Audio Montage workspace, select Edit > Store Master Section 
preset inside montage.

Loading a Master Section Preset to an Audio File or Audio 
Montage

You can apply the Master Section settings that have been stored along with an 
audio file or inside an audio montage to the project.

If the option Open option box when selecting a preset is activated in the Presets 
menu of the Master Section, the Load Master Section Preset dialog opens when 
applying a Master Section preset. In this dialog, you can specify which parts of a 
saved Master Section preset to load when opening it.

• To load a Master Section preset stored along with the currently opened audio 
file, in the Audio Files workspace, select Edit > Load Master Section preset 
stored with the audio file.

• To load a Master Section preset stored inside the currently opened audio 
montage, in the Audio Montage workspace, select Edit > Load Master 
Section preset stored with the montage.
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Load Master Section Preset Dialog

In this dialog, you can specify which parts of a saved Master Section preset to load 
when opening it.

This dialog only opens if it is activated in the Master Section’s Presets menu. Open 
the Presets menu at the bottom of the Master Section window, and activate Open 
option box when selecting preset.

Now, when restoring a temporarily saved preset or opening a saved preset a dialog 
with the following options opens:

Name

Displays the name of the preset.

Load/Replace effect plug-ins

If this option is activated, the active effect plug-ins are removed, and any new 
plug-ins are inserted from the top slot.

Insert effect plug-ins from focused slot (keep existing plug-ins)

If this option is activated, the present effect plug-ins are kept, and any new 
plug-ins are inserted from the top slot.

Load/Reset Master Level settings

If this option is activated, the present Master Level settings are reset, and any 
new settings are loaded.

Load/Replace Dithering plug-in

If this option is activated, the present Dithering plug-in is removed, and the 
new plug-in is loaded.

Including a Master Section Preset When Rendering

You can include the Master Section preset that is stored with the audio montage in 
the rendering process of super clips’ audio montages.

This means that when this option is activated for an audio montage, anytime this 
audio montage is rendered so that its image is used in a parent montage, its 
associated Master Section preset is used by the rendering process.
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• To include the Master Section preset when rendering a super clip, in the 
Audio Montage workspace, select Edit > Include Master Section preset 
when rendering as super clip, or activate the Include Master Section 
preset when rendering as super clip icon on the lower right of the montage 
window.

Master Section Preset Menu

This menus offers several options for saving, managing, and restoring Master 
Section presets.

To open the Preset menu of the Master Section, click the preset icon on the bottom 
of the Master Section window.

Save

Saves the changes you have made to an existing preset.

Save as

Opens a dialog where you can select a name for the preset and choose a 
location.

Organize presets

Opens the Preset folder of the Master Section, where you can rename or 
delete presets.

Define shortcut for the current preset

Opens the Shortcut Definitions dialog, where you can define key sequences 
and keywords.

Open from any location

Selects any Master Section preset located anywhere, not just in the default 
root folder. For example, this is useful if you want to load a preset provided by 
another source that is not located in your default root folder.

You can also navigate to any other location where you have stored presets.

Import WaveLab 4/5/6 presets

Lets you select WaveLab 4/5/6 presets.

Presets are relative to Master Project

If this option is activated, presets are searched in the preset folder of the 
Master Project. This is useful if you want to organize Master Section presets 
per project, rather than having a common central place for them.

Open option box when selecting preset

If this option is activated, a dialog opens that allows you to choose how to load 
the preset you select.

Store temporarily

Lets you select one of the slots to temporarily store a preset.
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Restore

Lets you restore a previously stored preset.

List of saved presets

Lists the presets that are stored in the Preset folder of the Master Section.

About Monitoring Background Tasks

When rendering you can monitor the process, and pause or cancel tasks.

You can adjust the priority with which they are processed, pause, or cancel them. 
This is useful if you have a number of lengthy processes underway and want to free 
up some processing power to focus on editing. You can either lower the priority of 
a task so it does not use as much of the computer processor capacity, or pause the 
task temporarily.

You can set the Background tasks window to open automatically, by activating 
Options (WaveLab menu on Mac) > Global preferences > Options tab > Make 
the Background Task Monitor visible when a task starts.

A status bar below the wave window and the montage window shows the progress 
of the current rendering process, and lets you cancel and pause the rendering, 
without opening the Background tasks window.

Background Tasks Window

This window allows you to view all background rendering processes that are in 
progress.

In the Audio Files workspace, Audio Montage workspace, or Control Window, 
select Workspace > Shared tool windows > Background tasks.

The list of background tasks shows the following information about the rendered file 
during the rendering process:

• Name

• Status

• Elapsed Time

• Remaining Time
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• Progress in %

• Progress bar

With the Pause and Cancel buttons, you can pause and cancel the rendering 
process.

From the Tasks menu, you can select the following options:

Suspend

Pauses the selected task.

Suspend all

Pauses all tasks.

Resume

Resumes the selected paused task.

Resume all

Resumes all paused tasks.

Cancel

Cancels the selected task.

Lowest priority

Runs the task at a the lowest speed to leave processing power to other tasks, 
and only when the mouse or keyboard are not in use.

Low priority

Runs the task at a low speed to leave processing power to other tasks.

High priority

Runs the tasks as fast as possible while giving you the possibility to continue 
working in WaveLab.

About Dropouts

A dropout most likely occurs when your computer does not have the processing 
power to handle all effect processors you have inserted.

To avoid dropouts, try the following:

• Use fewer effects.

• Consider rendering the processing rather than running it in real time. Then 
master from the processed file without any effects. Dropouts never occur 
when rendering to a file.

• Do not process any files in the background.

• If neither of the above helps, check the audio card preference settings. You 
might need to adjust the audio buffer settings. If a dropout occurs during a 
real-time mastering process we recommend that you re-master. Stop 
playback, click the dropout indicator to reset it, and try again.
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Markers

Markers allow you to save and name certain positions in a file. Markers are useful 
for editing and playback, for example, to indicate cue points or absolute time 
locations, to highlight problem sections, and to visually separate tracks.

For example, markers can be used to:

• Set the wave cursor to a specific position.

• Select all audio between two positions.

• Define CD tracks.

• Loop sections in an audio file.

There is no limit to the amount of markers that you can have in a file.

The following marker types come in pairs: CD, Loop, Mute, Region, Error and 
Correction. When you delete a marker of a marker pair, the other marker is also 
deleted.

Since you cannot have a CD track that starts but never ends, a loop end point 
without a start, etc., special rules exist for creating, deleting, and moving these types 
of markers. CD track markers must always be balanced. For example, if you delete 
a track start, the corresponding end marker is also deleted.

Loop, mute, correction, error, and region markers only have a functionality when 
balanced.

NOTE

The functions in the Markers window of the Audio Files workspace and the Audio 
Montage workspace are the same. However, the Markers window of the Audio 
Montage workspace offers additional options regarding clips.

Marker Types

The following marker types are available:

Generic markers

Allow you to locate positions and select all the audio between two points, for 
example. They can be created during recording.

Temporary markers

Can be used for any purpose. They are deleted when the corresponding file 
is closed.
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CD track start and end markers

Denote where a CD track begins and ends. They also serve for DVD-A discs. 
CD/DVD markers are used in pairs.

CD track splice markers

Are used when a CD track starts exactly where another ends. They also serve 
for DVD-A discs.

CD track index markers

Are used to create index points in CD tracks. They also serve for DVD-A 
discs.

Playback start markers

Define a playback start point.

Region start and end markers

Define start and end points for generic regions. They can be created during 
recording and are used in pairs.

Exclusion start and end markers

Let you temporarily silence a section. Sections between exclusion regions are 
skipped if you select Transport > Skip range. The Render dialog also allows 
you to exclude regions from being rendered. Exclusion markers are used in 
pairs.

Loop start and end markers

Are used to define loop points and are required to access loop editing 
functions on the Process menu of the Audio Files workspace. They are 
connected to the Loop mode when playing back audio. These markers are 
useful for editing and creating loops before transferring a sound to a sampler. 
Loop markers are used in pairs.

Error start and end markers

Are used to highlight errors such as clicks. They are saved in audio files if 
Save Error and Correction markers is activated in the Audio file editing 
preferences dialog, on the File tab. The error start and end markers can be 
placed manually, but their main use is with the Error Correction tool.

Correction start and end markers

Are used to highlight corrections performed on regions previously marked as 
errors. They are saved in audio files if Save Error and Correction markers is 
activated in the Audio file editing preferences dialog, on the File tab. The 
correction markers can be placed manually, but their main use is with the Error 
Correction tool.
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Markers Window

In this window, you can create, edit, and use markers while working on an audio 
waveform or audio montage.

If the window is not already visible, do the following: In the Audio Files workspace 
or the Audio Montage workspace, select Workspace > Specific tool windows > 
Markers.

Markers window in the Audio Files workspace

Markers List

The Markers window contains a list of all markers of the active file along with their 
details and controls. You can create and edit markers directly from the markers list.

Numbers

Clicking the number of a marker scrolls the waveform to reveal the 
corresponding marker.

Playback triggers

The following playback buttons are available:

Playback from start with a pre-roll.

-[Alt]/[Option]

Playback from start with a long pre-roll.

Playback from start.

Marker type

Shows the marker type. To change the marker type, click the marker icon and 
select another marker type from the pop-up list.

Name

Shows the marker name. To change the name, double-click in the 
corresponding cell and enter a new value.

Time

Shows the marker position on the time ruler. To change the time position, 
double-click in the corresponding cell and enter a new value.
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Length

Shows the time value from the marker start position until the corresponding 
end or splice marker.

• To zoom on the region between a start and end marker, in the Length 
column, click the corresponding cell.

• To select the region between a start and end marker, in the Length 
column, double-click the corresponding cell.

Lock

Allows you to lock markers. Locking markers prevents them from being 
accidentally dragged to a new position in the wave window or the montage 
window. To lock a marker, activate the checkbox for the markers that you want 
to lock.

Clip reference (Audio Montage workspace only)

A marker can be attached to the left or right edge of a clip, and to its 
waveform. When such reference moves, the marker moves along. The clip 
reference column shows the name of the clip.

Offset (Audio Montage workspace only)

Shows the distance between the marker and the reference point.

Comment

Allows you to enter a comment. To enter a comment, double-click in a cell.

Insert Menu

On this menu, you can select the marker type that you want to insert at the edit or 
playback cursor position.

Functions Menu

The options on this menu differ depending on the workspace. The following options 
are available in the Audio Files workspace and the Audio Montage workspace:

Select all

Selects all markers in the markers list.

Select in time range

Selects the markers located in the selection range.

Deselect all

Deselects all markers.

Delete selected markers

Deletes all markers that are selected.

Delete selected markers

Opens the Delete Markers dialog, where you can select the markers to 
delete according to various criteria.
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Convert marker types

Opens a dialog where you can convert markers to another type.

Move markers

Opens the Move multiple markers dialog, where you can select which 
markers you want to move by a specified amount.

Batch renaming

Opens the Batch renaming dialog where you can rename several markers in 
one go.

Generate markers

Opens the Generate Markers dialog where you can specify a sequence of 
markers to create.

Export markers list as text

Opens a dialog where you can export the markers list in various file formats, 
or as print out. You can decide which information about the markers to include 
in the exported file.

Lock selected marker

Locks the selected marker. If this option is activated, the marker cannot be 
moved or deleted.

Customize commands

Opens a dialog where you can customize marker-related menus and 
shortcuts.

The following options of the Functions menu are only available in the Audio 
Montage workspace:

Import markers from focused clip's audio file to audio montage

Automatically adds all markers of the clip’s source audio file to the audio 
montage. To visualize these markers before importing them, it is 
recommended to activate Source’s ruler and markers in one of the following 
ways:

• In the Focused clip window, select Options, and activate Source’s 
ruler and marker.

• In the Clips window, select Functions, and activate Show/Hide 
source’s ruler and marker. You can also right-click the upper part of 
a clip, and activate this option in the pop-up menu.

Bind selected marker to start of focused clip

Makes the marker’s position relative to the start of the focused clip. When the 
start of this clip moves, the marker moves, too.

Bind selected marker to end of focused clip

Makes the marker’s position relative to the end of the focused clip. When the 
end of this clip moves, the marker moves, too.
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Bind selected marker to audio samples of focused clip

Locks the selected marker relatively to audio samples referenced by the 
focused clip. The marker moves when the audio samples move relatively to the 
start of the montage.

Detach selected marker from its associated clip

Makes the marker’s position relative to the start of the audio montage.

Automatically attach new marker to the most suitable clip

Links all newly created markers to a clip when a reasonable pattern is 
detected. For example, an end marker at the end of a clip or slightly beyond, 
or any marker inside a clip. The marker type and its position relatively to the 
closest clip determine the type of bond.

Full clip attachment

Attaches markers to a clip so that they are copied or deleted when the clip is 
copied or deleted.

Filter Menu

Use the Filter menu to toggle which types of markers are displayed in the markers 
list and on the timeline.

Filtering Markers

The search field allows you to filter the markers list by names.

You can search for text in the Name and Comment columns. The search only 
happens in the sorted columns. The function Select All only selects the filtered 
items.

• In the Markers window’s toolbar, click in the search field, and enter the text 
that you want to search for. You can use wildcard characters. “*” substitutes 
for zero or more characters, and “?” substitutes for any character.

• To switch the focus from the search field to the markers list, press the arrow 
down key.

• To switch the focus from the markers list to the search field, press 
[Ctrl]/[Command]-[F].

• To view all markers again, erase the search.
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About Creating Markers

Markers can be created during playback or in stop mode. You can generate a 
sequence of markers or mark a selection range, for example.

You can create specific markers if you already know what you want to mark, or 
create generic markers. Creating markers is done in the same way in the Audio Files 
workspace and the Audio Montage workspace.

Creating Markers

You can create markers in the wave window and montage window in stop mode or 
during playback.

PROCEDURE

1. Do one of the following:
• Start playback.

• In the wave/montage window, set the cursor to the position where you want to 
insert the marker.

2. Do one of the following:
• In the Markers window, click a marker button, or select a marker from the 

Insert menu.

• In the Markers window, select Insert > Create/Name marker, enter a name 
and select a marker type, and click Create or Create and close.

• Right-click the upper part of the time ruler, and select a marker from the context 
menu.

• Press [Insert]/[M]. This creates a generic marker.

• To create CD start/end markers in the Audio Montage workspace, open the CD 
window, and use the CD Wizard. This only works in stop mode.

Create Marker Dialog

This dialog allows you to create and name a marker in stop mode and during 
playback.

In the Markers window, select Insert > Create/Name marker.

Name

Lets you enter the name of the marker.
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When clicking the icon to the right of the name field, a default name is 
generated. To edit the default names, in the Markers window, select 
Functions > Default names.

Type

Lets you select the type of marker.

Toggle start/end markers

If this option is activated, and you create a region start or end marker, the 
related end or start marker is created when you click the Create or Create 
and close button again.

Create and close

Creates the defined markers and closes the dialog.

Create

Creates the defined markers while leaving the window open allowing you to 
create more markers.

RELATED LINKS

Default Marker Names Dialog on page 416

Creating Markers at Selection Start and End

You can mark a selection for looping or review, for example.

PROCEDURE

1. In the wave window or the montage window, create a selection range.

2. Do one of the following:
• In the Markers window, click a marker pair button, or open the Insert menu and 

select one of the marker pairs.

• In the Markers window, select Insert > Create/Name region from selection, 
enter a name for the start and end marker, select a region type, and click 
Create or Create and close.

• In the wave window, make a selection range, right-click it, and select one of the 
marker pairs.

• In the wave window or the montage window, create a selection range, 
right-click the time ruler, and select one of the marker pairs.
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Create Region Dialog

This dialog allows you to create and name a start and end marker from a selection 
during stop mode and during playback.

In the Markers window, select Insert > Create/Name region from selection.

Region name

Lets you enter the name of the start and end marker. If nothing is entered, a 
generic name is created.

When clicking the icon to the right of the name field, a default name is 
generated. To edit the default names, in the Markers window, select 
Functions > Default names.

Set a different name for the closing marker

If this option is activated, you can enter a different name for the closing marker. 
If this option is deactivated, the name of the start marker is also used for the 
end marker.

Region type

Lets you select the type of region marker.

Create and close

Creates the defined markers and closes the dialog.

Create

Creates the defined markers and leaves the window open allowing you to 
create more markers.

RELATED LINKS

Default Marker Names Dialog on page 416

Duplicating Markers

This is a quick way to create a marker from an existing marker.

PROCEDURE

• In the wave window or the montage window, hold down [Shift], click a marker, 
and drag.
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Generating a Sequence of Markers

You can generate several markers at once in a specified time range. This allows you 
to create markers at every beat, or create markers as guidelines for inserting silence 
when you want to distribute demo sounds, for example.

PROCEDURE

1. Decide where you want to insert the generated markers. Do one of the 
following:
• To generate markers in a certain time range, create a selection range in the 

wave window or the montage window.

• To generate markers from the cursor position to the end of the audio or 
generate a fixed number of markers from the cursor position, set the cursor 
position where you want the first marker to be created.

2. In the Markers window, select Functions > Generate Markers.

3. Select the type of marker and specify the gap between markers, and if you 
have selected a marker pair, the region length.

4. Optional: Activate Naming and select a naming scheme.

5. Select a numbering scheme.

6. Click OK, to generate the markers.

Generate Markers Dialog

This dialog allows you to generate markers at regular intervals in a specified time 
range. You can fill a selected time range, the region between the cursor position and 
the end of the audio, or specify a fixed number of markers to be generated.

In the Markers window, select Functions > Generate Markers.
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Marker type

Specifies the type of marker to be generated.

Gap between markers

Sets the time between two markers or two regions.

Region length

Sets the length for the region to be generated.

Naming

Allows you to set up a naming scheme.

Depending on whether you have selected a single marker or a start/end 
marker, you can specify the naming scheme for a single marker, or one naming 
scheme for the start marker and one for the end marker.

If you select Custom, the Marker Naming dialog opens, where you can 
specify a custom naming scheme.

Naming fields

Allows you to specify a base name for the markers, an optional separator 
between name and marker number, and the start value of the marker index.

The base name is also used as a basis for the Custom naming scheme.

Fill selected time range

Generates markers in the selected time range.

Start after gap

If this option is activated, the first generated marker is inserted after the gap 
time specified at the top of the dialog.

Fill from cursor till end

Generates markers between the edit cursor position and the end of the audio.

Fixed number, starting from cursor

Generates a specified number of markers or regions, starting at the edit 
cursor position.

Allow to insert past last clip

Determines whether markers can be generated beyond the end of the last 
clip, when Fixed number, starting from cursor is activated.
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Deleting Markers

Markers can be deleted in the wave window or the montage window, in the Markers 
window, and in the Delete Markers dialog.

Deleting Markers in the Wave/Montage Window

Individual markers can easily be deleted in the wave window.

• In the wave/montage window, right-click a marker, and select Delete.

• Drag and drop a marker icon above the time ruler.

Deleting Markers in the Markers Window

This is useful if your project has many markers or if the marker that you want to 
delete is not visible in the wave/montage window.

PROCEDURE

1. In the Markers window, select one or several markers.
You can also select Functions > Select all.

2. Click the Delete selected markers button, or select Functions > Delete 
selected markers.

Deleting Markers by Type

This is useful to delete markers of a certain type in the whole wave/montage window 
or in a selection range.

PROCEDURE

1. Optional: If you only want to delete markers in a certain time range, create a 
selection range in the wave/montage window.

2. In the Markers window, select Functions > Delete Markers.

3. Select the marker types that you want to delete.

4. Optional: Define conditions that have to be met for markers to be deleted.

5. Set the Range.
If you have selected an audio range and want to use it, activate In selected audio 
range.

6. Click OK.
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Delete Markers Dialog

In this dialog, you can define which markers to delete by selecting marker types and 
conditions.

In the Markers window, select Functions > Delete Markers.

Marker types

Allows you to select the marker types to delete.

Conditions

Allows you to select a condition that has to be met for markers to be deleted. 
For example, Marker name must contain this text.

Select all

Selects/deselects all markers.

Range – All

Deletes all markers.

Range – In selected time range

Deletes all markers in the selected time range.

Range – Skip locked markers

Skips locked markers.
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Moving Markers

You can adjust marker positions in the wave window and the montage window.

PROCEDURE

• In the wave/montage window, drag a marker to a new position on the time 
ruler.
If Magnetic bounds is activated, the marker snaps to the cursor position, or the 
beginning/end of a selection or waveform.

Moving Multiple Markers

You can move multiple markers simultaneously, keeping the relative distances 
between the markers.

PROCEDURE

1. Optional: If you only want to move markers in a certain time range, create a 
selection range in the wave window or the montage window.

2. In the Markers window, select Functions > Move Markers.

3. Specify the amount of time by which you want to move the markers.

4. Select the marker types that you want to move.

5. Optional: Define conditions with or without regular expressions.

6. Optional: If you have selected an audio range and want to use it, activate In 
selected audio range.

7. Click OK.
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Move Multiple Markers Dialog

In this dialog you can select which markers you want to move by a certain amount 
of time.

In the Markers window, select Functions > Move Markers.

Move markers by this amount

Defines the distance that markers are moved.

Move these marker types

Allows you to select the marker types that are moved.

Conditions

Allows you to select a condition that has to be met for markers to be moved. 
For example, Marker name must contain this text.

Range - All

Moves all markers.

Range - In selected time range

Moves all markers in the selected time range.

Range - Skip locked markers

Skips locked markers.
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Navigating to Markers

You can jump to the previous or next marker using the corresponding marker 
buttons.

• To jump to the previous/next marker, on the View command bar, click the 
Previous marker/Next marker button.

• To set the wave cursor to a marker position, in the wave window or the 
montage window, double-click a marker triangle.

Hiding Markers of a Certain Type

For a better overview, you can hide marker types.

PROCEDURE

1. In the Markers window, select Filter.

2. Deactivate the marker type that you want to hide.
You can make the markers visible again by activating the corresponding marker type.

Converting Marker Types

You can convert markers of a specific type to another type.

Converting the Type of a Single Marker

PROCEDURE

1. In the Markers window, click the marker icon that you want to convert.

2. Select a new marker type from the list.

Converting All Markers of a Specific Type

You can convert loop markers to CD track markers, for example.

PROCEDURE

1. Optional: If you only want to convert markers in a certain time range, create a 
selection range in the wave window or the montage window.

2. In the Markers window, select Functions > Convert marker types.
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3. Use the From and To pop-up menus to specify the source and target marker 
type.

4. Optional: Specify a condition.

5. Select whether you want to convert all markers or only markers in the selected 
range.

6. Click OK.

Convert Marker Type Dialog

In this dialog, you can convert marker types.

In the Markers window, select Functions > Convert marker types.

From

Specifies the source marker type.

To

Specifies the target marker type.

Conditions pop-up menu

Allows you to specify conditions for the conversion. Select an option and 
enter a text in the text field below.

The following conditions are available:

• Marker name must be empty

• Marker name must contain this text

• Marker name must NOT contain this text

• Marker name must contain this text (with wildcards)

• Marker name must NOT contain this text (with wildcards)
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• Marker name must contain this regular expression

• Marker name must NOT contain this regular expression

Markers to convert - All

Converts all markers.

Markers to convert - In selected time range

Converts only markers of the selected time range.

Markers to convert - Skip locked markers

Excludes locked markers from the conversion.

Renaming Markers

You can change the automatically generated names of markers.

• To rename a marker in the wave window or the montage window, right-click 
a marker, select Rename, and enter a new name.

• To rename markers in the Markers window, double-click a marker name in the 
Name column, and enter a new name.

• To batch rename multiple markers according to specified settings, in the 
Markers window, select Functions > Batch renaming.

• To edit the default names, in the Markers window, select Functions > 
Default names.

RELATED LINKS

Batch Renaming on page 585

Default Marker Names Dialog

In this dialog, you can specify the default marker names.

In the Markers window, select Functions > Default names.

Marker type

Lets you select the type of marker to which you want to assign a default name.

Default name for this type of marker

Lets you specify the default name for the selected marker type.
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About Selecting Markers

There are several ways to select markers.

• In the wave window or the montage window, click a marker.

• In the Markers window, click in a cell. The corresponding marker is selected.

• Use [Ctrl]/[Command] and [Shift] to select multiple markers.

The marker icon changes its background, to indicate the selected marker.

Selecting the Audio Between Markers

You can quickly select the audio between two adjacent markers or between any two 
markers. This allows you to select a section that has been marked.

• To select the audio between two adjacent markers, double-click between two 
adjacent markers.

• To select several regions between two adjacent markers, double-click 
between two adjacent markers, and after the second click, drag to select the 
adjacent regions.

• To select the audio between a region marker pair, hold down [Shift], and 
double-click a region marker.

• To extend the selection until the end of a marker region, in the wave/montage 
window, hold down [Shift], and double-click in the marker region that you 
want to select.

• To activate the Markers window and display further information about a 
certain marker, hold down [Alt]/[Option], and double-click a marker.

Binding Markers to Clips in the Audio Montage

In the Audio Montage workspace, you can bind markers to clips. By doing this, the 
marker remains in the same position relative to the clip start/end, even if the clip is 
moved in the audio montage or resized.

You can find the options regarding clips and markers in the Functions menu of the 
Markers window, and when right-clicking a marker.
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When a marker is bound to a clip element, its name is preceded by a blue character.

RELATED LINKS

Markers Window on page 401

Exporting the Markers List as Text

You can export the markers list as text. The markers list contains the marker’s 
names, positions, region lengths, types, and comments.

PROCEDURE

1. In the Audio Files workspace or the Audio Montage workspace, open the 
Markers window.

2. In the Markers window, select Functions > Export markers list as text.

3. Choose the information that you want to export, and the output format.

4. Click OK.

RESULT 

The markers list opens in the selected output format. When selecting Print, the 
Print Preview window opens. The text file is stored in the specified folder for 
temporary files.

RELATED LINKS

Specifying Folders on page 83
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Export Markers List as Text Dialog

This dialog allows you to export the markers list in various file formats, or as print 
out. You can decide which information about the markers to include in the exported 
file.

In the Audio Files workspace or the Audio Montage workspace, in the Markers 
window, select Functions > Export markers list as text.

How Marker Information is Stored

WaveLab uses MRK files to have a file format independent way to store information. 
However, to make marker information exchangeable between applications to a 
certain extent, WaveLab also stores optionally some information in the Wave 
headers.

This makes saving files quicker if only a marker settings has been changed. 
However, this only applies when Write markers in WAV file header is deactivated 
in the Audio File editing preferences on the File tab. By default, both MRK files 
are created and information are stored in the Wave headers.

• When you import a file for the first time, any loop points are imported and 
displayed as loop markers.

• When you save the file in the Wave format, the loop points are saved both as 
part of the actual file and in the MRK file.

• When you open a file that includes markers that were added in WaveLab, and 
markers that were added in another application, all markers are displayed 
when reopening the file in WaveLab.
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Metering

WaveLab contains a variety of audio meters that you can use when monitoring and 
analyzing audio. Meters can be used to monitor audio during playback, rendering, 
and recording. Furthermore, you can use them to analyze audio sections when 
playback is stopped.

Metering Window

Audio Meters can be used in the Audio Files workspace, in the Audio Montage 
workspace, and in the Control Window.

They can be used as following:

• A docked window in a workspace

• A tabbed window in the Control Window

• An independent floating window. In this mode, it can be useful to select 
Window > Hide frame, to save screen space. In this case, the whole menu 
is accessed by right-clicking.

There can only be one instance of each audio meter.

The axis of most audio meters can be rotated, to view the graphics horizontally or 
vertically. For some meters, you can also style and customize parameters via a 
settings dialog.

Real Time vs. Non-Real Time

Metering can be used to measure audio in real time (playback, record), or offline 
audio in non-real time (audio range or around cursor stats).

Real time in the context of metering means that audio is played back. Non-real time 
means that the audio is in stop mode.
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Metering Monitor Modes

You can choose which audio source to monitor and select a mode for displaying 
information in the meters.

You can access the following monitoring functions from the Meters menu or via the 
Meter commands bar.

Monitor Playback

This is the standard metering mode, in which the meters reflect the audio 
being played back. Metering occurs after the Master Section, which means 
that effects, dithering, and Master faders are taken into account. You can 
monitor playback in audio files, audio montages, audio CD track lists, etc.

Monitor Audio Input

In this mode, the meters reflect the audio input. Typically, this is the mode to 
use when recording. The Master Section settings are not taken into account.

Freeze meters

This mode freezes the values for all open meters. The meters remain frozen 
until you select another monitor mode.

Monitor File Rendering

In this mode, you can monitor what is being written to disk during file 
rendering or when recording. Like Analyze audio selection, average and 
min/max peak values are calculated. After rendering, the meters freeze until 
you refresh or change monitor mode.

Monitor Edit cursor position (Audio Files workspace only)

In this mode, the meters are static, showing the levels and other values for the 
audio at the position of the edit cursor, in stop mode. This allows you to 
analyze a certain position in an audio file in real time. The Master Section 
settings are not taken into account.

Analyze audio selection (Audio Files workspace only)

In this mode the meters display the average values calculated for a selected 
range. The Master Section settings are not taken into account.

When you change the selection, you have to update the meter displays by 
selecting Meters > Update selection analysis, or by clicking the Update 
selection analysis button on the Meters command bar.

Update selection analysis (Audio Files workspace only)

Analyzes the audio selection again and updates the meters.
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About Meter Settings

You can set up most meters according to your needs in the corresponding settings 
dialogs. For example, you can adjust the behavior, scale, and color of the meters.

• To open the settings dialog for a meter, select Functions > Settings.

• To check the results after changing the settings without closing the settings 
dialog, click Apply.

• To close the settings dialog and discard any changes that you have made, 
even if you have clicked the Apply button before, click Cancel.

Multichannel Metering

WaveLab features 8 audio channels that can be routed to inputs and outputs on a 
multi i/o audio card. The audio montage supports various surround channel 
configurations using up to 8 channels.

WaveLab can display multiple meters. When working with multiple channels in an 
audio montage, each channel has its own meter. This applies to all meters (up to 8 
real time FFTs, 8 level meters, 4 pan meters, 4 phase scopes, etc.). If a surround 
configuration is selected, each meter indicates the corresponding surround channel 
(Lf, Rf, LFE, etc.).

When working with more than two channels, it is recommended to use floating 
meter windows, because they can be resized more easily.

Resetting the Meters

You can reset the display of some meters, for example, the values of the Level Meter.

PROCEDURE

• In the meter window, click the Reset icon, or select Functions > Reset.

RESULT 

All meters and numerical indicators are reset.
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Using Presets in the Meter Windows

You can save the settings that you have made for a meter window as a preset. By 
assigning presets to preset buttons, you can quickly switch between different level 
scales and display modes, for example.

• To save your settings as a preset, select Functions > Settings, click the 
Presets button, and select Save as.

• To assign a preset to one of the preset buttons, select Functions > Settings, 
click the Presets button, and from the Assign to preset submenu, select a 
preset button.

• To apply a preset, select it from the Functions menu, or click the 
corresponding preset button.

Preset buttons 1-5

Level Meter

The Level Meter displays the peak and average loudness/decibel level of your audio 
file, and the balance between the left and right channels in a stereo file.

In the Audio Files workspace or the Audio Montage workspace, select Meters > 
Level Meter.

Level Meters

The upper part of the window shows the peak level and average loudness in the 
following way:

• The Peak Level meters display the peak levels of each channel, graphically 
and numerically.



Metering
Level Meter

424

• The VU meters measure the average loudness (RMS) of each channel. These 
meters have a built-in inertia, evening out loudness variations over a 
user-defined time span. If you are monitoring playback or the audio input, you 
can see two vertical lines following each VU meter bar. These lines indicate 
the average of the most recent minimum RMS values (left line) and the 
average of the most recent maximum RMS values (right line). To the left, the 
difference between the minimum and maximum average values is displayed. 
This gives you an overview of the dynamic range of the audio material.

• If you are monitoring real-time audio (playback or input), the maximum peak 
and loudness values are displayed to the right of the meter bars. The numbers 
in brackets to the right of the maximum peak values indicate the number of 
times that clipping occurs (0 dB signal peaks). Values between 1 and 2 clips 
are acceptable, but if you get a larger number, you should lower the master 
level to avoid digital distortion.

• Recording levels should be set so that they only rarely clip. If the master level 
is set too high, the sound quality and frequency response are compromised 
at high recording levels, with unwanted clipping effects. If the level is set too 
low, noise levels can be high relative to the main sound being recorded.

Pan Meters

The lower part of the window shows the difference in level between the left and right 
channel of a stereo audio file.

• The upper pan meters show the peak level difference between the channels. 
The level bars can go to the left or right, indicating which channel is loudest.

• The lower pan meters show the average difference in loudness between the 
channels. This gives you a visual indication of whether a stereo recording is 
properly centered, for example.

• If you are monitoring real-time audio (playback or input), the maximum balance 
difference values (peak and loudness) for each channel are displayed 
numerically to the left and right of the meter bars.

Level/Pan Meter Settings Dialog

In this dialog, you can adjust the behavior, scale, and color of the meters.

In the Level Meter window, select Functions > Settings, or click the tool icon.

Peak Meter Section

Peaks pop-up menu

On this pop-up menu, select whether WaveLab should use sample values 
(digital peaks) or analog reconstructed values (true peaks).

Ballistics - Release rate

Determines how fast the peak level meter falls after a peak.
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Ballistics - Peak hold time

Determines how long a peak value is displayed. The peak can be displayed as 
a line or a number. If the meter's height is too narrow, only the line is displayed.

Top/Middle/Low zone

The color buttons allow you to select colors for the low, middle, and top zones 
of the level meter. You can define the range for the top and middle zones by 
changing the corresponding values.

Cursor mode - Unit

If this option is activated, you can specify which unit is used to display the 
peak value.

Show value of single sample

If this option is activated, the value of the single sample is displayed at the 
cursor position. If this option is deactivated, several samples are scanned 
around the cursor to determine the peak value. Generally, this is best 
activated when you have zoomed in on the waveform to see the details.

VU Meter (Loudness) Section

VU Meter (Loudness)

Activates/deactivates the VU meter.

Modes pop-up menu

On this pop-up menu, you can choose between the standard mode and three 
K-System modes. The settings for K-System modes are shown in the Zones 
section.

Ballistics - Resolution

Sets the time that is used for determining the loudness. The smaller this value, 
the more the VU meter behaves like the Peak meter.

Ballistics - Range inertia

Sets the time that is used for determining the recent minimum and maximum 
value lines, and therefore determines how quickly these respond to changes 
in loudness.

Top/Middle/Low zone

The color buttons allow you to select colors for the low, middle, and top zones 
of the VU level meter. You can define the range for the top and middle zones 
by changing the corresponding values.

Cursor mode - Samples to scan

Determines how many samples are scanned when calculating the VU meter 
value in Monitor edit cursor position mode.

Panning Meter Section

Panning Meter

Shows/hides the panning meter in the Level Meter window.
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Range

Determines the dB range of the panning meter.

Peak and Loudness Left/Right, Global colors

Lets you specify the colors for the different elements.

Global Colors Section

In this section, you select colors for the meter background, marks (scale units), and 
grid lines.

Global Range (Peak and VU Meter) Section

In this section, you specify the minimum and maximum values of the displayed level 
range. Typically, you want to create a preset showing the full level range, and other 
presets for a detailed view of a smaller range.

K-System VU Meter Modes

K-System integrates standardized metering, monitor calibration, and level practices.

In WaveLab, you can choose between three metering modes which all set the 0 dB 
VU point below the standard Level meter. To fully utilize the K-System, you have to 
calibrate your monitor level so that 0 VU equals 83 dB.

You should use a pink noise reference signal and a SPL level meter. Use C 
weighting (slow response), and adjust your playback level so that your noise meter 
indicates 83 dB SPL per channel or 86 dB SPL when played on the two channels 
simultaneously.

The K-System has three meter operating modes (selectable from the VU-Meter 
pop-up in the Level/Pan Meter Settings dialog). These are intended for different 
uses:

• K-System 20: This places 0 VU 20 dB lower than standard VU mode, and is 
intended for music with a very wide dynamic range, e.g. classical music.

• K-System 14: This places 0 VU 14 dB lower than standard VU mode, and is 
intended for music with a slightly more compressed dynamic range. Use this 
for pop, R&B, and rock music.

• K-System 12: This places 0 VU 12 dB lower than standard VU mode, and is 
primarily intended for broadcast applications.
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Loudness Meter

Loudness Meter is an audio meter for monitoring loudness, according to the EBU 
R-128 standard.

In the Audio Files workspace, select Meters > Loudness Meter.

1) Momentary loudness bar

Displays the loudness of a 400 milliseconds slice that is evaluated every 100 
milliseconds.

2) Short-term loudness bar

Displays the loudness of a 3 seconds slice that is evaluated every second.

3) Integrated loudness bar

Displays the average loudness. This bar is evolving over time, because it 
makes an average of the loudness by measuring 400 millisecond slices every 
100 milliseconds.

4) Target loudness

The purple vertical line corresponds to the target loudness defined in the 
Loudness Meter Settings dialog. The purple shadow around it corresponds 
to the acceptable deviation.

5) EBU R-128 Loudness Range (LRA)

This loudness range displays the difference between the estimates of the 
10th and the 95th percentiles of the loudness distribution. The lower 
percentile of 10 % can, for example, prevent the fade-out of a music track from 
dominating the loudness range. The upper percentile of 95 % ensures that an 
unusually loud sound, such as a gunshot in a movie, is not responsible for a 
large loudness range.

The loudness ranges of number 5, 6, and 7 help to decide if dynamic 
compression is necessary, by giving instant feedback about the dynamics (too 
low, good, too much).

6) Dynamics range of the short-term loudness

This loudness range monitors the recent minimum/maximum loudness 
measurements to provide a hint about the short-term dynamics.
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7) Dynamics range of the momentary loudness

This loudness range monitors the recent minimum/maximum loudness 
measurements to provide a hint about the momentary dynamics.

8) Loudness curve

This curve shows where the loudness is distributed in a song. The audio 
signal is divided into small blocks, and the loudness of each block is 
computed. The curve informs about how often audio events with a given 
loudness appear in the file in comparison to all other events. If the curve has 
a peak, the given loudness often appears in the song.

The curve is always normalized. The peak shows which loudness is the most 
represented in a song. The curve is directly related to the LRA as the LRA 
starts at the left part of the curve and ends at the right part, with a 10 %/95 % 
tolerance.

9) Gate LED

The Gate LED lights up when audio is discarded from measurement. The EBU 
standard discards audio below a certain level, relative to the average 
loudness.

10) Numerical values of the bars

This section shows the numerical values of the bars. The values in brackets 
are the loudness ranges.

11) True Peak LED

The True Peak LED is based on a true peak analysis and lights up when 
clipping is detected.

RELATED LINKS

EBU Loudness Standard R-128 on page 43
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Loudness Meter Settings Dialog

In this dialog, you can set up the appearance of the Loudness Meter window.

In the Loudness Meter window, select Functions > Settings, or click the tool icon.

Short-term Loudness/Momentary Loudness

Top zone/Middle zone/Low zone

Here, you can specify the colors for the top, middle, and low zones of the 
meter.

From

Allows you to specify what should be considered as middle and top zones.

Show maximum values

If this option is activated, the maximum short-term and momentary values are 
displayed instead of the loudness range values.

Loudness range

If this option is activated, a moving rectangle is displayed, which symbolizes 
the short-term loudness range/momentary loudness.
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Ballistics

Determines the inertia of the loudness range for the short-term 
loudness/momentary loudness, that is, how fast the range edges meet each 
other after a new minimum or maximum loudness is reported.

Integrated Loudness

Target loudness

Here, specify the ideal loudness to match. -23 LUFS is the EBU R-128 
standard.

Acceptable deviation

Here, specify the loudness range that you consider as acceptable deviation 
from the target loudness.

Outside the acceptable deviation

Lets you specify the color of the range that is outside the acceptable 
deviation.

Loudness Range

Range color

Lets you specify the range colors if the range size is above the associated 
value (too much), exactly as the associated value (good), or below the 
associated value (not enough).

Below/From

A loudness range that you consider to be not enough (Below) and too much 
(From).

Transition

Lets you specify how fast the color changes from Good to Too Much, and 
from Good to Not Enough. 0 % means that the color changes abruptly when 
a threshold is reached. 100 % means that the color changes gradually.

Additional Settings

Background/Marks/Grid/Curve

Lets you set the colors for the meter background, marks, grid lines, and the 
loudness distribution curve of the Loudness Meter.

Peak hold time

Determines how long the peak LED remains lit after a new true peak.

Show loudness histogram

If this option is activated, a loudness histogram is displayed in the Loudness 
Meter.
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Scale

In this section, you can specify the low and high end of the displayed level range. 
Typically, you may want to create a preset showing the full level range, and other 
presets for a detailed view of a smaller range.

The EBU +9 scale and the EBU +18 scale are EBU recommendations. Both of 
these scales are centered around 0 LU, which represetns -23 LUFS, the 
recommended EBU loudness.

Phasescope

The Phasescope indicates the phase and amplitude relationship between two 
stereo channels.

In the Audio Files workspace or the Audio Montage workspace, select Meters > 
Phasescope.

Reading the Phasescope

The Phasescope works as follows:

• A vertical line indicates a perfect mono signal (the left and right channels are 
the same).

• A horizontal line indicates that the left channel is the same as the right, but 
with an inverse phase.

• A fairly round shape indicates a well balanced stereo signal. If the shape leans 
to one side, there is more energy in the corresponding channel.

• A perfect circle indicates a sine wave on one channel, and the same sine wave 
shifted by 45° on the other.

• Generally, the more you can see a thread, the more bass is in the signal, and 
the more spray-like the display, the more high frequencies are in the signal.
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Phase Correlation Meter

The Phase Correlation meter at the bottom of the display works as follows:

• The green line shows the current phase correlation, and the two red lines 
show the recent minimum and maximum values.

• With a mono signal, the meter shows +1, indicating that both channels are 
perfectly in phase.

• Similarly, –1 means that the two channels are the same, but one is inverted.

• Generally, for a good mix, the meter should show a value between 0 and +1.

The Phase Correlation meter is also available in Analyze audio selection mode, 
showing an average value for the selected range.

Phasescope Settings Dialog

In this dialog, you can adjust the behavior, scale, and color of the meters.

In the Phasescope window, select Functions > Settings.

Background

Click this to change the background color.

Coil display

Allows you to adjust the color for the grid and phase coil display.

Auto-size

When Auto-size is activated, the display is optimized to fit within the window.

Correlation display

This is where you select colors for the elements in the Phase Correlation 
meter display, and adjust the Peak hold time for the maximum and the 
minimum indicator.

Number of samples to display

This setting affects the length of the phase coil and the density of the display. 
For audio with high sample rates, you might want to raise this value.
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Spectroscope

The Spectroscope shows a graphical representation of the frequency spectrum, 
analyzed into 60 separate frequency bands, represented as vertical bars.

In the Audio Files workspace or the Audio Montage workspace, select Meters > 
Spectroscope.

Peak levels are shown as a horizontal lines above the corresponding bands, 
indicating recent peak/maximum values. The Spectroscope offers a quick spectrum 
overview. For a more detailed analysis of the audio spectrum, use the Spectrometer.

On the Functions menu, you can specify whether only high audio levels are 
displayed, or whether medium and low levels are also shown.

Spectrometer

The Spectrometer uses FFT (Fast Fourier Transform) techniques to display a 
frequency graph, providing a precise and detailed real-time frequency analysis.

In the Audio Files workspace or the Audio Montage workspace, select Meters > 
Spectrometer.

The current frequency spectrum is shown as a linear graph. Spectrum peaks are 
shown as short horizontal lines.
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Zooming

In the Spectrometer window, you can zoom in on a frequency area.

• To zoom in on a frequency area, click and drag a rectangle in the spectrum. 
The display is zoomed in so that the selected frequency range fills the window.

• To return to full-scale display, select Functions > Zoom out fully, or 
double-click in the spectrum.

Snapshots of the Spectrometer

You can take snapshots of the current spectrum, to check the effects of adding EQ, 
for example.

The snapshots are displayed on the spectrum graph. Up to five snapshots can be 
displayed. The sixth snapshot replaces the earliest snapshot.

• To take a snapshot, select Functions > Add snapshot.

• To erase the last snapshot, select Functions > Erase last snapshot.

Exporting FFT Data as ASCII Text

FFT (Fast Fourier Transform) analysis is a method to convert a waveform from the 
time domain to the frequency domain. You can export the displayed FFT data as a 
text file.

PROCEDURE

1. In the Audio Files workspace, on the Meters menu, activate Monitor edit 
cursor position or Analyze audio selection.

2. In the Spectrometer window, select Functions > Export FFT data as 
ASCII.

3. Specify a file name and location.

4. Click Save.

RESULT 

The resulting text file can be imported into Microsoft Excel, or other applications that 
allow graph plotting from text files.
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Spectrometer Settings Dialog

In this dialog, you can adjust the behavior and display of the meters, and assign up 
to five sets of Spectrometer settings to the preset buttons.

In the Spectrometer window, select Functions > Settings.

Process Tab

Analysis block size

The higher this value, the higher the accuracy in the frequency domain (the 
spectrum is divided into more bands). At the same time, the time localization 
is reduced. This means that the higher the value, the less easy to know where 
a given frequency starts and ends in time.

However, raising the block size value also requires more CPU power and 
introduces a higher latency. Therefore, high values should only be used for 
off-line monitoring.

Analysis overlapping

To get more accurate results, the program can analyze overlapping blocks. 
This setting determines the amount of overlap between these blocks – the 
higher the value, the more accurate the results. Raising this value is very CPU 
intensive. A setting of 50 % requires twice the amount of CPU power, a 
setting of 75 % requires four times the CPU power, etc.

Smoothing window

Allows you to choose which method to use for pre-processing the samples in 
order to optimize the spectrum display.

Display Tab

Frequency ruler range

Determines the frequency range to be shown, at full-scale display. The lowest 
frequency to be shown depends on the Analysis block size setting and the 
highest actual frequency depends on the sample rate.

Logarithmic scale

When this is activated, each octave occupies the same horizontal space in the 
display. If you need more resolution in the high frequency range, you may want 
to turn this off.

Level ruler range

Determines the range of the vertical level ruler, in dB or as a percentage value.

Normalize display to 0 dB

If this option is activated, the level display is offset, so that the highest point 
on the curve is displayed as 0 dB. This is only possible in non-real time mode.

Optimize scale

Optimizes the level scale so that only the relevant level range is shown. This 
is only possible in non-real time mode.
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Display type

Allows you to switch the display between curve and bar graph.

Peak Hold time

Determines for how long the peak level graph remains displayed when the 
levels drop.

Colors

This is where you select colors for the curves, grid, background, etc.

Bit Meter

The Bit meter shows how many bits are used.

In the Audio Files workspace or the Audio Montage workspace, select Meters > 
Bit-meter.

While you may expect the maximum number of bits to be the same as the resolution 
of the audio file, this is not necessarily the case.

As soon as you perform any kind of real-time processing on an audio file, the audio 
data is treated at a much higher resolution (32-bit floating point), to allow for pristine 
audio quality. The only time when a 16-bit file is played back at 16-bit resolution is, 
for example, if you play it without any fades or effects, and with the master faders 
set to 0.00.

How to Read the Bit Meter

• The inner meters show how many bits are used.

• The outer meters show how many bits were recently in use.

• The Over segment indicates clipping.
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• If the Below segment is lit, there are more than 24 bits. The bit meter shows 
the 24 higher bits, and the Below segment indicates the existence of extra, 
lower bits.

• If the Inter segment is lit, this indicates that the audio data cannot be correctly 
expressed on a regular 24-bit scale. For example, this is the case when 
floating point values in between bits are present, which is typically the case if 
you apply effects, etc.

When to Use the Bit Meter

The Bit meter is useful in the following situations:

• To check whether dithering is necessary or not. As a rule if you are playing 
back or mixing down to 16 bits, and the Bit meter shows that more than 16 bits 
are used, you should apply dithering.

• To see the actual resolution of an audio file. For example, even though a file is 
in 24-bit format, only 16 bits may be used. Or, a 32-bit file may only use 
24 bits, in which case, the Below segment would not be lit.

• To see whether a plug-in that is set to zero still affects your signal, or whether 
a plug-in uses 16-bit internal processing.

Bit Meter Settings Dialog

In this dialog, you can adjust the behavior and display of the Bit meter.

In the Bit meter window, select Functions > Settings.

Colors

You can adjust the colors of the meter segments, grids, background, etc. by 
clicking the corresponding color buttons.

Bit hold time

Determines for how long peak values are held by the outer meters.

Bit display

Determines how the bits are displayed. In Intuitive mode, the absolute value 
of the signal is shown. The bar graph goes higher with higher signal levels, 
similar to a common level meter.

In True mode, the meter shows the direct mapping of the bits. However, 
because the actual values may be negative, there is no intuitive relationship 
with the level. This mode is useful if you want to quickly check the full range, 
because all bits are displayed, regardless of the audio signal level.
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Oscilloscope

The Oscilloscope offers a highly magnified view of the waveform around the 
playback cursor position.

In the Audio Files workspace or the Audio Montage workspace, select Meters > 
Oscilloscope.

If you are analyzing stereo audio, the Oscilloscope normally shows the separate 
levels of the two channels. However, if you activate Show sum and subtraction on 
the Options pop-up menu, the upper half of the Oscilloscope shows the mix of the 
two channels and the lower half shows the subtraction.

Oscilloscope Settings Dialog

In this dialog, you can adjust the display colors, and activate/deactivate Auto-zoom. 
When Auto-zoom is activated, the display is optimized so that the highest level 
reaches the top of the display at all times and even small signals are visible.

In the Oscilloscope window, select Functions > Settings.

Wavescope

The Wavescope meter displays a real-time waveform drawing of the audio signal 
being monitored. It can be useful when recording or rendering a file if Monitor File 
rendering mode is active.

In the Audio Files workspace or the Audio Montage workspace, select Meters > 
Wavescope.
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Wavescope Settings Dialog

In this dialog, you can make various color settings for the background, grid, and 
waveform display, and set the waveform rendering speed and vertical zoom.

In the Wavescrope window, select Functions > Settings.

Colors

Lets you select colors for the waveform graphics.

Waveform rendering speed

Determines how much the waveform display is compressed.

Level zoom

Determines the level zoom. Set a high value if the waveform has a low 
amplitude.

Clear waveform when reaching right of pane

If this option is activated, the waveform display is cleared each time the cursor 
reaches the right end of the display. If this option is deactivated, the new 
waveform overwrites the previous waveform.
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Basic Audio CD

In WaveLab, you can write Basic Audio CDs that are compatible with the Red Book 
standard.

In the Basic Audio CD window, you create your audio CD by adding audio files to 
a list of tracks. Each track contains a reference to the external audio file. This means 
that you can save your Basic Audio CD layout as its own session and continue 
editing individual tracks, for example.

A Basic Audio CD project contains the information about the CD track start position 
and the length of the referenced audio file. If the CD markers of an audio file are 
deleted, the audio file is removed from the Basic Audio CD project.

Once you have set up your CD layout, you can check the CD for conformity to the 
Red Book standard, write the CD, or export it to the Audio Montage workspace for 
further editing. You can also consolidate the audio files in the CD into a single audio 
file containing track markers.

A Basic Audio CD can also be used as a generic playlist. It allows you to assemble 
lists of files or sections of files with adjustable pauses in between.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Writing Basic Audio CDs offers only basic functionality. For professional CD 
creation you should use the Audio Montage workspace.

RELATED LINKS

About the CD Window on page 311
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Basic Audio CD Window

In this window, all tracks of the Basic Audio CD are listed. Here you can assemble 
and write Basic Audio CDs that are compatible with the Red Book standard.

In the Audio Files workspace, select Workspace > Specific tool windows > Basic 
Audio CD.

Track List

The track list shows information about the CD tracks. Apart from the entries in the 
Name column, you cannot edit the information shown in this window. The following 
informations are available for each track:

• Name

• Start position

• Length

• ISRC code

• Comment (not stored on the CD)

To show the markers and pauses of a track, click the arrow icon in front of the track.

The total time of the CD is displayed at the bottom of the window.

The following playback buttons are available:

Playback from start with a pre-roll.

-[Alt]/[Option]

Playback from start with a long pre-roll.

Playback from start.

The following options are available on the menus of the Basic Audio CD window:
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File Menu

New

Closes the current Basic Audio CD and opens an empty one.

Open

Lets you open a Basic Audio CD.

Add Tracks

Opens a file browser where you can select the audio files that you want to add 
to the Basic Audio CD.

Save

Saves the current Basic Audio CD.

Save as

Saves the current Basic Audio CD with a specific name.

Create an independent clone

Creates a single audio file that contains all the audio material used by the 
Basic Audio CD, as well as a new Basic Audio CD file. The new Basic Audio 
CD is independent from the audio files and markers that are referenced by the 
active Basic Audio CD.

Save each CD track as an audio file

Opens a dialog where you can specify a location to save each track as 
separate audio file.

Open recent

Opens the list of recently used files.

Edit Menu

Delete

Deletes the selected track from the Basic Audio CD.

Edit audio

Displays the audio of the selected track in the wave window.

Write Audio CD or DDP

Opens a dialog from which you can write a CD.

Check CD conformity

Verifies that the structure of the Basic Audio CD is correct according to the 
Red Book standard.

Display all CD tracks as one audio file

Creates an audio file that recreates the structure of the Basic Audio CD and 
opens it in the wave window, without writing any audio sample to disk.
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Convert to audio montage

Creates an audio montage with the same structure of CD tracks as the Basic 
Audio CD.

Options

Options

Opens the Basic Audio CD Options dialog.

Basic Audio CD Options Dialog

In this dialog, you can specify an UPC/EAN code for the CD, add silence before 
and after tracks, specify pauses, and decide whether to play back the audio through 
the Master Section.

In the Basic Audio CD window, select Options > Options.

UPC/EAN Code

Here you can specify an optional UPC/EAN code for the CD.

Adjust gaps between markers and sound (as CD frames)

If this option is activated, WaveLab performs small adjustments to the spacing 
before and after the CD Track Markers. This is useful to ensure that a 
low-quality CD player does not miss the start of tracks or cut them off before 
their actual end, for example. You can specify the silence length for the 
following options:

• Silence after first track start marker

• Silence after track start marker

• Silence before each track end marker

• Silence before last track end marker

Default pause

Lets you add a few frames of silence before the first track of the CD. Usually, 
the pause needs to be longer for the first track than for the other tracks, to 
ensure that a low-quality CD player does not miss the start of the first track, 
for example.

Reset pause of all tracks

If this option is activated, the pauses of all tracks are reset to the default value 
when you close the dialog.

Play through Master Section

If this option is activated, playback of the Basic Audio CD passes the Master 
Section.

NOTE

You cannot use this option when writing a Basic Audio CD.
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Save as default settings

If this option is activated, the settings made in this dialog are used for newly 
created Basic Audio CDs.

About CD Markers

A track in the Basic Audio CD window is defined by CD track start and end markers 
or CD track splice markers.

• CD track splice markers indicate the end of one track and the start of the next. 
If you insert a start marker after another start marker, the second marker is 
automatically converted into a splice marker.

• If you delete the CD markers defining a track, the track is deleted from the 
Basic Audio CD list.

• If you edit the marker position of a CD track, the change is reflected in the 
track in the Basic Audio CD.

• When you create a CD track start marker, a CD track end marker is 
automatically created at the start of the next track or at the end of the audio 
file, whichever comes first.

• If you try to move CD track markers beyond the end of the corresponding file, 
to a position inside another track, etc., the marker is automatically moved to 
the closest valid position.

• The name of a CD track is the name of the CD track start marker. Editing the 
marker name also changes the CD Track name, and vice versa.

Preparing a Basic Audio CD

You can add any type of file to a Basic Audio CD. However, when writing the files 
to CD, the files must meet certain specifications.

• 44100 Hz (44.1 kHz)

• Mono, dual-mono, or stereo.

• 8, 16, 20, or 24-bit resolution. During the writing process, files are converted 
to 16-bit stereo.

A track can only be used once in a Basic Audio CD.
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Creating a Basic Audio CD

PROCEDURE

1. In the Basic Audio CD window, select File > New.

2. Add tracks to the Basic Audio CD project using the following methods:
• In the Basic Audio CD window, select File > Add Tracks, select the audio 

files that you want to add, and click Open.

• Drag audio files from the file browser of your computer to the Basic Audio CD 
window.

• Drag a selection of an audio file from the wave window to the Basic Audio CD 
window.

If a file contains CD start and sub-index markers, these are used to define the track 
in the list.

If a file does not contain markers, a dialog asks you if you want to use the file start and 
end as boundaries for the track.

3. Select File > Save, specify a name and location, and click Save.

RESULT 

The audio files are added to the Basic Audio CD project.

Saving a Basic Audio CD

PREREQUISITE 

Set up your Basic Audio CD.

PROCEDURE

1. In the Basic Audio CD window, do one of the following:
• To save a Basic Audio CD that has never been saved before, select File > 

Save as.

• To save a Basic Audio CD that has been saved before, click the Save button, 
or select File > Save.

2. In the Save Basic Audio CD dialog, specify a file name and location.

3. Decide whether to activate one of the following options:
• Open standard file selector before this dialog

• Save copy

4. Click Save.
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Opening a Basic Audio CD Project

There can only be one Basic Audio CD project open at a time per workspace.

PROCEDURE

1. In the Basic Audio CD window, select File > Open.

2. Select a Basic Audio CD file and click Open.

RESULT 

All audio files referenced by the Basic Audio CD are opened in WaveLab. However, 
they do not appear in the wave windows.

Deleting CD Tracks from a Basic Audio CD

You can delete a CD track from a Basic Audio CD project by deleting its CD track 
markers or by deleting it from the Basic Audio CD list.

• In the wave window, right-click the CD track start or end marker of the CD 
track that you want to delete, and select Delete.

• In the Basic Audio CD window, select a track, and select Edit > Delete or 
click the Delete button.

Adjusting Pauses in CD Tracks

You can change the length of the pause that is played before the beginning of a 
track in the Basic Audio CD.

PROCEDURE

1. In the Basic Audio CD window, click the arrow icon next to a track to unfold it.

2. Double-click the Length column of the Pause row, enter a value, and press 
[Return].

Opening CD Tracks for Editing

You can open the tracks of a Basic Audio CD in a wave window to edit the audio 
or open the tracks as a clip in an audio montage.

• To open an entire CD track, double-click it in the Length column. A wave 
window opens and the entire CD track is selected.

• To open an entire CD track and position the cursor at track start or end, click 
the arrow icon to unfold the CD track, and double-click the Length column of 
the Track Start or Track End rows.
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• To insert a CD track into an open audio file, drag a CD track on an open audio 
file in the wave window.

• To open a CD track as a clip in an audio montage, drag the CD track into an 
audio montage and select one of the insert options.

About Playing Back Files in the Track List

You can play back files directly from the Basic Audio CD window by using the play 
buttons of each CD track.

• What you hear during playback is identical to the audio that is played back 
from the actual CD. All pauses and other adjustments are taken into account.

• If you have audio files in the list that do not have the correct sample rate 
(44.1 kHz), they can still be played back. However, when you activate 
playback, all files play back at the same rate. The inherent rate of the selected 
file (the one that plays first) is used for all files.

Playing Back Files in the Track List

There are several ways to play back files in the track list of a Basic Audio CD.

• In the Start column, click the time information of the track that you want to play 
back.

• Select a track, and click Play on the transport bar. Press Stop to stop 
playback.

• To play back from the marker position, in the Start column, click the right play 
icon of a track. To play back from the marker position with a pre-roll, click the 
left play icon.
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Playing Back Files in the Track List Through the Master Section

Playing back files through the Master Section takes all the settings and effects in 
the Master Section into account.

PROCEDURE

1. In the Basic Audio CD window, select Options > Options, or click the 
options icon.

2. Activate Play through Master Section, and click OK.

Saving Basic Audio CD Tracks as Separate Files

You can save tracks of a Basic Audio CD as separate audio files on your hard disk. 
This is useful for archiving, for example.

PROCEDURE

1. Set up a Basic Audio CD as you want it.

2. In the Basic Audio CD window, select File > Save each CD track as an 
audio file.

3. Specify a location, and the output format.

4. Click OK.

RESULT 

The tracks in the list are saved as separate audio files in the specified folder.

Saving Basic Audio CD Tracks as One File

You can save tracks of a Basic Audio CD as one audio file on your hard disk.

PREREQUISITE 

Set up a Basic Audio CD as you want it. A track must be at least 4 seconds long.

PROCEDURE

1. In the Basic Audio CD window, select File > Create an independent clone.

2. Specify a location, and the output format.

3. Click OK.

RESULT 

The tracks in the list are saved as one audio file in the specified folder.
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DVD-Audio

In WaveLab, you can author a DVD-Audio from a collection of audio montages and 
then write it to DVD-Audio.

You can add your audio montages to the DVD-Audio window, check the 
DVD-Audio layout for conformity, and write a DVD-Audio disk.

Compared to a Basic Audio CD, the DVD-Audio has the following advantages:

• More disk space

• Higher audio quality with up to 192 kHz and 24 bit

• Surround support

• Picture slide show support

The contents of a DVD-Audio project are stored in a folder named AUDIO_TS 
(Audio Title Set), which includes all audio, still picture, text, and visual menu data.

The AUDIO_TS contents are created when you render a DVD-Audio project, these 
data files are readable by the DVD-Audio player, but cannot be opened or edited in 
WaveLab.

You can use DVD+R, DVD-R, DVD+RW, DVD-RW, DVD-RAM for writing 
DVD-Audio compatible discs.

NOTE

Throughout WaveLab, where “CD” is mentioned (for example, in messages or 
marker names), this usually also applies for DVD-Audio.

Structure of a DVD-Audio Project

You structure your DVD-Audio projects in groups.

• An album can contain up to 9 groups. In WaveLab, a group corresponds to 
an audio montage. A group is similar to a CD and can be represented by an 
audio montage.

• Each group can contain up to 99 tracks. Tracks are defined by CD track start 
and end markers in the audio montage.
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DVD-Audio Formats

A DVD-Audio project can contain audio in a variety of resolutions.

The sample rates can be 48 kHz, 96 kHz, 192 kHz, 44.1 kHz, 88.2 kHz, or 176 kHz 
and the bit-depths can be 16 or 24.

You can use other bit resolutions for audio files in a montage, but they are stored 
on the DVD-Audio disc as either 16-bit or 24-bit audio samples, regardless of the 
original resolution. The bit resolution of the DVD is specified in the Audio montage 
preferences dialog.

DVD-Audio Format Considerations

There are two main considerations when planning a DVD-Audio project: the total 
size of the album and the maximum allowable data rate for a group.

A single album cannot contain more data than 4.7 GB (using a standard single layer 
DVD).

Maximum Allowable Data Rate for a Group

The data rate is the data bandwidth necessary to reproduce a given number of 
channels at a certain bit resolution and sample frequency. The DVD-Audio 
specification allows for a maximum data rate of 9.6 Mbps when using an 
uncompressed PCM audio format.

To keep a DVD-Audio project within the allowable data rate limit, use the following 
table as a guide:

Number of 
Channels

Maximum Bit Resolution/Sample Rate

6 Up to 16 bit/96 kHz or 24 bit/48 kHz

4 Up to 24 bit/96 kHz

2 Up to 24 bit/192 kHz
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DVD-Audio Window

In this window, you can author DVD-Audio and write it to DVD.

In the Audio Montage workspace, select Workspace > Specific tool windows > 
DVD-Audio.

DVD-Audio List

The columns in the DVD-Audio window show information about the audio 
montages in the project. Apart from the entries in the Group Name column, you 
cannot edit any of the information shown in this window.

Group name

If you double-click the name, you can enter a new name for the group. By 
default the name of the audio montage is used as the group name. The group 
name is shown in the DVD menu display.

File

The name of the audio montage. If you double-click the audio montage name, 
the corresponding audio montage opens.

Titles

The number of titles in the audio montage.

Time

The total time of all titles.

Bits

The bit depth of the samples in the audio montage (as they will be stored on 
the final DVD).

Rate

The sample rate of the audio montage.

Channel

The number of audio channels used in the audio montage.

Size

The total size of the audio montage.
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Menu Options

The following options are available from the menus of the DVD-Audio window:

New

Closes the currently opened DVD-Audio and opens an new one.

Open

Lets you select a DVD-Audio file. This closes the currently opened 
DVD-Audio.

Add audio montages

Opens the file browser where you can select the audio montages that you 
want to add to the DVD-Audio.

Delete

Deletes the selected audio montage from the DVD-Audio.

Edit audio montage

Opens the montage window of the selected audio montage.

Write DVD-Audio

Opens a dialog from which you can write a DVD.

Check DVD-Audio conformity

Verifies that the structure of the DVD-Audio is correct according to the 
standard.

Options

Opens the DVD-Audio options dialog.

Save/Save as

Lets you save the DVD-Audio.

DVD-Audio Options Dialog

In this dialog, you can make various settings for the DVD-Audio.

In the DVD-Audio window, select Options > Options.

Disc identification - Volume ID/Number of volumes

Allows you to specify disc information. For example, if you have a project that 
has 3 DVD discs, you can specify 3 volumes, and specify the ID for the 
volumes 1, 2, and 3.

Disc identification - Album name

Lets you type in the name of the album. This name is also used as the DVD 
volume name.

Disc identification - Provider information

Lets you type in information about the DVD-Audio provider.
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Default still picture

If this option is activated, you can define a default still picture that is displayed 
when the DVD-Audio is played back.

Still picture effects - Mode

Lets you define effect transitions between pictures. Choose a mode and a 
duration of the transition for start and end of playback. Not all DVD players 
support this feature.

Options - Generate menus

If this option is activated, a basic menu displaying the album/group/tracks 
structure is automatically generated. This menu appears when playing back 
the DVD-Audio in a DVD player.

Options - Include still picture tracks

If this option is activated, pictures placed on audio montage picture tracks are 
included on the DVD, and are displayed by a compatible DVD player.

Options - Auto play

If this option is activated, DVD playback starts automatically when the DVD is 
inserted into a compatible DVD player.

TV System

Specifies whether the DVD-Audio disc should conform to the NTSC or 
PAL/SECAM video standard.

About TV Systems

If you want to use still pictures you need to specify whether the DVD-Audio disc 
should conform to the NTSC or PAL/SECAM video standard.

This is important because the NTSC (used in North America and Asia) and 
PAL/SECAM (used in Western Europe, Australia/France, and Eastern Europe) use 
different resolutions.
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Preparing a DVD-Audio

Creating a DVD-Audio

PROCEDURE

1. In the DVD-Audio window, select File > New.

2. Add tracks to the DVD-Audio project using the following methods:
• In the DVD-Audio window, select File > Add Audio Montages, select the 

audio montages that you want to add, and click Open.

• Drag audio montages from the file browser of your computer to the DVD-Audio 
window.

• Drag an audio montage by its Document button to the DVD-Audio window.

3. Select File > Save, specify a name and location, and click Save.

RESULT 

The audio montages are added to the DVD-Audio project.

Opening a DVD-Audio Project

There can only be one DVD-Audio project open at a time per workspace.

PROCEDURE

1. In the DVD-Audio window, select File > Open.

2. Select a Basic Audio CD file and click Open.

RESULT 

All audio montages referenced by the DVD-Audio file are opened in WaveLab. 
However, they do not appear in the montage window.

Setting an Audio Montage to DVD-Audio Mode

To be able to write an audio montage to DVD-Audio, the mode of the audio montage 
must be DVD-Audio compatible.

PROCEDURE

1. In the Audio Montage workspace, select Edit > Audio Montage properties.

2. From the Mode pop-up menu, select Multichannel, DVD-Audio compatible.

3. Click OK.

4. Click File > Save to save the changes.
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Deleting Audio Montages from a DVD-Audio

When deleting audio montages from a DVD-Audio, the audio montage references 
are removed from the DVD-Audio, but the audio montage files are not affected.

PROCEDURE

• In the DVD-Audio window, select an audio montage, and select Edit > 
Delete or press the Delete button.

Opening Audio Montages for Editing

There are several ways to open an audio montage of a DVD-Audio project for 
editing in the montage window.

• Double-click the audio montage in DVD-Audio window. A montage window 
opens.

• Select an audio montage from the list, and click the Edit Audio Montage 
button.

• Drag an audio montage from the DVD-Audio window to an open audio 
montage, or the montage window area.

Checking the DVD-Audio Conformity

Before rendering the DVD-Audio project, you can use the Check DVD-Audio 
conformity function. This checks all audio montages in the project and displays a 
warning if the project does not comply with the DVD-Audio standard. However, this 
is done automatically before writing to disk.

PROCEDURE

• In the DVD-Audio window, select Edit > Check DVD-Audio conformity, or 
click the Check DVD-Audio conformity icon.

RESULT 

All audio montages added to the DVD-Audio project open, and a message appears 
stating the result of the conformity check.
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Writing Operations

This chapter describes the CD/DVD writing processes in WaveLab. This chapter 
assumes that the preparations have been completed, and that you are ready to run 
the actual writing process.

Refer to the chapters Basic Audio CD, DVD-Audio, and CD window for a 
description of the preparations before following the instructions in this chapter.

RELATED LINKS

Basic Audio CD on page 440
DVD-Audio on page 449
About the CD Window on page 311

Write Audio CD or DDP Dialog

In this dialog, you can write your Audio CD project and audio montage to audio CD 
or DDP image.

• When you want to write audio files to an audio CD or a DDP image, in the 
Audio Files workspace, open the Basic Audio CD window, and select Edit 
> Write Audio CD or DDP.

• When you want to write audio montages to an audio CD or a DDP image, in 
the Audio Montage workspace, open the CD window, and select Functions 
> Write Audio CD or DDP.

The following options are the same for writing both audio files and audio montages 
to audio CD/DDP image:
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Device

Here, select the disc writer that you want to use, or select DDP Image to write 
a set of DDP files on the hard drive.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, 
the drive is under the control of the operating system and is not available for 
WaveLab.

Refresh

Scans the system for connected optical devices. This is done automatically, 
when this dialog opens. Click the refresh icon after you insert a new blank 
media to update the Speed menu.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, 
the drive is under the control of the operating system and is not available for 
WaveLab.

Eject optical medium

Ejects the optical medium present in the selected drive.

Information about selected device

Opens the Device information dialog, that shows information about the 
selected device.

Erase optical media

Erases the optical disc present in the selected drive, provided it is a rewritable 
media.

If DDP Image is selected, clicking the button erases the existing DDP files.

Bypass Master Section

If this option is activated, the audio signal is not processed through the Master 
Section before being written to the media. For writing a Basic Audio CD, this 
option is always activated.

Destination folder (DDP Image must be selected)

Lets you specify the destination path. If you type a non-existing path, it is 
automatically created.

Write table of contents and customer information (DDP Image must be 
selected)

If this option is activated, a file called IDENT.TXT is written in the DDP folder. 
It contains a table of contents of the tracks and some customer information. 
This file is not officially part of the DDP specification, but it can be used by the 
recipient of the DDP image to identify the files.

Speed

Lets you select the writing speed. The highest speed depends both on the 
capabilities of your writing device and of the media present in the device.
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Copies

Lets you enter the number of copies that you want to write.

Test only, do not write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Render to temporary file before writing (only available for writing audio 
montages)

If this option is activated, a disk image is created before writing, which 
eliminates the risk of buffer underruns. This is useful if your project uses many 
audio plug-ins while writing. It is activated automatically when writing multiple 
copies. While this option makes the writing operation longer, it may allow you 
to select an higher writing speed.

CD-Extra compatible (new session possible)

If this option is activated, the resulting audio CD is compatible with the 
CD-Extra format.

Eject after completion

If this option is activated, the disc is ejected after the write process.

Erase Optical Media Dialog

In this dialog, you can quickly or fully erase the disc before writing.

In the Write Audio CD or DDP dialog, click the eraser icon.

Quick erase

Erases the table of contents of the disc.

Full erase

Erases all parts of the disc.

Force erasing even if a disk appears to be blank

If this option is activated, the disc is erased, even if it is declared as blank. Use 
this option to make sure that discs that were partially or minimally erased are 
fully erased.
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About Writing Audio Files

You can write the audio files of a Basic Audio CD project to an audio CD or a DDP 
image.

Writing Audio Files to an Audio CD

PREREQUISITE 

Set up a Basic Audio CD project.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, the drive 
is under the control of the operating system and is not available for WaveLab.

PROCEDURE

1. Optional: Check the Basic Audio CD project to make sure that all starts, ends, 
and transitions are as intended.

2. Optional: In the Basic Audio CD window, select Edit > Check CD 
conformity, to check that all settings conform to the Red Book standard.

3. Insert an empty CD into your drive.

4. In the Basic Audio CD window, select Edit > Write Audio CD or DDP.

5. From the Device pop-up menu, select the writing device that you want to use.

6. Select the writing speed from the Speed pop-up menu.

7. Optional: Activate one or several of the following options:
• Activate Test only, do not write, if you want to test if the writing operation 

would be successful.

• Activate CD-Extra compatible (new session possible), if you want the 
resulting audio CD to be compatible with the CD-Extra format.

• Activate Eject after completion, if you want the disc to be automatically 
ejected after the writing operation.

8. Click OK to start the writing operation.

RELATED LINKS

Write Audio CD or DDP Dialog on page 456
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Writing Audio Files to DDP Image

There might be situations when you want to freeze an entire Basic Audio CD, 
without actually writing a CD. This is done by saving as a DDP image.

PREREQUISITE 

Set up a Basic Audio CD project.

PROCEDURE

1. Optional: Check the Basic Audio CD project to make sure that all starts, ends, 
and transitions are as intended.

2. Optional: In the Basic Audio CD window, select Edit > Check CD 
conformity, to check that all settings conform to the Red Book standard.

3. In the Basic Audio CD window, select Edit > Write Audio CD or DDP.

4. From the Device pop-up menu, select DDP Image.

5. Specify the destination folder.

6. Optional: Activate Write table of contents and customer information, to 
create a text file, containing information about the DDP file.

7. Click OK, to start the writing operation.

RESULT 

The following files and folders are created:

• A Basic Audio CD file with the specified name. This is the file you need to 
open the next time you want to access this CD image.

• A single wave file, containing all the tracks and markers.

• A marker file that contains the markers.

• A peak file for the wave file.

RELATED LINKS

Write Audio CD or DDP Dialog on page 456
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Write Audio CD From DDP Image

In this dialog, you can write a CD from a DDP image that you have previously 
created with WaveLab or another application.

In the Audio Files workspace or the Audio Montage workspace, select File > 
Export > Write Audio CD from DDP image.

Device

Here, select the disc writer that you want to use.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, 
the drive is under the control of the operating system and is not available for 
WaveLab.

Refresh

Scans the system for connected optical devices. This is done automatically, 
when this dialog opens. Click the update icon after you insert a new blank 
media to update the Speed menu.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, 
the drive is under the control of the operating system and is not available for 
WaveLab.

Eject optical medium

Ejects the optical medium present in the selected drive.

Information about selected device

Opens the Device information dialog, that shows information about the 
selected device.

Erase optical disc

Erases the optical disc present in the selected drive, provided it is a rewritable 
media. If DDP Image is selected, clicking the button erases the existing DDP 
files.
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Speed

Here, select the writing speed. The highest speed depends both on the 
capabilities of your writing device and of the media present in the device.

Test only, do not write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Eject after completion

If this option is activated, the disc is ejected after the write process.

DDP Image folder

Lets you specify the source path of the DDP image.

About Writing Audio Montages

You can write audio montages to an audio CD or a DDP image.

Writing an Audio Montage to an Audio CD

PREREQUISITE 

Set up your audio montage, and make your CD writing settings in the Global 
preferences.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, the drive 
is under the control of the operating system and is not available for WaveLab.

PROCEDURE

1. Optional: Check the audio montage to make sure that all starts, ends, and 
transitions are as intended.

2. Optional: In the CD window, select Functions > Check CD conformity, to 
check that all settings conform to the Red Book standard.

3. Insert an empty CD into your drive.

4. In the CD window, select Functions > Write Audio CD or DDP.

5. From the Device pop-up menu, select the writing device that you want to use.

6. If you want to bypass the Master Section, activate Bypass Master Section.

7. Select the writing speed from the Speed pop-up menu.

8. Select the number of copies that you want to write.
When you want to write more than one copy, it is recommended to activate Render 
to temporary file before writing.
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9. Optional: Activate one or several of the following options:
• Activate Test only, do not write, if you want to test if the writing operation 

would be successful.

• Activate Render to temporary file before writing, if your audio montage uses 
many plug-ins. This way, the audio data is sent to the CD writer fast enough.

• Activate CD-Extra compatible (new session possible), if you want the 
resulting audio CD to be compatible with the CD-Extra format.

• Activate Eject after completion, if you want the disc to be automatically 
ejected after the writing operation.

10. Click OK.

RESULT 

The writing operation starts.

RELATED LINKS

Write Audio CD or DDP Dialog on page 456

Writing an Audio Montage to a DDP Image

PREREQUISITE 

Set up your audio montage, and make your CD writing settings in the Global 
preferences.

PROCEDURE

1. Optional: Check the audio montage to make sure that all starts, ends, and 
transitions are as intended.

2. Optional: In the CD window, select Functions > Check CD conformity, to 
check that all settings conform to the Red Book standard.

3. In the CD window, select Functions > Write Audio CD or DDP.

4. From the Device pop-up menu, select DDP Image.

5. If you want to bypass the Master Section, activate Bypass Master Section.

6. Specify the destination folder.

7. Optional: Activate Write table of contents and customer information, to 
create a text file, containing information about the DDP file.

8. Click OK, to start the writing operation.

RELATED LINKS

Write Audio CD or DDP Dialog on page 456
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Writing Audio Montages With Any Sample Rate

You can write audio montages to CD/DDP even if they are not at 44.1 kHz. To be 
able to do this, you must set up the Crystal Resampler plug-in in the Master Section. 
This procedure is not automated so that you can customize the resampling quality, 
limiting, and dithering.

PREREQUISITE 

Set up your audio montage.

PROCEDURE

1. In the Master Section, add the Crystal Resampler plug-in to an Effects slot.

2. In the Crystal Resampler, set the Sample rate to 44.1 kHz.

3. Optional: Add a Peak Limiter and a Dithering plug-in at the end of the 
Master Section.

4. Write the audio montage as you would write any other audio montage.

RELATED LINKS

Writing an Audio Montage to an Audio CD on page 462
Writing an Audio Montage to a DDP Image on page 463

Checking the Transition Between Tracks

You can set up a pre-roll time before tracks start and then play back all tracks. This 
way you can check the transition between tracks.

PREREQUISITE 

Set up your audio montage.

PROCEDURE

1. In the Audio Montage workspace, in the CD window, select Options > Edit 
playback times.

2. Make your settings, and click OK.

3. In the CD window, select Functions > Play all CD-track starts.

RESULT 

Each track start and end point is played back according to the values set in the Edit 
playback times dialog.
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About CD-Text

CD-Text is an extension of the Red Book Compact Disc standard and allows you 
to store text information such as title, songwriter, composer, and disc ID on an audio 
CD.

The text data is then displayed by CD players that support the CD-Text format. The 
CD-Text can also be included in the audio CD report.

CD-Text Editor Dialog

In this dialog, you can specify information such as track title, performer, and 
songwriter, that is written onto the CD as CD-Text.

You can add information about the disc itself and each individual track. This 
information is entered in the text fields that scroll horizontally. There is one pane of 
fields for the disc itself and a pane for each track.

In the Audio Montage workspace, in the CD window, select the track for which you 
want to edit the CD-Text, and select Functions > Edit CD-Text.

Copies the name of the CD track start marker to this field.

Copies the name of each CD track start marker to the title field of each CD 
track.

Copies the text to all tracks located after the current one.

Scrollbar

Use the scrollbar to navigate across all CD-Texts. The first position 
corresponds to the whole CD, other positions to individual tracks.
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Language selection

Here, select how characters should be encoded on the CD.

NOTE

If a character is not CD-Text compatible, it is displayed as a ? character.

Restrict to ASCII

To ensure the maximum compatibility with CD players, it is recommended to 
restrict the characters to ASCII when using the Western European option. If 
this option is activated, and you type a non-compatible character, a ? 
character is displayed.

Enable CD-Text writing

If this option is activated, the CD-Text is written onto the CD.

Audio CD Reports

An audio CD report is a detailed report about the active audio CD. This report 
includes a full track listing with ISRC codes, track times, and CD-Text.

The audio CD report can be output in HTML, Adobe PDF, XML, simple text format, 
CSV format, or printed out. You can choose the details of what is displayed and 
include your custom logo. You can send the audio CD report to your client, an 
album artwork designer, or to the CD replication house when presenting them with 
a master CD, for example.

There are two types of variables:

• Factory variables provide automatically generated information about a project 
such as number of tracks, track times, track names, etc. – based on the actual 
contents of the project.

• User defined variables contain personal data such as company name and 
copyright information, etc.

Along with the variables, the audio CD report can also include any CD-Text that you 
have specified, for examples, composers, performers, etc.

Generating an Audio CD Report

An audio CD report should be generated when an audio montage is fully prepared 
and ready for CD writing.

PROCEDURE

1. In the Audio Montage workspace, open the audio montage that you want to 
create a report for.
The audio montage must be in stereo mode.

2. Open the CD window.

3. In the CD window, select Functions > Generate Audio CD report.
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4. On the Rich Text tab, in the Output format section, specify one of the 
following output formats:
• HTML, Adobe PDF, Print, XML, or CSV

5. Make your settings.

6. Optional: On the Raw Text tab, select a cue-sheet template or enter 
cue-sheet information.

7. Optional: If you want to save the audio CD report to a specific location, 
activate Generate specific file, and specify a file name and location.

8. Click Apply.

Audio CD Report Dialog

In this dialog, you can generate an audio CD report and specify which information 
to include in this report.

In the Audio Montage workspace, in the CD window, select Functions > Generate 
Audio CD report.

Global Options

The following option is available on the Rich Text tab and the Raw Text tab.

Generate specific file

Lets you specify a name and location for the report. The file is created, when 
you click Apply.
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Rich Text Tab

Font and Font Size

Determines the font and font size to use in the report.

Header image

Lets you select an image to be inserted at the top of the report.

Center image

Centers the image horizontally. If deactivated, the image is placed on the left.

Header

Adds general information at the start of the report.

Custom text

Lets you enter text to be inserted at the top of the report. To insert custom 
variables, right-click the text field.

Extra lines

Lets you select which of the following information you want to add to the 
header:

• Date

• Name of the audio montage

• UPC/EAN Code

• Number of tracks

• Disc duration
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Skip lines with empty values

If this option is activated, when a line contains an empty variable, the line is 
not added to the report.

Details

Adds a description of the pause, track start, and possible sub-indexes to the 
report.

CD-Text

If this option is activated, the CD-Text is included in the report.

Pause

If this option is activated, the pause information is included in the report.

Pre-emphasis status

Adds a column to the report to display the track pre-emphasis status.

Copy status

Adds a column to the report to display the copy status of the track.

ISRC

Adds a column to the report to display the ISRC code.

Sub-indexes

If this option is activated, track sub-indexes are described in the report.

Sub-indexes are relative to track

Sets the sub-index values to be relative to the start of the corresponding track. 
If deactivated, they are relative to the start of the CD.

Start time (in audio montage)

Adds a column to the report to display the event times from the start of the 
audio montage.

Start time (on CD)

Adds a column to the report to display the event times from the start of the 
CD.

Output format

Lets you select the output format for the report.

• HTML generates an html file with a UTF-8 character format.

• Adobe PDF generates a PDF file.

• Print generates a preview of the report, allowing you to print the report. 
If no printer is connected, the preview is empty.

• XML generates an XML file that includes the CD information.

• CSV generates a CSV file that can be imported in a spreadsheet. The 
CSV file can only store the main properties of the CD report. You can 
set the type CSV delimiter in the Global Preferences dialog.
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Value format

Opens the Value formats dialog, where you can edit the format of the 
auto-generated values. These variables are part of any presets saved for this 
dialog.

Generate specific file

Lets you specify a name and location for the report. The file is created, when 
you click Apply.

Raw Text Tab

Template

Lets you select a template for the report layout. When selecting Custom, you 
can also create your own cue-sheet template.

Cue-sheet field

Lets you write a cue-sheet.
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Copy to clipboard

Copies the text to the clipboard.

Cue-Sheet Templates

A cue-sheet is an alternate form of the CD report, based on raw UTF-8 text, and can 
be customized in several ways. Creating a cue-sheet requires an understanding of 
computers, and some knowledge about programming, since it makes use of the 
commands and variables concept.

Cue-sheets are organized in the following way. There are a number of codes, 
commands, and variables, which you place in a text file - the template. When you 
ask the program to generate a cue-sheet, it creates the text file based on the codes 
it finds in the template.

If the program encounters a variable, it replaces this with some information about 
the CD. For example, there is a variable called "NUM_TRACKS". When the program 
finds this, it replaces it with the actual number of tracks in the CD.

Commands, on the other hand, are instructions for the program to do something. 
For example, the command "TIMECODE SEPARATOR =" followed by a few 
special characters, instructs the program what characters should be inserted 
between time code values, so that you can get time code values printed out in the 
format 00:00:00.00, "00 00 00 00", or anything else you prefer.

The following codes can be entered for specific purposes:

All other text characters can be entered on their own lines or among the variables, 
and are used as they are. For example, if you type “Title: $TITLE” and the title you 
have entered is “My Greatest Hits!”, the text “Title: My Greatest Hits” appears in 
the cue-sheet.

To find out about the available commands and how they are used, you can open the 
included templates and study them. The following variables are available:

Code Description

$ A variable. The text that follows right after the “$” is the command name, for 
example, “$TITLE”. A variable can occur anywhere on a line, and there can be 
any number of variables on a line.

# A command. The text that follows after the “#” is the command name, for 
example, “#FOR EACH TRACK”. There can only be one command per line 
and there should not be anything else on that line.

; If a line starts with a semi-colon (;), the line is interpreted as a comment. 
Nothing on such a line is used in the cue-sheet. This is useful for making 
notes, for example.
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Track Number

Track Index

Copy Protection Status

Emphasis Status

Absolute Time of Index

Variable Description

T0 As decimal number “1” or “22”

T1 Blank Justified Two Digit Number “1” or “22”

T2 Zero Justified Two Digit Number “01” or “22”

Variable Description

I0 As decimal number “1” or “22”

I1 Blank Justified Two Digit Number “1” or “22”

I2 Zero Justified Two Digit Number “01” or “22”

Variable Description

C1 “x” or “ ”

C2 “Y” or “N”

Variable Description

E1 “x” or “ ”

E2 “Y” or “N”

Variable Description

TIME_IA_0 As decimal number

TIME_IA_1 Blank justified 7 digit decimal number
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Index Time Relative to Start of CD

TIME_IA_2 Time as “hh:mm:ss:ff”

TIME_IA_3 Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_IA_4 Time as “hh:mm:ss:ff” compressed, if there are no hours, none are 
displayed

TIME_IA_5 Time as “mm:ss:ff” no hours displayed

TIME_IA_6 Time as “mm:ss:ff” blank justified, leading zero not shown, no 
hours displayed

TIME_IA_7 Time as “mm:ss:ff” no minutes displayed if not required, no hours 
displayed

TIME_IA_8 Time format as “1h 2mn 3s 4f”

TIME_IA_9 Time format as “1h 2mn 3s”

Variable Description

Variable Description

TIME_IR_0 As decimal number

TIME_IR_1 Blank justified 7 digit decimal number

TIME_IR_2 Time as “hh:mm:ss:ff”

TIME_IR_3 Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_IR_4 Time as “hh:mm:ss:ff” compressed, if there are no hours, none are 
displayed

TIME_IR_5 Time as “mm:ss:ff” no hours displayed

TIME_IR_6 Time as “mm:ss:ff” blank justified, leading zero not shown, no 
hours displayed

TIME_IR_7 Time as “mm:ss:ff” no minutes displayed if not required, no hours 
displayed

TIME_IR_8 Time format as “1h 2mn 3s 4f”

TIME_IR_9 Time format as “1h 2mn 3s”
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Index Time Relative to Start of Track

Pause Length

Variable Description

TIME_IT_0 As decimal number

TIME_IT_1 Blank justified 7 digit decimal number

TIME_IT_2 Time as “hh:mm:ss:ff”

TIME_IT_3 Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_IT_4 Time as “hh:mm:ss:ff” compressed, if there are no hours, none are 
displayed

TIME_IT_5 Time as “mm:ss:ff” no hours displayed

TIME_IT_6 Time as “mm:ss:ff” blank justified, leading zero not shown, no 
hours displayed

TIME_IT_7 Time as “mm:ss:ff” no minutes displayed if not required, no hours 
displayed

TIME_IT_8 Time format as “1h 2mn 3s 4f”

TIME_IT_9 Time format as “1h 2mn 3s”

Variable Description

TIME_PA_0 As decimal number

TIME_PA_1 Blank justified 7 digit decimal number

TIME_PA_2 Time as “hh:mm:ss:ff”

TIME_PA_3 Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_PA_4 Time as “hh:mm:ss:ff” compressed, if there are no hours, none are 
displayed

TIME_PA_5 Time as “mm:ss:ff” no hours displayed

TIME_PA_6 Time as “mm:ss:ff” blank justified, leading zero not shown, no 
hours displayed

TIME_PA_7 Time as “mm:ss:ff” no minutes displayed if not required, no hours 
displayed

TIME_PA_8 Time format as “1h 2mn 3s 4f”
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Track Length

CD Length

TIME_PA_9 Time format as “1h 2mn 3s”

Variable Description

Variable Description

TIME_TR_0 As decimal number

TIME_TR_1 Blank justified 7 digit decimal number

TIME_TR_2 Time as “hh:mm:ss:ff”

TIME_TR_3 Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_TR_4 Time as “hh:mm:ss:ff” compressed, if there are no hours, none are 
displayed

TIME_TR_5 Time as “mm:ss:ff” no hours displayed

TIME_TR_6 Time as “mm:ss:ff” blank justified, leading zero not shown, no 
hours displayed

TIME_TR_7 Time as “mm:ss:ff” no minutes displayed if not required, no hours 
displayed

TIME_TR_8 Time format as “1h 2mn 3s 4f”

TIME_TR_9 Time format as “1h 2mn 3s”

Variable Description

TIME_CD_0 As decimal number

TIME_CD_1 Blank justified 7 digit decimal number

TIME_CD_2 Time as “hh:mm:ss:ff”

TIME_CD_3 Time as “hh:mm:ss:ff” blank justified, leading zero not displayed

TIME_CD_4 Time as “hh:mm:ss:ff” compressed, if there are no hours, none are 
displayed

TIME_CD_5 Time as “mm:ss:ff” no hours displayed

TIME_CD_6 Time as “mm:ss:ff” blank justified, leading zero not shown, no 
hours displayed
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Various

Creating a Cue-Sheet Template

You can create a cue-sheet template and load it each time you want to create an 
audio CD report.

PROCEDURE

1. In the Audio Montage workspace, open an audio montage that contains CD 
tracks.
The audio montage must be in stereo mode.

2. Open the CD window.

3. In the CD window, select Functions > Generate Audio CD report.

4. Open the Raw Text tab.

5. In the Template section, select Custom to start with an empty cue-sheet, or 
select one of the available cue-sheets to modify them.

6. Enter the cue-sheet information.

7. Activate Generate specific file, and specify a file name and location.

8. Click Apply to save the cue-sheet template.

TIME_CD_7 Time as “mm:ss:ff” no minutes displayed if not required, no hours 
displayed

TIME_CD_8 Time format as “1h 2mn 3s 4f”

TIME_CD_9 Time format as “1h 2mn 3s”

Variable Description

Variable Description

NUM_TRACKS Total number of tracks as decimal number

UPC UPC/EAN code

ISRC ISRC code

FILE File name (no path)

PFILE File name (with path)

TRACK_NAME Track name

TRACK_COMME
NT

Track comment
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Write DVD-Audio Function

Before writing an audio montage to DVD-Audio, the contents of the DVD-Audio 
project must be rendered to an AUDIO_TS folder. This folder is automatically added 
to a Data CD/DVD project, from where you can start the actual writing operation.

DVD-Audio Creation Dialog

This dialog allows you to make settings for the DVD-Audio creation.

In the Audio Montage workspace, in the DVD-Audio window, set up the DVD-Audio 
project and click the Write DVD-Audio icon.

Test only

If this option is activated, all data is checked and rendered in memory, to know 
if the DVD-Audio project is complete and ready for rendering. When the test 
is finished, a report opens.

Render each audio montage with its own plug-in set

If this option is activated, each audio montage is rendered with its own Master 
Section effects.

Use current Master Section settings for all audio montages

If this option is activated, all audio montages are rendered using the selected 
Master Section settings.

Ignore

If this option is activated, the audio montages are rendered without any Master 
Section effects.

Output folder

Lets you select the destination folder for the rendered files.
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Rendering the DVD-Audio

To be able to write the DVD-Audio project to disk or ISO image, you must render 
the DVD-Audio project first.

PREREQUISITE 

Set up the DVD-Audio project.

If you want to use the Master Section plug-ins when rendering the project, set up 
the Master Section to your liking.

PROCEDURE

1. In the DVD-Audio window, select Edit > Write DVD-Audio, or click the Write 
DVD-Audio icon.

2. In the Master Section plug-ins section, activate one of the following options:
• Render each audio montage with its own plug-in set
• Use current Master Section settings for all audio montages
• Ignore

3. Specify an output folder.

4. Click OK.

RESULT 

The Write Data CD/DVD dialog opens, allowing you to write your DVD-Audio 
project.

Write Data CD/DVD Dialog When Writing DVD-Audio

In this dialog, you can write your DVD-Audio project to CD/DVD or ISO file.

In the Audio Montage workspace, in the DVD-Audio window, set up and render the 
DVD-Audio project. After the rendering operation is finished, the Write Data 
CD/DVD dialog opens.
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Device

Lets you select the disc writer that you want to use, or select ISO Image to 
write a file on the hard drive. Writing an ISO image creates a copy of a future 
optical media.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, 
the drive is under the control of the operating system and is not available for 
WaveLab.

Refresh

Scans the system for connected optical devices. This is done automatically, 
when this dialog opens. Click the update icon after you insert a new blank 
media, to update the speed menu.

NOTE

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, 
the drive is under the control of the operating system and is not available for 
WaveLab.

Eject optical medium

Ejects the optical medium present in the selected drive.

Information about selected device

Opens the Device information dialog, that shows information about the 
selected device.

Erase optical disc

Erases the optical disc present in the selected drive, provided it is a rewritable 
media. If ISO Image is selected, clicking the button erases the existing ISO 
file.

ISO file name

When ISO Image is selected on the Device menu, specify the file name and 
file location of the ISO file in the text field.

Speed

Here, select the writing speed. The highest speed depends both on the 
capabilities of your writing device and of the media present in the device.

Test only, do not write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Verify after write

If this option is activated, the data on the medium is automatically verified after 
the writing process.
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Eject before verifying

If this option is activated, the disc is ejected and retracted before the 
verification process, to force the drive out of the write state. This is only 
possible if the disc can be retracted automatically.

Eject after completion

If this option is activated, the disc is ejected after the write process.

Writing a DVD-Audio Project to a Data CD/DVD

After rendering the DVD-Audio project, you can write it to a Data-CD/DVD.

PREREQUISITE 

Set up and render a DVD-Audio project.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

On the Mac, insert a media in the drive after opening WaveLab. Otherwise, the drive 
is under the control of the operating system and not available for WaveLab.

PROCEDURE

1. Optional: Check the DVD-Audio project to make sure that all starts, ends, and 
transitions are as intended.

2. Optional: In the DVD-Audio window, select Edit > Check DVD-Audio 
conformity, to check that all settings are compatible with the Red Book 
standard.

3. Insert an empty DVD into your drive.

4. From the Device pop-up menu, select the disc writing device you want to use.

5. Select the writing speed from the Speed pop-up menu.

6. Optional: Activate one or several of the following options:
• Activate Test only, do not write, if you want to test if the writing operation 

would be successful.

• Activate Verify after write, if you want the file to be verified after the writing 
operation.

• Activate Eject before verifying and/or Eject after completion if you want the 
disc to be automatically ejected at the corresponding situations.

7. Click OK to start the writing operation.
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Writing a DVD-Audio Project to an ISO Image

When you want to save an entire DVD-Audio project without actually writing a DVD, 
you can save the project as an ISO image.

PREREQUISITE 

Set up and render a DVD-Audio project.

PROCEDURE

1. Check the DVD-Audio project to make sure that all starts, ends, and 
transitions are as intended.

2. Optional: In the DVD-Audio window, select Edit > Check DVD-Audio 
conformity, to check that all settings conform to the Red Book standard.

3. In the Write Data CD/DVD dialog, from the Device pop-up menu, select ISO 
image.

4. Specify an ISO file name and location.

5. Click OK.
The writing of the ISO file starts.

6. When the operation is finished, click OK.

Data CD/DVD Projects

A data CD/DVD project can be used to compile and write a data-only CD, DVD, 
Blu-ray, or to write to ISO image. You can enter a name for your disc and change 
the disc file structure before writing your data to a CD, DVD, Blu-ray, or ISO image.

Creating a Data CD/DVD Project

A data CD/DVD project can be used to compile and write a data-only CD, DVD, 
Blu-ray, or to write to ISO image.

PROCEDURE

1. In any workspace, select Global > Data CD/DVD.

2. Add files to the project, using one of the following methods:
• Drag the files from the WaveLab file browser or from the Explorer/Finder into 

the Data CD/DVD window.

• Drag a tab from any workspace into the Data CD/DVD window.

• In any workspace, select File > Special > Add to Data CD/DVD, to add the 
open file to the Data CD/DVD project.

3. Optional: Click the New Folder icon, specify a folder name, and arrange the 
files by dragging.
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Writing a Data CD/DVD Project

PREREQUISITE 

Open the Data CD/DVD dialog, and add the files that you want to write to a data 
CD/DVD.

PROCEDURE

1. Click the Write Data CD/DVD icon.

2. Select a writing device.
• When you select ISO Image, specify a file name and file location.

• When you select a CD/DVD writer, specify the writing speed and make further 
settings.

3. Click OK.

Data CD/DVD Dialog

In this dialog, you can create a data CD/DVD project, and write it to CD, DVD, 
Blu-ray, or ISO image.

In any workspace, select Global > Data CD/DVD.

Media

Select the media type you want to write. If the media size that you want to use 
is not listed, select the media type that offers a size closest to your 
requirements.

Volume name

Specify the volume name of the CD/DVD.

Open Explorer/Finder

Opens the Explorer/Finder to show the location of the selected file.

Remove selected files and folders

Removes the selected files and folders from the CD/DVD project.
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New folder

Creates a folder. You can also create sub-folders.

Write Data CD/DVD dialog

Opens the Write Data CD/DVD dialog from which you can write the media.

Data CD/DVD list

Shows the contents of the CD/DVD project, and the size and creation date of 
the files.

Available space on media

Indicates how much space is used on the media. The total size of the data 
CD/DVD project is shown below the data CD/DVD list.

Reset

Removes all files from the data CD/DVD project.

Write Data CD/DVD Dialog

In this dialog, you can write a data CD/DVD project to CD/DVD or ISO file.

In the Data CD/DVD dialog, click the Write Data CD/DVD icon.

Device

Here, select the disc writer you want to use, or select ISO Image to write a 
file on the hard drive. Writing an ISO image creates a copy of a future optical 
media.

NOTE

On the Mac, open WaveLab without a media in the drive. Otherwise, the drive 
is under the control of the operating system and is not available for WaveLab.

Refresh

Scans the system for connected optical devices. This is done automatically, 
when this dialog opens. Click the update icon after you insert a new blank 
media, to update the speed menu.
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Eject optical medium

Ejects the optical medium present in the selected drive.

Information about selected drive

Opens the Device information dialog, that shows information about the 
selected device.

Erase optical disc

Erases the optical disc present in the selected drive, provided it is a rewritable 
media. If ISO Image is selected, clicking the button erases the existing ISO 
file.

ISO file name

When ISO Image is selected in the Device menu, specify the file name and 
file location of the ISO file in the text field.

Speed

Here, select the writing speed. The highest speed depends both on the 
capabilities of your writing device and of the media present in the device.

Test only, do not write

If this option is activated, clicking OK initiates a simulation of writing the CD. 
If this test is passed, the real write operation will succeed. If the test fails, try 
again at a lower writing speed.

Create CD-Extra session

If this option is activated, the data is written in a new session, after the audio 
tracks. This creates a CD Extra, also known as Enhanced CD and CD Plus. 
For this to work, the CD in the drive must have audio tracks on it, written with 
the CD Extra option. Otherwise the operation fails.

Verify after write

If this option is activated, the data on the medium is automatically verified after 
the writing process.

Eject before verifying

If this option is activated, the disc is ejected and retracted before the 
verification process, to force the drive out of the write state. This is only 
possible if the disc can be retracted automatically.

Eject after completion

If this option is activated, the disc is ejected after the write process.
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About Audio CD Formats

This chapter provides you with background information on the CD format, to help 
you better understand how to create your own CDs.

This documentation can only give basic information on this subject. For more 
information, try a text-book on the subject, or search the internet.

Basic CD Formats

There are a number of different formats for the contents of a CD disc. For example, 
audio CDs, CD-ROMS, and CD-I. These are all slightly different.

The audio CD specification is called Red Book. It is this standard to which 
WaveLab conforms.

NOTE

Red Book CD is not a real file format. All the audio on the CD is stored in one big 
file. This is different from hard disks, for example, where each file is stored 
separately. Keep in mind that all the audio is in fact one long stream of digital data.

CD-Extra Support

CD-Extra is a format that allows for the writing of both audio and data on a single 
CD, just like Mixed Mode CDs. When writing an audio CD, you can prepare it for 
CD-Extra support (also known as Enhanced CD or CD Plus).

The difference is that when Mixed Mode CDs are written with the audio placed on 
the last tracks of the CD, for CDs in the CD-Extra format the audio is contained in 
the first tracks of the CD, and the data follows subsequently.

All features of the Red Book audio CD are possible with CD-Extra, unlike with Mixed 
Mode CDs. After an audio CD has been written with CD-Extra support, the data can 
be added to the CD in a separate session, by creating and writing a Data CD 
Project.

NOTE

Some computer CD drives may not recognize CDs in the CD-Extra format.
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Types of Events on an Audio CD

There are three types of events that can be used to specify various sections of audio 
on the CD.

About Frames, Positions, Small Frames, and Bits

The data on an audio CD is divided into frames.

A frame consists of 588 stereo samples. 75 frames make up one second of audio. 
This is because 75 x 588 = 44100, and since the sampling frequency of the CD 
format is 44100 Hz (samples per second), this equals one second of audio. When 
you specify positions on the CD, in WaveLab, you do it in the format mm:ss:ff 
(minutes:seconds:frames). The frame values go from 0 to 74, since there are 75 
frames to a second.

Technically, there is no way to specify something smaller than a frame on a CD. One 
effect of this is that if the sample length of a track on the CD does not equal a 
perfect number of frames, some blank audio must be added at the end. Another 
effect of this is that when you play the CD, you can never locate to anything closer 
than a frame. If you need some data in the middle of a frame, you still have to read 
the whole frame. Again, this is unlike a hard disk, where you can retrieve any byte 
on the disk, without reading the surrounding data.

But frames are not the smallest block of data on a CD. There is also something 
called “small frames”. A small frame is a container of 588 bits. 98 small frames 
together make up one regular frame. In each small frame there is only room for six 
stereo samples, which means that a lot of space is left for data other than the actual 
audio. There is information for encoding, laser synchronization, error correction, and 
the PQ data to indentify the track boundaries. This PQ data is of major importance 
to anyone who wants to create their own CD, and handled effortless in WaveLab.

Event Description

Track start There can be up to 99 tracks on one CD. Each is identified by its 
start point only.

Track sub-index On advanced CD players, a track can be divided into sub-indexes 
(sometimes called only indexes). These are used to identify 
important positions within a track. There can be 98 sub-indexes in 
each track. However, since it is difficult and time-consuming to 
search for and locate to a sub-index, many CD players ignore this 
information.

Pause A pause appears before each track. Pauses can be of variable 
lengths. Some CD players indicate the pauses between tracks on 
their displays.
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PQ Codes Handling

The PQ codes convey information about track start, sub-indexes, and pauses.

However, when creating a CD there are a number of rules you must take into 
account. For example, there should be some silent frames before each track, 
sub-indexes should be slightly early, there should be pauses at the beginning and 
end of the entire CD, etc.

When creating CDs from an audio montage, these rules and settings are handled 
by the CD Wizard. If you do not change these settings, you will get default values 
that ensure your CD will work properly. However, you can still adjust the PQ codes 
to your liking. We recommend to leave the settings as they are.

WaveLab only exposes intuitive CD markers and automatically generates the 
corresponding PQ codes to be written to CD.

ISRC Codes

International Standard Recording Code (ISRC) is an identification that is only used 
on CDs intended for commercial distribution. WaveLaballows you to specify an 
ISRC code for each audio track. These codes are provided by your publisher or 
clients.

The ISRC code is structured as follows:

• Country Code (2 ASCII characters)

• Owner Code (3 ASCII characters or digits)

• Recording Year (2 digits or ASCII characters)

• Serial Number (5 digits or ASCII characters)

The groups of characters are often presented with hyphens to make them easier to 
read, but hyphens are not part of the code.

UPC/EAN Codes

UPC/EAN code - the Universal Product Code/European Article Number, is a 
catalog number for an item (such as a CD) intended for commercial distribution. On 
a CD, the code is also called the Media Catalog Number and there is one such code 
per disc. These codes are provided by your publisher or clients.

UPC is a 12-digit barcode widely used in the USA and Canada. EAN-13 is a 
13-digit barcoding standard (12 + a checksum digit) defined by the GS1 standards 
organization. EAN is now renamed as International Article Number, but the 
abbreviation has been retained.
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Pre-Emphasis

CD pre-emphasis refers to process designed to increase, within a band of 
frequencies, the magnitude of some (usually higher) frequencies compared to the 
magnitude of other (usually lower) frequencies in order to improve the overall 
signal-to-noise ratio by lowering the frequencies during reproduction.

Pre-emphasis is commonly used in telecommunications, digital audio recording, 
record cutting and in FM broadcasting transmissions. The presence of 
pre-emphasis on a track is sometimes indicated by a tick in the  column on the 
Import Audio CD dialog.

Disc-At-Once - Writing CD-Rs for Duplication Into Real CDs

WaveLab only writes audio CDs in Disc-at-Once mode.

• If you want to create a CD-R to use as a master for a real CD production, you 
must write the CD-R in Disc-At-Once mode. In this mode, the entire disc is 
written in one pass. There are other ways of writing a CD, namely 
Track-At-Once and Multi-Session. If you use these writing formats, the link 
blocks created to link the various recording passes together will be 
recognized as uncorrectable errors when you try to master from the CD-R. 
These links can also result in clicks when playing back the CD.

• Disc-At-Once mode provides more flexibility when specifying pause lengths 
between tracks.

• Disc-At-Once is the only mode that supports sub-indexes.

Writing On The Fly vs. CD Images

WaveLab writes a CD on the fly, that is, it does not create a CD image before 
writing. This method makes writing CDs/DVDs faster and requires less disc space. 
However, you can also create an image prior to writing a CD/DVD.
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Spectrum Editing

Spectrum editing allows you to edit and process individual frequency ranges 
instead of the full frequency spectrum.

There are two main operational modes:

• Surgical processing (offline processing) is intended for audio restoration 
purposes applied to short time ranges.

• Master Section processing allows you to process a specific frequency range 
via the Master Section.

Both modes operate on a spectrum region, which is set using the Spectrum 
selection tool. The region selection defines a time and a specific frequency range. 
This allows you to edit and process audio both in the time domain and in a specific 
frequency domain.

Spectrum editing can perform many different types of processing. Although it is 
developed for audio restoration, it can also be used for artistic or special effects.

Spectrum editing comprises the following steps:

• Switching the wave window to spectrum display mode.

• Defining the region that you want to edit.

• Editing the region in the Spectrum Editor by applying filter operations, by 
copying regions, or by sending it to the Master Section to apply effects.

Spectrum editing can only be performed when the Spectrum mode is selected.

Spectrum Display

The spectrum display in the wave window shows the frequency spectrum in relation 
to time.

To see the spectrum view of the audio file in the Audio Files workspace, click the 
Spectrum tab below the waveform display.
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To see the spectrum view of the audio file and activate the spectrum editing mode, 
click the Spectrum selection tool.

Each vertical line represents the frequency spectrum at a particular time position.

• Low frequencies are shown at the bottom of the display, and high frequencies 
at the top.

• In the Spectrogram options dialog, you can define how to represent the 
spectrum. The spectrum can be represented in color, or in black and white. In 
color mode, frequencies with loud volume intensities are shown in red, and 
soft frequencies in dark purple.

• The vertical ruler on the left shows the frequency range in Hz.

• The status bar shows the time/frequency position of the mouse cursor.

• If you point the mouse cursor at a defined region, a tooltip appears showing 
the frequency range and the time range for the current region.

NOTE

The spectrum display is useful for audio restoration purposes using the editing and 
processing procedures in the Spectrum Editor. These are usually applied to very 
short time segments in an audio file. For standard editing procedures, use the wave 
display.

RELATED LINKS

Spectrogram Options on page 123
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Surgical Processing

Surgical processing can be used to process short regions up to 30 seconds offline. 
This type of processing is mainly used to reduce, remove, or replace unwanted 
sound artifacts in the audio material with great precision.

For example, this can be useful to replace a part of a live recording that contains an 
unwanted noise such as a mobile phone ring tone, with a copy of a similar region of 
the spectrum that contains a clean signal.

NOTE

In general, the spectral copy/paste combination gives the best results, if that the 
source and destination regions are properly chosen.

As with all Spectrum editor operations, you first have to define a time/frequency 
region. Once a region has been set, you can select one of the following Surgical 
processing modes:

• Filtering operations allow you to filter the selected region in various ways.

• Copy operations allow you to copy the spectrum region and apply it to 
another region.

Filtering Individual Frequencies

Filtering individual frequencies is useful for audio restoration purposes.

PREREQUISITE 

Select the Spectrum selection tool and define the region to process. The selected 
region must not exceed 30 seconds.

PROCEDURE

1. In the Spectrum Editor window, click the Surgery button.

2. In the Processing of the selection section, select a processing type.

3. In the Filter settings section, make the filter settings that you want to use.

4. Set up the Crossfade time of processed audio parameter.

5. Click Apply.
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Spectrum Editing by Copying Regions

You can edit the spectrum of an audio file by copying a defined region to another 
region. The crossfade times and the filter settings have an effect here, because the 
audio is copied and crossfaded both in the time domain and in the frequency 
domain.

PREREQUISITE 

Select the Spectrum selection tool to switch the wave window to spectrum 
editing. In the Spectrum Editor window, click the Surgery button.

Spectrum editing by copying regions is useful for removing unwanted sounds in the 
audio material. You first define a source region and a target region. Then you copy 
the audio from the source region to the target region.

PROCEDURE

1. In the Audio Files workspace, use the Spectrum selection tool to select the 
region that you want to use as source region.

2. In the Spectrum Editor window, click Define selection as SOURCE.

3. Click the source region to select it, then press [Shift] to preserve the 
frequency range or [Ctrl]/[Command]-[Shift] to preserve the time range, and 
click and drag the selection to the region that you want to edit.

4. With the region you want to edit selected, click Define selection as 
TARGET.

5. In the Copy audio from one region to another section, open the pop-up 
menu and select one of the options.
• Selecting Copy exactly copies the defined source region exactly.

• Selecting Copy ambience copies an average of the frequencies of the source 
region, blurring the original dynamics and pitches, and making the copied 
region appear less identifiable.

6. In the Filter settings section, set a high Steepness value, or activate the 
Infinite option.

7. Click Copy SOURCE to TARGET.

8. Play back the audio file to hear the result.

Rules and Tips for Spectrum Editing by Copy Operations

Copy operations in the Spectrum Editor are mainly intended for audio restoration 
purposes. You define a source region and a destination region, then you copy audio 
from the source region to the destination region.

• The source and the target region must have the same length and the same 
frequency range.

• The regions have to be part of the same audio file.
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• Setting the source region just before or after the sound to remove can 
produce very accurate results, as this region probably contains a similar 
frequency spectrum as the target region containing the artifact.

• When copying between different frequency regions, pitch shifting occurs. 
Using the Move upwards/downwards 1 oct options may produce better 
results.

• In the low to low-mid frequency range, the masking or removal of unwanted 
artifacts is difficult to achieve without audible interruptions. Finding a limited 
frequency area is important to not interrupt the flow of the audio when 
removing artifacts.

Master Section Processing

Master Section Processing allows you to process a specific frequency range via the 
Master Section.

The selected or non-selected regions of the spectrum can be processed differently. 
You can also use a number of filters (Bandpass/Low-pass/High-pass) to further 
refine the range of frequencies to be affected by any Master Section effects.

The signal is split so that one part (selected spectrum or non-selected spectrum) is 
sent to the plug-ins, while the other part can be mixed with this processed signal, 
after the Master Section output.

The arrows show the three possible routing options for the spectrum region 
selection. The non-selected spectrum has the same options, although it cannot use 
the same routing destination as the region selection.

The following operations can be performed:
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• Processed separately by the Master Section plug-ins. The non-selected 
spectrum can either be bypassed or sent to the Master Section.

• Bypassed. This removes the selected spectrum region from the audio file. The 
non-selected spectrum can either be routed to the Master Section input or 
the Master Section output.

• Sent to Master Section output. The non-selected spectrum can be bypassed 
or sent to the Master Section input. In the latter case, it is mixed with the 
selected spectrum region at the Master Section output.

Applying Master Section Processing

PROCEDURE

1. In the Audio Files workspace, select the Spectrum selection tool and define 
a region.

2. In the Spectrum Editor window, activate Master Section.

3. In the Filter settings, select a filter and specify a Steepness.

4. Specify a crossfade time for the processed audio.

5. Select how to process the selected region.

6. Click Render to apply the settings.

Spectrum Editor Window

The Spectrum Editor is an audio restoration and processing tool set that provides 
high quality linear-phase filters to process a frequency range selection.

In the Audio Files workspace, click the Spectrum selection icon to open the 
Spectrum Editor window.

The Spectrum Editor window provides two modes:

• The Surgery mode is intended for audio restoration purposes applied to short 
time ranges.

• The Master Section mode allows you to process an individual frequency 
range via the Master Section.

Filter and Crossfade Settings

The filter and crossfade settings are available in Surgery mode and in Master 
Section mode. The following options are available:
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Bandpass filter

Attenuates all frequencies outside the region equally.

Low-pass filter

Attenuates high frequencies in the region more strongly.

High-pass filter

Attenuates low frequencies in the region more strongly.

Steepness

Determines how quickly frequencies are attenuated. Steepness is expressed 
in dB per octave, with higher numbers indicating a steeper filter. The 
Steepness parameter creates a crossfade in the frequency domain between 
the processed and the unprocessed section. If the steepness value is low, the 
selected region contains much of the unprocessed signal near the frequency 
edges.

Infinite

Sets the filter steepness to an infinite number of dB per octave.

Crossfade time of processed audio

Sets the duration of the crossfade between the processed and the 
unprocessed signal.

Settings

Opens the Spectrum editing options dialog, where you can activate the 
following options:

• Show pop-up window about regions

• Maintain independent settings for each file

Pin button

If this option is activated, the Spectrum Editor window remains displayed 
when the Spectrum selection tool is not selected. Otherwise the window is 
hidden as soon as the Time selection tool is selected, and none of the 
opened audio files is associated with the Spectrum Editor.
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Spectrum Editor Window - Surgery Mode

The Surgery mode of the Spectrum Editor allows you to process short regions up 
to 30 seconds offline.

In the Audio Files workspace, select Workspace > Specific tool windows > 
Spectrum Editor, and activate Surgery.

Selection Options

Edit

Opens the Audio Range dialog that allows you to accurately define a 
selection.

Deselect channel with cursor

When you edit a stereo file, this option deselects the channel where the 
cursor is located.

Change channel

When you have defined a region in only one channel in a stereo file, this option 
moves the selection to the other channel.

Zoom

Zooms in on the selected region.

Select a single channel

Generally, when you edit a stereo file and make a selection on one channel, 
the selection is automatically applied to the other channel. Activating this 
option allows you to unlink the channels, and edit a single channel.

Select till top/bottom

Extends the selection to the top/bottom of the frequency axis.

Select till start/end of file

Extends the selection to the beginning/end of the audio file.

Select all file length

Extends the selection to the entire file.
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Move backwards

Moves the selection to the left so that it ends at its previous start position on 
the time axis.

Move forwards

Moves the selection to the right so that it starts at its previous end position on 
the time axis.

Move upwards

Moves the selection up on the frequency axis so that its lower edge is placed 
at the previous upper edge.

Move downwards

Moves the selection down on the frequency axis so that its upper edge is 
placed at the previous lower edge.

Move upwards/downwards 1 oct

Moves the selection up/down by one octave on the frequency axis.

Define selection as source

Defines the current selection as source region for copy operations.

Define source at cursor

Copies the selection rectangle to the current cursor position, and defines it 
as source region for copy operations. This ensures that the selection to copy 
and the selected region that you want to edit have the same size.

Define selection as target

Defines the current selection as the target region for copy operations.

Define target at cursor

Copies the selection rectangle to the current cursor position, and defines it 
as target region for copy operations. This ensures that the selection to copy 
and the selected region that you want to edit have the same size.

Clear all

Clears all selections.

Copy Operations

Copy exactly

Copies the defined source region exactly.

Copy ambience

Copies an average of the frequencies of the source region, blurring the 
original dynamics and pitches, and making the copied region appear less 
identifiable. Depending on the audio material, this may avoid a repetition 
effect.

Copy from cursor to replace selection

Copies a region of the size of the current selection starting at the cursor, and 
replaces the selection by it.
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Copy from cursor to replace target

Copies a region of the size of the defined target region starting at the cursor, 
and replaces the target region by it.

Copy source to target

Copies the defined source region to the defined target region.

Copy source to cursor

Copies the defined source region to the current cursor position.

Processing Options

Crossfade times and filter settings are taken account for these options.

Gain

Determines the level of the filter processing. Negative gain settings attenuate 
the level, positive gain settings boost the level.

Damp

Attenuates or boosts the level of the selected region according to the set 
gain.

Blur peaks

Attenuates or boosts the level of the frequencies with the highest level in the 
selection according to the set gain. If the gain is set to a negative value, these 
frequencies are blurred. This is useful for removing acoustic feedback, for 
example.

Dispersion

Blurs the dynamics and pitches of the selected region without changing the 
frequency content.

Fade-Out

Gradually filters out the frequencies in the region along the time axis, creating 
a fade-out.

Fade-In

Gradually lets pass frequencies in the region along the time axis, creating a 
fade-in.

Fade out then in

Lets the frequencies fade out and fade in again.

Fade in then out

Lets the frequencies fade in and fade out again.

Apply

Applies the selected processing mode.
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Spectrum Editor Window - Master Section Mode

The Master Section mode of the Spectrum Editor allows you to process the 
selected spectral region through the Master Section.

In the Audio Files workspace, select Workspace > Specific tool windows > 
Spectrum Editor, and activate Master Section.

Master Section Mode Options

In Master Section mode, you can decide whether you want to send the selected 
region or the non-selected region to the Master Section for processing. The 
following options are available for both the selected region and the non-selected 
region:

Bypass

Mutes the selected/non-selected region.

Send to Master Section input

Sends the selected/non-selected region to the Master Section, allowing you 
to apply plug-ins to it.

Send to Master Section output (pre-master)

Sends the selected/non-selected region directly to the Master Section output 
without plug-in processing. Only the post-master plug-in is applied.

Render

Processes the selected/non-selected region according to the settings in the 
Spectrum Editor.



Spectrum Editing
Defining a Region for Spectrum Editing

500

Spectrum Editing Options Dialog

In this dialog, you can make settings for the spectrum editing.

In the Audio Files workspace, select Workspace > Specific tool windows > 
Spectrum Editor, and select Settings.

Show pop-up window about regions

If this option is activated, a pop-up window displays details when you position 
the mouse cursor over a region or adjust a region.

Maintain independent settings for each file

If this option is activated, the settings are saved when you switch to another 
audio file and restored when you switch back to the original file.

Defining a Region for Spectrum Editing

All Spectrum editing functions are applied to a selected region, or from a selection 
region if Master Section processing is used. A region set in the Spectrum editor 
contains a time range and a frequency range.

PREREQUISITE 

Zoom in on the time range where you want to perform spectrum editing.

PROCEDURE

1. In the Audio Files workspace, on the toolbar, click the Spectrum selection 
tool.

2. Click in the spectrum display and drag a rectangle around the region that you 
want to edit.
When defining a region in a stereo file, a corresponding region is automatically 
created in the other channel.
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3. Optional: Click and drag the defined region to move it.
Pressing [Shift] restricts to horizontal movement, to ensure that the frequency range 
is retained. Pressing [Ctrl]/[Command]-[Shift] restricts to vertical movement, to 
ensure that the selected time range is retained.

4. Optional: Move the cursor over a region edge, and click and drag to resize the 
defined region.

AFTER COMPLETING THIS TASK 

Process the selected region by means of the Spectrum Editor window.

Processing Frequency Ranges via the Master Section

The Spectrum Editor allows for frequency-selective processing via the Master 
Section.

PREREQUISITE 

Select the Spectrum selection tool, and define the region to process. The selected 
region must be longer than one second.

You can route the frequency spectrum of the selected region to the Master Section 
where it is processed separately from the non-selected frequency spectrum, or vice 
versa. At the Master Section output, the processed region is mixed with the 
non-processed signal.

PROCEDURE

1. In the Spectrum Editor window, click the Master Section button.

2. In the Filter settings section, select a filter type from the pop-up menu.

3. Set the Steepness value and the Crossfade time of processed audio value.
The Crossfade time of processed audio value is needed for rendering.

4. In the Routing of selected spectral region and Routing of non-selected 
spectral region sections, make settings to define where to route the selected 
frequency range and the non-selected frequency range.

5. Open the Master Section and set up the plug-ins that you want to apply to 
the selected/non-selected frequency range.
Do not use any plug-ins that change the number of samples.

6. Click Render to apply the Master Section settings to the selected region.
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Auto Split

The auto split function allows you to automatically split audio files or clips in an audio 
montage according to specific rules.

Auto split can create new audio files or audio montage clips referencing the original 
files. The new audio files or clips can be automatically named and/or numbered.

Auto Split in Audio Files

You can use the auto split function in many situations, for example, to cut a recorded 
audio file into single takes, to cut a drum loop into its individual drum hit samples, to 
output individual tracks from an album master file, or to silence the regions between 
audio information in an instrumental take.

You can use auto split to split audio files at:

• Markers

• Regions containing silences

• Beats using beat detection

• Specific intervals

• Specific regions derived from a text file
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Auto Split Dialog in the Audio Files Workspace

In this dialog, you can set up auto split rules for audio files.

In the Audio Files workspace, select Tools > Auto Split.

The Auto Split dialog contains a series of pages, with different parameters and 
options depending on the selected auto split method.

On the first page, you specify which files to process with auto split. You have the 
following options:

• The audio file in the active window.

• All audio files are in a specified folder.

• The audio files derived from a file list.

On the second page, you select the type of splitting that you want to perform. The 
following types are available:

Split according to markers

Splits the files at specific marker positions. If you select this option, you can 
specify the marker type that will be used for the splitting on the next page.

Split at specific intervals

Splits the files at specific time intervals. If you select this option, you can 
specify the time interval, that is, the duration of each region, on the next page.

Split between silences

Splits the files so that each non-silent section becomes a separate region. If 
you select this option, you can specify the minimum region duration, the 
minimum duration of a silent section, and the signal level that should be 
considered as silence on the next page.
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Split at beats

Detects beats in the audio material and splits the files at each beat. If you 
select this option, you can specify the sensitivity of the beat detection, the 
minimum beat level to create a split point, and the minimum region duration 
on the next page.

Cut head and tail

Removes sections from the start and/or end of the files, silent sections or 
specified sections.

Learn regions from a text file

Splits an audio file according to a description of regions stored in a text file.

Convert stereo files to two mono files

Splits stereo files into two mono files.

The third page of the dialog varies according to the selected split method. The 
following pages of the dialog are common to all types of auto split, except that 
certain options are grayed out in the dialogs if they are not applicable.

On the fourth page, you specify what to do with the regions created by auto split. 
You can save the regions as separate files or create clips and add these to a new 
or existing audio montage. You can also select to create markers at the split points 
instead of splitting the files.

On the fifth page, you can insert silence at the start and/or end of the files, or 
automatically assign root key note numbers to the files.

On the last page, you specify how to name the files, clips, or markers created by 
auto split. Options include name as source file name plus a key name or number, or 
name as specified in a text file. To open a saved naming scheme file, click Open, 
select the text file that you want to open, and click Open.

The Finish button is available from all pages. If you are sure about your settings, you 
can click Finish without having to go to all pages. For example, when you are using 
a preset and you know that you do not want to make changes on the last pages, you 
can click Finish earlier.
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Learn Regions From Text File

You can split an audio file according to a description of regions stored in a text file.

Each region must be described by a name, a start position, and an end position (or 
region length). The text file must be placed in the same folder as the audio file, with 
the same name, and with the extension that you specify in the WaveLabdialog (for 
example, “txt” or “xml”).

You can use four tags to specify the regions.

• Region name

• Start

• End

• Length

These tags can be customized in the Auto Split dialog. The text file must specify 
either the “End” or the “Length” parameter.

Each parameter must be located on a separate text line.

The time values must be in samples or in timecode format.

• Hours:minutes:seconds:samples

You can use three text formats.

• “Tag”=“Value”: The tag comes first, then “=”, then the value.

• “Tag” Tabulation “Value”: The tag comes first, then a tabulation, then the 
value.

• XML style: The tag comes first, surrounded by < and >, then the value, then 
the tag surrounded by </ and >.

Text files must be in UTF-8 format.

Example for Using Auto Split for Audio Files

You can split a long recording into samples. This is useful if you are working with a 
sampler, for example, HALion.

PROCEDURE

1. In the Audio Files workspace, select Tools > Auto Split.

2. Select Audio File in active window, and click Next.

3. Select Split at silences, and click Next.

4. Set up the page according to the audio file, and click Next.
Adjust the first setting according to the length of the shortest recorded note, the 
second setting according to the shortest period of silence between two notes, and 
the third setting according to the level of the silence between the notes.

5. Select Save as separate files, specify the format and location for the new 
files, and click Next.
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6. On the Options page, activate Assign Key, select Detect pitch, and click 
Next.
This way, the correct key is assigned to each sample. If you activate Quantize to 
nearest semitone, WaveLabsets the key according to the closest semitone. If not, 
the Detune setting in the sample may also be adjusted, according to any pitch 
deviations.

7. Select the naming option As audio file name + key, and click Finish.

RESULT 

The file is split according to your settings, and creates new files in the specified 
location.

Auto Split in Audio Montages

You can use the auto split function to split the focused clip. You can use the auto 
split function in many situations, for example, to cut single clip of a recording into 
single takes, to cut a drum loop into its individual drum hit samples, to output 
individual tracks from an album master file, or to silence the regions between audio 
information in an instrumental take.

During the analysis, only the audio files of the audio montage are taken into account. 
Envelopes and effects are ignored.

You can use auto split to split the focused clip at:

• Markers

• Specific intervals

• Between silences

• Beats
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Auto Split Dialog in the Audio Montage Workspace

In this dialog, you can set up auto split rules for audio montages.

In the Audio Montage workspace, in the Focused clip window, on the Edit pane, 
select Auto Split.

The Auto Split dialog contains a series of pages, with different parameters and 
options depending on the selected auto split method.

On the first page, you select the target for the auto split.

On the second page, you select the type of splitting. The following types are 
available:

Split according to markers

Splits the files at specific marker positions. If you select this option, you can 
specify the marker type that will be used for the splitting on the next page.

Split at specific intervals

Splits the files at specific time intervals. If you select this option, you can 
specify the time interval, that is, the duration of each region, on the next page.

Split at silences

Splits the files so that each non-silent section becomes a separate region. If 
you select this option, you can specify the minimum region duration, the 
minimum duration of a silent section, and the signal level that should be 
considered as silence on the next page.

Split at beats

Detects beats in the audio material and splits the files at each beat. If you 
select this option, you can specify the sensitivity of the beat detection, the 
minimum beat level to create a split point, and the minimum region duration 
on the next page.
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Cut head and tail

Removes sections from the start and/or end of the files, silent sections or 
specified sections.

The third page of the dialog varies according to the selected split method. The 
following pages of the dialog are common to all types of auto split, except that 
certain options are grayed out if they are not applicable.

On the fourth page, you specify what to do with the regions created by auto split. 
For example, you can choose to split the regions or cut out silent parts. You can also 
select to not split the files but to create markers at the split points instead.

On the last page, you specify how to name the clips created by auto split. Options 
include name as marker names, name as clip name, or name as specified in a text 
file. To save this text file, select Save, enter a name and location, and select Save. 
To open a saved naming scheme file, click Open, select the text file that you want 
to open, and click Open.

The Finish button is available from all pages. If you are sure about your settings, you 
can click Finish without having to go to all pages. For example, when you are using 
a preset and you know that you do not want to make changes on the last pages, you 
can click Finish earlier.
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Loops

This chapter describes various operations that are related to looping. Looping is 
used to simulate the infinite or at least very long sustain of many instrumental 
sounds. WaveLab has tools for creating smooth loops, even for the most complex 
types of sounds.

Basic Looping

Looping a sound allows you to repeat a section of the sample indefinitely in order 
to create a sustain of unlimited length. Instrumental sounds in samplers rely on 
looping. An example of this would be an organ sound.

Without looping, you can only play audio as long as the original recording. With 
looping, audio can be of any length. In WaveLab, loops are defined by loop markers. 
Loop markers are added, moved, and edited such as any other type of marker.

To ensure that you find a good loop point note the following:

• There are only two types of loops: very long and very short loops. Loops of 
intermediate lengths usually do not provide good results.

• A long loop sounds the most natural and should be used whenever possible. 
However, if the sound does not have a stable section in the middle (an even 
sustain part), it might be hard to find a good long loop. For example, a piano 
note which decays continuously is hard to loop since the start point of the 
loop is louder than the end point. A flute is much simpler, because the sound 
in the sustain section is very stable.

• Very short loops that cover only a few cycles or periods can almost always be 
found but may sound static and unnatural.

• A loop should start shortly after the attack portion, that is, when the sound has 
stabilized to a sustaining note.

• If you set up a long loop, it should end as late as possible but before the sound 
starts decaying to silence.

• Short loops are difficult to position within the sound. Try to position them near 
the end.

NOTE

More information about looping in general, and the exact capabilities of your 
sampler in particular can be found in the manual of the sampler.
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Creating a Basic Loop

PROCEDURE

1. In the Audio Files workspace, select the audio section that you want to loop.

2. Right-click the top of the ruler, and select Create loop from selection.

3. On the Transport bar, activate Loop.

4. Play back the loop and adjust the position of the markers to change the loop.

AFTER COMPLETING THIS TASK 

Dragging markers to various positions does not necessarily lead to good loops. 
Most often, you hear a click or an abrupt change in timbre at the turning point.

We suggest you only use this method for setting up the basic length of the loop and 
then use the Loop Tweaker and Loop Tone Uniformizer for optimizing.

About Refining Loops

The Loop Tweaker tool allows you to refine a region of audio for seamless looping. 
Use the Loop Tweaker to tweak an existing loop selection so that it loops perfectly 
or use it to create a loop from material which does not naturally repeat.

You can automatically detect loop points by scanning the area between two loop 
markers. You can specify parameters that determine how accurate the program 
should be when suggesting loop points.

If the automatic search for loop points is not successful, you can process the 
waveform to allow for smoother loops by crossfading areas of the waveform close 
to the loop start and end points.

To use the Loop Tweaker, you must first define a loop using a pair of loop markers.

Loop Points Adjustment Tab

Use the Loop Points Adjustments tab in the Loop Tweaker dialog to manually 
refine a loop selection by dragging on the waveform left/right or by using the 
automatic search buttons to find the nearest good loop point. The aim is to align the 
waveforms so that they meet at a zero-crossing point where the waveforms match 
as closely as possible. When you adjust your loop start and end points within the 
dialog, the start and end loop markers in the main waveform window adjust 
accordingly. Note that this movement may or may not be visible depending on how 
much you move the markers and on the zoom factor that you have selected.

It may be helpful to loop the transport during playback so that you can hear the 
difference when you adjust the loop markers within the dialog. Note that if you are 
not using a crossfade or post-crossfade, you do not need to click Apply when 
tweaking loop points. You can also leave this dialog window open and manually 
adjust the position of the markers in the main waveform windows.
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Crossfade Tab

This tab allows you to apply a crossfade of the end of a loop with a copy of the 
beginning of the loop. This can be useful to smooth the transition between the end 
of a loop and its beginning, especially when you use material that does not naturally 
loop. Use the envelope drag points or value sliders to adjust the crossfade 
envelope. Click Apply to process the crossfade.

Post-Crossfade Tab

This tab allows you to cross fade the loop back into the audio behind the end of the 
loop by mixing a copy of the loop back into the audio. Use the envelope drag points 
or value sliders to adjust the crossfade envelope. Click Apply to process the post 
crossfade.

Refining Loops

You can refine loops using the Loop Tweaker tool.

PREREQUISITE 

Set up a basic loop.

PROCEDURE

1. In the Audio Files workspace, select the loop that you want to refine by 
clicking between its loop start and loop end marker.

2. Select Process > Loop Tweaker.

3. Refine your loop using the settings in the Loop Tweaker tool.

4. Click Apply.

Moving Loop Points Manually

If your loop still has glitches or bumps at the turning points, you can use the Loop 
Tweaker tool to move the points in small steps to remove the glitch.

This is similar to moving the loop points in the wave display, but with a visual 
feedback to facilitate finding good loop points.

There are two ways of moving the loop points manually on the Loop points 
adjustment tab in the Loop Tweaker dialog:

• Drag the waveform to the left and right.

• Use the green arrows below the waveform to nudge the audio to the left and 
right. Each click moves the loop point by a single sample.

The following applies when moving the loop points manually:
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• To move the end point to a later or earlier position, move the left part of the 
display.

• To move the start point to a later or earlier position, move the right part of the 
display.

• To move the start and end points simultaneously, activate Link start and end 
points. This way, when adjusting a loop point, the length of the loop stays the 
same, but the entire loop is moved.

• You can also adjust the loop markers in the wave window.

Automatically Detect Good Loop Points

The Loop Tweaker tool can automatically search for good loop points.

PROCEDURE

1. In the Audio Files workspace, select the loop that you want to refine by 
clicking between its loop start and loop end marker.

2. Select Process > Loop Tweaker.

3. On the Loop points adjustment tab, make sure that Link start and end 
points is deactivated.

4. In the Automatic search section, specify the Aimed correspondence and 
the Search accuracy.

5. Click the yellow arrow buttons to start the automatic search for a good loop 
point.
WaveLab scans from the current point forwards or backwards, until it finds a point 
that matches. You can stop at any time by clicking the right mouse button. The 
program then jumps back to the best found match.

6. Check the loop by playing it back.

7. Optional: If you think there might be a better loop point, continue with the 
search.

Temporarily Storing Loop Points

Temporarily saving and restoring loop points allows you to quickly compare different 
loop settings.

PREREQUISITE 

Set up a basic loop and open the Loop Tweaker tool.

NOTE

• There are five slots for temporarily saving loop point settings per wave window 
and montage window, not one per set of loop points. This means that if you 
have several sets of loops in your file, you must be careful to not recall the 
wrong set.
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• Only loop positions are temporarily saved.

PROCEDURE

1. On the Loop points adjustment tab, in the Temporary memories section, 
select M.

2. Select one of the five memory slots.

About Crossfades in Loops

Crossfading is useful to smooth the transition between the end of a loop and its 
beginning, especially when using material that does not naturally loop.

Sometimes it is impossible to find a loop that does not cause any glitches. This is 
especially true for stereo material, where you might be able to find a perfect 
candidate for only one channel.

In this case crossfading smears the material around the end loop point so that it 
loops perfectly. This is achieved by mixing material from before the loop start with 
material that is located before the loop end.

Note that this technique alters the waveform and therefore changes the sound. 
However, normally you can find settings that minimize this problem.

Creating a Crossfade

PROCEDURE

1. In the Audio Files workspace, create a good a loop as you can.

2. Select Process > Loop Tweaker.

3. Decide if you want to create a crossfade or a post-crossfade:
• If you want to create a crossfade, click the Crossfade tab.

• If you want to create a post-crossfade, click the Post-Crossfade tab.

4. Make sure that Crossfade audio at end of loop with audio before loop 
(Crossfade tab) or Crossfade audio after loop with audio of loop start 
(Post-Crossfade tab) is activated.

5. Decide on a length for the crossfade either by dragging the length handle or 
by adjusting the Length value below the graph.

6. Decide on a crossfade shape by dragging the shape handle or by adjusting 
the Shape (from equal gain to equal power) value.
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7. Click Apply.
The sound is processed. Each time that you click Apply, the previous loop process is 
automatically undone. This allows you to try out many settings quickly.

NOTE

Do not move the loop points after you have performed a crossfade. The 
waveform has been processed specifically for the current loop settings.

AFTER COMPLETING THIS TASK 

• You can check the crossfade visually by opening the Loop points 
adjustment tab and activating Display processed audio. When this is 
activated, the display shows a preview of the crossfaded waveform. When the 
option is deactivated, the display shows the waveform original. Switching 
back and forth allows you to compare the two.

About Post-Crossfades

Post-crossfading means crossfading the loop back into the audio after the end of 
the loop so that there is not glitch when playback continues after the loop. This is 
done by mixing a copy of the loop back into the audio.

The post-crossfade can be set up on the Post-Crossfade tab of the Loop Tweaker 
dialog.

The post-crossfade analyzes the part of the waveform that occurs just after the loop 
start and processes a certain area that begins at the end of the loop. The length 
parameter adjusts the size of this area. Everything else is identical with regular 
crossfading.

Loop Tweaker Dialog

This dialog allows you to adjust the loop start and end points, and crossfade the 
loop boundaries.

In the Audio Files workspace, select Process > Loop Tweaker.

The Loop Tweaker dialog consists of the following tabs:
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Loop Points Adjustment Tab

The top of this dialog shows the beginning and the end of the waveform between 
the loop markers. The bottom of this dialog offers the following options:

Loop End - Green Arrows

Move the loop end points to the left/right.

Loop End - Yellow Arrows

Invokes an automatic search for the nearest good loop point to the left/right 
of the loop end point and moves the end point to that position.

Loop Start - Green Arrows

Moves the loop start points to the left/right.

Loop Start - Yellow Arrows

Invokes an automatic search for the nearest good loop point to the left/right 
of the loop start point, and moves the start point to that position.

Stereo merge

If this option is activated for a stereo file, the two waveforms are overlayed, 
otherwise they are shown in two separate sections.

Overlap

If this option is activated, the waveforms of both halves are continued in the 
other half. This shows how the waveform looks like right before and after the 
loop.

Display processed audio

If this option is activated, the display shows a preview of the waveform after 
crossfading. If deactivated, you see what the waveform looks like without 
crossfading. This option only makes sense after you have set up a crossfade 
and clicked Apply.
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Automatic vertical zooming

If this option is activated, the vertical magnification is adjusted so that the 
waveform always fills the entire display vertically.

Zoom

Sets the zoom factor.

Current correspondence

Indicates how well the waveforms near the loop points match one another. 
The left value estimates the similarity across several wave cycles, while the 
right value estimates the similarity of the few samples near the loop points. 
The higher the values, the better the match.

Aimed correspondence (0-1000)

Sets up the automatic search for good loop points. This defines how well the 
found section must resemble the section to which it is compared, in order to 
be considered a match. The higher the value, the more precise the 
resemblance must be. A value of 1000 most likely fails, since it requires a 
100 % perfect match.

Search accuracy

Determines how many samples should be taken into account by the auto-find 
analysis. Higher values result in greater accuracy, but also in longer 
processing times.

Link start and end points

If this option is activated, both the start and end points move simultaneously 
when you adjust the loop points manually. That is, the loop length is exactly 
the same, but the entire loop moves.

Temporary memories

Allows you to save up to five different sets of loop points which you can later 
recall. This allows you to try out several different loop settings. To store a set, 
click this button, then on one of the buttons 1-5.
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Crossfade Tab

Crossfade audio at end of loop with audio before loop

To enable crossfading, activate this checkbox. The crossfade is applied when 
you click Apply.

Length

Determines the section length of the audio file to be used in the crossfade. 
Generally, you want the crossfade to be as short as possible, with an 
acceptable result:

• Using a long crossfade smoothens the loop. However, more of the 
waveform is processed, which changes its character.

• A shorter crossfade affects the sound less, but the loop is not as 
smooth.

Shape (from equal gain to equal power)

Determines the shape of the crossfade. Generally, use low values for simple 
sounds and high values for complex sounds.
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Post-Crossfade Tab

Crossfade audio after loop with audio of loop

To enable crossfading, activate this checkbox. The crossfade is applied when 
you click Apply.

Length

Determines the section length of the audio file to be used in the crossfade. 
Generally, you want the post-crossfade to be as short as possible, with an 
acceptable result:

• Using a long post-crossfade smoothens the loop. However, more of the 
waveform is processed, which changes its character.

• A shorter post-crossfade affects the sound less, but the loop is not as 
smooth.

Shape (from equal gain to equal power)

Determines the shape of the post-crossfade. Generally, use low values for 
simple sounds and high values for complex sounds.

About Looping Seemingly Unloopable Audio

Sounds that constantly decay in level or continuously change in timbre are difficult 
to loop. The Loop Tone Uniformizer allows you to create loops from sounds that 
seem unloopable.

The Loop Tone Uniformizer applies processing to the sound that evens out 
changes in level and timbral characteristics in order for a sound to loop properly. 
For example, this is useful for creating looped samples for a softsynth or hardware 
sampler.
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The Loop Tone Uniformizer includes a crossfade facility so that the original sound 
fades into the processed sections as playback approaches the loop start.

To use the Loop Tone Uniformizer, you must have a loop defined using a pair of 
loop markers. The original length of the loop is not changed.

Looping Seemingly Unloopable Audio

PROCEDURE

1. In the Audio Files workspace, set up a basic loop.

2. Select Process > Loop Tone Uniformizer.

3. Make sure that either Slice mixing or Chorus smoothing is activated and 
make the settings.

4. Optional: Open the Pre-Crossfade tab, and set up a crossfade.

5. Click Apply.
The sound is processed. Each time that you click Apply, the previous loop process is 
automatically undone. This allows you to try out many settings quickly.

NOTE

Do not move the loop points after you have performed a crossfade. The 
waveform has been processed specifically for the current loop settings.

AFTER COMPLETING THIS TASK 

After using the Loop Tone Uniformizer, the transition from the end of the loop to 
the end of the file is in many cases not very natural. This can be fixed by creating a 
post-crossfade using the Loop tweaker.

Loop Tone Uniformizer Dialog

This dialog allows you to create sounds that loop from audio that seems unloopable. 
These are normally sounds that constantly decay in level or continuously change in 
timbre.

In the Audio Files workspace, select Process > Loop Tone Uniformizer.

The Loop Tone Uniformizer dialog consists of the following tabs:
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Uniformizers Tab

This tab allows you to specify the methods that are used to even out the sound that 
you want to loop.

For slice mixing, you must experiment to see how many slices are needed. 
Generally, the more slices you use, the more natural the sound will be.

Slice Mixing

Cuts the loop in slices, which are then mixed together to uniformize the sound.

For slice mixing, you need to determine the number of slices. Only 
experimentation can tell how many slices are needed, but generally, the more 
slices you have, the more natural the sound (to a certain extent). However, the 
program puts a restriction on the number of slices, so that each one is never 
shorter than 20 ms.

For example, if you specify eight slices, the loop is cut up into eight sections 
of equal length. These sections are then overlapped and mixed together as 
one sound which is repeated eight times. This new piece of audio replaces all 
audio inside the loop in a smart way so that no harmonic cancelation due to 
phase offsets occurs.

Slice Mixing - Number of slices

The more slices you have, the more the sound changes.

Chorus smoothing

This processor uses a method known as phase vocoding to filter the 
harmonics. This method is recommended for looping ensemble and choir 
sounds and can drastically change the timbre.

Chorus smoothing - Timbre

Governs the amount by which the timbral characteristics of the sample should 
be evened out. The higher the value, the more pronounced the effect.

Chorus smoothing - Chorusing

Determines the depth of the chorus effect.
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Chorus smoothing - Enhance Warmth

Creates a smoother, warmer sounding effect.

Chorus smoothing - Stereo Expansion

Increases the width of the sample in the stereo sound image.

Pre-Crossfade Tab

This tab allows you to crossfade the end of the loop with the start of the newly 
processed section so that transition into the newly looped section is smoother 
during playback. Use the envelope drag points or value sliders to adjust the cross 
fade.

You need to use this feature since the Loop Tone Uniformizer itself changes the 
timbre only inside the loop. This means that the transition into the loop is not as 
smooth as expected unless you apply crossfading.

Crossfade audio before loop with audio of end of loop

Enables crossfading, which is applied when you click Apply.

Length

Determines the section length of the audio file to be used in the crossfade. 
Generally, you want the post-crossfade to be as short as possible, with an 
acceptable result:

• A long crossfade produces a smoother loop. However, more of the 
waveform is processed, which changes its character.

• A shorter crossfade affects the sound less, but the loop is not as 
smooth.

Shape (from equal gain to equal power)

Determines the shape of the crossfade. Generally, use low values for simple 
sounds and high values for complex sounds.
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About Sample Attributes

Sample attributes allow you to define settings for an audio sample before loading it 
into a hardware or software sampler.

Sample attributes do not process the sample, they just provide the file properties 
that the receiving sampler can use. This includes information about the pitch of the 
sample, which can be detected automatically, the key range that the sample should 
span, and the velocity range to occupy. For WAV and AIFF files, this information is 
stored in the header of the file. By default, there are no sample attributes in an audio 
file.

NOTE

Depending on your sampler and the protocol that you use for communicating, the 
sample attributes may not be supported.

Editing Sample Attributes

PROCEDURE

1. In the Audio Files workspace, open the Sample Attributes window.

2. In the Sample Attributes window, select Create.

3. Optional: If you want to automatically detect the pitch of an audio selection, 
select an audio range, and select Detect from audio selection.

4. Specify the sample attributes.

5. Save the audio file to store the sample attributes settings in the audio file.
The sample attribute is only saved in WAV and AIFF files.

Sample Attributes Window

In this window, you can create sample attributes for an audio sample.

In the Audio Files workspace, select Workspace > Specified tool windows > 
Sample Attributes.

Create/Remove

Creates/Removes sample attributes for the active audio file.
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Tune - Key

Specifies which key plays back the sound at its basic pitch.

Tune - Detune

Specifies whether the sample should be played back at a slightly different 
pitch. The range is ±50 % of a semitone, which translates into a quarter tone 
in each direction.

Detect from audio selection

Detects the pitch from an audio selection. Make sure that the audio selection 
contains a clearly defined pitch.

Key range - High/Low

Specifies the key range for the sample if the sample is part of a multi-sample 
key map.

Velocity range - High/Low

Specifies the velocity range for the sample if the sample is part of a 
multi-sample key map with velocity-switchable samples.
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Generating Signals

In WaveLab, you can generate synthesized sounds and DTMF or MF tones.

Signal Generator

The Signal Generator allows you to generate complex synthesized sounds in mono 
or stereo.

You can layer different waveform generators together and if outputting a stereo file, 
adjust different settings for both the left and right channels. There are a multitude of 
settings to adjust the character (Source tab), frequency (Frequency tab), and 
amplitude (Level tab) of the generated signals.

Use the Signal Generator for:

• Testing the specifications of audio equipment.

• Measurements of various kinds, including calibrating tape recorders.

• Testing signal processing methods.

• Educational purposes.

The Signal Generator is based on a waveform generator that can generate a large 
number of basic waveforms, such as sine, saw, pulse, and various types of noise.

The Signal Generator has a multitude of settings for character (Source tab), 
frequency (Frequency tab), and amplitude (Level tab).

You can combine up to 64 signal generators into layers and make separate settings 
for the left and right channel.

NOTE

The Signal Generator is not intended for synthesizing musical sounds.
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Signal Generator Dialog

This dialog allows you to generate complex synthesized sounds in mono or stereo.

In the Audio Files workspace, select Tools > Signal Generator.

Audio properties

Opens the Audio Properties dialog in which you can select sample rate, bit 
resolution, etc.

Global gain

Adjusts the global level of all combined layers.

Number of layers

Determines the number of layers, for example, the number of independent 
signals to be combined.

All channels, Left channel, Right channel

Determines whether the settings on the tab are applied to the left or right 
channel of the selected layer, or to both channels.

Copy

Copies all settings of the current layer.

Paste

Pastes the settings to the selected layer.

NOTE

Clicking Paste replaces the source, frequency, and level settings on all tabs, 
not just on the selected one.

Generate

Applies the settings.
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Source Tab

Waveform

Use this pop-up menu to select a waveform for the selected layer.

Width

If you select one of the pulse waveforms, you can set this parameter to the 
width of the pulse, specified as a percentage or a number of samples.

Angle (0-359°)

Sets the phase of the signal for the selected layer.

Adjust signal length to end on a cycle boundary

If this option is activated, the generated waveform ends with a complete cycle, 
regardless of the phase setting.

Frequency Tab

Envelope section

In this section, you can set up the frequency envelope of the selected layer. 
The envelope consists of four frequency values and three duration values in 
between the frequency values.

If you want to set a static frequency (no envelope curve), make sure that all 
time values are set to 0, and set the frequency with the Median Freq. 2 
parameter.

Vibrato section

In this section, you can add vibrato to the frequency of the selected layer. You 
can select a waveform for the vibrato, set the frequency, and adjust the 
intensity.

Change frequency at cycle boundaries

If this option is activated, the vibrato is not continuously applied from 
sample-to-sample, but recomputed after each cycle.
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Linear frequency variations

If this option is activated, the frequency varies linearly.

Level Tab

Envelope

In this section, you can set up the amplitude envelope of the selected layer. 
The envelope consists of three level values and three duration values in 
between the level values. In addition, the Silence Before and Silence After 
parameters make it possible to include a period of silence before or after the 
signal of the selected layer.

NOTE

The Overall gain parameter determines the overall level of the layer.

Tremolo

In this section, you can add tremolo (continuous level variation) to the selected 
layer. You can select a waveform for the tremolo, set the frequency, and adjust 
the intensity.

Change level at cycle boundaries

If this option is activated, the tremolo is not continuously applied from 
sample-to-sample, but recomputed after each cycle.

DC Offset

Allows you to add a DC offset to the signal of the selected layer.

Overall gain

Allows you to set an overall level for the selected layer.

Generating an Audio Signal

PROCEDURE

1. In the Audio Files workspace, select Tools > Signal Generator.

2. Click the audio properties to open the Audio properties dialog, and set up 
the channels, sample rate, and accuracy.
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3. Choose how many layers of signal generators you want to use by setting the 
Number of layers parameter.
You can change this value at a later stage.

4. Set the Global gain.

5. For each layer, edit the settings on the Source, Frequency, and Level tabs.

6. If you have selected stereo channels, you can make changes for both or just 
one of the channels by selecting All channels, Left channel, or Right 
channel.

7. Once all settings are made, select Generate.
The file is generated and opens in a new window.

DTMF Generator

With the DTMF Generator you can generate DTMF (Dual Tone Multi Frequency) or 
MF tones as used by analog telephone systems.

These tones are created by combining two sine waves with variable frequencies. 
Push button telephones generate these two sine waves at different frequencies 
depending on the number that you press. These dial pulses are then decoded by 
the telephone exchange to identify which letters or numbers you pressed.
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DTMF Generator Dialog

This dialog allows you to generate DTMF or MF tones.

In the Audio Files workspace, select Tools > DTMF Generator.

Dial string

Lets you enter the numbers that you want to convert to DTMF tones. The 
characters that you can use for DTMF are 0123456789ABCD*#,) and for MF 
0123456789ABC*#,.

DTMF

DTMF is the most commonly used standard. DTMF strings are limited to 16 
characters.

MF

MF uses a different frequency than DTMF. MF strings are limited to 15 
characters.

Leading silence

Determines the length of the silent region before the first tone.

Tone

Sets the length of each tone.

Inter-tone

Adjusts the time interval between the tones.

Pause

Determines the length of any pauses in the dial string. A pause is entered by 
typing a comma character (,) in the dial string.
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Trailing silence

Determines the length of the silent region after the last tone.

Overall

Controls the level of the tone’s mix.

High frequencies gain

The DTMF signal consists of a mix between two tones. One high frequency 
tone and one low frequency tone. You can either choose to let the two tones 
have the same amplitude by leaving this at zero, or you can raise the high 
frequency tone by up to 12 dB. On some telephone lines, the high frequency 
tones are set 2 dB higher than the low ones.

Fade in/out tones

If this option is activated, the generated tones will fade in and out.

Time

Lets you set the time of the fades if the corresponding option is activated.

Audio Properties

Opens the Audio Properties dialog in which you can select sample rate, bit 
resolution, etc.

Generating DTMF Files

PROCEDURE

1. In the Audio Files workspace, select Tools > DTMF Generator.

2. Enter a dial string in the text field at the top of the dialog.
The characters that you can use are shown above the text field.

3. Select the standard to use.

4. Make the settings for Durations and Amplitude.

5. Click the audio properties to select a bit resolution and a sample rate.
The Audio Properties dialog opens where you can edit settings for the audio file.

6. Click Generate.
The file is generated and opens up in a new window.
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Importing Audio CD Tracks

You can read audio tracks from regular CDs and save them as a digital copy in any 
audio format on your hard disk.

Although WaveLab supports a large number of CD drives, there are some 
restrictions you need to be aware of:

• There are a number of different protocols for retrieving audio from a 
CD-ROM/CD-R drive. WaveLabsupports as many of these methods as 
possible, but there are no guarantees that it works with any particular drive. 
This applies for CD-Text and ISRC.

• Observe and respect any copyright notices on the CDs from which you are 
importing tracks.

When importing tracks, they are named “Track XX” by default, where XX is a 
number starting at 01. The numbering scheme can be changed.

NOTE

• Importing audio CD tracks is technically more complicated than reading files 
from a CD-ROM or hard disk, because audio sectors can be hard to detect. 
Some CDs which do not conform completely to the CD standard may cause 
problems, especially when being copy protected.

• If you import a CD track with Emphasis, and later want to use this on a CD of 
your own, remember to activate Emphasis for that track in the audio montage 
or Basic Audio CD window.

Import Audio CD Dialog

In this dialog, you can import one or more tracks from an audio CD.

In any workspace, select File > Import > Audio CD.

Menus

Functions - CD Info

Displays the CD length and the UPC/EAN code, if available.
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Functions - Extract ISRC codes

Reads the ISRC codes and displays them in the track list. Depending on your 
CD drive, this can take a while.

Functions - Examine CD-Text

Opens the CD-Text dialog where you can view the CD-Text. Not all CD drives 
support CD-Text.

Functions - Extract CD-Text

Extracts the CD-Text and displays a summary in the track list.

Rename tracks - Name

Renames the tracks according to the selected renaming scheme.

Rename tracks - Search track names on the internet (FreeDb)

Searches track names from an internet database. If the album is found, the CD 
track list is updated.

Convert - Convert to audio montage (all)

Extracts all audio CD tracks and uses them to create an audio montage.

Convert - Convert to audio montage (selected tracks)

Extracts the selected audio CD tracks and uses them to create an audio 
montage.

Convert - Convert to Basic Audio CD (all)

Extracts all audio CD tracks and uses them to create a Basic Audio CD.

Convert - Convert to Basic Audio CD (selected tracks)

Extracts the selected audio CD tracks and uses them to create a Basic Audio 
CD.
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Actions Tab

Source

Select the CD drive from which you want to import audio CD tracks.

Speed

Here, you select the writing speed. The highest speed depends on the 
capabilities of your writing device and of the media present in the device.

Refresh

If you insert a CD while the Import Audio CD dialog is open, you need to click 
this button to show the contents of that CD in the list.

Eject optical medium

Ejects the medium of the selected drive.

Track list

Shows the tracks on the CD.

Range - Start/Length

Use the Range Start and Length fields to define a start point and length if you 
want to import only a section of a track.

Output - Where

Here, you define an output location.

Output - File Format

Here, you define an output file format.

Select All

Selects all CD tracks in the track list.
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Play

Plays back the selected CD track.

Options Tab

Trim silence

If this option is activated, silence between imported tracks is removed. Only 
digital silence is removed, that is, samples with a zero level.

Automatically refresh on CD change

If this option is activated, WaveLab checks for the presence of a new CD in 
the drive several times a second. If a new CD is found, the track list display is 
refreshed.

Automatically extract ISRC codes

If this option is activated, ISRC codes are automatically extracted when a CD 
is inserted.

Automatically extract CD-Text

If this option is activated, CD-Text is automatically extracted when a CD is 
inserted.

Automatically search track names on the internet

If this option is activated, track names are automatically searched on the 
internet when a CD is inserted.

Grab pause before first track, if any

If this option is activated, when a section of audio is located before the first 
track, it is extracted together with the first track. This usually corresponds to 
a hidden bonus track.

Use a Japanese CD-Text decoder

If this option is activated, CD-Text is interpreted as Japanese the next time it 
is extracted.
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Create Peak File

If this option is activated, a peak file is created together with the rendered files.

Show times with CD frame units

If this option is activated, times are shown in CD frame units. There are 75 CD 
frames per second.

Playback through Master Section

If this option is activated, the audio track signal goes through the Master 
Section when playing back.

Convert titles and CD-Text to meta-data

If this option is activated when importing tracks into an audio format 
supporting meta-data (for example, MP3 and WMA), the titles of the tracks 
and the CD-Text are automatically added to the file header.

Ultra-Safe Mode (slow)

If this option is activated, each CD track is read several times until the same 
result is found (checksums are used). Specify the number of times that a track 
should be read with the same result before it is saved to disk.

Real audio before and after tracks

You can ensure that entire tracks are imported properly by defining how much 
audio should be read before and after a CD track.

Importing Audio CD Tracks

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import > Audio CD.

3. In the Source section, select the drive from which you want to read, as well 
as the read speed.

4. Optional: Rename the files and adjust the numbering scheme.
The tracks must have unique names if you want to import them all.

5. Optional: On the Options tab, in the Read audio before and after tracks 
section, define how much audio should be read before and after a CD track.

6. In the track list, select the tracks that you want to import.

7. Optional: If you have only selected one file, in the Range section, you can 
define a Start and Length, to import just a part of the track.

8. In the Output section, click the folder icon, and select an output location.
You can also drag one or more CD tracks onto an audio montage track.



Importing Audio CD Tracks
Searching Track Names on the Internet

536

9. In the Output section, click the file format field, and select a file format for the 
imported audio files.

10. Click Save.

RESULT 

The tracks are retrieved.

Searching Track Names on the Internet

You can search for information about your CDs, using the FreeDb database of CD 
information.

PREREQUISITE 

You must be connected to the internet to use the FreeDb function.

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import > Audio CD.

3. Select Rename tracks > Search track names on the internet (FreeDb), or 
click the corresponding icon.

Submitting Track Names to the Internet

You can submit information about the audio CD that you want to import to the 
FreeDb database of CD information.

PREREQUISITE 

You must be connected to the internet to use the FreeDb function.

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import > Audio CD.

3. In the Import Audio CD dialog, rename each track.

4. Select Rename tracks > Submit track names to the internet (FreeDb), or 
click the corresponding icon.
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5. In the Submit CD Information dialog, fill out the text fields and enter an 
E-Mail address.

NOTE

An E-Mail address is required to report submission errors. It will not be stored.

The FreeDb database does not offer the possibility to enter different artists or genres 
for individual tracks. If the artists differ from track to track, you can write the track title 
in the following way:

Title/Artist

6. Click OK.

About Ultra-Safe Mode

Sometimes, a small bit of a CD track is not properly retrieved. This depends on the 
quality of your CD drive. This can result in unpleasant clicks and pops. To solve this 
issue, you can activate the Ultra-Safe Mode in the Import Audio CD dialog 
options.

When this option is activated, you can specify how many times each CD track is 
read with the same result, before it is saved to disk.

Converting Audio CD Tracks to an Audio Montage

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import > Audio CD.

3. Optional: On the Options tab, select which information you want to extract 
from the Audio CD when converting.

4. Decide whether to convert only selected tracks or all tracks.
• To convert only selected tracks, select Convert > Convert to Audio Montage 

(selected tracks).
• To convert all tracks, select Convert > Convert to Audio Montage (all).

RESULT 

When the conversion is finished, the imported files open in the Audio Montage 
workspace.
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Converting Audio CD Tracks to a Basic Audio CD

PROCEDURE

1. Insert a CD into the CD-ROM/CD-R device.

2. Select File > Import > Audio CD.

3. Optional: On the Options tab, make your settings.

4. Decide whether to convert only selected tracks or all tracks.
• To convert only selected tracks, select Convert > Convert to Basic Audio CD 

(selected tracks).
• To convert all tracks, select Convert > Convert to Basic Audio CD (all).

RESULT 

When the conversion is finished, the imported files are added to the Basic Audio 
CD window in the Audio Files workspace.
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Batch Processing

Batch processing in WaveLab allows you to process any number of audio files or 
audio montage files with Master Section plug-ins and presets, offline effects, and 
other plug-ins that are unique to batch processing.

Each file is processed and then saved to a folder of your choice. You can change 
the file format, rename the file according to a set of rules, and run an external 
application when the batch is finished. You can process as many files as you want 
taking advantage of multi-processing on multi-core processors, if available.

When you save batch processor files you can run batches repeatedly, if required. 
For example, you may have a folder of 24-bit audio files which you want to normalize, 
add a fade-out to, and dither down to 16 bit 44.1 kHz. You could save this as a batch 
processor file, and re-run the batch each time that you update the original files. This 
procedure can be simplified using batch templates.
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Advantages of the WaveLab Batch Processor

While processing multipass plug-ins, other plug-ins of the plug-in chain are only 
gone through when necessary and file writing is reduced to a single writing process. 
This results in an improved performance of the batch processing. The following 
graphic shows the advanced uses of the multipass plug-ins of the batch processor.

Batch Processing Meta-data

You can batch process meta-data. For this you can set up the Meta-data dialog in 
the Batch Processors workspace, and apply this meta-data to the files of the batch 
process.

RELATED LINKS

Meta-Data in the Batch Processors Workspace on page 158
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Overview of the Batch Processors Workspace

This workspace allows you to process any number of audio files or audio montages 
with Master Section plug-ins and presets, offline effects, and other plug-ins.

Edit Menu

Add specific audio files

Opens the file dialog to select audio files.

Add specific audio montages

Opens the file dialog to select audio montages.

Add files from folder

Opens a dialog in which you can select files of a specific type from a folder.

Remove all files

Removes all files from the list that are not currently being processed.

Remove selected files

Removes all selected files from the list that are not currently being processed.
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Remove all but selected

Removes all files that are currently not selected and not being processed.

Remove successfully processed files

Removes files with the status “Success” from the list.

Remove files with errors

Removes files with the status “Error” from the list.

Reset the status of all files

Sets the files with the status “Done” or “Error” to “To do”.

Reset the status of all files with an error

Sets the files with the status “Error” to “To do”.

Process Menu

Start

Runs the batch process.

Pause

Interrupts the process to reduce the CPU load. You can continue the process 
by clicking Pause again.

Cancel

Cancels the running process.

Run all batches in workspace

Runs sequentially all batches in workspace. That is, a batch process starts 
when the previous one ends. An error does not prevent a new batch process 
from starting. If you stop the active process, the global process stops.

Tools Menu

List of external tools

Lists the external tools.

Configure external tools

Opens a dialog in which you can configure external tools.

Plug-ins

Here, you can select plug-ins and Master Section presets for the batch process. A 
plug-in or preset can be dragged into the audio plug-in chain of the active batch 
processor document. You can also double-click a plug-in to add it at the end of the 
chain. From the following categories, you can select plug-ins or Master Section 
presets:

Master Section presets

This is the list of Master Section presets.
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Master Section Plug-ins

This is the list of all plug-ins available in the Master Section.

Monopass Plug-ins

This is the list of monopass plug-ins. Monopass means that the audio signal 
needs to pass through the plug-in only once to be processed. These plug-ins 
are not available in the Master Section.

Multipass Plug-ins

This is the list of multipass plug-ins. Multipass means that the audio needs to 
be analyzed at least once before it is modified. These plug-ins are not 
available in the Master Section. Some are unique to the Batch Processor.

Metapass Plug-ins

This is the list of metapass plug-ins. Metapass means that the audio is 
analyzed once, and is processed after all other files have been analyzed, to 
take all analyses into account. These plug-ins are not available in the Master 
Section and are unique to the Batch Processor.

Audio Plug-in Chain

Here, you can add plug-ins that the audio signal traverses, from top to bottom.

You set up the list by dragging plug-ins from the plug-ins section.

• To remove a plug-in from the list, drag it back onto the plug-ins section, or 
select it and press [Delete], or right-click a plug-in and select Remove.

• To edit a plug-in, double click it, or right-click a plug-in and select Edit.

Red, green, and blue arrows on the right of the Audio plug-in chain visualize the 
audio signal path when plug-ins have been added to the list.

You can prevent a plug-in from processing by deactivating it.

Files to Process

Here, you specify which files to process. You can add files to the list via drag and 
drop, or use the Edit menu. You can right-click a file, to access a context menu with 
the following options:

Reset status

Sets the status of the selected files to “unprocessed”.

Remove

Removes the selected files from the list.

Open in WaveLab

Opens the selected file in WaveLab.

Reveal in Windows Explorer/Finder

Opens the folder of the selected file in the Windows Explorer/Mac OS Finder.
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Open with default application

Opens the selected file with the default application, for example, a media 
player.

Insert audio files

Opens a file browser and allows you to select the files that you want to insert 
in the file list.

Insert all open audio files

Inserts all audio files currently open in WaveLab.

The following options are available below the files list:

Preview duration

Determines the length of the preview duration.

Accept dual-mono files

If this option is activated, you can add dual-mono files to your batch process. 
Clicking the tool icon opens the Audio file editing preferences dialog, 
where you can set up the dual-mono file identification.

The following options are available above the files list:

Folder

Lets you select the folder that you want to add to the batch process.

Each time you start the batch process, the selected folder is scanned and the 
audio files that are found in the folder are processed.

 To disable this option, clear the path name.

NOTE

If you want to use XML files in the folder mode, you must activate XML 
descriptors in the File types to grab menu.

Scan subfolders

If this option is activated, the subfolders of the selected folder are also 
scanned. The audio files inside these subfolders are added to the batch 
process.

Refresh

Refreshes the selected folder and, if Scan subfolders is activated, its 
subfolders. All audio files inside the folders are added to the batch process.

File types to process

Lets you specify which file types should be added to the batch process. You 
can also select that all file types should be added to the batch process.



Batch Processing
Overview of the Batch Processors Workspace

545

Output Tab

Type of destination folder

Define a type of destination folder. The following types are available:

• Temporary, and can be undone

Writes the processed audio in a temporary file. For this, the source file 
must already be open in the Audio Files workspace.

• As source path

The file is rendered in its own folder.
• Subfolder of source path

The file is rendered in a customizable subfolder of its own folder.
• Output subfolder

The file is rendered inside the Output subfolder of the Watch Folder. 
This subfolder is created automatically by WaveLab.

• Explicit path

The file is rendered in a destination folder that you must specify.
• Explicit path + Source folder

As previous option, but the folder name of the source file is added to the 
path.

• Explicit path + Source folder (2 levels)

As previous option, but the folder name of the source file, and its parent, 
are added to the path.

• Explicit path + Source folder (3 levels)

As previous option, with one more added element of the source path.
• No output

Processing takes place while no file is written to the disk.
When using Watch Folders, this option only makes sense if you use the 
Audio Analyser plug-in to produce a text file from the source audio file, 
without rendering a new audio file. The text file is always written in the 
Output subfolder of the Watch Folder.

NOTE

For Watch Folders, the destination folder can also be determined by an XML 
file that contains this information.

Path

Specify the folder into which the files are rendered.

Renaming

If this option is activated, the source file names are processed through a 
renaming preset, to produce new names for the rendered files.

Renaming field

Opens the Renaming dialog, where you can set up a renaming scheme.
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Format Tab

File format

Opens the Audio File Format dialog.

Batch meta-data

Lets you select one of the following options for handling the batch meta-data:

• Ignore the batch meta-data and preserve the meta-data in the audio file.

• Merge the batch meta-data with the meta-data found in the audio file.

• Replace the meta-data of the audio file with the batch meta-data.

These options only have effect if Inherit from source file is activated in the 
Audio File Format dialog.

For audio montages, render CD images and cue-sheets

If this option is activated, audio montages are rendered as CD images 
together with cue-sheets.

XML Tab

On this tab, you can make settings to generate XML files containing information 
about the audio files.

Process

Lets you select whether the output XML file should be generated from scratch 
(Generate XML/HTML file) or can use the input XML files as reference 
(Transform input XML file). If you do not want to use an XML process, select 
the No XML process option.

Presets

Lets you save and restore setting presets.

XSLT file

The path of the XSLT file that is used to generate the XML file.

Optional parameters

The list of the parameters to send to the XSLT process. You can type new 
parameters directly into the text field or click the pen icon to open the 
Parameters for XSLT processing dialog and enter the new parameters 
there.

External Tool Tab

On this tab, you can select an external tool to run after the batch process is finished. 
For example, you could email, upload, or archive the resulting files. To be able to 
select tools, you need to specify them in the Configure external tools dialog.

This option has no effect when using Watch Folders.
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Options Tab

Auto start when dropping files

If this option is activated, the processing starts automatically when dragging 
a file into the list.

Auto remove converted files

If this option is activated, a file is removed from the list once it is successfully 
processed.

Stop on error

If this option is activated, the global process stops if an error is encountered. 
If it is deactivated, the file associated with the error is marked in red, and the 
next file is processed.

This option has no effect when using Watch Folders.

Include file list when saving

If this option is activated, the list of files (with their status) is saved with the 
batch processor document.

Create peak files

If this option is activated, peak files are created for each rendered file.

When a file is to be overwritten

Specify the behavior when a file is to be overwritten. The following options are 
available:

• Overwrite without question

• Stop and ask

• Report as error

• Skip and mark as done

This option has no effect when using Watch Folders.

Multitasking Tab

On this tab, you select how many cores are to be used simultaneously. The contents 
of this tab depend on your computer hardware.

Comment Tab

On this tab, you can enter a comment for the active batch process document.

About Off-Line Processors

There are several different types of plug-ins that can be applied to a batch process.

The following types of batch processing plug-ins are available:
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• Monopass plug-ins only require one pass when processing. A monopass 
plug-in effect processes the signal and then outputs it to any subsequent 
plug-in.

• Multipass plug-ins require two or more passes (one or more analysis passes 
followed by a process pass) before processing the audio. Some are unique 
to the Batch Processors workspace while others are also found as offline 
processors in the Audio Files workspace.

• Metapass plug-ins are unique to the Batch Processors workspace and 
require at least one analysis pass on all audio files before audio is processed. 
After analyzing the audio, a metapass plug-in takes into account all other 
plug-ins in the effects chain before processing the audio.

Master Section Presets

These presets are updated each time that you save a new preset in the Master 
Section. The presets also contain the Master Section gain settings.

Master Section Plug-ins

These plug-ins are all the plug-ins available from the Master Section, sorted in the 
same manner.

About Metapass Plug-ins

A metapass plug-in analyzes all files in the batch, collects the results, and 
processes the files by varying amounts. The result of the analysis of one file can 
affect how other files are processed.

A typical example of a metapass plug-in is the Loudness Meta Normalizer, which 
can process a number of files so that they all get the loudness of the loudest file in 
the batch.

Metapass plug-ins can be freely combined with other types of processors. For 
example, you can use both the Loudness Meta Normalizer and a regular Normalizer 
in the same batch. You may also combine metapass plug-ins with multipass 
plug-ins.

A metapass plug-in requires two processing passes. During the first pass all the 
files in the batch are analyzed and during the second pass they are all processed.

This is different from other multipass plug-ins, where each file is 
analyzed/processed twice or more times if required.
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Avoid Clipping When Increasing the Signal Level

Processors often increase the signal level. If you are not careful, your file may be 
distorted when it exits the batch. To prevent this, you can use the Level Normalizer 
plug-in’s Only if clipping option.

It is no problem for the signal to be amplified above 0 dB (full level) within the audio 
stream, since WaveLab uses 32-bit internal processing. There is a lot of extra 
headroom and the signal will not be clipped. However, when a signal that exceeds 
0 dB is converted to a 16-bit file at the output of the Batch Processor, clipping 
occurs.

To remedy this, you can insert the Normalizer effect at the end of the signal chain. 
The Normalizer raises or lowers the levels as required so that the signal peaks 
exactly at the specified value just before it is converted to a file. This is useful to do 
even when Only if Clipping is not activated.

If you only want the Normalizer to be applied to avoid clipping, activate Only if 
Clipping. When this is activated, the signal output may be low, but the audio does 
not clip due to amplification within any of the processors.

This allows you to use the Normalizer as a completely distortion-free limiter.

If you reduce the bit depth, add the dithering plug-in after the Normalizer plug-in.

Working with the Batch Processors Workspace

Opening the Batch Processors Workspace

PROCEDURE

1. Click the Batch Processors icon, and select Open empty workspace, or 
select Workspace > New Workspace > Batch Processor.

2. Activate the layout that you want to use.

3. Click OK.

Creating a Batch Process Document

There are several ways to create a batch process document. The following steps 
describe the way of creating a batch process document in the Batch Processors 
workspace.

PROCEDURE

1. In the Batch Processors workspace, click the Create empty document 
button, or select File > New.
If you have specified a template to be the default template, clicking New opens a new 
template with the settings of the default template.
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2. If you have created a batch process template before, the Create from 
Template dialog opens. Choose one of the following options:
• To create a new document from a template, select a template from the list, and 

click Open.

• To create an empty document, click None.

Saving a Batch Process Document

PREREQUISITE 

Set up your batch process.

PROCEDURE

1. In the Batch Processors workspace, do one of the following:
• To save a batch process document that has never been saved before, select 

File > Save as.

• To save a batch process document that has been saved before, click the Save 
button, or select File > Save.

2. In the Save Batch Processor dialog, specify a file name and location.

3. Decide whether to activate one of the following options:
• Include file list

• Open standard file selector before this dialog

• Save copy

4. Click Save.

Save Batch Processor Dialog

In this dialog, you can specify the name and location of the batch processor file that 
you want to save.

In the Batch Processors workspace, click the Save as button, or select File > Save 
as.

Name

The name of the file to write.

Where

The location where you want to save the file.

Include file list

If this option is activated, the file list is also saved, including the status of each 
file.
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Open standard file selector before this dialog

If this option is activated, the standard file selector opens before this dialog. 
Use this option if you rarely change the options in this dialog and prefer the 
standard file selector.

Save copy

If this option is activated, a copy of the open batch processor file is saved and 
the batch process continues to refer to the source file.

Adding Files to a Batch Process

You can add audio files and audio montages to a batch process.

Adding Audio Files

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. Select Edit > Add specific audio files.

2. Browse to the location of the audio file that you want to add, and select it.

3. Click Open.

RESULT 

The audio file is added to the batch process.

NOTE

You can also add audio files by right-clicking the Files to process window, and 
selecting Insert all open audio files, or selecting one of the open audio files from 
the list.
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Adding Audio Montages

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. Select Edit > Add specific audio montages.

2. Browse to the location of the audio montage that you want to add, and select 
it.

3. Click Open.

RESULT 

The audio montage is added to the batch process.

NOTE

You can also add audio montages by right-clicking the Files to process window, 
and selecting one of the open audio montages from the list.

Adding Files from a Folder

You can add all audio files or audio montages that are included in a folder to a batch 
process.

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. Select Edit > Add files from folder.

2. Specify the folder location.

3. Optional: Activate Search also in subfolders if you want to include files 
located in subfolders.

4. Specify the file type.

5. Click OK.

RESULT 

All audio files are added to the Files to process list.
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Adding a Folder as Source

You can specify a source folder in which you put the files that you want to batch 
process. Each time that you start the batch process, the selected folder is scanned 
and the audio files that are found in the folder are added to the file list and 
processed.

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. In the Folder field, specify the source folder.

2. If you want to include the files that are located in the subfolders, activate Scan 
subfolders.

3. From the File types to process menu, select which audio file types you want 
to include.

4. To start the batch process, select Process > Start.

RELATED LINKS

Overview of the Batch Processors Workspace on page 541
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Custom Plug-in Chain vs. Associated Master Section Preset

You can batch process files using a common custom plug-in chain or batch 
process each file with its own associated Master Section preset. You can also 
choose to use no plug-in at all for the batch process and only use the other features 
of the Batch Processors workspace, for example, the file format conversion or 
meta-data processing.

Adding Plug-ins to the Batch Process

You can create a custom plug-in chain and include it in the batch process.

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. Open the batch processing menu, and select Custom plug-in chain.

2. Do one of the following:
• In the plug-in section, select the plug-in or the Master Section preset that you 

want to use, and drag it to the Custom plug-in chain.

• Double-click a plug-in or a Master Section preset to add it at the end of the 
plug-in chain.

Audio Signal Path

The audio signal path of a batch process is indicated by red, green, and blue arrows 
in the Audio plug-in chain list.

• A red arrow indicates that the signal is processed, then sent to the next 
plug-in.

• A green arrow indicates that the signal is analyzed at this stage of the audio 
chain, but is not yet modified and therefore not sent to the next plug-in. When 
the audio stream comes to an end, it is restarted. Next time the signal reaches 
this plug-in, it is modified, and sent to the next plug-in. Certain plug-ins need 
several analyses before passing to the next plug-in.

• A blue arrow indicates that the signal has been fully processed at this stage 
and is written to disk.

• A vertical separator line indicates that a meta-pass happens. This means that 
the files are read and processed again one after the other.
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NOTE

Some multipass plug-ins request more than one analysis pass, or send the signal 
further in the chain without ordering the audio stream to restart. This behavior 
depends on the plug-in settings and on the audio material and cannot be 
influenced.

Removing Files and Plug-ins from the Batch Process

PROCEDURE

• In the Custom plug-in chain or Files to process list, right-click the item that 
you want to remove, and select Remove, or select the item and press 
[Delete].

Changing the Order of the Plug-ins in the Batch Process

PREREQUISITE 

In the Batch Processors workspace, create a new document, or open an existing 
document.

PROCEDURE

• Select a plug-in or Master Section preset from the Audio plug-in chain list, 
and drag it to another position.

Previewing the Effect of the Batch Process

You can preview the effect of the batch processor on any file of a batch. The 
preview includes all effects and the file format.

PREREQUISITE 

Set up your batch process.

PROCEDURE

1. In the lower right corner of the Batch Processors workspace, set up the 
Preview duration.
The preview duration can be between 2 seconds and 59 seconds.

2. Right-click the file that you want to preview, and select Preview processing.
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About Processing Open Files

If you are processing a file that is already open there are certain things to consider.

• If the new file will have the same name and is saved in the same location, the 
file will not be saved since it is already open.

• If the new file will have the same name and is saved in the same location, and 
the number of channels changes in the file (mono becomes stereo or vice 
versa), a new document is created, which is opened in an untitled window.

Selecting an Output Format for the Batch Process

You can render to a single audio format or to multiple audio formats.

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. In the Batch Processors workspace, select the Format tab.

2. Click the File Format field.
The Audio File Format dialog opens.

3. Make the settings, and click OK.

Setting Up a File Location for the Batch Process

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. In the Batch Processors workspace, select the Output tab.

2. Set the type of destination folder and the folder in which the audio files are 
rendered.
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Specifying an Overwriting Strategy

PREREQUISITE 

In the Batch Processors workspace, create a new document or open an existing 
document.

PROCEDURE

1. Select the Options tab.

2. From the When a file is to be overwritten menu, select one of the following 
overwriting strategies:
• Overwrite without question

• Stop and ask

• Report as error

• Skip and mark as done

Naming Rendered Audio Files

With the renaming function of the Batch Processors workspace, you can generate 
new names for the rendered files according to custom rules.

PREREQUISITE 

Open a batch processor document in the Batch Processors workspace.

PROCEDURE

1. In the Batch Processors workspace, select the Output tab.

2. Activate Renaming, and click the renaming field.

3. Make your settings, and click OK.

Running and Stopping the Batch Process

Once all settings are made, you can start the batch process. You can pause and 
cancel the processing procedure at any time.

• To start the batch process, select Process > Start, or click the Start button.

• To pause the batch process, select Process > Pause, or click the Pause 
button. You can continue the batch processing by clicking the Pause button 
again.

• To cancel the batch process, select Process > Cancel, or click the Cancel 
button.
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Batch Processing Status Icons

The icons next to the file number indicate the status of the files in the Files to 
process list.

Resetting the Status of Batch Processor Files

To apply the batch process again on already processed files, you need to reset the 
status of these files.

• To reset the status of one or several files in the File to process list, select one 
or several files, right-click them, and select Reset status.

• To reset the status of all files in the Files to process list, select Edit > Reset 
the status of all files.

• To reset the status of files with an error in the Files to process list, select Edit 
> Reset the status of all files with an error.

About Multitasking During the Batch Process

You can select how many CPU cores of your computer should be used 
simultaneously. The available number of cores depends on your computer 
hardware.

Each task uses one core, therefore the multitasking setting represents the maximum 
number of tasks that can be run in parallel. It is not always recommended to use the 
highest settings for the following reasons:

• If you want to continue working with your computer during batch processing, 
you need to spare power.

• The disk is slower.

• Graphics performance and user interface responsiveness are reduced.

Icon Description

Green circle Indicates that the file is ready to be processed.

Cogwheel icon Indicates that the file is currently being processed. The Batch 
Processing workspace cannot be closed if any files have this 
status.

Yellow dot Indicates that the process is done partially. For example, the files 
have been analyzed (analysis pass), but not yet processed 
(modifying pass).

Green dot Indicates that the file has been successfully processed. In order to 
process the file again, you need to reset its status.

Red dot Indicates that an error occurred.
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• If your processor uses hyper-threading, half of the cores are virtual and do not 
bring as much power as real cores.

If many large files are written, using multitasking is not always recommended, 
because the files can become more fragmented on your disk. The resulting files 
might be slower to read, unless you are using SSD drives.

NOTE

The number of cores to be used can be changed at any time. Tasks that are already 
running are continued or paused, depending on the new setting.

Selecting Processor Cores for the Batch Process

PROCEDURE

• On the Multitasking tab, select the number of processor cores that you want 
to use.

Watch Folders

Watch Folders can be used to automate batch processing tasks. By copying files 
into a Watch Folder a predefined batch processor is automatically applied to these 
files.

In the batch processor, you can use all audio processing functions that WaveLab 
offers. For example, processing with VST plug-in chains, R-128 loudness 
normalizing, audio analysis reports, MP3 conversions, etc.

NOTE

To fully take advantage of the Watch Folder feature, you must be acquainted with 
the Batch Processors workspace in WaveLab.

Any kind of Windows Explorer/Mac OS Finder folder can be defined as Watch 
Folder. You can drag or copy files into the folder, or save audio files directly into a 
Watch Folder from any application. Watch Folders can process both audio files and 
audio montages.

You can set up multiple Watch Folders, each corresponding to a different audio 
process.

WaveLab processes any files that are copied into Watch Folders, even if it is not 
the active application.

The procedure to set up a Watch Folder is to set up a batch processor, create a 
Watch Folder, associate the Watch Folder with the batch processor, and then 
activate the Watch Folder. When you now drag files into this folder, they are 
processed automatically.
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The files that you drag into the Watch Folder can be located in folders with 
subfolders. The processed files in the output folder will have the same folder 
structure as the source files.

You can also drag XML files into the Watch Folder that specify the audio files that 
you want to process.

RELATED LINKS

Batch Processing on page 539
XML Files in Batch Processing on page 575

Setting Up a Batch Processor for Watch Folders

You can associate any existing batch processor configuration with your Watch 
Folders or set up a new batch processor configuration for your Watch Folders.

A Watch Folder can be associated with multiple batch processor tasks. For 
example, copying a file into a Watch Folder could automatically produce an 96 kbps 
MP3 file, a 192 kbps MP3 file, an OGG file, and a normalized WAVE file.

• To edit the batch processor, double-click a batch processor in the Watch 
Folder window.

• To edit the output folder of a batch processor, double-click the Output folder 
column of a batch processor in the Watch Folder window.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Plug-ins that show a validation dialog on startup cannot be used.

RELATED LINKS

Working with the Batch Processors Workspace on page 549
About Multitasking During the Batch Process on page 558

Watch Folder Window

In this window, you can set up and edit the Watch Folder configuration.

If the window is not already visible, do the following: In the Batch Processors 
workspace, select Workspace > Specific tool windows > Watch Folders.
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NOTE

The configurations that you make in the Watch Folder window are automatically 
saved as you edit.

Watch Folder List

The Watch Folder list shows the selected Watch Folder and its associated batch 
processors.

• To edit a Watch Folder, double-click the folder in the list.

• To exclude batch processors from being triggered, uncheck the 
corresponding checkbox in the Watch Folders window.

Functions Menu

Add Watch Folder task

Opens the Watch Folder Task dialog, where you can assign a new Watch 
Folder to a batch processor.

Remove

Removes the selected task.

Settings

Opens the Watch Folder Settings dialog, where you can make additional 
settings for the Watch Folder.

Verify configuration

Verifies that the Watch Folder configuration is valid and ready to be activated. 
This check is automatically performed when you activate the Watch Folder.

Start

Activates the Watch Folder. If you drag files into an active Watch Folder, the 
associated batch processors are applied.

Pause

Pauses the Watch Folders.

Stop

Stops the Watch Folders. All tasks that are currently running are canceled.

Multi computer processing

Allows you to activate the Watch Folders as master instance or slave 
instance.

Presets Menu

Save as

Allows you to save the active Watch Folder configuration as a preset.
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Presets list

Lets you select a Watch Folder configuration preset.

Defining a Watch Folder

PREREQUISITE 

Set up a batch processor.

PROCEDURE

1. In the Batch Processors workspace, do one of the following:
• In the Watch Folders window, select Functions > Add Watch Folder task.

• In the Watch Folders window, click the + icon.

• Drag a folder that you want to make a Watch Folder or a batch processor file 
into the Watch Folders window. This opens the Watch Folder task dialog and 
sets the corresponding folder or batch processor file as default.

2. In the Watch Folder task dialog, do the following:
• Specify the path of the folder that you want to use as a Watch Folder.

• Specify the file types that you want to process.

• Specify the path of the batch processor that you want to trigger in the selected 
Watch Folder.

If a batch processor is already open in the Batch Processors workspace, it will be 
proposed by default in the Batch processor file field.

3. Click OK.
The Watch Folder setup is added to the Watch Folders list.

4. In the Watch Folders window, select Functions > Settings and make 
additional settings for the Watch Folders.

5. To validate the Watch Folder setup, select Functions > Verify configuration.

6. Optional: Assign another batch processor to the Watch Folder.

AFTER COMPLETING THIS TASK 

When you are done creating a Watch Folder configuration, you must activate it.

RELATED LINKS

XML Files in Batch Processing on page 575
Watch Folder Settings Dialog on page 569
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Watch Folder Task Dialog

In this dialog, you can specify the Watch Folder location, its associated batch 
processor file, and the file types that should be processed.

In the Watch Folder window, select Functions > Add Watch Folder task or click 
the + icon.

Watch Folder location

Allows you to specify the Watch Folder location.

File types to process

Allows you to select the file types that are associated with the Watch Folder. 
Only files with the corresponding file format are added to the batch process.

Batch processor file

Allows you to specify the batch processor file that you want associate with the 
Watch Folder.

You can click  to see a list of all open batch processors and a list of all 
recently used batch processors.

Activating the Watch Folder Configuration

Once you have set up a Watch Folder configuration, you can activate it.

PREREQUISITE 

Set up a batch processor and create one or more Watch Folders.

PROCEDURE

1. In the Watch Folders window, select Functions > Start.

2. In the Watch Folder activation dialog, make your settings, and click Activate.

RESULT 

The Watch Folder configuration is active. Once you drag a file into a Watch Folder, 
the associated batch processors are triggered.
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IMPORTANTIMPORTANTIMPORTANTIMPORTANT

To apply the changes that you have made for an active Watch Folder configuration, 
you must stop and restart the Watch Folders.

AFTER COMPLETING THIS TASK 

Via the system tray icon you can access information about the activated Watch 
Folder, and pause or stop the processing.

Processing Watch Folders in the Background

WaveLab’s Watch Folder feature can be used as a background task. For this, an 
additional instance of WaveLab is opened in the background. The two instances 
can run simultaneously.

The GUI mode is mainly used for setting up the Watch Folder and test the 
functionality. Once everything has been set up, you can activate the Watch Folder 
configuration using the WaveLab background instance.

The background instance can be used once you have set up the Watch Folder. 
When you drag files into your Watch Folder, the WaveLab background instance 
processes the files. You can have the background instance launched automatically 
with the operating system.

You can use the Multi computer processing option to run a WaveLab background 
instance on a different computer to increase the processing speed.

NOTE

Once a background instance is opened, it is independent from the instance that you 
work with.

RELATED LINKS

Watch Folder Activation Dialog on page 566
Global Preferences Dialog on page 666
Multi Computer Processing on page 565

Automatically Starting a Background Instance on Startup

You can start a WaveLab background instance automatically with the operating 
system.

• To activate or deactivate the automatic startup function, open the Watch 
Folder activation dialog, and select Activate Watch Folders at computer 
startup.

You can also deactivate the automatic startup function outside WaveLab.

• On Windows, remove the WatchFolders.lnk file from the following location: 

C:\Users\[UserName]\AppData\Roaming\Microsoft\Windows
\Start Menu\Programs\Startup
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• On Mac, remove the WaveLab entry from the login items list:

System preferences/Users & groups/Login items

RELATED LINKS

Activating the Watch Folder Configuration on page 563

Multi Computer Processing

You can use several computers that are located in the same network to process the 
same Watch Folders. For example, if there are 10 computers and 800 files to 
process, each computer processes 80 files. This increases the processing speed.

If the Watch Folder is located on a shared network path, the processing tasks are 
distributed between the computers. One instance of WaveLab is the “master” 
version that distributes the files between the other computers that are in “slave” 
mode. This allows for much faster processing of the files.

The Watch Folder configuration of the master instance is used and shared with the 
slave instances.

The multi computer processing option uses the background instance mode for each 
computer in the setup.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

• All computers in the network must be either Windows or Mac.

• All computers in the network must be set to the same language.

• Each computer must be set up with the plug-ins that are used by the batch 
processors.

• The paths specified in the Watch Folder configuration must be specified in a 
universal form.

On Windows, this must be in the following form: \\ServerName\volume

On Mac, this must be in the following form: /ServerName/volume

• If a task depends on certain settings (for example, the XML settings), these 
settings must be set on each computer. You can use the Synchronization 
settings option in the WaveLab global preferences to synchronize the 
computers.
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Activating a Multi Computer Processing Watch Folder

PREREQUISITE 

Set up a batch processor and create one or more Watch Folders.

PROCEDURE

1. In the Watch Folder window, do one of the following:
• To activate a master instance, select Functions > Multi computer 

processing > Start as master.
• To activate a slave instance, select Functions > Multi computer processing 

> Start as slave.

NOTE

When you are setting up a new multi computer processing, you must first start 
the master instance.

2. Specify the network setting path.

3. Decide whether to activate the Watch Folders at computer startup.

4. Click Activate.

RESULT 

The Watch Folder starts in master or slave mode.

Watch Folder Activation Dialog

In this dialog, you can set up the Watch Folder mode for the Watch Folders that you 
are activating.

Depending on whether you are activating a standard Watch Folder or use the multi 
computer processing mode, the Watch Folder activation dialog has different 
options.

Standard Watch Folder Activation Dialog

In this dialog, you can specify whether the Watch Folder runs in GUI mode or as a 
background application.

In the Batch Processors workspace, in the Watch Folders window, set up a Watch 
Folder task, and select Functions > Start.
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Start in this WaveLab session

If this option is activated, the currently active WaveLab instance is used for 
processing files in the Watch Folders. When files are copied into a Watch 
Folder, the corresponding batch processor file is activated. This allows you to 
see the progress of the processing from within WaveLab.

This mode is useful for setting up the Watch Folder configuration.

Start as background application

If this option is activated, a new WaveLab instance is launched in the 
background. This instance is used for processing the Watch Folders.

Priority

When using a WaveLab background instance for processing files in the 
Watch Folders, this can slow down other programs when files are processed. 
You can set the priority with which the background instance uses the 
resources of the computer.

The following priorities are available:

• normal: Causes the WaveLab background instance to run with the 
same priority as all other programs.

• low: Causes a WaveLab background instance to run with a lower 
priority. Processing is slower, leaving more power to other applications.

• lowest: Causes a WaveLab background instance to run with the lowest 
priority. Processing is slower, leaving more power to other applications 
than the low option.

Activate Watch Folder at computer startup

If this option is activated, a background instance of WaveLab automatically 
launches when the computer starts. This instance is used for processing files 
in the Watch Folders.

Watch Folder Activation Dialog for a Master or Slave Instance

In these dialogs, you can set up the multi computer processing. This allows you to 
distribute the processing of the batch processor files over several computers in the 
network.

Network setting path

When using multi computer processing, the Watch Folder configuration must 
be shared among all computers and the network path must be accessible for 
all computers in the network.
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Activate Watch Folder at computer startup

If this option is activated, a background instance of WaveLab automatically 
launches when the computer starts. This instance is used for processing files 
in the Watch Folders.

Using the Watch Folder

Once you have set up the Watch Folder configuration, you can start to process files.

PREREQUISITE 

Set up one or several batch processor files, associate them with one or more Watch 
Folders, and activate the Watch Folder configuration.

PROCEDURE

• Drag, copy, or save audio files into your Watch Folders.
You can also drag entire folders into the Watch Folder.

NOTE

If you drag an empty folder into the Watch Folder, it is automatically deleted.

NOTE

If you have set up the Scheduled folder option, place the files into the 
Scheduled subfolder inside the Watch Folder. Otherwise, they are 
processed immediately.

RESULT 

The files are processed according to your settings.

Saving a Watch Folder Configuration as Preset

You can save the Watch Folder settings and list as a preset. However, the preset 
does not include the batch processor files, which are independent files.

PROCEDURE

1. Set up a Watch Folder configuration.

2. In the Batch Processors workspace, in the Watch Folders window, select 
Presets > Save as.

3. In the Save preset as dialog, do one of the following:
• To save the preset in the default folder, enter a name and click Save.

• To save the preset in a custom subfolder of the default folder, click the folder 
icon, enter a name for the subfolder, and click OK. Then select the subfolder, 
enter a name for the preset and click Save.
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Watch Folder Settings Dialog

In this dialog, you can make settings for the Watch Folders.

In the Batch Processors workspace, in the Watch Folders window, select 
Functions > Settings.

Main Tab

Once an input file has been processed

Once an input file is successfully processed, it has to be removed from its 
folder. The following options are available:

• Move it to the Sources subfolder

If this option is activated, processed files are moved to a folder called 
Sources, inside the Watch Folder. The original folder structure is 
preserved.

NOTE

When using an XML file to describe the files to process, an audio file can be 
located anywhere outside the Watch Folder. In that case, the Move it to 
Source subfolder option has no effect.

• Delete it

If this option is activated, processed files are deleted from the Watch 
Folder.

If an input file cannot be processed

If an input file cannot be successfully processed, it has to be removed from its 
folder. The following options are available:
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• Move it to the Errors subfolder

If this option is activated and a file cannot be successfully processed, it 
is moved to a folder called Errors, inside the Watch Folder. The 
original folder structure is preserved.

• Delete it

If this option is activated and a file cannot be successfully processed, it 
is deleted from the Watch Folder.

Scheduled folder

You can specify a time range for the processing of Watch Folders. This allows 
you to automatically process files over night or during lunch break, for 
example.

To do so, create a folder named Scheduled inside the Watch Folder, 
activate the Scheduled Folder option, and specify the time range.

Files that reside copied outside the Scheduled subfolder are processed 
immediately.

Notification after processing

If this option is activated, a system tray notification pops up when the files 
have been processed successfully. Clicking this notification opens the folder 
where the last file was rendered.

Add readme file to each Watch Folder

If this option is activated, a file called “readme.html” is added to the root folder 
of each Watch Folder. The readme file contains information about the settings 
of the Watch Folder.

Advanced Tab
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Timing

• Poll period

This is the period during which WaveLab scans Watch Folders. The 
shorter the time, the sooner the files that are copied into the Watch 
Folder are processed.

• Delay before processing starts

A file must be fully written to the Watch Folder before processing can 
start. Therefore, WaveLab monitors how the file size increases and the 
time stamp of the file. Once these indicators are stable, WaveLab waits 
for the specified time before starting the batch processors.
If the files are written by another application, for example, a Cubase 
mixdown, a value of 2 seconds is recommended. If the audio files are 
copied or moved from the Windows Explorer/Mac OS Finder, you can 
use a smaller value.

• Wait for companion file

If an audio file is copied into the Watch Folder along with a marker file 
(.mrk), the processing should only start when both files are present in 
the Watch Folder. The delay value specifies how long WaveLab waits 
for a marker file.
If you never process audio files with marker files, you can set this value 
to 0.
WaveLab also waits for both mono audio files of a dual-mono file if this 
is activated in the batch processor. The Wait for companion file option 
is independent from the dual-mono file capability, which relies on file 
naming analysis that you can set up in the audio file preferences.

Log file

You can create a log file that is continuously updated with messages about 
the batch processing inside the Watch Folders. The log file helps you locate 
errors in the Watch Folder configuration.

• File path

Here, you can specify the name and the location of the log file.
If you use Watch Folders in a distributing network environment, one 
independent log file is created on each computer.

• Clear log file when activating Watch Folders

If this option is activated, the log file is cleared each time Watch Folders 
are activated. This option is always activated, if the log file has a markup 
format.

• Only report errors

If this option is activated, only error messages are written to the log.
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• Format

Lets you select whether the log file is a raw text file or a markup file (XML 
or HTML).
For markup files, an end tag is added only when the Watch Folders are 
deactivated. In case of a distributing computing environment, this tag is 
added by the master computer.

RELATED LINKS

XML Files in Batch Processing on page 575
Dual-Mono Files on page 145

System Tray Icon

If Watch Folders are active, a system tray icon is displayed that gives information 
about the progress and errors, and offers several options regarding the active 
Watch Folder.

To open the context menu, click the system tray icon.

System tray icon on Windows.

Explore Watch Folder

Lets you open the active Watch Folders in the Windows Explorer/Mac OS 
Finder.

Info

Opens a pop-up message about the number of successfully processed files 
and the number of error messages.

Open log file

Opens the log file for the Watch Folders.

Start WaveLab

If the system tray icon corresponds to a background instance of WaveLab, 
this option opens a new WaveLab instance.

If there is already a visible instance of WaveLab, it is put to the front.

Start

Activates the Watch Folders. If this option is not available, the Watch Folders 
are already activated.
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Pause

If this option is activated, WaveLab stops watching folders. If files are being 
processed, their processing is paused. It will continue as soon as Pause is 
deactivated.

Stop

If this option is activated, WaveLab stops watching folders and cancels any 
batch processing that is currently taking place.

Quit

Quits WaveLab and cancels any batch processing that is currently active. 
This option is only available if WaveLab is running in the background.

System Tray Status Icons

The system tray icon changes according to the status of the Watch Folder.

Indicates that the Watch Folder is active.

Indicates that the Watch Folder is currently processing.

Indicates that the Watch Folder is paused.

Indicates that the Watch Folder is stopped.

Indicates that an error occurred during processing. However, processing is 
not stopped.

Folder Structure

There are different types of subfolders that WaveLab automatically creates inside a 
Watch Folder.

Output, Sources, Errors, Scheduled, and $TEMP$ are reserved for WaveLab. 
You cannot create a subfolder with one of these names.

Output

When you create a new batch process, this is the folder where processed 
files are written by default. You can change the output folder in the Output 
tab of each batch processor.

Sources

This is the folder where processed files are moved when they are successfully 
processed. For this, the corresponding option must be activated in the Watch 
Folder settings.
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Errors

This is the folder where files that could not be processed are moved. For this, 
the corresponding option must be activated in the Watch Folder settings.

Scheduled

If you want to process some files only at a specific time, this is the folder 
where you must place the files. These files are only processed at the time that 
is specified in the Watch Folder settings.

$TEMP$

This is a temporary folder that is created and deleted by WaveLab during 
processing.

Controlling the WaveLab Background Application via 
Command Line Parameters

You can control the WaveLab background instance via command line parameters.

The following options are available:

--serviceLaunch

This command launches a WaveLab background instance. It must be 
followed by one of the following options:

• alone: Causes a WaveLab background instance to be launched for use 
in a single computer system.

• master: Causes a WaveLab background instance to be launched in 
Master mode for a multi computer system.

• slave: Causes a WaveLab background instance to be launched in 
Slave mode for a multi computer system.

For these commands, a background WaveLab instance is launched in stop 
mode by default. This command can be followed by the commands 
--serviceCommand start and --servicePriority, for example.

--serviceLaunch alone --serviceCommand start 
--servicePriority low

--serviceAuto

This command causes a WaveLab background instance to be launched in the 
mode that was active when you last selected Activate Watch Folders at 
computer startup from the Watch Folder activation dialog.

For such an instance, the Watch Folders are automatically activated.

--serviceCommand

This command starts, pauses, or stops the WaveLab background instance. It 
must be followed by one of the following options:

• start: Starts the WaveLab background instance.

• pause: Pauses the WaveLab background instance.
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• stop: Stops the WaveLab background instance.

--servicePriority

This command defines the priority with which the WaveLab background 
instance is using the processing power of the computer. It must be followed 
by one of the following options:

• normal

• low

• lowest

--serviceSettingPath

This command specifies the network path used to synchronize the 
configuration between the computers when you are running WaveLab in 
master and slave mode. For example:

--serviceSettingPath "\\server\volume\test"

An example to start a master instance:

--serviceLaunch master --serviceCommand start 
--serviceSettingPath "\\server\volume\test"

An example to start a slave instance:

--serviceLaunch slave --serviceCommand start 
--serviceSettingPath "\\server\volume\test"

--serviceStatus

This command instructs WaveLab to write the status of the Watch Folder to 
a file. This command must be followed by a file name and WaveLab must run 
as a background instance.

The status file gives information about whether WaveLab is running, paused, 
or stopped, the number of error messages, and success messages.

This command is useful to check the status of the Watch Folder system.

--serviceStatus "d:\tests\status.txt"

XML Files in Batch Processing

WaveLab can read information from XML files, such as audio file location and 
meta-data. WaveLab can also write information to XML or HTML files, such as 
custom data, meta-data, and audio analysis.

This is useful for handling and tagging huge amounts of audio files. Also, the batch 
input to WaveLab and the batch output from WaveLab can be controlled externally 
with XML files.

The input XML files must not be formatted in a restricted way. You can instruct 
WaveLab to understand the structure of your XML files.
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XML Input

You can add an XML file to a batch processor to pass information to WaveLab.

There are three types of elements that WaveLab can identify.

• Input file path and file name

To instruct WaveLab where to find the audio file that you want to process. 
This information is mandatory.

• Output file path

To instruct WaveLab where to render the audio file. This information is 
optional.

If this information is available, it has priority over the output path settings that 
you make for the batch process on the Output tab.

• Meta-data

To transmit meta-data that WaveLab can add to the audio files that you want 
to process. This information is optional.

Instructing WaveLab How to Understand your XML Files

You must instruct WaveLab how to understand you XML files, in order to make use 
of the XML input function.

PROCEDURE

1. In the Batch Processors workspace, select Options > XML Audio 
Description.

2. In the XML audio file description dialog, specify the input location.

3. Optional: Specify more elements.
If you have selected User variable (to import meta-data), specify a user variable.

4. Specify a tag and, if necessary, an attribute name and value.

NOTE

You can only specify one attribute per tag. If your XML file has other attributes, 
these are ignored by WaveLab.

5. If necessary, specify the enclosing element tag and its attribute name and 
value.

6. Optional: To save the settings as preset, click the presets field, select Save 
as, enter a name, and click OK.

7. Click OK.

RESULT 

WaveLab can understand the structure of your XML file. You can now add the XML 
file to your batch process.
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XML Audio File Description Dialog

In this dialog, you can instruct WaveLab how to understand the structure of the XML 
file that you want to read.

In the Batch Processors workspace, select Options > XML Audio Description.

Element

Lets you select the element that you want WaveLab to identify in the XML file. 
You can specify the file location of the input file and the file location of the 
output file. The following input and output elements are available:

• Input Folder/Output Folder

The input folder is the folder where the audio file is located. The output 
folder is the folder where you want to save the file. These paths can be 
relative to the path of the XML file.
If no input/output folder is found, the file path of the XML file is used 
instead.

• Input File Name/Output File Name

The file name of the input/output file. For example, Piano.wav.
• Input File Path/Output File Path

The complete input/output path including the file name. For example, 
C:\AudioFiles\Piano.wav.

For the input, you must specify either the Input File Path or the Input Folder 
+ Input File Name. If the audio file is located in the same folder as the XML 
file, it is sufficient to specify only the File Name.

If you do not make any output settings, the settings of the batch processor are 
used.

User variable

Lets you specify custom variables that you want WaveLab to identify in the 
XML file. This option is available if you have selected User variable on the 
Element menu.

The custom variables are shared throughout WaveLab. To edit the variables, 
select Options > Variables and Text Snippets.
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Identification - Tag

Lets you specify the XML tag that describes the element to identify.

Identification - Attribute name and value

If this option is activated, you can specify an XML attribute and its value for 
the tag to identify an element. In the text field, you must write the name and 
value in the following style:

attr=”value”

Enclosing element

If this option is activated, the element must be further identified by a parent 
tag.

Enclosing element - Tag

Lets you specify the XML tag of the enclosing element.

Enclosing element - Attribute name and value

If this option is activated, you can specify an XML attribute and its value for 
the tag of the enclosing element to identify an element. In the text field, you 
must write the name and value in the following style:

attr=”value”

Preview

Shows a preview of the structure that WaveLab expects in the XML file.

RELATED LINKS

Variables and Text Snippets on page 643

XML Output

After a batch process, WaveLab can automatically produce an XML or HTML file 
that describes the processed audio files. This file can contain the type of 
processing, the embedded meta-data, and the audio analysis result, for example.

An XSLT file must be specified to instruct WaveLab how to generate the 
XML/HTML file. The XSLT file must use the UTF-8 character set.

XML tab of the Batch Processors workspace

You can generate the XML/HTML file from scratch or generate an XML file that is 
based on an existing XML file. The structure of the existing input XML file must be 
specified in the XML Audio File Description dialog. The input XML file can contain 
the location of the audio files that you want to process and information that you want 
to find in the XML/HTML output file, for example.
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Once the XML/HTML files are generated, you can import them to a database or a 
podcast, for example.

RELATED LINKS

Instructing WaveLab How to Understand your XML Files on page 576
XML Tab on page 546

About XSLT Files

WaveLab needs an XSLT file to create an XML output file or transform an XML or 
HTML document to another XML document.

XSLT is a language for transforming XML documents into other XML documents, or 
generating XML documents from scratch. The WaveLab XSLT processor is 
compatible with the XSLT 2.0 standard. However, not all features are supported, for 
example, xsl:output.

The XSLT file in WaveLab determines whether the generated output file will be in 
XML or in HTML format. WaveLab provides XSLT example files to generate XML or 
HTML files that describe the processed audio files.

• To use the XSLT example files, open the XML tab, open the Presets menu, 
and select Factory presets > HTML example or Factory presets > XML 
example.

In order for the example to work properly, the processed audio file must 
contain information for the ID3v2 meta-data fields Title and Genre.

Parameters for XSLT Processing

You can specify which parameters will be included in an XML or HTML output file 
that you can generate with the batch process. For example, you can include 
meta-data and the results of an audio analysis in such an output file.

To transmit parameters to the XSLT script, define them in the Parameters for XSLT 
processing dialog.

NOTE

ID3v2 meta-data can have custom fields (“TXXX”) that WaveLab cannot list 
automatically on the menu. However, you can enter them manually.

Including Audio Analyser Results in the XML or HTML Output File

You can include the audio analysis results of the Audio Analyser batch processor 
monopass plug-in in the XML or HTML output file.

• In the Audio Analyser dialog, you must activate the Send analysis results 
to XML processor option.

Then, in the Parameters for XSLT processing dialog, you must select the 
parameters of the audio analysis that you want to include in the output XML.
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Parameters for XSLT Processing Dialog

In this dialog, you can edit the parameters that you want to find in the XML or HTML 
file that you can generate with the batch process.

In the Batch Processors workspace, in the XML tab, click the pen icon.

Creates a new parameter.

Removes the selected parameter.

Parameter list

In the left column, you can specify a parameter name that is known by your 
XSLT file. In the right column, you can specify the value for the parameter.

The parameter values can be custom variable codes, custom variable values, 
auto variable codes, auto variable values, and text snippets. To see a list of all 
available parameters, click the arrow icon.

RELATED LINKS

Variables and Text Snippets on page 643

Generating an XML or HTML File From Scratch

PREREQUISITE 

• Set up your batch process.

• Set up an XSLT file.

PROCEDURE

1. In the Batch Processors workspace, open the XML tab.

2. On the output menu, select Generate XML/HTML file.

3. In the XSLT file field, specify the path to your XSLT file.
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4. Optional: In the Optional parameters field, click the pen icon and specify 
additional parameters.

5. Select Process > Start to start the batch process.

RESULT 

The audio files are processed and an XML/HTML file is generated with the 
information that are specified by the XSLT script.

The XML/HTML file is saved in the same location and with the same name 
(extension .xml or .html) as the rendered audio file. If No output is activated, the 
XML/HTML file is saved in the Output subfolder of the Watch Folder.

Generating an XML File Based on an Existing Input XML File

PREREQUISITE 

• Set up your batch process.

• Set up an XSLT file.

• Instruct WaveLab how to understand the input XML file.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

The input XML file must be valid to the structure that is specified in the XML audio 
description dialog.

PROCEDURE

1. In the Batch Processors workspace, click the XML tab.

2. On the output menu, select Transform input XML file.

3. In the XSLT file field, specify the path to your XSLT file.

4. Optional: In the Optional parameters field, click the pen icon and specify 
additional parameters.

5. Add the input XML file to the batch process.
The audio files that are specified in the input XML file are displayed in the batch 
processor list.

IMPORTANT

Do not manually add audio files to the batch process. The location of the audio 
files that you want to process is taken from the input XML file.

6. Select Process > Start to start the batch process.

RESULT 

The audio files are processed and an output XML file is generated with the 
information that are specified by the XSLT script.
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The XML file is saved in the same location and with the same name (extension 
.xml) as the rendered audio file. If No output is activated, the XML file is saved in 
the same location as the source file.

RELATED LINKS

Instructing WaveLab How to Understand your XML Files on page 576
XML Audio File Description Dialog on page 577
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Batch Conversion

You can convert multiple files simultaneously to another format. If no processing is 
needed, this can be done using the Batch Conversion dialog.

Batch Conversion Dialog

This dialog allows you to convert the file format of a group of audio files.

In the Audio Files workspace, select Tools > Batch conversion of audio files.

Plus icon

Opens a dialog, where you can select files to add to the list.

Minus icon

Removes the selected item from the list.

List of files to convert

Shows the files to convert.

Output - Folder

Specify the folder in which the converted files are stored.
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Output - File Format

Opens the Audio File Format dialog, where you can set the file format.

Options - Auto start when dropping files

If this option is activated, the conversion starts automatically when you drag a 
file into the list.

Options - Auto remove converted files

If this option is activated, a file is removed from the list, once it is successfully 
converted. Otherwise, it remains in the list with a green mark indicating its 
status.

Options - Stop on error

If this option is activated, the global process stops if an error is encountered. 
If this option is deactivated, the file associated with the error is marked in red, 
and the next file is processed.

Multitasking - Usage of processor cores

Selects how many core to use simultaneously. The contents of this menu 
depend on your computer hardware.

Batch Converting Files

PROCEDURE

1. In the Audio Files workspace, select Tools > Batch conversion of Audio 
Files.

2. Click the plus icon to add files, or simply drag the files into the Files to 
convert list.

3. On the Output tab, select a file location and a file format.

4. Optional: Make further settings on the Options and Multitasking tabs.

5. Click Start to begin converting the files.
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Batch Renaming

With the batch renaming functions, you can batch rename multiple files, markers, 
and clips. You can convert, remove, format, import, and insert text. This allows you 
to batch rename file names according to user specified rules.

You can use simple options to match text, or you can build your own regular 
expressions. Batch renaming can be useful with large projects, for example, so you 
can apply easily identifiable names to all referenced files, clips, and markers 
belonging to the project.

You can use batch renaming for the following operations:

• Rename files

• Rename clips in an audio montage

• Rename markers in audio files and audio montages

Batch Renaming Dialogs

The Batch renaming dialogs for files, clips, and markers share most features, with 
some differences.

The Batch renaming dialog has 3 pages.

1) The first page defines which files, clips, or markers are renamed. It is different 
for all renaming operations.

2) The second page defines how the renaming is run. It is identical for all 
renaming operations.

3) The third page shows you a preview of the resulting names.

Batch Renaming Files

You can batch rename multiple files according to specified seettings.

PROCEDURE

1. Select File > Batch file renaming.

2. Select the files that you want to rename and click Next.
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3. Define the batch rename operation and click Next.

4. Verify that the renaming is performed as intended, then click Finish.

Batch File Renaming Dialog

In this dialog, you can batch rename individual files. Any currently open files that 
reference these files are updated automatically.

Select File > Batch file renaming.

On the first page of this dialog, you can define which files to rename, by using the 
following options:

Rename files in this folder

Specify the folder that contains the files to rename.

Scan subfolders

If this option is activated, files are also searched in subfolders.

Only rename files with this extension

If this option is activated, only files with the extension specified in the text field 
below are renamed.

Only rename files with specific names

If this option is activated, only files with a name that corresponds to a certain 
specification are renamed. You can type in a text string in the text field below, 
and select one of the following options from the menu:

• File name must contain this text

• File name must NOT contain this text

• File name must contain this text (with wild cards)

• File name must NOT contain this text (with wild cards)

• File name must contain this regular expression
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• File name must NOT contain this regular expression

Skip read-only files

If this option is activated, files that are read-only are not renamed.

Set new extension

If this option is activated, the extension of files is changed with the extension 
specified below.

Batch Renaming Markers

You can batch rename multiple markers according to specified settings.

PROCEDURE

1. Optional: If you only want to rename markers in a certain time range, create a 
selection range in the wave window or the montage window.

2. In the Audio Files workspace or the Audio Montage workspace, open the 
Markers window, and select Functions > Batch renaming.

3. On the Target page, make your settings, and click Next.
If you have made an audio selection and want to use it, activate All markers in audio 
selection.

4. Define the batch rename operation, and click Next.

5. Verify in the preview list that the renaming is performed as intended, and click 
Finish.



Batch Renaming
Batch Renaming Markers

588

Batch Marker Renaming Dialog

In this dialog, you can batch rename markers of any type.

In the Markers window, select Functions > Batch renaming.

All markers

If this option is activated, all markers in the selected file are renamed.

All markers in audio selection

If this option is activated, all markers in the selected audio range are renamed.

Types to rename

Only the markers of the type selected here are renamed.

Only markers with specific names

If this option is activated, only markers with a name that corresponds to a 
certain specification are renamed. You can type in a text string in the text field 
below, and select one of the following options from the menu:

• Marker name must contain this text

• Marker name must NOT contain this text

• File name must contain this text (with wild cards)

• File name must NOT contain this text (with wild cards)

• Marker name must contain this regular expression

• Marker name must NOT contain this regular expression

Skip locked markers

If this option is activated, markers that are locked are not renamed.
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Batch Renaming Clips

You can batch rename multiple clips according to specified seettings.

PROCEDURE

1. In the Audio Montage workspace, from the Clips window, select Functions 
> Batch clip renaming.

2. Select the clips that you want to rename and click Next.

3. Define the batch rename operation and click Next.

4. Check in the preview list if the renaming is as intended, then click Finish.

Batch Clip Renaming Dialog

In this dialog, you can batch rename clips in the Audio Montage workspace.

In the Clip window, select Functions > Batch clip renaming.

On the first page of this dialog, you can define which clips to rename, by using the 
following options:

All clips

If this option is activated, all clips are renamed.

All clips in focused track

If this option is activated, all clips on the focused track are renamed.

All selected clips

If this option is activated, all selected clips are renamed.

Only clips with specific names

If this option is activated, only clips with a name that corresponds to a certain 
specification are renamed. You can type in a text string in the text field below, 
and select one of the following options from the menu:
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• Clip name must contain this text

• Clip name must NOT contain this text

• File name must contain this text (with wild cards)

• File name must NOT contain this text (with wild cards)

• Clip name must contain this regular expression

• Clip name must NOT contain this regular expression

Skip locked clips

If this option is activated, clips that are locked are not renamed.

Renaming Operation Categories and Types

On the first page of the Batch renaming dialog which clips after selecting, files, or 
markers to batch rename you set up the renaming operation that you want to 
perform.

The Category pop-up menu lists the renaming operations categories. The Type 
pop-up menu lists the various types of renaming operations. When you select a 
type, the related controls are displayed. The types depend on the selected category.

The following categories and types are available:

Remove

All

Removes all characters from the selected range.

Spaces

Removes all spaces from the selected range.

Spaces at start/end

Removes all spaces at start and end of the selected range.

Duplicate

Replaces two consecutive similar characters by one. Specify the character to 
remove in the Character field.

Specific characters

Removes all instances of one or more characters. Specify the characters to 
remove in the Character field.
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Surrounded text

Removes all instances of one or more characters. In the Left character field, 
specify the characters from which on the text is removed. In the Right 
character field, specify the characters until which the text is removed.

Then specify in the Occurrence menu, which character to remove if several 
are found.

Convert

To lower case

Sets all characters in the selected range to lower case.

To upper case

Sets all characters in the selected range to upper case.

Capitalize

Sets the first character to upper case, and the rest to lower case. On the 
menu, you can specify whether only the first word or all words should be 
capitalized.

Initials to upper case

Sets only isolated letters to upper case. For example, u.s.a to U.S.A.

Specific character to text

Replaces each instance of a given character with a custom string. In the 
Character to replace field, enter the character you want to replace. In the 
Replacement field, enter the replacement string.

Pad number with zeros

Pads a number present in the selected range with zeros at the left side. On 
the menu below, specify how many digits the number should consist of.

Invert character order

Inverts the order of the characters in the selected range.

Replace with new text

Replaces the selected range by a specific text string. In the text field below, 
enter this string.

Insert

Nothing

Inserts nothing.

Counter

Inserts a number at the selected position, and updates its value for the next 
insertion. Set up the counter with the additional options.

Specific text

Inserts a string at the selected position. In the text field below, enter the text 
to be inserted.



Batch Renaming
Renaming Operation Categories and Types

592

Part of original name

Inserts a part of the original name (before the first operation was performed) 
at the selected position. In the text field below, enter the regular expressions. 
Clicking on the bulb icon opens a menu with shortcuts for several regular 
expressions.

Pair of characters around text

Inserts specific characters before and after the selected range. In the Left 
character field, specify the characters to insert before the selected range. In 
the Right character field, specify the characters to insert after the selected 
range.

Spaces around text

Inserts a space before and after the selected range.

Space after specific characters

Inserts a space after certain characters. In the field below, enter the 
characters that should be followed by a space.

Space before each capitalized word

Inserts a space before each word starting with an upper case letter. For 
example, MyNicePiano to My Nice Piano.

If Lower case for each word but first one is activated, only the first word is 
capitalized (My nice piano).

Today’s Date/Time

Inserts the current date and time.

Universal unique identifier

Inserts a unique identifier. This is useful for recordings, for example.

Random word

Inserts a random pronounceable word.

Find and Replace from Table

This category allows you to define a table of words and to associate each word with 
a replacement. This feature is useful to reformat a text according to a new style. For 
example, it can be used to map a series of numbers to a series of tags, to change a 
numerical sequence like “000 - 127” to “C-2 - G8” (MIDI notes).

Find anywhere in text

Replaces each word of the table which is present in the selected range.

Find exact text

Replaces a word of the table if it equals the selected range.

In the table below these types, you can define a list of strings to find, and define a 
replacement for each one. Double-click the cells to edit the list. If a file cell is empty, 
it is ignored.
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If Case sensitive search is activated, the search takes the letter cases into 
account. If Keep letter case is activated, the case of the replacement text is 
adapted to the case of the found text.

Import and Insert External Data

This category allows you to insert information taken from a file or current context. 
This is mostly audio-oriented as some features analyze the audio file headers. The 
available options differ depending on the selected Batch Renaming dialog.

Sample rate

Inserts the sample rate of the file. In the fields below, enter a prefix and suffix, 
and select how to format the imported data.

Number of channels

Inserts the number of channels of the file. In the fields below, enter a prefix and 
suffix, and select how to format the imported data.

Sample bit resolution

Inserts the bit resolution of the file. In the fields below, enter a prefix and suffix, 
and select how to format the imported data.

Bit rate

Inserts the bit rate of the file if the file is encoded. In the fields below, enter a 
prefix and suffix, and select how to format the imported data.

Variable/Constant Bit Rate

Inserts the tag VBR or CBR if the file is encoded. In the fields below, enter a 
prefix and suffix.

File length

Inserts the length of the file. In the fields below, enter a prefix and suffix.

File extension

Inserts the extension of the file. In the fields below, enter a prefix and suffix.

Date/Time

Inserts the date/time of the item at the selected position. In the Format field 
below, enter a date.

Folder name

Inserts the name of the folder containing the item. In the fields below, enter a 
prefix and suffix.

Folder name (2 positions up)

Inserts the name of the folder located two positions higher in the hierarchy. In 
the fields below, enter a prefix and suffix.

Folder name (3 positions up)

Inserts the name of the folder located three positions higher in the hierarchy. 
In the fields below, enter a prefix and suffix.
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Sample: MIDI note

Inserts the sample note of the item if available. In the fields below, enter a 
prefix and suffix, and select how to format the imported data.

Sample: detune

Inserts the sample detune if available. In the fields below, enter a prefix and 
suffix.

Sample: key range

Inserts the sample note of the item if available. In the fields below, enter a 
prefix, suffix, and separator, and select how to format the imported data.

Sample: velocity range

Inserts the velocity range of the item, if available. In the fields below, enter a 
prefix, suffix, and separator, and select how to format the imported data.

Meta-data: Title

Inserts the title if this information is present in the meta-data of the item. In the 
fields below, enter a prefix and suffix.

Meta-data: Artist

Inserts the artist if this information is present in the meta-data of the item. In 
the fields below, enter a prefix and suffix.

Meta-data: Genre

Inserts the genre if this information is present in the meta-data of the item. In 
the fields below, enter a prefix and suffix.

Meta-data: Album

Inserts the album if this information is present in the meta-data of the item. In 
the fields below, enter a prefix and suffix.

Meta-data: BWF description

Inserts the corresponding meta-data. You can insert the title, artist, genre, 
album, and BWF description.

Timeline position

Inserts the position of the item in the timeline. In the fields below, enter a prefix 
and suffix.

Line [x] from text file

Inserts the specified line from a text file to the specified renaming operation. 
In the field below, specify the location of the text file (UTF-8) from which the 
strings should be collected.
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List of Renaming Operations

In this section on the Operation page of the Batch renaming dialog, you can 
create, delete, and arrange renaming operations.

Plus icon

Adds a new operation at the end of the list.

X icon

Deletes the selected operation.

Arrow Up/Down icons

Moves the selected operation one position up/down.

List of the operations to be performed on the original name

Lists all operations performed on the original name. The operations are run 
one after the other.

Preview Section

In this section on the Operation page of the Batch renaming dialog, you can 
preview the renaming result of the selected operation.

When you enter a name in the Original field, the change is automatically reflected 
in the Output format field. This preview is continuously updated.

If the preview cannot display missing data, an “X” is shown instead.
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Range Parameters

In the range sections on the Operation page of the Batch renaming dialog, you 
can specify where in the name the operation is run.

Range to Process

All

If this option is activated, the whole name is processed by the operation.

Regular expression

Select this option if you want only a part of the name to be processed by the 
operation. In this case, you need to define a regular expression. Clicking on 
the bulb icon opens a menu with shortcuts for several regular expressions. 
The sub-string found by this regular expression is the range to process.

From/To

If this option is activated, you can set the start and end position of the range 
independently in the From and To sections.

From

Start

If this option is activated, the position is the beginning of the source name.

Character position

If this option is activated, the position is a fixed offset from the beginning of 
the of the source name.

Start of regular expression

Select this option if you want the position to be the one of the sub-strings 
found by the regular expression applied on the source name.

After regular expression

Select this option if you want the position to be the one right after the 
sub-string found by the regular expression applied on the source name.

End of previous operation

If this option is activated, the position corresponds to the end of the change 
performed by the previous operation.



Batch Renaming
Previewing and Performing All Renaming Operations

597

End

The end of the source name.

To

End

If this option is activated, the position is the end of the source name.

Position from end

If this option is activated, the position is a fixed offset before the end of the 
source name.

Number of characters

If this option is activated, the end position is given by the start position plus a 
number of characters.

Before start of regular expression

Select this option if you want the position to be just before the sub-string 
found by the regular expression applied on the source name.

End of regular expression

Select this option if you want the position to be the end of the sub-string 
found by the regular expression applied on the source name.

Previewing and Performing All Renaming Operations

On the last page of the Batch Renaming dialog, you can see how all the selected 
file, clip, or marker names are changed before you start the batch renaming. If the 
name contains a random item, this item name will likely be different in the preview.

PREREQUISITE 

In the Batch renaming dialog, after setting up what files, clips, or markers to 
rename and in which way, click Next, to open the third page of the dialog.

PROCEDURE

1. In the list, check if the changes are as you intended.

2. Click Finish.
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About Regular Expressions

A regular expression is a formula composed of characters that have special 
meanings (called operators). Other characters are plain letters and numbers that 
are searched for. The search engine browses the target text one character at a time 
and stops as soon as it finds a sequence of characters that matches the regular 
expression.

At various places in WaveLab, you can use regular expressions to build complex text 
matching capabilities into your conversion and renaming processes. A regular 
expression is a set of text symbols that describe a method to find a specific text 
string within a large body of text, and then apply a specific operation to this text 
string. Regular expressions are available for the advanced user to perform powerful 
string search/replace operations, for example, in batch renaming or batch 
processing.

Throughout WaveLab, wherever you see the bulb icon, there is a field where you 
can create your own regular expressions. A menu containing shortcuts to build up 
the basic syntax of an expression is also available.

It is beyond the scope of the WaveLab documentation to describe this subject 
thoroughly, please see other resources for further details on regular expressions.

Common Regular Expressions

There are various versions of regular expressions. WaveLab uses a version that 
represents a good compromise between power and ease-of-use.

The term “expression” refers to a single character, a character class, or a 
sub-expression enclosed with () or {}. Searches for regular expressions are not case 
sensitive.

The following items are available on the Regular Expression pop-up menu.

Regular Expressions Menu

Menu Item Operator Description

Any character . Symbolizes any character.

Character in 
range

[ ] A bracketed text is treated as a single character, for 
example: [AEW13] means A or E or W or 1 or 3. A 
hyphen within the brackets specifies a range of 
characters. For example, [F-I] means F or G or H or I, 
and [A-Z0-9] matches all letters and all digits.

Character not in 
range

[^] A circumflex located at the first position in a bracket 
is a complement operator. It describes a situation 
where all characters match except those included in 
the bracket. For example, [^E] means any character 
except E.
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0 or 1 match (1 if 
possible)

? Matches 0 or 1 time the preceding expression. 1 
repeat if possible is grabbed, then the rest of the 
regular expression continues to be evaluated.

0 or 1 match (0 if 
possible)

?? Matches 0 or 1 time the preceding expression. 0 
repeat if possible (the NEXT step in the regular 
expression is also evaluated and has priority).

0 or more 
matches (as many 
as possible)

* Matches 0 or more times the preceding expression. 
As many repeats as possible are grabbed, then the 
rest of the regular expression continues to be 
evaluated.

0 or more 
matches (as few 
as possible)

*? Matches 0 or more times the preceding expression. 
As few repeats as possible are grabbed (the NEXT 
step in the regular expression is also evaluated and 
has priority).

1 or more 
matches (as many 
as possible)

+ Matches 1 or more times the preceding expression. 
As many repeats as possible are grabbed, then the 
rest of the regular expression continues to be 
evaluated.

1 or more 
matches (as few 
as possible)

+? Matches 1 or more times the preceding expression. 
As few repeats as possible are grabbed (the next 
step in the regular expression is also evaluated and 
has priority).

Or | OR operator. Use this to separate two expressions 
and to match expression #1 or expression #2. For 
example, Piano|Drum matches all texts that contain 
Piano or Drum.

Not ! Negation operator: the expression following ! must 
not match the text. For example, a!b matches any “a” 
not followed by “b”.

Generic group () Grouping operator. Useful to form a sub-expression.

Capture {} Capture operator. By default, the found text 
corresponds to the entire regular expression. But it 
is possible to limit a part of the regular expression 
with { }, and if a part is matched, this will be the 
retained part. For instance the regular expression 
“ab{cd}ef” that is applied on “abcdef” will return 
“cd”.

Beginning of text ^ Use the circumflex sign to specify that the text must 
be located at the start of the browsed text. Any 
match not located at the start of the browsed text is 
ignored.

Menu Item Operator Description
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Special Characters Submenu

On this submenu, all special characters for regular expressions are available.

Shortcuts Submenu

End of text $ Use this sign to specify that the text must be located 
at the end of the text. Any match not located at the 
end of the text is ignored.

Menu Item Operator Description

Menu Item Operator Description

Any digit (0-9) /d Symbolizes any digit, as [0-9].

Any non-digit (not 
0-9)

/D Symbolizes any non-digit, as [^0-9].

Any letter (a-z or 
A-Z)

/l Symbolizes any letter, as [a-z].

Any non-letter 
(not a-z, not A-Z)

/L Symbolizes any non-letter, as [^a-z]. - Any 
alphabetic /w Special code to symbolize any 
alphabetic character, as [0-9a-z].

Any alphabetic 
(a-z, or A-Z, or 
0-9)

/w Symbolizes any alphabetic character, as [0-9a-z].

Any 
non-alphabetic 
(not a-z, not A-Z, 
not 0-9)

/W Symbolizes any non-alphabetic character, as 
[^0-9a-z].

Number /u Symbolizes a number (without a sign).

Number (with 
possible +- 
before)

/i Symbolizes a number which can be preceded by a + 
or - sign.

Quoted string /q Symbolizes quoted text.

Simple word /z Symbolizes a simple word (a sequence of letters 
surrounded by non-letters, for example, spaces).
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Presets Submenu

Menu Item Description

1st/2nd/3rd word Searches for the first, second, or third word (separated by a 
space).

Last word Searches for the last word (separated by a space).

1st/2nd/3rd 
expression in 
parentheses

Searches for the first, second, or third string enclosed in 
parentheses.

Last expression in 
parentheses

Searches for the last string enclosed in parentheses.

1st/2nd/3rd 
expression in brackets

Searches for the first, second, or third string enclosed in 
brackets.

Last expression in 
brackets

Searches for the last string enclosed in brackets.
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Podcasts

Podcasting is a method of distributing multimedia files over the internet, for 
example, for playback on mobile devices and personal computers.

A Podcast can be downloaded automatically, using software that is capable of 
reading RSS feeds. RSS (Really Simple Syndication) is a standard for distributing 
news and other information via the internet. An RSS news feed sends short 
messages on a certain topic from a specific web site. In order to read the messages, 
the user employs a program that has the ability to monitor multiple feeds and 
automatically download new messages on a regular basis. This can be special feed 
readers or an internet browser, for example.

A Podcast is an RSS feed including data content, such as audio or video files. This 
can be a show of which new episodes are released regularly. The file formats .mp4a, 
.mp3, and .ogg are commonly used for podcasts.
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Podcast Workspace

The Podcast workspace is divided into two panes. The upper pane shows the 
information for the feed or an episode, depending on the item that is selected in the 
list below. This is where you can add files, internet links, or textual information to the 
Podcast feed and its episodes. The lower pane shows an item list of the basic feed 
and all episodes that are included in the Podcast.

Episodes Menu

In the Episodes menu, you can create, delete, and move individual Podcast 
episodes.

New

Adds a new untitled episode without any information present.

Duplicate selected

Adds a new episode, copying all the information from the existing episode to 
the new one.

Delete selected

Deletes the selected episode. Alternatively, you can exclude an Episode from 
the Podcast by deactivating the Enabled box.

Cut/Copy/Paste

Cuts, copies, and pastes the selected episode.
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Move up/Move down

Moves the selected episode one position up or down in the item list. 
Alternatively, use drag and drop.

Publish Menu

In the Publish menu, you can define where your Podcast is going to be uploaded 
via FTP.

Update all items on FTP

Uploads/updates the XML Podcast file on the FTP server. It also uploads all 
media files of the item, but only if they are not yet available on the FTP server. 
This is the most common function to upload and update your Podcast.

Update selected item on FTP

Uploads/updates the XML Podcast file on the FTP server. It also uploads the 
media file of the selected item in the list, but only if it is not yet available on the 
FTP server.

Upload/Replace all items on FTP

This is the same as above, but it always uploads/replaces all of the media files 
belonging to the item. This is useful if you have changed the audio data, for 
example.

Upload/Replace selected items on FTP

This is the same as above, but it always uploads/replaces the media file of the 
selected item in the list. This is useful if you have changed the audio data, for 
example.

View published Podcast

Opens your Podcast (via the URL specified in your FTP site settings) using 
your default browser.

View XML source code

Opens an XML editor to display the source code of the Podcast.

FTP site

Edit the FTP settings that are related to this Podcast.

Options Menu

On the Options menu, you can set additional options that are valid for all Podcast 
windows.

Options

Edit the automatic picture resizing, set a time offset with Greenwich Mean 
Time, and specify the path of the HTML editor.

Folders

Edit the default folders where to open and save files.
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Main Tab

On the Main tab, you can assign parameters to your Podcast. The available 
parameters change, depending on whether you select a feed or an episode. Field 
labels in bold letters mark fields that are mandatory to fill.

Title

Sets the title of the feed, for example, the topic of your Podcast.

Description

Gives space for a further description of the feed content.

Internet link (URL)

The main link of the feed that the user sees. Use this to direct people to a 
certain web site that is related to your feed. Clicking the world icon opens the 
specified URL in your default internet browser.

Picture (only available for feeds)

According to the RSS standard, this picture may not be larger than 144 x 400 
pixels, so the picture is automatically resized. Clicking the sunglasses icon 
opens the specified picture in your default image viewer of your system.

Publication date and time

Sets the publication date and time of the feed or episode. Clicking the Now 
button transfers current date and time of your system.

As most recent episode (only available for feeds)

If As most recent episode is activated, the date and time of the most recent 
episode are automatically matched.

Import HTML file (only available for episodes)

Lets you browse for an HTML document that replaces the description.

Audio file (only available for episodes)

This sets the path to the audio file that you want to add to the episode. The 
audio file can be any file type that is supported by the media reader of your 
browser. An .mp3 file provides best compatibility. Click the icon to list the 
audio files that are already open in WaveLab. Select one for your episode.

Alternatively, you can drag the list icon of an audio file into the audio file pane. 
Click the play icon to open the specified file in the default media player or 
viewer of your system, for previewing or checking purposes.

Extra Tab

In the Extra tab, you can assign parameters to your Podcast. The available 
parameters change, depending on whether you select a feed or an episode.

The following parameters are available when a feed is selected:

• Webmaster (email address)

• Editor (email address)

• Copyright
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• Category

• Related domain (URL)

• Language

• Frequency of updates

• Skip hours (0 to 23, separate each one with a comma)

• Time to live (number of minutes)

The following parameters are available when an episode is selected:

• Author (email address)

• Comments (URL)

• Category

• Related domain (URL)

• Title

• Original domain (URL)

iTunes Tab

In the iTunes tab, you can activate the iTunes extension, that allows you to specify 
additional feed and episode information. The available parameters change, 
depending on whether you select a feed or an episode.

The following parameters are available when a feed is selected:

• Subtitle

• Summary

• Categories

• Keywords (separate them with a comma)

• Author

• Owner name

• Picture

• New URL of Feed

• Hide in iTunes

• Explicit material

The following parameters are available when an episode is selected:

• Subtitle

• Summary

• Keywords (separate them with a comma)

• Author

• Duration
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• Hide in iTunes

• Explicit material

Global Podcast Options

You can set some additional options that are valid for all Podcast windows.

In the Podcast workspace, select Options > Options.

Automatic picture resizing (not for iTunes)

Defines what to do if specified pictures exceed the maximum size allowed by 
the RSS standard. If pictures need resizing, the original images on your hard 
disk is not modified.

Time offset with GMT (Greenwich Mean Time)

The displayed dates and times are local. If your system is properly set, 
WaveLab automatically adjusts the time offset in relation to GMT. However, if 
you want to have time and date relative to a different time zone, adjust the 
value with this option.

HTML Editor

Sets the path to the external HTML editor that is launched when clicking the 
Pen button in the Import HTML file section.

Creating a Podcast

There are several ways to create a new Podcast feed or episode.

• To create a new podcast, in the Podcast workspace, select File > New.

• To create a new podcast from the selected audio file, in the Audio Files 
workspace, select File > Export > Create Podcast from active file.

• To add an audio file to an existing podcast, in the Audio Files workspace, 
select File > Special > Add to Podcast.

• To add a new untitled episode to a podcast, in the Podcast workspace, select 
Episodes > New.

• To duplicate an episode, in the Podcast workspace, select Episodes > 
Duplicate. This adds a new episode, and copies all information from the 
existing episode to the new one.
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Setting Up a FTP for Podcast Publishing

To be able to upload a Podcast to your FTP server, you must enter the FTP server 
details first.

PROCEDURE

1. In the Podcast workspace, select Publish > FTP site.

2. Enter the following details:
• The log-in details for your FTP server.

• The relative path and file name of the Podcast (extension .xml).

• Your web site address including the path to the feed.

3. Click OK.

Publishing a Podcast

You can upload a Podcast from within WaveLab directly to your FTP server.

PREREQUISITE 

Set up your FTP settings within WaveLab.

PROCEDURE

1. In the Podcast workspace, select the Publish menu, and select one of the 
following options:
• Update all items on FTP

• Update selected item on FTP

• Upload/Replace all items on FTP

• Upload/Replace selected items on FTP

2. Check if the FTP settings are correct, and click OK.

RESULT 

The Podcast is uploaded to your FTP site.
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FTP Site Dialog

In the FTP site dialog, you can manage all required information for the Podcast 
upload process.

In the Podcast workspace, select Publish > FTP site.

Host

The host name or IP address of the FTP server.

User name

The login name to your FTP server.

Password

The password to the login.

Use Passive Mode

Keep this activated and only change this if you experience problems with the 
FTP connection.

Feed file name (with path)

The Podcast file name that is displayed on your FTP server (extension .xml), 
including the relative path. File name and path are part of the final public 
internet address of the Podcast, so you may want to avoid long names.

Associated web site (URL)

Your own web site address including the path to the feed.

FTP Site Dialog Example

• Your FTP host address is “ftp.MyPage.com”, your public web site address is 
“www.MyPage.com”.
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• The feed file name setting is “podcasts/fantastic-cast.xml”, the associated 
web site setting is “www.MyPage.com/podcasts”.

• The media files of the Podcast will be uploaded to the FTP server at 
“ftp.MyPage.com/podcasts”.

• The Podcast file itself and the internet address to be distributed will be found 
at “www.MyPage.com/podcasts/fantastic-cast.xml”.

Each Podcast saves its own complete FTP site information. It is also possible to 
save and recall FTP site presets using the Preset functions at the bottom of the 
dialog.

Checking the Podcast

After creating and publishing a Podcast, you can check if the upload was 
successful.

• To visualize the contents of the feed XML file in your default XML editor, in the 
Podcast workspace, select Publish > View XML source code.

• To open your default internet browser and receive the Podcast that you have 
just published from the internet, in the Podcast workspace, select Publish > 
View published Podcast.
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Master Projects

If you work on a large project that consists of several audio montage files, audio 
files, and editing notes that all belong to an album project, it is useful to open all 
these items from a central place. In the master project, you can organize the files in 
folders and subfolders.

You can drag files into the master project and from the master project to external 
locations. Each file is listed with its path and has a comment field. Only one master 
project can be open at a time.

The master project also stores a general window layout.

Setting Up a Master Project

To set up a master project, can add all kinds of files to a master project, for example, 
audio montages, audio files, text files, and pictures.

PROCEDURE

1. Select Workspace > Specific tool windows > Master Project.

2. Add files to the master project by dragging them into the Master Project 
window.
You can drag files from various locations, for example, from the File Browser window 
or the Windows Explorer/Mac OS Finder.

3. Optional: Edit further settings in the master project.
• In the Comments column, add comments to the files.

• Click the New folder icon to add folders in which you can organize the master 
project.

• Select the Notes tab and add notes to the master project.

4. Click the Save icon.
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Saving a Master Project

PREREQUISITE 

Set up your master project.

PROCEDURE

1. In the Master Project window, do one of the following:
• To save a master project that has never been saved before, select File > Save 

as.

• To save a master project that has been saved before, click the Save button, or 
select File > Save.

2. In the Save Master Project dialog, specify a file name and location.

3. Optional: Activate the following settings:
• Open standard file selector before this dialog

• Save copy

4. Click Save.

Writing Files of a Master Project to Data CD/DVD

You can archive the contents of a master project to a data CD or DVD.

PREREQUISITE 

You have set up and saved a master project.

PROCEDURE

1. In the Master Project window, select File > Add to Data CD/DVD.

2. Set up the data CD/DVD and click the Write Data CD/DVD icon.

3. Select a writing device.
• If you select ISO Image, specify a file name and file location.

• If you select a CD/DVD writer, specify the writing speed and edit further 
settings.

4. Click OK.



Master Projects
Master Project Window

613

Master Project Window

This window allows you to organize the files of a master project in folders and 
subfolders and add comments to the files.

In any workspace, select Workspace > Specific tool windows > Master Project.

File List

The file list displays the name and path of the files in the master project. In the 
Comment column you can add comments to the files. Double-clicking a file in the 
list opens the file.

File Menu

New

Creates a new master project. The current master project is closed.

Open

Opens a dialog where you can select a master project.

Open recent

Opens the Recently used files dialog from where you can open recently 
used master project files.

Save

Saves the current master project.

Save as

Allows you to save the current master project with a different name and in a 
different location.

Add to Data CD/DVD

Opens the Data CD/DVD dialog and adds the documents of the master 
project to the data CD/DVD.

Favorite Master Projects

Opens a submenu that lets you add the master project to the list of favorite 
master projects. To edit this list, select Edit list.



Master Projects
Master Project Window

614

Functions Menu

Find

Opens a search field at the bottom of the Master Project window in which 
you can enter text to search files in the master project. You can search for file 
names and path names.

New folder

Creates a new folder in the master project where you can add file references 
and subfolders.

Delete

Deletes the selected item.

Save general layout

Saves the general layout as the layout for the master project. This layout 
contains all open files. This means that you can recover an exact session.

Restore general layout

Restores the general master project layout.

Customize commands

Opens the Customize commands dialog, where you can define shortcuts for 
the Master Project window.

Help

Opens the WaveLab help.
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Customizing

Customizing means making settings so that the program behaves and looks the way 
that you want it to.

Window Layout

Window layouts are used for creating various work displays for different situations.

You can create a window layout that always appears when you launch WaveLab. 
Optionally, the snapshots and the files that you had opened automatically reopen.

There are 2 types of layouts:

• Workspace layouts that concern a given type of workspace

• General window layouts that concern the placement of all main windows

Workspace Layout

You can save a workspace layout to later recall the favorite layout for a given editing 
task. Since workspaces can be complex, it is useful to have layouts with a reduced 
number of visible tool windows to perform a given task.

General Window Layout

A general window layout serves two different purposes, each one being selectable 
when saving a general window preset.

1) It can recall the placements of all main windows, without recalling how they 
are layouted inside. This is useful when you work with multi screen setups or 
large screens, for example, to display two workspaces next to each other. The 
position and sizes of the windows are saved. When restoring such a layout, 
only the already open windows are adjusted. For example, if the layout 
contains a Batch Processors workspace, and none is open when applying the 
preset, no batch workspace will open.

2) It can save the exact window snapshot. In this case, the inner layouts (tool 
windows, command bars, tab groups, etc.) are saved and restored. When 
restoring such a layout, all the open windows are first closed, and an exact 
snapshot is restored. Whether the data files are reopend or not, is an option.

Windows such as the Import Audio CD dialog are part of general window layouts.



Customizing
Window Layout

616

Working with Window Layouts

Once you have your tool windows, command bars, and tab groups set up the way 
that you want to work, you can save them as a preset. You can either save the 
window layout of the currently active workspace, or for all workspaces.

NOTE

If you hold down [Ctrl]/[Command] when launching the program, the startup dialog 
that allows you to choose the startup layout is displayed.

Workspace Layout

You can define options when saving the layout of a workspace. You can save the 
placement of the workspace frame and all its tool windows and/or the layout of 
tabbed data windows. It allows you to choose whether to retain or discard these 
elements of your current layout arrangement when saving a new layout.

• To save the layout of the currently active workspace as preset, select 
Workspace > Layout > Save as, enter a name, and click Save.

• To save the layout of the currently active workspace as default, select 
Workspace > Layout > Save current layout as default.

• To restore the default layout, select Workspace > Layout > Restore default 
layout. The default layout is used when a new workspace is created.

• To activate a previously saved preset, select Workspace > Layout, and 
select a preset from the menu.

• To save the position and size of the workspace and its command bars and tool 
windows in the preset, activate Save placement of this workspace and its 
peripheral windows before saving.

• To save the position and size of the tab groups within the workspace in the 
preset, activate Save layout of tab groups before saving.

General Window Layout

• To save the current layout as preset for all workspaces, select Global > 
General window layout > Save as, enter a name, and click Save.

• To save the current layout as default layout for all workspaces, select Global 
> General window layout > Save current layout as default.

• To apply the default window layout, select Global > General window layout 
> Close all and restore default layout. The default layout saves all window 
placements as well as their inner layouts, but not the documents links. This 
option can be selected from the startup dialog, too.

• To activate a previously saved preset, select Global > General window 
layout, and select a preset from the menu.
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NOTE

Plug-in windows are not part of a general layout.

Locking the Window Layout

Once you have set up a window layout, you can lock it, to prevent tool windows from 
being closed or moved by accident. This also makes the layout more compact by 
hiding certains caption bars used to move tool windows. The only edit possibility for 
locked windows is to move the separators and to move floating windows.

PROCEDURE

1. Set up the window layout to your liking.

2. In any workspace, activate Workspace > Lock layout.

RESULT 

The window layout is globally locked for all workspaces.

Workspace Layout Dialog

This dialog allows you to save the window layout of the active workspace as a 
preset.

In any workspace, select Workspace > Layout > Save as.

Path name

Opens the root folder of the preset in the Windows Explorer/Mac OS Finder. 
Here, you can create subfolders in which presets can be stored.

Presets list

Lists all existing presets.

Name

Lets you specify the name of the preset to save.
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Create shortcut for selecting the preset

If this option is activated and you click Save, the Shortcut Definitions dialog 
opens, which allows you to define a shortcut to apply to this preset.

If a preset already has an assigned shortcut, this option is grayed out. To 
change the existing shortcut, double-click the preset name in the presets list.

Save placement of this workspace and its peripheral windows

Saves the position and size of the workspace and its command bars and tool 
windows.

Save layout of tab groups

Saves the position and size of the tab groups within the workspace.

General Window Layout Dialog

This dialog allows you to save the current layout as preset for all main windows.

In any workspace, select Global > General window layout > Save as.

Path name

Opens the root folder of the preset in the Windows Explorer/Mac OS Finder. 
Here, you can create subfolders in which presets can be stored.

Presets list

Lists all existing presets.

Name

Lets you specify the name of the preset to save.

Create shortcut for selecting the preset

If this option is activated and you click Save, the Shortcut Definitions dialog 
opens, which allows you to define a shortcut to apply to this preset.

If a preset already has an assigned shortcut, this option is grayed out. To 
change the existing shortcut, double-click the preset name in the presets list.
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Restore options

Lets you select the way a general window layout is restored.

Restore position and size of the currently active windows

If this option is activated, when the preset is restored later, only the position 
and size of the currently opened main windows are adjusted, according to the 
layout they had when the preset was saved.

When restoring a general layout, currently opened main windows that were 
not part of this layout, are not affected and no new window are created.

Restore the currently active layout

If this option is activated, when the preset is restored later, all windows are 
first closed and the same window layout as when the preset was saved, is 
restored. No files are reopened, though.

This option is useful to create reference working layouts to which you can add 
files.

This is the same as selecting Restore last window layout without files on 
the launch screen of WaveLab.

Restore documents

This option is as the previous option, with some additions. If this option is 
activated, the files that are opened when the preset is saved, are restored 
when the preset is recalled. This is like saving/restoring an exact working 
session.

This is the same as selecting Restore last window layout on the launch 
screen of WaveLab.

Starting WaveLab With a General Layout Preset

You can start WaveLab with a given general window layout by specifying a preset 
name in the command line.

The format of the command line is “--layout presetName”.

If the preset is stored inside a folder in the layout preset, you must specify the 
relative path. If the preset name contains spaces, put the name in quotes. For 
example, --layout “My Folder/presetName”.

An example of setting up the command line:

1) Set up a general window layout, and save it as “Layout 1”.

2) Start WaveLab with the command line --layout “Layout 1“.
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Customizing the Wave Window and the Montage 
Window

You can style the wave/montage window to your liking, by adjusting colors of 
waveforms, background, cursor lines, etc., and changing the look of the ruler and 
other window details. This helps you find your way through the audio file or audio 
montage.

Customizing can be done in the following ways:

• By changing the default style.

• By assigning different styles, according to specific conditions. For example, a 
certain file type or a certain file name.

Default colors are provided, but you can also define custom colors. You can copy 
and paste colors to transfer colors between various parts of the wave/montage.

Assigning Custom Colors to the Wave Window or the Montage 
Window

PROCEDURE

1. Depending on whether you want to customize the colors of the wave window 
or the montage window, do the following:
• In the Audio Files workspace, select Options > Audio file editing 

preferences, and select the Style tab.

• In the Audio Montage workspace, select Options > Colors.

2. Select the part from the Parts list.

3. Specify a color using the color picker or the RGB fields.

4. Click OK.
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Assigning Custom Colors According to Conditions

You can have different color schemes automatically applied to different clips, 
according to their names or properties of their audio files.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

If you redefine colors, be careful not to choose colors that cause some elements to 
disappear. For example, when having black marker lines on a black background.

PROCEDURE

1. Depending on whether you want to customize the colors of the wave window 
or the montage window, do one of the following:
• In the Audio Files workspace, select Options > Audio file editing 

preferences, and select the Style tab.

• In the Audio Montage workspace, select Options > Color.

2. Depending on the workspace you are in, do one of the following:
• In the Audio file editing preferences dialog, on the Style tab, select one of 

the Conditional options from the menu at the top of the dialog.

• In the Audio montage colors dialog, in the Parts list, select one of the 
Custom entries.

3. Specify a color using the color picker or the RGB fields.

4. In the This style is used if these conditions apply section, specify the 
conditions.

5. Click OK.

Copying Color Settings

You can copy the color settings of one part, or all parts of a custom color schema.

• To copy a color setting, select the part from which you want to copy the color, 
and select Copy color. Then select the part to which you want to copy the 
color, and select Paste.

• To copy all color settings of a custom color setting, drag the name of a custom 
color setting onto another custom color name, and click OK.
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Audio Montage Colors Dialog

In this dialog, you can specify custom colors to clips and parts of a clip in the 
montage window.

In the Audio Montage workspace, select Options > Colors.

Parts list

Shows parts that can be colorized. Click a part to edit the color.

Undo all

Undoes all changes that have been made since this dialog was opened.

Undo

Undoes the last change.

Hide

Hides the selected part.

Change both channels

It is possible to make separate color settings for the left and the right side of 
stereo clips. If this option is activated, settings for the left side of a clip are 
automatically mirrored on the right side, and vice versa.

Color picker

Lets you select the color for the selected part. Click the surrounding circle to 
select the hue. Click in the triangle to adjust the saturation and lightness.

Red/Green/Blue

Lets you specify the red, green, and blue components of the RGB color 
spectrum.

Copy color

Copies the current color to the clipboard.

Paste

Pastes the color from the clipboard.
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This style is used if these conditions apply

Lets you define conditions under which a certain color style is applied.

File extension is any of

If this option is activated, the color style is applied to clips referencing a file 
with the specified extension. Separate extensions with a “;” character.

Name contains any of these keywords

If this option is activated, the color style is applied to clips with certain 
keywords in their name. Separate keywords with a “;” character.

Sample rate is in the range

If this option is activated, the color style is applied to clips referencing a file 
having a sample rate within the specified range.

Bit resolution is in the range

If this option is activated, the color style is applied to clips referencing a file 
having a bit resolution within the specified range.

Number of channels is

If this option is activated, the color style is applied to clips having the specified 
number of channels.

Color Elements in the Audio Montage Workspace

You can assign custom colors to various elements of the Audio Montage 
workspace.

In the Audio Montage workspace, select Options > Colors.

Clip Colors

The following clip types are available:

Crossfade region

Allows you to set the background color for overlapping clip sections.

Default

The default colors, used for clips for which you have not selected any specific 
color.

Locked

The colors used for all fully locked clips.

Muted

The colors used for all muted clips.

Custom

These options correspond to the items on the color submenus. These can be 
renamed, and you can also set up conditions for when these should be 
automatically applied.
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The following color elements are available:

Background top/bottom (normal/selected/selected range)

The background colors of the clip for selected and unselected clips, and the 
selection range). The resulting display backgrounds are gradient fades from 
the top colors to the bottom colors.

Waveform (normal/selected/selected range)

The waveform color for selected and unselected clips, and the selection 
range.

Waveform outline (normal/selected/selected range)

The color of the waveform outline for selected and unselected clips, and the 
selection range).

Edge

The left and right edge of the clip.

Edge (selected)

The left and right edge if the clip is selected.

Edge (selected range)

The left and right edge if within a selection range.

Axis (level zero)

The color of the horizontal dotted line in the middle of a clip, indicating zero 
level.

Axis (half level)

The color of the horizontal dotted lines halfway up and down from the middle 
of a clip, indicating 50 % level.

Channel separator (stereo clip)

The line dividing the two sides in a stereo clip.

Clip name

The name label of the clip.

Focused clip name

The name label of the focused clip.

Focused clip name background

The name label background of the focused clip.

Miscellaneous

Background top/bottom

The background colors of the track view for area without a clip.

Background (selected range) top/bottom

The background colors in selected ranges.
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Cursor (edit)/Cursor (edit, no focus)/Cursor (playback)

The color of the corresponding cursor.

Marker line

The color of the marker lines in the audio montage.

Cue point line/End cue point line

The color of the vertical dotted cue point lines and end cue point lines.

Marker line (source)

The color of marker lines from the source montage window. The marker lines 
are displayed, when the option Show/Hide source’s ruler and markers is 
activated on the Functions menu of the Clips window.

Time ruler (source)

The color of the source ruler. The source ruler is displayed, when the option 
Show/Hide source’s ruler and markers is activated on the Functions menu 
of the Clips window.

Time grid lines

The color of the time grid if activated in the menu of the time ruler.

Audio Files Colors Dialog

This tab in the Audio file editing preferences dialog allows you to specify custom 
colors to parts of the wave window.

In the Audio Files workspace, select Options > Audio file editing preferences, 
and select the Style tab.

Styles list

Lets you select the default style and conditional styles.

Parts list

Shows parts that can be colorized. Click a part to edit the color.

Hide (for certain parts only)

Hides the selected part.
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Dotted line (for certain parts only)

Changes the line to a dotted line.

Transparency (for certain parts only)

Lets you edit the degree of transparency of the selected element.

Element size (for certain parts only)

Lets you edit the size of the selected element.

Change both channels

Allows you to make separate color settings for the left and the right side of 
stereo file. If this option is activated, settings for the left side of a file are 
automatically mirrored on the right side, and vice versa.

Change both main view and overview

Allows you to make separate color settings for the main view and the 
overview. If this option is activated, settings for the main view are automatically 
mirrored on the overview, and vice versa.

Color picker

Lets you select the color for the selected part. Click the surrounding circle to 
select the hue. Click in the triangle to adjust the saturation and lightness.

Red/Green/Blue

Lets you specify the red, green, and blue components of the RGB color 
spectrum.

Copy color

Copies the current color to the clipboard.

Paste

Pastes the color from the clipboard.

This style is used if these conditions apply

Lets you define conditions under which a certain color style is applied.

File extension is any of

If this option is activated, the color style is applied to files with the specified 
extension. Separate extensions with a “;” character.

Name contains any of these keywords

If this option is activated, the color style is applied to files with certain 
keywords in their name. Separate keywords with a “;” character.

Sample rate in the range

If this option is activated, the color style is applied to files having a sample rate 
within the specified range.

Bit resolution is in the range

If this option is activated, the color style is applied to files having a bit 
resolution within the specified range.
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Number of channels is

If this option is activated, the color style is applied to files having the specified 
number of channels.

Color Elements in the Audio Files Workspace

You can assign custom colors to various elements of the Audio Files workspace. 
Depending on the selected element, additional settings can be made for 
transparency, appearance, or whether a line should be dotted, for example.

In the Audio Files workspace, select Options > Audio file editing preferences, 
and select the Style tab.

Left/Right Channel

Waveform

The waveform color.

Waveform (selected)

The waveform color of the selected part of the waveform.

Waveform outline

The outline color of the waveform.

Waveform outline (selected)

The outline color of the selected part of the waveform.

Background top

The color of the background top.

Background top (selected)

The color of the selected part of the background top.

Background bottom

The color of the background bottom.

Background bottom (selected)

The color of the selected part of the background bottom.

Waveform main axis

The color of the waveform main axis and its style.

Waveform 50 % axis

The color of the waveform 50 % axis and its style.

Waveform Elements

Channel separator

The color of the channel separator line.
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Cursor (edit)

The color of the edit cursor, its width, and transparency.

Cursor (edit, no focus)

The color of the edit cursor for a file that does not have the focus.

Cursor (play)

The color of the cursor during playback.

Marker line

The color of the marker lines and an optional transparency.

End of file indicator

The color of the end of the file indicator.

Time ruler style

The color of the time ruler and its style.

Time ruler font

The color of the font on the time ruler and the font size.

Level ruler style

The color of the level ruler, its style, and transparency.

Level ruler font

The color of the font on the level ruler and the font size.

About Customizing Shortcuts

In WaveLab, you can control many functions via shortcuts to speed up your 
workflow. You can edit existing shortcuts, and create new shortcuts.

Most shortcuts are restricted to a specific context, so you can reuse the same 
shortcut combination in different workspaces. The exception is the Master Section 
where all shortcuts are global to the application. Shortcuts that cannot be edited 
are grayed out. The shortcuts that you created are displayed in blue in the editor.

You can create new shortcuts in the following ways:

• By specifying a key sequence of between one to three keys that must be 
pressed in a certain order to invoke the operation.

• By specifying a MIDI command. You need a MIDI controller device connected 
to your PC/Mac for this to work.

• By specifying keywords.
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Keywords

Keywords are custom words that are assigned to a function in the Customize 
commands dialog or to a preset in the Shortcut Definitions dialog. When entering 
the keyword in the Keyword field command bar, the corresponding function is 
triggered.

EXAMPLE

For example, you want to have a quick way to normalize audio to -1 dB.

1) In the Audio Files workspace, select Process > Normalize level.

2) Set the Peak level to -1 dB.

3) Click the Presets field, and select Save as.

4) Enter a name for the preset, and activate Create shortcut for applying the 
preset.

5) Click Save.

6) In the Shortcut Definitions dialog, enter “norm_1” as a Keyword, and click 
OK.

7) Now, to trigger the preset, enter “norm_1” in the Keyword field, and press 
[Return].

Editing Shortcuts

You can see the list of all shortcuts in the Customize commands dialog, and edit 
and assign shortcuts in the Shortcut Definitions dialog.

NOTE

The Customize commands dialog provides a different command set for each 
menu or dialog.

• To open the Shortcut Definitions dialog, where you can edit the shortcuts, 
double-click the shortcut text or its placeholder, or select a command and 
click Edit shortcut.

• You can enter a keyword which you can later use to activate a command by 
typing it into the Keyword field command bar.

• You can assign a command to be triggered by an external MIDI controller. For 
example, this could be useful for issuing transport commands from your midi 
keyboard. You can specify a sequence of up to three midi events. The MIDI 
shortcut is displayed in the MIDI Trigger column.
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• You can define one key shortcut, and/or one MIDI shortcut, and/or one 
keyword per command. Each shortcut can be a sequence of up to four 
keystrokes or three MIDI events. A keyword can be of any length.

• To reset some or all types of shortcuts to their factory defaults use the Reset 
button.

Defining Key Sequences

You can define key sequences for a keyboard and for a MIDI controller.

PREREQUISITE 

If you want to define a key sequence for a MIDI controller, make sure that your MIDI 
controller is connected to your PC/Mac, and selected in the Remote devices 
dialog.

On Mac, commands for the main menus must be of a single key command.

When using multiple key stroke commands, make sure that the key commands do 
not interfere with each other. For example, when you have one shortcut [Shift]+L, M 
and define another to be [Shift]+L, the second shortcut has no effect.

PROCEDURE

1. In any workspace, select Options > Customize commands, or select 
Customize commands when available in tool windows or other places in 
WaveLab.

2. In the customize commands list, select the command for which you want to 
define a key sequence, and click Edit shortcut, or double-click the Key 
sequence column of the corresponding command.

3. In the Shortcut Definitions dialog, click in the 1st key stroke field, and press 
the buttons that you want to use as the key sequence.

4. Optional: Define up to 4 key sequences for the command.

5. Click OK.

RESULT 

When you now press the keys/buttons specified in the dialog, the corresponding 
operation is performed. The key strokes must be executed one after the other.
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Selecting a MIDI Controller for Defining MIDI Commands

Before you can use MIDI commands, you have to select a MIDI controller.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > Remote 
devices.

2. On the Device editing tab, select the MIDI shortcuts for menus option from 
the pop-up menu at the top.

3. Select Active, to activate the selected device.

4. From the In-Port menu, select a MIDI input port.

Customizing Menus and Command Bars

You can individually decide whether to hide or show a certain option in the menu 
and/or command bar icons. This way you can customize menus and command bars 
by removing unwanted commands.

PROCEDURE

1. In any workspace, select Options > Customize commands, or select 
Customize commands when available in tool windows or other places in 
WaveLab.

2. Do the following:
• To show a certain command in menus, activate the checkbox in the Menu 

column for corresponding command.

• To show a certain command in the command bar, activate the checkbox in the 
Bar column for the corresponding command.

3. Click OK.
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Generating a List of All Shortcuts

You can generate an HTML file or print out a list that contains all shortcuts for the 
active command set.

PREREQUISITE 

When you want to print out the list, make sure a printer is connected to your system.

PROCEDURE

1. In any workspace, select Options > Customize commands, or select 
Customize commands when available in tool windows or other places in 
WaveLab.

2. Click Summary, and select one of the following options:
• To open the Print preview dialog, from which you can print out the list of all 

shortcuts, select Print preview. For Print preview to be available, a printer 
must be connected.

• To open the list of all shortcuts in the HTML file format in the standard browser, 
select HTML report.

Customize Commands Dialog

This dialog allows you to customize your own shortcuts for WaveLab. It shows a list 
of already assigned shortcuts for WaveLab commands and menu options.

In any workspace, select Options > Customize commands, or select Customize 
commands when available in tool windows or other places in WaveLab.
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Search by

Allows you to select the part of the commands list in which the search is 
performed.

Search field

Allows you to search for a command.

Use wildcards

If this option is activated, the wildcard characters “*” and “?” can be used.

“*” substitutes zero or more characters, and “?” substitutes any character.

For example, if Search by keyboard shortcut is selected, type “*” to display 
all the commands already associated with a shortcut.

Expand/Collapse

Expands/collapses the folder tree.

Commands list

Shows all commands and their shortcuts for the active command set.

Reset

Resets the commands to the factory setting.

Summary

Opens a menu from which you can generate a list of all commands and their 
shortcuts either in HTML or as a print out.

Edit shortcut

Opens the Shortcut Definitions dialog where you can edit the shortcuts of 
the selected command.
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Shortcut Definitions Dialog

This dialog allows you to define your own customized shortcuts for a particular 
function. These custom shortcuts can speed up your workflow in WaveLab.

In the Customize commands dialog, select a command, and click Edit shortcut.

Key Sequence

1st key stroke

Lets you select the first key of an optional sequence of up to 4 keys. Set the 
focus in the key stroke field, then press the key combination. If nothing is 
displayed, a key is not allowed in this context.

2nd/3rd/4th key stroke (optional)

Lets you select additional keys that have to be triggered to execute the 
command. The command is only executed if this key event happens after the 
first one.

Clear

Erases all key event fields.

Keyword

Lets you type in a keyword that invokes the command.

MIDI event sequence

This section is only available if a MIDI input port has been specified in the main 
preferences in WaveLab.
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1st event

Lets you select the first MIDI event of an optional sequence of up to 4 MIDI 
events. Set the focus in the event field, then trigger the MIDI event from your 
MIDI controller.

2nd/3rd event (optional)

Lets you select additional MIDI events that have to be triggered to execute the 
command. The command is only executed if this MIDI event happens after the 
first one.

Clear

Erases all MIDI event fields.

Plug-ins Organization

WaveLab comes with various plug-ins, and additional plug-ins can be added. To 
remain an overview about the plug-ins that are relevant to your project, you can 
organize your plug-ins in groups.

In the Organize tab of the Plug-in settings, you can organize how your plug-ins 
appear on menus in the program. In the plug-ins list, you find subfolders, 
representing groups of plug-ins.

How you organize your effects is up to you, but initially, they are categorized by 
vendor, category, favorite plug-ins, and recently used plug-ins.

In case 32 bit and 64 bit versions of WaveLab are used on the same system, their 
settings are shared. An exception to this rule are the following options in the Plug-in 
settings dialog:

• Additional VST plug-in folders

• Ignore plug-ins located in the following subfolders

This is because 32-bit plug-ins cannot be used in WaveLab 64 bit and reciprocally.

Deactivating Plug-ins

You can deactivate plug-ins. This is useful if you have plug-ins installed that you do 
not want to use in WaveLab.

Many of the DirectX plug-ins, for example, do not apply to audio and are of no 
relevance to WaveLab. By disabling these, you make it easier to find the plug-ins 
that you want to use in WaveLab.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > Plug-in 
settings.

2. Select the Organize tab.
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3. In the plug-ins list, navigate to the plug-in that you want to deactivate, or use 
the search field.

4. Deactivating the checkbox in for the corresponding plug-in.
• When selecting multiple plug-ins, you can deactivate all of them with a single 

click.

• To deactivate the plug-in from the plug-in selection menus, deactivate the 
checkbox in the Effect column.

• To deactivate the plug-in in the Dithering panel of the Master Section, 
deactivate the checkbox in the Dither column.

• To deactivate the plug-in in the Post-Processing panel of the Master Section, 
deactivate the checkbox in the Post column.

Adding Plug-ins to the Favorites Menu

You can add plug-ins that you are using regularly to the Favorites menu of the 
plug-in selection menu.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > Plug-in 
settings.

2. Select the Organize tab.

3. In the plug-ins list, navigate to the plug-in that you want to add to the favorites, 
or use the search field.

4. Specify whether to add or remove a plug-in from the favorites, by 
activating/deactivating the checkbox in for the corresponding plug-in in the 
Favorites column.

NOTE

If the Favorites menu is empty, it does not appear in plug-in selection menus.

Customizing Plug-in Groups

In any workspace, except the Podcast workspace, select Options > Plug-in 
settings, and open the Organize tab. Here, you can customize the appearance and 
sorting of plug-ins.

• To update the tree with the following changes, click the Show changes 
button.



Customizing
Plug-ins Organization

637

• To create a custom category for a plug-in, click the Custom category column 
for the corresponding plug-in, and enter a new category name. 
[Alt]/[Option]-click to delete the category. Use the character “|” to create 
subcategories, for example, “Folder-1|Folder-2”. If you select multiple 
plug-ins, the category name is set to all selected plug-ins.

• To rename a custom category, click the existing category name in the Custom 
category column, and select Rename category from the pop-up menu. In the 
Rename category dialog, enter the name of the category that you want to 
rename in the Find field, and the name that you want to replace it with in the 
Replace with field. Then click Replace all.

• The category labels used to create the hierarchy are supplied by the plug-in 
manufacturers. To change the category name, in the Category renaming 
table, click in the Original column, and select the category that you want to 
rename. Then click in the Modified column, and enter a new name.

• To change the sorting of plug-in groups, in the Customize section, in the 
sorting menu, select whether to sort by category or by vendor. If a plug-in 
does not publish a vendor name or category, the name of the enclosing 
plug-in folder on disc is used as vendor name or category, if it is not the VST 
plug-in root folder.

• To group all plug-ins that start with the same prefix in one submenu, activate 
Create submenus based on prefixes, and specify the number of plug-ins 
that must start with the same prefix. Only if this number is reached, a submenu 
is created.

• To group plug-ins in a single submenu if their number is below a specified 
value, activate Compress hierarchy, and specify the threshold. A tree is 
flattened to a single submenu if the number is below the threshold. This 
prevents having small submenus.

• To activate the Recently used category, activate Submenu with recently 
used plug-ins, and specify the maximum number of recently used plug-ins 
that should be displayed in this category.

• You can make the Recently used category global to all places or individual 
for each context, for example, for the Master Section, audio montage track, 
audio montage clip, or batch processors. To make the Recently used 
category individual for each context, activate Independent for each context.

Adding Additional VST Plug-ins

You can specify folders where additional VST plug-ins can be found. This is useful 
if you are using third-party VST plug-ins that you do not want to store in the 
standard VST folder.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > Plug-in 
settings.

2. Select the General tab.
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3. In the Additional VST plug-in folder (WaveLab specific) section, click the 
folder icon, and navigate to the folder that contains the VST plug-ins that you 
want to add.

4. Click OK.

Excluding Plug-ins

You can specify a list of plug-ins that WaveLab does not open.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > Plug-in 
settings.

2. Select the General tab.

3. In the Do not load the following plug-ins section, type in the name of the 
plug-in that you do not want to open:
• Enter the exact file name, without path and without file extension.

• Enter one name per line.

• If you put “*” in front of the name, any plug-in that contains the name is ignored.

4. Click OK.

Replacing Missing Plug-ins

When opening an audio montage and some plug-ins for tracks or clips are missing, 
you can select plug-ins to replace the missing plug-ins.

PROCEDURE

1. In the Missing plug-ins dialog, click the Replacement column, and select a 
replacement for the plug-in displayed in the Original column.
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2. If you want the settings to be persistent for the future, activate Save the 
replacements as default.

3. Click OK.

Plug-in Settings Dialog

In this dialog, you can access a number of options for managing your VST plug-ins.

You can specify where WaveLab should search for your VST plug-ins and which 
ones it should ignore. It also allows you to choose how your VST plug-in knobs 
respond to mouse interactions and how frequently graphics are updated.

If you use your own file structure to organize and store VST plug-ins, this dialog 
allows you to have full control over which ones are loaded or not. This is useful if you 
want to disable a particular plug-in that you suspect of not functioning properly, or 
if you want to ignore certain plug-ins you never want to use with WaveLab.

In any workspace, except the Podcast workspace, select Options > Plug-in 
settings.

General Tab

Search standard VST plug-in shared folders

If this option is activated, WaveLab searches VST plug-ins in the default VST 
plug-in folders.



Customizing
Plug-ins Organization

640

Information about the searched folders

Clicking on the info icon opens a window in which you can see in which 
folders WaveLab searched for plug-ins when it was launched. When you 
cannot find a plug-in in WaveLab, this helps you to determine whether you 
have specified the correct folder, for example.

Additional VST plug-in folders (WaveLab specific)

Lets you specify additional folders where VST plug-ins can be found.

Ignore plug-ins located in the following subfolders (separate folder names 
with a semicolon)

Lets you specify folder names, that WaveLab skips when searching VST 
plug-ins.

Do not load the following plug-ins

Lets you specify plug-ins that WaveLab does not open. Enter the file names, 
without path and without file extension. Write each plug-in on a new line.

If you put the character * in front of the name, any plug-in that contains the 
name is ignored.

Force plug-in detection at next launch

Analyzes the plug-ins when launching WaveLab the next time. To reduce the 
start time of WaveLab, the plug-ins are not analyzed every time WaveLab is 
started. However, WaveLab keeps a list of plug-ins and updates this 
automatically when a date or size change is detected.

Keep plug-ins in memory until WaveLab ends

If this option is activated, the plug-ins are kept in memory even when no longer 
used. This results in a faster reopening of plug-ins. However, if you use many 
plug-ins, too much memory could be used after a certain time, which slows 
down the application.

Faster graphics refreshing (consumes more computer power)

Refreshes the graphics of VST plug-ins more quickly.

VST plug-in knobs

Lets you set the mode for using knobs in plug-ins. You can set the mode to 
Circular, Circular with relative movement, and Linear.
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Organize Tab

Plug-ins list

Displays the hierarchy of the plug-ins in WaveLab. Here, you can specify 
whether a plug-in should be available from the plug-in selection menus and/or 
the Dithering panel and Post-Processing panel of the Master Section. You 
can add plug-ins to the Favorites list, create shortcuts for plug-ins, specify 
custom categories, and decide whether to use the generic user interface or 
the plug-in specific user interface.

Expand/Collapse

Expands/collapses the folder tree.

Search field

The search field allows you to filter the plug-ins list for names.

• Click in the search field, and enter the text that you want to search for.

• To switch the focus from the search field to the plug-ins list, press the 
arrow down key.

• To switch the focus from the plug-ins list to the search field, press 
[Ctrl]/[Command]-[F].

Only show new plug-ins

If this option is activated, only the recently detected plug-ins are displayed.

Clear “new” status

Resets the “new” status of the recently detected plug-ins.

Display changes

Regenerates the plug-in tree according to the current settings.



Customizing
Plug-ins Organization

642

Sorting

Determines how the plug-ins should be primarily hierarchized. The other 
parameters act on that hierarchy.

Compress hierarchy

Merges all items into a single submenu if a submenu and all its submenus 
contain less than a certain number of plug-ins (Threshold).

Compress hierarchy - Threshold

Represents the minimum number of items that are needed to compress the 
hierarchy.

Create submenus based on prefixes

Creates a submenu that is labeled as the prefix, when several items in a 
submenu start with the same prefix.

Create submenus based on prefixes - Threshold

Represents the minimum number of items that must start with the same prefix 
that are needed to create submenus that are labeled as the prefix.

Merge single submenus

Merges submenus that contain another submenu with only a single item in it.

Category renaming

The category labels used to create the hierarchy are supplied by the plug-in 
manufacturers. In this section you can change the category name. This can 
also be useful to merge two categories into one, by renaming these two 
categories with the same name.

Submenu with recently used plug-ins

Toggles if the Recently used submenu is shown or hidden.

Submenu with recently used plug-ins - Maximum size

Determines the maximum number of plug-ins in the Recently used submenu.

Submenu with recently used plug-ins - Independent for each context

Determines whether the Recently used submenu is global to all places where 
plug-ins can be selected, or if it is local to each context.

Ignored plug-ins

Opens the Ignored Plug-ins dialog, where you can see the plug-ins that 
were not loaded. This dialog lets you instruct WaveLab to rescan these 
plug-ins at the next launch. This is fast than a full rescan.

Number of plug-ins

Shows the number of plug-ins that are available in WaveLab.
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Variables and Text Snippets

You can define and use custom variables and text snippets, or use auto variables in 
various places in WaveLab, for example, in the Meta-data dialog.

Custom variables can be used to replace codes with a specified text in meta-data 
saved within audio files. For example, you can define the variable %proj% to be 
replaced by the name of the current project. A custom variable can also contain 
references to other variables. For example, %comment% can be defined as 
“%proj% started on @Date1@”.

Variable codes are replaced with the variable values at the time of file writing. For 
example, when the meta-data is saved inside an audio file.

Auto variables are automatically set by WaveLab. For example, the current date, the 
sample rate, or the bit resolution.

Text snippets can be used to define words that you are using regularly when filling 
in text fields. These can be inserted into a text field over the Text Snippets menu.

Certain auto-variables depend on contexts. For example:

• CD Text variables are only used when rendering an audio montage.

• Auto-variables that relate to CD tracks are only used when rendering CD 
tracks from an audio montage. To render CD tracks, activate one of the 
following options in the Render dialog: Selected CD track, One region (CD 
Track markers), or Regions (track markers).

If a variable is used in a wrong context, it is replaced with a blank.

NOTE

Variable codes are case sensitive. It is recommended to select the codes from the 
menus.
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Defining Variables and Text Snippets

You can create new variables and text snippets, and define values for them.

PROCEDURE

1. In any workspace, except the Podcast workspace, select Options > 
Variables and Text Snippets.

2. Do one of the following:
• On the Custom Variables tab, click the plus icon to add a new variable, or 

double-click an existing variable that you want to modify.

• On the Text Snippets tab, click the plus icon to add a new definition, or 
double-click an existing definition that you want to modify.

3. For custom variables, enter the name, code, and value for the variable. For text 
snippets, enter the text.

4. If you are done defining variables and text snippets, click OK.

Applying Variables and Text Snippets

You can apply custom variables, auto variables, and text snippets at various places 
in WaveLab.

PREREQUISITE 

Define custom variables and text snippets.

PROCEDURE

1. In a value field, click the arrow icon. When several fields are selected, 
right-click to access the pop-up menu.

2. From the menu, select a custom variable, auto variable, or text snippet.

The variable or text snippet is added to the value field.
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Variables and Text Snippets Dialog

This dialog allows you to define custom variables, see the auto variables, and define 
text snippets that are local to the project that you are working on.

In any workspace, except the Podcast workspace, select Options > Variables and 
Text Snippets.

Plus icon

Adds a new variable/text snippet.

Minus icon

Removes the selected variable/text snippet.

About Scripting

WaveLab contains a powerful scripting language to help advanced users create 
their own scripts to automate tasks. Using basic scripts can be useful for 
automating repetitive editing tasks such as trimming and cropping a file at specific 
times, for example.

You can write scripts that perform other basic editing commands, apply offline 
processing, place markers, and display information about the active file. You can 
script commands to edit the active audio file or the active audio montage. If you have 
some experience of programming with modern scripting languages you should have 
no problem writing utility scripts for WaveLab.

The WaveLab Scripting language is based on ECMAScript, with the addition of 
WaveLab specific commands. If you have had any experience with Javascript, 
Jscript, or Actionscript the code syntax will be familiar to you as they are all based 
on ECMAScript, too. If not, there is a large amount of teaching and reference 
material available online. A Javascript reference such as www.w3schools.com or a 
book like JavaScript: The Definitive Guide are good places to start.
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To begin exploring the WaveLab specific functions available see WaveLab 
Scripting Language chapter. For a broader look at the complete subset of 
commands available see ECMAScript Reference.

On Windows, there is an additional scripting interface, to control WaveLab from 
external applications using VBScript or JScript. The documentation of this interface 
can be found in the folder: WaveLab 8.5\Tools\Windows Scripting\

This topic is about scripts executed from within WaveLab.

Writing and Executing a Script

PROCEDURE

1. In the Audio Files workspace or the Audio Montage workspace, open the 
Script window.

2. Type your script directly in the Script window or copy and paste it from an 
external text editor.
A script can also be written in another text editor, and loaded via the File menu or by 
copying it into the Script window.

3. To run the script, click the Execute script icon.

RESULT 

The script runs if there are no syntax errors. Any errors appear in a dialog box to help 
you debug them.

NOTE

There are several free utility text editors that are context sensitive. This means that 
they can color and highlight parts of your code to make it more readable. If you use 
one of these for writing and editing your scripts, choose Javascript as the editing 
language and/or save the file with a .js (Javascript) extension.

Script Window

This window allows you to write and execute scripts in WaveLab.

The inbuilt text editor helps you when writing scripts by highlighting the different 
parts of the script with colors, making it more readable.
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In the Audio Files workspace or the Audio Montage workspace, select Workspace 
> Specific tool windows > Script.

New

Creates a new script. The current script is closed as only one instance can be 
opened at a time.

Open

Opens a dialog where you can select a script.

Save

Saves the current script.

Save as

Allows you to save the current script with a different name and in a different 
location.

Execute script

Executes the script.



Customizing
About Scripting

648

Using the Log Window When Scripting

It is a good idea to begin scripting by writing some simple scripts that output some 
text to the Log window.

The goal of the following example is to output a simple text message in the Log 
window.

PROCEDURE

1. In the Audio Files workspace or the Audio Montage workspace, open the Log 
window.

2. Copy and paste the following script into the Script window.
//output the number of samples in the active wave as text in the log window.

logWindow.printInfo("This file has " + activeWave.size() + " samples");

NOTE

Any lines of a script that begin with two forward slashes // are comments, and 
are ignored when the script is executed.

3. Execute the script.

RESULT 

In the Log window, the number of samples used in the active file is displayed.

WaveLab Scripting Language

The scripting language of WaveLab varies slightly between workspaces. This 
chapter briefly introduces you to the commands that are available in each 
workspace and to those that are global.

Global Commands

These are scripting commands that are available in all scripting contexts.

logWindow

Object representing the Log window, where you can output messages to. If 
the Log window is not open, all functions are ignored.

printInfo(messageString)

Outputs an informal message to the Log window. The message argument 
must be typed as a string. For example, between inverted commas:

logWindow.printInfo("start");

printWarning(messageString)

Outputs a warning message to the Log window.
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printError(messageString)

Outputs an error message to the Log window.

clear()

Clears the Log window. For example:

logWindow.clear();

Audio Files Workspace

activeWave

Object representing the active audio file. Many functions make use of presets 
as an argument. For example, the normalize() function accepts a preset as 
an argument:

activeWave.normalize("myPreset");

The advantage is that you do not need to specify many parameters in your 
scripts, instead you can use the corresponding dialog to define the settings 
of a particular function, and then save them as a preset file. Since each type 
of preset is unique, you do not need to specify a full path name to the preset. 
Only specifying the preset name is enough, there is no need for its file 
extension. Since presets can also be stored in a subfolder, you can use a 
relative path name if necessary.

For example, if you want to normalize a file using a preset you have defined in 
the Level Normalizer dialog and saved in a subfolder as a preset, it looks like 
this:

activeWave.normalize("mySubFolder/myPreset");

All audio processing functions operate on the selected audio range. If there is 
no selection the whole file range will be processed, if this option is activated 
in the Audio file editing preferences. If the cursor or selection is in one 
channel only, only that channel is processed. In other words, it operates 
exactly the same as if you were applying a process from within a dialog.

If the preset is a factory preset, you must specify this using the prefix 
%factory%/. For example:

activeWave.normalize("%factory%/EBU R-128 
Recommendation")

All positions and sizes are measured in sample units. If you want to specify a 
time range in another unit you need to convert it from samples:

var twoSeconds = 2 * activeWave.sampleRate();

size()

Returns the number of samples in the audio file.

sampleRate()

Returns the sample rate of the audio file.

numChannels()

Returns the number of channels of the audio file.
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cursorPosition()

Returns the current cursor position in samples.

setCursorPosition(pos)

Sets the current cursor position at a certain sample location.

selectionStart()

Returns the index of the first selected sample, or -1 if there is no selection.

selectionSize()

Returns the number of selected samples.

select(presetName)

Loads the audio range preset and applies its setting to the active audio file.

select(start, size)

Selects a number of samples, starting from a given position.

setCursorChannel(channel)

Sets the cursor position to a new channel. Use leftCh, rightCh or allCh as 
arguments.

addMarker(type, name, comment)

Adds a marker at the cursor position. Possible values for type are:

• generic

• temporary

• cdTrackStart

• cdTrackEnd

• cdTrackFrontier

• cdTrackIndex

• loopStart

• loopEnd

• muteStart

• muteEnd

• playbackStarter

• regionStart

• regionEnd

• errorStart

• errorEnd

• correctionStart

• correctionEnd

For example:

activeWave.addMarker(generic, "SomeName", 
"SomeComment");
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findNextMarkerPosition(posStartSearch, type)

Searches for the next marker of type, from a given position. Returns the marker 
position if any is found, or -1.

normalize(presetName)

Loads the normalizer preset and applies its setting to an audio range.

normalizeLoudness(presetName)

Loads the loudness normalizer preset and applies its setting to an audio 
range.

normalizePan(presetName)

Loads the pan normalizer preset and applies its setting to an audio range.

silence(presetName)

Loads the silence preset and applies its setting to an audio range.

timeStretch(presetName)

Loads the time stretch preset and applies its setting to an audio range.

pitchCorrection(presetName)

Loads the pitch correction preset and applies its setting to an audio range.

pitchQuantize(presetName)

Loads the pitch quantize preset and applies its setting to an audio range.

changeLevel(dbValue)

Changes the level of the selected audio range.

fadeIn(shape) and fadeOut(shape)

Applies a fade on the selected audio range. Shape can be one of the 
following:

• linear

• sinus

• squareRoot

• sinusoid

• log

• exp

• expp

For example:

activeWave.fadeIn(squareRoot);

levelEnvelope(presetName)

Loads the envelope shape and applies its setting to an audio range.

morph(presetName)

Loads an effect morphing preset and applies it according to its settings.

invertPhase()

Inverts the phase of the samples in the audio range.
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reverse()

Reverses the order of the samples in the audio range.

cut()

Cuts the selected audio range.

copy()

Copies the selected audio range.

paste()

Pastes audio from the clipboard to the current cursor position.

trim()

Trims the selected audio range.

remove()

Deletes the selected audio range.

removeSmooth()

Deletes the selected audio range and cross fades the resulting regions 
together.

mute()

Mutes the selected audio range.

swapChannels()

Swaps stereo channels.

undo()

Undoes the last command.

removeDcOffset()

Removes the DC offset in the audio range.

readSamples(channelIndex, from, numSamples)

Reads a number of samples from a given cursor position, on a given channel:

• Use 0 for the left channel

• Use 1 for the right channel

This returns the result in an array. For example:

buf = activeWave.readSamples(0, 20, 100); // read 100 
samples on left channel, from sample index 20

for (i = 0; i < 100; i++)

{

logWindow.printInfo(buf[i]);

}
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Audio Montage Workspace

size()

Returns the number of samples in the audio montage.

sampleRate()

Returns the sample rate of the audio montage.

numChannels()

Returns the number of output channels of the audio montage.

numTracks()

Returns the number of tracks of the audio montage.

cursorPosition()

Returns the current cursor position (in samples).

setCursorPosition(pos)

Sets the current cursor position at a certain sample location.

selectionStart()

Returns the index of the first selected sample, or -1 if there is no selection.

selectionSize()

Returns the number of selected samples.

select(presetName)

Loads the audio range preset and applies its setting to the active audio 
montage.

select(start, size)

Selects a number of samples, starting from a given position.

setFocusedTrack(index)

Sets the focused track.

addMarker(type, name, comment)

Add a marker at the cursor position. Possible values for type are:

• generic

• temporary

• cdTrackStart

• cdTrackEnd

• cdTrackFrontier

• cdTrackIndex

• loopStart

• loopEnd

• muteStart

• muteEnd

• playbackStarter
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• regionStart

• regionEnd

• errorStart

• errorEnd

• correctionStart

• correctionEnd

For example:

activeWave.addMarker(generic, "SomeName", 
"SomeComment");

findNextMarkerPosition(posStartSearch, type)

Searches for the next marker of type, from a given position. Returns the marker 
position if any is found, or -1.

insertMonoTrack(where)

Adds a mono audio track at index 'where'.

insertStereoTrack(where)

Adds a stereo audio track at index 'where'.

insertClip(iTrack, timePosition, fileName, autoShift)

Creates a clip from 'fileName', inserts it in track 'iTrack', on the timeline at 
position 'timePosition', and shifts other clips to make room according to the 
following autoShift parameters:

• autoShiftNo

• autoShiftTrack

• autoShiftGlobal

This function returns the ID of first created clip, or 0.

clipWithName(name)

Returns the ID of first clip with name 'name', or 0.

clipWithFile(name)

Returns the ID of first clip that refers to 'fileName', or 0.

firstClip()

Returns the first audio montage clip ID, or 0 if the audio montage is empty.

nextClip(clipId)

Returns the ID of the clip stored after 'clipId', or 0. Clips are not sorted in any 
special order. Using both firstClip and nextClip allow to access all audio 
montage clips.

clipName(clipId)

Returns the name of the clip identified by 'clipId'.

clipPosition(clipId)

Returns the timeline position of the clip identified by 'clipId'.
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clipSize(clipId)

Returns the size of the clip identified by 'clipId'.

setClipName(clipId, name)

Rename the clip identified by 'clipId'.

setTrackName(index, name)

Rename the track identified by 'index'.

moveClip(clipId, newPos)

Move on the timeline the clip identified by 'clipId'.

resizeClip(clipId, qlonglong newSize)

Resize the clip identified by 'clipId'. The size will be limited by the audio file 
referenced by the clip.

setClipDefaultFadeIn(clipId)

Sets the default fade-in shape and time for the clip identified by 'clipId'.

setClipDefaultFadeOut(clipId)

Sets the default fade-out shape and time for the clip identified by 'clipId'.

undo()

Undoes the last command.

ECMAScript Reference

The scripting language of WaveLab is based on the ECMAScript scripting 
language, as defined in standard ECMA-262. Microsoft's JScript, Netscape's 
JavaScript, and Adobe's Actionscript are also based on the ECMAScript standard.

If you are not familiar with the ECMAScript language, there is a large amount of 
teaching and reference material available online.

This reference page contains a list of all ECMAScript objects, functions and 
properties supported by the WaveLab scripting system. These are available in any 
scripting context but are not WaveLab specific.

Some basic scripting examples are included below so you can see the scripting 
syntax in context. These scripts will work if you copy, paste, and execute them in a 
script window.

Supported ECMAScript Subset

Global Object

Values

• NaN
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• Infinity

• undefined

• Math

Functions

• eval(x)

• parseInt(string, radix)

• parseFloat(string)

• isNaN(number)

• isFinite(number)

• decodeURI(encodedURI)

• decodeURIComponent(encodedURIComponent)

• encodeURI(uri)

• encodeURIComponent(uriComponent)

Objects

• Object

• Function

• Array

• String

• Boolean

• Number

• Date

• RegExp

• Error

For example

//Test if a value is not a number

var isNumber = isNaN("this is a string");

//Print the result in the log window

logWindow.printInfo(isNumber); //Traces "true" because it is a String

//Convert a string to a number

var numStr = "2.345";

var num = parseFloat(numStr);

//Print the result in the log window
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logWindow.printInfo(num);

//Encode a string into an internet valid ASCII String

var str = "a sentence with spaces";

var encodedStr = encodeURI(str);

logWindow.printInfo(encodedStr);

Function Object

Prototypes

• toString()

• toLocaleString()

• valueOf()

• hasOwnProperty(V)

• isPrototypeOf(V)

• propertyIsEnumerable(V)

Functions

• toString()

• apply(thisArg, argArray)

• call(thisArg [, arg1 [, arg2, ...]])

For example

//Create a new custom marker Object

function customMarker(name, comment, timeSecs)

{

this.name=name;

this.comment=comment;

this.timeSecs=timeSecs;

}

//Create a new instance of the custom marker

var myMarker=new customMarker("A custom marker", "My custom marker 
comments",5);

//Use prototype function to add a new property to it

customMarker.prototype.samples = null;

myMarker.samples = activeWave.sampleRate() * myMarker.timeSecs;
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//Trace the results in the log window

logWindow.printInfo(myMarker.name);

logWindow.printInfo(myMarker.samples);

Array Objects

Functions

• toString()

• toLocaleString()

• concat([item1 [, item2 [, ...]]])

• join(separator)

• pop()

• push([item1 [, item2 [, ...]]])

• reverse()

• shift()

• slice(start, end)

• sort(comparefn)

• splice(start, deleteCount[, item1 [, item2 [, ...]]])

• unshift([item1 [, item2 [, ...]]])

For example

//Create an empty array

var a = new Array();

//Add some items to it

a.push("first array item");

a.push("next array item", "last array item");

//Print them out in the Log window

logWindow.printInfo(a.toString());

//Call the Array's reverse function

a.reverse();

//View the results in the Log window

logWindow.printInfo(a.toString());
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String Objects

Functions

• toString()

• valueOf()

• charAt(pos)

• charCodeAt(pos)

• concat([string1 [, string2 [, ...]]])

• indexOf(searchString ,position)

• lastIndexOf(searchString, position)

• localeCompare(that)

• match(regexp)

• replace(searchValue, replaceValue)

• search(regexp)

• slice(start, end)

• split(separator, limit)

• substring(start, end)

• toLowerCase()

• toLocaleLowerCase()

• toUpperCase()

• toLocaleUpperCase()

For example

//Create a string variable

var str = new String("WaveLab is a powerful editing tool");

//Make it all upper case

var capsStr = str.toUpperCase();

//View the results in the Log window

logWindow.printInfo(capsStr);

Boolean Objects

Functions

• toString()
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• valueOf()

For example

//Test if an equation is true or false

var isTrue = (1 + 1 == 3);

//Convert the Boolean to a String and trace in the Log window

logWindow.printInfo(isTrue.toString());

Number Objects

Functions

• toString(radix)

• toLocaleString()

• toFixed(fractionDigits)

• toExponential(fractionDigits)

• toPrecision(precision)

For example

//Convert a number into exponential notation

var num = new Number(13.3714);

//Show the result in the Log window

logWindow.printInfo(num.toExponential());

Math Objects

Values

• E

• LN10

• LN2

• LOG2E

• LOG10E

• PI

• SQRT1_2

• SQRT2
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Functions

• abs(x)

• acos(x)

• asin(x)

• atan(x)

• atan2(y, x)

• ceil(x)

• cos(x)

• exp(x)

• floor(x)

• log(x)

• max([value1 [, value2 [, ...]]])

• min([value1 [, value2 [, ...]]])

• pow(x, y)

• random()

• round(x)

• sin(x)

• sqrt(x)

• tan(x)

For example

//Get a random number from 0 to 1

var r = Math.random();

//Print it out in the log window

logWindow.printInfo(r);

//Trace out Pi in the log window

logWindow.printInfo(Math.PI);

Date Objects

Functions

• toString()

• toDateString()

• toTimeString()
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• toLocaleString()

• toLocaleDateString()

• toLocaleTimeString()

• valueOf()

• getTime()

• getFullYear()

• getUTCFullYear()

• getMonth()

• getUTCMonth()

• getDate()

• getUTCDate()

• getDay()

• getUTCDay()

• getHours()

• getUTCHours()

• getMinutes()

• getUTCMinutes()

• getSeconds()

• getUTCSeconds()

• getMilliseconds()

• getUTCMilliseconds()

• getTimeZoneOffset()

• setTime(time)

• setMilliseconds(ms)

• setUTCMilliseconds(ms)

• setSeconds(sec [, ms])

• setUTCSeconds(sec [, ms])

• setMinutes(min [, sec [, ms]])

• setUTCMinutes(min [, sec [, ms]])

• setHours(hour [, min [, sec [, ms]]])

• setUTCHours(hour [, min [, sec [, ms]]])

• setDate(date)

• setUTCDate(date)

• setMonth(month [, date])
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• setUTCMonth(month [, date])

• setFullYear(year [, month [, date]])

• setUTCFullYear(year [, month [, date]])

• toUTCString()

For example

//Create a new date object

var d = new Date();

//Print it out in the log window

logWindow.printInfo(d);

//Get just the hours

logWindow.printInfo(d.getHours());

RegExp Objects

Functions

• exec(string)

• test(string)

• toString()

For example

//Create a new regular expression defining a 5 digit number

var reg = new RegExp(/^\d{5}$/);

//Test a string with it to see if it contains a 5 digit number

var isFiveDigit = reg.test("12345");

//Trace the result to the log window

logWindow.printInfo(isFiveDigit);

Errors Objects

Values

• name

• message
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Functions

• toString()

Types of native errors available

• EvalError

• RangeError

• ReferenceError

• SyntaxError

• TypeError

• URIError

Basic Scripting Example

Below is a basic scripting example which uses some WaveLabscripting functions 
to perform some simple operations on an audio file in the Audio Files workspace.

The script first displays information about the audio file, fades in the start and fades 
out the end of the file, and then adds ten markers at 1 second intervals. Examine it 
line by line and read the comments for each operation to see how it works.

/* To run this script:

- open an Audio File that is at least 10 seconds long

- open the Log window via the Global menu

- copy and paste this script into the Script window

- choose Functions > Execute Script */

//clear the log window

logWindow.clear();

//show some information about the active wave file in the log window

logWindow.printInfo("This wave file has " + activeWave.size() + " samples");

logWindow.printInfo("Its sample rate is " + activeWave.sampleRate());

logWindow.printInfo("It has " +activeWave.numChannels() + " channels");

//Work out how long the file is in seconds and round to a whole number

var lengthSecs = activeWave.size() / activeWave.sampleRate();

logWindow.printInfo("This wave file is " + lengthSecs + " seconds long");

//Select the first 10 seconds of the file

activeWave.select(0, 10 * activeWave.sampleRate());

//Trim the file to 10 seconds
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activeWave.trim();

//select the first two seconds of the file and fade it in

activeWave.select(0, 2 * activeWave.sampleRate()); //sample rate multiplied 
by two = 2 seconds

activeWave.fadeIn(linear);

//select the last two seconds of the file and fade it out

activeWave.select(activeWave.size() - (2 * activeWave.sampleRate()), 
activeWave.size());

activeWave.fadeOut(linear);

//loop through 10 times and add a marker each second

for (i = 1; i <= 10; i++)

{

//work out next cursor time

var nextCursorPosition = i * activeWave.sampleRate();

//set cursor position forwards by a second

activeWave.setCursorPosition(nextCursorPosition);

//add a generic marker at the next cursor position and give it a name and comment

activeWave.addMarker(generic, "Marker "+i, "A comment for marker "+i);

//write some information about the new marker

var cursorTimeSecs = nextCursorPosition/activeWave.sampleRate();

logWindow.printInfo("created a new marker at " + cursorTimeSecs + " 
seconds");

}
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Configuring the Software

You can configure WaveLab according to your needs.

About Global Preferences

Global preferences are preferences that apply throughout WaveLab. Before 
starting to work with WaveLab, edit these preferences to set up WaveLab 
according to your needs.

Global Preferences Dialog

This dialog allows you to view and change options that are common throughout 
WaveLab.

In any workspace, select Options (WaveLab menu on Mac) > Global 
preferences.
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General Tab

This tab allows you to change the location of settings files and the user interface 
language. You must restart the application for changes to take effect.

Language

Allows you to select the user interface language.

Setting location - Common for all users

Shares the preferences settings with all users on this computer.

Setting location - Independent for each user

Lets each user on this computer make their own preferences settings.

Setting location - In the application folder (portable installation)

Saves settings in the application directory. Use this option to install the 
application on a portable device.

Setting location - Specific folder

Allows you to save the settings in a specified folder.

Setting location - Open active setting folder

Opens the folder that is currently used to save settings. This way you know 
where the settings are stored and you can back up the settings.

Synchronization settings - Master folder

Lets you specify where the reference settings are saved.

Synchronization settings - Synchronize at every launch

If this option is activated, the settings are synchronized whenever WaveLab is 
launched.



Configuring the Software
About Global Preferences

668

Synchronization settings - Synchronize at next launch

If this option is activated, the settings are synchronized the next time that 
WaveLab is launched.

Synchronization settings - Preferences handling

Determines how to synchronize the preferences, that is, all settings except the 
presets. You can either ignore or mirror the preferences.

Synchronization settings - Preset handling

Determines how to synchronize the presets that are saved in the master 
folder. The following options are available:

• Ignore presets: the presets are not synchronized.

• Mirror presets: the presets will be restored from the master folder, 
regardless of their time stamp. Any additional local presets are deleted.

• Import new presets: the presets in the master folder that are 
unavailable on the computer are imported.

• Update old presets: as above, but existing presets are overwritten if a 
newer version is found in the master folder.

Ignore the following preset folders (separate them with a semicolon)

Lets you specify which preset folders you want to ignore when synchronizing 
the settings. For example, to ignore the VST Audio Connection settings, add 
"VST Audio Connections" to the field.

Synchronization settings - Update master

If you click this button, the settings that were used when launching WaveLab 
are used to update the master folder.

IMPORTANT

This procedure should only be run by the system administrator if multiple 
WaveLab stations are used.
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Display Tab

This tab allows you change many aspects of the user interface that apply across the 
whole application. These options provide useful information and usability functions 
but can be deactivated to streamline the interface.

Style

Overall style

Changes the overall look of the application.

Button size in main command bars

Increases the button size in the command bars, but not in the tool windows.

Window transparency

Sets the degree of transparency for windows that have this option activated.

Use textured background for non-blocking windows

If this option is activated, you can easily determine whether a dialog is modal 
or not.

Show icons in menus

If this option is activated, icons are displayed in textual menus.

Miscellaneous options

Maximum number of items in Recent File menus

Sets the maximum number of files that are listed in menus.

Maximum number of items in Recent File Manager

Sets the maximum number of files that are listed in the Recent File Manager.

Maximum number of items in the Recent Folders menu

Sets the maximum number of files that are listed in the Recent Folder menus.



Configuring the Software
About Global Preferences

670

Show tips when mouse stays over buttons

If this option is activated, tooltips are displayed when you move the mouse 
cursor over markers or command bar buttons.

When available, tips have a link to “What is this” information

If this option is activated, tooltips contain “What is this” information if 
available.

Hide top level windows when the application is not active (Windows only)

If this option is activated, all floating windows are automatically hidden when 
another application becomes active. When deactivated, floating windows 
remain on top of other application windows.

Workspaces

Tab Groups - Show tab if there is a single window

If this option is activated, the tabs are always visible, even if there is only one 
active file.

Tab Groups - Show tabs in classical mode (MDI)

If this option is activated, the tabs are always visible in classical mode (MDI). 
(Audio Files workspace only)

Tab Groups - When closing the active tab

Determines the behavior of the program when closing the active tab.

Docked Tool Windows - Auto-fold title bars of tabbed windows/Auto-fold title 
bars of isolated windows

If these options are activated, the title bar of docked tool windows is partially 
hidden to provide slightly more space to the contents area. A thin bar remains 
visible.

To unfold a title bar, simply move the mouse cursor over the thin bar.

Display active file path in title bar

Displays the file path of the active file in the title bar of the workspace.

Display status bar

If this option is activated, a status bar is displayed at the bottom of each 
workspace. The status bar is used to show hints, for example, when moving 
the mouse in a menu.

Use Floating Window Switcher

Activates the Floating Window Switcher.

Auto-hide if active workspace has a switcher

If this option is activated, the Floating Window Switcher is only visible in the 
following cases:

• WaveLab is not active and there is no blocking dialog. The apparent 
switcher allows you to re-activate WaveLab easily or to drag a file onto 
it to open it in WaveLab.

• The active workspace does not have a Switcher bar.
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Keep visible when switching to other applications

Keeps the Floating Window Switcher visible when WaveLab is not the active 
application.

Include Audio Montage

Enables the button that activates the Audio Montage workspace in the 
Floating Window Switcher.

Include Batch Processor

Enables the button that activates the Batch Processors workspace in the 
Floating Window Switcher.

Include Podcast

Enables the button that activates the Podcast workspace in the Floating 
Window Switcher.

Include Control Window

Enables the button that activates the Control Window workspace in the 
Floating Window Switcher.

Semi-transparent

Displays the Floating Window Switcher semi-transparent, according to the 
settings in the Window transparency field in the Style section.

Formats tab

This tab allows you to adjust settings for some of the audio formats and units that 
WaveLab uses.

Use AES17 standard for RMS values

Determines how RMS values are reported.

• If this option is activated, the displayed level for a full scale sine audio 
file is 0 dB. This follows the AES17 standard.

• If this option is deactivated, the displayed level for a full scale sine audio 
file is -3 dB.

Pitch of A3 (used in frequency-to-note conversions)

Sets the reference pitch in WaveLab. The frequency-to-note conversions take 
this pitch into account.
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MIDI note display

The options in this section allow you to choose whether to display the different 
key values in WaveLab with the pitch or the MIDI note number of the key. In 
musical notation, keys are denoted according to their pitch. For example, C3 
means the note C in the third octave.

Each key corresponds to a MIDI note number from 0 to 127. For example, key 
C3 corresponds to the MIDI note number 48. MIDI note numbers make it 
possible for samplers to automatically map samples to the correct keys.

MIDI note display - Numeric style

Determines the format for MIDI notes that are displayed as numbers.

MIDI note display - Middle C (note #60)

Determines the key convention for the MIDI note range (0-127).

MIDI note display - Display

Determines how MIDI notes are displayed throughout the application.

CSV delimiter

In several places of WaveLab, it is possible to export information in the CSV 
text format. This option lets you set the character that you want to use as a 
text delimiter to achieve the best match with the 3rd-party-software that 
imports these files.

CD Writing tab

This tab allows you to set a number of parameters for CD writing.

Use burnproof

Fixes possible buffer underrun errors automatically, provided the CD writer 
supports this technology.

Allow disc overflow

Allows WaveLab to attempt writing more data (max. 2 minutes) than the 
official capacity of the disc.

Maximum Audio CD size

Allows you to specify the maximum length for a CD. A warning message will 
appear if the project exceeds this length.



Configuring the Software
About Global Preferences

673

The standard maximum length is 74 minutes.

DDP Creation - Format 1.0/Format 2.0

Determines which format to create when producing DDP files for an audio 
project.

Write checksum file (CRC-32)

If this option is activated, a file called “CHECKSUM.CHK” is added to the 
DDP files that are created on the hard drive. The checksum contains the 
CRC32 checksums of the created DDP files.

Write checksum file (MD5)

If this option is activated, a file called “CHECKSUM.MD5” is added to the 
DDP files that are created on the hard drive. The checksum file contains the 
MD5 checksums of the created DDP files.

Write log file

If this option is activated, a text file called “gear.log” is added to the DDP files 
that are created on the hard drive. The log file contains the trace of all 
operations.

Warn if files already exist

If this option is activated, a warning message is displayed if files are about to 
be overwritten in the specified destination folder.

Options Tab

This tab allows you to control application-wide start-up options. You can also reset 
the default message boxes.

Show logo screen on start-up

Determines whether the WaveLab logo is displayed during initialization.

Make the Background Task Monitor visible when a task starts

If this option is activated, the Background tasks window opens when a 
background task starts.
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Play a sound when a long task completes

Allows you to select a sound that is played when a task finishes.

Minimum duration

Specifies how long a task must be for a sound to be triggered at its end. 
When the task duration is shorter, no sound is triggered.

Path and name of the audio file

Lets you select which audio file is played. On Windows systems, the file 
format must be WAV, and on Mac OS, the file format can be WAV or AIFF.

Only play the sound for blocking tasks

If this option is activated, the sound only plays if the task prevents you from 
working elsewhere in WaveLab. For example, background tasks do not 
produce a sound upon their completion.

Alternative external file browser

Allows you to specify an alternative external file browser that opens when you 
use the Reveal folder in Windows Explorer/Mac OS Finder or Reveal files 
in Windows Explorer/Mac OS Finder options in WaveLab.

If the application needs a special command line formatting, you can specify it 
in the Command line field. Use the %1 symbol as a place holder for the file 
or folder that you want to browse to.

Interval for the zoom key command

Allows you to specify how much the waveform zoom factor changes each time 
that the zoom shortcuts are triggered. Higher values allow you to zoom in and 
out more quickly but with bigger steps.

Reset default answers

Resets all message box options to their default settings. For example, the “Do 
not show again” options are cleared.

Global Shortcuts Tab

This tab allows you edit key sequences for shortcuts that are available across all 
workspaces.



Configuring the Software
Audio File Editing Preferences Dialog

675

Search by

Allows you to select the part of the commands list in which the search is 
performed.

Search field

Allows you to search for a command.

Use wildcards

If this option is activated, you can use the wildcard characters “*” and “?” for 
searching.

“*” substitutes zero or more characters, and “?” substitutes any character.

For example, if Search by keyboard shortcut is selected, type “*” to display 
all the commands that are already associated with a shortcut.

Expand/Collapse

Expands/collapses the folder tree.

Commands list

Shows all commands and their shortcuts.

Reset

Resets the commands to their default setting.

Summary

Opens a menu from which you can generate a list of all commands and their 
shortcuts either in HTML or as a print out.

Edit shortcut

Opens the Shortcut Definitions dialog where you can edit the selected 
shortcut.

RELATED LINKS

About Customizing Shortcuts on page 628
Multi-User Settings on page 683

Audio File Editing Preferences Dialog

This dialog allows you to define settings for editing in the Audio Files workspace. 
However, these settings also effect other parts of WaveLab. You can choose 
defaults for editing and playback, adjust the visual appearance of the waveform 
displays, and determine how WaveLab works with audio and peak files.

In the Audio Files workspace, select Options > Audio file editing preferences.
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Editing Tab

Save view settings in companion file

If this option is activated, zoom settings, ruler settings, and optionally the 
Master Section preset that is associated with the audio file are saved in a 
companion file. When the audio file is reopened, these settings are reused. 
Deleting a companion file does not alter the audio contents.

Save in an independent folder

If this option is activated, the companion file is not saved in the same folder as 
the related audio file but in a specific folder that you can choose.

Edit

Opens the Folders dialog, where you can specify where to save the 
companion files.

Open new audio file windows with overview

If this option is activated and you open an audio file, the overview is also 
displayed.

Overview: passive range indicator also covering the waveform

If this option is activated, the range indicator that is displayed in the time ruler 
of the overview also covers the waveform area. Unlike the time ruler indicator, 
it is passive and cannot be modified.

Analog waveform emulation at sample level zooming

If this option is activated and a waveform is zoomed at the sample level in the 
timeline, an analog emulation of the waveform is displayed.

Auto zoom for overviews

If this option is activated on opening a file, the zoom of the overview is set to 
display the whole file.

Display file extension on tabs

If this option is activated, tabs display file names with their extension. For 
example, “piano.mp3” instead of “piano”.

Number of seconds to display on opening

Lets you specify how much time to display when opening an audio file for the 
first time. WaveLab converts this time to the appropriate zoom factor.
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Whole audio file

If this option is activated, the horizontal zoom is set to display the whole file.

Select all channels with the mouse

If this option is activated when you select a range with the mouse in a stereo 
file, both channels are selected. To select the channels individually, press 
[Shift] while selecting. To switch from one channel selection to the other, 
press [Tab].

Process whole file if there is no selection

If this option is activated and a process is to be applied to an audio file, the 
whole file is processed if there is not audio selection. In the same situation, if 
the option is deactivated, a warning appears.

Playback scrubbing - Restrict to Play Tool

If this option is activated, this function only works if the Play Tool is used.

Playback scrubbing - Sensitivity

Lets you set the micro audio loop duration that is performed when you move 
the mouse cursor over the time ruler.

Snap selection to zero-crossing - Do not snap at high zoom factors

If this option is activated, snapping does not occur if the waveform is 
displayed at a high zoom factor.

Snap selection to zero-crossing - Scan range

Lets you define how far WaveLab can search a zero-crossing point in the left 
and right direction.

Default fade/crossfade

Lets you specify the default duration and shape of the fades or crossfades 
that WaveLab creates automatically in certain processes.

File Tab

Warn when opening a file with a malformed header

If this option is activated, a message appears when you open a file with a 
corrupt header. This might be a damaged file, or a file that is not properly 
formatted by another application.
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If this option is deactivated, WaveLab tries to open the file, but you are not 
informed about possible issues.

Support RF64 file format

If this option is activated, WaveLab creates WAV files that can be larger than 
2 GB. This file type is not supported by all applications.

Default sample rate for files without header

Lets you specify the sample rate of audio files that do not have a header 
describing this property.

Create optimized audio file headers

If this option is activated, WaveLab increases the WAV file headers to a value 
that slightly improves disk access. Although this is a standard procedure, 
some applications cannot open these files correctly.

Save audio files in the background

If this option is activated, WaveLab saves audio files in the background so that 
you can continue working.

Write markers in WAV file header

If this option is activated, markers are written in WAV file headers. Thus, the 
markers are always available even if you open the files in another application.

Write markers in separate file

If this option is activated, markers are written in a separate file (.MRK 
extension) that is saved in the same folder as the audio file. This allows to 
support markers in file formats that do not support markers, or that do not 
support markers in a way that is as advanced as WaveLab.

Save Error and Correction markers

If this option is activated, Error and Correction markers are saved with the 
other markers.

Create peak files in an independent folder

If this option is activated, peak files are not saved in the same folder as the 
related audio file. You can specify the folder location by clicking Edit, and 
specifying a folder.

Create peak files when writing audio files

If this option is activated, WaveLab writes peak files while rendering audio 
files.

Delete peak files when closing audio files

If this option is activated, peak files are deleted after use. This saves disk 
space but means that audio files take longer to open.

Allow opening of dual-mono files

Allows to recognize multiple selected mono files as stereo files according to 
their name, and edit them as one stereo file.

Dual-mono file identification - Name creation/Name interpretation

You can define a name creation pattern and up to 7 name interpretation 
patterns for different naming schemes.
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• Name interpretation patterns (up to 7) are used by WaveLab to identify 
the original channel of mono files through an analysis of their name.

• Name creation pattern (only 1) is used by WaveLab to add the specified 
suffix to audio files when creating dual-mono files. The default suffix is 
“-L” and “-R”.

Dual-mono file identification - Left channel ID/Right channel ID

These IDs are the character sequences that are used to identify the left and 
right channel files in their name. For example, “_l” for the left channel and “_r” 
for the right channel.

Dual-mono file identification - Suffix

In this mode, the channel ID string must be located at the end of the file name.

Dual-mono file identification - Advanced

In this mode, the channel ID string can be located anywhere in the file name 
and not only as a suffix. For this purpose, a name pattern must be defined. This 
name pattern must have a {capture} section.

The default suffixes for recognizing dual-mono files are as follows:

• -L/-R

• _L/_R

• .L/.R

This mode is only available for input patterns.

Style Tab

This tab allows you to specify custom colors to parts of the wave window.
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Audio Montage Preferences Dialog

In the Audio montage preferences, you can set up general parameters for all audio 
montages or the active audio montage only.

In the Audio Montage workspace, select Options > Audio montage preferences.

Active Audio Montage Tab

The settings made on this tab apply only to the active audio montage.

Default gap

Sets the default gap for clips. This setting is used for separating clips, for 
example, when you insert several clips at the same time.

DVD-Audio resolution

Defines the DVD-Audio resolution for writing the audio montage to 
DVD-Audio. You can select 16 bit (more room available) or 24 bit (best 
quality).

Implicit relative folder to store audio files

Sets the path, which is relative to the audio montage folder, to the folder 
where audio files are implicitly created. For example, if you enter “Data” in the 
text field, a folder named “Data” is created in the audio montage folder. Files 
in this folder are not deleted when you close the audio montage.

If no folder is defined, the audio montage folder is used.

Reset plug-ins when starting playback

If this option is activated, all active effect plug-ins are instructed to release all 
samples in their memory when you start playback.

Use this option if you experience clicks or noises when the playback position 
reaches the start of a clip that contains effects (typically reverb or delay). 
Otherwise you should leave this option deactivated since it could lead to a 
delayed response upon playback start.

It is recommended to deactivate this option, unless you experience shortage 
of memory that is caused by too many plug-ins.
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Reset plug-ins before rendering

If this option is activated before rendering, all active plug-ins are reloaded.

Use this option if you experience clicks or noises in rendered audio files.

Auto save Master Section preset

Automatically saves the current Master Section preset along with the audio 
montage when closing the audio montage. This is recommended when you 
work on one audio montage at a time.

All Audio Montages Tab

The settings made on this tab apply to all audio montages.

Maximum number of backups

Specifies how many previous versions are kept.

Auto save

Automatically saves the audio montage in intervals which you can specify in 
the time field below.

History - Clear after each saving

Clears the memory that is used by the operation history each time the audio 
montage is manually saved. Any operations that is performed before saving 
can no longer be undone.

History - Group similar operations

Groups similar successive operations into one undo operation.

For example, if you move a clip in several steps until you find the right position, 
you can undo each step as usual. However, as soon as you perform another 
operation, all the previous steps are considered as one entry in the undo 
history. This saves memory and facilitates work, since you do not have to undo 
every step to revert to the clip’s original position.

Closing of unmodified montages

Defines the actions that are performed, when closing an unmodified audio 
montage. An audio montage is only tagged as modified if the audio-related 
data has been modified. The following options can be selected:
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• Save and update time stamp: The audio montage is saved to 
remember its current state (for example, selection and zoom), and the 
time stamp of its file is updated.

• Save and retain time stamp: The audio montage is saved to remember 
its current state, and the time stamp of its original file is retained.

• Do not save: The audio montage is not saved and therefore not 
preserved for the next launch of WaveLab.

Display indications of possible actions

Displays hints in the status bar of the audio montage about what you can do 
at the current mouse position in the montage window.

Display envelope tooltip while editing

Displays a tooltip when you click and drag an envelope element. The tooltip 
indicates the value of the performed editing.

Synchronize super clip size and sub-montage size

If this option is activated, the length of super clips is adjusted if the length of 
the corresponding audio file is changed.

Basic amplitudes for nudging - Time/Gain

Defines the amount with which elements are adjusted when you modify them 
with the nudge commands. This is used for nudging the position of objects or 
edges and for nudging volume gains.

CD cue-sheets - Write audio file names without path

If this option is activated, audio files are referenced without a path when 
generating CD cue-sheets.

Settings Management

You can make some reference settings available to other WaveLab installations. 
These settings can then be used by other WaveLab stations to keep the settings in 
sync on different computers.

PROCEDURE

1. In any workspace, select Options (WaveLab menu on Mac) > Global 
preferences, and select the General tab.

2. In the Setting location section, specify where to store the settings.

3. Click OK.
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Multi-User Settings

If you use multiple WaveLab stations in your studio, in your school, as 
administration, etc., you can set up one WaveLab station to be the master station. 
The shared preferences and presets of this station can then be used by other slave 
stations.

These settings can be stored on the local network, for example.

If the administrator updates these settings, the different WaveLab stations can 
synchronize with the master settings. You can also use this feature for single 
computers to back up a reference setting and revert to this if necessary.

The settings in the General tab of the Global preferences dialog are not 
synchronized. These are stored for each user in the startup.ini (Windows) or 
startup.plist (Mac).

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

Settings cannot be synchronized between PC and Mac.

RELATED LINKS

Global Preferences Dialog on page 666

Setting Up a Multi-User Setup

You can use the settings that you have made on a master WaveLab station for other 
slave WaveLab stations.

PROCEDURE

1. Set up a WaveLab station with all settings and presets that you want to use 
on other WaveLab stations.

2. Assign read-only access to the settings folder of the master WaveLab station.

3. Open WaveLab on another station for which you want to use the master 
settings.

4. In any workspace, select Options (WaveLab menu on Mac) > Global 
preferences, and select the General tab.

5. In the Synchronization settings section, set up the Master folder, specify 
when the settings should be synchronized, and specify whether to include the 
preferences and/or presets.

6. Click OK, and close WaveLab.
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7. Copy the startup.ini (Windows) or startup.plist (Mac) of the slave WaveLab 
station to the settings folder of the other WaveLab stations, except the master 
WaveLab station.
This avoids having to make the above procedure on each slave station.

RESULT 

All slave WaveLab stations use the settings of the master WaveLab station.

About External Tools

You can configure external tools to work with WaveLab. You can pass command 
line arguments to the external tools so that they can process the current file/folder 
on which you are currently working on, or the settings folder of WaveLab.

This function is useful if you want to edit an audio file in another application, or if you 
want to compress all your audio files into a backup ZIP file, for example.

Once you have defined an external tool, you can run it by selecting it from the Tools 
menu in the Audio Files workspace, Audio Montage workspace, or Batch 
Processors workspace.

NOTE

An external tool only works within the workspace in which it is defined. Thus, each 
type of workspace can have its own external toolkit.

RELATED LINKS

Configuring External Tools on page 684
Configure External Tools Dialog on page 685

Configuring External Tools

To be able to select external tools from the Tools menu, you must configure them.

PROCEDURE

1. In the Audio Files workspace, the Audio Montage workspace, or the Batch 
Processors workspace, select Tools > Configure external tools.

2. Click the plus icon to create a new tool definition.

3. Specify a title, the path to the external tool that you want to run, arguments, 
an initial folder, and a comment.
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4. Optional: Add more tool definitions by clicking the plus icon again.

5. When you are finished, click OK.

RESULT 

The external tool is configured and can be selected from the Tools menu.

Once an external tool has been configured you can assign a shortcut from the 
Customize commands dialog on the Options menu.

RELATED LINKS

Configure External Tools Dialog on page 685
About Customizing Shortcuts on page 628

Running an External Tool After a Batch Process

You can specify external tools to be run after completing the batch process. For 
example, you can run a tool to zip the output files or an FTP tool to upload the files 
to the internet.

PREREQUISITE 

Configure the external tool that you want to run after the batch process.

PROCEDURE

1. In the Batch Processors workspace, select the External Tool tab.

2. From the On success, run external tool menu, select the external tool that 
you want to run after the batch process.

RELATED LINKS

Configuring External Tools on page 684
Configure External Tools Dialog on page 685

Configure External Tools Dialog

In this dialog you can configure external tools to work with WaveLab. For example, 
you can run a tool to zip the output files or an FTP tool to upload the files to the 
internet.

In the Audio Files workspace, the Audio Montage workspace, or the Batch 
Processors workspace, select Tools > Configure external tools.

List of external tools

The list of all external tools that are currently defined, in the order as they 
appear in the Tools menu.

Create item

Creates a new tool definition.
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Delete item

Deletes the selected tool definition from the list.

Move selected item one position up/down

Moves the selected tool definition one position up/down.

Title

The title for the tool definition.

Application

The full path and file name of the application to run.

Arguments text field

The list of arguments to pass to the application. Normally, there is at least one 
argument, for example, the active file name in WaveLab. The required 
arguments depend on the application to run. Refer to the related 
documentation.

The arguments must be separated from one another by a space character. If 
an argument contains space characters, it must be enclosed in quotes.

Predefined arguments can be selected via the menu button next to this text 
field.

Arguments button

This button opens a menu with a list of predefined arguments. These are 
placeholders that are replaced by actual values at runtime.

For example, if you select from the menu Active file name with its path, the 
following text is inserted: $(FilePathAndName). At runtime, this symbol could 
be replaced by C:/Music/Piano.wav, presuming that this is the active file in 
WaveLab.

Initial folder

Specify the reference path that might be needed by the application. This path 
depends on the application. This setting is optional.

Comment

Allows you to add comments.

Before execution - Warn if active file has unsaved changes (Audio Files 
workspace and Audio Montage workspace only)

If this option is activated, WaveLab warns you if the active file has unsaved 
changes before running the external tool.

Before execution - Close active file (Audio Files workspace and Audio 
Montage workspace only)

If this option is activated, WaveLab closes the active file before running the 
external tool. This is useful if the tool is meant to modify the active file.
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Before execution - Stop playback (Audio Files workspace and Audio Montage 
workspace only)

If this option is activated, WaveLab stops playing back the file before running 
the external tool. This is useful if the tool is meant to play back the file.

RELATED LINKS

About External Tools on page 684
Configuring External Tools on page 684
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Plug-in Reference

Steinberg created Virtual Studio Technology (VST) to allow effect plug-ins to be 
integrated with audio editors, such as WaveLab. VST uses Digital Signal 
Processing (DSP) to closely simulate the effects of familiar recording studio 
hardware in software.

A vast number of plug-ins are available, from freeware to high-end commercial 
products.

The order of processing is significant. You can change the order in which effects 
are processed by moving the effect icons by dragging them between slots. 
WaveLab provides slots for up to ten plug-ins.

Most plug-ins provide a custom GUI, often displaying controls similar to the physical 
switches and knobs of audio hardware. Other plug-ins rely on the host application 
for their UI.

Built-in Plug-ins

These plug-ins use a plug-in format of WaveLab, and cannot be used with other 
applications.

• WaveLab specific plug-ins can only be used in the Master Section and in 
batch processes. However, some WaveLab effects are also included as VST 
plug-ins, available as track or clip effects in audio montages.

• You can specify which plug-ins should be available in the Effects pane and 
Dithering pane of the Master Section by using the Plug-in settings dialog.

• Only certain built-in plug-ins can be used as master effects when a 
multichannel configuration is used in the audio montage. Note that all 
channels in the Master Section are affected equally.
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Crystal Resampler

This plug-in is a professional sample rate converter providing exceptional 
transparency and preservation of the frequency content. It is only available in the 
Master Section.

NOTE

This plug-in is very CPU consuming, especially in high quality modes.

Sample rate (6-384 kHz)

Defines the output sample rate while the input sample rate is determined by 
the sample rate of the active audio file or audio montage.

Quality

Defines the quality of the algorithm that is used (Preview (fast), Standard, 
High, Ultra (slow)). In Preview mode the CPU load is much lower than in 
Ultra mode but the sound quality of the resulting audio is also lower.

Ducker

This plug-in lets you control (modulate) the volume of clips placed on a track with 
the signal of one or more clips placed on the next adjacent track below it. The 
Ducker plug-in can only be used as a clip effect in the audio montage.

It uses the Route to... options that can be found on the Track menu. You can use 
mono or stereo tracks for both the modulating and the upper track.

Threshold

Sets the loudness threshold that triggers the Ducker. Clips on the modulator 
track with levels above the threshold will cause the level of a clip on the upper 
track to be lowered.
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Damping

Sets the amount of level reduction that is applied to the clip on the upper 
track.

Fall time

Sets the time it takes for the level to change from 0 dB to the set damping 
level.

Hold time

When the modulating signal falls below the set threshold, this setting 
determines how long the level will stay reduced before it starts rising to normal 
level again.

Rise time

Sets the time after which the reduced level rises to the normal level when the 
modulating signal falls below the set threshold (after the Hold time).

Mix mode

If this is activated, the Ducker outputs a mix of the two tracks. This is only 
useful if the Route to upper track only option has been activated for the 
modulating track. Then this feature can be used for processing several clips 
through the same plug-in chain if more plug-ins have been assigned after the 
Ducker on the upper track.

Note that the mixed output is controlled by the upper track. If this is not playing 
a clip, both of the tracks will be silent.

Leveler

This plug-in is useful for correcting an imbalance or adjusting levels between stereo 
channels, or for mixing down to mono.

Volume Left/Volume Right (-48 dB to 12 dB)

Governs how much of the signal is included in the left and/or right channel of 
the output bus.

Stereo Link (OFF or LINKED)

When set to LINKED, Volume Right delivers the gain that is set for Volume 
Left.

Mix to Mono (OFF or ON)

When set to ON, a mono mix of the stereo channels is delivered to the output 
bus.
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Leveler Multi

This plug-in takes multichannel input and applies a fader equally to all channels.

Volume (-48 dB to 12 dB)

Governs how much gain is applied to the signal before it is routed to the 
output bus.

Peak Master

This is a basic plug-in that minimizes peaks in your audio file, allowing a louder mix 
without clipping. It is useful in taming dynamic instruments.

It is primarily used as a brickwall limiter. For example, you can limit audio peaks 
without altering the rest of the audio signal. In this case, set Input Gain to 0 dB and 
Out Ceiling to 0 dB, to achieve a clip-free audio signal. When used in this way, 
Peak Master is an excellent plug-in to succeed a resampler plug-in, and to proceed 
a dithering plug-in.

Input Gain

Values range from -12 dB to 24 dB.

Out Ceiling

This is the maximum level of the output signal. Values range from -18 dB to 
0 dB.

Softness

This governs the speed at which the signal becomes unaffected after limiting 
has been triggered on some samples. Values range from -5 to +5.
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Silence

This plug-in provides a simple way of inserting a precise period of silence at the 
start or at the end of an audio file. Use this plug-in to add silence at the end of a file, 
so that the tail of a reverb plug-in does not cut immediately at the end of the file.

Start

Use the slider to insert from 0 to 60,000 ms of silence at the start of the file.

End

Use the slider to insert from 0 to 60,000 ms of silence at the end of the file.

Stereo Expander

This plug-in is a stereo width enhancer that makes a stereo signal sound wider. It 
gives better results from real stereo material, as opposed to mono channels panned 
to different positions in the stereo image.

Width (0 to 100 %)

Higher values result in a greater stereo width. Usually, you set Width to values 
between 0 % and 20 %. Higher values can be used for special effects.

Steinberg VST 3 Plug-ins

In WaveLab there is no limitation to the use of VST plug-ins. They can be used 
wherever plug-ins can be inserted.

• You can specify which VST plug-ins should be available in the Effects pane 
and Dithering pane of the Master Section by using the Plug-in settings 
dialog.

• VST plug-ins have their own preset handling. You can save or load effect 
programs (presets).
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AutoPan

This plug-in is a simple auto-pan effect. It can use different waveforms to modulate 
the left-right stereo position (pan), using manual modulation speed settings.

Rate

Sets the auto-pan speed.

Width

Sets the depth of the auto-pan effect, that is, how far out to the left/right 
speaker the sound should move.

Waveform Shape selector

Allows you to select the modulation waveform. Sine produces a smooth 
sweep. Triangle creates a ramp, that is, a sweep from one speaker to the 
other and then a quick jump back.

Brickwall Limiter

Brickwall Limiter ensures that the output level never exceeds a set limit.

Due to its fast attack time, Brickwall Limiter can reduce even short audio level peaks 
without creating audible artifacts. However, this plug-in creates a latency of 1ms. 
Brickwall Limiter features separate meters for input, output, and the amount of 
limiting. Position this plug-in at the end of the signal chain, before dithering.

Threshold (-20 to 0 dB)

Only signal levels above the set threshold are processed.
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Release (ms)

Sets the time after which the gain returns to the original level when the signal 
drops below the threshold. If the Auto button is activated, Brickwall Limiter 
automatically finds the best release setting, depending on the audio material.

Link

If this button is activated, Brickwall Limiter uses the channel with the highest 
level to analyze the input signal. If the button is deactivated, each channel is 
analyzed separately.

Detect Intersample Clipping

If this option is activated, Brickwall Limiter detects and limits signal levels 
between two samples to prevent distortion when converting digital signals 
into analog signals.

NOTE

Brickwall Limiter is designed for the reduction of occasional peaks in the signal. If 
the Gain Reduction meter indicates constant limiting, try raising the threshold or 
lowering the overall level of the input signal.

Channel Extractor

This plug-in allows you to only keep the left or the right channel of a stereo stream.

Channel

Lets you select whether to keep the left or the right channel of the stereo 
stream.

Chorus

This plug-in is a single-stage chorus effect. It works by doubling the audio that is 
sent into it with a slightly detuned version.
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Rate

If tempo sync is deactivated, this sets the sweep rate.

Width

Determines the depth of the chorus effect. Higher settings produce a more 
pronounced effect.

Spatial

Sets the stereo width of the effect. Turn clockwise for a wider stereo effect.

Mix

Sets the level balance between the dry signal and the wet signal. If the effect 
is used as a send effect, set this to the maximum value as you can control the 
dry/effect balance with the send.

Waveform Shape selector

Allows you to select the modulation waveform, altering the character of the 
chorus sweep. A sine and triangle waveform are available.

Delay

Affects the frequency range of the modulation sweep by adjusting the initial 
delay time.

Filter Lo/Hi

Allow you to roll off low and high frequencies of the effect signal.

Compressor

This plug-in reduces the dynamic range of the audio, making softer sounds louder 
or louder sounds softer, or both.

Compressor features a separate display that graphically illustrates the compressor 
curve shaped according to the Threshold and Ratio parameter settings. 
Compressor also features a Gain Reduction meter that shows the amount of gain 
reduction in dB, Soft knee/Hard knee compression modes, and a 
program-dependent auto feature for the Release parameter.

Threshold (-60 to 0 dB)

Determines the level where Compressor kicks in. Signal levels above the set 
threshold are affected, but signal levels below are not processed.
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Ratio (1:1 to 8:1)

Sets the amount of gain reduction applied to signals over the set threshold. A 
ratio of 3:1 means that for every 3 dB the input level increases, the output level 
increases by only 1 dB.

Soft Knee

If this button is deactivated, signals above the threshold are compressed 
instantly according to the set ratio (hard knee). If Soft Knee is activated, the 
onset of compression is more gradual, producing a less drastic result.

Make-up (0 to 24 dB or Auto mode)

Compensates for output gain loss, caused by compression. If the Auto button 
is activated, the knob becomes dark and the output is automatically adjusted 
for gain loss.

Attack (0.1 to 100 ms)

Determines how fast Compressor responds to signals above the set 
threshold. If the attack time is long, more of the early part of the signal (attack) 
passes through unprocessed.

Hold (0 to 5000 ms)

Sets the time the applied compression affects the signal after exceeding the 
threshold. Short hold times are useful for DJ-style ducking, while longer hold 
times are required for music ducking, for example, when working on a 
documentary film.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to the original level when the signal 
drops below the threshold. If the Auto button is activated, Compressor 
automatically finds the best release setting that varies depending on the audio 
material.

Analysis (0 to 100) (Pure Peak to Pure RMS)

Determines whether the input signal is analyzed according to peak or RMS 
values, or a mixture of both. A value of 0 is pure peak and 100 pure RMS. RMS 
mode operates using the average power of the audio signal as a basis, 
whereas Peak mode operates more on peak levels. As a general guideline, 
RMS mode works better on material with few transients such as vocals, and 
Peak mode works better for percussive material with a lot of transient peaks.

Live

If this button is activated, the look-ahead feature of Compressor is 
disengaged. Look ahead produces more accurate processing, but adds a 
certain amount of latency as a trade-off. If Live mode is activated, there is no 
latency, which might be better for live processing.
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CurveEQ

Voxengo CurveEQ is a spline equalizer for professional music and audio production 
applications. CurveEQ shows the filter response you are designing by means of a 
spline, that is, a smooth curvy line. This way you can see how the EQ alters the 
sound.

CurveEQ implements spectrum matching technology that allows you to transfer the 
spectral shape of one recording to another. In other words, you can copy the 
frequency balance of existing time-proven mixes so that other mixes can be 
improved. CurveEQ’s filters can be switched between linear-phase and 
minimum-phase modes. CurveEQ also features a customizable spectrum analyzer. 
Furthermore, you can display, save, and load static spectrum plots for comparison 
and matching purposes.

Main Layout

Title Bar

Plug-in instance name

This text box allows you to name the current plug-in instance.
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Bypass

Use this button to compare the sound of the unprocessed signal to that of the 
processed signal. The Bypass button does not reduce the plug-in’s CPU load 
when switched on.

General Control Bar

Presets selector

Allows you to store and restore custom settings.

Undo

Allows you to undo changes.

History

Opens a change log that lists up to 32 changes in the order you have made 
them.

Parameter changes are logged with the group name in parentheses, for 
example, Gain (Ls) change.

Redo

Allows you to redo changes that were undone.

A/B

By pressing the A/B button, you can switch between two plug-in states (A 
and B).

A>B (B>A)

Copies the current plug-in state to the other state (A or B). This is useful to 
copy programs between Session Bank slots.

Reset

This is the master reset button. It resets the plug-in to its default state. The 
default state can be chosen in the Preset Manager window.

Routing selector

The Routing button opens the Channel Routing Window, where you can 
change several routing options. The pop-up menu provides access to 
common routing options.

Save CSV

Allows you to save the selected EQ curve in a comma-separated text file. The 
EQ curve is stored as series of frequency/gain pairs, one per line, in the 
following form:

20.00,3.00

400.00,2.51

1000.00,1.45 # comment

5000.00,3.40
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20000.00,1.05

Each pair defines the position of a single control point on the CurveEQ’s 
control surface. Write decimal points as a period, not as a comma. Comments 
can be added at any position, starting with a hash character.

Load CSV

Allows you to load a previously saved CSV file or any externally generated EQ 
curve specification, such as room correction or RIAA phono correction. 
Frequencies defined in the file should lie between 20 and 20000 Hz.

Settings

Allows you to change general settings.

EQ Top Control Bar

Equalizer dB gain range

Lets you change the maximum boost/decrease of frequencies per band.

MIN-Phase

Enables minimum-phase filtering instead of linear-phase filtering. 
Minimum-phase filtering sounds better at steeper EQ slopes because it lacks 
pre-ringing artifacts present in linear-phase filters. Furthermore, it does not 
add a considerable processing latency.

Static & Match

Opens the Static Spectrums Editor where you can display static spectrums 
and perform spectrum matching. Spectrum matching allows you to match the 
spectrum shape of a sound recording to that of another sound recording.

Mode selector

Allows you to select a mode for spectrum matching.

Edit

Opens the Spectrum Mode Editor.
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Main EQ Control Surface

The heart of CurveEQ is the equalizer control surface with a built-in real-time 
spectrum analyzer.

• To add a control point, double-click the curve.

• To delete a control point, double-click it.

The picture above shows the equalizer control surface with control points that can 
be dragged to adjust the filter’s gain and frequency.

The readouts show the mouse cursor position within the display, the musical note 
and detune in cents that correspond to the frequency position, and the mouse 
cursor position within the spectrum power range.

If two or three curves are displayed, a white curve shows the summary frequency 
response of all currently enabled filters.

While dragging a control point with the mouse, you can adjust the filter’s bandwidth 
by additionally holding the right mouse button or pressing . Alternatively, you can 
use the mouse wheel to adjust the filter’s bandwidth.

• To enable the gain adjustment only, press  while dragging a point.

• To enable frequency adjustment only, press -.

• To set a control point to 0 dB, press , and double-click it.

Equalizer – Group Editing
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You can perform editing operations on a group of control points.

• To select several control points, click inside the equalizer control surface and 
drag a rectangle over the control points that you want to select.

• To select all control points at once, right-click the control surface.

• To deselect any selected points, click in the control surface.

• To add control points to the current selection, press and click the control 
points that you want to add.

• To remove control points from the selection, hold  and click the control point 
that you want to remove.

For group editing, the following controls are available:

Up/down arrow button

Allows you to change the relationship of the selected control points.

Inv

Inverts the gain of the selected control points.

Reset

Resets the current filter to its default state.

Equalizer - Spectrum

The equalizer control surface can display the Fourier spectrum analysis plot. The 
spectrum analysis and the display of parameters can be selected via the Mode 
selector. The Spectrum Mode Editor can be used to customize these parameters 
further. You can also click the control surface anywhere to reset the spectrum 
analysis display.

A red vertical line is displayed if the visible frequency range is wide. This line shows 
the maximum frequency of the input signal and depends on the input sample rate.

By default, Voxengo plug-ins use a slope value of 4.5 dB per octave for the 
spectrum display. This setting can be changed in the Spectrum Mode Editor 
window.

To zoom in on the spectrum’s peak values, -click and drag a selection rectangle.

If the spectrum does not fit the display, adjust the visible spectrum range in the 
Spectrum Mode Editor.

Equalizer - Narrow-Band Sweeping

To highlight the resonances in the sound, you can enable the narrow-band 
sweeping function by pressing  and dragging in the control surface with the mouse. 
As a result of this action, the curve of the band-pass filter only passes the selected 
frequency range. You can adjust the bandwidth of the filter with the mouse wheel.
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The band-pass filter’s curve is applied on top of the existing equalizer curve. This 
means that the curve you see when engaging the narrow-band sweeping is 
composed of the existing equalizer curve and band-pass filter’s own equalizer 
curve.

Zooming

• To zoom into the spectrum display, press  and drag the control surface.

• To zoom out of the spectrum display, press  and double-click the control 
surface.

Scrollbar

The horizontal and vertical scrolling controls feature zooming functionality. The 
scrollbars are found at the sides of the equalizer control surface.

The diamond-shaped button between a horizontal and vertical scrollbar can be 
used to control the positions of both scrollbars at once in a single X-Y coordinate 
space.

You can double-click scrollbars and diamond-shaped buttons to quickly switch 
between the zoomed and non-zoomed views of the control surface.

EQ Bottom Control Bar

Hide Points

Hides the control points, which allows you to evaluate the EQ curve more 
precisely.

Freeform

Enables freeform mode, in which you can draw the EQ curve manually by 
drawing on the control surface with the left mouse button.

Note that switching to freeform mode and back can be destructive and some 
EQ curve features can be lost.

Curve 1/2/3

You can define up to 3 equalizer curves for every channel group. This is useful 
if you are using spectrum matching. For example, you can apply a matching 
EQ curve generated automatically and at the same time apply any additional 
EQ curve that you draw manually.

Note that CurveEQ has a lower resolution at the frequencies below 200 Hz. 
At these frequencies, the EQ curve does not always follow the control point 
positions.



Plug-in Reference
Steinberg VST 3 Plug-ins

703

Underlay

Allows you to select another EQ curve from any other channel group that is 
displayed as an underlay.

Up/down arrow button

Allows you to scale the gain of the EQ curve.

Inv

Inverts the current EQ curve.

Copy To

Copies the envelope to the same envelope in another group.

Reset

Resets the current EQ curve to its default state.

Group Bar and Hint Line

Group 1/2/3/4

These buttons represent the channel groups. You can select the channel 
group whose parameters are being edited or monitored. Only groups that are 
assigned to the internal channels in the Channel Routing window are shown.

Solo

Allows you to solo the output of the selected group. The state of the Solo 
button is not saved between project sessions and is not restored when the 
project is reloaded.

Copy To

Allows you to copy parameter settings defined for the selected channel group 
to another channel group.

Reset

Resets the parameters of the active group.

NOTE

Note that the group bar is not visible if the Min Infrastructure option in the Settings 
window is activated. In that case, you can use the Routing selector to select a 
channel group.
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Channel Group List

CurveEQ shows a list of input channels that are routed to the selected channel 
group. This list is connected to the Channel Routing window and displays routing 
settings defined by it. Internal channel names (A, B, C, etc.) that accept the 
corresponding input channel are displayed in a superscript style. These internal 
channel names are also displayed on the level meters. If more than one input 
channel is routed to the same internal channel, the sum is displayed in the form 
“(IN1+IN2)”.

When the internal channel is assigned to a mid/side group, its input channels are 
written in parentheses with the “m” (mid) or “s” (side) prefix. For example, “s(IN1 & 
IN2)” means “side part of the mid/side pair consisting of IN1 and IN2 input 
channels”.

Hint Line

This interface element displays hint messages and can also display other 
informational messages. The hint line can be disabled in the Settings window.

Level Meter

The level meter shows several bars that correspond to the channels (A, B, etc.) of 
the selected channel group. The level meter displays all available channels if the 
Show All Channel Meters button is activated in the Channel Routing window.

Level meters can show a small horizontal white bar that represents the peak level. 
In output level meters, such as peak level, it can turn red. This means that the output 
level has entered the area above the 0 dBFS signal level and clipping can occur if 
the plug-in is inserted at the final position in the signal chain of the host application. 
If the plug-in is inserted in an intermediate position, that is, before other plug-ins, 
clipping does not necessarily occur.

Level meter ballistics and peak level hold time can be defined for all instances of the 
plug-in in the Settings window.
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Output level meters usually feature a Out/In display, showing the difference in RMS 
level between the input and output signals of the plug-in.

Spectrum Matching

With CurveEQ you can match the sound of any audio track to another, whether it is 
your to-die-for guitar into or your favorite kick drum sample.

All spectrum related functions are located in the Static & Match display.

NOTE

Spectrum matching uses parameters specified in the Spectrum Mode Editor. Only 
spectrums present in static spectrum slots can be used for matching. The usual 
realtime primary and secondary spectrums are not used for matching, unless taken 
as snapshots by means of the Take or Take 2nd buttons.

When you perform spectrum matching it is suggested to set the Type selector in 
the Spectrum Mode Editor to Avg, so that average spectrum is used for matching. 
You must run the averaging for several seconds until the visible spectrum becomes 
smooth enough. After achieving the required spectrum shape on the screen you can 
click the Take (or Take 2nd) button in the static spectrum slot to store this 
spectrum for matching purposes.

You need at least two spectrum snapshots in two slots for matching. The spectrum 
that you want to equalize and the reference spectrum should be marked with the 
Apply To and Reference switches. You can define more than one Apply To or 
Reference spectrum. In that case the mean value of the spectrums is used.

The Points parameter specifies how many measuring points to use for matching. 
The more points you use the more precise the match will be. However, in many 
cases more precise match does not mean a better sounding match. It is suggested 
to try several values to determine which one sounds best.

IMPORTANTIMPORTANTIMPORTANTIMPORTANT

The EQ curve present on the screen affects the spectrum averaging process, so the 
EQ curve should be flat when spectrum data is being collected.

NOTE

The static spectrum’s gain shift has no effect on the matching process.
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Spectrum Mode Editor

Spectrum matching options are placed in the Spectrum Mode Editor, which can be 
opened by clicking the Edit button on the EQ top control bar.

Spectrum Disable

Disables the spectrum analysis function of the plug-in.

Filled Display

Enables additional semi-transparent filling of the spectrum display.

2nd Spectrum

Enables the secondary spectrum curve, which is displayed in a darker color.

Type selector

Allows you to select a spectrum analysis type. The RT Avg mode applies 
realtime spectrum averaging analysis. This type of analysis produces an 
RMS-averaged spectrum over the period specified by the AVG Time 
parameter. The analysis type Max produces a cumulative maximum power 
spectrum. The Avg type produces a cumulative average power spectrum. The 
RT Max mode produces a realtime maximum spectrum with spectrum 
fall-down. For better spectrum maximum estimate, use a higher Overlap 
setting. If you need an infinite peak hold, use the Max analysis type.

Block Size

Specifies the block size of the FFT (fast Fourier transform) spectrum analyzer. 
Higher block sizes provide more resolution in the lower frequency range, but 
decrease time coherence (time precision) in the higher frequency range; the 
higher frequency information becomes over-averaged. Also, at higher block 
size settings the spectrum is refreshed less frequently. This can be 
compensated by increasing the Overlap parameter.



Plug-in Reference
Steinberg VST 3 Plug-ins

707

When working at increasingly higher sample rates, you need to increase the 
block size value, because the setting is used over the full spectral bandwidth. 
Therefore, at higher sample rates the analyzer’s resolution in the visible 
frequency range will be lower for the given block size.

If you want to measure the frequency of a low-frequency sound such as a 
drum or bass guitar precisely, use a higher Block Size value along with a 
higher Overlap value.

In order to avoid clicks and glitches in playback when using high Block Size 
values, you need to increase the audio buffer size in your host application.

2nd Type

If 2nd Spectrum is activated, you can use this pop-up menu to select an 
analysis type for the secondary spectrum. For example, by setting the 2nd 
Type to RT Max and Type to RT Avg, you can see the average and maximum 
spectrums simultaneously.

Note that the secondary spectrum uses the same Block Size and Avg Time 
values as the primary spectrum.

Overlap

Controls the overlap between the adjacent FFT spectrum analysis windows. 
Higher overlap values allow spectrum to be updated more frequently at the 
expense of a higher CPU load.

AVG Time

Specifies the average (fall-down) time used when the RT Avg or RT Max 
analysis is active. This value specifies after how many milliseconds the 
spectrum level falls down by 20 dB.

Smoothing

Lets you select the smoothing function’s resolution. Smoothing produces a 
drop of 6 dB per octave when stationary sine wave signals are used. For 
example, even if the signal consists of 2 sine waves (1 kHz and 2 kHz) of equal 
peak amplitude, the 2 kHz sine wave looks like it is 6 dB quieter. This happens 
because the fast Fourier transform produces a narrower spectrum for 
high-frequency stationary signals in comparison to low-frequency stationary 
signals. This drop does not appear when non-stationary (musical) signals are 
analyzed.

Freq Low/Freq High

Specify the visible frequency range of the spectrum view.

Range Low/Range High

Specify the accessible spectrum power range.

Slope

Allows you to adjust slope in the spectrum analyzer display around 1 kHz. 
Skewing the spectrum can be useful because higher frequencies usually have 
weaker power in comparison to the lower frequencies. By choosing an 
appropriate spectrum slope, you can compensate for this fact.
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Static Spectrums Editor

CurveEQ features a static spectrum display that can be controlled via the Static 
Spectrums Editor.

You can select the display name of the spectrum slot, its color, and the shift in dB 
of the static spectrum. The static spectrum can be shown or hidden using the 
visibility checkbox. The shift in dB can be used for a more convenient placing of the 
static spectrum on the screen and it does not affect the shape of the spectrum.

Take/Take 2nd

These buttons take a snapshot of the primary or secondary spectrum. The 
static spectrum snapshots are taken using the spectrum parameters specified 
in the Spectrum Mode Editor.

Before taking a spectrum, choose a spectrum analysis type via the Spectrum 
Mode Editor, usually Avg or Max, and analyze long enough so that the 
spectrum becomes general enough. When analyzing a song, it is 
recommended to store separate spectrums for verse, chorus, and bridge 
parts, as they can have distinctively differing spectral balance.

If no snapshot is taken after pressing a Take button, no spectrum is available. 
You either have to configure the spectrum mode or start the audio playback 
first.

Load/Save

You can save the spectrum in a static spectrum slot as a spectrum file with 
the extension .csf (compressed spectrum file).

X

Removes the spectrum in the selected slot.
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Preset Manager

You can use the main preset manager to save and load plug-in state presets.

Presets in the main preset manager are shared among all instances of the same 
Voxengo plug-in. All presets within the main preset manager are stored in user 
preset banks. Beside user preset banks two special banks exist: the Session Bank 
and Factory ROM bank.

The Session Bank contains programs rather than presets. Each program in the 
Session Bank contains its own undo/redo change log. The Session Bank lists 
programs that mirror programs of the host application. When you activate a 
program in the Session Bank, the program in the host application switches.

The Factory ROM bank contains presets that cannot be changed. The Factory ROM 
bank is loaded into the Session Bank every time a new instance of the plug-in is 
created in the host application.

The main preset manager contains the following control buttons:

+/-

Allow you to add and remove a bank or preset. Right-clicking the plus button 
(+) inserts the preset at the current list position rather than at the end of the 
list.

Load/Save

Allow you to save and load the bank or preset to and from a file.

U

Updates the selected preset with the current plug-in state.

Set as Default

Makes the selected preset the default preset. The default preset is loaded 
every time a new plug-in instance is created in the host application or when 
the master Reset button is pressed. If you want to restore the original default 
preset, select the “Default” preset in the Factory ROM bank and click the “Set 
as Default” button.

Activate

Loads the selected preset. You can also double-click a preset name.
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NOTE

Voxengo plug-ins use a proprietary format to store presets and preset banks. Add 
a meaningful prefix to bank and preset file names so that you do not mix up presets 
created in different Voxengo plug-ins. Voxengo plug-in preset files have the 
extension .cpf, preset bank files the extension .cbf.

To rename a preset or bank, select it and after a small delay click the item again.

Channel Routing Window

In the Channel Routing window, the following options are available:

Routing Presets

Opens a window that contains presets for the Channel Routing window, 
including channel labels.

Show all Channel Meters

Enables displaying of all channel meters and statistics counters regardless of 
the selected channel group. When this option is deactivated, only meters 
belonging to the selected channel group are shown.

Activating this option is useful when you are using dual-mono or mid-side 
processing. This option allows you to see channel meters for left and right, or 
mid and side channels together.

Input and Output Routing

Allow you to route external plug-in inputs to internal plug-in channels and vice 
versa, and to route internal plug-in channels to external plug-in outputs. The 
plug-in has a pre-defined number of internal channels, but the number of input 
and output channels can vary depending on the host application’s track or 
bus on which the plug-in is inserted.
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Note that if the input routing selector is red, the selector refers to a 
non-existent input channel. You can correct this by selecting an existing 
channel. External side-chain inputs are denoted by parenthesized labels, for 
example, (IN3), (IN4).

Mid/Side Pairs

Allow you to assign internal channels to mid/side pairs for encoding and 
decoding. The mid/side encoding is a wide-spread technique that allows you 
to process the middle (center) and side (spatial) information in stereo signals 
independently of each other, thus offering a great deal of control over that 
signal’s stereophony.

Mid/side encoding works with paired channels only and thus requires two 
channels to be assigned to the same mid/side pair. An input signal is mid/side 
encoded before it is processed by the plug-in, and decoded afterwards 
before it is routed to an output of the plug-in.

Group Assignments

The plug-in allows you to assign its internal audio channels to logical channel 
groups. Each group is affected by its own set of parameter values (EQ shape, 
gain factor, etc.). The current channel group is selected via the channel group 
selector.

Individual audio channels can be assigned to different channel groups. For 
example, you can make separate EQ settings for channel 1 and for channel 2 
by assigning channel 1 to group 1 and channel 2 to group 2.

In a surround setup you can assign left and right channels to group 1 and 
surround channels to group 2, and apply different EQ shapes to the groups.

Each plug-in audio channel can be assigned to a single channel group only. 
Channel grouping also affects channel-linking in case of dynamics 
processing and other processes that estimate signal loudness envelope: 
channels assigned to the same group are linked during processing and signal 
loudness estimation.

IN Channel Labels

Opens the label assignment window where you change the display names for 
the input channels.

You can also import channel labels from the host application by pressing the 
“Import labels from host” button. However, not all host applications provide 
distinctive input channel names.

Group Names

Opens the group names where you can change the display names for the 
groups.
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CurveEQ Settings

In the CurveEQ Settings window the following parameters are available:

Color scheme

The icons show possible color schemes. To change the color scheme, click 
an icon.

UI scale

Adjusts the size of the plug-in panel. Note that changing this setting requires 
a restart of the host application.

Show hints

If activated, hint messages appear at the bottom of the plug-in panel.

Min Infrastructure

Activate this to hide part of the plug-in interface in favor of showing a larger 
EQ control surface.

Level meter settings – Density mode

Activates the density metering mode. In this mode you can see levels at which 
a signal stays often. By examining the range of levels at which a signal stays, 
you can draw conclusions about the effective dynamic range of the material.

Note that the signal level estimation is affected by the meter’s integration and 
release times. In this mode, the display of the signal level is also affected by 
the Peak Level hold time setting.

Level meter settings – Integration time

Affects the level integration time of all level meters. The value reflects the time 
it takes for a signal level to fall down by 20 dB, or raise up from one steady 
level to another steady level.

Note that this setting does not affect the peak level on the level meters, but 
directly affects the visible difference between the peak and RMS levels when 
a musical signal is measured.
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Level meter settings – Release Time

Changes the level meter’s release time. This is the time it takes for a signal to 
fall down by 20 dB.

Level meter settings – Peak level hold time

Adjusts the time that a registered peak level with a width of 1 sample stays 
unchanged on the level meter.

Global Plug-in Settings

The global plug-in settings can be accessed via the Settings window. The following 
parameters are available:

Mouse Wheel Precision

Affects the precision of the mouse wheel. The higher the precision, the finer 
the value changes using the mouse wheel.

SHIFT Key Precision

Affects the precision when using  and dragging a control with the mouse.

Drag Precision

Affects how quickly knobs and readouts react to mouse movements.

Visual settings

You can customize the look of the plug-in with the following settings:

• Flat Panels – When enabled, all buttons and panels of the plug-in look 
flat, without a gradient fill.

• Spotlight – Enables a wide light area that looks like a spotlight.

• Textures – Adds texture to the plug-in panel.

• Shadows – Enables shadows on graphical elements.

• Flat Level Meters – Enables the flat, non-blocky look of the level meters.

Show Knob Labels

Enables numeric labels that appear when you point the mouse at a knob.
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Tablet Mode

When activated, you can control the plug-in with a pen tablet.

Show Virtual Keyboard

When this is activated, a virtual computer keyboard is shown when you enter 
values. The virtual computer keyboard is useful if the host application blocks 
certain keys from reaching the plug-in’s user interface.

Radial Knob Mode

When this is activated, you can click on the corona to set the parameter value 
immediately.

Control Surface Crosshair

Displays a crosshair cursor in the control surface area.

Anti-Denormal Noise

Enables insertion of anti-denormalization noise on the plug-in inputs. This 
noise has an RMS value of -220 dB – well below the audible dynamic range. 
If you are using the plug-in in a host application that applies such noise 
automatically, you can deactivate this option to save CPU power. Without 
anti-denormalization noise the filters of the plug-in can overload the CPU 
when silence is processed.

Remember Window Positions

When this is activated, the relative position of the plug-in windows is 
remembered after reopening the plug-in.

Show All Filter Shapes

When this is activated, all active filters are shown together with the shape of 
the selected filter.

Do Not Show Latency Changes

Disables the Latency Changed warning message completely.

Standard Control Elements in Detail

Knob

Knobs can be controlled as follows:

• If Radial Knob Mode is activated, you can drag the corona of a knob to adjust 
the value of the corresponding parameter. During dragging, you can move the 
mouse cursor away from the knob to increase value adjustment precision.

• Drag the center of a knob to adjust the value of the parameter with up and 
down mouse movements, linearly. If you press the left and right mouse buttons 
together while dragging the center, you enter high-precision adjustment 
mode. You can also enter this mode by holding down  when dragging. The 
dragging precision can be adjusted in the global settings window.

• Turn the mouse wheel to adjust the parameter.

• Double-click a knob to reset it to the default state.
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When you point the mouse at a knob, an additional ring shows approximate 
parameter values at different knob positions. These values are also referred to as 
knob labels. Thousands are suffixed with an asterisk (2*). This ring can be disabled 
in the global settings window.

Keyboard Value Entry

Most readout values such as gain or frequency can be clicked to enter a new value.

Value List Selector

This type of control allows you to choose a value or an option from the list. You can 
click the selector button to display the value list. You can also use the mouse’s 
forward and backward buttons or the mouse wheel to scroll through the values of a 
list without opening it.

To reset a value list to its default value, right-click the selector.

Slider

Sliders can be dragged with the left mouse button. If you press the left and right 
mouse buttons together while dragging the slider, you enter high-precision 
adjustment mode. You can also enter this mode by holding down  when dragging.

Location of CurveEQ Files

CurveEQ creates settings files, including presets. All CurveEQ settings and presets 
are available to the specific user of the computer only.

On Windows systems, the files reside in the following folder: \Users\<user 
name>\ Application Data\Voxengo\Audio Plug-ins\.

On Mac OS X systems, the files reside in the following folder: /Users/<user 
name>/Library/Preferences/ Voxengo/Audio Plug-ins/.

You can safely remove, copy and replace these files, including the whole 
Voxengo\Audio Plug-ins\ subfolder.

DeEsser

This effect reduces excessive sibilance, primarily for vocal recordings. Basically, it 
is a special type of compressor that is tuned to be sensitive to the frequencies 
produced by the s-sound.
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Close proximity microphone placement and equalizing can lead to situations where 
the overall sound is just right, but there is a problem with sibilants.

Reduction

Controls the intensity of the de-essing effect.

Threshold

If the Auto option is deactivated, you can use this control to set a threshold 
for the incoming signal level above which the plug-in starts to reduce the 
sibilants.

Auto

Automatically and continually chooses an optimum threshold setting 
independent of the input signal. The Auto option does not work for low-level 
signals (< -30 db peak level). To reduce the sibilants in such a file, set the 
threshold manually.

Release

Sets the time after which the de-essing effect returns to zero when the signal 
drops below the threshold.

Level meters

Indicate the dB values of the input (IN) and output (OUT) signals as well as 
the value by which the level of the sibilant (or s-frequency) is reduced (GR). 
The gain reduction meter shows values between 0 dB (no reduction) and 
-20 dB (the s-frequency level is lowered by 20 dB).

Distortion

Distortion adds crunch to your tracks.

Boost

Increases the distortion amount.

Feedback

Feeds part of the output signal back to the effect input, increasing the 
distortion effect.

Tone

Lets you select a frequency range to which to apply the distortion effect.

Spatial

Changes the distortion characteristics of the left and right channels, thus 
creating a stereo effect.
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Output

Sets the output level.

DualFilter

This plug-in filters out certain frequencies while allowing others to pass through.

Position

Sets the filter cutoff frequency. If you set this to a negative value, DualFilter 
acts as a low-pass filter. Positive values cause DualFilter to act as a high-pass 
filter.

Resonance

Sets the sound characteristic of the filter. With higher values, a ringing sound 
is heard.

EnvelopeShaper

This plug-in can be used to attenuate or boost the gain of the attack and release 
phase of audio material.

You can use the knobs or drag the breakpoints in the graphical display to change 
parameter values. Be careful with levels when boosting the gain and if needed 
reduce the output level to avoid clipping.
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Attack (-20 to 20 dB)

Changes the gain of the attack phase of the signal.

Length (5 to 200 ms)

Determines the length of the attack phase.

Release (-20 to 20 dB)

Changes the gain of the release phase of the signal.

Output (-24 to 12 dB)

Sets the output level.

Expander

Expander reduces the output level in relation to the input level for signals below the 
set threshold. This is useful if you want to enhance the dynamic range or reduce the 
noise in quiet passages.

You can either use the knobs or drag the breakpoints in the graphical display to 
change the Threshold and the Ratio parameter values.

Threshold (-60 to 0 dB)

Determines the level where expansion kicks in. Signal levels below the 
threshold are affected. Signal levels above the threshold are not processed.

Ratio (1:1 to 8:1)

Determines the amount of gain boost applied to signals below the threshold.

Soft Knee

If this button is deactivated, signals below the threshold are expanded 
instantly according to the set ratio (hard knee). If soft knee is activated, the 
onset of expansion is more gradual, producing less drastic results.

Attack (0.1 to 100 ms)

Determines how fast Expander responds to signals below the set threshold. 
If the attack time is long, more of the early part of the signal (attack) passes 
through unprocessed.

Hold (0 to 2000 ms)

Sets the time the applied expansion affects the signal below the threshold.
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Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level when the signal 
exceeds the threshold. If the Auto button is activated, Expander automatically 
finds the best release setting for the audio material.

Analysis (0 to 100) (Pure Peak to Pure RMS)

Determines whether the input signal is analyzed according to peak or RMS 
values, or a mixture of both. A value of 0 is pure peak and 100 pure RMS. RMS 
mode operates using the average power of the audio signal as a basis, 
whereas Peak mode operates more on peak levels. As a general guideline, 
RMS mode works better on material with few transients such as vocals, and 
Peak mode better for percussive material with a lot of transient peaks.

Live

If this button is activated, the look-ahead feature of Expander is disengaged. 
Look ahead produces more accurate processing, but adds a certain amount 
of latency as a trade-off. If Live mode is activated, there is no latency, which 
might be better for live processing.

Gate

Gating, or noise gating, silences audio signals below a set threshold. As soon as 
the signal level exceeds the threshold, the gate opens to let the signal through.

Threshold (-60 to 0 dB)

Determines the level where Gate is activated. Signal levels above the set 
threshold trigger the gate to open, and signal levels below the set threshold 
close the gate.

State LED

Indicates whether the gate is open (LED lights up in green), closed (LED 
lights up in red) or in an intermediate state (LED lights up in yellow).

Filter buttons (LP, BP, and HP)

If the Side-Chain button is activated, you can use these buttons to set the 
filter type to either low-pass, band-pass, or high-pass.
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Side-Chain

This button activates the internal side-chain filter. The input signal can then be 
shaped according to the filter parameters. Internal side-chaining can be useful 
for tailoring how the gate operates.

Center (50 to 20000 Hz)

If the Side-Chain button is activated, this sets the center frequency of the 
filter.

Q-Factor (0.01 to 10000)

If the Side-Chain button is activated, this sets the resonance of the filter.

Monitor

Allows you to monitor the filtered signal.

Attack (0.1 to 1000 ms)

Sets the time after which the gate opens when it is triggered.

NOTE

Deactivate the Live button to make sure that the gate is already open when a 
signal above the threshold is played back.

Hold (0 to 2000 ms)

Determines how long the gate stays open after the signal drops below the 
threshold.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gate closes (after the set Hold time). If the Auto 
button is activated, Gate automatically finds the best release setting for the 
audio material.

Range

Adjusts the attenuation of the gate when it is shut. If Range is set to , the 
gate is completely shut. The higher the value, the higher the level of the signal 
that passes through the shut gate.

Analysis (0 to 100) (Pure Peak to Pure RMS)

Determines whether the input signal is analyzed according to peak or RMS 
values, or a mixture of both. A value of 0 is pure Peak and 100 pure RMS. RMS 
mode operates using the average power of the audio signal as a basis, 
whereas Peak mode operates more on peak levels. As a general guideline, 
RMS mode works better on material with few transients such as vocals, and 
Peak mode better for percussive material, with a lot of transient peaks.

Live

If this button is activated, the look-ahead feature of Gate is disengaged. Look 
ahead produces more accurate processing, but adds a certain amount of 
latency as a trade-off. If Live mode is activated, there is no latency, which is 
better for live processing.
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GEQ-10/GEQ-30

These graphic equalizers are identical, except for the number of available frequency 
bands (10 and 30).

Each band can be attenuated or boosted by up to 12 dB, allowing for fine control 
of the frequency response. In addition, there are several preset modes available that 
can add color to the sound of GEQ-10/GEQ-30.

You can draw response curves in the main display by clicking and dragging with the 
mouse. You have to click one of the sliders before you drag across the display.

At the bottom of the window, the individual frequency bands are shown in Hz. At the 
top of the display, the amount of attenuation/boost is shown in dB.

Output

Controls the overall gain of the equalizer.

Flatten

Resets all the frequency bands to 0 dB.

Range

Allows you to adjust how much a set curve cuts or boosts the signal.

Invert

Inverts the current response curve.

Mode pop-up menu

This pop-up menu allows you to set the filter mode that determines how the 
various frequency band controls interact to create the response curve, see 
below.

EQ Modes

The Mode pop-up menu in the lower right corner allows you to select an EQ mode, 
which add color or character to the equalized output in various ways.

True Response

Applies serial filters with an accurate frequency response.
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Digi Standard

In this mode, the resonance of the last band depends on the sample rate.

Classic

Applies a classic parallel filter structure where the response does not follow 
the set gain values accurately.

VariableQ

Applies parallel filters where the resonance depends on the amount of gain.

ConstQ u

Applies parallel filters where the resonance of the first and last bands 
depends on the sample rate.

ConstQ s

Applies parallel filters where the resonance is raised when boosting the gain 
and vice versa.

Resonant

Applies serial filters where a gain increase of one band lowers the gain in 
adjacent bands.

Limiter

This plug-in is designed to ensure that the output level never exceeds a set output 
level, to avoid clipping in following devices.

Limiter can adjust and optimize the Release parameter automatically according to 
the audio material, or it can be set manually. Limiter also features separate meters 
for the input, output and the amount of limiting (middle meters).

Input (-24 to 24 dB)

Adjusts the input gain.

Output (-24 to 6 dB)

Determines the maximum output level.

Release (0.1 to 1000 ms or Auto mode)

Sets the amount of time it takes for the gain to return to its original level. If the 
Auto button is activated, Limiter automatically finds the best release setting 
for the audio material.
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L/R -> M/S, M/S -> L/R

This plug-in allows you to convert a stereo signal into a M/S signal and vice versa.

The L/R -> M/S tool converts a L/R signal that is devided into a left and a right 
signal into a M/S signal that is devided into a mid signal (L+R) and side signals 
(L-R).

The M/S -> L/R tool reconverts the M/S signal into a L/R signal.

Maximizer

This plug-in raises the loudness of audio material without the risk of clipping.

Output (-24 to 6 dB)

Determines the maximum output level. Set this to 0 dB to avoid clipping.

Optimize (0 to 100)

Determines the loudness of the signal.

Soft Clip

If this button is activated, Maximizer starts limiting or clipping the signal softly, 
at the same time generating harmonics which add warm, tube-like 
characteristics to the audio material.
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Mix6to2

This plug-in lets you quickly mix down your surround mix format to stereo. You can 
control the levels of up to six surround channels and decide for each channel up to 
which level it is included in the resulting mix.

NOTE

This plug-in does not simulate a surround mix or add any psycho-acoustical artifacts 
to the resulting output – it is simply a mixer. The plug-in is only available in the 
Master Section and if a surround audio montage is active.

Surround Channels

Volume

Govern how much of the signal is included in the left and/or right channel of 
the output bus.

Link

Links the two volume faders.

Invert

Allow you to invert the phase of the left and right channel of the surround bus.

Output Bus

Volume

Set the volume of the of the mixed output.

Link

Links the two Output faders.

Normalize

If this option is activated, the mixed output is normalized. For example, the 
output level is automatically adjusted so that the loudest signal is as loud as 
possible without clipping.
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Mix8to2

This plug-in lets you quickly mix down your surround mix format to stereo. You can 
control the levels of up to eight surround channels and decide for each channel up 
to which level it is included in the resulting mix.

This plug-in does not simulate a surround mix or add any psycho-acoustical artifacts 
to the resulting output – it is simply a mixer. The plug-in is only available in the 
Master Section and if a 8 channel audio montage is active.

Surround Channels

Volume

Govern how much of the signal is included in the left and/or right channel of 
the output bus.

Link

Links the two volume faders.

Invert

Allow you to invert the phase of the left and right channel of the surround bus.

Output Bus

Volume

Set the volume of the of the mixed output.

Link

Links the two Output faders.

Normalize

If this option is activated, the mixed output is normalized. For example, the 
output level is automatically adjusted so that the loudest signal is as loud as 
possible without clipping.
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MonoDelay

This is a mono delay effect that can either be tempo-based or use freely specified 
delay time settings.

Delay

If tempo sync is activated, this is where you specify the base note value for the 
delay. If tempo sync is deactivated, the delay time can be set freely in 
milliseconds.

Feedback

Sets the number of repeats for the delay.

Filter Lo

Affects the feedback loop of the effect signal and allows you to roll off low 
frequencies. The button below the knob activates/deactivates the filter.

Filter Hi

Affects the feedback loop of the effect signal and allows you to roll off high 
frequencies. The button below the knob activates/deactivates the filter.

Mix

Sets the level balance between the dry and the wet signal. If this effect is used 
as a send effect, set this to the maximum value as you can control the 
dry/effect balance with the send.

MonoToStereo

This effect turns a mono signal into a pseudo-stereo signal. The plug-in can be used 
on a mono file or a stereo file with equal channels.

Width

Controls the width or depth of the stereo enhancement. Turn clockwise to 
increase the enhancement.



Plug-in Reference
Steinberg VST 3 Plug-ins

727

Delay

Increases the amount of differences between the left and right channels to 
further increase the stereo effect.

Color

Generates additional differences between the channels to increase the stereo 
effect.

Mono

Switches the output to mono, to check for possible unwanted coloring of the 
sound which sometimes can occur when creating an artificial stereo image.

MultibandCompressor

MultibandCompressor allows a signal to be split into a maximum of four frequency 
bands. You can specify the level, bandwidth, and compressor characteristics for 
each band.

Frequency Band Editor

The frequency band editor in the upper half of the panel is where you set the width 
of the frequency bands as well as their level after compression. The vertical value 
scale to the left shows the input gain level of each frequency band. The horizontal 
scale shows the available frequency range.

• To define the frequency range of the different frequency bands, use the 
handles at the sides.
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• To attenuate or boost the input gain by ±15 dB after compression, use the 
handles on top of each frequency band.

You can drag the handles provided in the frequency band editor with the mouse. 
You use them to set the corner frequency range and the input gain levels for each 
of the frequency bands.

Bypassing Frequency Bands

To bypass each frequency band, activate the B button in each compressor 
section.

Soloing Frequency Bands

To solo a frequency band, activate the S button in each compressor section. 
Only one band can be soloed at a time.

Compressor Section

By moving breakpoints or using the corresponding knobs, you can specify the 
Threshold and Ratio. The first breakpoint from which the line deviates from the 
straight diagonal is the threshold point.

Threshold (-60 to 0 dB)

Determines the level where Multiband Compressor kicks in. Signal levels 
above the threshold are affected. Signal levels below are not processed.

Ratio (1000 to 8000) (1:1 to 8:1)

Determines the amount of gain reduction applied to signals above the 
threshold. A ratio of 3000 (3:1) means that for every 3 dB the input level 
increases, the output level increases by only 1 dB.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds to signals above the 
threshold. If the attack time is long, more of the early part of the signal passes 
through unprocessed.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level when the signal 
drops below the threshold. If the Auto button is activated, the compressor 
automatically finds the best release setting for the audio material.

Output (-24 to 24 dB)

Controls the total output level of MultibandCompressor.
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Octaver

This plug-in can generate two additional voices that track the pitch of the input 
signal one octave and two octaves below the original pitch. Octaver is best used 
with monophonic signals.

Direct

Adjusts the mix of the original signal and the generated voices. A value of 0 
means only the generated and transposed signal is heard. By raising this 
value, more of the original signal is heard.

Octave 1

Adjusts the level of the generated signal one octave below the original pitch. 
A setting of 0 means that the voice is muted.

Octave 2

Adjusts the level of the generated signal two octaves below the original pitch. 
A setting of 0 means that the voice is muted.

PingPongDelay

This is a stereo delay effect that alternates each delay repeat between the left and 
right channels. 

Delay

If tempo sync is activated, this is where you specify the base note value for the 
delay. If tempo sync is deactivated, the delay time can be set freely in 
milliseconds.

Feedback

Sets the number of repeats for the delay.

Filter Lo

Affects the feedback loop of the effect signal and allows you to roll off low 
frequencies. The button below the knob activates/deactivates the filter.
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Filter Hi

Affects the feedback loop of the effect signal and allows you to roll off high 
frequencies. The button below the knob activates/deactivates the filter.

Spatial

Sets the stereo width for the left/right repeats. Turn clockwise for a more 
pronounced stereo ping-pong effect.

Mix

Sets the level balance between the dry and the wet signal. If this effect is used 
as a send effect, set this to the maximum value as you can control the 
dry/effect balance with the send.

PostFilter

This effect allows quick and easy filtering of unwanted frequencies, creating room 
for the important sounds in your mix.

The PostFilter plug-in combines a low-cut filter, a notch filter, and a high-cut filter. 
You can make settings by dragging the curve points in the graphical display, or by 
adjusting the controls below the display section.

Level meter

Shows the output level, giving you an indication of how the filtering affects the 
overall level of the edited audio.

Low Cut Freq (20 Hz to 1 kHz, or Off)

Allows you to eliminate low-frequency noise. The filter is inactive if the curve 
point is located all the way to the left.

Low Cut Slope

Allows you to choose a slope value for the low-cut filter.



Plug-in Reference
Steinberg VST 3 Plug-ins

731

Low Cut Preview

Use this button between the Low Cut Freq button and the graphical display 
to switch the filter to a complementary high-cut filter. This deactivates any 
other filters, allowing you to listen only to the frequencies that you want to filter 
out.

Notch Freq

Sets the frequency of the notch filter.

Notch Gain

Adjusts the gain of the selected frequency. Use positive values to identify the 
frequencies that you want to filter out.

Notch Gain Invert

This button inverts the gain value of the notch filter. Use this button to filter out 
unwanted noise. When looking for the frequency to omit, it sometimes helps 
to boost it first (set the notch filter to positive gain). After you have found 
frequency of the noise, you can use the Invert button to cancel it out.

Notch Q-Factor

Sets the width of the notch filter.

Notch Preview

Use the Preview button between the notch filter buttons and the graphical 
display to create a band-pass filter with the peak filter's frequency and Q. This 
deactivates any other filters, allowing you to listen only to the frequencies you 
want to filter out.

Notches buttons (1, 2, 4, 8)

These buttons add additional notch filters to filter out harmonics.

High Cut Freq (3 Hz to 20 kHz, or Off)

This high-cut filter allows you to remove high-frequency noise. The filter is 
inactive if the curve point is located all the way to the right.

High Cut Slope

Allows you to choose a slope value for the high-cut filter.

High Cut Preview

This button between the High Cut Freq button and the graphical display 
allows you to switch the filter to a complementary low-cut filter. This 
deactivates any other filters, allowing you to listen only to the frequencies you 
want to filter out.
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RoomWorks

RoomWorks is a highly adjustable reverb plug-in for creating realistic room 
ambiance and reverb effects in stereo and surround formats. The CPU usage is 
adjustable to fit the needs of any system. From short room reflections to 
cavern-sized reverb, this plug-in delivers high quality reverberation.

Input Filters

Lo Freq

Determines the frequency at which the low-shelving filter takes effect. Both 
the high and low settings filter the input signal prior to reverb processing.

Hi Freq

Determines the frequency at which the high-shelving filter takes effect. Both 
the high and low settings filter the input signal prior to reverb processing.

Lo Gain

Controls the amount of boost or attenuation for the low-shelving filter.

Hi Gain

Controls the amount of boost or attenuation for the high-shelving filter.

Reverb Character

Pre-Delay

Controls how much time passes before the reverb is applied. This allows you 
to simulate larger spaces by increasing the time it takes for the first reflections 
to reach the listener.

Reverb Time

Allows you to set the reverb time in seconds.

Size

Alters the delay times of the early reflections to simulate larger or smaller 
spaces.
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Diffusion

Affects the character of the reverb tail. Higher values lead to more diffusion 
and a smoother sound, while lower values lead to a clearer sound.

Width

Controls the width of the stereo image. 100 % gives you full stereo reverb. At 
0 %, the reverb is all in mono.

Variation

Clicking this button generates a new version of the same reverb program 
using altered reflection patterns. This is helpful if certain sounds are causing 
odd ringing or undesirable results. Creating a new variation often solves these 
issues. There are 1000 possible variations.

Hold

Activating this button freezes the reverb buffer in an infinite loop. You can 
create some interesting pad sounds using this feature.

Damping

Lo Freq

Determines the frequency below which low-frequency damping occurs.

High Freq

Determines the frequency above which high-frequency damping occurs.

Low Level

Affects the decay time of the low frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes low frequencies to decay quicker. Values above 
100 % cause low frequencies to decay more slowly than the mid-range 
frequencies.

High Level

Affects the decay time of the high frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes high frequencies to decay quicker. Values above 
100 % cause high frequencies to decay more slowly than the mid-range 
frequencies.

Envelope

Amount

Determines how much the envelope attack and release controls affect the 
reverb itself. Lower values have a more subtle effect while higher values lead 
to a more drastic sound.
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Attack

The envelope settings in RoomWorks control how the reverb follows the 
dynamics of the input signal in a fashion similar to a noise gate or downward 
expander. Attack determines how long it takes for the reverb to reach full 
volume after a signal peak (in milliseconds). This is similar to a pre-delay, but 
the reverb is ramping up instead of starting all at once.

Release

Determines how long after a signal peak the reverb can be heard before being 
cut off, similar to a release time of a gate.

Output

Mix

Sets the level balance between the dry and the wet signal. If RoomWorks is 
used as an insert effect for an FX channel, you most likely want to set this to 
100 % or use the wet only button.

Wet only

This button deactivates the Mix parameter, setting the effect to 100 % wet or 
affected signal. This button should normally be activated if RoomWorks is 
used as a send effect for an FX channel or a group channel.

Efficiency

Determines how much processing power is used for RoomWorks. The lower 
the value, the more CPU resources are used, and the higher the quality of the 
reverb. Interesting effects can be created with very high Efficiency settings 
(>90 %).

Export

Determines if during audio export RoomWorks uses the maximum CPU power 
for the highest quality reverb. During export, you may want to keep a higher 
efficiency setting to achieve a specific effect. If you want the highest quality 
reverb during export, make sure this button is activated.

Output meter

Indicates the level of the output signal.

RoomWorks SE

RoomWorks SE is a smaller version of the RoomWorks plug-in. This plug-in 
delivers high quality reverberation, but has fewer parameters and is less CPU 
demanding than the full version.
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Pre-Delay

Controls how much time passes before the reverb is applied. This allows you 
to simulate larger spaces by increasing the time it takes for the first reflections 
to reach the listener.

Reverb Time

Allows you to set the reverb time in seconds.

Diffusion

Affects the character of the reverb tail. Higher values lead to more diffusion 
and a smoother sound, while lower values lead to a clearer sound.

Hi Level

Affects the decay time of the high frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes high frequencies to decay quicker. Values above 
100 % cause high frequencies to decay more slowly than the mid-range 
frequencies.

Lo Level

Affects the decay time of the low frequencies. Normal room reverb decays 
quicker in the high- and low-frequency range than in the mid-range. Lowering 
the level percentage causes low frequencies to decay quicker. Values above 
100 % cause low frequencies to decay more slowly than the mid-range 
frequencies.

Mix

Sets the level balance between the dry signal and the wet signal. When using 
RoomWorks SE inserted in an FX channel, you most likely want to set this to 
100 %.

StereoDelay

StereoDelay has two independent delay lines with freely specified delay time 
settings.

Delay 1 and 2

If tempo sync is activated, this is where you specify the base note value for the 
delay. If tempo sync is deactivated, the delay time can be set freely in 
milliseconds.

Feedback 1 and 2

Set the number of repeats for each delay.
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Filter Lo 1 and 2

Affect the feedback loop of the effect signal and allow you to roll off low 
frequencies. The buttons below the knobs activate/deactivate the filter.

Filter Hi 1 and 2

Affect the feedback loop of the effect signal and allow you to roll off high 
frequencies. The buttons below the knobs activate/deactivate the filter.

Pan 1 and 2

Set the stereo position for each delay.

Mix 1 and 2

Set the level balance between the dry and the wet signal. If this effect is used 
as a send effect, set these controls to the maximum value as you can control 
the dry/effect balance with the send.

StereoEnhancer

This plug-in expands the stereo width of (stereo) audio material. It cannot be used 
with mono files.

Width

Controls the width or depth of the stereo enhancement. Turn clockwise to 
increase the enhancement.

Delay

Increases the amount of differences between left and right channels to further 
increase the stereo effect.

Color

Generates additional differences between the channels to increase the stereo 
enhancement.

Mono

Switches the output to mono, to check for possible unwanted coloring of the 
sound which sometimes can occur when enhancing the stereo image.
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Stereo Tools

Stereo Tools allows you to pan or position both the left and right channels 
independently of one another. You can use it for stereo files that you do not want to 
convert to mono or for fixing a problem with the stereo file, for example.

Invert left phase/Invert right phase

Inverts the polarity of an audio channel. You can use it for removing the center 
information or for fixing a channel that has been inverted, for example.

Swap stereo channels

Swaps the left and right channels.

Transform

Determines the conversion method:

• Nothing: No conversion of the signal.

• Left/Right -> Mid/Side: Converts a stereo signal into a mid/side 
signal.

• Mid/Side -> Left/Right: Converts a mid/side signal into a stereo 
signal.

Left/Mid gain (dB)

Sets the gain of the left stereo signal or the mid signal of the M/S signal.

Right/Side gain (dB)

Sets the gain of the right stereo signal or of the side signals of the M/S signal.

Left/Mid panning (%)

Pans the left stereo signal or the mid signal of the M/S signal.

Right/Side panning (%)

Pans the right stereo signal or the side signals of the M/S signal.
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StudioChorus

StudioChorus is a two-stage chorus effect that adds short delays to the signal and 
modulates the pitch of the delayed signals to produce a doubling effect. The two 
separate stages of chorus modulation are independent and are processed serially 
(cascaded).

Rate

Sets the chorus sweep rate.

Width

Determines the extent of the chorus effect. Higher settings produce a more 
pronounced effect.

Spatial

Sets the stereo width of the effect. Turn clockwise for a wider stereo effect.

Mix

Sets the level balance between the dry signal and the wet signal. If the effect 
is used as a send effect, set this to the maximum value as you can control the 
dry/effect balance with the send.

Waveform Shape selector

Allows you to select the modulation waveform, altering the character of the 
chorus sweep. A sine and a triangle waveform are available.

Delay

Affects the frequency range of the modulation sweep by adjusting the initial 
delay time.

Filter Lo/Hi

Allow you to roll off low and high frequencies of the effect signal.
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StudioEQ

Studio EQ is a high-quality 4-band parametric stereo equalizer with two fully 
parametric mid-range bands. The low and high bands can act as either shelving 
filters (three types), or as peak filter (band-pass), or as cut filter 
(low-pass/high-pass).

Band 1 Gain (-20 to +24 dB)

Sets the amount of attenuation/boost for the low band.

Band 1 Inv

This button inverts the gain value of the filter. Use this button to filter out 
unwanted noise. When looking for the frequency to omit, it sometimes helps 
to boost it in the first place (set the filter to positive gain). After you have found 
the frequency of the noise, you can use the Inv button to cancel it out.

Band 1 Freq (20 to 2000 Hz)

Sets the frequency of the low band.

Band 1 Q-Factor (0.5 to 10)

Controls the width, or resonance, of the low band.

Band 1 Filter mode

For the low band, you can choose between three types of shelving filters, a 
peak filter (band-pass), and a cut filter (lowpass/high-pass). If Cut mode is 
selected, the Gain parameter is fixed.

• Shelf I adds resonance in the opposite gain direction slightly above the 
set frequency.

• Shelf II adds resonance in the gain direction at the set frequency.

• Shelf III is a combination of Shelf I and II.

Band 2 Gain (-20 to +24 dB)

Sets the amount of attenuation/boost for the first mid band.
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Band 2 Inv

This button inverts the gain value of the filter. See also the description of the 
Invert button for band 1.

Band 2 Freq (20 to 20000 Hz)

Sets the center frequency of the first mid band.

Band 2 Q-Factor (0.5 to 10)

Sets the width of the first mid band. The higher this value, the narrower the 
bandwidth.

Band 3 Gain (-20 to +24 dB)

Sets the amount of attenuation/boost for the second mid band.

Band 3 Inv

This button inverts the gain value of the filter. See also the description of the 
Invert button for Band 1.

Band 3 Freq (20 to 20000 Hz)

Sets the center frequency of the second mid band.

Band 3 Q-Factor (0.5 to 10)

Sets the width of the second mid band. The higher this value, the narrower the 
bandwidth.

Band 4 Inv

This button inverts the gain value of the filter. See also the description of the 
Invert button for Band 1.

Band 4 Gain (-20 to +24 dB)

Sets the amount of attenuation/boost for the high band.

Band 4 Freq (200 to 20000 Hz)

Sets the frequency of the high band.

Band 4 Q-Factor (0.5 to 10)

Controls the width, or resonance, of the high band.

Band 4 Filter mode

For the high band, you can choose between three types of shelving filters, a 
peak filter, and a cut filter. If Cut mode is selected, the Gain parameter is fixed.

• Shelf I adds resonance in the opposite gain direction slightly below the 
set frequency.

• Shelf II adds resonance in the gain direction at the set frequency.

• Shelf III is a combination of Shelf I and II.

Output (-24 to +24 dB)

This knob on the top right of the plug-in panel allows you to adjust the overall 
output level.
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Auto Gain

If this button is activated, the gain is automatically adjusted, keeping the 
output level constant regardless of the EQ settings.

Spectrum

Shows the spectrum before and after filtering.

Reset

Resets the EQ settings.

Using Modifier Keys

When using the mouse to change the parameter settings, modifier keys can be 
used. When no modifier key is pressed and you drag an EQ point in the display, the 
Gain and Frequency parameters are adjusted simultaneously.

[Shift]

If you keep [Shift] pressed and drag the mouse, the Q-factor of the 
corresponding EQ band is modified.

[Alt]/[Option]

If you keep [Alt]/[Option] pressed and drag the mouse, the frequency of the 
corresponding EQ band is modified.

[Ctrl]/[Command]

If you keep [Ctrl]/[Command] pressed and drag the mouse, the gain value of 
the corresponding EQ band is modified.

TestGenerator

This utility plug-in allows you to generate an audio signal, which can be recorded as 
an audio file.

The resulting file can then be used for a number of purposes:

• Testing the specifications of audio equipment

• Measurements of various kinds, such as calibrating tape recorders

• Testing signal processing methods

• Educational purposes
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The TestGenerator is based on a waveform generator which can generate a number 
of basic waveforms such as sine and saw as well as various types of noise. 
Furthermore, you can set the frequency and amplitude of the generated signal. As 
soon as you add the TestGenerator as an effect on an audio track and activate it, a 
signal is generated. You can then activate recording as usual to record an audio file 
according to the signal specifications.

Waveforms and noise section

Allows you to set the basis for the signal generated by the waveform 
generator. You can choose between four basic waveforms (sine, triangle, 
square, and sawtooth) and three types of noise (white, pink, and brownian).

Frequency section

Allows you to set the frequency of the generated signal.

Gain section

Allows you to set the amplitude of the signal. The higher the value, the 
stronger the signal. You can select one of the preset values, or use the slider 
to set a value between -81 and 0 dB.

Tube Compressor

This versatile compressor with integrated tube-simulation allows you to achieve 
smooth and warm compression effects. The VU meter shows the amount of gain 
reduction. Tube Compressor features an internal side-chain section that lets you 
filter the trigger signal.

Drive (1.0 to 6.0)

Controls the amount of tube saturation.

Input (-24.0 to 48.0)

Determines the compression amount. The higher the input gain, the more 
compression is applied.

Limit

Increases the ratio of the compressor for a limiting effect.

Output (-12.0 to 12.0)

Sets the output gain.
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Attack (0.1 to 100.0)

Determines how fast the compressor responds. If the attack time is long, more 
of the initial part of the signal passes through unprocessed.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to the original level. If the Auto 
button is activated, Tube Compressor automatically finds the best release 
setting for the audio material.

Mix (0 to 100)

Adjusts the mix between dry and wet signal preserving the transients of the 
input signal.

In/Out Meters

Show the highest peaks of all available input and output channels.

VU Meter

Shows the amount of gain reduction.

Side-chain (if supported)

Activates/Deactivates the internal side-chain filter. The input signal can then 
be shaped according to the filter parameters. Internal side-chaining is useful 
for tailoring how the compressor operates.

Filter section (LP, BP, and HP)

If the Side-Chain button is activated, you can use these buttons to set the 
filter type to low-pass, band-pass, or high-pass.

Side-chain section

Center

Sets the center frequency of the filter.

Q-Factor

Sets the resonance or width of the filter.

Monitor

Allows you to monitor the filtered signal.
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VintageCompressor

VintageCompressor is modeled after vintage type compressors.

This compressor features separate controls for Input and Output gain, Attack, and 
Release. In addition, there is a Punch mode which preserves the attack phase of 
the signal and a program-dependent Auto feature for the Release parameter.

Input (-24 to 48 dB)

In combination with the Output setting, this parameter determines the 
compression amount. The higher the input gain setting and the lower the 
output gain setting, the more compression is applied.

Output (-48 to 24 dB)

Sets the output gain.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds. If the attack time is long, more 
of the early part of the signal passes through unprocessed.

Punch (On/Off)

If this is activated, the early attack phase of the signal is preserved, retaining 
the original punch in the audio material, even with short Attack settings.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to its original level. If the Auto button 
is activated, Vintage Compressor automatically finds the best release setting 
for the audio material.

VU Meter

Shows the amount of gain reduction.

In/Out Meters

Show the highest peaks of all available input and output channels.
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VSTDynamics

VSTDynamics is an advanced dynamics processor. It combines three separate 
processors: Gate, Compressor, and Limiter, covering a variety of dynamic 
processing functions.

The window is divided into three sections, containing controls and meters for each 
processor. Activate the individual processors using the buttons Gate, 
Compressor, and Limiter at the bottom of the plug-in panel.

Gate Section

Gating, or noise gating, is a method of dynamic processing that silences audio 
signals below a set threshold. As soon as the signal level exceeds the threshold, the 
gate opens to let the signal through. The Gate trigger input can also be filtered 
using an internal side-chain signal.

The following parameters are available:

Threshold (-60 to 0 dB)

Determines the level where the gate is activated. Signal levels above the 
threshold trigger the gate to open, and signal levels below the threshold close 
the gate.

State LED

Indicates whether the gate is open (LED lights up in green), closed (LED 
lights up in red) or in an intermediate state (LED lights up in yellow).

Side-Chain

Activates the internal side-chain filter. You can use this to filter out parts of the 
signal that might otherwise trigger the gate in places you do not want it to, or 
to boost frequencies you want to accentuate, allowing for more control over 
the gate function.

LP (low-pass), BP (band-pass), HP (high-pass)

These buttons set the basic filter mode.

Center (50 to 22000 Hz)

Sets the center frequency of the filter.
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Q-Factor (0.001 to 10000)

Sets the resonance or width of the filter.

Monitor (On/Off)

Allows you to monitor the filtered signal.

Attack (0.1 to 100 ms)

Sets the time after which the gate opens when it is triggered.

Hold (0 to 2000 ms)

Determines how long the gate stays open after the signal drops below the 
threshold level.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gate closes (after the set Hold time). If the Auto 
button is activated, Gate automatically finds the best release setting for the 
audio material.

Range

Adjusts the attenuation of the Gate when it is shut. If Range is set to , the 
gate is completely shut. The higher the value, the higher the level of the signal 
that passes through the shut gate.

Input Gain Meter

Shows the input gain.

Compressor Section

The compressor reduces the dynamic range of the audio, making softer sounds 
louder or louder sounds softer, or both. The compressor features a separate display 
that graphically illustrates the compressor curve shaped according to your settings.

Threshold (-60 to 0 dB)

Determines the level where the compressor kicks in. Signal levels above the 
set threshold are affected. Signal levels below are not processed.

Ratio (1:1 to 8:1)

Determines the amount of gain reduction applied to signals above the 
threshold. A ratio of 3:1 means that for every 3 dB the input level increases, 
the output level increases by only 1dB.

Make-Up (0 to 24 dB)

Compensates for output gain loss, caused by compression. If the Auto button 
is activated, gain loss is compensated automatically.

Attack (0.1 to 100 ms)

Determines how fast the compressor responds to signals above the set 
threshold. If the attack time is long, more of the early part of the signal (attack) 
passes through unprocessed.
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Release (10 to 1000 ms or Auto mode)

Sets the amount of time after which the gain returns to the original level if the 
signal drops below the threshold. If the Auto button is activated, the 
compressor automatically finds an optimal release setting that varies 
depending on the audio material.

Graphical display

Use the graphical display to graphically set the threshold and ratio values. To 
the left and right of the graphical display, you find two meters that show the 
amount of gain reduction in dB.

Limiter Section

The limiter ensures that the output level never exceeds a set threshold, to avoid 
clipping in following devices. Conventional limiters usually require very accurate 
setting up of the attack and release parameters to prevent the output level from 
going beyond the set threshold level. The limiter adjusts and optimizes these 
parameters automatically according to the audio material.

Output (-24 to 6 dB)

Determines the maximum output level. Signal levels above the threshold are 
affected. Signal levels below are left unaffected.

Soft Clip

If this button is activated, the signal is limited when the signal level exceeds 
-6 dB. At the same time, harmonics are generated, adding a warm, tube-like 
characteristic to the audio material.

Release (10 to 1000 ms or Auto mode)

Sets the time after which the gain returns to the original level if the signal 
drops below the threshold. If the Auto button is activated, the limiter 
automatically finds the best release setting for the audio material.

Meters

The three meters show the input gain (IN), the gain reduction (GR) and the 
output gain (OUT).

Module Configuration Button

Using the Module Configuration button in the bottom right corner of the plug-in 
panel, you can set the signal flow order for the three processors. Changing the 
order of the processors can produce different results, and the available options 
allow you to quickly compare what works best for a given situation. Simply click the 
Module Configuration button to change to a different configuration. There are 
three routing options:

• C-G-L (Compressor-Gate-Limit)

• G-C-L (Gate-Compressor-Limit)

• C-L-G (Compressor-Limit-Gate)
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Sonnox Restoration Toolkit

The Sonnox Restoration Toolkit consists of the De-Clicker, De-Noiser, and 
De-Buzzer tools. The tools are for restoring old material, removing clicks, pops, 
buzzes, and background noise that can occur in new recordings.

Sonnox DeBuzzer

Sonnox DeBuzzer allows you to remove hum and buzz noises from audio material.

Sonnox Menu Options button

Opens a menu where you can select the following options:

• Duration of the input/output meter clip lights hold (indefinitely, 2 s, 5 s)

• Knob behavior

• Information about the version number and build date

Input Level meter

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. This gives a clear and intuitive 
impression of the working headroom.

Trim Input Level

Allows you to adjust the input signal level by up to ±12 dB.

Frequency Knob and touch pad (Hz)

The DeBuzzer has an active frequency range for the buzz fundamental of 
between 20 and 440 Hz. In Auto mode, this knob sets the frequency from 
which the buzz detection circuit starts to hunt for buzz components. In Freeze 
mode, this knob sets the exact frequency of the buzz fundamental. The knob 
is graduated around the circumference, and clicking on any labeled 
graduation sets the frequency to that graduation.
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Fine Adjust button

Enables fine tuning of the buzz frequency control. The graduations around the 
circumference of the frequency knob re-draw to a finer scale, and scrolling the 
touch pad enables very quick fine tuning of a hunt frequency. Scrolling past 
an end-stop continues to scroll the frequency and the marked graduations 
re-draw appropriately.

Fine Adjust mode forces Freeze, so that the selected frequency can be 
specified exactly, without the Auto circuitry hunting for a stronger 
fundamental. If entering Fine Adjust mode from Auto, the Freeze button 
flashes and the plug-in reverts to Auto when Fine Adjust mode is exited.

Tone On button

Enables an audible tone generator, which can be used to aid location of the 
buzz fundamental. While the Tone button is on, a touch pad appears above 
the button and becomes a Tone level control. It defaults to -18 dB, and has a 
range of -6 dB to -96 dB.

Sensitivity knob and touch pad (%)

Controls the sensitivity of the buzz detection circuit. Fully sensitive might allow 
the detection circuit to lock to inaudible and possibly undesirable frequencies. 
Stronger buzzes, which typically would be removed first, require a less 
sensitive setting.

Hum/Buzz Mode button

Control switches between Hum mode and Buzz mode. In Hum mode the 
bandwidth limit for harmonic removal is 0 to 800 Hz. In Buzz mode the 
bandwidth limit for harmonic removal is 0 to 4000 Hz. Hum mode is less 
damaging, and should be used when possible.

Enable button

Enables the buzz removal processing. It allows glitch-less comparisons with 
and without the buzz removal. When Enable is deactivated, the buzz 
detection circuit is still enabled and the Detect display still shows the degree 
of buzz detection.

Reduction display

Indicates the level of audio that is being removed from the signal.

Attenuation knob and touch pad (dB)

Determine the level of attenuation that the buzz removal circuit apply, up to a 
maximum of 96 dB. Generally this should be set so that the buzz is just 
inaudible. Excessive use of attenuation can degrade the signal unnecessarily.

Auto button

Enables Auto mode for the buzz detection circuit. In this mode the buzz 
detection is continually calculated and a slow drift in the buzz fundamental 
frequency automatically follows. This mode is useful for material with a 
time-varying buzz component. In this mode the removal filters follow the 
detected frequency.
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Freeze button

Enables Freeze mode for the buzz detection circuit. In this mode the buzz 
fundamental is fixed to the frequency shown in the touch pad window. This 
mode is useful for material with fluctuating buzz level, but with a constant buzz 
frequency. In this instance, Auto mode would suffer when the buzz level drops 
and would typically re-hunt for a different buzz fundamental. In this mode the 
removal filters follow the nominal frequency.

Detect display

Indicates the degree of detection that the buzz detection circuit has achieved.

Output Level meter (dB)

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. There is a peak-hold feature that 
holds the highest peak, helping to give a better impression of the working 
dynamic range.

Trim Output Level

Allows you to reduce the output level by up to 12 dB. Dithering is applied after 
output gain control, so it may be necessary to reduce this value by a small 
amount to avoid clipping.

Using the Sonnox DeBuzzer

• Find the nominal frequency. Start with Sensitivity and Attenuation controls 
at the default positions (90 % and -48 dB).

• If you know the rough frequency of the nominal, select that frequency using 
either the knob or by typing into the touch pad.

• In Auto mode, allow the detector time to drift towards the actual fundamental. 
The Detect display indicates confidence of hum detection. Auto mode should 
be used if the fundamental drifts over time.

• Freeze mode should be used to select a specific frequency that might be 
variable in strength. Fine Adjust (which forces Freeze mode) can be used to 
increase the resolution of selecting the fundamental.

• If you are still having difficulty finding the fundamental, use the Tone control.

• The Hum mode removes harmonics up to 800 Hz. If you can hear harmonics 
that are higher in frequency, select Buzz mode, which removes harmonics up 
to 4000 Hz. If there are no harmonics above 800 Hz, be sure to use Hum 
mode to preserve as much original audio as possible.

• In order to cause as little damage to the audio as possible, back off the 
attenuation until you can just hear the buzz, then increase it until the buzz is 
inaudible.

• Then reduce the sensitivity until the buzz is inaudible.
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Sonnox DeClicker

Sonnox DeClicker allows you to remove clicks from audio material.

Sonnox Menu Options Button

Opens a menu where you can select the following options:

• Duration of the input/output meter clip lights hold (indefinitely, 2s, 5s)

• Information about the version number and build date

Input Level Meter

Gives exactly 1 dB per LED for the top 18 dB of dynamic range, and 2 dB per 
LED thereafter. This gives a clear and intuitive impression of the working 
headroom.

Trim Input Level

Allows you to adjust the input signal level by up to ±12 dB.

Sensitivity Fader and Touch Pad (%) (DePop, DeClick, DeCrackle)

Controls the sensitivity of the detection circuits. Fully sensitive might allow the 
detection circuit to react to low level signals and possibly mis-classify 
programme as pops or clicks. Stronger pops and clicks require a less 
sensitive setting.

In Button (DePop, DeClick, DeCrackle)

Enables the pop, click or crackle removal processing. When In is deactivated, 
the pop, click, or crackle detection circuit is still enabled and the detect 
display still shows the degree of event detection.

Detect Meter Display (DePop, DeClick, DeCrackle)

Combines two indications. The main rising column indicates the sum of the 
energy of events that have been detected. With the In button de-selected (i.e. 
the repair circuit disabled), this column is colored orange/red. With the repair 
circuit active the column is colored blue. The bottom segment of the meter is 
an indication of each individual detected event.
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Output Level Meter (dB)

Gives exactly 1 dB per LED for the top 18 dB of dynamic range, and 2 dB per 
LED thereafter. There is a peak-hold feature that holds the highest peak, 
helping to give a better impression of the working dynamic range.

Trim Output Level

Allows you to reduce the output level by up to 12 dB. Dithering is applied after 
output gain control, so it can be necessary to reduce this value by a small 
amount to avoid clipping.

Using the Sonnox DeClicker

• We recommend repair the larger and more energetic events first.

• If there are large displacement events in the programme material, enable the 
DePop section and raise the sensitivity fader until the largest events are 
detected and repaired.

• For clicks, enable that section and raise the sensitivity fader until they are 
detected and repaired.

• Finally, if there is crackle left, enable that section and raise its fader to remove 
the crackle.

• There is necessarily some degree of overlap in the detection circuits of clicks 
and crackle. Decreasing the DeClick sensitivity can increase the apparent 
detection of crackle and increasing the DeClick sensitivity can indicate less 
crackle. Best results are likely if the two controls are balanced.

Sonnox DeNoiser

Sonnox DeNoiser removes wide-band noise from audio material.

Sonnox Menu Options button

Opens a menu where you can select the following options:

• Duration of the input/output meter clip lights hold (indefinitely, 2 s, 5 s)
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• Knob behavior

• Information about the version number and build date

Graphical display

Shows the real-time frequency/gain curve of the program material. It is 
graduated from 0 to 20 kHz and from 0 to -144 dB. The yellow line is the 
calculated noise spectrum level, and in Adapt mode continually follows the 
noise in real time. Everything below this contour is assumed to be noise, and 
everything above the line is program signal.

Input Level meter

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. This gives a clear and intuitive 
impression of the working headroom.

Trim Input Level

Allows you to adjust the input signal level by up to ±12 dB.

Sensitivity fader and Trim touch pad (dB)

The sensitivity fader defaults to 0.0 dB, which is the midpoint of its travel. It 
adjusts the sensitivity of the noise detection circuit, and the visible effect of 
this is to move the yellow noise contour line up and down. The sensitivity level 
can be changed by up to ±18 dB.

To reduce the sensitivity and make the DeNoiser less reactive to the noise 
component, move the fader down. The noise contour displaces downwards, 
showing less noise component in the detection circuit. If the sensitivity is set 
too low, little noise reduction occurs.

To increase the sensitivity and make the DeNoiser more reactive to the noise 
component, move the fader up. The noise contour displaces upwards, 
showing more noise component in the detection circuit. The default setting is 
for the noise contour to lie just below the peaks of the signal. Making the 
detection circuit more sensitive to noise decreases the signal component, 
possibly pushing the contour up towards the peaks of the signal. In this case, 
it is likely that processing artifacts are heard, as the noise removal circuit acts 
on the signal component as well as the noise component.

Adapt button

Enables Adapt mode for the noise detection circuit. In this mode the noise 
fingerprint is continually calculated and updated. This mode is useful for 
material with a time-varying noise component.

Freeze button

Enables Freeze mode for the noise detection circuit. In this mode the noise 
fingerprint is calculated. This mode is useful for material with a constant noise 
component, and would typically be sampled when the signal is absent and 
only the noise component is present.

In button

Enables the noise removal processing. It allows glitch-less comparisons with 
and without the noise reduction. When In is deactivated, the noise detection 
circuit is still enabled and the graphical display still shows the real-time 
frequency display and the noise contour line.
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HF Limit knob and touch pad (Hz)

Displays and controls the frequency beyond which the attenuation is applied 
nondynamically. Scrolling the frequency down from the default of 22 kHz 
shows a red region in the frequency display that has a fixed attenuation. To 
the left of the HF Limit line the noise removal circuit behaves as normal. To the 
right the signal is attenuated by a fixed amount set by the attenuation fader. 
This mode is useful for band-limited program material.

A good example is a low bitrate encoded signal, which might be band limited 
to 12 kHz. Due to the sharp discontinuity, the noise removal circuit can 
introduce audible artifacts around the band limit, and setting the HF Limit 
frequency slightly lower than the band limit removes those artifacts.

Attenuation fader and touch pad (dB)

Determine the level of attenuation that the noise removal circuit applies in the 
range 0 to -18 dB. Generally this should be set so that the noise reduction is 
pleasing. Excessive use of attenuation can degrade the signal unnecessarily.

Output Level meter (dB)

This meter is designed to give exactly 1 dB per LED for the top 18 dB of 
dynamic range, and 2 dB per LED thereafter. There is a peak-hold feature that 
holds the highest peak, helping to give a better impression of the working 
dynamic range.

Trim Output Level

Allows you to reduce the output level by up to 12 dB. Dithering is applied after 
output gain control, so it can be necessary to reduce this value by a small 
amount to avoid clipping.

Using the Sonnox DeNoiser

• Start with Sensitivity and Attenuation controls at the default positions 
(0.0 dB and -4.5 dB).

• Select Adapt mode if the noise varies in time. Select Freeze for a defined and 
static noise fingerprint.

• Adjust the Sensitivity to find the correct balance between being too low (not 
enough noise is removed) and too high (too much signal is removed).

• Adjust the Attenuation to find the most pleasing audio. Too much attenuation 
can impair the audio, either by reducing brightness or by introducing low-level 
distortion.

You might be working with bandwidth-limited material, possibly as a result of 
sample rate conversion or lossy compression (for example, limited at around 
10 kHz). If you experience distortion around the limit try reducing the HF Limit 
control. Adjust until it lies just to the lower frequency side of the limit (around 9.5 kHz 
in our example).
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Legacy Plug-ins

Under Windows, a set of plug-ins is provided for compatibility with audio projects 
that referenced these effects when using earlier versions of WaveLab. An audio 
montage which referenced these plug-ins would otherwise require cumbersome 
user intervention to open, for example.

Their use with new audio projects is not recommended and they are not 
documented.

Dithering Plug-ins

Dithering plug-ins add small quantities of noise to a signal to reduce the audibility 
of low level distortion in a digital recording. A small amount of random noise is 
added to the analog signal before the sampling stage, reducing the effect of 
quantization errors.

Internal Dithering

This is a built-in plug-in that provides a simple way of adding a small amount of noise 
to the rendered signal to improve the apparent signal-to-noise ratio of the output.

The following parameters are available when selecting Internal.

Noise Type

Sets the noise type for adding to the signal.

• In No Noise mode, no dithering is applied.

• The Noise Type 1 mode is the most all-round method.

• The Noise Type 2 mode emphasizes higher frequencies more than 
Noise Type 1.

Noise Shaping

Increases the apparent signal to noise ratio by altering the spectrum of the 
low-level audio signal which results from lowering the number of bits. The 
higher the number you select here, the more the noise is moved out of the 
ear’s mid-range.

Bit Resolution

Allows you to specify the intended bit resolution for the final audio, after 
dithering, regardless of whether you want to render the settings or play back 
in real-time.

Dithering changes the sample resolution, but not the sample size. For 
example, when dithering 24 bit to 16 bit, the file will still be 24 bit in size, 
although only 16 bits of information will have significance. When rendering to 
a 16-bit file, specify the file resolution to avoid wasting space.
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MBIT+™ Dithering

This plug-in allows you to convert and dither to 24, 20, 16, 12, or 8 bits. This is 
useful for mastering a track for a CD (16-bit) from a 24-bit source, for example.

The MBIT+™ dither algorithm reduces quantization distortion with minimal 
perceived noise and produces smooth and quiet conversions.

Bit quantization

Sets the bit depth to which you are dithering. MBIT+™ produces 32-bit 
floating-point output, but all low-order bits will be zero and should be 
truncated.

Type

Sets the type of dithering. MBIT+™ contains two traditional dithering types 
and a proprietary MBIT+™ dithering type.

• Type 1 is a traditional dither based on a rectangular probability 
distribution function (PDF).

• Type 2 is a traditional dither based on a triangular PDF.

• MBIT+™ offers superior results when used with all types of source 
material.

Dither amount

When using MBIT+™ dither, this controls the amount of dithering. The None 
and Low settings can leave some non-linear quantization distortion or dither 
noise modulation, while higher settings completely eliminate the non-linear 
distortion at the expense of a slightly increased noise floor. The Normal 
setting is suffice for most cases.

When using Type 1 or Type 2 dither, this controls the number of bits used to 
perform dithering. In most cases, 1 bit is suffice, but over-dithering with 2 bits 
can be useful in same cases.

Noise shaping

When using MBIT+™ dither, this controls the amount of noise shaping. The 
choices range from no noise shaping to very aggressive noise shaping, 
providing approximately 14 dB of audible noise suppression, at the expense 
of a higher noise floor.
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When using Type 1 or Type 2 dither, this controls the noise shaping. Dithering 
noise can be shaped in order to make it less audible. Simple noise shaping 
performs simple high-pass filtering on the noise. Clear noise shaping 
aggressively moves the noise toward the Nyquist frequency. Psych 5 is a 
5th-order filter designed to move noise away from audible bands, and Psych 
9 is a 9th-order filter with similar characteristics.

Auto-blanking

If this option is activated, MBIT+™ mutes dither output when the input is 
completely silent for at least 0.7 seconds.

Minimize peaks

If this option is activated, spurious peaks in the noise-shaped dither are 
suppressed.

Harmonics suppression

If this option is activated, the truncation rules are slightly altered, moving the 
harmonic quantization distortion away from overtones of audible frequencies. 
This option does not create any random dithering noise floor. Instead it works 
more like truncation, but with better tonal quality in the resulting signal. This 
option is applicable only in the modes without dithering noise and without 
aggressive noise shaping.

Copyright © 2013 iZotope, Inc. All rights reserved.

UV22HR

This is an advanced version of Apogee's renowned UV22 dithering algorithm, 
capable of dithering to 8, 16, 20, or 24 bits.

8, 16, 20, 24 bit

These buttons allow you to select the intended bit resolution for the final 
audio. As when using the internal dithering, it is important to set this to the 
correct resolution.

Hi

Applies a normal dither gain.

Lo

Applies a lower level of dither noise.

Auto black

If this option is activated, the dither noise is gated during silent passages.
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ASIO Plug-ins

External Gear

This Master Section plug-in allows you to process audio files using external 
hardware processors. One or more ASIO outputs are used to send the audio signal 
to your processor, and corresponding ASIO inputs are used to return the signal 
from the external processor.

By default, this plug-in is located in the ASIO submenu of the Master Section 
effects. An ASIO driver must be used, and only one instance of this plug-in is 
allowed in the Master Section plug-in chain.

External Gear Plug-in

In the Effects pane of the Master Section window, select the External Gear plug-in 
from the ASIO submenu.

Num. Outputs

Here you can set the number of outputs to use. Normally this is the same as 
the number of inputs (the As Inputs option). However, you can use a mono 
out/stereo in configuration in which case you set this parameter to 2 with the 
slider.

Latency

External gear may introduce latency. WaveLab can automatically compensate 
for this if you select Auto (only active during rendering), or you can set this 
latency compensation yourself (in milliseconds). The latency introduced by 
the ASIO driver is automatically taken into account by WaveLab.

Send level

Allows you to adjust the send level. This should normally be set to 0 dB. If 
necessary, adjust the input level on the external effect.

Using External Gear

PROCEDURE

1. Select Options > VST Audio Connections, and set the Audio Device to 
ASIO.

2. Open the ASIO plug-ins tab.
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3. Select the channels to be used for device output (to gear) and device input 
(from gear), and click OK.
These should be different I/O channels than the ones you use for playback and 
recording. The available outputs in this plug-in equals the number of inputs (up to 8).

4. In the Effects pane of the Master Section window, select the External Gear 
plug-in from the ASIO submenu.
The External Gear plug-in window opens.

5. Make your settings.

AFTER COMPLETING THIS TASK 

Now you can process a signal through the external processor, just as if it was a 
software plug-in effect. If you render a file using the External Gear plug-in, playback 
is not available during the rendering.

Audio Input

This is a special Master Section plug-in that allows you to render a signal coming in 
to the inputs of a sound card together with any Master Section effects. This signal 
can be anything your sound card accepts, such as a feed from a mixer, a recorder, 
or a microphone.

By default, this plug-in is located in the ASIO submenu of the Master Section 
effects. An ASIO driver must be used, and only one instance of this plug-in is 
allowed in the Master Section plug-in chain.

When the Audio Input plug-in is loaded, wave playback is not possible.

Setting Up the Audio Input Plug-in

PROCEDURE

1. In any workspace, select Options > VST Audio Connections, and set the 
Audio Device to ASIO.

2. Open the ASIO plug-ins tab.

3. Select the channels to be used for device input, optionally name them, and 
click OK.

4. In the top effect slot of the Effects pane of the Master Section window, select 
the Audio Input plug-in from the ASIO submenu.

5. In the Audio input plug-in window, set the number of inputs and the sample 
rate.
You have to match the number of inputs in the VST Audio Connections dialog to the 
number of inputs selected here.

6. Start playback.
The cursor does not move, but the Play button is lit and you can now monitor the input 
source. Pressing Stop ends input monitoring.
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7. If you change the settings in the control panel, click Stop, and restart playback 
to apply them.

8. Click the Render button.

9. Select a name, an audio format, and a location for the file to be rendered.

10. Click OK.
Recording/rendering starts, recording the external input from the output of the Master 
Section, including all real-time processing. You can monitor the recording as it 
happens.

11. Click Stop to stop the recording/rendering.

Batch Processing Plug-ins

In the Batch Processors workspace, you can add a sequence of plug-ins that can 
be used to process a batch of audio files. These plug-ins can be standard plug-ins 
available from the Master Section, offline processes available in the Audio Files 
workspace, and plug-ins that are only available within batch processing.

Audio Analyzer

This plug-in allows you to generate text files with statistics about the audio files in a 
batch process.

This monopass plug-in is exclusive to the Batch Processors workspace.

If you want to analyze files without writing anything, select No Output in the Output 
tab of the Batch Processors workspace.
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Information to Report

In this section you specify which information to include in the output. The following 
information can be included:

• Sample rate

• Number of channels

• Real bit resolution

• Number of samples/duration

• Digital peaks

• True peaks

• Integrated loudness

• Loudness range

• Short-term loudness (maximum)

• Short-term loudness (minimum)

• Momentary loudness (maximum)

• Momentary loudness (minimum)

• Loudness balance

• DC Offset

Output

In this section you set up the output of the Audio Analyzer. The following options are 
available:

Send analysis results to XML processor

If this option is activated, the analysis results are passed as parameters to the 
XML or HTML output of the batch processor.

Create one report per audio file

If this option is activated, one report is created for each audio file in the batch 
process. The audio file name is used as the report file name.

Merge results into one global report

If this option is activated, the results of the analysis are merged into one global 
report. The audio file name is used as the report file name.

Open global report at end of batch process

If this option is activated, a global report opens after the batch process.

File name suffix

Lets you specify a file name suffix. This is necessary when you are using this 
plug-in multiple times in a batch process, for example, to see the stats before 
and after certain plug-ins.
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Use different suffixes for each instance of the Audio Analyzer plug-in used in 
the processing chain.

Output format

Lets you select the output format. The following formats are available:

• Pure text

• HTML

• Adobe PDF

• Open Office

• Spreadsheet

• XML

Audio Injector

This plug-in allows you to insert an audio file at the beginning and/or end of the 
audio file being processed. The inserted file can also be cross faded with the 
original audio file, if required.

This monopass plug-in is exclusive to the Batch Processors workspace.

Audio file to inject at the start (<= 60 sec)

Specifies the audio file to be added before the main audio file.

Audio file to inject at the end (<= 60 sec)

Specifies the audio file to be added after the main audio file.

Perform crossfade

Allows you to select a crossfade time and shape for the crossfade between 
the main audio file and the injected audio file.

DC Remover

This plug-in allows you to remove any DC Offset from an audio file.

It is useful to apply this plug-in first in a batch before other plug-ins to avoid further 
processing a file containing any DC Offset. For example, an audio file that has a DC 
offset is not at its loudest possible volume when normalized, because the offset 
consumes headroom.
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This multipass plug-in is available in the Batch Processors workspace and as an 
offline processor in the Audio Files workspace.

Fade-In/Fade-Out

This plug-in allows you to fade the beginning (Fade-In) or the end (Fade-Out) of a 
batch audio file. You can choose the length and shape of the fade, its duration, and 
the gain you want it to start/end at.

The fade plug-ins are exclusive to the Batch Processors workspace. Fade-in is a 
monopass plug-in and Fade-out is a multipass plug-in.

Shape

Determines the shape of the fade.

Duration

Determines the duration of the fade.

Start gain

Determines the gain with which the fade starts. It ends with 0 dB.

About the Instructor Plug-in

Instructor is a special utility plug-in that allows you to instruct the next plug-in in the 
batch with information about the audio it needs to process. This is useful for 
situations where you want to use monopass plug-ins that require an analysis stage 
that is not available at this point.

In effect, the Instructor plug-in turns a monopass plug-in into a dual pass one. Some 
monopass plug-ins, such as Denoisers or DeBuzzer, need to learn about the audio 
they are to process before they can begin processing correctly. The Instructor 
plug-in can help in this situation, since it can teach the next plug-in in the audio 
chain about the audio it is about to process.

The Instructor plug-in must be used as a pair:

1) The first instance replicates the start of the audio stream. This means the next 
plug-in in the chain receives the start of the audio stream twice.

2) The second instance of the plug-in comes after the plug-in being instructed. 
It cuts out the extra audio injected by the first instance of the Instructor 
plug-in.

For example, this means that the Denoiser plug-in has time to sufficiently analyze 
the audio stream before the second stream start is injected. The “badly” processed 
first part of the stream is skipped by the second instance of the Instructor plug-in.

You can set the Instructor plug-in to replicate up to 20 seconds of audio.
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NOTE

Do not set a value that is longer than the shortest file in the batch, otherwise a short 
file is over truncated by the second instance of the plug-in.

Instructor

This monopass plug-in is exclusive to the Batch Processors workspace.

Action – Replicate stream start

Injects the start of the audio stream twice into the next plug-ins. This action 
must be selected for the first instance of the Instructor plug-in.

Action – Reverse stream

If this option is activated, the start of the stream is injected first in reverse 
sample order, then in normal sample order. This changes nothing from the 
spectrum analysis point of view, but it improves the transition between the 
repeated streams.

Action – Trim stream start

Skips the start of the audio stream. This action must be selected for the 
second instance of the Instructor plug-in.

Duration

Specifies how much audio to replicate or skip.

Loudness Meta Normalizer

This plug-in allows you to normalize a batch of files to the same loudness, while 
taking the EBU R-128 loudness measurement and a true peak analysis into 
account.

The purpose of this plug-in is to achieve the same loudness in all files (the highest 
loudness found, if possible), while being certain that no file clips. For each file, a 
specific gain is computed by the plug-in once all files have been analyzed and prior 
to actually applying any gain to achieve the common loudness. If it is not possible 
to match the highest found loudness, the level of the file with the highest loudness 
is reduced, so that other files can get the same loudness. Since no peak 
compression is used, the dynamics is preserved and no distortion is introduced.
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This metapass plug-in is exclusive to the Batch Processors workspace.

Match loudness menu

Select what loudness the clip should get. The following options are available:

• Match loudest audio file

• Match maximum achievable loudness

• Match specific loudness

Loudness

Determines the specific loudness to match. For example, -23 LUFS if you 
want to follow the EBU R-128 recommendation for broadcast.

Reference menu

Select whether WaveLab should use as reference the loudness of the entire 
clip (EBU R-128 recommendation), the average loudest 3 second audio 
section (Top of loudness range), or the loudest 3 seconds audio section 
(Maximum short-term loudness).

Peaks menu

Select whether WaveLab should refer to sample values (digital peaks) or to 
analog reconstructed values (true peaks).

Loudness Restorer

Loudness Restorer captures the loudness at a certain point in the audio chain and 
restores that loudness at another point. For this reason, the Loudness Restorer 
must be inserted in pairs into the signal chain: one plug-in for capturing and one 
plug-in for restoring.

This multipass plug-in is exclusive to the Batch Processors workspace.



Plug-in Reference
Batch Processing Plug-ins

766

Mode - Capture

The first instance in the plug-in pair must be set to this mode. This makes the 
plug-in read the signal at this position in the audio chain.

Mode - Restore peak level/Restore loudness (EBU R-128 weighted)

The second instance in the plug-in pair must be set to one of these modes. 
Select one of these options if you want to use peak levels as a basis for 
determining what is considered equal level. Restore loudness (EBU R-128 
weighted) produces a more natural result than Restore peak level.

Reference menu

Select whether WaveLab should use as reference the loudness of the entire 
file (EBU R-128 recommendation), the average loudest 3 second audio 
section (Top of loudness range), or the loudest 3 seconds audio section 
(Maximum short-term loudness).

Peak menu

Select whether WaveLab should use sample values (digital peaks) or analog 
reconstructed values (true peaks).

Limit to 0 dB

If this option is activated, the restoration process will never result in levels 
above 0 dB.

Meta Leveler

This plug-in allows you to change the level of a batch of files consistently.

The core purpose of this plug-in is to apply the same gain to all files, while being 
certain that a specific peak level never exceeds in any file. The unique gain that you 
want to apply is (possibly) reduced by the plug-in, once all files in the batch have 
been analyzed, and prior to actually applying the gain across the batch.

This metapass plug-in is exclusive to the Batch Processors workspace.

Gain

Applies the specified gain to each file. The actual gain can be lower and even 
negative, to not exceed the value specified in the Maximum peak level field.

Maximum peak level

Specifies the maximum peak level that any audio file should get at the end of 
the process.
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Peak reference menu

Select whether WaveLab should refer to sample values (digital peaks) or to 
analog reconstructed values (true peaks).

Level Normalizer

This plug-in allows you to raise or lower levels so that the signal peaks exactly at the 
specified value just before it is converted to a file.

Peak level

Specify the highest level of any audio sample.

Stereo link

Applies the gain to both channels.

Mix to mono

Mixes the left and right channels. The resulting mono file gets the specified 
peak level. This ensure a clip-less mix.

Only if clipping

Only applies a gain change if the audio file is beyond the reference peak level 
at some point. If not, the signal is untouched.
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Resizer

This plug-in allows you to specify the duration of all audio files in the batch, and to 
choose whether to insert silence after the end of the chosen duration. It is only 
available in the Batch Processors workspace.

Stereo -> Mono

This plug-in allows you to mix a stereo signal down to a mono signal while being 
certain not to clip while mixing channels because of the multipass approach. You 
can choose to use the same peak level that the stereo file contains, or set the gain 
to be applied and/or the maximum level to be reached in the resulting mono file.

This multipass plug-in is exclusive to the Batch Processors workspace.

Keep same peak level as stereo file

If this option is activated, the peak level of the resulting mono file is the same 
as the peak level of the original stereo file.

Gain

Specifies the increase or decrease in peak level for the resulting mono file, in 
relation to the original stereo file.

Maximum level of mono signal

Specifies the peak level that the resulting mono file must not exceed. This 
ensure that the output file never clips. This way, the result never exceeds 0 dB, 
regardless of the specified Gain value.

Trimmer

This plug-in allows you to remove a specified duration (from 0 ms to 60 s) of audio 
from the head and/or tail of an audio file.

This monopass plug-in is exclusive to the Batch Processors workspace.
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